Módulos e interfaces de Cisco : Módulos de red de Cisco

Ejemplo de configuración del módulo de la red EtherSwitch (ESW)

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Marzo 2008) | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo del EtherSwitch Network Module instalado en el Router de Servicio Integrado (ISR). Este documento no explica el ejemplo de configuración de EtherSwitch Network Module.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 2800 Series Router en el Software Release 12.4 o Posterior de Cisco IOS�

  • Módulo de la red EtherSwitch del puerto 10/100 NM-16ESW-PWR= 16 (NM)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

Esta configuración también se puede utilizar con las siguientes versiones de hardware y software:

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Módulos EtherSwitch - Conceptos

Hay dos tipos de módulos EtherSwitch disponibles para Cisco ISR. Las fallas son las siguientes:

  • Módulo de la red EtherSwitch (ESW)

  • Módulo de servicio del EtherSwitch (ES)

Los módulos ESW son configurados por el IOS del router. Estos módulos no funcionan con el software distinto. El software es integrado en el IOS del router del host. Usted puede crear los VLA N, los VLA N de la configuración, atravesando - árbol, VLAN Trunking Protocol (VTP), y así sucesivamente del router del host. El router también salva el archivo de base de datos de VLAN (vlan.dat) en el Flash. Este documento muestra el ejemplo de configuración para el módulo ESW.

Los módulos ES tienen sus propios procesadores, motores de Switching y memoria flash que funcionen con a la independiente de los recursos del router del host. Después de que el módulo ES esté instalado en el router, usted puede consolar en el módulo ES del router del host. Entonces usted puede crear los VLA N, los VLA N de la configuración, atravesando - árbol, VTP, y así sucesivamente del módulo ES. Los módulos ES se basan en la plataforma del Catalyst 3750.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/82156/ether-switch-nm-config-1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Interfaces VLAN de la configuración

Por abandono todos los puertos pertenecen al VLAN1. Usted puede crear los VLA N solamente del vlan database mode. Después de que los VLA N se creen del vlan database mode, el archivo del vlan.dat se crea y se salva en el sistema de archivos Flash del router. Usted puede ver los VLA N usando el comando del showvlan-Switch. En este ejemplo, un servidor del Protocolo de configuración dinámica de host (DHCP) (172.16.10.20) está situado en el VLAN10. El comando del iphelper-direccionamiento se configura en todos los VLA N a menos que VLAN10 para obtener la dirección IP del servidor DHCP a los dispositivos situados en estos VLA N.

Router1

Create VLANs


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Configure VLANs


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4, 
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active    
50   VLAN0050                         active    
51   VLAN0051                         active    
100  VLAN0100                         active    
200  VLAN0200                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0   
50   enet  100050     1500  -      -      -        -    -        0      0   
51   enet  100051     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0   
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

Configuración VTP, trunk, Canal de puerto, y Spanning-tree

Por abandono, el modo VTP es el servidor y el Domain Name es en blanco. El VTP se puede configurar solamente del vlan database mode. El único modo del árbol de expansión soportado es PVST+. La encapsulación del tronco predeterminada es dot1q. Cuando usted configura el puerto troncal para permitir solamente los VLAN especificados, usted puede ser que consiga un mensaje de error que dice la lista permitida mún VLA N. En este caso, usted puede ser que necesite no prohibir a los VLAN predeterminados 1-2, 1002-1005 junto con su lista de VLAN de encargo. Debido a esto, usted también necesita permitir los VLAN predeterminados y sus VLA N de encargo en el switch de vecino conectado con este puerto troncal para evitar las inconsistencias del trunk.

Router1

VTP Configuration


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Spanning-Tree Configuration


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Trunk and Port Channel Configuration


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1

Access1 Switch Configuration


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

Puertos de acceso de la configuración

La configuración del puerto de acceso es similar a la configuración estándar del switch LAN.

Router1

Port for Server Configuration


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Port for Printer Configuration


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

Configure el puerto de voz

La configuración del puerto de voz es similar a la configuración estándar del switch LAN.

Router1

Configure the port for Voice

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Calidad de Servicio (QoS) de la configuración

Ésta es la configuración de QoS predeterminada en el módulo ESW:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

Estas secciones explican estas configuraciones:

Configure las colas de administración del tráfico del wrr

Usted no puede configurar el acceso basado QoS en los puertos del 2 Switch de la capa. Las colas de administración del tráfico se pueden configurar solamente de una configuración global. El ejemplo de configuración asocia los valores de CoS a las cuatro diversas colas de administración del tráfico. Cuando un paquete ingresa el motor de la capa 2 directamente de un puerto del switch, se coloca en una de cuatro colas en el dinámico, buffer de memoria compartida del 32 MB. Ningunos expresan los paquetes del portador que vienen adentro de los Teléfonos IP de Cisco en el VLA N de la Voz se colocan automáticamente en la prioridad más alta (cola 4) basada en el valor 802.1p (CoS 5) generado por el teléfono del IP. Las colas de administración del tráfico entonces se mantienen sobre una base cargada del ordenamiento cíclico (WRR). El tráfico de control, que utiliza CoS o el Tipo de servicio (ToS) de 3, se pone en la cola 3.

Router1
Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7

!--- wrr-queue cos-map <queue-number> <cos values separated by space>

Router(config)#wrr-queue bandwidth 1 16 64 255

!--- wrr-queue bandwidth <Weight of Queue1> <Weight of Queue2> 
!--- <Weight of Queue3> <Weight of Queue4>

Verifique los parámetros de la cola:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8 

!--- Default values


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255 

!--- Configured values


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4  

!--- Default values

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4  

!--- Configured values

Esta tabla muestra el número de la cola, el valor de CoS y la ponderación de cada cola después de la configuración.

Número de la cola Valor de CoS Peso
1 0 1 1
2 2 16
3 3 4 64
4 5 6 7 255

Configure el puerto para confiar en CoS

Router1
Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos

!--- Trust the CoS value of the frames from the IP phone.

Router1(config-if)#mls qos cos override

!--- Reset the CoS value of the frames from PC to 0.

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos

!--- Trust the CoS value of the frames from this trunk link.

Router1(config-if-range)#exit

Policer de la configuración

Esto secciona las demostraciones la configuración de establecimiento de política en la interfaz fa1/2 para limitar el tráfico FTP al 5 Mbps.

Router1
Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

Hay pocas restricciones en la configuración de establecimiento de política en los módulos ESW. Se enumeran aquí:

  • Las correspondencias de políticas con la clasificación ACL en la dirección de salida no se soportan y no se pueden asociar a una interfaz usando el comando interface configuration del Policy-map-name de la entrada de política de servicio.

  • En una correspondencia de políticas, la clase nombrada class-default no se soporta. El Switch hace no filtrar tráfico basado en la correspondencia de políticas definida por el comando de configuración de correspondencia de políticas del class class-default.

  • Usted puede crear el directiva-mapa y aplicarse solamente al ingreso de las interfaces ESW. Y en el directiva-mapa, solamente se soporta el policer.

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
  • No hay soporte para limpiar en un VLA N o un nivel del Switched Virtual Interface (SVI).

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 82156