Tecnología inalámbrica / Movilidad : LAN inalámbrica (WLAN)

QoS en los reguladores del Wireless LAN y el ejemplo de configuración ligero AP

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (17 Abril 2008) | Inglés (20 Diciembre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de configuración que muestra cómo configurar la Calidad de Servicio (QoS) en una red Cisco Unified Wireless mediante Cisco Wireless LAN Controllers (WLC) y Lightweight Access Points (LAP).

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimientos básicos de la configuración de LAPs y WLCs de Cisco

  • Conocimiento de cómo configurar la encaminamiento básica y QoS en una red alámbrica

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • WLC de Cisco 2006 que funciona con la versión de firmware 4.0

  • Cisco 1000 Series LAP

  • Adaptador de red inalámbrica de cliente de Cisco 802.11a/b/g que funciona con la versión de firmware 2.6

  • Cisco 3725 Router que funciona con el Software Release 12.3(4)T1 de Cisco IOS�

  • Cisco 3640 Router que funciona con el Cisco IOS Software Release 12.2(26)

  • Dos 3500 XL Series Switch de Cisco que funcionan con el Cisco IOS Software Release 12.0(5)WC3b

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

QoS refiere a la capacidad de la red de proporcionar mejor o al servicio especial a un conjunto de los usuarios o a las aplicaciones al detrimento de otros usuarios o aplicaciones.

Con QoS, el ancho de banda se puede manejar más eficientemente a través de los LAN, que incluye los WLAN y los WAN. Éste es cómo QoS proporciona servicio aumentado y de red confiable:

  • Ancho de banda dedicado de los soportes para los usuarios críticos y las aplicaciones

  • Jitter y tiempo de espera de los controles (requeridos por el tráfico en tiempo real)

  • Maneja y minimiza la congestión de red

  • Forma el tráfico de la red para alisar el flujo de tráfico

  • Establece las prioridades del tráfico de la red

En el pasado, los WLAN fueron utilizados principalmente para transportar el ancho de banda baja, tráfico de la aplicación de datos. Actualmente, con la extensión de los WLAN en la vertical (tal como venta al por menor, finanzas, y educación) y los entornos para empresas, los WLAN se utilizan para transportar las aplicaciones de datos del ancho de banda alto conjuntamente con el time sensible, las aplicaciones multimedia. Este requisito llevado a la necesidad para QoS inalámbrico.

El Grupo de trabajo de IEEE 802.11e dentro del comité regulatorio del IEEE 802.11 ha completado la definición estándar. Sin embargo, la adopción del estándar 802.11e está en sus fases tempranas, y como con muchos estándares hay muchos componentes opcionales. Apenas mientras que lo que ocurrió con la Seguridad del 802.11 en 802.11i, los grupos industriales tales como el Wi-Fi Alliance, y los líderes de la industria tales como Cisco están definiendo los requisitos dominantes en la red inalámbrica (WLAN) QoS con sus programas de las multimedias (WMM) y de los Ciscos Compatibles Extension del Wi-Fi (CCX). Esto asegura la salida de las características fundamentales y del interoperation con sus programas de certificación.

Soporte de Productos del Cisco Unified Wireless WMM, un sistema de QoS basado en el proyecto de IEEE 802.11e que ha sido publicado por el Wi-Fi Alliance.

El regulador soporta cuatro niveles de QoS:

  • Platino/Voz — Asegura un de alta calidad del servicio para la Voz sobre la Tecnología inalámbrica.

  • Aplicación de video de alta calidad del oro/de los Soporte de video.

  • De plata/mejor esfuerzo — Soporta el ancho de banda normal para los clientes. Ésta es la configuración predeterminada.

  • Bronce/fondo — Proporciona el ancho de banda más bajo para los servicios del invitado.

Los clientes de la voz sobre IP (VoIP) deben ser fijados al platino, al oro, o a la plata mientras que los clientes del ancho de banda baja pueden ser fijados para broncear.

Usted puede configurar el ancho de banda de cada QoS llano usando los perfiles de QoS y después aplicar los perfiles a los WLAN. Las configuraciones del perfil se avanzan a los clientes asociados a esa red inalámbrica (WLAN). Además, usted puede crear los papeles de QoS para especificar diversos niveles del ancho de banda para el asiduo y los Usuarios invitados.

Para la información sobre cómo configurar los perfiles de QoS usando el GUI, refiérase usando el GUI para configurar los perfiles de QoS.

Para la información sobre cómo configurar los perfiles de QoS usando el CLI, refiérase usando el CLI para configurar los perfiles de QoS.

Refiera a la sección de QoS del Cisco Unified Wireless de la guía de diseño de la movilidad de la empresa para más información sobre cómo QoS trabaja en la red del Cisco Unified Wireless.

Este documento proporciona un ejemplo de configuración que ilustre cómo configurar QoS en los reguladores y comunicar con una red alámbrica configurada con QoS.

Mejoras de la Marcación de paquetes QoS de la capa 3

La red del Cisco Unified Wireless soporta el marcado del Differentiated Services Code Point IP de la capa 3 (DSCP) de los paquetes enviados por el WLCs y los revestimientos. Esta característica aumenta cómo el uso del (APS) de los Puntos de acceso esta información de la capa 3 para asegurarse de que los paquetes reciben el correcto sobre - ventila el priorización del AP al cliente de red inalámbrica.

En una arquitectura de WLAN centralizada, los datos WLAN son tunneled entre el AP y el WLC vía el protocolo del Lightweight Access Point (LWAPP). Para mantener la clasificación de QoS original a través de este túnel, las configuraciones de QoS del paquete de datos encapsulados deben ser asociadas apropiadamente a la capa 2 (802.1p) y acodar 3 (IP DSCP) campos del paquete del túnel externo.

No es paquetes posibles de la DSCP-etiqueta entre el regulador y el REVESTIMIENTO si hay DSCP o 802.1P valor en el paquete original sí mismo.

El regulador no aplica su propio QoS. El soporte de QoS en el WLC da a WLC la capacidad de aplicar la misma prioridad que se establece en el alambre (o la aplicación).

Por lo tanto, la única acción un WLC o un AP hará es copiar el valor del paquete original al encabezado exterior del paquete lwapp. El propósito entero del oro, de la plata, y de las opciones de QoS del bronce en el WLC es realizar las traducciones apropiadas de QoS entre 802.11e/802.1p ENCIMA de los valores y de los valores IP DSCP, que dependen de la aplicación o del estándar se utiliza que. De nuevo, QoS en el WLC se asegura de que los paquetes reciban el QoS apropiado que dirige de punta a punta. El regulador no realiza su propio comportamiento de QoS. El soporte está allí para que el regulador siga el ejemplo si existe QoS ya y la prioridad necesita ser aplicada a los paquetes inalámbricos. Usted no puede hacer que QoS solamente exista en el regulador.

El regulador no soporta el Clase de Servicio (CoS) que marca los valores basados en la configuración de la red inalámbrica (WLAN) en el modo LWAPP de la capa 2. Se recomienda para utilizar el LWAPP de la capa 3 para implementar el CoS QoS.

Éste es un ejemplo de cómo QoS trabaja con el WLCs. La aplicación, por ejemplo CallManager, pudo fijar un valor de QoS del alto. Por lo tanto, el paquete de datos original de la aplicación será encapsulado por un encabezado IP que tenga el valor establecidovalor establecido DCSP al alto. Ahora, el paquete alcanza el regulador. Después, el paquete pasa a través de la prueba SSID. Sin embargo, si usted tiene una prueba SSID en su regulador configurado para el bronce del perfil de QoS, el encabezado IP del paquete que encapsula el regulador de la forma del paquete lwapp al AP, tendrá el bronce del valor (aunque el encabezado IP alrededor del paquete original de la aplicación tendrá prioritario). Este documento asume que el DCSP fijado por la aplicación y el perfil de QoS para ese SSID en el regulador son lo mismo. Éste no es siempre el caso.

/image/gif/paws/81831/qos-wlc-lap1.gif

Por ejemplo, cuando el tráfico 802.11e es enviado por un cliente WLAN, tiene una clasificación de la prioridad de usuario (PARA ARRIBA) en su trama. El AP necesita asociar esta clasificación 802.11e en un valor DSCP para el paquete lwapp que lleva la trama. Esto se asegura de que el paquete esté dado la prioridad apropiada en su manera al WLC. Un de proceso similar necesita ocurrir en el WLC para los paquetes lwapp que van al AP. También, un mecanismo es necesario clasificar el tráfico en el AP y el WLC para los clientes non-802.11e, para poder también dar sus paquetes lwapp la prioridad apropiada. Esta tabla ilustra cómo los paquetes se manejan en cada dispositivo:

# Desde A ENCIMA DE (802.1p/802.11e) IP DSCP
1 Regulador Punto de Acceso No traduce el valor DSCP del paquete entrante al AVVID 802.1p ENCIMA del valor. El valor DSCP, si es presente en el paquete, entra transparente en el paquete. Copie el valor DSCP del paquete entrante.
2 Punto de Acceso Cliente de red inalámbrica Cliente WMM: Traduzca el valor DSCP del paquete lwapp entrante al 802.11e ENCIMA del valor. Limpie el valor para asegurarse que no excede el valor máximo permitido para la red inalámbrica (WLAN) política de calidad de servicio (QoS) asignada a ese cliente. Coloque el paquete en la cola del tx del 802.11 apropiada para el valor ASCENDENTE. Cliente regular: Coloque el paquete en la cola predeterminada del tx del 802.11 para la red inalámbrica (WLAN) política de calidad de servicio (QoS) asignada a ese cliente. N/A (se preserva el valor original DSCP)
3 Punto de Acceso Regulador N/A (los Puntos de acceso no soportan las etiquetas 802.1Q/802.1p) Cliente WMM: Limpie el 802.11e ENCIMA del valor para asegurarse que no excede el valor máximo permitido para política de calidad de servicio (QoS) asignado a ese cliente; traduzca el valor al valor DSCP. Cliente regular: Utilice el 802.11e ENCIMA del valor para política de calidad de servicio (QoS) asignado a ese cliente; traduzca el valor al valor DSCP.
4 Regulador Switch de Ethernet Traduzca el valor DSCP de los paquetes lwapp entrantes al 802.1p ENCIMA del valor. N/A (se preserva el valor original DSCP)

Esta tabla siguiente proporciona las traducciones que ocurren entre 802.11e/802.1p ENCIMA de los valores y de los valores IP DSCP. Porque la arquitectura Cisco para los datos de la Voz, video e integrados (AVVID) define la traducción a partir del 802.1 hasta IP DSCP, y el IEEE define la traducción de IP DSCP a 802.11e PARA ARRIBA, dos diversos conjuntos de las traducciones deben ser utilizados.

El Cisco AVVID 802.1p Para arriba-basó el tipo de tráfico IP DSCP del Cisco AVVID Cisco AVVID 802.1p PARA ARRIBA IEEE 802.11e PARA ARRIBA Notas
Control de red - 7 - Reservado para el control de red solamente
Control de la red interna 48 6 7 (AC_VO) Control del LWAPP
Voice 46 (EF) 5 6 (AC_VO) Regulador: Perfil de QoS del platino
Vídeo 34 (AF41) 4 5 (AC_VI) Regulador: Perfil de QoS del oro
Control de la Voz 26 (AF31) 3 4 (AC_VI) -
Mejor esfuerzo 0 (Be) 0 3 (AC_BE) 0 (AC_BE) Regulador: Perfil de plata de QoS -
Fondo (fondo del oro del Cisco AVVID) 18 (AF21) 2 2 (AC_BK) -
Fondo (fondo de plata del Cisco AVVID) 10 (AF11) 1 1 (AC_BK) Regulador: Perfil de bronce de QoS

Nota: El IEEE 802.11e SUBE el valor para los valores DSCP que no se mencionan en la tabla son calculados considerando 3 bits MSB de DSCP. Por ejemplo, el IEEE 802.11e ENCIMA del valor para el DSCP 32 (100 000 en el binario) sería el valor convertido decimal del MSB (100), que es 4. El 802.11e ENCIMA del valor del DSCP 32 es 4.

Configuración de la red

En este documento, se utiliza esta configuración de red:

  • La red alámbrica comprende del dos Routers, del router1 y del router2, que ejecutan el OSPF entre ellos. Los host atados con alambre comprenden de un servidor FTP (F1), de un cliente de la Voz (V1) y de un cliente video (Vi1). Los host atados con alambre conectan con la red con un Layer 2 Switch que está conectada con los fast ethernet del r1 del router.

  • La red inalámbrica conecta con la red con el router2 tal y como se muestra en del diagrama. Los host inalámbricos comprenden de un FTP cliente (NON-WMM habilitado), de un cliente V1 (7920 teléfonos) de la Voz y de un cliente video Vi1 (WMM habilitado).

  • Los paquetes de voz se deben dar la prioridad más alta seguida por los paquete de video. Los paquetes FTP se deben dar la menos prioridad.

  • En la red alámbrica, el Weighted Random Early Detection (WRED) se utiliza para implementar QoS. Clasifican y se dan prioridad a los diversos tipos de tráfico sobre la base de los valores DSCP. El WRED se implementa en los paquetes prioritarios.

  • En la red inalámbrica, tres WLAN deben ser creados para cada tipo de tráfico, y habilitar los perfiles apropiados de QoS.

    • red inalámbrica (WLAN) 1 — FTP cliente: Perfil de bronce de QoS

    • red inalámbrica (WLAN) 2 — Clientes video: Perfil de QoS del oro

    • red inalámbrica (WLAN) 3 — Clientes de la Voz: Perfil de QoS del platino

Los dispositivos para la conectividad de IP básica y el permiso QoS ambos necesitan ser configurados en la red alámbrica y la red inalámbrica.

/image/gif/paws/81831/qos-wlc-lap4.gif

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Para configurar los dispositivos para esta configuración, estos necesidad de ser realizado:

Configure la red inalámbrica para QoS

Antes de que usted configure QoS en el WLCs, usted debe configurar el WLC para la operación básica y registrar los revestimientos al WLC. Este documento asume que el WLC está configurado para la operación básica y que los revestimientos están registrados al WLC. Si usted es usuario nuevo que intenta configurar el WLC para la operación básica con los revestimientos, refiera al registro ligero AP (REVESTIMIENTO) a un regulador del Wireless LAN (WLC).

Los revestimientos se registran al WLC, completan una vez estas tareas para configurar los revestimientos y el WLC para esta configuración:

  1. Configuración WLAN para las diversas clases de tráfico

  2. Perfiles de QoS del permiso para los WLAN

Complete estos pasos para crear una red inalámbrica (WLAN) en el WLC para los clientes de la Voz:

  1. Haga clic los WLAN del regulador GUI para crear una red inalámbrica (WLAN).

  2. Haga clic nuevo para configurar una nueva red inalámbrica (WLAN).

    En este ejemplo, la red inalámbrica (WLAN) se nombra VoiceClients y el ID DE WLAN es 1.

  3. Haga clic en Apply (Aplicar).

    qos-wlc-lap5.gif

  4. En la red inalámbrica (WLAN) > edite la ventana, definen los parámetros específicos a la red inalámbrica (WLAN) VoiceClients.

    1. Para la red inalámbrica (WLAN), elija la interfaz apropiada del campo de nombre de la interfaz.

      Este ejemplo asocia la Voz de la interfaz a la red inalámbrica (WLAN) VoiceClients.

    2. Del Calidad de Servicio (QoS) tire hacia abajo el menú, eligen el perfil apropiado de QoS para la red inalámbrica (WLAN).

      En este ejemplo, se selecciona el perfil de QoS del platino. Esto da la prioridad más alta a la red inalámbrica (WLAN) de la Voz.

    3. Para el parámetro de 7920 soportes telefónicos, elija el tipo del control de admisión de llamadas (CAC).

      Este ejemplo utiliza el límite AP CAC.

    4. Seleccione los otros parámetros, que dependen de los requisitos de diseño.

      Los valores predeterminados se utilizan en este ejemplo.

    5. Haga clic en Apply (Aplicar).

      qos-wlc-lap6.gif

      Nota: No habilite el modo WMM si Cisco 7920 teléfonos se utiliza en su red. Usted no puede habilitar el modo WMM y el modo cliente-controlado CAC en la misma red inalámbrica (WLAN). Cuando se habilita un CAC AP-controlado, el AP envía un elemento de información propietario de Cisco CAC (IE) y no envía el QBSS estándar IE.

El despliegue de la Voz sobre la infraestructura WLAN implica más que simplemente el proporcionar de QoS en la red inalámbrica (WLAN). Una red inalámbrica (WLAN) de la Voz necesita considerar los requisitos de la cobertura del estudio sobre el sitio, los requisitos del comportamiento del usuario, de la itinerancia y el control de admisión. Esto se cubre en las guías de diseño del Cisco Unified IP Phone de la serie 7900.

Semejantemente, cree los WLAN para los clientes video y los FTP cliente. Asocian a los clientes video al vídeo de la interfaz dinámica y asocian a los FTP cliente a la interfaz dinámica FTP. Éstos son el screenshots:

Nota: Este documento no explica cómo crear los VLA N en el WLCs. Refiera a los VLA N en el ejemplo de configuración de los reguladores del Wireless LAN para la información sobre cómo configurar las interfaces dinámicas en el WLCs.

/image/gif/paws/81831/qos-wlc-lap7.gif

qos-wlc-lap8.gif

Nota: El soporte del cliente WLAN para WMM no significa que el tráfico del cliente se beneficia automáticamente de WMM. Las aplicaciones que buscan las ventajas de WMM asignan una clasificación apropiada de la prioridad a su tráfico, y el sistema operativo necesitan pasar que clasificación a la interfaz de la red inalámbrica (WLAN). En los dispositivos especialmente diseñados, tales como microteléfonos de VoWLAN, esto se hace como parte del diseño. Sin embargo, si usted implementa en una plataforma de fines generales, tal como un PC, una clasificación del tráfico de aplicación y un soporte OS debe ser implementado antes de que las características WMM se puedan utilizar al buen efecto.

Para los clientes video, se selecciona el oro del perfil de QoS y se habilita WMM. Para los FTP cliente, el bronce se selecciona como el perfil de QoS y se inhabilita WMM porque en este ejemplo los FTP cliente no soportan WMM.

qos-wlc-lap9.gif

qos-wlc-lap10.gif

Nota: Cuando el regulador está en el modo de la capa 2 y se habilita WMM, usted debe poner los AP en un puerto troncal para permitir que se unan al regulador.

Publique estos comandos para configurar los WLAN y el QoS en el WLC usando el CLI:

  • Publique los config wlan crean el comando del <wlan-name> del <wlan-id> para crear una nueva red inalámbrica (WLAN). Para la WLAN-identificación, ingrese un ID a partir de la 1 a 16. Para el WLAN-nombre, ingrese un SSID hasta 31 caracteres alfanuméricos.

  • Publique el comando wlan del <wlan-id> del permiso de los config para habilitar una red inalámbrica (WLAN).

  • Publique la WLAN-identificación wlan de los qos de los config {bronce | plata | oro | comando del platino} para asignar un QoS llano a una red inalámbrica (WLAN).

  • Publique el wmm wlan de los config {inhabilitado | permitido | } comando requerido WLAN-identificación para habilitar el modo WMM.

  • Publique el cliente-CAC-límite wlan 7920-support de los config {habilitado | } comando discapacitado WLAN-identificación para los teléfonos que requieren CA cliente-controlado.

  • Publique el ap-CAC-límite wlan 7920-support de los config {habilitado | } comando discapacitado WLAN-identificación para los teléfonos que requieren el CAC AP-controlado.

Configure la red alámbrica para QoS

Para configurar la red alámbrica para esta configuración, usted necesita configurar la Conectividad de los routeres para básica y habilitar QoS en la red alámbrica. El OSPF se utiliza como el Unicast Routing Protocol.

La característica WRED se utiliza para implementar QoS en la red alámbrica. La característica del DiffServ Compliant WRED permite al WRED para utilizar el valor DSCP cuando calcula la probabilidad de caída para un paquete.

Éstos son el r1 y r2 de las configuraciones para Routers:

Router1
Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifies FTP Packets based on Access List 103.

  match access-group 103
class-map match-all Video

!--- Classifies Video Packets based on Access List 102.

  match access-group 102
class-map match-all Voice

!--- Classifies Voice Packets based on Access List 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Sets DSCP value af11 for FTP packets.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Sets DSCP value ef for Voice packets.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Sets DSCP value af41 for Video packets.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based 

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Applies the policy Marking-For-Voice to the interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Applies the policy Marking-For-Video to the interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Applies the policy Marking-For-FTP to the interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Access list used to classify Voice packets.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Access list used to classify Video packets.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Access list used to classify FTP packets.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router2
Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

Verificación y resolución de problemas

Una vez que la Tecnología inalámbrica y la red alámbrica se configuran para la conectividad básica y se implementa QoS, se clasifican, se marcan y se envían los paquetes basado en las directivas configuradas para cada tipo de tráfico.

La aplicación de las características de QoS no se pudo detectar fácilmente en una red ligeramente cargada. Las características de QoS comienzan a afectar el rendimiento de la aplicación mientras que la carga en la red aumenta. QoS trabaja para guardar el tiempo de espera, jitter, y la pérdida para el tráfico seleccionado teclea dentro de los límites aceptables.

Para un WMM habilitado cliente video:

Cuando un cliente video en la cara tela envía los datos al cliente video en el lado de la Tecnología inalámbrica, esta Secuencia de eventos ocurre:

  1. En la interfaz FastEthernet en el router1, la directiva del Marca-Para-vídeo se aplica a los paquete de video y los paquetes se marcan con un valor DSCP del AF41.

  2. Los paquete de video marcados pasan a través de las interfaces seriales S3/0 en el router1 y S0/0 en el router2. Aquí es donde la probabilidad de caída del paquete se marca contra el umbral configurado para el WRED. Cuando la longitud de la cola promedio alcanza el umbral mínimo (40 paquetes en este caso para los paquete de video), el WRED cae aleatoriamente algunos paquetes con el valor AF41 DSCP. Semejantemente, cuando la longitud de la cola promedio excede el umbral máximo (50 paquetes en este caso para los packedts video), el WRED cae todos los paquetes con el valor AF41 DSCP.

  3. Una vez que los paquete de video alcanzan el WLC con el FastEthernet en el router2, el WLC traduce el valor DSCP del paquete entrante al AVVID 802.1p ENCIMA del valor y copia el valor DSCP del paquete entrante al paquete lwapp como se muestra aquí. En este ejemplo, el valor AF41 DSCP se traduce 802.1p al valor correspondiente 4.

    qos-wlc-lap11.gif

  4. Cuando el paquete alcanza el REVESTIMIENTO, el REVESTIMIENTO traduce el valor DSCP del paquete lwapp entrante al 802.11e ENCIMA del valor y limpia el valor para asegurarse que no excede el valor máximo permitido para la red inalámbrica (WLAN) política de calidad de servicio (QoS) asignada a ese cliente. El REVESTIMIENTO entonces coloca el paquete en la cola del tx del 802.11 apropiada para el valor ASCENDENTE. En este ejemplo, el valor AF41 DSCP se traduce al 802.11e correspondiente ENCIMA del valor 5.

    /image/gif/paws/81831/qos-wlc-lap12.gif

Cuando un cliente video en el lado inalámbrico envía los datos a la cara tela, esta Secuencia de eventos ocurre:

  1. Cuando un cliente habilitado WMM envía un paquete al REVESTIMIENTO, el REVESTIMIENTO limpia el 802.11e ENCIMA del valor para asegurarse que no excede el valor máximo permitido para política de calidad de servicio (QoS) asignado a ese cliente. Entonces, traduce el valor al valor DSCP. En este ejemplo, la red inalámbrica (WLAN) video se ha configurado con el oro del perfil de QoS, que tiene un 802.11e ENCIMA del valor de 4. Este valor se traduce al valor correspondiente AF41 DSCP y se envía al regulador.

    /image/gif/paws/81831/qos-wlc-lap13.gif

  2. El regulador traduce el valor DSCP del paquete lwapp entrante al 802.1p ENCIMA del valor como se muestra y el valor original DSCP también se envía inalterado.

    /image/gif/paws/81831/qos-wlc-lap14.gif

  3. Los paquetes con el valor af41 DSCP en el FastEthernet en el router2 pasan a través de las interfaces seriales en el router2 y el router1, y alcanzan a los clientes video en la cara tela. Cuando el paquete atraviesa las interfaces seriales, la probabilidad de caída del paquete se marca contra el umbral configurado para el WRED.

Para un WMM FTP cliente inhabilitado:

Cuando el servidor FTP en la cara tela envía los datos al FTP cliente en el lado de la Tecnología inalámbrica, esta Secuencia de eventos ocurre:

  1. En la interfaz FastEthernet en el router1, la directiva Marca-Para-FTP se aplica a los paquetes FTP y los paquetes se marcan con un valor DSCP del AF11.

  2. Los paquetes FTP marcados pasan a través de las interfaces seriales s3/0 en el router1 y S0/0 en el router2. Aquí es donde la probabilidad de caída del paquete se marca contra el umbral configurado para el WRED. Cuando la longitud de la cola promedio alcanza el umbral mínimo (30 paquetes en este caso para los paquetes FTP), el WRED cae aleatoriamente algunos paquetes con el valor AF11 DSCP. Semejantemente, cuando la longitud de la cola promedio excede el umbral máximo (40 paquetes en este caso para los paquetes FTP), el WRED cae todos los paquetes con el valor AF11 DSCP.

  3. Una vez que los paquetes FTP alcanzan el WLC con el FastEthernet en el router2, el WLC traduce el valor DSCP del paquete entrante al AVVID 802.1p ENCIMA del valor y copia el valor DSCP del paquete entrante al paquete lwapp como se muestra aquí. En este ejemplo, el valor AF11 DSCP se traduce 802.1p al valor correspondiente 1.

  4. Cuando el paquete alcanza el REVESTIMIENTO, el REVESTIMIENTO coloca el paquete en la cola predeterminada del tx del 802.11 para la red inalámbrica (WLAN) política de calidad de servicio (QoS) asignada a ese cliente. En este ejemplo, el paquete se coloca en la cola para el perfil de bronce de QoS.

Cuando un FTP cliente en el lado inalámbrico envía los datos a la cara tela, esta Secuencia de eventos ocurre:

  1. Cuando un FTP cliente en la red inalámbrica envía un paquete al REVESTIMIENTO, el REVESTIMIENTO utiliza el 802.11e ENCIMA del valor para política de calidad de servicio (QoS) asignado a ese cliente. Entonces, el REVESTIMIENTO traduce el valor al valor DSCP y envía el paquete al regulador. Porque el FTP cliente pertenece al bronce IEEE 802.11e del perfil de QoS ENCIMA del valor 1 se traduce al valor AF11 DSCP.

  2. El regulador traduce el valor DSCP del paquete lwapp entrante al 802.1p ENCIMA del valor como se muestra y el valor original DSCP también se envía inalterado. El paquete entonces se remite al router2 a través del 2 Switch de la capa.

  3. Los paquetes con el valor AF11 DSCP en el FastEthernet en el router2 pasan a través de las interfaces seriales en el router2 y el router1, y alcanzan a los clientes video en la cara tela. Cuando el paquete atraviesa las interfaces seriales, la probabilidad de caída del paquete se marca contra el umbral configurado para el WRED.

Un procedimiento similar ocurre cuando travesía de los paquetes de voz del atada con alambre a la red inalámbrica y vice versa.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

Usted puede publicar estos comandos cisco ios en el Routers para resolver problemas y verificar su configuración de QoS:

  • cola de la demostración {Número de interfaz del interface name} — Enumera la información sobre los paquetes que están esperando en una cola en la interfaz.

  • la espera de la demostración al azar-detecta la interfaz {Número de interfaz del interface name} — las listas configuración y información estadística sobre la herramienta de los Datos en espera en una interfaz.

  • show policy-map interface {Número de interfaz del interface name} — Visualiza las estadísticas y las configuraciones de las directivas entradas y salidas que se asocian a una interfaz. Aseegurese utilizar este comando en el modo EXEC apropiado.

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • haga el debug de los qos fijados — Visualiza la información sobre la Marcación de paquetes QoS.

En el WLC, publique este comando para ver las configuraciones del perfil de QoS:

  • qos de la demostración {bronce/plata/oro/platino} — provee información en el perfil de QoS configurado para los WLAN.

    Aquí está una salida de muestra del comando show qos:

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • muestre wlan <WLAN-ID > — Visualiza la información sobre la red inalámbrica (WLAN). Éste es un ejemplo de salida:

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 81831