Tecnología inalámbrica / Movilidad : LAN inalámbrica (WLAN)

Multicast con el ejemplo de configuración de los reguladores (WLCs) y de los Puntos de acceso ligeros del Wireless LAN (revestimientos)

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (17 Abril 2008) | Inglés (20 Diciembre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de configuración sobre cómo configurar controladores de LAN inalámbricos (WLC) y Lightweight Access Points (LAP) para la multidifusión y comunicación con una red alámbrica habilitada de multidifusión.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimientos básicos de la configuración de LAPs y WLCs de Cisco

  • Conocimiento de cómo configurar la encaminamiento y la multidistribución básicas en una red alámbrica

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • WLC de Cisco 4400 que funciona con la versión de firmware 4.0

  • Cisco 1000 Series LAP

  • Adaptador de red inalámbrica de cliente de Cisco 802.11a/b/g que funciona con la versión de firmware 2.6

  • Cisco 2500 Router que funciona con el Software Release 12.4(2) del � del Cisco IOS

  • Dos 3500 XL Series Switch de Cisco que funcionan con el Cisco IOS Software Release 12.0(5)WC3b

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Multicast en los reguladores del Wireless LAN (WLCs)

Antes de la versión de software de red del Cisco Unified Wireless 3.2, cuando el Multicast IP fue habilitado, el regulador los paquetes de multidifusión entregados a los clientes del Wireless LAN (red inalámbrica (WLAN)) haciendo las copias de los paquetes de multidifusión, después remitió los paquetes a través de un túnel del protocolo del Lightweight Access Point del unicast (LWAPP) a cada punto de acceso conectado con el regulador. Cada trama de multidifusión recibida por el regulador de un VLA N en el primer router de saltos fue copiada y enviado sobre el túnel del LWAPP a cada uno de los AP conectó con él.

El regulador pudo necesitar generar hasta 300 copias de cada paquete de multidifusión, que depende del número de AP. Este mecanismo es ineficaz, y pone una carga de proceso grande en el regulador. Esto inunda la red con un gran número de paquetes de unidifusión duplicados.

En las versiones de software de red del Cisco Unified Wireless 3.2 y posterior, el funcionamiento del Multicast de la red del Cisco Unified Wireless se ha optimizado. Estas versiones introducen una manera más eficiente de entregar el tráfico Multicast del regulador a los AP. En vez de usar el unicast para entregar cada paquete de multidifusión sobre el túnel del LWAPP a cada AP, utilizan a un grupo de multidifusión del LWAPP para entregar el paquete de multidifusión a cada AP. Esto permite que el Routers en la red utilice las técnicas estándar del Multicast para replicar y para entregar los paquetes de multidifusión a los AP. Para el grupo de multidifusión del LWAPP, el regulador se convierte en el origen de multidifusión y los AP sienten bien a los receptores de multidifusión. Para la característica del funcionamiento del Multicast, los AP validan las interrogaciones del Internet Group Management Protocol (IGMP) solamente del router y de los paquetes de multidifusión con una dirección IP de origen del regulador al cual se asocian actualmente.

Si su red soporta la multidistribución del paquete, usted puede configurar el método del Multicast que el regulador utiliza. El regulador realiza la multidistribución en dos modos:

  • Modo unidifusión — En este modo, el unicasts del regulador cada paquete de multidifusión a cada AP asociado al regulador. Este modo es ineficaz pero se pudo requerir en las redes que no soportan la multidistribución.

  • Modo de multidifusión — En este modo, el regulador envía los paquetes de multidifusión a un grupo de multidifusión del LWAPP. Este método reduce por encima en el procesador del regulador y desplaza el trabajo de la replicación del paquete a su red, que es mucho más eficiente que el método del unicast.

    Usted puede habilitar el modo del Multicast usando el regulador GUI o CLI.

Comportamiento del Multicast en diversas versiones del software WLC

Antes de la versión de firmware 4.0.206.0 del WLC, la expedición de paquete de multidifusión habilitó en el unicast o el modo del Multicast, expedición de paquete de broadcast también habilitada. En la versión de firmware 4.0.206.0 del WLC, el broadcast y el tráfico Multicast se deben habilitar por separado. El broadcast se inhabilita por abandono. Publique este comando del WLC CLI para habilitar el broadcast:

config network broadcast enable

También, el broadcast utiliza el modo del Multicast que se configura en el WLC, incluso si el Multicast no se gira. Si usted quiere habilitar el broadcast sin habilitar el Multicast, usted realiza esto vía el CLI pero no con el GUI. Esto es porque usted no puede fijar la dirección IP o el modo a menos que usted habilite el Multicast en el GUI. Por lo tanto, si el modo del Multicast es unicast y se gira el broadcast, ésta es las aplicaciones del broadcast del modo (se replica el tráfico de broadcast y unicast a cada AP). Si el modo del Multicast se fija al Multicast con una dirección Multicast, después el broadcast utiliza este modo (cada paquete de broadcast se envía vía el grupo de multidifusión a los AP).

config network multicast mode multicast 
                           Or
config network multicast unicast

El Multicast con la invalidación AAA se soporta de la versión 4.2 del regulador del Wireless LAN y posterior. Usted tiene que permitir al IGMP Snooping en el regulador para hacer el trabajo del Multicast con la invalidación AAA.

En el Software Release 4.2 del regulador, el IGMP Snooping se introduce para dirigir mejor los paquetes de multidifusión. Cuando se habilita esta característica, el regulador recolecta los informes IGMP de los clientes, procesa los informes, crea los ID de grupos únicos del Multicast (MGIDs) de los informes IGMP después de marcar la dirección Multicast de la capa 3 y el número VLAN, y envía los informes IGMP al Switch de la infraestructura. El regulador envía estos informes con la dirección de origen pues el direccionamiento de la interfaz en el cual recibió los informes de los clientes.

El regulador entonces pone al día la tabla del Punto de acceso MGID en el AP con el MAC Address del cliente. Cuando el regulador recibe el tráfico Multicast para un grupo de multidifusión determinado, él adelante él a todos los AP. Sin embargo, solamente esos AP que tienen los clientes activos que escuchan o inscritos a ese grupo de multidifusión para enviar el tráfico Multicast en esa red inalámbrica (WLAN) determinada. Los paquetes del IP se remiten con un MGID que sea único para un VLA N del ingreso y el grupo de la multidifusión de destino. Los paquetes de multidifusión de la capa 2 se remiten con un MGID que sea único para la interfaz de ingreso.

Nota: El IGMP Snooping no se soporta en los 2000 Series Controller, los 2100 Series Controller, o el módulo de red del controlador LAN de la tecnología inalámbrica de Cisco para el Routers de los Servicios integrados de Cisco.

Las aplicaciones de multidifusión han conocido las limitaciones de rendimiento en los 2100 Series Controller y el módulo de red del controlador LAN de la tecnología inalámbrica de Cisco para el Routers de los Servicios integrados de Cisco. Cisco está trabajando para dirigir estas limitaciones en una versión futura del código de producción. Mientras tanto, Cisco recomienda que usted utiliza las 4400 Series o los reguladores de WiSM para las aplicaciones intensivas del Multicast.

Nota: El Multicast no se soporta en los AP que están conectados directamente con el puerto local de un 2100 Series Controller.

Refiera al capítulo del diseño del Multicast del Cisco Unified Wireless de la guía de diseño de la movilidad de la empresa para más información sobre el Multicast con el WLCs.

Este documento proporciona un ejemplo de configuración que ilustre cómo configurar la multidistribución en el WLCs para conectar con una red alámbrica habilitada Multicast.

Multicast inalámbrico que vaga por

Un desafío importante para un cliente del Multicast en un entorno de red inalámbrica es mantener su calidad de miembro de grupo de multidifusión cuando está movido sobre la red inalámbrica (WLAN). Los descensos en la conexión de red inalámbrica que se mueven desde el AP-a-AP pueden causar una interrupción en la aplicación de multidifusión de un cliente. El Internet Group Management Protocol (IGMP) desempeña un papel importante en el mantenimiento de la información dinámica de la membresía del grupo.

Una Comprensión básica del IGMP es importante entender qué sucede a la sesión del Multicast de un cliente cuando vaga por sobre la red. En un caso de itinerancia de la capa 2, las sesiones se mantienen simplemente porque el AP no nativo, si está configurado correctamente, pertenece ya al grupo de multidifusión, y el tráfico no es tunneled a un diverso punto de anclaje en la red. Los entornos de itinerancia de la capa 3 son un poco más complejos de este modo, y, dependiente sobre qué modo del Tunelización usted ha configurado en sus reguladores, los mensajes IGMP enviados de un cliente de red inalámbrica pueden ser afectados. El modo predeterminado del Tunelización de la movilidad en un regulador es asimétrico. Esto significa que el tráfico de retorno al cliente está enviado al WLC del ancla y después remitido al WLC no nativo, donde reside la conexión cliente asociada. Los paquetes salientes se remiten hacia fuera la interfaz no nativa del WLC. En el modo simétrico del Tunelización de la movilidad, ambo el tráfico entrante y saliente es tunneled al regulador del ancla.

Guías de consulta para usar al modo de multidifusión

Utilice estas guías de consulta cuando usted habilita el modo del Multicast en su red:

  • La solución de red del Cisco Unified Wireless utiliza algunos alcances del IP Address para los propósitos específicos. Tenga estos rangos presente cuando usted configura a un grupo de multidifusión:

    Aunque no esté recomendada, cualquier dirección Multicast pueda ser asignada al grupo de multidifusión del LWAPP; esto incluye a las direcciones Multicast locales del link reservado usadas por el OSPF, el EIGRP, el PIM, el HSRP, y otros protocolos del Multicast.

    Cisco recomienda que asignen las direcciones Multicast administrativo del bloque 239/8 del scoped. El IANA ha reservado el rango de 239.0.0.0-239.255.255.255 como administrativo direccionamientos del scoped para los dominios del Multicast del uso en privado. Vea la nota para las restricciones adicionales. Estos direccionamientos son similares en la naturaleza a los rangos reservados del unicast del IP privado, tales como 10.0.0.0/8, definidos en el RFC 1918. Los administradores de la red están libres de utilizar a las direcciones Multicast en este rango dentro de su dominio sin el miedo del conflicto con otros a otra parte en Internet. Este administrativo o espacio de dirección privada se debe utilizar dentro de la empresa y su licencia o entrada bloqueada del dominio autónomo (COMO).

    Nota: No utilice el intervalo de direcciones 239.0.0.X o el intervalo de direcciones 239.128.0.X. Los direccionamientos en estos rangos solapan con los MAC Address local de link e inundan hacia fuera todos los puertos del switch, incluso con el IGMP Snooping girado.

    Cisco recomienda que los administradores de red para empresas más futuros subdividen este intervalo de direcciones en alcances administrativos geográficos más pequeños dentro de la red para empresas para limitar el “alcance” de las aplicaciones de multidifusión determinadas. Esto evita que el tráfico Multicast de la alta velocidad salga de un campus (donde está abundante el ancho de banda) y congestionando los links de WAN. También permite la filtración eficiente del Multicast del ancho de banda alto de alcanzar el regulador y la red inalámbrica. Para más información sobre las guías de consulta de la dirección Multicast, refiera a las guías de consulta para la asignación de IP Multicast Address de la empresa.

  • Cuando usted habilita el modo del Multicast en el regulador, usted debe configurar a una dirección de grupo de multidifusión del LWAPP en el regulador. Los AP inscriben al LWAPP al grupo de multidifusión que usa el Internet Group Management Protocol (IGMP).

  • 1130, 1200, 1230, y 1240 los AP del Cisco 1100, utilizan los IGMP versión 1, 2, y 3. Sin embargo, las Cisco 1000 Series AP utilizan solamente el v1 IGMP para unirse a al grupo de multidifusión.

  • El modo de multidifusión trabaja solamente en el modo LWAPP de la capa 3.

  • Los AP en el modo monitor, el modo del sniffer, o el modo rogue del detector no se unen a la dirección de grupo de multidifusión del LWAPP.

  • Cuando usted utiliza los reguladores que funcionan con la versión 4.1 o anterior, usted puede utilizar a la misma dirección Multicast en todos los reguladores. Si usted utiliza los reguladores que funcionan con la versión 4.2 o posterior, el grupo de multidifusión del LWAPP configurado en los reguladores debe ser diferente para cada regulador usado en la red.

  • Si usted utiliza los reguladores con la versión 4.1 o anterior, el modo del Multicast no trabaja a través de los eventos de la movilidad del intersubnet, tales como Tunelización del invitado, VLA N específicos del sitio, o invalidación de la interfaz que utilice el RADIUS. El modo del Multicast trabaja en estos eventos de la movilidad de la subred cuando usted inhabilita las características de la capa 2 IGMP snooping/CGMP en el LAN cableado.

    En versiones posteriores, es decir, 4.2 o más adelante, el modo del Multicast no actúa a través de los eventos de la movilidad del intersubnet, tales como Tunelización del invitado. Hace, sin embargo, actuar con la interfaz reemplaza ese RADIO del uso (pero solamente cuando se habilita el IGMP Snooping) y con los VLA N específicos del sitio (VLA N del grupo del Punto de acceso).

  • El regulador cae cualquier paquete de multidifusión enviado a los números del puerto 12222, 12223, y 12224 UDP. Aseegurese las aplicaciones de multidifusión en su red no utilizan esos números del puerto.

  • El tráfico Multicast se transmite en el 6 Mbps en una red del 802.11a. Por lo tanto, si varios WLAN intentan transmitir en el 1.5 Mbps, la pérdida del paquete ocurre. Esto rompe la sesión del Multicast.

Configuración de la red

En esta configuración, la red alámbrica se comprende del tres Routers, del r1, del r2 y del R3, ese funcionamiento OSPF entre ellos.

Los host atados con alambre conectan con la red a través de un 2 Switch de la capa que esté conectado con el r1 del router. La red inalámbrica conecta con la red a través del router R3, tal y como se muestra en del diagrama.

Los dispositivos necesitan ser configurados para la conectividad de IP básica y habilitan la multidistribución en la red. Por lo tanto, los usuarios pueden enviar y recibir el tráfico Multicast de la cara tela al lado de la Tecnología inalámbrica y vice versa.

Este documento utiliza estos IP Addresses para el WLC, el REVESTIMIENTO y los clientes de red inalámbrica:

WLC Management Interface IP address: 172.16.1.30/16
WLC AP Manager Interface IP address: 172.16.1.31/16
LAP IP address: 172.16.1.50/16
Wireless Client C1 IP address: 172.16.1.75/16
Wireless Client C2 IP address: 172.16.1.76/16
Wired Client W1 IP address: 192.168.0.20/16
Wired Client W2 IP address: 192.168.0.30/16
Wired Client W3 IP address: 192.168.0.40/16

/image/gif/paws/81671/multicast-wlc-lap1.gif

Configurar

Para configurar los dispositivos para esta configuración, estos necesidad de ser realizado:

Configure la red inalámbrica para Multicasting

Antes de que usted configure la multidistribución en el WLCs, usted debe configurar el WLC para la operación básica y registrar los revestimientos al WLC. Este documento asume que el WLC está configurado para la operación básica y que los revestimientos están registrados al WLC. Si usted es usuario nuevo que intenta configurar el WLC para la operación básica con los revestimientos, refiera al registro ligero AP (REVESTIMIENTO) a un regulador del Wireless LAN (WLC).

Nota: No utilice el 239.0.0.X o los intervalos de direcciones 239.128.0.X. Los direccionamientos en estos rangos solapan con los MAC Address local de link e inundan todos los puertos del switch, incluso con el IGMP Snooping habilitado. Refiera a la sección de direcciones Multicast de la capa 2 de la reseña general de tecnología del Multicast IP para más información sobre los Multicast MAC Address que solapan.

Los revestimientos se registran al WLC, completan una vez estas tareas para configurar los revestimientos y el WLC para esta configuración:

  1. Configure la red inalámbrica (WLAN) para los clientes

  2. Habilite al modo de multidifusión de los Ethernetes vía el GUI

Configure la red inalámbrica (WLAN) para los clientes

El primer paso es crea una red inalámbrica (WLAN) a la cual los clientes de red inalámbrica puedan conectar y recibir el acceso a la red. Complete estos pasos para crear una red inalámbrica (WLAN) en el WLC:

  1. Haga clic los WLAN del regulador GUI para crear una red inalámbrica (WLAN).

  2. Haga clic nuevo para configurar una nueva red inalámbrica (WLAN).

    En este ejemplo, la red inalámbrica (WLAN) se nombra MulticastUsers y el ID DE WLAN es 1.

    /image/gif/paws/81671/multicast-wlc-lap2.gif

  3. Haga clic en Apply (Aplicar).

  4. En la red inalámbrica (WLAN) > edite la ventana, definen los parámetros específicos a la red inalámbrica (WLAN).

    1. Para la red inalámbrica (WLAN), elija la interfaz apropiada del campo de nombre de la interfaz.

      Este ejemplo asocia la interfaz de administración a la red inalámbrica (WLAN).

    2. Seleccione los otros parámetros, que depende de los requisitos de diseño.

      Los valores predeterminados se utilizan en este ejemplo.

    3. Haga clic en Apply (Aplicar).

      multicast-wlc-lap3.gif

      Nota: En este ejemplo, acode 2 métodos de seguridad para autenticar a los usuarios de red inalámbrica no se utilizan. Por lo tanto, no elija ninguno en el campo de Seguridad de la capa 2. Por abandono, la opción de seguridad de la capa 2 es 802.1x.

      Nota: En vez de asociar la red inalámbrica (WLAN) (SSID) a la interfaz de administración, las interfaces dinámicas se pueden también configurar en el WLC para dividir a los usuarios de red inalámbrica en segmentos y la red inalámbrica (WLAN) se puede asociar a las interfaces dinámicas. Refiera a los VLA N en el ejemplo de configuración de los reguladores del Wireless LAN para la información sobre cómo configurar las interfaces dinámicas en el WLCs.

Publique estos comandos para configurar los WLAN en el WLC usando el CLI:

  1. Publique los config wlan crean <wlan-identificación > <wlan-nombre > comando para crear una nueva red inalámbrica (WLAN). Para la WLAN-identificación, ingrese un ID a partir de la 1 a 16. Para el WLAN-nombre, ingrese un SSID hasta 31 caracteres alfanuméricos.

  2. Publique el permiso wlan de los config <wlan-identificación > comando para habilitar una red inalámbrica (WLAN).

    Por el ejemplo en este documento, los comandos son:

    config wlan create 1 MulticastUsers
    config wlan enable 1
    

Modo de multidifusión de los Ethernetes del permiso vía el GUI

El siguiente paso es configurar el WLC para multicasting. Complete estos pasos:

  1. De la página web del general de regulador, asegúrese de que fijen al modo de transporte LWAPP para acodar 3.

    La característica del funcionamiento del Multicast trabaja solamente en este modo.

    /image/gif/paws/81671/multicast-wlc-lap4.gif

    Nota: Cuando el Multicast se habilita como unicast del Multicast, los paquetes se replican para cada AP; éste puede ser hace un uso intensivo del procesador, así que utilícelo con cautela. El Multicast habilitado como Multicast del Multicast utiliza a la dirección Multicast asignada usuario para hacer un Multicast más tradicional hacia fuera a los AP.

  2. Del menú desplegable para el modo de multidifusión de los Ethernetes, elija el Multicast y ingrese a una dirección de grupo de multidifusión.

    En este ejemplo, el direccionamiento es 239.255.1.60.

    /image/gif/paws/81671/multicast-wlc-lap7.gif

  3. Haga clic en Apply (Aplicar).

    Nota: El WLC 4100 no soporta el modo del Multicast. El Multicast se hace solamente en el modo unidifusión. Esto significa que el regulador tiene que replicar el paquete de multidifusión para cada AP y el unicast el paquete de multidifusión a cada uno de los AP.

    Publique estos comandos para habilitar el Multicast con el CLI:

    1. De la línea de comando, publique el comando enable global del Multicast de la red de los config.

    2. De la línea de comando, publique el <multicast-grupo-IP-direccionamiento > el comando del Multicast del modo del Multicast de la red de los config.

      Por el ejemplo en este documento, los comandos son:

      config network multicast global enable
      config network multicast mode multicast 239.255.1.60
      

Después de que el administrador habilite el Multicast (el modo del Multicast se inhabilita por abandono) y configure a un grupo de multidifusión del LWAPP, el nuevo algoritmo del Multicast trabaja en una de estas maneras:

Cuando la fuente del grupo de multidifusión está en el LAN cableado:

El LWAPP AP descarga el regulador que la dirección de grupo de multidifusión del LWAPP durante el normal se une al proceso (en el tiempo del inicio) al regulador. Después de que un AP se una a un regulador y descargue su configuración, el AP publica una petición IGMP para unirse a al grupo de multidifusión del LWAPP del regulador. Esto acciona la configuración normal para el estado del Multicast en el Routers habilitado para multicast, entre el regulador y los AP. La dirección IP de origen para el grupo de multidifusión es la dirección IP de la interfaz de administración del regulador, no la dirección IP del AP manager usada para el modo de la capa 3.

Cuando el regulador recibe un paquete de multidifusión de los VLA N uces de los del cliente en el primer router de saltos, transmite el paquete al grupo de multidifusión del LWAPP vía la interfaz de administración en el nivel más bajo de QoS. Los bits de QoS para el paquete de multidifusión del LWAPP están puestos en hard-code en el más bajo y no se pueden cambiar por el usuario.

La red habilitada para multicast entrega el paquete de multidifusión del LWAPP a cada uno de los AP que se han unido a al grupo de multidifusión del LWAPP. Los usos de la red habilitados para multicast los mecanismos normales del Multicast en el Routers de replicar el paquete a lo largo del camino, según las necesidades, de modo que el paquete de multidifusión alcance todos los AP. Esto alivia el regulador de la replicación de los paquetes de multidifusión.

Los AP pueden recibir otros paquetes de multidifusión, pero el proceso solamente los paquetes de multidifusión que vienen del regulador al cual se unen a actualmente. Se desecha cualquier otra copia. Si más de una red inalámbrica (WLAN) SSID se asocia al VLA N de donde el paquete de multidifusión original fue enviado, el AP transmite el paquete de multidifusión sobre cada red inalámbrica (WLAN) SSID (que sigue a la BITMAP de la red inalámbrica (WLAN) en el encabezamiento LWAPP). Además, si esa red inalámbrica (WLAN) SSID está en ambas radios (802.11g y 802.11a), ambas radios transmiten el paquete de multidifusión en la red inalámbrica (WLAN) SSID si hay clientes asociados a ella, incluso si esos clientes no pidieron el tráfico Multicast.

Cuando la fuente del grupo de multidifusión es un cliente de red inalámbrica:

El paquete de multidifusión es unicast (Lwapp-encapsulado) del AP al regulador, similar al tráfico estándar del cliente de red inalámbrica.

El regulador hace dos copias del paquete de multidifusión. Una copia se envía el VLA N asociado a la red inalámbrica (WLAN) SSID en la cual llegó. Esto permite a los receptores en el LAN cableado para recibir la secuencia de multidifusión y al router para aprender sobre el nuevo grupo de multidifusión. La segunda copia del paquete Lwapp-se encapsula y se envía al grupo de multidifusión del LWAPP de modo que los clientes de red inalámbrica puedan recibir la secuencia de multidifusión.

Configure la red alámbrica para Multicasting

Para configurar la red alámbrica para esta configuración, usted necesita configurar la Conectividad de los routeres para básica y habilitar la multidistribución en la red alámbrica.

Según lo mencionado anterior, el OSPF se utiliza como el Unicast Routing Protocol.

Cualquier Multicast Protocol se puede utilizar en la red alámbrica. Este documento utiliza el PIM-DM como el Multicast Protocol. Refiera a la guía de configuración del Multicast IP del Cisco IOS para información detallada sobre los diversos protocolos que se pueden utilizar para multicasting en una red alámbrica.

Éstos son el r1, r2 y R3 de las configuraciones para Routers:

R1 del router
RouterR1#show run
Building configuration...

Current configuration : 836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR1
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.3.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR3
 ip address 10.2.4.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
 !
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

R2 del router
RouterR2#show run
Building configuration...

Current configuration : 616 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR2
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 description Connnected to RouterR3
 ip address 10.2.2.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.3.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router R3
RouterR3#show run
Building configuration...

Current configuration : 711 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterR3
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

 
!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.2.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.4.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Para los 2 Switch de la capa, no se requiere ninguna configuración para multicasting. Todos los 2 Switch de la capa basada en IOS tienen CGMP habilitado por abandono. Por lo tanto, el Switches procesa automáticamente los mensajes CGMP del Routers.

Verificación y resolución de problemas

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Para verificar la configuración, usted necesita enviar el tráfico Multicast de la fuente W1 y marcar si el tráfico Multicast atraviesa la red alámbrica y alcanza a los miembros atados con alambre y inalámbricos del grupo, W2, c1 y C2.

Realice esta tarea para probar si el Multicast IP se configura correctamente en su red.

Si todo el Routers del multicast capaz es miembros de un grupo de multidifusión, haciendo ping que el grupo hace a todo el Routers responder, que pueden ser administrativa y una herramienta de debugging útiles.

Otra razón para tener un router unirse a un grupo de multidifusión es cuando otros host en la red tienen una configuración del Interior Gateway Routing Protocol (IGRP) que evite que contesten correctamente a las interrogaciones IGMP. Cuando usted tiene el router unirse a al grupo de multidifusión, éste hace a los routeres ascendentes mantener la información del tabla de Multicast Routing para ese grupo y guardar las trayectorias para ese active del grupo. Para configurar a un router para ser parte del grupo de multidifusión, publique este comando del modo de configuración de la interfaz:

ip igmp join-group <group-address> 
Example: Router(config-if)#ip igmp join-group 239.255.1.60

Aquí está la salida del ping del router R3:

RouterR3#ping 239.255.1.60

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.255.1.60, timeout is 2 seconds:

Reply to request 0 from 10.2.2.2, 40 ms
Reply to request 0 from 10.2.3.1, 84 ms
Reply to request 0 from 10.2.4.1, 44 ms

Localización de un salto defectuoso

Realice esta tarea para monitorear y diagnosticar una configuración básica del Multicast IP. Usted puede utilizar este procedimiento cuando un receptor y una fuente no actúan como se esperaba.

/image/gif/paws/81671/multicast-wlc-lap6.gif

Aquí están las salidas de la calidad de miembro del igmp del IP de la demostración y los comandos show ip mroute count para el ejemplo de configuración. Estas salidas fueron tomadas del router R3.

RouterR3#sh ip igmp membership
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
       <ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
 *,224.0.1.40                   10.2.2.1        1d21h    stop  2LA    Se0
 *,239.255.1.60                    172.16.1.1      1d06h    02:17 1LA    Et0
RouterR3#sh ip mroute count
IP Multicast Statistics
5 routes using 3094 bytes of memory
2 groups, 1.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.255.1.60, Source count: 3, Packets forwarded: 6860, 
Packets received: 7087
  Source: 172.16.1.30/32, Forwarding: 304/1/147/0, Other: 304/0/0
  Source: 172.16.1.75/32, Forwarding: 6329/8/57/3, Other: 6329/0/0
  Source: 192.168.0.20/32, Forwarding: 227/1/69/0, Other: 454/227/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

De estas salidas, usted puede ver que el tráfico Multicast fluye de la fuente W1 y es recibido por los miembros del grupo.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 81671