Switches : Switches Cisco Catalyst de la serie 6500

Ejemplo de Configuración para Migrar Spanning Tree de PVST+ a MST

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo para migrar el modo del árbol de expansión de PVST+ a Multiple Spanning Tree (MST) en la red de oficinas centrales.

prerrequisitos

Requisitos

Refiera comprensión del protocolo multiple spanning-tree (802.1s) antes de que usted configure el MST.

Esta tabla muestra el soporte del MST en los switches de Catalyst y el software mínimo requerido para ese soporte.

Plataforma Catalyst MST con el RSTP
Catalyst 2900XL y 3500XL No disponible
Catalyst 2950 y 3550 12.1(9)EA1 del Cisco IOS
Catalyst 3560 Cisco IOS 12.1(9)EA1
Catalyst 3750 Cisco IOS 12.1(14)EA1
Catalyst 2955 Todas las versiones del IOS de Cisco
Catalyst 2948G-L3 y 4908G-L3 No disponible
Catalyst 4000, 2948G, y 2980G (Catalyst OS (CatOS)) 7.1
Catalyst 4000 y 4500 (Cisco IOS) 12.1(12c)EW
Catalyst 5000 y 5500 No disponible
Catalyst 6000 y 6500 (CatOS) 7.1
Catalyst 6000 y 6500 (Cisco IOS) 12.1(11b)EX, 12.1(13)E, 12.2(14)SX
Catalyst 8500 No disponible

  • Catalyst 3550/3560/3750: La implementación de TheMST en el Cisco IOS Release 12.2(25)SEC se basa en el estándar del IEEE 802.1S. Las implementaciones MST en versiones anteriores del Cisco IOS son prestandard.

  • Catalyst 6500 (IOS): La implementación MST en el Cisco IOS Release 12.2(18)SXF se basa en el estándar del IEEE 802.1S. Las implementaciones MST en versiones anteriores del Cisco IOS son prestandard.

Componentes Utilizados

Este documento se crea con el Cisco IOS Software Release 12.2(25) y el CatOS 8.5(8), pero la configuración es aplicable a la versión de IOS mínima mencionada en la tabla.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Antecedentes

La característica MST es el IEEE 802.1S y es una enmienda al 802.1Q. El MST amplía el algoritmo rápido del Spanning-tree 802.1w (RST) a los árboles de expansión múltiples. Esta extensión prevé la convergencia rápida y el Equilibrio de carga en un entorno del VLA N. Instancia del árbol de expansión del funcionamiento PVST+ y Rapid-PVST+ para cada VLA N. En el MST, usted puede agrupar los VLA N en una instancia única. Utiliza la versión 3 del (BPDU) de la Unidad de bridge protocol data que es compatible con versiones anteriores con el 802.1D STP que utiliza la versión 0 BPDU.

Configuración MSTP: La configuración incluye el nombre de la región, del número de revisión, y de la correspondencia de la asignación del VLA N-a-caso MST. Usted configura el Switch para una región con el comando global configuration de la configuración del mst del atravesar-árbol.

Región MST: Una región MST consiste en los Bridges interconectados que tienen la misma configuración de MST. No hay límite en el número de regiones MST en la red.

Instancias del árbol de expansión dentro de la región MST: Un caso no es nada sino un grupo de VLA N asociados en el comando configuration del mst del atravesar-árbol. Por abandono, todos los VLA N se agrupan en IST0, que se llama un Spanning-tree interno (IST). Usted puede crear manualmente los casos numerados 1 a 4094, y se etiquetan MSTn (n =1 a 4094), pero la región puede soportar solamente hasta 65 casos. Algunas de las versiones soportan solamente 16 casos. Refiera la guía de configuración de software para su plataforma del switch seleccionar.

IST/CST/CIST: El IST es el único caso que puede enviar y recibir los BPDU en la red MST. Un caso de MSTn es local a la región. Los IST en diversas regiones se interconectan con un Common Spanning Tree (CST). La colección de IST en cada región MST y el CST que conecta los IST se llaman el Spanning-tree común e interno (CIST).

Compatibilidad descendente: El MST es compatible con versiones anteriores con el PVST+, Rapid-PVST+, y Prestandard MST (MISTP). El Switch MST es conectado con el otro Switches STP (PVST+ y Rapid-PVST+) por el Common Spanning Tree (CST). El otro Switches STP (PVST+ y Rapid-PVST+) considera la región MST entera como un solo switch. Cuando usted conecta el Switch del prestandard MST con el Switch estándar MST, usted necesita configurar el mst del atravesar-árbol PRE-estándar en la interfaz del Switch estándar MST.

Configurar

Este ejemplo contiene dos secciones. La primera sección muestra la configuración actual PVST+. La segunda sección muestra la configuración que emigra del PVST+ al MST.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Este diagrama incluye este Switches:

  • Distribution1 y Distribution2, que están en la capa de distribución

  • Dos switches de capa de acceso llamaron Access1 (IOS) y Access2 (CatOS)

  • Dos Switches de la agregación del servidor llamó Services1 y Services2

Los VLA N 10, 30, y 100 llevan el tráfico de datos. Los VLA N 20, 40, y 200 llevan el tráfico de voz.

/image/gif/paws/72844/MST-1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Configuración PVST+

El Switches se configura en el PVST+ para llevar los datos y el tráfico de voz según el diagrama de la red. Éste es un resumen corto de la configuración:

  • El Switch Distribution1 se configura para convertirse en un Root Bridge primario para los VLAN de datos 10, 30, y 100 con el atravesar-árbol 10,30,100 vlan Distribution1(config)# arraigan el comando primary, y el Root Bridge secundario para los VLA N 20, 40, y 200 de la Voz utiliza el comando secondary vlan de 20,40,200 raíces del atravesar-árbol Distribution1(config)#.

  • El Switch Distribution2 se configura para convertirse en un Root Bridge primario para los VLA N 20 de la Voz, 40, y 200 con el atravesar-árbol 20,40,200 vlan Distribution2(config)# arraigan el comando primary, y el Root Bridge secundario para los VLAN de datos 10, 30, y 100 utiliza el comando secondary vlan de 10,30,100 raíces del atravesar-árbol Distribution2(config)#.

  • Configuran al comando spanning-tree backbonefast en todo el Switches de converger el STP más rápidamente en caso de la falla de link indirecto en la red.

  • Configuran al comando spanning-tree uplinkfast en los switches de capa de acceso de converger el STP más rápidamente en caso de la falla de link ascendente directa.

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Usted puede ver que el puerto Fa1/0/24 está configurado con el comando vlan de la prioridad de puerto 64 del atravesar-árbol 20,40,200. Distribution2 es la raíz configurada para los VLA N 20,40, y 200. Distribution2 tiene dos links a Distribution1: Fa1/0/23 y Fa1/0/24. Ambos puertos se señalan los puertos para los VLA N 20, 40, y 200 porque Distribution2 es la raíz para esos VLA N. Ambos puertos tienen la misma prioridad 128 (valor por defecto). También, estos dos links tienen el mismo coste de Distribution1: fa1/0/23 y fa1/0/24. Distribution1 elige el número del puerto más bajo de los dos puertos para fijar el puerto en el estado de reenvío. El número del puerto más bajo es Fa1/0/23 pero, según el diagrama de la red, los VLA N 20, 40, y 200 de la Voz pueden atravesar Fa1/0/24. Usted puede lograr esto con estos métodos:

  1. Disminuya el costo de puerto en Distribution1: Fa1/0/24.

  2. Disminuya la prioridad de puerto en Distribution2: Fa1/0/24.

En este ejemplo, la prioridad de puerto se disminuye para remitir los VLA N 20, 40, 200 fa1/0/24 directos.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Usted puede ver que el puerto Fa0/5 en Services1, y Fa0/6 y Fa0/48 en Services2 tiene la configuración del coste y de la prioridad de puerto del puerto de árbol de expansión. Aquí el STP está ajustado de modo que el VLAN 100 y 200 de Services1 y de Services2 puedan pasar a través de los links de troncal entre ellos. Si esta configuración no es aplicada, Services1 y 2 no pueden pasar el tráfico a través de los links de troncal entre ellos. En lugar, elige la trayectoria con Distribution1 y Distribution2.

Services2 ve dos trayectos de igual costos al VLAN 100 arraigar (Distribution1): un Services1 directo y el segundo un Distribution2 directo. El STP elige el mejor trayecto (puerto raíz) en esta orden:

  1. El costo del trayecto

  2. El Bridge ID del Switch de la expedición

  3. La prioridad de puerto más baja

  4. El número más bajo del puerto interno

En este ejemplo, ambas las trayectorias tienen el mismo coste, pero el Distribution2 (24576) tiene una prioridad baja que Services1 (32768) para el VLAN 100, así que Services2 elige Distribution2. En este ejemplo, el costo de puerto en Services1: fa0/5 se fija más bajo para dejar Services2 elegir el Services1. El costo del trayecto reemplaza el número de prioridad del Switch de la expedición.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

El mismo concepto es aplicado para que Services1 elija Services2 para remitir el VLA N 200. Después de que usted reduzca el coste para el VLA N 200 en Services2 - fa0/6, Services1 elige fa0/47 para remitir el VLA N 200. El requisito aquí es remitir a VLA N 200 fa0/48 directos. Usted puede lograr esto con estos dos métodos:

  1. Disminuya el costo de puerto en Services1: Fa0/48.

  2. Disminuya la prioridad de puerto en Services2: Fa0/48.

En este ejemplo, la prioridad de puerto en Services2 se disminuye para remitir a VLA N 200 fa0/48 directos.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

Migración MST

Es difícil convertir todo el Switches en la red para empresas al MST al mismo tiempo. Debido a la compatibilidad descendente, usted puede convertirla fase por la fase. Implemente los cambios en la ventana de mantenimiento planificado porque el atravesar - la reconfiguración del árbol puede interrumpir el flujo de tráfico. Cuando usted habilita el MST, también habilita el RSTP. El spanning-tree uplinkfast y las características del backbonefast son características PVST+, y se inhabilita cuando usted habilita el MST porque esas características se construyen dentro del RSTP, y el MST confía en el RSTP. Dentro de la migración, usted puede quitar esos comandos en el IOS. En el backbonefast y el uplinkfast del catOS, los comandos se borran automáticamente de la configuración, pero la configuración de las características tales como el PortFast, el bpduguard, el bpdufilter, la protección raíz, y el loopguard son también aplicables en el modo MST. El uso de estas características es lo mismo que en el modo PVST+. Si usted ha habilitado ya estas características en el modo PVST+, sigue siendo activo después de la migración al modo MST. Cuando usted configura el MST, siga estas guías de consulta y restricciones:

  • El primer paso en la migración a 802.1s/w es identificar correctamente el Punto a punto y los puertos de borde. Asegúrese de que todos los links entre switches, en los cuales se desea una transición rápida, sean FULL-duplex. Los puertos de borde se definen a través de la característica portfast.

  • Elija un nombre de la configuración y un número de revisión que sean comunes a todo el Switches en la red. Cisco recomienda que usted pone tanto Switches como sea posible en una sola región; no es ventajoso dividir una red en segmentos en las regiones separadas.

  • Decida cuidadosamente cuántos casos se necesitan en la red de switch, y tenga presente que un caso traduce a una topología lógica. Evite asociar cualquier VLA N sobre el caso 0. Decida qué VLA N a asociar sobre esos casos, y para elegir cuidadosamente una raíz y la raíz de reserva para cada caso.

  • Asegúrese de que los trunks lleven todos los VLA N que se asocian a un caso o no llevan ningunos VLA N en absoluto para este caso.

  • El MST puede obrar recíprocamente con los Legacy Bridge que ejecutan el PVST+ en una basada en cada puerto, así que no es un problema para mezclar ambos tipos de Bridges si las interacciones se entienden claramente. Intente siempre guardar la raíz del CST y del IST dentro de la región. Si usted obra recíprocamente con un Bridge PVST+ a través de un trunk, asegúrese de que el Bridge MST sea la raíz para todos los VLA N que se permitan en ese trunk. No utilice los Bridges PVST como la raíz del CST.

  • Asegúrese de que todos los Bridges de la raíz del árbol de expansión PVST tengan (numéricamente) prioridad más alta más baja que el Root Bridge CST.

  • No inhabilite atravesar - árbol en ningún VLA N en los Bridges uces de los PVST.

  • No conecte el Switches con los vínculos de acceso porque los vínculos de acceso pueden dividir un VLA N.

  • Cualquier configuración de MST que implique un gran número de puertos VLAN lógicos actuales o nuevos se debe completar dentro de una ventana de mantenimiento porque la base de datos completa MST consigue reinicializada para cualquier cambio ampliado, tal como la adición de nuevos VLA N a los casos o el movimiento de los VLA N a través de los casos.

En este ejemplo, la red de oficinas centrales tiene una región MST region1 nombrado y dos casos de MST1 - los VLAN de datos 10, 30, y 100, y MST2 - expresan los VLA N 20, 40, y 200. Usted puede ver que el MST funciona con solamente dos casos, pero el PVST+ funciona con seis casos. Distribution1 se elige como raíz regional CIST. Significa que Distribution1 es la raíz para IST0. Para cargar la balanza el tráfico en la red según el diagrama, Distribution1 se configura como la raíz para MST1 (caso para los VLAN de datos), y se configura MST2 mientras que la raíz para MST2 (caso para los VLA N de la Voz).

Usted necesita emigrar la base primero y trabajar su manera abajo a los switches de acceso. Antes de que usted cambie al modo del árbol de expansión, configure la configuración de MST en el Switches. Entonces cambie el tipo STP al MST. En este ejemplo, la migración ocurre en esta orden:

  1. Distribution1 y Distribution2

  2. Services1 y Services2

  3. Access1

  4. Access2

  1. Migración Distribution1 y Distribution2:

    
    !--- Distribution1 configuration:
    
    Distribution1(config)#spanning-tree mst configuration
    Distribution1(config-mst)#name region1
    Distribution1(config-mst)#revision 10
    Distribution1(config-mst)#instance 1 vlan 10, 30, 100
    Distribution1(config-mst)#instance 2 vlan 20, 40, 200
    Distribution1(config-mst)#exit
    Distribution1(config)#spanning-tree mst 0-1 root primary
    Distribution1(config)#spanning-tree mst 2 root secondary
    
    
    !--- Distribution2 configuration:
    
    Distribution2(config)#spanning-tree mst configuration
    Distribution2(config-mst)#name region1
    Distribution2(config-mst)#revision 10
    Distribution2(config-mst)#instance 1 vlan 10, 30, 100
    Distribution2(config-mst)#instance 2 vlan 20, 40, 200
    Distribution2(config-mst)#exit
    Distribution2(config)#spanning-tree mst 2 root primary
    Distribution2(config)#spanning-tree mst 0-1 root secondary
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    
    Distribution1(config)#interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)#interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    !--- STP mode conversion.
    
    Distribution1(config)#spanning-tree mode mst
    Distribution2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic.
    
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#spanning-tree mst 2 port-priority 64
    
    
    !--- PVST+ cleanup.
    
    Distribution1(config)#no spanning-tree backbonefast
    Distribution2(config)#no spanning-tree backbonefast
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#no spanning-tree vlan 20,40,200 port-priority 64
    

    Nota: Se recomienda que usted fija la raíz MST0 manualmente. En este ejemplo, se elige Distribution1 mientras que la raíz MST0, así que Distribution1 se convierte en la raíz CIST.

    Ahora la red está en la configuración mezclada. Puede ser representada según este diagrama:

    MST-2.gif

    Distribution1 y Distribution2 están en MST region1, y el Switches PVST+ considera el region1 como solo Bridge. El flujo de tráfico después del reconverge se muestra en el diagrama 2. Usted puede todavía ajustar el Switches PVST+ (VLA N X del atravesar-árbol costado) al loadbalance los datos y el tráfico de voz según el diagrama 1. Después de que usted emigre el resto de Switches según los pasos 2 a 4, usted consigue la topología del árbol de expansión final según el diagrama 1.

  2. Migración Services1 y Services2:

    
    !--- Services1 configuration:
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)#name region1
    Services1(config-mst)#revision 10
    Services1(config-mst)#instance 1 vlan 10, 30, 100
    Services1(config-mst)#instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    !--- Services2 configuration:
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)#name region1
    Services2(config-mst)#revision 10
    Services2(config-mst)#instance 1 vlan 10, 30, 100
    Services2(config-mst)#instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the 
    !--- VLANs that are mapped to an instance.
    
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    !--- STP Mode conversion:
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic:
    
    Services1(config)#interface fastEthernet 0/46
    Services1(config-if)#spanning-tree mst 2 cost 200000
    Services1(config-if)#exit
    Services1(config)#interface fastEthernet 0/47
    Services1(config-if)#spanning-tree mst 2 cost 100000
    Services1(config-if)#exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)#exit
    
    
    !--- PVST+ cleanup:
    
    Services1(config)#no spanning-tree uplinkfast
    Services1(config)#no spanning-tree backbonefast
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#no spanning-tree vlan 100 cost 18
    Services1(config-if)#exit
    
    Services2(config)#no spanning-tree uplinkfast
    Services2(config)#no spanning-tree backbonefast
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#no spanning-tree vlan 200 cost 18
    Services2(config-if)#exit
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#no spanning-tree vlan 200 port-priority 64
    Services2(config-if)#exit
    
  3. Migración Access1:

    
    !--- Access1 configuration:
    
    Access1(config)#spanning-tree mst configuration
    Access1(config-mst)#name region1
    Access1(config-mst)#revision 10
    Access1(config-mst)#instance 1 vlan 10, 30, 100
    Access1(config-mst)#instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    !--- STP mode conversion:
    
    Access1(config)#spanning-tree mode mst
    
    
    !--- PVST+ cleanup:
    
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
  4. Migración Access2:

    
    !--- Access2 configuration:
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    !--- Ensure that trunks carry all the VLANs that are mapped to an instance:
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- Backbonefast and uplinkfast configurations are cleaned up automatically.
    
    

Verificación

Se recomienda para verificar la topología del árbol de expansión cada vez que se cambia la configuración.

Verifique que el Switch Distribution1 sea el Root Bridge para los VLAN de datos 10, 30, y 100, y verifique que el trayecto de reenvío del atravesar-árbol haga juego según la trayectoria en el diagrama.

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- CIST root is Distribution1. All the 
!--- switches are in the same region "region1".
!--- Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 72844