Switches : Switches Cisco Catalyst de la serie 6500

Spanning-tree del PVST+ al ejemplo de configuración de la migración Rápido-PVST

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (1 Mayo 2008) | Inglés (20 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo para migrar el modo del árbol de expansión de PVST+ a rapid-PVST+ en la red de oficinas centrales. También explica la configuración PVST+, el Equilibrio de carga del Spanning-tree, y las características de UplinkFast y del BackboneFast.

prerrequisitos

Requisitos

Se recomienda para leer comprensión del protocolo rapid spanning-tree (802.1w) antes de que usted configure rapid-PVST+.

Esta tabla muestra el soporte del protocolo rapid spanning-tree (RSTP) en los switches de Catalyst, y el software mínimo requerido para ese soporte.

Plataforma Catalyst Rapid-PVST+
Catalyst 2900XL/3500XL No disponible
Catalyst 2940 12.1(20)EA2
Catalyst 2950/2955/3550 12.1(13)EA1
Catalyst 2970/3750 12.1(14)EA1
Catalyst 3560 12.1(19)EA1
Catalyst 3750 Metro 12.1(14)AX
Catalyst 2948G-L3/4908G-L3 No disponible
Catalyst 4000/2948G/2980G (CatOS) 7.5
Catalyst 4000/4500 (IOS) 12.1(19)EW
Catalyst 5000/5500 No disponible
Catalyst 6000/6500 7.5
Catalyst 6000/6500 (IOS) 12.1(13)E
Catalyst 8500 No disponible

Componentes Utilizados

La información en este documento se basa en el software de Cisco IOS� Release12.2(25) y CatOS 8.5(8). Sin embargo, la configuración es aplicable en la versión del Cisco IOS mínimo mostrada en la tabla.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

el Spanning Tree Protocol 802.1D (STP) tiene una desventaja de la convergencia lenta. Tipos del soporte tres del Switches del Cisco Catalyst de STP, que son PVST+, rapid-PVST+ y MST. El PVST+ se basa en IEEE802.1D estándar e incluye las extensiones propietarias de Cisco tales como BackboneFast, UplinkFast, y PortFast. Rapid-PVST+ se basa en el IEEE 802.1W estándar y tiene una convergencia más rápida que 802.1D. El RSTP (IEEE 802.1W) incluye nativo la mayor parte de las mejoras propietarias de Cisco al Spanning-tree 802.1D, tal como BackboneFast y UplinkFast. Rapid-PVST+ tiene estas funciones únicas:

  • Utiliza la versión 2 del (BPDU) de la Unidad de bridge protocol data que es compatible con versiones anteriores con el 802.1D STP, que utiliza la versión 0 BPDU.

  • Todo el Switches genera los BPDU y los envía en todos los puertos cada 2 segundos, mientras que en 802.1D STP solamente el Root Bridge envía los BPDU de configuraciones.

  • Funciones del puerto — Puerto raíz, puerto designado, puerto alternativo y puerto de backup.

  • Estados de puerto — Desechando, aprendiendo, y envío.

  • Tipos de puerto — Puerto de borde (PortFast), Punto a punto y puerto compartido.

El Rápido-PVST utiliza el RSTP para proporcionar una convergencia más rápida. Cuando cualquier puerto RSTP recibe la herencia 802.1D BPDU, recurre a la herencia STP y las ventajas inherentes de la convergencia rápida de 802.1w se pierden cuando obra recíprocamente con los Legacy Bridge.

Configurar

Este ejemplo contiene dos secciones. La primera sección muestra la configuración actual PVST+. La segunda sección muestra la configuración para emigrar del PVST+ a rapid-PVST+.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Este diagrama tiene este Switches:

  • Distribution1 y Distribution2, que están en la capa de distribución

  • Dos switches de capa de acceso llamaron Access1 (IOS) y Access2 (CatOS)

  • Dos Switches de la agregación del servidor llamó Services1 y Services2

Los VLA N 10, 30, y 100 llevan el tráfico de datos. Los VLA N 20, 40, y 200 llevan el tráfico de voz.

rapidpvst-mig-config1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Configuración PVST+

El Switches se configura en el PVST+ para llevar los datos y el tráfico de voz según el diagrama de la red. Éste es un resumen corto de la configuración:

  • El Switch Distribution1 se configura para convertirse en un Root Bridge primario para los VLAN de datos 10, 30, 100 usando el comando primary vlan de 10,30,100 raíces del atravesar-árbol Distribution1(config)#, y el Root Bridge secundario para los VLA N 20 de la Voz, 40, 200 utiliza el comando secondary vlan de 20,40,200 raíces del atravesar-árbol Distribution1(config)#.

    Nota: El comando primary de la raíz del árbol de expansión altera la prioridad de Bridge del Switch a 8192 y el comando secondary de la raíz del árbol de expansión altera la prioridad a 16384.

  • El Switch Distribution2 se configura para convertirse en un Root Bridge primario para los VLA N 20 de la Voz, 40, 200 usando el comando primary vlan de 20,40,200 raíces del atravesar-árbol Distribution2(config)#, y el Root Bridge secundario para los VLAN de datos 10, 30, 100 utiliza el comando secondary vlan de 10,30,100 raíces del atravesar-árbol Distribution2(config)#.

  • Configuran al comando spanning-tree backbonefast en todo el Switches de converger el STP más rápidamente en caso de la falla de link indirecto en la red.

  • Configuran al comando spanning-tree uplinkfast en los switches de capa de acceso de converger el STP más rápidamente en caso de la falla de link ascendente directa.

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 8192
spanning-tree vlan 20,40,200 priority 16384
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Usted puede ver que el puerto Fa1/0/24 está configurado con el comando vlan de la prioridad de puerto 64 del atravesar-árbol 20,40,200. Distribution2 es raíz configurada para los VLA N 20,40,200. Distribution2 tiene dos links a Distribution1: Fa1/0/23 y Fa1/0/24. Ambos puertos se señalan los puertos para los VLA N 20, 40, 200 porque Distribution2 es la raíz para esos VLA N. Ambos puertos tienen la misma prioridad 128 (valor por defecto). También, estos dos links tienen el mismo coste de Distribution1: fa1/0/23 y fa1/0/24. Distribution1 elige el número del puerto más bajo de los dos puertos para fijar el puerto en el estado de reenvío. El número del puerto más bajo es Fa1/0/23. Sin embargo, según el diagrama de la red, los VLA N 20 de la Voz, 40, 200 deben atravesar Fa1/0/24. Usted puede lograr esto con estos métodos:

  1. Disminuya el costo de puerto en Distribution1: Fa1/0/24

  2. Disminuya la prioridad de puerto en Distribution2: Fa1/0/24

En este ejemplo, la prioridad de puerto se disminuye para remitir los VLA N 20, 40, 200 fa1/0/24 directos.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Usted puede ver que el puerto Fa0/5 en Services1, y Fa0/6 y Fa0/48 en Services2 tiene el coste del puerto de árbol de expansión y configuración de la prioridad de puerto. Aquí el STP está ajustado de modo que el VLAN 100 y 200 de Services1 y de Services2 puedan pasar a través de los links de troncal entre ellos. Si esta configuración no es aplicada, Services1 y 2 no pasarán el tráfico a través de los links de troncal entre ellos. En lugar, elige la trayectoria con Distribution1 y Distribution2.

Services2 ve dos trayectos de igual costo a la raíz del VLAN 100 (Distribution1). Uno vía Services1, segundo vía Distribution2. El STP elige el mejor trayecto (puerto raíz) en esta orden:

  1. Costo del trayecto

  2. El Bridge ID del Switch de la expedición

  3. La prioridad de puerto más baja

  4. El número más bajo del puerto interno

En este ejemplo, ambas las trayectorias tienen el mismo coste. Sin embargo, el Distribution2 (24576) tiene prioridad baja que Services1 (32768) para el VLAN 100. Por lo tanto, Services2 elige Distribution2. En este ejemplo, costo de puerto en Services1: fa0/5 se fija más bajo para dejar Services2 elegir el Services1. El costo del trayecto reemplaza el número de prioridad del Switch de la expedición.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

El mismo concepto es aplicado para que Services1 elija Services2 para remitir el VLA N 200. Después de que usted reduzca el coste para el VLA N 200 en Services2 - fa0/6, Services1 elige fa0/47 para remitir el VLA N 200. Sin embargo, el requisito aquí es remitir a VLA N 200 fa0/48 directos. Usted puede lograr con estos dos métodos:

  1. Disminuya el costo de puerto en Services1: Fa0/48

  2. Disminuya la prioridad de puerto en Services2: Fa0/48

En este ejemplo, la prioridad de puerto en Services2 se disminuye para remitir a VLA N 200 fa0/48 directos.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

UplinkFast y BackboneFast

Es bueno conocer el comportamiento de UplinkFast y del BackboneFast antes de que usted comience el proceso de migración. En el diagrama de la red, el Switch Access1 funciona con el Cisco IOS. Esta salida se lleva antes de la migración el modo rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  Uplinkfast enabled

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p


Access1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled
BackboneFast                 is enabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Se toma esta salida después de que el modo se cambie a rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  UplinkFast enabled but inactive in rapid-pvst mode

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled but inactive in rapid-pvst mode
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Usted puede ver en el comando show spanning-tree summary hecho salir que UplinkFast y el BackboneFast están habilitados, pero está inactivo en el modo rápido-PVST. Es opcional quitar ambos los comandos. No afecta a la operación ua de los rápido-PVST si usted no quita los comandos. Si usted inhabilita el UplinkFast con el comando configuration mode del no spanning-tree uplinkfast, la prioridad de Bridge y el costo de puerto invierten de nuevo al valor por defecto. Es recomendable tener la prioridad de Bridge del Switch de la no raíz como número más elevado. Esta salida muestra después de que la Función UplikFast se inhabilite en el modo rápido-PVST:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        19
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 19        128.107  P2p
Fa3/0/2          Altn BLK 19        128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

CatOS no permite que usted cambie el modo al rápido-PVST si se habilita la característica del BackboneFast. Usted tiene que inhabilitar el BackboneFast antes de la migración. UplinkFast actúa como lo mismo que se comporte en el IOS.

Access2> (enable) set spantree mode rapid-pvst+
Cannot change the spantree mode to RAPID-PVST+ when backbonefast is enabled.

Migración Rapid-PVST+

Rapid-PVST+ utiliza el mismo formato BPDU que el 802.1D y él es compatibles con versiones anteriores. Es difícil convertir todo el Switches en la red para empresas al mismo tiempo a rapid-PVST+. Debido a la compatibilidad descendente, usted puede convertir la fase por la fase. Se recomienda para implementar los cambios en la ventana de mantenimiento planificado porque el atravesar - la reconfiguración del árbol interrumpe el flujo de tráfico. Las características del spanning-tree uplinkfast y del BackboneFast son características PVST+. Se inhabilitan éstos cuando usted habilita rapid-PVST+ porque esas características se construyen dentro de rapid-PVST+. Por lo tanto, durante la migración usted puede quitar esos comandos. La configuración de las características tales como PortFast, BPDUguard, BPDUfilter, protección raíz, y loopguard es aplicable en el modo rapid-PVST+ también. El uso de estas características es lo mismo que en el modo PVST+. Si usted ha habilitado ya estas características en el modo PVST+, las características siguen siendo activas después de la migración al modo rapid-PVST+. En este ejemplo, la migración ocurre en esta orden:

  1. Access1

  2. Access2

  3. Services1 y Services2

  4. Distribution1 y Distribution2

  1. Migración Access1:

    Access1(config)#spanning-tree mode rapid-pvst
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
    
    Access1#show spanning-tree vlan 10
    
    VLAN0010
      Spanning tree enabled protocol rstp
      Root ID    Priority    24586
                 Address     0015.63f6.b700
                 Cost        19
                 Port        107 (FastEthernet3/0/1)
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
    
      Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
                 Address     000f.f794.3d00
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time 300
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa3/0/1          Root FWD 19        128.107  P2p Peer(STP)
    Fa3/0/2          Altn BLK 19        128.108  P2p Peer(STP)
    
    
    !--- Type P2p Peer(STP) represents that the neighbor switch runs PVST.
    
    
  2. Migración Access2:

    Access2> (enable) set spantree backbonefast disable
    Backbonefast disabled for all VLANs.
    
    Access2> (enable) set spantree mode rapid-pvst+
    PVST+ database cleaned up.
    Spantree mode set to RAPID-PVST+.
    
    
    Access2> (enable) clear spantree uplinkfast
    This command will cause all portcosts, portvlancosts, and the
    bridge priority on all vlans to be set to default.
    Do you want to continue (y/n) [n]? y
    VLANs 1-4094 bridge priority set to 32768.
    The port cost of all bridge ports set to default value.
    The portvlancost of all bridge ports set to default value.
    uplinkfast all-protocols field set to off.
    uplinkfast disabled for bridge.
  3. Migración Services1 y Services2:

    Services1(config)#spanning-tree mode rapid-pvst
    Services1(config)#no spanning-tree backbonefast
    
    Services2(config)#spanning-tree mode rapid-pvst
    Services2(config)#no spanning-tree backbonefast
    
  4. Migración Distribution1 y Distribution2:

    Distribution1(config)#spanning-tree mode rapid-pvst
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution1 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution1(config)#no spanning-tree backbonefast
    
    
    Distribution2(config)#spanning-tree mode rapid-pvst
    
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    own
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    p
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution2 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution2(config)#no spanning-tree backbonefast
    

Salida de los debugs - Modo mezclado

En una red para empresas grande, el proceso de migración puede tardar algunos días. Durante el proceso de migración, usted puede ejecutar el LAN en el modo mezclado, tal como algún Switches en el PVST+ y algún Switches en el modo rapid-PVST+. En el modo mezclado, usted no recibe las ventajas completas de rapid-PVST+. El tiempo de convergencia total es lo mismo que el tiempo de convergencia del modo PVST+. Para aprovechar completo de rapid-PVST+, todo el Switches en la topología del árbol de expansión debe ejecutar el rapid-PVST+. Para mostrar cómo el atravesar - el árbol se comporta en el modo mezclado, a ejemplo de resultado de comando debug se muestra aquí. Distribution1 y Distribution2 están en el PVST+, y Access1 está en el modo rapid-PVST+.

La salida del comando debug spanning-tree muestra el Funcionamiento del STP cuando el link entre Access1 y Distribution1 falla.

Access1

00:55:13: RSTP(10): updt roles, root port Fa0/1 going down
00:55:13: RSTP(10): Fa0/2 is now root port
00:55:13: RSTP(10): Fa0/2 received a tc ack
00:55:15: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
00:55:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

00:55:20: STP: VLAN0010 Topology Change rcvd on Fa1/0/23
00:55:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:55:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
00:55:22: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

Distribution2

00:55:06: STP: VLAN0010 Topology Change rcvd on Fa1/0/2
00:55:06: STP: VLAN0010 sent Topology Change Notice on Fa1/0/23

La salida del comando debug spanning-tree muestra el Funcionamiento del STP cuando el link entre Access1 y Distribution1 está para arriba.

Access1

00:55:40: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:55:43:  STP: PVST vlan 10 port Fa0/1 created, ext id 2E42430, vp 3389640
00:55:43: RSTP(10): initializing port Fa0/1
00:55:43: RSTP(10): Fa3/0/1 is now designated
00:55:43:  STP: PVST vlan 20 port Fa0/1 created, ext id 2E42430, vp 300EC20
00:55:43: RSTP(20): initializing port Fa0/1
00:55:43: RSTP(20): Fa0/1 is now designated
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): updt roles, received superior bpdu on Fa0/1
00:55:43: RSTP(10): Fa0/1 is now root port
00:55:43: RSTP(10): Fa0/2 blocked by re-root
00:55:43: RSTP(10): Fa0/2 is now alternate
00:55:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to up
00:55:44: RSTP(20): updt roles, received superior bpdu on Fa0/1
00:55:44: RSTP(20): Fa0/1 is now alternate

Distribution1

00:55:49: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
00:55:50: set portid: VLAN0010 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDB708
00:55:50: STP: VLAN0010 Fa1/0/1 -> listening
00:55:50: set portid: VLAN0020 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 3C06F20
00:55:50: STP: VLAN0020 Fa1/0/1 -> listening
00:55:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to up
00:56:05: STP: VLAN0010 Fa1/0/1 -> learning
00:56:05: STP: VLAN0020 Fa1/0/1 -> learning
00:56:20: STP: VLAN0010 Fa1/0/1 -> forwarding
00:56:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:56:20: STP: VLAN0020 Fa1/0/1 -> forwarding


!--- This output is evident that the Access1 switch waits for the 
!--- standard 802.1D Spanning Tree process of listening, learning and forwarding
!--- to complete in Distribution1.




Distribution2

00:55:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
00:56:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24


!--- This output shows that Distribution2 is notified
!--- about the indirect link outage by TCN BPDUs.

Salida de los debugs - Modo Rapid-PVST+

El Switches Distribution1, Distribution2 y Access1 está en el modo rapid-PVST+. La salida del comando debug spanning-tree muestra el Funcionamiento del STP cuando el link entre Access1 y Distribution1 falla.

Access1

01:31:04: RSTP(10): updt roles, root port Fa0/1 going down
01:31:04: RSTP(10): Fa0/2 is now root port
01:31:06: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
01:31:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

01:31:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
01:31:14: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

La salida del comando debug spanning-tree muestra el Funcionamiento del STP cuando el link entre Access1 y Distribution1 está para arriba.

Access1

01:35:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:35:48:  STP: PVST vlan 10 port Fa3/0/1 created, ext id 2E42430, vp 3C8E360
01:35:48: RSTP(10): initializing port Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now designated
01:35:48:  STP: PVST vlan 20 port Fa3/0/1 created, ext id 2E42430, vp 3C8E3E0
01:35:48: RSTP(20): initializing port Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now designated
01:35:48: RSTP(10): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now root port
01:35:48: RSTP(10): Fa3/0/2 blocked by re-root
01:35:48: RSTP(10): synced Fa3/0/1
01:35:48: RSTP(10): Fa3/0/2 is now alternate
01:35:48: RSTP(20): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now alternate
01:35:48: RSTP(10): transmitting an agreement on Fa3/0/1 as a response to a prop
osal

Distribution1

01:35:55: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
01:35:56:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDCCD8
01:35:56: RSTP(10): initializing port Fa1/0/1
01:35:56: RSTP(10): Fa1/0/1 is now designated
01:35:56:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 2D21C60
01:35:56: RSTP(20): initializing port Fa1/0/1
01:35:56: RSTP(20): Fa1/0/1 is now designated
01:35:56: RSTP(10): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(10): received an agreement on Fa1/0/1
01:35:57: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:59: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:01: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:03: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:06: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:08: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:10: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:11: RSTP(20): Fa1/0/1 fdwhile Expired
01:36:12: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:14: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:16: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:18: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:20: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:22: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:24: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): Fa1/0/1 fdwhile Expired


!--- Distribution1 puts the port Fa1/0/1 as designated for VLANs 10 and 20.
!--- It also proposes that Fa1/0/1 is designated for VLANs 10, 20. Access1 agrees with the 
!--- proposal for VLAN10. However, it does not agree with the proposal for VLAN20 because it  
!--- has the superior BPDU for VLAN20 from Distribution2.

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Se recomienda para verificar la topología del árbol de expansión cada vez que se cambia la configuración.

Verifique que el Switch Distribution1 sea el Root Bridge para los VLAN de datos 10, 30, 100. También, verifique que el atravesar - el trayecto de reenvío del árbol hace juego según la trayectoria en el diagrama de la red.

Distribution1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     0015.63f6.b700
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 19        128.1    P2p
Fa1/0/3          Desg FWD 19        128.3    P2p
Fa1/0/5          Desg FWD 19        128.5    P2p
Fa1/0/23         Desg FWD 19        128.23   P2p
Fa1/0/24         Desg FWD 19        128.24   P2p


Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Access2> (enable) show spantree 30
VLAN 30
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24606
Designated Root Cost        19
Designated Root Port        3/3
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-1d
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT        19   32 P2P
 3/4                     blocking      ALTR        19   32 P2P

Access2> (enable) show spantree 40
VLAN 40
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24616
Designated Root Cost        19
Designated Root Port        3/4
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-27
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR        19   32 P2P
 3/4                     forwarding    ROOT        19   32 P2P


Services1#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        18
             Port        7 (FastEthernet0/5)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Root FWD 18        128.7    P2p
Fa0/46           Desg FWD 19        128.50   P2p
Fa0/47           Desg FWD 19        128.51   P2p

Services1#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        37
             Port        51 (FastEthernet0/47)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Altn BLK 19        128.7    P2p
Fa0/46           Altn BLK 19        128.50   P2p
Fa0/47           Root FWD 19        128.51   P2p

Services2#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        37
             Port        42 (GigabitEthernet0/42)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Altn BLK 19        128.6    P2p
Fa0/42           Root FWD 19        128.42   P2p
Fa0/43           Altn BLK 19        128.43   P2p

Services2#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        18
             Port        6 (GigabitEthernet0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Root FWD 18        128.6    P2p
Fa0/42           Desg FWD 19        128.42   P2p
Fa0/43           Desg FWD 19         64.43   P2p

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 72836