Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Guía de Configuración y Troubleshooting del Cisco DSL Router - Router DLS de Cisco que actúa como Cliente de PPPoE con un IP Address dinámico

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Su Proveedor de Servicios de Internet (ISP) ha asignado una dirección IP pública dinámica a su Cisco Digital Subscriber Line (DSL) Router.

Consejo: Si usted no es familiar con cómo configurar los dispositivos de Cisco y quisiera seguir una configuración gradual, refiera a la configuración gradual del PPPoE con un IP Address dinámico.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Tareas de realizarse

  • Diseñe un esquema de IP Addressing para su LAN privado.

  • Configure ajuste una dirección IP, una máscara de subred, y de un Maximum Segment Size TCP (MSS) en la interfaz de Ethernet del router DLS de Cisco.

  • Configure la interfaz ATM (Digital Subscriber Line del Asymetric (ADSL) interfaz) del router DLS de Cisco con un circuito virtual permanente (PVC) y la encapsulación atmósfera.

  • Configure un grupo virtual de la red de datos privada del Point-to-Point Protocol over Ethernet (PPPoE) (VPDN) para el software de Cisco IOS� más viejo que 12.2(13)T.

  • Cree y configure la interfaz del dialer del router DLS de Cisco para el PPPoE con una dirección IP negociada.

  • (Para la traducción de dirección de red [NAT]) — Configure el NAT en el router DLS de Cisco para permitir la distribución de la dirección IP de las públicas dinámicas de la interfaz del dialer.

    • Opcional: Agrupamiento NAT, si los IP Addresses adicionales han sido proporcionados por su ISP.

    • Opcional: NAT estático, si los usuarios de Internet requieren el acceso a los servidores internos.

  • Configure cada PC cliente con una dirección IP, una máscara de subred, un default gateway, y un servidor del Domain Name System (DNS).

    (Para el [DHCP] del protocolo DHCP) — Alternativamente, si usted quisiera que el router DLS de Cisco asignara los IP Address dinámicos de sus clientes PC, configure cada PC para obtener una dirección IP y los servidores DNS automáticamente vía el DHCP.

Pasos de configuración necesarios posibles en el PC

Si su el router DLS de Cisco software support el IP tcp ajusta-mss 1452 o el IP ajusta-mss 1452 comandos configuration, no hay otra acción necesaria y usted puede continuar con la sección de la configuración.

Si su software del router DLS de Cisco no soporta el IP tcp ajusta-mss 1452 o el IP ajusta-mss 1452 comandos configuration, usted debe cambiar los Tamaños de la unidad máxima de transmisión (MTU) en cada PC en su LAN que tenga acceso a Internet a través del router DLS de Cisco.

Complete estos pasos para cambiar la talla del MTU:

  1. Descargue la última versión del Dr. herramienta TCPleavingcisco.com .

  2. Restaure su página del navegador para asegurarse que la página es actual.

  3. Funcione con al Dr. herramienta TCP.

  4. Del menú elija su adaptador Ethernet.

  5. Tipo 1492 en el campo MTU.

  6. El tecleo se aplica para salvar el cambio, y después hace clic la salida.

  7. Reinicie el PC cliente PPPoE.

Se guarda el cambio de registro cuando los finales así que usted del procedimiento necesitan funcionar con la utilidad solamente una vez por el PC.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Configuración

Consejo: Si usted no es familiar con cómo configurar los dispositivos de Cisco y quisiera seguir una configuración gradual, refiera a la configuración gradual del PPPoE con un IP Address dinámico.

Router DLS de Cisco con un IP Address dinámico

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
 vpdn-group pppoe
  request-dialin
   protocol pppoe

!--- These commands are needed only on Cisco IOS Software earlier than 12.2(13)T.

!
!
ip subnet-zero
!


!--- For DHCP:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported,  
 !--- try this configuration statement:
 !--- ip adjust-mss 1452   


 
!--- If this command is not supported in your current Cisco DSL Router software
 !--- release, either upgrade to the latest Cisco DSL Router software or follow the 
 !--- procedure in the "Possible Required Configuration Steps on the PC" 
 !--- section of this document. 

 


!--- For NAT:


ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
 pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address negotiated
 mtu 1492


!--- For NAT:


 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication chap pap callin
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!


!--- For NAT:


ip nat inside source list 1 interface dialer1 overload


!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> 
!---  <last ip address> netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer 1


!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network was 10.10.10.0, configuring 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 would allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Si su servicio DSL no está trabajando correctamente, vea la localización de averías del Cliente de PPPoE del router DLS de Cisco.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 71118