Servicios de redes de aplicaciones : Cisco Cache Engines de la serie 500

Configurar el IP spoofing en el motor del caché en una configuración transparente con un Content Services Switch

24 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (1 Octubre 2014) | Comentarios


Contenido


Introducción

Este documento brinda un ejemplo de configuración de memoria caché transparente y de simulación de IP simultáneamente sin utilizar el Web Cache Communications Protocol (WCCP) en el Cisco Cache Engine y en el balanceador de carga Cisco Content Services (CSS) 11000 o CSS 11500.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Oculte el motor (CE) 500 Application and Content Networking Software corrientes (ACNS) 4.2 o más adelante

  • CSS11000 o CSS11500

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

Almacenamiento en memoria caché transparente significa que el tráfico de un cliente a un servidor es redireccionado en forma silenciosa por un router o un switch de Capa 4 a un dispositivo de caché (Cisco Cache Engine en este caso).

Si el dispositivo del caché tiene ya una copia del contenido el cliente está buscando, el caché contestará en nombre del servidor. Si el contenido no está presente en el caché, el dispositivo intentará obtenerlo del servidor antes de responder la solicitud del cliente.

Por abandono, el caché entrará en contacto el servidor usando su propia dirección IP. Es a veces necesario, sin embargo, utilizar el dirección IP del cliente. Esto es posible configurando el IP spoofing.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

ip_spoofing-a.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

  • CSS 11000

  • Motor 500 de memoria caché

CSS 11000
!Generated on 04/18/2003 09:30:41
!Active version: ap10500007s

configure

!*************************** GLOBAL ***************************
  no restrict web-mgmt 
  no restrict xml 
  bridge spanning-tree disabled 
  persistence reset remap 
  acl enable 

!--- An Access Control List (ACL) is needed. Enable the ACL.

 
  ip route 0.0.0.0 0.0.0.0 10.48.66.1 1 
  ip route 192.168.10.0 255.255.255.0 192.168.20.100 1 
  ip route 192.168.20.0 255.255.255.0 10.48.66.31 1 
  ip route 192.168.20.0 255.255.255.0 192.168.30.3 1
 

!--- Very important !!!!
!--- For the ECMP feature of the CSS to work, 
!--- you need one route pointing to the upstream router, 
!--- and one identical route pointing to the cache.
!--- The CSS will know which one to use based on where 
!--- the traffic came in first.


!************************* INTERFACE *************************
interface e1
  phy 100Mbits-FD 

interface e2
  bridge vlan 149 
  phy 100Mbits-FD 

interface e3
  bridge vlan 161 
  phy 100Mbits-FD 

!************************** CIRCUIT **************************
circuit VLAN1

  ip address 10.48.66.130 255.255.254.0 

circuit VLAN149

  ip address 192.168.10.70 255.255.255.0 

circuit VLAN161

  ip address 192.168.30.1 255.255.255.0 

!************************** SERVICE **************************
service agra 

!--- Definition of the cache device.

  ip address 192.168.30.3 
  type transparent-cache


!--- It is important to set the type to transparent-cache
!--- so that the CSS does not NAT the destination IP address.
!--- Only the destination MAC address is modified.



  port 80 
  active 
!**************************** EQL ****************************
eql CacheMe 

!--- Definition of what objects are cacheable.

  extension gif 
  extension html 
  extension pdf 
  extension zip 
  extension gz 

!*************************** OWNER ***************************
owner gilles 
  content ToCache 

!--- Definition of the content rule to redirect the traffic.
!--- No VIP address specified since you want to intercept all HTTP traffic.

  
    protocol tcp 
    port 80 
    url "/*" eql CacheMe 

!--- Redirect all requests of a cahceable object.
	 
    add service agra 
    active 
!**************************** ACL ****************************
acl 1 
  clause 10 bypass tcp any destination 192.168.10.2 eq 80

!--- This ACL is necessary to make sure that the HTTP requests from
!--- the cache itself are not intercepted by the content rule.


  clause 20 permit any any destination any 
  apply circuit-(VLAN161) 
acl 2 

!--- Permit all traffic for the other interfaces.

  clause 20 permit any any destination any 
  apply circuit-(VLAN149) 
  apply circuit-(VLAN1) 

Motor 500 de memoria caché
 
hostname CE500
! 
http l4-switch enable


!--- Tells the Cache Engine to accept traffic with any IP destination.

http l4-switch spoof-client-ip enable 


!--- This is a new command in ACNS 5.x. this command replaces the 
!--- wccp spoof-client-ip enable command.


!
!
!
!
!
!
exec-timeout 0
!
!
!
interface FastEthernet 0/0
 ip address 192.168.30.3 255.255.255.0
 exit
interface FastEthernet 0/1
 shutdown
 exit
!
!
ip default-gateway 192.168.30.1
!
primary-interface FastEthernet 0/0
!
!
!
logging console enable
!
!
!
!
!
!
!
wccp version 2
wccp spoof-client-ip enable


!--- This commands enable IP spoofing, and it works 
!--- even if you do not use WCCP. This command only works with
!--- WCCP redirected traffic if you have ACNS 5.x.
!--- Therefore, if you are using version 5.x of ACNS, this command
!--- should be replaced with the command http l4-switch spoof-client-ip enable
!--- mentioned above.


!
!
CE500#

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Comandos show CSS11000

  • show summary — Muestra los contadores de aciertos de regla de contenido para verificar si CSS recibe y redirecciona tráfico.

  • show service name — Muestra el estado del servicio.

Comandos de motor de memoria caché

  • show stat http request name—Muestra el número de petición de HTTP recibido por la memoria caché.

  • show stat http savings name—Muestra la cantidad de aciertos y pérdidas en el Cache Engine.

Troubleshooting

Para solucionar este problema, utilice los comandos anteriores. La mayor parte del tiempo, sin embargo, es necesario utilizar un sniffer para descubrir el trayecto exacto seguido por el tráfico.

Usted puede también publicar el comando flow trace CSS disponible en el modo del debug. Usted conseguirá un mejor resultado con un sniffer sin embargo.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 42162