Voz y Comunicaciones unificadas : Cisco Unified Communications Manager (CallManager)

Configuración de la gateway MGCP del IOS de Cisco

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Marzo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento:

  • Le dirige con una configuración simple del Media Gateway Control Protocol (MGCP)

  • Presenta solamente los comandos required mínimos de construir una configuración que trabaje para un router con dos dos de la Estación de intercambio remota (FXS) puertos del Oficina de intercambio remoto (FXO) y

Nota: Las instrucciones en este documento trabajan para un gateway de voz de Cisco 200 (VG200) y los Cisco 2600 y 3600 Series Router que funcionan con el Software Release 12.1(5)T y Posterior de Cisco IOS�. Refiera a la documentación del Cisco IOS Software para las versiones de software admitido de otros gatewayes MGCP del Cisco IOS.

Síntomas:

Usted puede potencialmente encontrar esta lista de síntomas cuando usted configura el Cisco CallManager con los gatewayes MGCP del Cisco IOS con el FXO analógico y los puertos FXS:

  • El gateway MGCP no se registra con el Cisco CallManager. Refiera a la falla en la inscripción del gateway MGCP con el Cisco CallManager.

  • El Identificador de llamada no funciona en los puertos FXO. Esto es porque el Identificador de llamada no se soporta con los puertos FXO cuando está configurado para el MGCP. Configure el gateway en el modo de H.323 en lugar de otro.

  • La paginación de arriba bloquea para arriba los puertos FXO durante el hookflash a menos que vayan los usuarios totalmente descolgado. Shut siguió por ningún cerrado reajusta el puerto. Esto se relaciona con el Id. de bug Cisco CSCef62275 (clientes registrados solamente) cuando está reparada en el Cisco IOS Software Release 12.3(14)T y Posterior.

Este documento es parte 2 de un conjunto de documento seises:

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Un Cisco IOS Gateway que funciona con una versión de Cisco IOS Software que soporte el MGCP con el Cisco CallManager

  • Cisco VG200

Nota: Hay otros trenes de versión del Cisco IOS Software que soportan el MGCP en los routeres Cisco. El Cisco IOS Software Release 12.1XM es un ejemplo.

precaución Precaución: El sintaxis para algunos de los comandos mgcp es diferente en otras versiones de Cisco IOS Software. Refiera a la documentación para su configuración para determinar el sintaxis se requiere que.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • 1 * X Cisco VG200/2 X FXS/2 FXO/1 fast ethernet 10/100 puerto; Cisco IOS Software Release 12.1(5)T

  • 1 * Cisco CallManager 3.0(5a) que se ejecuta en un MCS7835

  • 2 * Auriculares analógicos

  • 2 * Teléfonos IP del Cisco 7960

Refiera al CME unificado Cisco y a la matriz de compatibilidad de la versión del Cisco IOS Software para las versiones de software recomendadas de la compatibilidad entre el Cisco CallManager y el Cisco IOS Gateway.

Nota: El Cisco IOS Software Release 12.2(11)T y Posterior se recomienda sobre la base de las mejoras del comando ccm-manager. El comando ccm-manager requiere el Cisco IOS Software Release 12.1(5)XM y después todo el Routers (2600 y 3600) y el VG200.

Soporte MGCP de los Cisco 2600 y 3600 Router si funcionan con el Cisco IOS Software Release 12.1(3)T y Posterior. Las versiones de software que usted requiere se basan en las características que usted necesita habilitar. El Cisco Callmanager server debe funcionar con el Software Release 3.0(5)a o Posterior. La configuración del router es lo mismo para todos los tipos de Routers. La configuración del CallManager de Cisco es también lo mismo para todos los tipos de Routers.

Soporte del Cisco IOS Software Release 12.1(5)XM1 y Posterior el VG200. Las versiones de software que usted requiere se basan en las características que usted necesita habilitar. Utilice el Software Release 3.0(5)a y Posterior aunque el VG200 se soporta en versiones de software CallManager de Cisco anteriores.

Nota: Hay otros trenes de versión del Cisco IOS Software que soportan el MGCP en los routeres Cisco. El Cisco IOS Software Release 12.1XM es un ejemplo.

precaución Precaución: El sintaxis para algunos de los comandos mgcp es diferente en otras versiones de Cisco IOS Software. Refiera a la documentación para su configuración para determinar el sintaxis requerido.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Tareas de realizarse

Complete estos pasos:

  1. Configure una dirección IP en la interfaz de Ethernet del Cisco IOS Gateway.

  2. Asigne un nombre único al Cisco IOS Gateway.

  3. Configure el Cisco IOS Gateway para ejecutar el MGCP como Signaling Protocol.

  4. Configure la dirección IP o el nombre del Sistema de nombres de dominio (DNS) para el Cisco Callmanager server.

  5. Seleccione el tipo de códec y la función del relay de múltiples frecuencias del tono dual (DTMF).

  6. Diga a Cisco IOS Gateway que comunica con un Cisco Callmanager server.

  7. Ate la aplicación MGCP a los puertos de voz.

  8. Habilite los puertos de voz.

  9. Habilite la conectividad del IP.

Paso a paso

Nota: El recordatorio de este documento refiere al VG200. El VG200 comienza con una configuración predeterminada, pues viene enviado.

Complete estos pasos:

  1. Configure una dirección IP en la interfaz de Ethernet VG200 y habilite la interfaz.

    router(config)#interface fastethernet 0/0
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    router(config-if)#no shut
    
  2. Asigne un nombre único al VG200. Esto permite que el Cisco Callmanager server lo identifique.

    router(config)#hostname VG200A 
    
    /* This is how CallManager keeps track of the MGCP network */
    /* devices it is communicating with. This name must be     */
    /* unique.                                                 */
  3. Configure el VG200 para ejecutar el MGCP como Signaling Protocol.

    VG200A(config)#mgcp
    
  4. Configure la dirección IP o el nombre DNS para el Cisco Callmanager server.

    VG200A(config)#mgcp call-agent 172.16.1.252
    
    VG200A(config)#ccm-manager config server 172.16.1.252
    
    VG200A(config)#ccm-manager config
    

    Utilizan al comando mgcp call-agent de configurar el direccionamiento y el protocolo del agente de la llamada para los puntos finales del MGCP en un gateway de medios. Este comando se puede utilizar para especificar la versión del protocolo usado. Para más información, refiera al llamada-agente del mgcp.

    Utilizan al comando ccm-manager config server de especificar el servidor TFTP del cual el gateway del Media Gateway Control Protocol (MGCP) descarga los archivos de configuración del Cisco CallManager XML.

    Requieren al comando ccm-manager config habilitar la descarga de los archivos de configuración del Cisco CallManager XML.

    Nota: Publique estos comandos de configurar los CallManageres redundantes de Cisco en el clúster del Cisco CallManager:

    VG200(config)#ccm-manager redundant-host [ip-address |
      dns-name] [ip-address | dns-name] 
    VG200(config)#ccm-manager switchback {graceful | immediate
      |schedule-time hh:mm | uptime-delay minutes} 
  5. Seleccione el tipo de códec y la función del relé dtmf.

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
    
  6. Publique este comando de habilitar el soporte para el Cisco CallManager dentro del MGCP:

    VG200A(config)#ccm-manager mgcp
    
  7. Ate la aplicación MGCP a los puertos de voz.

    Nota: Publique el comando show voice port de determinar el tipo de puertos que el VG200 tenga y en qué orden están instalados.

    VG200A(config)#dial-peer voice 1 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/0
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 2 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/1
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 3 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/0
    
    /* FXS port */
    
    VG200A(config)#dial-peer voice 4 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/1
    
    /* FXS port */

    Nota: El comando application MGCPAPP es con diferenciación entre mayúsculas y minúsculas en algunas versiones de Cisco IOS Software. Publique siempre este comando en el mayúscula a menos que usted sepa que su versión de software no es con diferenciación entre mayúsculas y minúsculas. Mire la salida del comando show running-config para marcar si su versión de software es con diferenciación entre mayúsculas y minúsculas. El Cisco IOS Software Release 12.1(5)T no es con diferenciación entre mayúsculas y minúsculas.

  8. Asegúrese que los puertos de voz estén habilitados.

    Nota: Los comandos shutdown and no shutdown afectan a ambos puertos en una placa interfaz de voz (VIC). Publique el comando en solamente uno de estos puertos.

    VG200A(config)#voice-port 1/0/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXO port */
    
    VG200A(config)#voice-port 1/1/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXS port */s
  9. Habilite la conectividad del IP.

    Habilite el Routing IP si los dispositivos de VoIP uces de los con los cuales el VG200 comunica están situados en diversos redes secundarios o el VLANS. Usted también necesita crear una red predeterminada, o el gateway de último recurso. Este paso muestra cómo realizar ambas tareas:

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway
    
    

    Nota: El VG200 no es un router IP. Usted no puede funcionar con los IP Routing Protocol tales como protocolo del Routing Information Protocol (RIP), del Interior Gateway Routing Protocol (IGRP), o del Open Shortest Path First (OSPF) en él. Se comporta más bién una estación terminal (cliente) por lo que la conectividad del IP.

    Nota: Usted puede configurar un Routing Protocol en vez de las Static rutas en los otros gatewayes del Cisco IOS, que son esencialmente Routers con las interfaces de voz. El problema importante es asegurar la conectividad del IP entre los dispositivos de VoIP.

    Nota: El comando ip routing no aparece en la configuración porque está normalmente en por abandono cuando usted habilita el Routing IP. Los comandos default no aparecen generalmente en una configuración del router de Cisco. Las imágenes del Cisco IOS VG200 reemplazan este comportamiento predeterminado poniendo en hard-code el comando no ip routing en la configuración inicial. Se crea esta configuración cuando se inicia la imagen:

    • En una plataforma donde el comando write erase ha borrado la configuración

    • En un VG200 que nunca se ha configurado

    El comando ip_address_of_gateway de 0.0.0.0 0.0.0.0 de la ruta de IP hace el VG200 instalar un gateway de último recurso en la tabla de ruteo. El comando show ip route confirma esto. El Gateway IP Address es 172.16.1.1 en este ejemplo:

    VG200A#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 172.16.1.1 to network 0.0.0.0
    
    C    172.16.0.0/16 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 [1/0] via 172.16.1.1
    VG200A#

    Nota: Requieren al comando ip classless también para que este gateway de último recurso sea eficaz. Habilitan al comando ip classless por abandono. Este comando es uno de los pocos comandos default del Cisco IOS Software que aparece en una configuración cuando es habilitado y también aparece en la ninguna forma cuando está inhabilitado. Publique el comando ip classless de habilitar el IP sin clase si su configuración incluye la línea ningún IP sin clase.

precaución Precaución: El Cisco CallManager controla todos los elementos de configuración plan-relacionados del dial. No configure estos elementos en el gateway MGCP para los puntos finales MGCP-manejados (ésos con el comando application mgcpapp en la declaración del dial peer). No configure ninguno de estos funciones:

  • Bajo los dial peer

    • destino-modelo

    • destino de la sesión

  • Bajo los puertos de voz

    • conexión {plar | línea de interconexión | trunk}

Resumen

El VG200 está listo ahora para comunicar con el Cisco Callmanager server. El VG200 envía periódicamente los mensajes en la tentativa de establecer una conexión. La conexión se establece automáticamente cuando la configuración del Cisco Callmanager server es completa. Usted no tiene que hacer para fomentar los cambios en el VG200.

Nota: Reajuste los puertos de gateway después de que usted complete la configuración, pues este ejemplo muestra:

router(config)#voice-port 1/0/0
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

Configuraciones

Esta tabla contiene la configuración completa del VG200A para este documento:

Configuración VG200A
VG200A#show running-config           
Building configuration...

Current configuration : 1244 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VG200A
!
boot system flash
boot system rom
boot system tftp vg200 172.16.1.253
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret #####
enable password #####
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
mgcp
mgcp call-agent 172.16.1.252
mgcp dtmf-relay codec all mode out-of-band
mgcp sdp simple
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
!
!
interface FastEthernet0/0
 ip address 172.16.1.206 255.255.0.0
 no ip mroute-cache
 speed auto
 full-duplex
!
ip default-gateway 172.16.1.1
ip classless
no ip http server
!
snmp-server engineID local 000000090200000196983000
snmp-server community public RO
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/0/1
!
dial-peer voice 3 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 4 pots
 application mgcpapp
 port 1/1/1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

VG200A#

Información de la versión VG200A
VG200A>show version
Cisco Internetwork Operating System Software
IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,  
RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by Cisco Systems, Inc.
Compiled Sat 11-Nov-00 10:33 by ccai
Image text-base: 0x80008088, data-base: 0x807D4784

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE 
SOFTWARE (fc1)

VG200A uptime is 19 hours, 37 minutes
System returned to ROM by reload
System image file is "flash:vg200"

cisco VG200 (MPC860) processor (revision 0x102) with 28672K/
4096K bytes of memory
y.
Processor board ID JAB0414058X (0)
M860 processor: part number 0, mask 49
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

VG200A>

Localización de averías del gateway MGCP IOS

Una falla de llamada de la manera, en la llamada de salida o las llamadas entrantes individualmente, puede ocurrir en un gateway MGCP IOS. Para resolver este problema, configure de nuevo el gateway MGCP. Generalmente, esto implica una reconfiguración de las interfaces PRI y/o de las interfaces FXO. Entonces, un reinicio del protocolo del mgcp en el gateway no publicando el ningún comando ios del mgcp y el comando mgcp en el modo de configuración global.

No puede hacer las llamadas de un teléfono analógico conectado con el gateway del IOS MGCP. Se recibe un tono de ocupado.

Realice este procedimiento para resolver este problema:

  1. Aseegure el comando application mgcpapp se configura en el puerto aplicable.

  2. Reordene al dial-peers del Servicio telefónico sencillo antiguo (POTS) para enumerar al dial-peers CallManager-generado Cisco primero en la lista del dial-peer. Asegúrese que el Control de llamadas interno y exterior eso sea dirigido por el dial-peer correcto bajo control MGCP.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 42105