IP : Túnel serial (STUN)

Protocolos asíncrono. el hacer un túnel en el ejemplo de configuración BSTUN

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Dedicado y los protocolos nativos asíncronos no se soportan directamente con ninguna implementación de Cisco. Sin embargo, el serial tunnel del bloque (BSTUN) tunelización genérica asíncrona puede proporcionar la capacidad limitada de hacer un túnel estos datos.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

Los Protocolos asíncrono. tales como TC500 de Diebold a comunicar al dinero ATMs o al hyperterminal del Tunelización de un PC a otro PC no tienen ningún soporte directo o implementación en el ½ del ¿Â del Cisco IOS ïÂ. Pues el nombre implica, ésta es una implementación genérica que tiene cierta capacidad para llevar este tipo de datos. Esto se conoce como async generic BSTUN, y requiere IBM o al conjunto de características IOS de la empresa.

El async generic BSTUN fue diseñado originalmente para llevar los paquetes unidireccionales, pequeños de los dispositivos de seguridad a un dispositivo de informe. El async generic BSTUN, sin embargo, puede llevar el tráfico interactivo. Esencialmente, los attaches de esta implementación al natural, los dispositivos asíncronos y reciben los datos en la interfaz serial y entonces en memoria intermedia. Periódicamente, los datos mitigados después se encapsulan en un paquete TCP y se envían al peerBSTUN donde están decapsulated y enviados al dispositivo asíncrono asociado en el sitio remoto.

El async generic BSTUN es una operación simplista. El router no tiene ninguna capacidad que se configurará para tener conocimiento del comienzo del bastidor (SOF), del extremo del bastidor (EOF), o del esquema de dirección del Protocolo asíncrono. Si la porción de dirección del bastidor es en cada trama, es un byte de largo, y es el mismo lugar en la trama, después el comando asp address-offset puede ser publicado para especificar al router donde encontrar el direccionamiento en la trama, según lo exampled más adelante en este documento. En muchas situaciones, sin embargo, no habrá una porción de dirección contenida en el protocolo. No tener ningún conocimiento de la construcción del Protocolo asíncrono. significa que el router no puede discernir los paquetes individuales de otros si no se separan por un período de tiempo. Requieren al ms aproximadamente 40 entre las tramas en los dígitos por segundo 9600 proporcionar al router cantidad de tiempo adecuada para discernir correctamente un paquete de otro. El router ve simplemente que una secuencia de datos en ella es interfaz serial y después que envuelve estos datos en el TCP. No hay posibilidad que el router puede toma las decisiones de ruteo basó sobre cualquier aspecto individual de la trama entrante. Así, el async generic BSTUN debe ser attaches físicamente diseñados de tan solamente un dispositivo a la interfaz del serial del router. No hay característica del reconocimiento local. El BSTUN soporta el Local-ack para el protocolo bisync IBM3270 solamente.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/41983/bstun_41983-A.gif

Ambos PC utilizan el hyperterminal de Microsoft o en lugar de uno de los PC podría estar una conexión en el puerto de la consola de un router Cisco. Estas configuraciones de muestra representan las configuraciones implementadas del Routers configurado no previamente en un escenario de laboratorio, y muestran las porciones pertinentes de la configuración necesaria. Éstos se configuran si se asume que 9600 bit/sec, la conexión 8N1.

Configuraciones

Este documento utiliza las configuraciones mostradas en esta sección.

  • Router principal (Cisco 1700 Router)

  • Router remoto (Cisco 3640 Router)

  • Router principal (Cisco 3600 Router)

  • Telecontrol #1 (Cisco 1700 Router)

  • Telecontrol #2 (Cisco 1700 Router)

Router principal (Cisco 1700 Router)
main#show running-config 
Building configuration...
.
.
.
ip subnet-zero
bstun peer-name 10.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 10.1.1.1 255.0.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
interface serial1
   ip address 20.1.1.1 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 1
   speed 9600
   databits 8
   parity none
   stopbits 1
.
.
.
!
end

Router remoto (Cisco 3640 Router)
REMOTE#show running-config 
Building configuration...
bstun peer-name 30.1.1.1.
bstun protocol-group 1 async-generic
interface loopback 0
   ip address 30.1.1.1
interface ethernet1/0
   shutdown
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
   
interface serial 2/1
   ip address 20.1.1.2 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 65
   speed 9600
   parity none
   databits 8
   stopbits 1
.
.
!
end

Nota: Cuando usted publica el comando physical-layer async en la interfaz serial, una línea TTY se asigna a la interfaz serial. Esta definición de línea TTY es donde se configuran los databits, los stopbits, la paridad, y la velocidad. Ésta es la fórmula para determinar qué línea corresponde con qué interfaz serial.

line#= (slot- x 32) + interface# + 1

La línea de la demostración en la salida de la configuración remota del router indica en la columna del extremo derecho el número de línea correspondiente. El Serial2/0 es representado por la línea 65 y las definiciones físicas para este link se configuran bajo línea 65

REMOTE#sh line 
   Tty Typ     Tx/Rx        A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
*    0 CTY                      -        -          -        -        -          0           0         0/0           - 
    65 TTY   9600/9600  -        -          -        -        -      0           0         0/0     Se2/0 
   129 AUX 9600/9600  -        -          -        -        -        0           0         0/0       - 
   130 VTY                     -        -          -        -        -          0           0         0/0       - 
   131 VTY                     -        -          -        -        -          0           0         0/0       - 
   132 VTY                     -        -          -        -        -          0           0         0/0       - 
   133 VTY                     -        -          -        -        -          0           0         0/0       - 
   134 VTY                     -        -          -        -        -          0           0         0/0       - 

Line(s) not in async mode -or- with no hardware support: 
1-64, 66-128 

En este escenario, un tándem comunica con los dispositivos ATM remotos. En esta configuración de muestra, el Protocolo asíncrono. funciona con un protocolo 4800 7E2 y el router principal conectado con el TÁNDEM es un 3600 Series Router a los 1700 Series Router remotos. Vea este diagrama de la red.

bstun_41983-B.gif

Router principal (Cisco 3600 Router)
main#show running-config 
Building configuration...
bstun peer-name 10.1.1.1.
bstun protocol-group 1 async-generic
bstun protocol-group 2 async-generic
interface loopback 0
   ip address 10.1.1.1
interface serial1/0
   encapsulation frame-relay
interface serial 1/0.1 point-to-point
   ip address 20.1.1.1 255.255.255.0
   frame-relay interface-dlci 100
interface serial 1/0.2 point-to-point
   ip address 20.2.1.1 255.255.255.0
   frame-relay interface-dlci 200
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
   
interface serial 2/1
 physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 2
   bstun route all tcp 30.2.1.1
   
ip route 30.2.1.0 255.255.0.0 20.2.1.2
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 65
   speed 4800
   parity even
   databits 7
   stopbits 1
.
line 66
   speed 4800
   parity even
   databits 7
   stopbits 1
.
!
end

Telecontrol #1 (Cisco 1700 Router)
REMOTE1#show running-config 
Building configuration...
bstun peer-name 30.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 30.1.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.1.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

Telecontrol #2 (Cisco 1700 Router)
REMOTE2#show running-config
Building configuration...
bstun peer-name 30.2.1.1
bstun protocol-group 2 async-generic
interface loopback0
   ip address 30.2.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 2
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.2.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.2.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

El BSTUN recibe un paquete en la interfaz serial, lo encapsula, y envía este paquete TCP al router remoto cuando publican el comando bstun route all tcp. El paquete TCP se recibe en el router remoto y es decapsulated. Los datos se envían en la interfaz serial. Si esta conexión no trabaja, los datos entrantes se deben primero verificar con el paquete ASP del debug. Usted ve los datos recibidos por el router en la interfaz serial. Puesto que el router no tiene ninguna construcción de protocolo y varía según el Protocolo asíncrono., el debug de la muestra no se proporciona. La secuencia de datos vista por el router debe hacer juego qué es enviada por el dispositivo. Si no hace juego, más que probablemente, la velocidad, los databits, la paridad, o los stopbits no se configuran para hacer juego el dispositivo. Éste puede ser el caso también si no se recibe ningunos datos.

Si los datos se reciben en la interfaz serial, publique el comando show bstun para mostrar si la conexión es abierta o cerrada. El estado abierto con solamente los paquetes transmitidos indica que el TCP está enviado al peerBSTUN remoto. En este momento, una prueba de ping de la dirección IP del par-nombre local BSTUN a la dirección IP del par-nombre del telecontrol BSTUN verifica si el IP es configurado y de trabajo correctamente. Si la prueba de ping es acertada, después en el telecontrol, publique el comando debug asp packet para determinar si el paquete se recibe y se envía sobre la interfaz serial al dispositivo asíncrono.

Complete estos pasos para resolver problemas.

  1. Verifique los datos se recibe en el router del host con el comando debug asp packet.

  2. Asegure la conectividad del IP con los ping de la compra de componentes de la prueba de ping de la dirección IP del par-nombre del bstun al IP Address remoto del par-nombre del telecontrol BSTUN.

  3. En el telecontrol, verifique que los paquetes estén enviados al dispositivo remoto con el comando debug asp packet.

  4. Si el Protocolo asíncrono. tiene un direccionamiento contenido en los paquetes enviados al router, puede ser beneficioso publicar el comando asp offset-address bajo interfaz con el número apropiado del byte correspondiente a donde el direccionamiento se contiene en el paquete. El valor predeterminado para esto es 0. por ejemplo, si el paquete es 01C1ABCDEF, donde está el direccionamiento el c1, la interfaz serial se puede configurar con el comando asp offset-address 01. En algunos casos, esto permite que el router identifique un paquete y aumenta la probabilidad que el router maneja los datos como paquete enmarcado y no apenas como secuencia de datos.


Información Relacionada


Document ID: 41983