IP : Multidifusión IP

Cómo implementar una política de filtrado para los puntos de encuentro

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (27 Abril 2015) | Comentarios


Contenido


Introducción

Este documento explica cómo implementar una política de filtrado para los puntos de encuentro (RP) en el agente mapping RP en un entorno multicast donde se aplica una Configuración de RP Dinámica (Auto-RP).

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Comprensión básica de la multidifusión independiente de protocolo (PIM)

Componentes Utilizados

Utilice este diagrama como referencia en este documento:

/image/gif/paws/41680/rp_announce_02.gif

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Auto-RP

Auto-RP está una forma dinámica de aprender la información RP para cada router en la red. Se alcanza esto cuando usted distribuye toda la información del grupo al RP vía el Multicast IP.

Todo el Routers habilitado para PIM se une a automáticamente el grupo de la detección de Cisco RP (224.0.1.40) que permite que reciban toda la información de mapeo del grupo al RP. Esta información es distribuida por una entidad llamada agente correlacionado RP. Los agentes correlacionados ellos mismos se unen a otro grupo — Cisco RP anuncia el grupo (224.0.1.39). Todo el candidato que los RP se hacen publicidad en los mensajes de multidifusión periódicos tuvo como objetivo el RP anuncia el grupo de dirección.

El agente correlacionado escucha todos los anuncios de candidato RP y construye una tabla con la información. Si varios RP se anuncian para un rango de grupos de multidifusión, el agente correlacionado elige solamente uno — el RP con la dirección IP más alta. Entonces hace publicidad del RP a todos los routeres PIM en la red usando un mensaje de detección RP. Los agentes correlacionados envían esta información cada 60 segundos (la configuración predeterminada).

Direccionamientos de filtración RP

Usted puede utilizar el comando ip pim rp-announce-filter rp-list access-list group-list access-list de filtrar a ciertos grupos de multidifusión RP con certeza.

El comando ip pim rp-announce-filter rp-list access-list group-list access-list tiene solamente significado si se configura en el agente correlacionado. La lista de acceso del rp list define una lista de acceso del candidato RP que, si está permitido, se valida para los rangos del Multicast especificados en el comando group-list access-list.

Nota: Utilice este comando con precaución. Los RP que son correspondidos con por el rp list (permitido por una declaración del permiso) tienen sus grupos de multidifusión filtrados por la lista de grupo. Los RP se niegan que (por un explícito o implícito niegan) no están conforme a la filtración de sus grupos de multidifusión y se validan “ciego” como candidato RP a todos sus grupos. Es decir solamente los RP que son permitidos por el rp list tienen sus grupos de multidifusión filtrados por la lista de grupo. El resto de los RP se validan sin el examen.

Un RP adicional anuncia que el filtro es necesario filtrar con eficacia los RP que se validan sin el examen. La sección Ejemplo de filtración aclara este procedimiento.

Ejemplo de filtración

En el diagrama en la sección usada los componentes, el r2 y el R4 se anuncian como candidato RP a estos grupos (que hagan publicidad de esta información vía los mensajes de detección RP):

  • 224.1.0.1

  • 224.1.0.2

  • 224.1.0.3

El R3 se configura como agente correlacionado y recopila esta información, construye su tabla, y envía solamente un direccionamiento RP al R6, que es solamente un router habilitado para PIM. El Intermediate System-to-Intermediate System (IS-IS) se utiliza en este ejemplo como el Unicast Routing Protocol, pero cualquier otro protocolo trabajaría también. Modo PIM sparseDense es necesario recibir la información del Multicast para los grupos 224.0.1.39 y 224.0.1.40 sin tener un RP configurado para esos grupos. Es decir el modo sparseDense trabaja como el modo denso si no hay RP sabido. Cuando se sabe un RP, utilizan al modo sparseDense para los grupos para quienes el RP se hace publicidad.

Configuración del r2

hostname R2

ip multicast-routing

interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.2.0.2 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0002.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupB
!         
!         
ip access-list standard groupB
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Configuración R4

hostname R4

ip multicast-routing

interface Loopback0
 ip address 50.0.0.4 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.3.0.4 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0004.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupA
!         
!         
ip access-list standard groupA
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Configuración R3

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0003.00

Configuración R6

hostname R6

ip multicast-routing

interface Loopback0
 ip address 50.0.0.6 255.255.255.255
 ip router isis
 
interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.6 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0006.00

Si usted quiere filtrar el R4 pues un RP posible para ningunos de esos grupos y tiene solamente r2 como RP de trabajo, configure un RP anuncian el filtro en el R3:

ip pim rp-announce-filter rp-list filtering-RP group-list filtering-group
!         
!         
ip access-list standard filtering-RP
 permit 50.0.0.2
 deny    50.0.0.4


!--- ACL "filtering-RP" specifically allows R2 and explicitly denies R4.


ip access-list standard filtering-group
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Entonces, borrar las asociaciones actuales del grupo al RP, publique el comando clear ip pim rp-mapping en el R3 y el R6.

Sin embargo, si usted ve el R6, usted puede ver que la información no es lo que usted espera:

R6#show ip pim rp mapping 
PIM Group-to-RP Mappings

Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55

Si usted ve el R3, usted puede ver que no se está realizando ninguna filtración realmente:

R3# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP-mapping agent

!--- This line confirms that R3 is configured as the mapping agent.


Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- No filtering has taken effect.

    Info source: 50.0.0.4 (?), elected via Auto-RP

!--- R4 is elected because it has a higher IP address.

         Uptime: 00:09:06, expires: 00:02:53
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:28

El direccionamiento del R4 se niega específicamente, y no está conforme a ninguna filtración de sus grupos de multidifusión — es validado “ciego” por el agente correlacionado. El agente correlacionado selecciona un RP basado en la dirección IP más alta (en este ejemplo, 50.0.0.4) y entonces adelante esta información al R6.

Configure otro RP anuncian el filtro que permite el R4 y niega a todos sus grupos para filtrar con eficacia el direccionamiento R4:

ip pim rp-announce-filter rp-list filtering-R4 group-list filtering-groupR4

ip access-list standard filtering-R4
 permit 50.0.0.4
ip access-list standard filtering-groupR4
 deny   any

Si usted ve el R3 y habilita el comando debug ip pim auto-rp tan pronto como usted reciba un RP anuncia el mensaje del R4, usted puede ver estos mensajes:

R3#
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4

Entonces, cuando usted ve la tabla del grupo al RP, usted puede ver solamente el r2:

R3#show ip pim rp mapping 
PIM Group-to-RP Mappings
This system is an RP-mapping agent

Group(s) 224.1.0.1/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:52
Group(s) 224.1.0.2/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:54
Group(s) 224.1.0.3/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:55

Finalmente, si usted quiere tener r2 como el RP para 224.1.0.1, y R4 como el RP para 224.1.0.2 y 224.1.0.3, usted tiene esta configuración en el R3:

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

router isis
 net 49.0002.0000.0000.0003.00

ip pim rp-announce-filter rp-list filtering-RP2 group-list filtering-group2
ip pim rp-announce-filter rp-list filtering-RP4 group-list filtering-group4
!        
!        
ip access-list standard filtering-RP2
 permit 50.0.0.2

ip access-list standard filtering-RP4
 permit 50.0.0.4

ip access-list standard filtering-group2
 permit 224.1.0.1

ip access-list standard filtering-group4
 permit 224.1.0.2
 permit 224.1.0.3

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 41680