Switching de LAN : Routing entre VLAN

Configuración del Ruteo InterVLAN con Catalyst 3750/3560/3550 Series Switches

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (1 Mayo 2008) | Inglés (6 Octubre 2015) | Comentarios


Contenido


Introducción

En este documento, se explica cómo configurar el ruteo InterVLAN con los Cisco Catalyst 3750/3560/3550 Series Switches. En el documento, se proporciona un ejemplo de configuración del ruteo InterVLAN con un Catalyst 3550 Series Switch que ejecuta software de imagen multicapa mejorada (EMI) en una situación de red típica. En el documento, se utiliza un Catalyst 2950 Series Switch y un Catalyst 2948G Switch como switches de bastidor de capa 2 (L2) que conectan al Catalyst 3550. La configuración del Catalyst 3550 también tiene una ruta predeterminada para todo el tráfico que va a Internet cuando el salto siguiente apunta a un Cisco 7200VXR Router. Usted puede sustituir un firewall u otros routers para el Cisco 7200VXR Router.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Catalyst 3550-48 que funciona con el Software Release 12.1(12c)EA1 EMI de Cisco IOS�

  • Catalyst 2950G-48 que ejecuta el Cisco IOS Software, versión 12.1(12c)EA1 EI

  • Catalyst 2948G que ejecuta el Catalyst OS (CatOS), versión 6.3(10)

Nota: La configuración del Cisco 7200VXR no es relevante; por lo tanto, no se muestra la configuración en este documento.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

Esta configuración también se puede utilizar con las siguientes versiones de hardware y software:

  • Cualquier Catalyst 3750/3560/3550 Switch que ejecute software de EMI o el Cisco IOS Software de imagen de multicapa estándar (SMI), versión 12.1(11)EA1 y posteriores

  • Cualquier modelo de switch de CatOS o Catalyst 2900XL/3500XL/2950/3550, utilizado como el switch de capa de acceso

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Teoría Precedente

En una red conmutada, las VLAN separan a los dispositivos en diferentes dominios de colisión y subredes de Capa 3 (L3). Los dispositivos dentro de una VLAN pueden comunicarse entre sí sin la necesidad de ruteo. Los dispositivos en VLAN separadas requieren un dispositivo de ruteo para comunicarse entre sí.

Los switches de solo L2 requieren un dispositivo de ruteo L3. El dispositivo es externo al switch o se encuentra en otro módulo en el mismo chasis. Una nueva generación de switches incorpora la capacidad de ruteo dentro del switch. Un ejemplo es el 3550. El switch recibe un paquete, determina que el paquete pertenece a otra VLAN y envía el paquete al puerto apropiado en la otra VLAN.

Un diseño de red típico divide la red en segmentos según el grupo o la función a la que pertenece el dispositivo. Por ejemplo, las VLAN de ingeniería solo tienen dispositivos que se relacionan con el departamento de ingeniería y las VLAN de finanzas solo tienen dispositivos que se relacionan con las finanzas. Si usted habilita el ruteo, los dispositivos en cada VLAN pueden comunicarse entre sí sin la necesidad de que todos los dispositivos estén en el mismo dominio de broadcast. Dicho diseño de VLAN también tiene un beneficio adicional. El diseño permite que el administrador restrinja la comunicación entre las VLAN con el uso de listas de acceso. En el ejemplo en este documento, puede utilizar las listas de acceso para restringir el acceso de la VLAN de ingeniería a dispositivos en la VLAN de finanzas.

El switch no rutea paquetes que no son IP entre las VLAN y los puertos ruteados. Usted puede reenviar estos paquetes que no son IP con el bridging de retroceso. Para utilizar esta función, debe tener la imagen de servicios IP, conocida anteriormente como la imagen de multicapa mejorada (EMI), instalada en su switch.

Aquí está un link a un vídeo (disponible en la comunidad del soporte de Ciscoleavingcisco.com ) que demuestre cómo configurar el InterVLAN Routing en un Catalyst 3550 Series Switch:

Cómo configurar el ruteo entre VLAN en los switches de Capa 3. leavingcisco.com

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

189-a.gif

En este diagrama, una pequeña red de ejemplo con el Catalyst 3550 proporciona el ruteo InterVLAN entre los diversos segmentos. De forma predeterminada, el Catalyst 3550 Switch actúa como dispositivo L2 con la incapacidad del ruteo IP. Para hacer que el switch funcione como dispositivo L3 y proporcionar el ruteo InterVLAN, debe habilitar el ruteo IP de forma global.

Estas VLAN son las tres VLAN que define el usuario:

  • VLAN 2 – VLAN de usuario

  • VLAN 3 - VLAN servidor

  • VLAN 10 - VLAN de administración

La configuración del gateway predeterminado en cada dispositivo host y servidor debe ser la dirección IP de interfaz de VLAN que corresponda en el 3550. Por ejemplo, en el caso de los servidores, el gateway predeterminado es 10.1.3.1. Los switches de capa de acceso, que son los Catalyst 2950 y 2948G, son trunked al Catalyst 3550 Switch.

La ruta predeterminada para el Catalyst 3550 apunta al Cisco 7200VXR Router. El Catalyst 3550 utiliza esta ruta predeterminada para rutear el tráfico destinado a Internet. Por lo tanto, el tráfico para el que el 3550 no tiene una entrada en la tabla de ruteo se reenvía al 7200VXR para su proceso.

Consejos Prácticos

  • Asegúrese de que la VLAN nativa para un trunk 802.1Q sea la misma en ambos extremos del link trunk. Si la VLAN nativa en un extremo del trunk es diferente a la VLAN nativa del otro extremo, el tráfico de las VLAN nativas en ambos lados no se podrá transmitir correctamente en el trunk. Esta falla de transmisión correcta puede implicar algunos problemas de conectividad en su red.

  • Separe la VLAN de administración de la VLAN de usuario o de servidor, como se muestra en este diagrama. La VLAN de administración es diferente a la VLAN de usuario o de servidor. Con esta separación, cualquier interrupción de los paquetes/de broadcast que ocurra en la VLAN de usuario o de servidor no afectará a la administración de los switches.

  • No utilice la VLAN 1 para la administración. Todos los puertos en los switches Catalyst se configuran de forma predeterminada a la VLAN 1, y todos los dispositivos que conectan a puertos no configurados se encuentran en la VLAN 1. El uso de la VLAN 1 para la administración puede causar posibles problemas con la administración de los switches, como se explica en el segundo consejo.

  • Utilice un puerto (ruteado) de capa 3 para conectar al puerto de gateway predeterminado. En este ejemplo, puede sustituir fácilmente un Cisco 7200VXR Router por un firewall que conecte al router de gateway de Internet.

  • No ejecute un protocolo de ruteo entre el Catalyst 3550 y el router de gateway de Internet. Este ejemplo, en su lugar, configura una ruta predeterminada estática en el 3550. Esta configuración es la mejor opción si hay solamente una ruta a Internet. Asegúrese de configurar rutas estáticas, resumidas preferentemente, en el router de gateway (7200VXR) para las subredes que puedan ser alcanzadas por el Catalyst 3550. Este paso es muy importante porque esta configuración no utiliza protocolos de ruteo.

  • Si usted tiene dos Catalyst 3550 Switches en su red, puede realizar una conexión doble de los switches de capa de acceso a ambos 3550. Ejecute Hot Standby Router Protocol (HSRP) entre los switches para proporcionar redundancia en la red. Para obtener más información sobre la configuración de HSRP, consulte la sección Configuración de HSRP de Configuración de Servicios IP.

  • Si necesita ancho de banda adicional para los puertos de enlace ascendente, puede configurar EtherChannel. EtherChannel también proporciona la redundancia de link en el caso de una falla de link.

Configuraciones

En este documento, se utilizan estas configuraciones:

Catalyst 3550 (Catalyst 3550-48 Switch)
Cat3550#show running-config 
Building configuration...

Current configuration : 3092 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
!
ip subnet-zero

!--- Enable IP routing for interVLAN routing.

ip routing
!!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

!
interface FastEthernet0/5
 description to SERVER_1

!--- Configure the server port to be in the server VLAN, VLAN 3.

switchport access vlan 3

!--- Configure the port to be an access port to prevent trunk negotiation delays.

 switchport mode access
 no ip address

!--- Configure PortFast for initial Spanning Tree Protocol (STP) delay. Refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information.

spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/48
 description To Internet_Router

!--- The port that connects to the router converts into a routed (L3) port.

no switchport

!--- Configure the IP address on this port. 

ip address 200.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
 description To 2950

!--- Configure IEEE 802.1 (dot1q) trunking, with negotiation, on the L2 switch.
!--- If there is not support for Dynamic Trunking Protocol (DTP) on the far switch, 
!--- issue the switchport mode trunk command to force the switch port to trunk mode.
!--- Note: The default trunking mode is dynamic auto. If you establish a trunk link 
!--- with the default trunking mode, the trunk does not appear
!--- in the configuration, even though a trunk has been established on 
!--- the interface. Use the show interfaces trunk command to verify the 
!--- establishment of the trunk. 

switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 description To 2948G
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description USER_VLAN

!--- This IP address is the default gateway for users.

 ip address 10.1.2.1 255.255.255.0
!
interface Vlan3
 description SERVER_VLAN

!--- This IP address is the default gateway for servers.

ip address 10.1.3.1 255.255.255.0
!
interface Vlan10
 description MANAGEMENT_VLAN

!--- This IP address is the default gateway for other L2 switches.

 ip address 10.1.10.1 255.255.255.0
!
ip classless

!--- This route statement allows the 3550 to send Internet traffic to 
!--- the default router which, in this case, is the 7200VXR (Fe 0/0 interface).

ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Nota: Dado que el 3550 tiene una configuración como servidor de VLAN Trunk Protocol (VTP), el switch no muestra la configuración VTP. Este comportamiento es estándar. Este switch utiliza estos comandos para crear un servidor de VTP con las tres VLAN que el usuario definió del modo de configuración global:

Cat3550(config)#vtp domain cisco
Cat3550(config)#vtp mode server
Cat3550(config)#vlan 2
Cat3550(config-vlan)#name USER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 3
Cat3550(config-vlan)#name SERVER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 10
Cat3550(config-vlan)#name MANAGEMENT
Catalyst 2950 (Catalyst 2950G-48 Switch)
Cat2950#show running-config 
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/33
 description HOST_1

!--- Configure HOST_1 to be the user VLAN, VLAN 2.

 
 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

!--- This IP address manages this switch. 

ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

!--- Configure the default gateway so that the switch is reachable from other
!--- VLANs/subnets. The gateway points to the VLAN 10 interface on the 3550.

ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Nota: Dado que el Catalyst 2950 tiene una configuración como cliente de VTP, el switch no muestra la configuración VTP. Este comportamiento es estándar. El 2950 adquiere la información de VLAN del servidor de VTP, que es el 3550. El 2950 utiliza estos comandos para convertir el switch en un cliente de VTP en el dominio de VTP de Cisco del modo de configuración global:

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client
Catalyst 2948G Switch
Cat2948G> (enable) show config 
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47 
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!       
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- Configure the VTP domain to be the same as the 3550, the VTP server.

set vtp domain cisco

!--- Choose the VTP mode as client for this switch.

set vtp mode client
!
#ip

!--- Configure the management IP address in VLAN 10.

set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

!--- Define the default route so that the switch is reachable.

set ip route 0.0.0.0/0.0.0.0         10.1.10.1      
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

!--- Configure HOST_2 and SERVER_3 ports in respective VLANs.

set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3

!--- Configure trunk to 3550 with dot1q encapsulation.

set trunk 2/49 desirable dot1q 1-1005
end

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración funcione correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Catalyst 3550

  • show vtp status

    Cat3550#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Server
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
  • show interfaces trunk

    Cat3550#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    Gi0/2     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    Gi0/2     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
  • show ip route

    Cat3550#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, FastEthernet0/48
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
    

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    
  • show interfaces trunk

    Cat2950#show interfaces trunk  
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
    

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain 
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk 
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    

Troubleshooting

Use esta sección para resolver problemas de configuración.

Procedimiento de Troubleshooting

Siga estas instrucciones:

  1. Si usted no puede hacer ping con los dispositivos dentro de la misma VLAN, verifique la asignación de VLAN de los puertos de origen y de destino para asegurarse de que el origen y el destino estén en la misma VLAN.

    Para verificar la asignación de VLAN, ejecute el comando show port mod/port para el CatOS o el comando show interface status para el Cisco IOS Software.

    Si el origen y el destino no están en el mismo switch, asegúrese de que el trunking esté configurado correctamente. Para verificar la configuración, ejecute el comando show trunk para el CatOS o el comando show interfaces trunk para el Cisco IOS Software. Además, verifique que la VLAN nativa coincida en ambos lados. Asegúrese de que la máscara de subred coincida entre los dispositivos de origen y de destino.

  2. Si usted no puede hacer ping con los dispositivos en diferentes VLAN, asegúrese de poder hacer ping con el respectivo gateway predeterminado.

    Nota: Consulte el paso 1.

    También, asegúrese de que el gateway predeterminado del dispositivo apunte a la dirección IP de interfaz de VLAN correcta. Asegúrese de que la máscara de subred coincida.

  3. Si usted no puede conectarse a Internet, asegúrese de que la ruta predeterminada en el 3550 apunte a la dirección IP correcta y que la dirección de subred coincida con el router de gateway de Internet.

    Para verificar esto, ejecute el comando show ip interface interface-id y el comando show ip route. Asegúrese de que el router de gateway de Internet tenga rutas a Internet y a las redes internas.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 41260