Switching por etiquetas multiprotocolo (MPLS) : MPLS

MPLS/VPN con el EIGRP en el ejemplo de configuración del lado del cliente

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra de Red Privada Virtual (VPN) Multiprotocol Label Switching (MPLS) cuando está presente EIGRP (Enhanced Interior Gateway Routing Protocol) en el lado del cliente.

Este documento le proporciona un ejemplo de configuración de EIGRP del lado del cliente en un entorno MPLS/VPN. Estos escenarios son detallados:

  • Dos puntos finales de conexión (CE) que pertenecen a los mismos sistemas autónomos EIGRP.

  • Dos CE que pertenecen a diversos sistemas autónomos EIGRP.

Para ambos escenarios, le presentan con la configuración y los pasos de verificación. Una muestra de intercambio de ruteo para los protocolos implicó — Border Gateway Protocol (BGP) y EIGRP — también se proporciona.

Cuando está utilizada con el MPLS, la característica VPN permite que varios sitios interconecten transparente a través de una red del proveedor de servicios. Una red proveedora de servicios puede ofrecer soporte a varias VPN IP diferentes Cada uno de éstos aparece a sus usuarios como red privada, a parte de las cualesquier otras redes. Dentro de una VPN, cada sitio puede enviar paquetes IP a cualquier otro sitio dentro de la misma VPN

Cada VPN está asociada con uno o más casos de reenvío o ruteo VPN (VRF). Un VRF consiste de una tabla de IP Routing, una tabla Cisco Express Forwarding (CEF) derivada y un conjunto de interfaces que usen estas tablas de reenvío.

El router mantiene un ruteo separado y una tabla CEF para cada VRF. Esto impide que la información se envíe fuera de la VPN y permite que pueda usarse la misma subred en varias VPN sin causar problemas de dirección IP duplicada

El router que utiliza el Multiprotocol BGP (MP-BGP) distribuye la información de VPN Routing usando las comunidades ampliadas MP-BGP.

Refiera a estos documentos para más información sobre la difusión de actualizaciones con un VPN:

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

El EIGRP entre el PE y el CE en la característica del entorno MPLS/VPN fue introducido en los Software Release 12.0(22)S y 12.2(15)T del ½ del ¿Â de Cisco IOSïÂ.

Productos Relacionados

Esta configuración se puede también utilizar con este serie de router:

  • Cisco 7200

  • Cisco 7500

  • Cisco 10000

  • Cisco 10700

  • Cisco 12000

  • Performance Route Processor de las Cisco 12000 Series (PRP)

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

Las rutas EIGRP son convertidas a las rutas BGP en la estructura báscia de la prestación de servicio por los nuevos atributos Eigrp-específicos de la comunidad ampliada. El router del borde del proveedor (PE) utiliza el BGP para distribuir la información de VPN Routing usando los atributos Eigrp-específicos de la comunidad ampliada, que se añaden al final del fichero a la ruta BGP. Cuando alcanzan el router PE que está conectado al router de borde del cliente (CE) de destino, las rutas BGP vuelven a convertirse en rutas EIGRP por los atributos de comunidad ampliados específicos de EIGRP.

Esta tabla describe los atributos de la comunidad ampliada que se añaden al final del fichero a las rutas BGP y se utilizan para llevar la información EIGRP a través de la estructura báscia de la prestación de servicio.

Atributo del EIGRP Tipo Uso Valor
General 0x8800 Información de ruta del EIGRP general Etiqueta e indicador de ruta
Métrico 0x8801 Información de medidas y sistema autónomo de la ruta EIGRP Sistema autónomo y retardo
0x8802 Información de medidas de la ruta EIGRP Confiabilidad, salto siguiente y ancho de banda
0x8803 Información de medidas de la ruta EIGRP Reserva, carga y unidad de transmisión máxima (MTU)
Externo 0x8804 Información del EIGRP External Route Sistema autónomo remoto e ID remota
0x8805 Información del EIGRP External Route Protocolo remoto y métrica remota

Escenario 1: Configure un solo sistema autónomo EIGRP

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

Esta sección utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/40883-mplsvpneigrp1.gif

Configuraciones

Esta sección usa estas configuraciones:

PE-1
PE-1#show run
Building configuration...
ip cef

!--- vpn1 commands.

ip vrf vpn1

!--- Enables the VPN routing and forwarding (VRF) routing table.


!--- This command can be used in global or
 

!--- router configuration mode.
  
rd 100:1

!--- Route distinguisher creates routing and forwarding
 

!--- tables for a VRF.

route-target export 100:1

!--- Creates lists of import and export route-target extended
 

!--- communities for the specified VRF.
 
route-target import 100:1
!
interface Loopback0
 ip address 7.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip vrf forwarding vpn1

!--- Associates a VRF instance with an interface or subinterface.
 
ip address 9.0.1.1 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family ipv4 vrf vpn1

!--- To enter address family configuration mode
 

!--- for configuring EIGRP routing sessions,
 

!--- that use standard VPN version 4 address prefixes.
 
redistribute bgp 1

!--- Enables redistribution of bgp into this specific instance of EIGRP.
  
 network 9.0.0.0 
 default-metric 10000 1 255 1 1500 
 no auto-summary
 autonomous-system 10

!--- Defines the autonomous system number for this specific instance of EIGRP.
  
 exit-address-family
 !
router bgp 1
 no bgp default 
 ipv4-unicast bgp 
 log-neighbor-changes 
 neighbor 7.0.0.4 remote-as 1

!--- Adds an entry to the BGP or multiprotocol BGP neighbor table.

 neighbor 7.0.0.4 update-source Loopback0

!--- Enables BGP sessions to use a specific operational
 

!--- interface for TCP connections.

!
 address-family vpnv4

!--- To enter address family configuration mode
 

!--- for configuring routing sessions, such as BGP,
 

!--- that use standard VPN version 4 address prefixes.

 neighbor 7.0.0.4 activate
 neighbor 7.0.0.4 send-community both

!--- Sends the community attribute to a BGP neighbor.
 
 no auto-summary 
 exit-address-family
!
 address-family ipv4 
 neighbor 7.0.0.4 activate
 exit-address-family
!
 address-family ipv4 vrf vpn1
 redistribute eigrp 10

!--- Enables redistribution of EIGRP AS 10 into BGP.

 no auto-summary
 no synchronization
 exit-address-family
!
end

PE-4
PE-4#show running-config
Building configuration...
Current configuration : 2439 bytes
!
ip cef
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
!         
interface Loopback0
 ip address 7.0.0.4 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 6.0.2.3 255.255.255.0
 no ip directed-broadcast
 tag-switching ip
!
!
interface Serial2/0
 ip vrf forwarding vpn1
 ip address 10.1.2.1 255.255.255.252
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family ipv4 vrf vpn1
 redistribute bgp 1
 network 10.0.0.0
 default-metric 10000 1 255 1 1500
 no auto-summary
 autonomous-system 10
 exit-address-family
!
 router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.0.0.1 remote-as 1
 neighbor 7.0.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 7.0.0.1 activate
 neighbor 7.0.0.1 send-community extended
 no auto-summary
 exit-address-family
 !
 address-family ipv4
 redistribute connected
 neighbor 7.0.0.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute eigrp 10
 no auto-summary
 no synchronization
 network 13.0.0.1 mask 255.255.255.255
 exit-address-family
!
end

Verificación

Para verificar su configuración, utilice un acercamiento gradual y verifique estas puntas en la orden. Complete estos pasos:

  1. Verifique que el caso del EIGRP esté configurado en la interfaz deseada — verifique el comando vrf y el comando de la red EIGRP bajo la direccionamiento-familia correcta.

    En este ejemplo, el VRF se llama vpn1.

    PE-1#show ip vrf vpn1
       Name                             Default RD          Interfaces
       vpn1                             100:1               Ethernet0/0
                                                           
    PE-1#show ip eigrp vrf vpn1 interfaces
     IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
    Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
    Et0/0            1         0/0    103          0/10         416          0
    PE-1#
  2. Verifique que la vecindad EIGRP esté establecida.

    En este ejemplo, usted puede ver que 9.0.1.2 (CE-1) es un vecino.

    PE-1#show ip eigrp vrf vpn1 neighbors
     IP-EIGRP neighbors for process 10
    H   Address            Interface      Hold Uptime   SRTT   RTO  Q  Seq Type
                                          (sec)         (ms)       Cnt Num
    0   9.0.1.2            Et0/0            13 00:30:19  103   618  0  9
       PE-1#
  3. Verifique que la tabla de topología EIGRP contenga las subredes locales aprendidas mediante EIGRP (9.0.0.2/32).

    En este ejemplo, usted puede ver que la tabla de topología EIGRP también contiene las subredes aprendidas a través de la estructura básica MPLS/VPN (10.1.2.0/30).

    Las subredes se muestran como docto vía redistribuido y tienen a distancia informada de 0.

    PE-1#show ip eigrp vrf vpn1 topology
     IP-EIGRP Topology Table for AS(10)/ID(9.0.0.1) Routing Table: vpn1
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
           r - Reply status
    P 10.1.3.0/24, 1 successors, FD is 2195456
             via Redistributed (2195456/0)
    P 9.0.1.0/24, 1 successors, FD is 281600
             via Connected, Ethernet0/0
    P 9.0.0.1/32, 1 successors, FD is 128256
             via Connected, Loopback1
    P 10.1.2.0/30, 1 successors, FD is 2169856
             via Redistributed (2169856/0)
    P 9.1.0.2/32, 1 successors, FD is 45867776
             via 9.0.1.2 (45867776/45842176), Ethernet0/0
    P 9.0.0.2/32, 1 successors, FD is 409600
             via 9.0.1.2 (409600/128256), Ethernet0/0
    P 10.0.0.6/32, 1 successors, FD is 2297856
             via Redistributed (2297856/0)
    P 13.0.0.1/32, 1 successors, FD is 256256
             via Redistributed (256256/0)
    PE-1#
  4. Si las subredes faltan, verifique que estén en la tabla BGP con estos comandos show para un VRF específico.

    Si la redistribución entre el BGP y el EIRGP no se configura correctamente, usted puede ser que vea la subred en una tabla y no en la otra.

    PE-1#show ip bgp vpnv4 vrf vpn1
    BGP table version is 45, local router ID is 7.0.0.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 100:1 (default for vrf vpn1)
    *> 9.0.0.1/32       0.0.0.0                  0         32768 ?
    *> 9.0.0.2/32       9.0.1.2             409600         32768 ?
    *> 9.0.1.0/24       0.0.0.0                  0         32768 ?
    *> 9.1.0.2/32       9.0.1.2           45867776         32768 ?
    *>i10.0.0.6/32      7.0.0.4            2297856    100      0 ?
    *>i10.1.2.0/30      7.0.0.4                  0    100      0 ?
    *>i10.1.3.0/24      7.0.0.4            2195456    100      0 ?
    *>i13.0.0.1/32      7.0.0.4                  0    100      0 i
    PE-1#
    
    PE-1#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
    BGP routing table entry for 100:1:9.0.0.1/32, version 12
    Paths: (1 available, best #1, table vpn1)
      Advertised to update-groups:
         1
               Local
        0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.1)
          Origin incomplete, metric 0, localpref 100, weight 32768, 
    valid, sourced, best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
     0x8802:65280:256 0x8803:65281:1514
    PE-1#
    
    PE-1# show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
    BGP routing table entry for 100:1:10.1.2.0/30, version 40
    Paths: (1 available, best #1, table vpn1)
      Not advertised to any peer
      Local
        7.0.0.4 (metric 139) from 7.0.0.4 (7.0.0.4)
          Origin incomplete, metric 0, localpref 100, valid, internal,
     best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:512000
     0x8802:65280:1657856 0x8803:65281:1500
    

    Los mismos comandos show deben ser utilizados encendido el telecontrol PE.

    En este ejemplo, el telecontrol PE es PE-4:

    PE-4#show ip eigrp vrf vpn1 interfaces
     IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
    Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
    Se1/0             0        0/0         0       0/10           0           0
    Se2/0             1        0/0       100       0/15         415           0
    
    PE-4#show ip eigrp vrf vpn1 neighbors
     IP-EIGRP neighbors for process 10
    H   Address            Interface      Hold Uptime   SRTT   RTO  Q  Seq Type
                                          (sec)         (ms)       Cnt Num
    0   10.1.2.2           Se2/0            10 00:18:57  100   600  0  2   
    
    PE-4#show ip eigrp vrf vpn1 topology
     IP-EIGRP Topology Table for AS(10)/ID(13.0.0.1) Routing Table: vpn1
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
           r - Reply status
    P 10.1.3.0/24, 1 successors, FD is 2195456
             via 10.1.2.2 (2195456/281600), Serial2/0
    P 9.0.0.1/32, 1 successors, FD is 128256
             via Redistributed (128256/0)
    P 9.0.1.0/24, 1 successors, FD is 281600
             via Redistributed (281600/0)
    P 10.1.2.0/30, 1 successors, FD is 2169856
             via Connected, Serial2/0
    P 9.1.0.2/32, 1 successors, FD is 45867776
             via Redistributed (45867776/0)
    P 9.0.0.2/32, 1 successors, FD is 409600
             via Redistributed (409600/0)
    P 10.0.0.6/32, 1 successors, FD is 2297856
             via 10.1.2.2 (2297856/128256), Serial2/0
    P 13.0.0.1/32, 1 successors, FD is 256256
             via Redistributed (256256/0)
    
    PE-4#show ip bgp vpnv4 vrf vpn1
     BGP table version is 61, local router ID is 7.0.0.4
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 100:1 (default for vrf vpn1)
    *>i9.0.0.1/32       7.0.0.1                  0    100      0 ?
    *>i9.0.0.2/32       7.0.0.1             409600    100      0 ?
    *>i9.0.1.0/24       7.0.0.1                  0    100      0 ?
    *>i9.1.0.2/32       7.0.0.1           45867776    100      0 ?
    *> 10.0.0.6/32      10.1.2.2           2297856         32768 ?
    *> 10.1.2.0/30      0.0.0.0                  0         32768 ?
    *> 10.1.3.0/24      10.1.2.2           2195456         32768 ?
    *> 13.0.0.1/32      0.0.0.0                  0         32768 i
    
    PE-4#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
    BGP routing table entry for 100:1:9.0.0.1/32, version 45
    Paths: (1 available, best #1, table vpn1)
      Not advertised to any peer
      Local
        7.0.0.1 (metric 139) from 7.0.0.1 (7.0.0.1)
          Origin incomplete, metric 0, localpref 100, valid, internal,
     best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
     0x8802:65280:
    256 0x8803:65281:1514
    
    PE-4#show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
    BGP routing table entry for 100:1:10.1.2.0/30, version 56
    Paths: (1 available, best #1, table vpn1)
      Advertised to update-groups:
         1
               Local
        0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.4)
          Origin incomplete, metric 0, localpref 100, weight 32768, 
    valid, sourced,
     best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:512000
     0x8802:65280:
    1657856 0x8803:65281:1500
    
    PE-4#
    CE-1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
    Gateway of last resort is not set
         9.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C       9.0.1.0/24 is directly connected, Ethernet0/0
    D       9.0.0.1/32 [90/409600] via 9.0.1.1, 1d02h, Ethernet0/0
    C       9.1.0.2/32 is directly connected, Loopback1
    C       9.0.0.2/32 is directly connected, Loopback0
         10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
    D       10.1.3.0/24 [90/2221056] via 9.0.1.1, 1d02h, Ethernet0/0
    D       10.1.2.0/30 [90/2195456] via 9.0.1.1, 1d02h, Ethernet0/0
    D       10.0.0.6/32 [90/2323456] via 9.0.1.1, 1d02h, Ethernet0/0
         13.0.0.0/32 is subnetted, 1 subnets
    D EX    13.0.0.1 [170/281856] via 9.0.1.1, 1d02h, Ethernet0/0

Resolución de problemas

En esta sección, información sobre la interrogación del eigrp recibida por el PE y la actualización de BGP correspondiente enviada a través de la nube MPLS/VPN se proporciona. Esto se hace para la subred 10.0.0.6/32 conectada directamente con el router CE-4 en la mano derecha del diagrama. “Cierre” y “ningún cerrado” se realizó en el Loopback Interface en CE-4 así como el comando debug apropiado ayuda usted para entender los tiggers.

Actualizar propagación en un sistema autónomo simple.

Utilizan a estos comandos debug de seguir actualizaciones de la subred 10.0.0.6/32 (Loopback Address de CE-4):

  • debug eigrp fsm

  • petición de la contestación de la interrogación de los paquetes EIGRP del debug actualización

  • debug ip eigrp 10 10.0.0.6 255.255.255.255

  • BGP vpnv4 del IP del debug

  • debug ip bgp update

Este ejemplo muestra una entrada EIGRP retirada después de a realizan al comando shut en la interfaz del loopback0 en CE-4:

PE-4
*Apr 30 08:36:59.913: DUAL: dual_rcvquery():10.0.0.6/32 via 10.1.2.2 
metric 4294967295/4294967295, RD is 2297856
*Apr 30 08:36:59.913: DUAL: Find FS for dest 10.0.0.6/32. FD is 2297856, 
RD is 2297856
*Apr 30 08:36:59.913: DUAL:     10.1.2.2 metric 4294967295/4294967295 not
 found Dmin is 4294967295
*Apr 30 08:36:59.913: DUAL: Dest 10.0.0.6/32 (Split Horizon) not entering
 active state.
*Apr 30 08:36:59.913: DUAL: Send reply about 10.0.0.6/32 to 10.1.2.2
*Apr 30 08:36:59.965: vpn: bgp_router, vpn ipv4 redistQ len = 1
*Apr 30 08:36:59.965: BGP(2): route 100:1:10.0.0.6/32 down
*Apr 30 08:36:59.965: BGP(2): no valid path for 100:1:10.0.0.6/32
*Apr 30 08:36:59.965: BGP(2): nettable_walker 100:1:10.0.0.6/32 no best path
*Apr 30 08:37:00.085: DUAL: Removing dest 10.0.0.6/32, nexthop 10.1.2.2
*Apr 30 08:37:00.085: DUAL: No routes.  Flushing dest 10.0.0.6/32
*Apr 30 08:37:00.961: vpn: bgp_router, vpn ipv4 redistQ len = 1
*Apr 30 08:37:00.961: BGP(2): route 100:1:10.0.0.6/32 down
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 computing updates, afi 2, neighbor 
version 73, table version 74, starting at 0.0.0.0
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 send unreachable 100:1:10.0.0.6/32
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 send UPDATE 100:1:10.0.0.6/32 -- 
unreachable
*Apr 30 08:37:01.993: BGP(2): 1 updates (average = 45, maximum = 45)
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 updates replicated for neighbors:
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 update run completed, afi 2, ran for
 0ms, neighbor version 74, start version 74, throttled to 74
*Apr 30 08:37:05.925: BGP: Import walker start version 73, end version 
74*Apr 30 08:37:05.925: BGP: ... start import cfg version = 0

PE-1
*Apr 30 08:35:04.069: BGP(2): 7.0.0.4 rcv UPDATE about 100:1:10.0.0.6/32
 -- withdrawn
*Apr 30 08:35:04.069: BGP: Withdraw path from 7.0.0.4
*Apr 30 08:35:04.069: BGP(2): no valid path for 100:1:10.0.0.6/32
*Apr 30 08:35:04.089: BGP(2): nettable_walker 100:1:10.0.0.6/32 no best path
*Apr 30 08:35:04.109: DUAL: dual_rcvupdate(): 10.0.0.6/32 via Redistributed 
metric 4294967295/4294967295
*Apr 30 08:35:04.109: DUAL: Find FS for dest 10.0.0.6/32. FD is 2297856,
 RD is 2297856
*Apr 30 08:35:04.109: DUAL:     0.0.0.0 metric 4294967295/4294967295 not
 found Dmin is 4294967295
*Apr 30 08:35:04.109: DUAL: Dest 10.0.0.6/32 entering active state.
*Apr 30 08:35:04.109: DUAL: Set reply-status table. Count is 1.
*Apr 30 08:35:04.109: DUAL: Not doing split horizon
*Apr 30 08:35:04.137: EIGRP: Enqueueing QUERY on Ethernet0/0 iidbQ un/rely
 0/1 serno 35-35
*Apr 30 08:35:04.169: EIGRP: Sending QUERY on Ethernet0/0
*Apr 30 08:35:04.169:   AS 10, Flags 0x0, Seq 17/0 idbQ 0/0 iidbQ un/rely
 0/0 serno 35-35
*Apr 30 08:35:04.349: EIGRP: Received REPLY on Ethernet0/0 nbr 9.0.1.2
*Apr 30 08:35:04.349:   AS 10, Flags 0x0, Seq 16/17 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:35:04.349: DUAL: dest(10.0.0.6/32) active
*Apr 30 08:35:04.349: DUAL: dual_rcvreply(): 10.0.0.6/32 via 9.0.1.2 metric
 4294967295/4294967295
*Apr 30 08:35:04.349: DUAL: Count is 1*Apr 30 08:35:04.349: DUAL: Clearing
 handle 0, count is now 0
*Apr 30 08:35:04.349: DUAL: Freeing reply status table
*Apr 30 08:35:04.349: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:35:04.349: DUAL: Removing dest 10.0.0.6/32, nexthop 0.0.0.0
*Apr 30 08:35:04.349: DUAL: Removing dest 10.0.0.6/32, nexthop 9.0.1.2
*Apr 30 08:35:04.349: DUAL: No routes.  Flushing dest 10.0.0.6/32

PE-1#
CE-1
*Apr 30 08:26:30.813: EIGRP: Received QUERY on Ethernet0/0 nbr 9.0.1.1
*Apr 30 08:26:30.813:   AS 10, Flags 0x0, Seq 13/0 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:26:30.813: DUAL: dual_rcvquery():10.0.0.6/32 via 9.0.1.1 metric
 4294967295/4294967295, RD is 2323456
*Apr 30 08:26:30.813: DUAL: Find FS for dest 10.0.0.6/32. FD is 2323456,
 RD is 2323456
*Apr 30 08:26:30.813: DUAL:     9.0.1.1 metric 4294967295/4294967295 not
 found Dmin is 4294967295
*Apr 30 08:26:30.813: DUAL: Dest 10.0.0.6/32 (Split Horizon) not entering
 active state.
*Apr 30 08:26:30.813: DUAL: Send reply about 10.0.0.6/32 to 9.0.1.1
*Apr 30 08:26:30.849: EIGRP: Enqueueing REPLY on Ethernet0/0 nbr 9.0.1.1 
iidbQ un/rely 0/1 peerQ un/rely 0/0 serno 31-31
*Apr 30 08:26:30.877: EIGRP: Sending REPLY on Ethernet0/0 nbr 9.0.1.1
*Apr 30 08:26:30.877:   AS 10, Flags 0x0, Seq 12/13 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/1 serno 31-31
*Apr 30 08:26:30.989: DUAL: Removing dest 10.0.0.6/32, nexthop 9.0.1.1
*Apr 30 08:26:30.989: DUAL: No routes.  Flushing dest 10.0.0.6/32

Este ejemplo muestra la creación de una entrada EIGRP después de a realizan al comando no shut en el loopback0 interfaz en CE-4:

PE-4
*Apr 30 08:38:53.685: DUAL: dest(10.0.0.6/32) not active
*Apr 30 08:38:53.685: DUAL: dual_rcvupdate(): 10.0.0.6/32 via 10.1.2.2
 metric 2297856/128256
*Apr 30 08:38:53.685: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:38:53.685: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:38:53.685: DUAL: RT installed 10.0.0.6/32 via 10.1.2.2
*Apr 30 08:38:53.685: DUAL: Send update about 10.0.0.6/32.  Reason: metric chg
*Apr 30 08:38:53.685: DUAL: Send update about 10.0.0.6/32.  Reason: new if
*Apr 30 08:38:53.745: vpn: bgp_router, vpn ipv4 redistQ len = 1
*Apr 30 08:38:53.745: BGP(2): route 100:1:10.0.0.6/32 up
*Apr 30 08:38:53.745: vpn: bgp allocate label: route_tag_change for 
vpn1:10.0.0.6/255.255.255.255
*Apr 30 08:38:53.745: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:38:53.745: vpn: intag=21, outtag=unknown, outtag owner=BGP
*Apr 30 08:38:53.745: BGP(2): nettable_walker 100:1:10.0.0.6/32 route 
sourced locally
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 computing updates, afi 2, neighbor
 version 77, table version 78, starting at 0.0.0.0
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 send UPDATE (format) 100:1:10.0.0.6/32,
 next 7.0.0.4, metric 2297856, path , extended community RT:100:1 0x8800:32768:0
 0x8801:10:640000 0x8802:65281:1657856 0x8803:65281:1500
*Apr 30 08:38:55.813: BGP(2): 1 updates (average = 123, maximum = 123)
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 updates replicated for neighbors:
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 update run completed, afi 2, ran 
for 0ms, neighbor version 78, start version 78, throttled to 78
*Apr 30 08:39:07.053: BGP: Import walker start version 77, end version 78
*Apr 30 08:39:07.053: BGP: ... start import cfg version = 0
*Apr 30 08:39:07.053: vpn: vpn1 same RD import, do best path
*Apr 30 08:39:07.053: vpn: bgp allocate label: route_tag_change for 
vpn1:10.0.0.6/255.255.255.255
*Apr 30 08:39:07.053: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:39:07.053: vpn: intag=21, outtag=unknown, outtag owner=BGP
*Apr 30 08:39:07.305: BGP(2): nettable_walker 100:1:10.0.0.6/32 route 
sourced locally
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 computing updates, afi 2, neighbor
 version 78, table version 79, starting at 0.0.0.0
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 send UPDATE (format) 100:1:10.0.0.6/32,
 next 7.0.0.4, metric 2297856, path , extended community RT:100:1 0x8800:32768:0
 0x8801:10:640000 0x8802:65281:1657856 0x8803:65281:1500
*Apr 30 08:39:09.413: BGP(2): 1 updates (average = 123, maximum = 123)
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 updates replicated for neighbors:
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 update run completed, afi 2, ran for 
0ms, neighbor version 79, start version 79, throttled to 79

PE-1
*Apr 30 08:35:36.409: BGP: 7.0.0.3 multihop open delayed 15100ms (no route) 
*Apr 30 08:35:37.981: BGP: Incoming path from 7.0.0.4
*Apr 30 08:35:37.981: BGP(2): 7.0.0.4 rcvd UPDATE w/ attr: nexthop 7.0.0.4,
 origin ?, localpref 100, metric 2297856, extended community RT:100:1 
0x8800:32768:0 0x8801:10:640000 0x8802:65281:1657856 0x8803:65281:1500
*Apr 30 08:35:37.981: BGP(2): 7.0.0.4 rcvd 100:1:10.0.0.6/32
*Apr 30 08:35:37.981: vpn: bgp_vpnv4_bnetinit: 100:1:10.0.0.6/32
*Apr 30 08:35:37.981: BGP: Accepted path from 7.0.0.4
*Apr 30 08:35:38.001: BGP(2): nettable_walker 100:1:10.0.0.6/32 no RIB
*Apr 30 08:35:38.189: BGP(2): 7.0.0.4 computing updates, afi 2, neighbor
 version 55, table version 56, starting at 0.0.0.0
*Apr 30 08:35:38.189: BGP(2): 7.0.0.4 update run completed, afi 2, 
ran for 0ms, neighbor version 56, start version 56, throttled to 56
*Apr 30 08:35:39.081: BGP: 7.0.0.2 multihop open delayed 16412ms (no route)
*Apr 30 08:35:50.437: BGP: Import walker start version 55, end version 56
*Apr 30 08:35:50.437: BGP: ... start import cfg version = 0
*Apr 30 08:35:50.437: vpn: vpn1 same RD import, do best path
*Apr 30 08:35:50.869: BGP(2): Revise route installing 1 of 1 route 
for10.0.0.6/32 -> 7.0.0.4(main) to vpn1 IP table
*Apr 30 08:35:50.889: DUAL: dest(10.0.0.6/32) not active
*Apr 30 08:35:50.889: DUAL: dual_rcvupdate(): 10.0.0.6/32 via Redistributed
 metric 2297856/0
*Apr 30 08:35:50.889: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:35:50.889: DUAL: RT installed 10.0.0.6/32 via 0.0.0.0
*Apr 30 08:35:50.889: DUAL: Send update about 10.0.0.6/32.  Reason: 
metric chg
*Apr 30 08:35:50.889: DUAL: Send update about 10.0.0.6/32.  Reason:
new if
*Apr 30 08:35:50.929: EIGRP: Enqueueing UPDATE on Ethernet0/0 iidbQ 
un/rely 0/1 serno 36-36
*Apr 30 08:35:50.957: EIGRP: Sending UPDATE on Ethernet0/0
*Apr 30 08:35:50.957:   AS 10, Flags 0x0, Seq 18/0 idbQ 0/0 iidbQ un/rely
 0/0 serno 36-36
*Apr 30 08:35:51.149: EIGRP: Received UPDATE on Ethernet0/0 nbr 9.0.1.2
*Apr 30 08:35:51.149:   AS 10, Flags 0x0, Seq 17/0 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:35:51.417: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:35:51.417: vpn: intag=vpn-route, outtag=20, outtag owner=BGPCE-1
*Apr 30 08:28:17.669: EIGRP: Received UPDATE on Ethernet0/0 nbr 9.0.1.1
*Apr 30 08:28:17.669:   AS 10, Flags 0x0, Seq 14/0 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:28:17.669: DUAL: dest(10.0.0.6/32) not active
*Apr 30 08:28:17.669: DUAL: dual_rcvupdate(): 10.0.0.6/32 via 9.0.1.1 
metric 2323456/2297856
*Apr 30 08:28:17.669: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:28:17.669: DUAL: RT installed 10.0.0.6/32 via 9.0.1.1
*Apr 30 08:28:17.669: DUAL: Send update about 10.0.0.6/32.  Reason:
 metric chg
*Apr 30 08:28:17.669: DUAL: Send update about 10.0.0.6/32.  Reason:
 new if
*Apr 30 08:28:17.709: EIGRP: Enqueueing UPDATE on Ethernet0/0 iidbQ 
un/rely 0/1 serno 32-32
*Apr 30 08:28:17.737: EIGRP: Sending UPDATE on Ethernet0/0
*Apr 30 08:28:17.737:   AS 10, Flags 0x0, Seq 13/0 idbQ 0/0 iidbQ un/rely
 0/0 serno 32-32

Escenario 2: Configure un sistema autónomo del EIGRP múltiple

Diagrama de la red

Esta sección utiliza esta configuración de red:

mplsvpneigrp2.gif

Configuraciones

Esta sección usa estas configuraciones:

PE-1
PE-1#show run
Building configuration...
ip cef
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface Loopback0
 ip address 7.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 9.0.1.1 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family ipv4 vrf vpn1
 redistribute bgp 1
 network 9.0.0.0
 default-metric 10000 1 255 1 1500
 no auto-summary
 autonomous-system 10
 exit-address-family
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.0.0.4 remote-as 1
 neighbor 7.0.0.4 update-source Loopback0
!
 address-family vpnv4
 neighbor 7.0.0.4 activate
 neighbor 7.0.0.4 send-community both
 no auto-summary exit-address-family
!
 address-family ipv4
 neighbor 7.0.0.4 activate
 exit-address-family
!
 address-family ipv4 vrf vpn1
 redistribute eigrp 10
 no auto-summary
 no synchronization
 exit-address-family
!
end

PE-4
PE-4#show running-config
Building configuration...
Current configuration : 2439 bytes
!
ip cef
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
!
interface Loopback0
 ip address 7.0.0.4 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 6.0.2.3 255.255.255.0
 no ip directed-broadcast
 tag-switching ip
!
!
interface Serial2/0
 ip vrf forwarding vpn1
 ip address 10.1.2.1 255.255.255.252
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family
 ipv4 vrf vpn1
 redistribute bgp 1
 network 10.0.0.0
 default-metric 10000 1 255 1 1500
 no auto-summary
 autonomous-system 20   

!--- The autonomous system is different from Scenario 1.

 exit-address-family
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.0.0.1 remote-as 1
 neighbor 7.0.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 7.0.0.1 activate
 neighbor 7.0.0.1 send-community extended
 no auto-summary
 exit-address-family
 !
 address-family ipv4
 redistribute connected
 neighbor 7.0.0.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute eigrp 20  

!--- The autonomous system is different from Scenario 1.

 no auto-summary
 no synchronization
 network 13.0.0.1 mask 255.255.255.255
 exit-address-family
!
end

Verificación

Utilice estos comandos de verificar su configuración:

  • muestre el vpn1 del vrf del eigrp del IP interfaces

  • show ip eigrp vrf vpn1 neighbors

  • show ip eigrp vrf vpn1 topology

IP-EIGRP Topology Table for AS(10)/ID(9.0.0.1) Routing Table: vpn1
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status
P 10.1.3.0/24, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.0.1.0/24, 1 successors, FD is 281600
         via Connected, Ethernet0/0
P 9.0.0.1/32, 1 successors, FD is 128256
         via Connected, Loopback1
P 10.1.2.0/30, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.1.0.2/32, 1 successors, FD is 45867776
         via 9.0.1.2 (45867776/45842176), Ethernet0/0
P 9.0.0.2/32, 1 successors, FD is 409600
         via 9.0.1.2 (409600/128256), Ethernet0/0
P 13.0.0.1/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.0.0.6/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.0.0.7/32, 1 successors, FD is 256256
         via Redistributed (256256/0)

PE-1#show ip bgp vpnv4 vrf vpn1
 BGP table version is 99, local router ID is 7.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best,
 i - internal,
              S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*> 9.0.0.1/32       0.0.0.0                  0         32768 ?
*> 9.0.0.2/32       9.0.1.2             409600         32768 ?
*> 9.0.1.0/24       0.0.0.0                  0         32768 ?
*> 9.1.0.2/32       9.0.1.2           45867776         32768 ?
*>i10.0.0.6/32      7.0.0.4            2297856    100      0 ?
*>i10.0.0.7/32      7.0.0.4            2323456    100      0 ?
*>i10.1.2.0/30      7.0.0.4                  0    100      0 ?
*>i10.1.3.0/24      7.0.0.4            2195456    100      0 ?
*>i13.0.0.1/32      7.0.0.4                  0    100      0 i

PE-1#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
BGP routing table entry for 100:1:9.0.0.1/32, version 12
Paths: (1 available, best #1, table vpn1)
  Advertised to update-groups:
     1
           Local
    0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.1)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid,
 sourced, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
 0x8802:65280:256 0x8803:65281:1514

PE-1#show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
BGP routing table entry for 100:1:10.1.2.0/30, version 95
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    7.0.0.4 (metric 139) from 7.0.0.4 (7.0.0.4)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:20:512000 
 0x8802:65280:1657856 0x8803:65281:1500

PE-1#
PE-4#show ip eigrp vrf vpn1 interfaces <output removed>
PE-4#show ip eigrp vrf vpn1 neighbors <output removed>
PE-4#show ip eigrp vrf vpn1 topology
IP-EIGRP Topology Table for AS(20)/ID(13.0.0.1) Routing Table: vpn1
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status
P 9.0.1.0/24, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.0.0.1/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.1.3.0/24, 1 successors, FD is 2195456
         via 10.1.2.2 (2195456/281600), Serial2/0
P 10.1.2.0/30, 1 successors, FD is 2169856
         via Connected, Serial2/0
P 9.1.0.2/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.0.0.2/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 13.0.0.1/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.0.0.6/32, 1 successors, FD is 2297856
         via 10.1.2.2 (2297856/128256), Serial2/0
P 10.0.0.7/32, 1 successors, FD is 2323456
         via 10.1.2.2 (2323456/409600), Serial2/0

PE-4#show ip bgp vpnv4 vrf vpn1
BGP table version is 23, local router ID is 7.0.0.4
Status codes: s suppressed, d damped, h history, * valid, > best,
 i - internal,
              S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*>i9.0.0.1/32       7.0.0.1                  0    100      0 ?
*>i9.0.0.2/32       7.0.0.1             409600    100      0 ?
*>i9.0.1.0/24       7.0.0.1                  0    100      0 ?
*>i9.1.0.2/32       7.0.0.1           45867776    100      0 ?
*> 10.0.0.6/32      10.1.2.2           2297856         32768 ?
*> 10.0.0.7/32      10.1.2.2           2323456         32768 ?
*> 10.1.2.0/30      0.0.0.0                  0         32768 ?
*> 10.1.3.0/24      10.1.2.2           2195456         32768 ?
*> 13.0.0.1/32      0.0.0.0                  0         32768 i

PE-4#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
BGP routing table entry for 100:1:9.0.0.1/32, version 13
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    7.0.0.1 (metric 139) from 7.0.0.1 (7.0.0.1)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
 0x8802:65280:256 0x8803:65281:1514

PE-4#show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
BGP routing table entry for 100:1:10.1.2.0/30, version 19
Paths: (1 available, best #1, table vpn1)
  Advertised to update-groups:
     1
           Local
    0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.4)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid,
 sourced, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:20:512000
 0x8802:65280:1657856 0x8803:65281:1500

PE-4#
CE-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
Gateway of last resort is not set
     9.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       9.0.1.0/24 is directly connected, Ethernet0/0
D       9.0.0.1/32 [90/409600] via 9.0.1.1, 1d06h, Ethernet0/0
C       9.1.0.2/32 is directly connected, Loopback1
C       9.0.0.2/32 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
D EX    10.1.3.0/24 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
D EX    10.1.2.0/30 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
D EX    10.0.0.6/32 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
D EX    10.0.0.7/32 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
     13.0.0.0/32 is subnetted, 1 subnets
D EX    13.0.0.1 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0

CE-1#show ip eigrp topology 10 10.1.2.0 255.255.255.252
IP-EIGRP topology entry for 10.1.2.0/30
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281856
  Routing Descriptor Blocks:
  9.0.1.1 (Ethernet0/0), from 9.0.1.1, Send flag is 0x0
      Composite metric is (281856/256256), Route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1010 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 9.0.0.1
        AS number of route is 1
        External protocol is BGP, external metric is 0
        Administrator tag is 0 (0x00000000)
CE-1#


Información Relacionada


Document ID: 40883