IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Configuración de IS-IS sobre IPv6

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento ofrece una configuración de ejemplo para el Sistema intermedio a sistema intermedio (IS-IS) sobre IP versión 6 (IPv6). También analiza cómo verificar y solucionar problemas de configuración.

prerrequisitos

Requisitos

Antes de utilizar esta configuración, asegúrese de que cumple con los siguientes requisitos:

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • 12.2(13)T con el conjunto de características para empresas

  • Plataforma Cisco 7200

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/40262/ipv6_sample_config.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

c7200-1
c7200-1# show run

ipv6 unicast-routing 
! Enable the forwarding of IPv6 unicast datagrams
!
interface Loopback0
 no ip address
 ipv6 address 2000:1::1/96
 circuit-type level-2-only
 address-family ipv6 unicast
!

!--- If the sole purpose of the loopback is a router ID, 
!--- a /128 is preferred. 
!--- A /96 is used here to advertise this route through IS-IS.
!--- Last two commands for getting advertised in the LSP


 ipv6 router isis alpha

!--- Enables IS-IS on the interface for area "alpha."

!
interface FastEthernet3/0
 ip address 172.16.88.51 255.255.255.224
 duplex half
 ipv6 address 1000:1:1:1:1:1:1:1/112
 ipv6 router isis alpha
!
router isis alpha

!--- Enables the IS-IS routing process for area "alpha."

 net 49.1111.2220.3330.4440.00

!--- Defines the area addresses for the IS-IS area and the system ID
!--- of the router. 49.1111 is the area id SysID is 2220.3330.4440.

!
end

c7200-2
c7200-2# show run
ipv6 unicast-routing
!
interface Loopback0                                                  
 no ip address
 ipv6 address 3000:1::1/96
 ipv6 router isis alpha
!
interface FastEthernet0/0
 ip address 172.16.88.50 255.255.255.224
 duplex auto
 speed auto
 ipv6 address 1000:1:1:1:1:1:1:2/112
 ipv6 router isis alpha
!
 router isis alpha
 net 49.1111.2222.3333.4444.00
 !
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show clns interface- Se utiliza para hacer una lista con información específica del Servicio de red no orientado a la conexión acerca de una interfaz

    c7200-1# show clns int fa3/0 
    FastEthernet3/0 is up, line protocol is up 
      Checksums enabled, MTU 1497, Encapsulation SAP 
      ERPDUs enabled, min. interval 10 msec. 
      CLNS fast switching enabled 
      CLNS SSE switching disabled 
    
      DEC compatibility mode OFF for this interface 
      Next ESH/ISH in 43 seconds 
      Routing Protocol: IS-IS 
        Circuit Type: level-1-2 
        Interface number 0x0, local circuit ID 0x1 
        Level-1 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-1 adjacencies: 1 
        Level-2 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-2 adjacencies: 1 
        Next IS-IS LAN Level-1 Hello in 1 seconds 
        Next IS-IS LAN Level-2 Hello in 1 seconds
  • muestre a los vecinos del clns - Utilizado para mostrar a los vecinos CLNS el estado.

    c7200-1# show clns neighbors
    System Id      Interface   SNPA                     State  Holdtime  Type Protocol 
    c7200-2        Fa3/0       0004.281e.e008           Up      25        L1L2 IS-IS
  • show ipv6 route – Se usa para verificar si una ruta existe en el IPv6.

    c7200-1# show ipv6 route 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         L   1000:1:1:1:1:1:1:1/128 [0/0] 
              via ::, FastEthernet3/0 
         C   1000:1:1:1:1:1:1:0/112 [0/0] 
              via ::, FastEthernet3/0 
         L   2000:1::1/128 [0/0] 
              via ::, Loopback0 
         C   2000:1::/96 [0/0] 
              via ::, Loopback0 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
         L   FE80::/10 [0/0] 
              via ::, Null0 
         L   FF00::/8 [0/0] 
              via ::, Null0
    
    c7200-1# show ipv6 route 3000:1::1 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
  • show isis database detail – Utilizado para mostrar los detalles de la base de datos IS-IS.

    c7200-1# show isis database detail
    IS-IS Level-1 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DB        0xC383        1103                   0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 10         IS c7200-1.01      
         c7200-1.01-00       * 0x000000D8        0x5C9A        1078                   0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DD        0x0219        757                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 3000:1::/96      
           Metric: 10         IS c7200-1.01      
         IS-IS Level-2 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DC        0x2569        893                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 20         IPv6 3000:1::/96      
         c7200-1.01-00       * 0x000000D9        0xE994        773                    0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DF        0x88E8        937                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 20         IPv6 2000:1::/96      
           Metric: 10         IPv6 3000:1::/96
  • ping – Se utiliza para determinar si un host remoto está activo o inactivo, y el retardo de ida y vuelta en la comunicación con el host.

    7200-2# ping 1000:1:1:1:1:1:1:1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1000:1:1:1:1:1:1:1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

  • debug isis adj-packet s – Se utiliza para mostrar paquetes de saludo IS-IS (IIH) que pasan a través de los vecinos CLNS.

Procedimiento de Troubleshooting

A continuación, encontrará información relevante para resolver problemas en esta configuración. Si IPv6 IS-IS no está funcionando adecuadamente, siga las instrucciones que aparecen a continuación para resolver los problemas de la configuración.

  1. Haga un ping al vecino y asegúrese de que funcione. Si falla, verifique para asegurarse de que las direcciones estén ubicadas en la misma subred y también verifique la Capa 1 y Capa 2. Es útil tener un direccionamiento del IPv4 en cada interfaz. Verifique si los pings IPv4 funcionan y esto lo ayudará a excluir cualquier problema de Capa 1 y Capa 2.

  2. Marque para ver si la configuración está correcta. Consultar el ejemplo de configuraciones en la sección Configuraciones de este documento. Si la configuración figura como correcta, envíe un comando debug clns adj-packets.

    Debe consultar los paquetes IIH que van en ambas direcciones, como se muestra a continuación en la salida de depuración de ejemplo:

    Nota: Antes de ejecutar los comandos de depuración en una red de producción, consulte Información importante sobre comandos de depuración.

    c7200-1# debug isis adj-packets 
    IS-IS Adjacency related packets debugging is on 
    
    5d23h: ISIS-Adj: Sending L1 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on Loopback0, length 1514n 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Rec L1 IIH from 0004.281e.e008 (FastEthernet3/0), cir type L1L2,
     cir id 2220.3330.4440.01, length 1497
  3. Si los vecinos del IPv6 IS-IS no están atando, marque para saber si hay un ID del sistema duplicado.

Para más detalles en configurar el IS-IS sobre el IPv6, refiera a la biblioteca de configuración del IPv6 del Cisco IOS.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 40262