Servicios de redes de aplicaciones : Cisco Content Engines de la serie 500

Configurar la versión de WCCP 2 en el Catalyst 3550

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para la versión 2 del protocolo web cache communication (WCCP) en el Catalyst 3550 con el Cisco Content Engine 560.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Esta configuración fue desarrollada y probada usando las versiones de software y hardware siguientes.

  • Software Release 12.1(11)EA1a del ½ del ¿Â de Cisco IOSï del Cisco Catalyst que se ejecuta 3550

  • Aplicación de Cisco del Cisco Content Engine 560 y versión corrientes 4.2.3 del Content Networking Software (ACNS)

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/29461/diagram.jpg

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

  • Catalyst 3550

  • Content Engine 560

Catalyst 3550
GIULIO#sh run
Building configuration...
Current configuration : 3426 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname GIULIO
!
enable password ww
!
ip subnet-zero
ip routing



!--- Only TCP port 80 may be redirected.
!--- You need to issue the sdm prefer extended-match command
!--- on the switch. Refer to the Verify and Troubleshoot section for 
!--- further information.


ip wccp web-cache
!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
�no switchport
�ip address 10.48.66.217 255.255.254.0
!
interface FastEthernet0/2
�no ip address
!
interface FastEthernet0/3
�no ip address
!
interface FastEthernet0/4
�no ip address
!
interface FastEthernet0/5
�no ip address
!
interface FastEthernet0/6
�no ip address
!���������
interface FastEthernet0/7
�no ip address
!
interface FastEthernet0/8
�no ip address
!
interface FastEthernet0/9
�no ip address
!
interface FastEthernet0/10
�no ip address
!
interface FastEthernet0/11
�no ip address
!
interface FastEthernet0/12
�no ip address
!
interface FastEthernet0/13
�no ip address
!
interface FastEthernet0/14
�no ip address
!
interface FastEthernet0/15
�no ip address
!
interface FastEthernet0/16
�no switchport
�ip address 33.33.33.33 255.255.255.0
�duplex full
�speed 100
!
interface FastEthernet0/17
�no ip address
!
interface FastEthernet0/18
�no ip address
!���������
interface FastEthernet0/19
�no ip address
!
interface FastEthernet0/20
�no ip address
!
interface FastEthernet0/21
�no ip address
!
interface FastEthernet0/22
�no ip address
!
interface FastEthernet0/23
�no ip address
!
interface FastEthernet0/24
�no ip address
!
interface FastEthernet0/25
�no ip address
!
interface FastEthernet0/26
�no ip address
!
interface FastEthernet0/27
�no ip address
!
interface FastEthernet0/28
�no ip address
!
interface FastEthernet0/29
�no ip address
!
interface FastEthernet0/30
�no ip address
!
interface FastEthernet0/31
�no ip address
!
interface FastEthernet0/32
�no ip address
!
interface FastEthernet0/33
�no ip address
!
interface FastEthernet0/34
�no ip address
!
interface FastEthernet0/35
�no ip address
!
interface FastEthernet0/36
�no ip address
!
interface FastEthernet0/37
�no ip address
!
interface FastEthernet0/38
�no ip address
!
interface FastEthernet0/39
�no ip address
!
interface FastEthernet0/40
�no ip address
!
interface FastEthernet0/41
�no ip address
!
interface FastEthernet0/42
�no ip address
!
interface FastEthernet0/43
�no ip address
!
interface FastEthernet0/44
�no ip address
!
interface FastEthernet0/45
�no ip address
!
interface FastEthernet0/46
�no ip address
!
interface FastEthernet0/47
�no ip address
!
interface FastEthernet0/48


!--- On this WCCP implementation, only input redirection is allowed.


�no switchport
�ip address 1.1.1.1 255.255.255.0
�ip wccp web-cache redirect in
!
interface GigabitEthernet0/1
�no ip address
!
interface GigabitEthernet0/2
�no ip address
!
!



!--- This access list 100, if associated as 'in' to Fa0/48, 
!--- can show if packets are reaching the Catalyst from the PC client.


access-list 100 permit tcp any eq www any log
access-list 100 permit tcp any any eq www log

access-list 100 permit any any any log

ip default-gateway 10.48.66.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.66.1
ip http server
!
!
!
!
line con 0
�exec-timeout 0 0
�password cisco
line vty 0 4
�exec-timeout 0 0
�password ww
�login
line vty 5 15
�login
!
end

GIULIO#

Content Engine 560
agra#sh run 
  hostname agra 
  ! 
  ! 
  ! 
  ! 
  ! 


!--- The Standby feature on the Content Engine  is optional in the 
!--- implementation, but it works fine with the Catalyst.

  interface FastEthernet 0/0 
  �ip address 122.122.122.1 255.255.255.0 
  �standby 1 ip 33.33.33.31 255.255.255.0
  �standby 1 priority 120 
  �no autosense 
  �bandwidth 100 
  �full-duplex 
  �exit 
  interface FastEthernet 0/1 
  �ip address 122.122.123.1 255.255.255.0 
  �standby 1 ip 33.33.33.31 255.255.255.0  
  �standby 1 priority 80 
  �no autosense 
  �bandwidth 100 
  �full-duplex 
  �exit 
  ! 
  ! 
  ip default-gateway 33.33.33.33 
  ! 
  primary-interface FastEthernet 0/0 
  ! 
  ! 
  ! 
  ! 


!--- The logging console is only used for troubleshooting, as it may cause 
!-- high CPU on the Content Engine in production.
� 
  logging console enable 
  logging console priority debug 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  
  wccp router-list 1 33.33.33.33 
  wccp web-cache router-list-num 1 l2-redirect 

!--- The assign-method-strict is not necessary.

  wccp version 2 


!--- Catalyst 3550 implementation of WCCP allows only Layer 2 redirection, 
!--- and not generic routing encapsulation (GRE). In addition, only TCP 
!--- port 80 may be redirected. 

  ! 
  ! 
  username admin password 1 bVmDmMMmZAPjY 
  username admin privilege 15 
  ! 
  ! 
  ! 
  ! 
  authentication login local enable primary 
  authentication configuration local enable primary 
  ! 
  !               

agra#

Verificación y resolución de problemas

Esta sección proporciona la información que usted puede utilizar para confirmar que su configuración está trabajando correctamente y para resolverlo problemas más lejos.

  • Para habilitar el redireccionamiento de WCCP en el switch de Catalyst, usted necesita publicar el comando sdm prefer extended-match (y reiniciar el Switch). Publicando el comando show sdm prefer, usted puede ver la configuración real del hardware TCAM/ASIC en el Switch.

  • Mientras que la implementación del WCCP en el Catalyst 3550 es limitada, la publicación del comando show ip wccp no muestra el número de paquetes que son reorientados. Sigue habiendo este índice en 0. También, el mismo Catalyst puede tener Content Engine múltiple en granja de caché, pero solamente uno Catalyst WCCP se permite. La salida del comando show ip wccp en el Catalyst se muestra abajo.

    GIULIO#sh ip wccp 
    
    Global WCCP information: 
      ��� Router information: 
      ������� Router Identifier:������������������  33.33.33.33 
      ������� Protocol Version:�������������������  2.0 
    
    ��� Service Identifier: web-cache 
      ������� Number of Cache Engines:�������������  1 
      ������� Number of routers:���������������������1 
      ������� Total Packets Redirected:��������������0 
      ������� Redirect access-list:����������������  -none- 
      ������� Total Packets Denied Redirect:�������  0 
      ������� Total Packets Unassigned:��������������0 
      ������� Group access-list:�������������������  -none- 
      ������� Total Messages Denied to Group:���     0 
      ������� Total Authentication failures:���������0 
      �
                                  Statistics - Requests
                                                    Total             % of Requests
                                ---------------------------------------------------
         Total Received Requests:                       4                         -
                  Forced Reloads:                       0                       0.0
                   Client Errors:                       0                       0.0
                   Server Errors:                       0                       0.0
             URL Blocked (Reset):                       0                       0.0
                     URL Blocked:                       0                       0.0
          Sent to Outgoing Proxy:                       0                       0.0
    Failures from Outgoing Proxy:                       0                       0.0
    Excluded from Outgoing Proxy:                       0                       0.0
                 ICP Client Hits:                       0                       0.0
                 ICP Server Hits:                       0                       0.0
                   If-Range Hits:                       0                       0.0
               HTTP 0.9 Requests:                       4                     100.0
               HTTP 1.0 Requests:                       0                       0.0
               HTTP 1.1 Requests:                       0                       0.0
           HTTP Unknown Requests:                       0                       0.0
               Non HTTP Requests:                       0                       0.0
              Non HTTP Responses:                       0                       0.0
          Chunked HTTP Responses:                       0                       0.0
            Http Miss Due To DNS:                       0                       0.0
         Http Deletes Due To DNS:                       0                       0.0
    
    
    agra#sho stat http savings 
                             Statistics - Savings
                            Requests                          Bytes
             -----------------------------------------------------------
      Total:                       4                           3132
       Hits:                       3                           2349
       Miss:                       1                            783
    Savings:                    75.0 %                         75.0 %
    
    
    agra#sho stat netstat 
    Active Internet connections (w/o servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 33.33.33.31:8999        10.48.66.123:2011       ESTABLISHED 
    
    udp        0      0 127.0.0.1:10000         127.0.0.1:32346         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10001         127.0.0.1:32347         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10002         127.0.0.1:32345         ESTABLISHED
  • Si la lista de acceso 100 se aplica al tráfico entrante en el FastEthernet 0/48, un mensaje similar al siguiente se debe enviar a la consola para cada paquete HTTP enviado por el buscador del cliente a Internet:

    *Mar� 1 04:19:09: %SEC-6-IPACCESSLOGP: list 109 permitted tcp 1.1.1.2(1828)    -> 10.48.66.125(80), 1 packet �    
    
    
  • En el Content Engine, los siguientes comandos permiten que usted considere el número de paquetes enviados por el Content Engine:

    • show statistics http requests

    • muestre el netstat de las estadísticas

    • muestre los ahorros HTTP de la estadística

    Todos los paquetes enviados a Internet tienen una dirección IP de origen idéntica al Content Engine, excepto cuando el Content Engine está en el modo de desvío y las peticiones son enviadas por PC del cliente la dirección IP de origen en lugar de otro.


Información Relacionada


Document ID: 29461