Banda ancha por cable : Sistemas de terminación de cable módems (CMTS)

configuración integral del uBR7100 en el modo Bridge

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento aporta una configuración de muestra para Cisco uBR7100 Cable Modem Termination System (CMTS) que actúa como un Protocolo de configuración de host dinámico (DHCP), Servicio hora del día (ToD) y servidor de TFTP. También explica cómo generar el archivo de configuración de Data-over-Cable Service Interface Specifications (DOCSIS) mediante la interfaz de línea de comandos (CLI) en CMTS. Esta configuración se conoce como “configuración integral para Cisco CMTS” mientras que CMTS se configura en el modo bridging. Actualmente, la plataforma uBR7100 es la única plataforma CMTS que soporta el bridging.

prerrequisitos

Requisitos

El Quien lea este documento debe tener una comprensión básica del bridging, del DOCSIS, del DHCP, del ToD, y de los protocolos TFTP.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Sistema de la terminación del cablemódem del Cisco uBR7100

  • Cablemódems que cumple con la norma DOCSIS

  • Software Release 12.1(7)EC o Posterior de Cisco IOS�

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Descripción

Un cablemódem que cumple con la norma DOCSIS requiere el acceso a tres tipos de servidores para venir con éxito en línea.

La mayoría del Cisco Network Registrar del uso de los operadores de cable (CNR) como el DHCP, el Domain Name Server (DNS), y servidores TFTP. El Servidor TOD no es una parte del CNR. El Servidor TOD se utiliza que depende de la plataforma del sistema del operador de cable. El ToD debe ser RFC-868leavingcisco.com - obediente. Para los sistemas Unix, se incluye en Solaris; es solamente necesario aseegurarse que el archivo inetd.conf en el directorio de /etc contiene estas líneas:

# Time service is used for clock synchronization.
#
time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal

Para Windows, el software más de uso general es Greywareleavingcisco.com .

Esta tabla muestra las versiones de Cisco IOS Software en las cuales diversas Capacidades del servidor se han agregado al CMTS:

Capacidades del servidor Versión de software del IOS de Cisco
DHCP 12.0(1)T
ToD 12.0(4)XI
TFTP 11.0 (para todas las plataformas)

Este documento explica cada uno de estas características. La configuración en el CMTS que contiene todas estas capacidades se llama la “configuración integral para el CMTS.” Con esta configuración, usted no necesita ninguna servidores adicional probar a sus plantas de cable y proporcionar el acceso a internet de alta velocidad.

También se puede configurar un archivo de configuración DOCSIS que se encuentra en CMTS, en lugar de en el servidor TFTP. De acuerdo con las notas de la versión, necesita al menos la versión de software 12.1(2)EC1 de Cisco IOS para usar esta función.

Aunque esta “configuración integral” sea muy conveniente para los ambientes de laboratorio, las pruebas iniciales, las pequeñas implementaciones, y localizar averías, no es scalable soportar un gran número de Cable módems. No se recomienda tanto como usted utiliza esta configuración en las plantas de cable operativas con las implementaciones grandes del Cable módems.

Los ingenieros de soporte técnicos de Cisco utilizan a menudo esta configuración para eliminar las variables mientras que localizan averías los problemas de cable.

Encaminamiento y Bridging Operation

El Routers del Cisco UBR7100 Series soporta estos modos de operación:

  • Modo de ruteo — Rutear la operación es el modo predeterminado típico para los routeres CMTS de Cisco. Él proporciona un amplio espectro de las funciones de ruteo del Cisco IOS Software, tales como un servidor DHCP y el control sobre los cuales los paquetes se envían sobre cada interfaz.

  • Modo de Puente transparente — El Bridging Operation entre la interfaz del cable y las interfaces de adaptador de puerto no se utiliza típicamente en las instalaciones del DOCSIS CMTS debido al rendimiento potencial y los problemas de seguridad. El bridging es muy eficaz, sin embargo, en los entornos CMTS con un número limitado de dispositivos del equipo en las instalaciones del cliente (CPE) — como en un entorno de la típica unidad de multivivienda (MDU) o de la unidad para varios abonados (MTU) — especialmente si el CMTS está substituyendo una red existente del bridging.

Integrated Routing and Bridging (IRB)

La operación del Integrated Routing and Bridging (IRB) permite el interligar dentro de un segmento específico de las redes o de los hosts, con todo también permite que esos hosts conecten con los dispositivos en otro, las redes ruteadas sin tener que utilizar un router separado para interconectar las dos redes.

Nota: Se soportan Puente transparente y el funcionamiento de IRB solamente al usar el Cisco IOS Software Release 12.1(7)EC y Posterior. Para los detalles completos en Puente transparente y funcionamiento de IRB, vea los capítulos del bridging en el Cisco IOS interligando y guía de configuración de las Redes IBM, Release12.1, disponibles en el cisco.com y el CD-ROM de documentación.

Interfaz Virtual del Grupo de Bridges

ubr7100_config_bridge_1.gif

Porque el interligar actúa en la capa del link de datos y el rutear actúa en la capa de red, siguen diversos modelos de la configuración del protocolo. Tomando el modelo básico del IP como ejemplo, todas las interfaces puenteadas pertenecerían a la misma red, mientras que cada interfaz ruteada representa una red distinta.

En el IRB, el Interfaz Virtual de Bridge-Group se introduce para evitar confundir el modelo de la configuración del protocolo cuando un protocolo específico se interliga y se rutea en un Grupo de Bridge.

La interfaz virtual de grupo de bridges es una interfaz ruteada normal que no soporta el bridging, pero representa al grupo de bridges correspondiente para la interfaz ruteada. Tiene todos los atributos de la capa de red (tales como una dirección de capa de red y filtros) que se aplican al grupo de bridges correspondiente. El número de interfaz asignado a esta interfaz virtual corresponde al grupo de bridges que representa esta interfaz virtual. Este número es el link entre la interfaz virtual y el grupo de bridges.

Cuando usted habilita la encaminamiento para un protocolo dado en el Interfaz Virtual de Bridge-Group, los paquetes que vienen de una interfaz ruteada pero destinados para un host en un dominio Bridged se rutean al Interfaz Virtual de Bridge-Group y se remiten a la interfaz Bridged correspondiente. Todo el tráfico ruteado a la interfaz virtual del grupo de bridges se reenvía al grupo de bridges correspondiente como tráfico puenteado. Todo el tráfico ruteable recibido en una interfaz puenteada se rutea a otras interfaces ruteadas como si proviniera directamente de la interfaz virtual del grupo de bridges.

Para recibir los paquetes ruteables que llegan en una interfaz bridged pero destinados a una interfaz ruteada, o recibir paquetes ruteados, la interfaz virtual del grupo de bridges debe tener también las direcciones apropiadas. Asignan las direcciones MAC y las direcciones de red al Interfaz Virtual de Bridge-Group de este modo:

  • La interfaz virtual del grupo de bridges “pide prestada” la dirección MAC de una de las interfaces puenteadas en el grupo de bridges asociado a la interfaz virtual del grupo de bridges.

  • Para rutear y puentear un protocolo dado en el mismo grupo de bridges, debe configurar los atributos de la capa de red del protocolo en la interfaz virtual del grupo de bridges.

  • Los atributos del protocolo no se deben configurar en las interfaces puenteadas y los atributos de bridging no se pueden configurar en la interfaz virtual del grupo de bridges.

Porque puede haber solamente un Interfaz Virtual de Bridge-Group que representa a un Grupo de Bridge — y el Grupo de Bridge puede ser compuesto de diversos tipos de media configurados para varios diversos métodos de encapsulación — usted puede necesitar configurar el Interfaz Virtual de Bridge-Group con los métodos de encapsulación determinados requeridos conmutar los paquetes correctamente.

El servicio del DHCP del Cisco IOS en un CMTS

Los routeres Cisco que funcionan con el Cisco IOS Software Release 12.0(1)T o Posterior tienen la capacidad de funcionar como servidores DHCP. Este servicio del DHCP se puede configurar para proporcionar los arriendos del DHCP al Cable módems y al CPE, tal como PC y puestos de trabajo.

Hay un conjunto mínimo de la opción DHCP que el Cable módems requiere típicamente para venir en línea:

  • Una dirección de IP (el campo yiaddr en el encabezado de paquetes de DHCP)

  • Una máscara de subred (DHCP Opción 1)

  • El desplazamiento de hora local a partir de la hora media de Greenwich (GMT) en los segundos (opción DHCP 2)

  • Un router predeterminado (DHCP Opción 3)

  • La dirección IP de un servidor ToD (DHCP Opción 4)

  • El servidor de registro (Opción 7 de DHCP)

  • La dirección IP de un servidor TFTP (el campo siaddr en el encabezado de paquetes de DHCP)

  • El nombre de un archivo de configuración de DOCSIS (el campo file (archivo) en el encabezado de paquetes de DHCP)

  • Tiempo de validez de DHCP en segundos (Opción 51 de DHCP)

En el router, esas opciones se pueden configurar con estos comandos:

!
ip dhcp pool cm-platinum
 network 10.1.4.0 255.255.255.0
 bootfile platinum.cm
 next-server 10.1.4.1
 default-router 10.1.4.1
 option 7 ip 10.1.4.1
 option 4 ip 10.1.4.1
 option 2 hex ffff.8f80
 lease 7 0 10
!

Éstas son explicaciones de cada uno de esos comandos:

  • pool DHCP — Define el nombre del alcance del módem de cable (platino del centímetro).

  • red — Proporciona la dirección IP y la máscara de subred (opción DHCP 1).

  • bootfile — Proporciona el nombre del archivo del inicio que, en este caso, es platinum.cm.

  • siguiente-servidor — Especifica el TFTP Server IP Address que, en este caso, es el IP Address principal en el c4/0 de la interfaz.

  • valor por defecto-router — Define el default gateway que, en este caso, es el c4/0 del IP Address de interfaz primario (opción DHCP 3).

  • opción 7 — Define la opción DHCP del servidor de registro.

  • opción 4 — Proporciona la dirección IP del Servidor TOD (c4/0 del IP Address de interfaz primario).

  • opción 2 — Proporciona la opción de desplazamiento de tiempo para el GMT – 8 horas (– 8 horas de iguales – 28800 segundos, que iguala ffff.8f80 en los números hexadecimales).

    Nota: Para aprender más sobre cómo convertir un valor decimal del tiempo del desplazamiento en el hexadecimal, refiérase a cómo calcular el valor hexadecimal para la opción DHCP 2 (desplazamiento del tiempo).

  • arriendo — Fija el Tiempo de validez (7 días, 0 horas, 10 minutos).

Para los dispositivos CPE, estas opciones son el mínimo requerido para actuar con éxito:

  • Una dirección de IP (el campo yiaddr en el encabezado de paquetes de DHCP)

  • Una máscara de subred (DHCP Opción 1)

  • Un router predeterminado (DHCP Opción 3)

  • La dirección IP de uno o más DNS (opción DHCP 6)

  • Un nombre de dominio (DHCP Opción 15)

  • Tiempo de validez de DHCP en segundos (Opción 51 de DHCP)

En el router, esas opciones se pueden configurar con estos comandos:

! 
ip dhcp pool pcs-irb

!--- The scope for the hosts.

   network 172.16.29.0 255.255.255.224

!--- The IP address and mask for the hosts.

   next-server 172.16.29.1

!--- TFTP server; in this case, the secondary address is used.

   default-router 172.16.29.1
   dns-server 172.16.30.2

!--- DNS server (which is not configured on the CMTS).

   domain-name cisco.com
   lease 7 0 10
!

Mayor funcionalidad del servidor DHCP

Éstas son algunas otras funciones que se pueden utilizar del servidor DHCP del Cisco IOS Software:

  • ping DHCP del IP — Ping antes de la función del arriendo, que se asegura de que el servidor DHCP no publique los arriendos para los IP Addresses que son ya funcionando.

  • base de datos DHCP del IP — Una función que salva los atascamientos del DHCP en las bases de datos externas para mantener las relaciones del MAC-direccionamiento-a-IP-direccionamiento durante un ciclo del poder CMTS.

  • muestre el DHCP del IP — Un conjunto de comandos que se puede utilizar para monitorear la operación del servidor DHCP.

  • ip dhcp server del debug — Un conjunto de comandos que se puede utilizar para resolver problemas la operación del servidor DHCP.

Todas estas funciones y características adicionales se describen en las notas de versión de la función del servidor DHCP del Cisco IOS Software en el documento sobre el Cisco IOS DHCP Server.

El Cisco IOS servicio TFTP

Una vez que un cable módem ha intentado comunicarse con un servidor ToD, intenta comunicarse con un servidor TFTP para descargar un archivo de configuración DOCSIS. Si se puede copiar un archivo de configuración DOCSIS binario a un dispositivo flash en un sistema Cisco CMTS, entonces el router puede actuar como un servidor TFTP para ese archivo.

Éste es el procedimiento para descargar un archivo de configuración de DOCSIS en el flash:

  1. Publique este comando ping de asegurarse de que el CMTS puede alcanzar el servidor donde se localiza el archivo de configuración de DOCSIS.

    Ubr7111# ping 172.16.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
    
    !--- Output suppressed.
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
  2. Copie el archivo (en este caso, se llama silver.cm) en el flash del CMTS.

    Ubr7111# copy tftp flash
    
    Address or name of remote host []? 172.16.30.2
    Source filename []? silver.cm
    Destination filename [silver.cm]?
    
    Accessing tftp://172.16.30.2/silver.cm...
    Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
    [OK - 76/4096 bytes]
    
    76 bytes copied in 0.152 secs
  3. Marque el flash y verifiquelo que los tamaños del archivo están correctos, usando el comando dir.

    Ubr7111# dir
    
    Directory of disk0:/
    
       1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
       2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
    
    47890432 bytes total (17936384 bytes free)
  4. Para habilitar servicio TFTP encendido el CMTS, publique este comando en el modo de configuración global:

    tftp-server slot0:silver.cm alias silver.cm
    
  5. Confirme el paso 4 marcando para saber si hay estas líneas en la configuración:

    !
    tftp-server slot0:silver.cm alias silver.cm
    tftp-server server
    !

Para más información sobre la configuración de un servidor TFTP en un router, refiera al documento adicional de los comandos function de la transferencia de archivos.

El servicio del ToD del Cisco IOS

Después de que un módem de cable adquiera con éxito un arriendo del DHCP, entonces intenta entrar en contacto un Servidor TOD. Los productos CMTS de Cisco que funcionan con el Cisco IOS Software Release 12.0(4)XI o Posterior pueden proporcionar un servicioleavingcisco.com del ToD del RFC 868.

Un concepto erróneo común es que el servicio del ToD que el Cable módems necesita utilizar para venir en línea es lo mismo que el servicio del Network Time Protocol (NTP) que se configura comúnmente en los routeres Cisco. El servicio NTP y el servicio ToD son incompatibles. El Cable módems no puede hablar con un servidor NTP. Mientras que el Cable módems debe intentar entrar en contacto un Servidor TOD como parte del proceso de venir en línea, los módems que cumplen con las últimas revisiones de la especificación de la interferencia en radio frecuencia del DOCSIS 1.0 (RFI) todavía proceden a venir en línea incluso si un Servidor TOD no puede ser alcanzado.

De acuerdo con las versiones más recientes de la especificación, si un cable módem no puede comunicarse con un servidor ToD entonces puede continuar con el proceso de ponerse en línea. Debe, sin embargo, intentar periódicamente entrar en contacto el Servidor TOD hasta que sea acertado. Las versiones anteriores de la especificación RFI del DOCSIS 1.0 asignaron que por mandato, si un módem de cable no podría entrar en contacto un Servidor TOD, después el módem no podría venir en línea. Es importante tener en cuenta que es posible que los cablemódem que ejecutan firmware anteriores cumplan con esta versión anterior de la especificación.

Nota: El Cable módems de algunos vendedores no interopera con el servicio del ToD del Cisco IOS Software. Si estos módems cumplen con las versiones más recientes de la especificación RFI DOCSIS 1.0, deben continuar conectándose. Este problema de interoperabilidad está siendo abordado por el Id. de bug Cisco CSCdt24107 (clientes registrados solamente).

Para configurar el ToD en Cisco CMTS, publique estos comandos global:

service udp-small-servers max-servers no-limit
!
cable time-server
!

Generación de archivos de configuración DOCSIS interno

Los productos CMTS de Cisco que ejecutan la versión 12.1(2) o posterior del software IOS de Cisco (en el tren de la versión EC) pueden ser configurados para generar y guardar internamente archivos de configuración DOCSIS. El hacer tan es útil porque se lleva el requisito del tener acceso a una herramienta externa de la generación del archivo de configuración DOCSIS. Cuando un archivo de configuración de DOCSIS se crea usando la herramienta de configuración interna, el archivo se convierte en automáticamente TFTP directo disponible. Además, solamente el Cable módems en las interfaces del cable conectado puede directamente descargar estos archivos de configuración.

Estos ejemplos de configuración muestran la creación de dos archivos de configuración de DOCSIS.

El primer se llama disable.cm, que permite venga un módem de cable en línea pero evita que los dispositivos CPE conectados accedan la red del proveedor de servicio. En este caso, hay comando access-denied. Note que las velocidades rio abajo y por aguas arriba en este caso son 1 kbps, y los tamaños máximos de ráfaga son 1600 bytes.

cable config-file disable.cm
   access-denied
   service-class 1 max-upstream 1
   service-class 1 max-downstream 1600
   timestamp
!

Un operador de cable utiliza este archivo de configuración de DOCSIS de disable.cm para negar el acceso al CPE detrás del módem de cable mientras que todavía permite que el módem de cable venga en línea. Esto es una manera más eficiente de negar un servicio del CPE que usando la opción de la exclusión en el CNR, que no permite que venga el módem de cable en línea: el módem de cable intenta venir en línea y pierde en varias ocasiones el ancho de banda.

El Cable módems con este archivo de configuración de DOCSIS muestra esta salida, cuando publican el comando show cable modem:

Cable1/0/U0 10  online(d)  2287  0.50  6  0  10.1.4.65  0010.7bed.9b45

Los consejos de verificación para la sección de configuración avanzada de este documento dan más detalles sobre esta salida. El estatus en línea (d) significa que el Cable módems está en línea pero el acceso está negado.

En el segundo ejemplo, un archivo de configuración de DOCSIS llamado platinum.cm se crea. En este caso, el valor por aguas arriba máximo es 1 Mbps, el valor por aguas arriba garantizado es 100 kbps, el descendente máximo es 10 Mbps, y permite que hasta 30 dispositivos CPE sean conectados.

cable config-file platinum.cm
   service-class 1 max-upstream 1000
   service-class 1 guaranteed-upstream 100
   service-class 1 max-downstream 10000
   service-class 1 max-burst 1600
   cpe max 30
   timestamp
!

Note que, mientras que configura el archivo de configuración de DOCSIS en el CMTS, usted no necesita el servidor slot0:platinum.cm alias platinum.cm de tftp de la declaración porque no hay archivo de .cm salvado en la memoria; reside dentro de la configuración.

Otros detalles en la herramienta interna del archivo de configuración de DOCSIS se pueden encontrar en los comandos de Configuración CMTS de Cisco del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Una topología típica de la configuración de laboratorio se muestra en esta imagen:

/image/gif/paws/29243/ubr7100_config_bridge_2.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Esta configuración se soporta solamente en las plataformas CMTS del uBR7100.

La versión de Cisco IOS Software que soporta la configuración integral, incluyendo la configuración del archivo de configuración de DOCSIS, es Cisco IOS Software Release 12.1(2)EC y tren de EC las versiones subsiguientes. El tren del Cisco IOS Software que fue utilizado en esta configuración es ubr7100-ik1s-mz.121-11b.EC.bin.

Configuración integral básica

Esta configuración resume todos los pedazos explicados hasta ahora. Tiene dos alcances de DHCP: uno para el Cable módems y otro para los hosts detrás del Cable módems.

Se crea un archivo de configuración de DOCSIS, llamado platinum.cm. Este archivo se aplica al recurso compartido DHCP denominado cm-platinum. El otro archivo de configuración de DOCSIS, llamado disabled.cm, no se aplica cualquier cosa en el momento.

Los comentarios están en el azul, después de los Comandos relacionados. Los comandos de la configuración integral están resaltados en negrita.

Configuración integral básica
ubr7100# show run
Building configuration...
 
Current configuration : 3511 bytes
!
! Last configuration change at 01:12:37 PST Mon Sep 3 2001
!
version 12.1
no service pad
service timestamps debug datetime msec localtime

!--- Provides useful timestamps on all log messages.

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

!--- Supports a large number of modems or hosts attaching quickly.

 
!
hostname ubr7111
!
boot system flash disk0:ubr7100-ik1s-mz.121-11b.EC.bin
!
cable spectrum-group 3 frequency 40800000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver

!---  Allows cable modems to obtain ToD from the uBR7100.

!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 8
 timestamp
!
clock timezone PST -9
clock calendar-valid
ip subnet-zero
no ip routing

!--- Disables routing on the CMTS.

no ip domain-lookup

!--- Prevents the CMTS from looking up domain names or attempting 
!--- to connect to machines (for example, when mistyping commands).

ip host ubr7111 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
 
ip dhcp excluded-address 10.45.50.1 10.45.50.5
!
ip dhcp pool cm-platinum

!--- Name of the DHCP pool. This scope is for the cable modems attached 
!--- to interface cable 4/0.

   network 10.1.4.0 255.255.255.0

!--- Pool of addresses for scope modems-c1/0.

   bootfile platinum.cm

!--- DOCSIS configuration file name associated with this pool.

   next-server 10.1.4.1

!--- IP address of the TFTP server which sends the boot file.

   default-router 10.1.4.1

!--- Default gateway for cable modems; necessary to get DOCSIS files.

   option 7 ip 10.1.4.1

!--- Log Server DHCP option.

   option 4 ip 10.1.4.1

!--- ToD server IP address.

   option 2 hex ffff.8f80

!--- Time offset for ToD, in seconds (HEX), from GMT.
!--- Pacific Standard Time offset from GMT = –28,000 seconds = ffff.8f80

   lease 7 0 10

!--- Lease 7 days 0 hours 10 minutes.

! 
ip dhcp pool pcs-irb

!--- Name of the DHCP pool. This scope is for the CPE attached to
!--- the cable modems that are connected to interface cable 1/0.

   network 172.16.29.0 255.255.255.0

!--- Pool of addresses for scope pcs-c4 (associated with the secondary address).

   next-server 172.16.29.1
   default-router 172.16.29.1
   dns-server 172.16.29.1
   domain-name cisco.com
   lease 7 0 10
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 duplex half
 speed auto
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/1
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 shutdown
 duplex auto
 speed 10
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Cable1/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no keepalive
 cable packet-cache
 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 cable downstream frequency 525000000
 no cable downstream rf-shutdown
 cable downstream rf-power 55
 cable upstream 0 frequency 17808000
 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000
 no cable upstream 0 shutdown
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.1.4.1 255.255.255.0
!
ip default-gateway 14.66.1.1
ip classless
no ip http server
!
no cdp run
bridge 1 protocol ieee
 bridge 1 route ip
alias exec scm show cable modem
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 15
 login
!
end

Consejos de verificación para una configuración básica

En esta sección encontrará información que puede utilizar para corroborar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  1. Aseegurese que los comandos son soportados en la versión de Cisco IOS Software publicando un comando show version.

  2. Verifique que el archivo de configuración de DOCSIS esté en el flash.

    Ubr7111# dir
    
    Directory of disk0:/
     
        1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
        2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
     
    47890432 bytes total (17936384 bytes free)

    Nota: El archivo silver.cm fue construido usando la herramienta del DOCSIS CPE Configurator. Para el archivo del platinum.cm que fue construido en la Configuración CMTS, usted no necesita el servidor slot0:platinum.cm alias platinum.cm de tftp de la declaración porque no hay archivo de .cm; reside dentro de la configuración.

  3. Verifique que el Cable módems esté en línea publicando el comando show cable modem.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Note que todo el Cable módems está en línea. Los que está conectados con el cable de interfaz 1/0/U0 están en la red 10.1.4.0. Usted puede ver de la configuración que sus IP Addresses están tomados del agrupamiento DHCP llamado platino del centímetro.

    También note que el Cable módems con las direcciones MAC 0010.7bed.9b23 y 0010.7bed.9b45 tiene un CPE detrás de ellas. Estos cablemódems se conectan con la configuración predeterminada de conexión en puente. Esos PC se configuran con el DHCP de modo que puedan conseguir sus IP Addresses de la red.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Esta captura de pantalla muestra que esos PC consiguen una dirección IP de los pools llamados pcs-c4.

    ubr7100_config_bridge_3.gif

    Usted puede también ver de este PC que las configuraciones TCP/IP están fijadas para obtener la dirección IP automáticamente.

    ubr7100_config_bridge_4.gif

Configuración integral avanzada

Esta sección proporciona un ejemplo de configuración más sofisticado que implique la funcionalidad de jerarquía de los agrupamientos DHCP. Los trabajos de la jerarquía del agrupamiento DHCP de la manera son que cualquier agrupamiento DHCP con un network number que sea un subconjunto del network number de otra piscina hereda todas las características de ese otro pool. Esto evita la repetición en la configuración del servidor DHCP. Si, sin embargo, la misma especificación se hace con un diverso parámetro, después el parámetro está sobregrabado. Este ejemplo muestra a una agrupación general con un archivo del inicio llamado platinum.cm y un subconjunto de este pool con un archivo del inicio llamado disable.cm.

Además de los agrupamientos DHCP creados en el ejemplo básico, hay requisitos especiales para dos Cable módems.

Primero, el módem de cable 0010.7bed.9b45 se niega el acceso; se concede una dirección IP pero no viene en línea. Cree este pool:

ip dhcp pool cm-0010.7bed.9b45
   host 10.1.4.65 255.255.255.0
   client-identifier 0100.107b.ed9b.45
   bootfile disable.cm

La mayoría de la notable función de este ejemplo de configuración es la sección donde usted especifica a los agrupamientos DHCP especiales que corresponden a las direcciones MAC del cablemódem individual. Tal especificación permite que el servidor DHCP envíe la opción DHCP única a estos módems. Para especificar un cable módem determinado, se utiliza el parámetro del cliente-identificador. El cliente-identificador se debe fijar a 01, seguido por la dirección MAC del dispositivo al cual la entrada corresponde. Los 01 corresponde a los Ethernetes para el tipo de hardware del DHCP.

Nota: Al cambiar los archivos de configuración para un módem, usted debe hacer estos pasos para asegurarse de que el módem de cable consigue manualmente los parámetros configurados:

  1. Borre la tabla de vinculación IP DHCP publicando el comando clear ip dhcp binding ip address.

  2. Reajuste el módem de cable en la pregunta publicando el comando clear cable modem mac address res.

En segundo lugar, el módem de cable 0010.7bed.9b23 también tiene un requisito especial: consigue un diverso Calidad de Servicio (QoS). Por lo tanto, un diverso archivo del inicio se asocia al alcance, tal y como se muestra en de esta configuración parcial:

ip dhcp pool cm-0010.7bed.9b23
   host 10.1.4.66 255.255.255.0
   client-identifier 0100.107b.ed9b.23
   bootfile silver.cm
!

Al configurar a los agrupamientos DHCP para el Cable módems específico, es siempre una práctica adecuada dar un nombre relevante. También, porque una dirección IP específica se asigna al pool usando el comando host, usted debe publicar el comando global que el DHCP del IP excluye 10.1.4.60 10.1.4.70. Este comando dice el DHCP no utilizar los direccionamientos en este rango.

Consejos de verificación para una configuración avanzada

La verificación de esta configuración se centra en los servicios que el Cable módems está consiguiendo, especialmente 0010.7bed.9b45 y 0010.7bed.9b23. Usted debe estar seguro que están consiguiendo los direccionamientos con los cuales fueron configurados manualmente y el servicio.

La primera cosa a probar es que viene 0010.7bed.9b45 en línea, pero que el servicio está negado. Publique el comando show cable modem.

7246VXR# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable4/0/U0 7    online     2813    0.00  7   0   10.1.4.7        0002.1685.b5db
Cable4/0/U0 8    online     2809    0.25  7   0   10.1.4.10       0002.fdfa.0a63
Cable4/0/U0 9    online     2288   -0.25  5   1   10.1.4.66       0010.7bed.9b23
Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45
Cable4/0/U0 11   online     2809   -0.50  7   0   10.1.4.6        0001.64ff.e47d
Cable4/0/U0 12   online     2812   -0.50  7   0   10.1.4.9        0004.2752.ddd5

Note estos hechos:

  • El módem de cable 0010.7bed.9b23 consiguió a la dirección IP 10.4.1.66, como se especifica en el alcance cm-0010.7bed.9b23. Hay una computadora asociada y obtiene la dirección IP del agrupamiento pcs-c4.

  • El cablemódem 0010.7bed.9b23 tiene una QoS diferente.

  • El módem de cable 0010.7bed.9b45 consiguió a la dirección IP 10.1.4.65, como se especifica en el alcance cm-0010.7bed.9b45. Hay un ordenador asociado a él; el valor del CPE, sin embargo, es 0 porque se niega eso el servicio.

  • El estado en línea de 0010.7bed.9b45 está en línea (d), así que significa que viene el módem de cable en línea pero el acceso a la red de cable está negado.

    Considere esta salida del comando debug cable mac log verbose publicado en el módem de cable:

    21:52:16:  78736.550 CMAC_LOG_RESET_RANGING_ABORTED              
    21:52:16:  78736.554 CMAC_LOG_STATE_CHANGE                       reset_interface_state
    21:52:16:  78736.558 CMAC_LOG_STATE_CHANGE                       reset_hardware_state
    21:52:17:  78737.024 CMAC_LOG_STATE_CHANGE                       wait_for_link_up_state
    21:52:17:  78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET              0x082B9CA8
    21:52:17:  78737.032 CMAC_LOG_LINK_DOWN                          
    21:52:17:  78737.034 CMAC_LOG_LINK_UP                            
    21:52:17:  78737.040 CMAC_LOG_STATE_CHANGE                       ds_channel_scanning_state
    21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
    21:52:18:  78738.386 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:19:  78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED             747000000
    21:52:19:  78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED          
    21:52:19:  78739.704 CMAC_LOG_STATE_CHANGE                       wait_ucd_state
    21:52:20:  78740.368 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.396 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.398 CMAC_LOG_ALL_UCDS_FOUND                     
    21:52:22:  78742.402 CMAC_LOG_STATE_CHANGE                       wait_map_state
    21:52:22:  78742.406 CMAC_LOG_FOUND_US_CHANNEL                   1
    21:52:24:  78744.412 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:24:  78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY               39984000
    21:52:24:  78744.420 CMAC_LOG_SLOT_SIZE_CHANGED                  8
    21:52:24:  78744.500 CMAC_LOG_UCD_UPDATED                        
    21:52:24:  78744.560 CMAC_LOG_MAP_MSG_RCVD                       
    21:52:24:  78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS          41
    21:52:24:  78744.566 CMAC_LOG_STATE_CHANGE                       ranging_1_state
    21:52:24:  78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO              9610
    21:52:24:  78744.574 CMAC_LOG_POWER_LEVEL_IS                     55.0  dBmV (commanded)
    21:52:24:  78744.578 CMAC_LOG_STARTING_RANGING                   
    21:52:24:  78744.580 CMAC_LOG_RANGING_BACKOFF_SET                0
    21:52:24:  78744.586 CMAC_LOG_RNG_REQ_QUEUED                     0
    21:52:24:  78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:24:  78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:24:  78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED               10
    21:52:24:  78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET              2286
    21:52:24:  78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO              11896
    21:52:24:  78744.638 CMAC_LOG_STATE_CHANGE                       ranging_2_state
    21:52:24:  78744.644 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:25:  78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:25:  78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:25:  78745.660 CMAC_LOG_RANGING_SUCCESS                    
    21:52:25:  78745.680 CMAC_LOG_STATE_CHANGE                       dhcp_state
    21:52:25:  78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS           10.1.4.65
    21:52:25:  78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS           10.1.4.1
    21:52:25:  78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS            10.1.4.1
    21:52:25:  78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS           
    21:52:25:  78745.834 CMAC_LOG_DHCP_TZ_OFFSET                     -28800
    21:52:25:  78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME              disable.cm
    21:52:25:  78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR  
    21:52:25:  78745.846 CMAC_LOG_DHCP_COMPLETE                      
    21:52:25:  78745.968 CMAC_LOG_STATE_CHANGE                       establish_tod_state
    21:52:25:  78745.978 CMAC_LOG_TOD_REQUEST_SENT                   
    21:52:26:  78746.010 CMAC_LOG_TOD_REPLY_RECEIVED                 3192525217
    21:52:26:  78746.018 CMAC_LOG_TOD_COMPLETE                       
    21:52:26:  78746.020 CMAC_LOG_STATE_CHANGE                       security_association_state
    21:52:26:  78746.024 CMAC_LOG_SECURITY_BYPASSED                  
    21:52:26:  78746.028 CMAC_LOG_STATE_CHANGE                       configuration_file_state
    21:52:26:  78746.030 CMAC_LOG_LOADING_CONFIG_FILE                disable.cm
    21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
    21:52:27:  78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE       
    21:52:27:  78747.066 CMAC_LOG_STATE_CHANGE                       registration_state
    21:52:27:  78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED                 
    21:52:27:  78747.076 CMAC_LOG_REG_REQ_TRANSMITTED                
    21:52:27:  78747.080 CMAC_LOG_REG_RSP_MSG_RCVD                   
    21:52:27:  78747.082 CMAC_LOG_COS_ASSIGNED_SID                   1/10
    21:52:27:  78747.088 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:27:  78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED
    21:52:27:  78747.094 CMAC_LOG_REGISTRATION_OK                    
    21:52:27:  78747.096 CMAC_LOG_STATE_CHANGE                       establish_privacy_state
    21:52:27:  78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED             
    21:52:27:  78747.102 CMAC_LOG_STATE_CHANGE                       maintenance_state
    21:52:31:  78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:31:  78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:37:  78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:37:  78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:43:  78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:43:  78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:49:  78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:49:  78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

    La salida de esta depuración muestra que el Acceso a la red está denegado.

Ubr7100# show cable modem detail

Interface   SID  MAC address    Max CPE  Concatenation  Rx SNR
Cable1/0/U0 7    0002.1685.b5db 10       yes            33.52
Cable1/0/U0 8    0002.fdfa.0a63 10       yes            33.24
Cable1/0/U0 9    0010.7bed.9b23 1        no             33.29
Cable1/0/U0 10   0010.7bed.9b45 1        no             33.23
Cable1/0/U0 11   0001.64ff.e47d 10       yes            33.20
Cable1/0/U0 12   0004.2752.ddd5 10       yes            33.44

Note que el CPE máximo para el Cable módems con los alcances especiales es 1 y el resto son 10. Si usted ve el platinum.cm de la configuración de alcance, hace 10 CPE especificar; por otra parte, el alcance disable.cm tiene solamente 1 CPE especificado. El archivo de configuración de DOCSIS preconfigurado silver.cm tiene también solamente 1 CPE especificado.

Ubr7111# show interface cable 1/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.1.4.7      dhcp      0002.1685.b5db
8     00         modem     up        10.1.4.10     dhcp      0002.fdfa.0a63
9     00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
9     00         modem     up        10.1.4.66     dhcp      0010.7bed.9b23
10    00         modem     up        10.1.4.65     dhcp      0010.7bed.9b45
11    00         modem     up        10.1.4.6      dhcp      0001.64ff.e47d
12    00         modem     up        10.1.4.9      dhcp      0004.2752.ddd5

Para verificar que el Cable módems esté consiguiendo el nivel correcto de servicio, publique el comando show cable qos profile.

Ubr7111# show cable qos profile

ID  Prio Max       Guarantee Max        Max   TOS  TOS   Create  B     IP prec.
         upstream  upstream  downstream tx    mask value by      priv  rate
         bandwidth bandwidth bandwidth  burst                    enab  enab
1   0    0         0         0          0     0x0  0x0   cmts(r) no    no
2   0    64000     0         1000000    0     0x0  0x0   cmts(r) no    no
3   7    31200     31200     0          0     0x0  0x0   cmts    yes   no
4   7    87200     87200     0          0     0x0  0x0   cmts    yes   no
5   4    64000     0         512000     0     0x0  0x0   cm      no    no
6   0    1000      0         1600000    0     0x0  0x0   cm      no    no
7   0    128000    10000     10000000   1600  0x0  0x0   cm      no    no
8   0    0         0         0          0     0x0  0x0   mgmt    no    no
10  0    0         0         0          0     0x0  0x0   mgmt    no    no
12  0    0         100000000 0          0     0x0  0x0   mgmt    no    no

Note que el ID de Calidad de servicio (QoS) 7 hace juego la configuración en el platinum.cm:

cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp

Lo mismo sucede con la configuración de DOCSIS de disable.cm:

Ubr7111# show ip dhcp binding

IP address       Hardware address        Lease expiration        Type
10.1.4.6         0100.0164.ffe4.7d       Mar 08 2001 07:58 AM    Automatic
10.1.4.7         0100.0216.85b5.db       Mar 08 2001 07:58 AM    Automatic
10.1.4.9         0100.0427.52dd.d5       Mar 08 2001 07:58 AM    Automatic
10.1.4.10        0100.02fd.fa0a.63       Mar 08 2001 08:36 AM    Automatic
10.1.4.65        0100.107b.ed9b.45       Infinite                Manual
10.1.4.66        0100.107b.ed9b.23       Infinite                Manual

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 29243