Switching por etiquetas multiprotocolo (MPLS) : MPLS

Soporte multidifusión para el ejemplo de configuración del MPLS VPNs

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento brinda un ejemplo de configuración y una guía general para configurar el soporte de Multicast para las VPN de Multiprotocol Label Switching (MPLS). Esta característica fue introducida en el ½ 12.2(13)T del ¿Â del andï del Software Release 12.0(23)S del½ del¿Â del Cisco IOSïÂ.

prerrequisitos

Requisitos

Antes de utilizar esta configuración, asegúrese de que cumple con estos requisitos:

  • Los proveedores de servicio deben tener una base habilitada para multicast para utilizar la característica del Multicast VPN de Cisco.

Componentes Utilizados

La información de este documento se basa en la versión 12.2(13)T del software del IOS de Cisco

Nota: Para obtener información actualizada acerca del soporte de plataforma para esta característica, utilice el Software Advisor (sólo para clientes registrados). El Software Advisor pone al día dinámicamente la lista de plataformas admitidas mientras que el nuevo Soporte de la plataforma se agrega para la característica.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

Para la información previa, refiera a la documentación de la nueva función del Cisco IOS Software Release 12.2(13)T para el soporte del Multicast IP para el MPLS VPNs.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/29220/config_mpls_vpn1.gif

Configuraciones

El diagrama de la red representa la estructura básica de un proveedor de servicio. Esto consiste en el r2 del Routers, el R3, y el R4. La estructura básica está configurada para admitir VPN MPLS. R2 y R4 son routers de Borde del proveedor (PE) mientras que R3 es un router del Proveedor (P). R1 y R5 representan los routers de borde del cliente (CE) que pertenecen a la misma instancia de ruteo o reenvío VPN, amarillo.

Para proporcionar los servicios de multidifusión, la estructura básica se debe configurar para ejecutar el ruteo multicast. El Protocolo independent multicast (PIM) y R3 se configuran como Punto de encuentro (RP). El r2 y el R4 también se configuran para ejecutar el ruteo multicast en el amarillo VRF. El modo escaso-denso PIM se configura como el Multicast Routing Protocol entre los PE y los CE. R2 ha sido configurado para ser el RP para el amarillo del VRF.

Para probar la Conectividad del Multicast, la interfaz s0/0 del R5 se configura para unirse al grupo de multidifusión 224.2.2.2. Los ping se envían de la dirección de loopback de R1 a 224.2.2.2. El eco del protocolo de mensajes de control de Internet (ICMP) es un paquete multidifusión, mientras que la respuesta ICMP es un paquete unidifusión dado que la dirección IP de destino es la dirección de loopback R1.

Las configuraciones presentadas en este documento incluyen éstos:

r1-(CE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip multicast-routing 

!--- Enable multicast routing.

!
!
interface Loopback0
 ip address 100.0.0.1 255.255.255.255
!
interface Serial0/0
 ip address 10.1.0.1 255.255.255.0
 ip pim sparse-dense-mode

!--- PIM sparce-dense mode is used between the PE and CE.
!--- PIM sparce-dense mode is the multicast routing protocol.

 
!
router rip
 version 2
 network 10.0.0.0
 network 100.0.0.0
 no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!         
end

r2-(PE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip vrf yellow
 rd 2:200
 route-target export 2:200
 route-target import 2:200
 mdt default 239.1.1.1

!--- Configure the default Multicast Distribution Tree (MDT) 
!--- for VRF yellow.

 mdt data 239.2.2.0 0.0.0.255 threshold 1

!--- Configure the range global addresses for 
!--- data MDTs and the threshold.

ip multicast-routing 

!--- Enable global multicast routing.

ip multicast-routing vrf yellow 

!--- Enable multicast routing in VRF yellow.

ip cef
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
!
!
interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip pim sparse-dense-mode


!--- Multicast needs to be enabled on loopback 
!--- interface. This is used as a source  
!--- for MPBGP sessions between PE routers that participate in MVPN.


!
interface Loopback100
 ip vrf forwarding yellow
 ip address 100.0.0.2 255.255.255.255
 ip pim sparse-dense-mode
!

!--- This router needs to be RP for 
!--- multicast in VRF yellow. Therefore, multicast
!--- needs to be enabled on the interface which is used as RP.


!
interface Serial1/0
 ip vrf forwarding yellow
 ip address 10.1.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Multicast is enabled on PE-CE interfaces in VRF.


!         
interface Serial2/0
 ip address 10.2.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Service provider core needs to run multicast
!--- to support MVPN services,
!--- so multicast is enabled on PE-P links.


 tag-switching ip        
!         
router ospf 1
 router-id 50.0.0.2
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.0.0.255 area 0
!
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf yellow
 version 2
 redistribute bgp 1
 network 10.0.0.0
 network 100.0.0.0
 default-metric 5
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 redistribute rip
 neighbor 50.0.0.4 remote-as 1
 neighbor 50.0.0.4 update-source Loopback0
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.6 remote-as 1
 neighbor 50.0.0.6 update-source Loopback0
 neighbor 50.0.0.6 activate
 no auto-summary
 !
 address-family ipv4 vrf yellow
 redistribute connected
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.4 send-community extended
 neighbor 50.0.0.6 activate
 neighbor 50.0.0.6 send-community extended
 no auto-summary
 exit-address-family
!         
ip classless
no ip http server
ip pim bidir-enable
ip pim vrf yellow send-rp-announce Loopback100 scope 100
ip pim vrf yellow send-rp-discovery Loopback100 scope 100

!--- Configure auto-RP. The R2's loopback 
!--- 100 is the RP in VRF yellow.

!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

R3-(P)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R3 
! 
! 
clock timezone CET 1 
ip subnet-zero 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.3 255.255.255.255 
 ip pim sparse-dense-mode 
! 
! 
interface Serial1/0 
 ip address 10.2.0.3 255.255.255.0 
 ip pim sparse-dense-mode

!--- Enable multicast on links to PE routers 
!--- which have MVPNs configured.

 
 tag-switching ip 
! 
interface Serial2/0 
 ip address 10.3.0.3 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
router ospf 1 
 router-id 50.0.0.3 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
ip pim send-rp-announce Loopback0 scope 100 
ip pim send-rp-discovery Loopback0 scope 100 

!--- R3 is configured to announce itself as 
!--- the RP through auto-RP.
 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login  
! 
end

R4-(PE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R4 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip vrf yellow 
 rd 2:200 
 route-target export 2:200 
 route-target import 2:200 
 mdt default 239.1.1.1 

!--- Configure the default MDT address.
 
 mdt data 238.2.2.0 0.0.0.255 threshold 1 

!--- Configure the data MDT range and threshold.
 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip multicast-routing vrf yellow  

!--- Enable multicast routing in VRF yellow.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Loopback100 
 ip vrf forwarding yellow 
 ip address 100.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Serial1/0 
 ip address 10.3.0.4 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
interface Serial2/0 
 ip vrf forwarding yellow 
 ip address 10.4.0.4 255.255.255.0 
 ip pim sparse-dense-mode 

!--- Enable the PIM toward the CE.
 
! 
router ospf 1 
 router-id 50.0.0.4 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
router rip 
 version 2 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 version 2 
 redistribute bgp 1 
 network 10.0.0.0 
 network 100.0.0.0 
 default-metric 5 
 no auto-summary 
 exit-address-family 
! 
router bgp 1 
 no synchronization 
 no bgp default ipv4-unicast 
 bgp log-neighbor-changes 
 redistribute rip 
 neighbor 50.0.0.2 remote-as 1 
 neighbor 50.0.0.2 update-source Loopback0 
 neighbor 50.0.0.2 activate 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 redistribute connected 
 redistribute rip 
 no auto-summary 
 no synchronization 
 exit-address-family 
 ! 
 address-family vpnv4 
 neighbor 50.0.0.2 activate 
 neighbor 50.0.0.2 send-community extended 
 no auto-summary 
 exit-address-family 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
! 
end

R5-CE
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R5 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip multicast-routing  

!--- Enable global multicast routing in the CE.
 
! 
! 
interface Loopback0 
 ip address 100.0.0.5 255.255.255.255 
! 
interface Serial0/0 
 ip address 10.4.0.5 255.255.255.0 
 ip pim sparse-dense-mode 
 ip igmp join-group 224.2.2.2 
! 
router rip 
 version 2 
 network 10.0.0.0 
 network 100.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
!          
end

Consejos sobre diseño

  • El Multicast para el MPLS VPNs (MVPN) se configura encima de la configuración VPN. La red del MPLS VPN necesita ser diseñada cuidadosamente, para observar todas las recomendaciones para las redes del MPLS VPN primero.

  • El núcleo del proveedor del servicio debe configurarse para el servicio nativo de multidifusión. Se debe configurar el núcleo para Modo disperso de PIM (PIM-SM), Multidifusión específica de Fuente (PIM-SSM) o PIM bidireccional (PIM-BIDIR). No soportan al modo PIM denso (PIM-DM) como protocolo de la base en configuraciones de MVPN. Es posible configurar una mezcla de protocolos admitidos en la base del proveedor. Esto puede ser hecha cuando a un modo PIM manejan a algunos grupos de multidifusión y a otro modo PIM soportado manejan a algunos otros grupos.

  • Todos los protocolos del Multicast se soportan dentro del Multicast VRF. Esto quiere decir que, dentro de un VRF de multidifusión, usted puede usar MSDP y PIM-DM además de PIM-SM, PIM-SSM y PIM-BIDIR

  • El servicio MVPN puede agregarse de forma separada VRF por VRF. Es decir, un router PE puede tener configurados tanto VRF activados por multidifusión como VRF de sólo unidifusión.

  • No todos los sitios de un solo unicast VRF se deben configurar para el Multicast. Es posible tener algunos sitios (e incluso interfaces del router MVPN PE) donde el Multicast no se habilita. Usted debe asegurarse de que las rutas nunca estén calculadas para señalar a las interfaces habilitadas del NON-Multicast. De lo contrario, el reenvío de multidifusión se interrumpirá.

  • Más de un VRF puede pertenecer al mismo dominio de multidifusión MVPN. El IP Addressing debe ser único dentro de un dominio del Multicast. El escaparse de las rutas y/o de los paquetes entre los dominios del Multicast o en un tabla de Multicast Routing global no es actualmente posible.

  • Una configuración predeterminada MDT es obligatoria para que el MVPN trabaje. Configurar los datos MDT es opcional. Se recomienda altamente para fijar el umbral para datos MDT si usted elige configurar uno.

  • La dirección de IP del MDT predeterminado, determina a cuál VRF de dominio multidifusión pertenece. Por lo tanto, es posible tener la misma dirección MDT predeterminada para más de un VRF. Sin embargo, compartirán los paquetes de multidifusión entre ellos y deben observar otros requisitos en los dominios del Multicast (tales como esquema de IP Addressing único).

  • Los datos MDT pudieron o no se pudieron configurar con el mismo rango de los IP Addresses en diverso Routers PE. Esto depende de qué modo PIM se utilice en el núcleo de un proveedor. Si la base del proveedor de servicio está utilizando al modo disperso de PIM, después cada router PE debe utilizar un rango único de los IP Addresses para los grupos de los datos MDT. Si la base del proveedor de servicio está utilizando el Source-Specific Multicast, después todo el Routers PE pudo ser configurado con el mismo rango de los IP Addresses para los datos MDT de cada dominio del Multicast.

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre a los grupos IGMP del IP — Visualiza a los grupos de multidifusión con los receptores que están conectados directamente con el router y que eran doctos con el Internet Group Management Protocol (IGMP).

  • muestre el BGP del mdt del pim del IP — Las visualizaciones detallaron el anuncio del Border Gateway Protocol (BGP) del Route Distinguisher (RD) para el grupo predeterminado MDT.

  • el mdt del <vrf-name> del vrf del pim del IP de la demostración envía — visualiza los anuncios de datos MDT que el router ha hecho en el VRF especificado.

  • el mdt del <vrf-name> del vrf del pim del IP de la demostración recibe — visualiza los anuncios de datos MDT recibidos por el router en el VRF especificado.

  • show ip mroute—Muestra el contenido de la tabla de ruteo de multidifusión IP en el núcleo del proveedor.

  • muestre el <vrf-name> del vrf de la ruta multicast del IP — Visualiza el tabla de Multicast Routing en el VRF del cliente.

Complete estos pasos para verificar que su configuración está trabajando correctamente.

  1. Marque que los PE se han unido a al grupo IGMP para el túnel del valor por defecto MDT.

    Si se configura después de que publiquen el comando default-mdt bajo configuración de VRF, el PE pudo no poder unirse a al grupo del valor por defecto MDT. Una vez que se configura el loopback, quite el comando mdt del VRF y colóquelo nuevamente para resolver el problema.

    • Para el PE-R2, publique el comando show ip igmp groups.

      IGMP Connected Group Membership
      Group Address  Interface   Uptime     Expires   Last Reporter
      224.0.1.40     Serial2/0   02:21:23   stopped   10.2.0.2
      239.1.1.1      Loopback0   02:36:59   stopped   0.0.0.0
    • Para el PE-R4, publique el comando show ip igmp groups.

      IGMP Connected Group Membership 
      Group Address  Interface    Uptime    Expires   Last Reporter
      224.0.1.40     Loopback0    02:51:48  00:02:39  50.0.0.4
      239.1.1.2      Loopback0    02:51:45  stopped   0.0.0.0
      239.1.1.1      Loopback0    02:51:45  stopped   0.0.0.0
      239.2.2.0      Loopback0    01:40:03  stopped   0.0.0.0 
  2. Marque el anuncio de BGP recibido para cada PE.

    Nota: Por este ejemplo, marque la fuente del MDT del par PE PE-R2 y PE-R4.

    • Para el PE-R2, publique el comando show ip pim mdt bgp.

      MDT-default group 239.1.1.1 
      rid: 50.0.0.4 next_hop: 50.0.0.4 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0
    • Para el PE-R4 publique el comando show ip pim mdt bgp

      MDT-default group 239.1.1.1 
      rid: 50.0.0.2 next_hop: 50.0.0.2 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0 
      MDT-data   : 239.2.2.0  Tunnel0     source-interface: Loopback0 
  3. Marque los datos MDT.

    Nota: Por este ejemplo, marque los datos que originos MDT o unido a por el PE-R2 y el PE-R4.

    • Para el PE-R2, publique el comando show ip pim vrf yellow mdt send.

      MDT-data send list for VRF: yellow 
        (source, group)                     MDT-data group      ref_count 
        (100.0.0.1, 224.2.2.2)              239.2.2.0           1 
    • Para el PE-R2, publique el comando show ip pim vrf yellow mdt receive.

      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group
      Joined MDT-data groups for VRF: yellow 
        group: 239.2.2.0 source: 0.0.0.0 ref_count: 1 
    • Marque el tabla de Multicast Routing global para el valor por defecto MDT.

      Nota: Note esta información:

      1. La lista de interfaz de salida es amarillo MVRF en los PE.

      2. El router P ve al grupo como grupo de multidifusión regular.

      3. Cada PE es una fuente para el valor por defecto MDT, y está solamente en el Routers PE.

      4. Un nuevo indicador, Z, indica que esto es un túnel del Multicast.

    • Para el PE-R2, publique el comando de 239.1.1.1 de la ruta multicast del IP de la demostración.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:37:16/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28 
      
      (50.0.0.2, 239.1.1.1), 02:37:12/00:03:29, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:36:09/00:02:33 
      (
      50.0.0.4, 239.1.1.1), 02:36:02/00:02:59, flags: JTZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28
    • Para el P-R3, publique el comando de 239.1.1.1 de la ruta multicast del IP de la demostración.

       
      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:50:24/stopped, RP 50.0.0.3, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.2, 239.1.1.1), 02:49:56/00:03:23, flags: T 
        Incoming interface: Serial1/0, RPF nbr 10.2.0.2 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.4, 239.1.1.1), 02:49:47/00:03:23, flags: T 
        Incoming interface: Serial2/0, RPF nbr 10.3.0.4 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
    • Para el PE-R4, publique el comando de 239.1.1.1 de la ruta multicast del IP de la demostración.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:51:06/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:51:06/00:00:48 
      
      (50.0.0.2, 239.1.1.1), 02:50:06/00:02:58, flags: JTZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:50:06/00:00:48 
      
      (50.0.0.4, 239.1.1.1), 02:51:00/00:03:10, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:35:24/00:03:00 
  4. Marque el tabla de Multicast Routing global para los datos MDT.

    Nota: Para el PE-R2, note que la interfaz saliente es tunnel0.

    • Para el PE-R2, donde se localiza la fuente (lado VRF), publique el comando de 224.2.2.2 del amarillo del vrf de la ruta multicast del IP de la demostración.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 224.2.2.2), 2d01h/stopped, RP 100.0.0.2, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 2d01h/00:02:34 
      
      (100.0.0.1, 224.2.2.2), 00:05:32/00:03:26, flags: Ty 
        Incoming interface: Serial1/0, RPF nbr 10.1.0.1 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 00:05:37/00:02:34
    • Para el PE-R2, donde se localiza la fuente (ruta de Multicast global), publique el comando de 239.2.2.0 de la ruta multicast del IP de la demostración.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.2.2.0), 02:13:27/stopped, RP 50.0.0.3, flags: SJPFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: Null 
      
      (50.0.0.2, 239.2.2.0), 02:13:27/00:03:22, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:13:27/00:03:26

    Nota: Sólo el router PE conectado al origen de multidifusión aparece como el origen para el tráfico de multidifusión de la dirección del grupo de datos MDT.

Troubleshooting

  • Publique el comando show ip pim vrf neighbor de marcar que el Routers PE estableció una relación del vecino del PIM a través de la interfaz del túnel dinámico. Si él hizo, después el MDT predeterminado actúa correctamente.

  • Si no funciona el MDT predeterminado, publique el comando show ip pim mdt bgp de marcar que los loopback del Routers remoto PE que participa en el MVPN son sabidos por el router local. Si él no es, verifique que el PIM esté habilitado en las interfaces del loopback usadas como fuente de sesiones de BGP MP

  • Marque que la base SP está configurada correctamente para entregar el Multicast entre el Routers PE. Para las para pruebas usted puede ser que configure el unir a-grupo del igmp del IP en el Loopback Interface de un router PE y haga el ping del Multicast originado del loopback de otro router PE.


Información Relacionada


Document ID: 29220