Banda ancha por cable : Sistemas de terminación de cable módems (CMTS)

Configuración de los servicios TFTP, DHCP, ToD en CMTS de Cisco: ‘Configuración integral

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra una configuración en el Sistema de terminación del cablemódem (CMTS) de Cisco que funciona como Protocolo de configuración dinámica de host (DHCP), ToD y servidor TFTP. También incluye la explicación para crear el archivo de configuración DOCSIS utilizando la CLI en el CMTS. Esta configuración se conoce como "configuración integral para CMTS de Cisco".

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

La persona que lea el material debe tener conocimientos básicos sobre el protocolo DOCSIS y la línea de comando Cisco IOS en los routers de serie uBR.

Componentes Utilizados

El uso de hardware en este documento es desde los cables módem Cisco uBR7200, uBR7100 o uBR10k CMTS y DOCSIS que cumplen con la norma.

Descripción

Un cablemódem que cumple con la norma DOCSIS requiere de tres tipos de servidores para conectarse de forma satisfactoria.

  • El primero es un servidor DHCP, que proporciona el cable módem con una dirección IP, una máscara de subred y otros parámetros relacionados con IP.

  • El segundo es un servidor de Hora del día (ToD) RFC868 compatible con RFC868 que le permite al módem saber cuál es la hora actual. El módem de cable necesita saber el tiempo para poder agregar correctamente indicadores de fecha y hora precisos en el registro de acontecimientos.

  • El tercero es un servidor del Trivial File Transfer Protocol (TFTP) del cual un módem de cable puede descargar un archivo de configuración de DOCSIS que contiene los parámetros del funcionamiento del específico del módem de cable.

La mayoría de los operadores de cable utilizan Cisco Network Registrar (CNR) como servidores de DHCP, DNS y TFTP. El servidor ToD no forma parte del CNR. El Servidor TOD se utiliza que depende de la plataforma de su sistema. El ToD debe ser RFC868 obediente. Para los sistemas UNIX, está incluido en Solaris, sólo es necesario asegurarse de que el archivo "inetd.conf" que reside en el directorio "/etc" contenga las siguientes líneas:

# Time service is used for clock synchronization.
#
time��� stream� tcp���� nowait� root��� internal
time��� dgram�� udp���� wait��� root��� internal

Para Windows, la mayoría del software común se utiliza que es Greywareleavingcisco.com .

La tabla siguiente muestra las versiones de software de Cisco IOS� en las cuales diversas Capacidades del servidor se han agregado al CMTS.

Capacidades del servidor Versión de software del IOS de Cisco
DHCP 12.0(1)T
ToD 12.0(4)XI�
TFTP 11.0 (para todas las plataformas)

Este documento explicará cada una de las características. La configuración en el CMTS que contiene todas estas capacidades es lo que llamamos “configuración integral para los cmts”. Con esta configuración, no necesita ningún servidor adicional para probar su red de cables y brindar acceso a Internet de alta velocidad.

También se puede configurar un archivo de configuración DOCSIS que se encuentra en CMTS, en lugar de en el servidor TFTP. De acuerdo con las notas de la versión, necesita al menos la versión de software 12.1(2)EC1 de Cisco IOS para usar esta función.

Aunque esta “configuración integral” sea muy conveniente para el ambiente de laboratorio, las pruebas iniciales, las pequeñas implementaciones, y localizar averías, no es scalable soportar un gran número de Cable módems. No se recomienda tan para utilizar esta configuración en las plantas de cable operativas con las implementaciones grandes del Cable módems.

Los ingenieros del TAC utilizan esta configuración con mucha frecuencia para poder eliminar variables al solucionar problemas de cables.

El servicio de Protocolo de configuración de host dinámico (DHCP) del IOS de Cisco en un CMTS

Los routers Cisco que ejecutan la versión 12.0(1)T de software del IOS de Cisco o una versión posterior tienen la capacidad de actuar como servidores DHCP. Este servicio del DHCP se puede configurar para proporcionar los arriendos del DHCP al Cable módems y al equipo en las instalaciones del cliente (CPE) por ejemplo los PC y los puestos de trabajo.

Hay un conjunto mínimo de opciones DHCP que los cablemódems generalmente requieren para conectarse. Estos incluyen:

  • Una dirección de IP (el campo yiaddr en el encabezado de paquetes de DHCP)

  • Una máscara de subred (DHCP Opción 1)

  • El ajuste de la hora local del GMT en segundos (DHCP Opción 2)

  • Un router predeterminado (DHCP Opción 3)

  • La dirección IP de un servidor ToD (DHCP Opción 4)

  • El servidor de registro (opción DHCP 7)

  • La dirección IP de un servidor TFTP (el campo siaddr en el encabezado de paquetes de DHCP)

  • El nombre de un archivo de configuración de DOCSIS (el campo file (archivo) en el encabezado de paquetes de DHCP)

  • Tiempo de validez de DHCP en segundos (Opción 51 de DHCP)

En el router, esto puede configurarse de la siguiente manera:

!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!

La explicación de cada comando es como sigue:

  • El comando dhcp pool define el nombre del alcance (cm-platinum que significa servicio platino para cablemódems).

  • La red provee la dirección IP y la máscara de subred (opción DHCP 1).

  • El archivo de inicialización proporciona el nombre del archivo de inicialización, en este caso es platinum.cm.

  • El comando next-server especifica la dirección IP del servidor TFTP (en este caso es la dirección ip principal en la interfaz c4/0).

  • El valor por defecto-router es el default gateway, que en este caso es el c4/0 del IP Address de interfaz primario (option3).

  • La opción 7 es la opción DHCP del servidor de registro.

  • La opción 4 es la dirección IP del servidor ToD (dirección IP principal de interfaz c4/0).

  • Opción 2 es la opción de desplazamiento de tiempo para GMT - 8 hs (-8 hs = - 28800 seg = fff.8f80 en hexadecimal).

  • El Tiempo de validez es 7 días 0 horas 10 minutos.

Nota: Para más información acerca de cómo convertir un valor decimal de desplazamiento del tiempo a hexadecimal, consulte Consejos técnicos sobre cómo calcular el valor hexadecimal para DHCP opción 2 (desplazamiento del tiempo).

Para los dispositivos CPE las opciones siguientes son las mínimas para poder actuar con éxito.

  • Una dirección de IP (el campo yiaddr en el encabezado de paquetes de DHCP)

  • Una máscara de subred (DHCP Opción 1)

  • Un router predeterminado (DHCP Opción 3)

  • La dirección IP de uno o más Servidores de nombre de dominio (DHCP Opción 6)

  • Un nombre de dominio (DHCP Opción 15)

  • Tiempo de validez de DHCP en segundos (Opción 51 de DHCP)

!
ip dhcp pool pcs-c4�

! -- the scope for the hosts

    network 172.16.29.0 255.255.255.224

! -- the ip address and mask for the hosts

��� next-server 172.16.29.1

! -- tftp server, in this case we put the secondary add.

��� default-router 172.16.29.1
��� dns-server 172.16.30.2

! -- dns server (which is not configured on the cmts)

��� domain-name cisco.com
��� lease 7 0 10
!

Al configurar a los pools DHCP, es importante incluir el comando cable dhcp-giaddr policy en la configuración de la interfaz del cable. Este comando tiene el efecto de indicar al servidor DHCP que asigne locaciones a los cable módems que corresponden al número de red principal en la interfaz del cable y locaciones a los CPE que corresponden al número de red secundario en la interfaz del cable. Si este comando falta entonces todos los arriendos del DHCP vendrán del pool correspondiente al número de red principal en la interfaz del cable. Además, como veremos en la configuración parcial de la interfaz a continuación, el alcance de cm-platinum está asociado con la primera dirección definida en el cable de interfaz 4/0 y el alcance de pcs-c4 se encuentra en la red de la segunda dirección.

!
interface Cable4/0
�� ip address 172.16.29.1 255.255.255.224 secondary

! -- CPE network

�� ip address 10.1.4.1 255.255.255.0

! -- Cable Modem Network

�� cable dhcp-giaddr policy
!

Nótese que no existe un comando cable helper-address o ip helper-address en la interfaz de cable. Esto es porque las solicitudes DHCP no necesitan reenviarse a un servidor externo cuando se utiliza un servidor DHCP del IOS. Si se agrega este comando por debajo de la interfaz y hay un servidor DHCP configurado, los cablemódems se registrarán con la configuración del DHCP externo.

Mayor funcionalidad del servidor DHCP

A continuación se detallan otras funciones que pueden utilizarse con el servidor DHCP del IOS de Cisco:

  • ip dhcp ping: Ping antes de que función del arriendo que se asegura de que el servidor DHCP no publique los arriendos para los IP Addresses que son ya funcionando.

  • ip dhcp database: Almacenamiento de vinculaciones DHCP en una base de datos externa a fin de mantener la dirección MAC para relaciones de direcciones IP en un ciclo de potencia del CMTS.

  • muestre el DHCP del IP: Un conjunto de comandos que puede usarse para monitorear el funcionamiento del servidor DHCP.

  • debug ip dhcp server: Un conjunto de comandos que puede usarse para resolver problemas de funcionamiento del servidor DHCP.

Todas estas funciones y características adicionales se describen en los Release Note de la característica del Cisco IOS DHCP Server situados en el documento sobre el Cisco IOS DHCP Server.

Servicio hora del día (ToD) del IOS de Cisco

Luego de que un cablemódem adquiere exitosamente una licencia de DHCP, intenta contactar a un servidor ToD. Los productos CMTS de Cisco que funcionan con el Cisco IOS Software Release 12.0(4)XI o Posterior pueden proporcionar un servicio del ToD del RFC868.

Un error común es creer que el servicio ToD que los cablemódems necesitan utilizar como parte del proceso de conexión es el mismo que el servicio Protocolo de tiempo de red (NTP) que usualmente está configurado en los routers de Cisco. El servicio NTP y el servicio ToD son incompatibles. Los Cablemódems no pueden comunicarse con un servidor NTP. Mientras que el Cable módems debe intentar entrar en contacto un servidor de hora del día como parte del proceso de venir en línea, los módems que cumplen con las últimas revisiones de la especificación RFI del DOCSIS 1.0 todavía procederán a venir en línea incluso si un Servidor TOD no puede ser alcanzado.

De acuerdo con las versiones más recientes de la especificación, si un cable módem no puede comunicarse con un servidor ToD entonces puede continuar con el proceso de ponerse en línea. No obstante, debe continuar tratando de contactar al servidor ToD periódicamente hasta tener éxito. Versiones anteriores de la especificación RFI DOCSIS 1.0 tenían instrucciones de que si un cablemódem no podía contactar un servidor ToD, entonces el módem no podía conectarse. Es importante tener en cuenta que es posible que los cablemódem que ejecutan firmware anteriores cumplan con esta versión anterior de la especificación.

Nota: El Cable módems de algún vendedor no interopera con el servicio de la hora del día de Cisco IOS. Si estos módems cumplen con las versiones más recientes de la especificación RFI DOCSIS 1.0, deben continuar conectándose. El problema de la interoperatividad se resuelve por medio del ID de falla de funcionamiento CSCdt24107 de Cisco.

Nota: Para configurar ToD en un CMTS de Cisco, sólo se necesitan dos comandos globales:

service udp-small-servers max-servers no-limit
!
cable time-server
!

Servicio del Protocolo trivial de transferencia de archivos (TFTP) del IOS de Cisco

Una vez que un cable módem ha intentado comunicarse con un servidor ToD, intenta comunicarse con un servidor TFTP para descargar un archivo de configuración DOCSIS. Si se puede copiar un archivo de configuración DOCSIS binario a un dispositivo flash en un sistema Cisco CMTS, entonces el router puede actuar como un servidor TFTP para ese archivo.

El procedimiento para descargar un archivo de configuración DOCSIS en la memoria flash es el siguiente:

Primero, aseegure el CMTS puede alcanzar el servidor donde vive el archivo de configuración DOCSIS:

7246VXR#ping 172.16.30.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Luego, copie el archivo, en este caso se llama silver.cm, en la memoria flash del CMTS.

7246VXR#copy tftp flash
Address or name of remote host []? 172.16.30.2
Source filename []? silver.cm
Destination filename [silver.cm]?�

Accessing tftp://172.16.30.2/silver.cm...
Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
[OK - 76/4096 bytes]

76 bytes copied in 0.152 secs

Finalmente, siempre es una buena idea comprobar la memoria flash y verificar que el tamaño del archivo es correcto. Para esto ejecute show flash.

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Para habilitar servicio TFTP encendido el CMTS allí que necesitamos solamente incluir el siguiente comando en el modo de configuración global.

tftp-server slot0:silver.cm alias silver.cm

Una vez que este comando es introducido, después se mostrará lo siguiente en la configuración:

!
tftp-server slot0:silver.cm alias silver.cm
tftp-server server��
!

Para obtener más información sobre la configuración del servidor tftp en un router consulte el documento Comandos de transferencia de archivos adicionales.

Generación de archivos de configuración DOCSIS interno

Los productos CMTS de Cisco que ejecutan la versión 12.1(2) o posterior del software IOS de Cisco (en el tren de la versión EC) pueden ser configurados para generar y guardar internamente archivos de configuración DOCSIS. Es útil porque quita el requisito de tener acceso a una herramienta de generación de archivo de configuración DOCSIS externa. Cuando se crea un archivo de configuración DOCSIS utilizando la herramienta de configuración interna, el archivo automáticamente se torna disponible vía TFTP. Asimismo, únicamente los cablemódems en interfaces conectadas directamente por cable pueden descargar estos archivos de configuración.

El siguiente ejemplo de configuración muestra la creación de dos archivo de configuración DOCSIS.

La primera se llama disable.cm, permite un cable módem para conectarse pero detiene los dispositivos CPE conectados desde el acceso de la red del proveedor de servicio. En este caso vemos el comando "access-denied". Tenga en cuenta que, en este caso, las velocidades descendentes y ascendentes son de 1kbps, el tamaño de ráfaga mayor es 1600 bytes.

cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�timestamp
!

La razón por la cual un operador de cable puede tener este archivo de configuración de DOCSIS "disable.cm" es que desea negar el acceso al CPE detrás de los cable módems mientras permite que el cable módem se conecte. Es una manera más eficiente para negar el servicio CPE que utilizar la opción “excluir” en CNR, la cual no permitirá que el módem de cable se conecte y, en consecuencia, el módem de cable intentará conectarse en línea una y otra vez lo que perderá el ancho de banda.

Los cable módems que reciban este archivo de configuración de DOCSIS, tendrán la misma apariencia que en el comando show cable modem:

Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45

(|| agregue el link cuando está disponible) abajo da más detalles en esta salida. El estado "online(d)" significa que el cablemódem está conectado pero el acceso es denegado.

En el segundo ejemplo se crea un nombre de archivo de configuración DOCSIS llamado “platinum.cm”. En este caso el valor ascendente máximo es 1 Mbps, el flujo ascendente garantizado es 100Kbps, el flujo descendente máximo es 10Mbps y permite que se conecten hasta 30 dispositivos CPE.

cable config-file platinum.cm
�service-class 1 max-upstream 1000
�service-class 1 guaranteed-upstream 100
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 30
�timestamp
!

Tenga en cuenta que durante la configuración del archivo de configuración de DOCSIS en el CMTS no necesitamos la sentencia "tftp server slot0:platinum.cm alias platinum.cm" ya que no existe ningún archivo ".cm" almacenado en la memoria. El mismo reside en la configuración. Puede encontrar más detalles acerca de la herramienta del archivo de configuración DOCSIS interna en el documento Comandos del sistema de terminación de cablemódems.

Ejemplo de diagrama

En la imagen se muestra una topología típica de configuración de laboratorio.

/image/gif/paws/28990/all_in_one_config1.gif

Configuraciones

Todas las plataformas CMTS de Cisco admiten esta configuración. Esto incluye el ubr7200, el uBR7246VXR, el uBR7100, y el uBR10000.

La versión de Cisco IOS Software que soporta todos en una configuración, incluyendo la configuración del archivo de configuración de DOCSIS, es Cisco IOS Software Release 12.1(2)EC y tren de EC las versiones subsiguientes.

Las siguientes configuraciones fueron efectuadas en un uBR7246 VXR utilizando la versión 12.1(4)EC del software Cisco IOS y con un NPE300. Primero se presenta una configuración básica y luego se presentará una configuración más avanzada.

Configuración integral básica

La siguiente configuración resume todas las partes que se explicaron en este documento. Tiene dos alcances de DHCP, uno para los módems de cable y otro para los hosts detrás de los módems de cable.

Un archivo de configuración de DOCSIS fue creado llamó el platinum.cm. Este archivo se aplica al recurso compartido DHCP denominado cm-platinum. El otro archivo de configuración de DOCSIS llamado disabled.com no se aplica a nada en la actualidad.

Hay dos conjuntos DHCP configurados en este ejemplo, uno para los cablemódems y otro para la PC detrás de los cablemódems.

Nota:  Los comandos de la configuración integral están resaltados en negrita.

Configuración integral básica 7246VXR
7246VXR#show run

version 12.1
no service pad
service timestamps debug datetime msec localtime

! -- provides nice timestamps on all log messages

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

! -- supports a large number of modems / hosts attaching quickly

!
hostname 7246VXR
!
logging buffered 1000000 debugging
enable password cable
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server

! --� permits cable modems to obtain Time of Day (ToD) from uBR7246VXR

!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
ip cef

! -- Turn on cef switching / routing, anything but process� switching (no ip route-cache)

ip cef accounting per-prefix�
no ip finger
ip tcp synwait-time 5
no ip domain-lookup

! -- Prevents cmts from looking up domain names / attempting�
! -- to connect to machines when mistyping commands

ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
!
!
!��
ip dhcp pool cm-platinum

! -- name of the dhcp pool. This scope is for the cable modems attached�
! -- to interface cable 4/0

�� network 10.1.4.0 255.255.255.0

! -- pool of addresses for scope modems-c4/0

�� bootfile platinum.cm

! -- DOCSIS config file name associated with this pool

�� next-server 10.1.4.1

! -- IP address of TFTP server which sends bootfile

�� default-router 10.1.4.1

! -- default gateway for cable modems, necessary to get DOCSIS files

�� option 7 ip 10.1.4.1

! -- Log Server DHCP option

�� option 4 ip 10.1.4.1

! -- ToD server IP address

�� option 2 hex ffff.8f80

! -- Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

�� lease 7 0 10

! -- lease 7 days 0 hours 10 minutes

!�
ip dhcp pool pcs-c4

! -- name of the dhcp pool. This scope is for the CPEs� attached�
! -- the cable modems that are connected to interface cable 4/0

�� network 172.16.29.0 255.255.255.224

! -- pool of addresses for scope pcs-c4 (associated with the secondary address)

�� next-server 172.16.29.1�
�� default-router 172.16.29.1
�� dns-server 172.16.30.2�
�� domain-name cisco.com�
�� lease 7 0 10������
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary

! -- used for the scope pcs-c4 so that PC's get an ip address on this network
ip address 10.1.4.1 255.255.255.0

! -- used for the scope modems-c4/0 so that cable modems get an ip address from this network

�no ip route-cache cef
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy

! -- Used to� modify the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets with a
! -- Relay IP address before they are forwarded to the DHCP server

!���������
!���������
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!���������
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!���������
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!���������
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server server

! -- enable the cmts to act as a tftp server

tftp-server slot0:silver.cm alias silver.cm

! -- get the DOCSIS config file called silver.cm that is pre-downloaded to flash.
! -- this DOCSIS config file is built using DOCSIS CPE Configurator.��

!���������
line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�login
!
ntp clock-period 17179977
ntp server 172.16.135.51
end

Consejos de verificación para una configuración básica

Primero, debemos asegurarnos de que los comandos sean admitidos por al versión del software IOS de Cisco. Para esto podemos hacer show version.

7246VXR#show version
Cisco Internetwork Operating System Software�
IOS (tm) 7200 Software (UBR7200-IK1S-M), Version 12.1(4)EC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Fri 08-Dec-00 17:35 by ninahung
Image text-base: 0x60008950, data-base: 0x612AA000

ROM: System Bootstrap, Version 12.0(19990210:195103) [12.0XE 105], DEVELOPMENT SOFTWARE
BOOTFLASH: 7200 Software (UBR7200-BOOT-M), Version 12.0(7)T,� RELEASE SOFTWARE (fc2)

7246VXR uptime is 9 minutes
System returned to ROM by reload at 09:47:00 PDT Tue Feb 27 2001
System restarted at 09:48:26 PDT Tue Feb 27 2001
System image file is "slot0:ubr7200-ik1s-mz.121-4.EC"

cisco uBR7246VXR (NPE300) processor (revision C) with 253952K/40960K bytes of memory.
Processor board ID SAB03500058
R7000 CPU at 262Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache
6 slot VXR midplane, Version 2.0

Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
4 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
5 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.

16384K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

Necesitamos verificar que el archivo de configuración de DOCSIS esté en el flash.

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Note que el archivo “silver.cm” fue construido usando la herramienta del configurador DOCSISCPE. Para el archivo platunum.cm que se construyó en la configuración del CMTS no necesita la sentencia "tftp server slot0:platinum.cm alias platinum.cm" ya que no existe ningún archivo "Cm", éste reside en la configuración.

El siguiente paso es verificar que el Cable módems está en línea. Podemos lograr esto con el comando show cable modem.

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 75�� online���� 2290��� 0.00� 5�� 1�� 10.1.4.2������� 0010.7bed.9b23
Cable4/0/U0 76�� online���� 2809��� 0.00� 5�� 0�� 10.1.4.3������� 0002.fdfa.0a63
Cable4/0/U0 77�� online���� 2288��� 0.25� 5�� 1�� 10.1.4.5������� 0010.7bed.9b45
Cable4/0/U0 78�� online���� 2810��� 0.50� 5�� 0�� 10.1.4.4������� 0004.2752.ddd5
Cable4/0/U0 79�� online���� 2813��� 0.25� 5�� 0�� 10.1.4.6������� 0002.1685.b5db
Cable4/0/U0 80�� online���� 2812�� -0.50� 5�� 0�� 10.1.4.7������� 0001.64ff.e47d


Tenga en cuenta que todos los cable módems están en línea. Los que están conectados al cable de interfaz 4/0/U0 están en la red 10.1.4.0. En la configuración podemos ver que sus direcciones de IP son tomadas del agrupamiento DHCP denominado "cm-platinum".

Tenga en cuenta también que los cablemódems con direcciones Mac 0010.7bed.9b23 y 0010.7bed.9b45 respectivamente, tienen CPE detrás. Estos cablemódems se conectan con la configuración predeterminada de conexión en puente. Esas PC están configuradas con DHCP para que puedan obtener su dirección IP desde la red.

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
75��� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
75��� 00�������� modem���� up������� 10.1.4.2����� dhcp����� 0010.7bed.9b23
76��� 00�������� modem���� up������� 10.1.4.3����� dhcp����� 0002.fdfa.0a63
77��� 00�������� host����� unknown�� 172.16.29.3�� dhcp����� 00a0.243c.eff5
77��� 00�������� modem���� up������� 10.1.4.5����� dhcp����� 0010.7bed.9b45
78��� 00�������� modem���� up������� 10.1.4.4����� dhcp����� 0004.2752.ddd5
79��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0002.1685.b5db
80��� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0001.64ff.e47d

Las siguientes imágenes muestran que esas PC obtienen una dirección IP de los recursos compartidos denominados "pcs-c4".

all_in_one_config2.gif

También se puede ver en esta PC que las configuraciones TCP/IP son para obtener una dirección IP automáticamente.

all_in_one_config3.gif

Configuración integral avanzada

Esta sección proporciona un ejemplo de configuración más sofisticado que implique la funcionalidad de jerarquía de los pools DHCP. Los trabajos de la jerarquía del agrupamiento DHCP de la manera son que cualquier agrupamiento DHCP con un network number que sea un subconjunto del network number de otra piscina hereda todas las características de ese otro pool. Esto evita la repetición en la configuración del servidor DHCP. Sin embargo, si la misma especificación se hace con un diverso parámetro entonces el parámetro será sobregrabado. Este ejemplo mostrará una agrupación general con un archivo de inicio denominado platinum.cm y el subconjunto de esta agrupación tendrá el archivo de inicio denominado disable.cm.

Además de los agrupamientos DHCP creados en el ejemplo básico, tenemos requisitos especiales para dos Cable módems.

El módem de cable 0010.7bed.9b45 será negado el acceso. Esto significa que el módem de cable será concedido una dirección IP pero no vendrá en línea. Para esto, crearemos el siguiente agrupamiento:

ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm

La mayoría de la notable función de este ejemplo de configuración es la sección donde especifican a los agrupamientos DHCP especiales correspondiente a las direcciones MAC del cablemódem individual. Esto es para que el servidor DHCP pueda enviar a estos módems opciones DHCP únicas. Para especificar un cablemódem en particular, se utiliza el parámetro “client-identifier” (cliente-identificador). El parámetro "client-identifier" debe establecerse en 01 seguido de la dirección MAC del dispositivo al que corresponde la entrada. Los 01 corresponde al tipo de hardware de Ethernetes para el DHCP.

Nota: Al cambiar los archivos de configuración para un módem es necesario hacer el siguiente de modo que el módem de cable consiga manualmente los parámetros configurados:

  • Borre la tabla de vinculación DHCP del IP usando el comando clear ip dhcp binding <ip address>.”

  • Reajuste el módem de cable en la pregunta usando el comando clear cable modem <mac address > res.

El módem de cable 0010.7bed.9b23 también tiene un requisito especial. Con esto obtendrá una calidad de servicio diferente. Por lo tanto, se asocia al alcance un archivo de inicio diferente. Consulte la configuración parcial siguiente:

ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm

!

Cuando se configuran agrupamientos de DHCP para cablemódems específicos, siempre es una práctica adecuada darles un nombre relevante. También, puesto que un IP Address específico se asigna al pool usando el comando host, necesitamos agregar el comando global que el DHCP del IP excluye 10.1.4.60 10.1.4.70. Dicho comando le indica al DHCP que no distribuya direcciones pertenecientes a este rango.

Configuración integral avanzada 7246VXR
7246VXR# show run

version 12.1
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit
!
hostname 7246VXR
!
logging buffered 1000000 debugging
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
no ip finger
no ip domain-lookup
ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
ip dhcp excluded-address 10.1.4.60 10.1.4.70
!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!
ip dhcp pool pcs-c4
�� network 172.16.29.0 255.255.255.224
�� next-server 172.16.29.1�
�� default-router 172.16.29.1�
�� dns-server 172.16.30.2�
�� domain-name cisco.com
�� lease 7 0 10
!
ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm
!
ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary
�ip address 10.1.4.1 255.255.255.0
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy
!
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!
access-list 188 permit tcp any any eq www log
access-list 188 permit ip any any
route-map docsis permit 10
!
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server slot0:silver.cm alias silver.cm
tftp-server server

line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�exec-timeout 0 0
�login
!
ntp clock-period 17179973
end

Consejos de verificación para una configuración avanzada

La verificación de esta configuración se centra en los servicios que están recibiendo los cablemódems, especialmente 0010.7bed.9b45 y 0010.7bed.9b23. Necesitamos asegurarnos de que están obteniendo las direcciones que se configuraron manualmente con el servicio.

La primera cosa a probar es que vendrá 0010.7bed.9b45 en línea pero el servicio será negado. Para esto nos dejamos hechar una ojeada el comando show cable modem:

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 7��� online���� 2813��� 0.00� 7�� 0�� 10.1.4.7������� 0002.1685.b5db
Cable4/0/U0 8��� online���� 2809��� 0.25� 7�� 0�� 10.1.4.10������ 0002.fdfa.0a63
Cable4/0/U0 9��� online���� 2288�� -0.25� 5�� 1�� 10.1.4.66������ 0010.7bed.9b23
Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45
Cable4/0/U0 11�� online���� 2809�� -0.50� 7�� 0�� 10.1.4.6������� 0001.64ff.e47d
Cable4/0/U0 12�� online���� 2812�� -0.50� 7�� 0�� 10.1.4.9������� 0004.2752.ddd5

Aquí hay varios puntos a tener en cuenta:

  • El módem de cable 0010.7bed.9b23 consiguió a la dirección IP 10.4.1.66 como se especifica en el alcance cm-0010.7bed.9b23. Hay un ordenador asociado a él y consigue su IP Address del pool pcs-c4.

  • El cablemódem 0010.7bed.9b23 tiene una QoS diferente.

  • El módem de cable 0010.7bed.9b45 se conectó a la dirección de IP 10.1.4.65, como se especificó en el ámbito cm-0010.7bed.9b45. Hay un ordenador asociado a él, no obstante el valor del CPE es 0. La razón es que el servicio está negado.

  • El estado en línea de 0010.7bed.9b45 es en línea(d), lo que significa que el cable módem se conecta pero se le niega el acceso a la red de cable. Consulte la salida de debug cable mac log verbose del cable módem.

21:52:16:� 78736.550 CMAC_LOG_RESET_RANGING_ABORTED��������������
21:52:16:� 78736.554 CMAC_LOG_STATE_CHANGE���������������������� reset_interface_state
21:52:16:� 78736.558 CMAC_LOG_STATE_CHANGE���������������������� reset_hardware_state
21:52:17:� 78737.024 CMAC_LOG_STATE_CHANGE���������������������� wait_for_link_up_state
21:52:17:� 78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET������������� 0x082B9CA8
21:52:17:� 78737.032 CMAC_LOG_LINK_DOWN��������������������������
21:52:17:� 78737.034 CMAC_LOG_LINK_UP����������������������������
21:52:17:� 78737.040 CMAC_LOG_STATE_CHANGE���������������������� ds_channel_scanning_state
21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
21:52:18:� 78738.386 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:19:� 78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED������������ 747000000
21:52:19:� 78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED����������
21:52:19:� 78739.704 CMAC_LOG_STATE_CHANGE���������������������� wait_ucd_state
21:52:20:� 78740.368 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.396 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.398 CMAC_LOG_ALL_UCDS_FOUND���������������������
21:52:22:� 78742.402 CMAC_LOG_STATE_CHANGE���������������������� wait_map_state
21:52:22:� 78742.406 CMAC_LOG_FOUND_US_CHANNEL������������������ 1
21:52:24:� 78744.412 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:24:� 78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY�������������� 39984000
21:52:24:� 78744.420 CMAC_LOG_SLOT_SIZE_CHANGED����������������� 8
21:52:24:� 78744.500 CMAC_LOG_UCD_UPDATED������������������������
21:52:24:� 78744.560 CMAC_LOG_MAP_MSG_RCVD�����������������������
21:52:24:� 78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS��������� 41
21:52:24:� 78744.566 CMAC_LOG_STATE_CHANGE���������������������� ranging_1_state
21:52:24:� 78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 9610
21:52:24:� 78744.574 CMAC_LOG_POWER_LEVEL_IS�������������������� 55.0� dBmV (commanded)
21:52:24:� 78744.578 CMAC_LOG_STARTING_RANGING�������������������
21:52:24:� 78744.580 CMAC_LOG_RANGING_BACKOFF_SET��������������� 0
21:52:24:� 78744.586 CMAC_LOG_RNG_REQ_QUEUED�������������������� 0
21:52:24:� 78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:24:� 78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:24:� 78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED�������������� 10
21:52:24:� 78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET������������� 2286
21:52:24:� 78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 11896
21:52:24:� 78744.638 CMAC_LOG_STATE_CHANGE���������������������� ranging_2_state
21:52:24:� 78744.644 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:25:� 78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:25:� 78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:25:� 78745.660 CMAC_LOG_RANGING_SUCCESS��������������������
21:52:25:� 78745.680 CMAC_LOG_STATE_CHANGE���������������������� dhcp_state
21:52:25:� 78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS���������� 10.1.4.65
21:52:25:� 78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS���������� 10.1.4.1
21:52:25:� 78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS����������� 10.1.4.1
21:52:25:� 78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS�����������
21:52:25:� 78745.834 CMAC_LOG_DHCP_TZ_OFFSET�������������������� -28800
21:52:25:� 78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME������������� disable.cm
21:52:25:� 78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR��
21:52:25:� 78745.846 CMAC_LOG_DHCP_COMPLETE����������������������
21:52:25:� 78745.968 CMAC_LOG_STATE_CHANGE���������������������� establish_tod_state
21:52:25:� 78745.978 CMAC_LOG_TOD_REQUEST_SENT�������������������
21:52:26:� 78746.010 CMAC_LOG_TOD_REPLY_RECEIVED���������������� 3192525217
21:52:26:� 78746.018 CMAC_LOG_TOD_COMPLETE�����������������������
21:52:26:� 78746.020 CMAC_LOG_STATE_CHANGE���������������������� security_association_state
21:52:26:� 78746.024 CMAC_LOG_SECURITY_BYPASSED������������������
21:52:26:� 78746.028 CMAC_LOG_STATE_CHANGE���������������������� configuration_file_state
21:52:26:� 78746.030 CMAC_LOG_LOADING_CONFIG_FILE��������������� disable.cm
21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
21:52:27:� 78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE�������
21:52:27:� 78747.066 CMAC_LOG_STATE_CHANGE���������������������� registration_state
21:52:27:� 78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED�����������������
21:52:27:� 78747.076 CMAC_LOG_REG_REQ_TRANSMITTED����������������
21:52:27:� 78747.080 CMAC_LOG_REG_RSP_MSG_RCVD�������������������
21:52:27:� 78747.082 CMAC_LOG_COS_ASSIGNED_SID������������������ 1/10
21:52:27:� 78747.088 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:27:� 78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED��������������
21:52:27:� 78747.094 CMAC_LOG_REGISTRATION_OK��������������������
21:52:27:� 78747.096 CMAC_LOG_STATE_CHANGE���������������������� establish_privacy_state
21:52:27:� 78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED�������������
21:52:27:� 78747.102 CMAC_LOG_STATE_CHANGE���������������������� maintenance_state
21:52:31:� 78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:31:� 78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:37:� 78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:37:� 78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:43:� 78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:43:� 78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:49:� 78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:49:� 78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

La salida de esta depuración muestra que el Acceso a la red está denegado.

7246VXR#show cable modem detail
Interface�� SID� MAC address��� Max CPE� Concatenation� Rx SNR
Cable4/0/U0 7��� 0002.1685.b5db 10������ yes����������� 33.52
Cable4/0/U0 8��� 0002.fdfa.0a63 10������ yes����������� 33.24
Cable4/0/U0 9��� 0010.7bed.9b23 1������� no������������ 33.29
Cable4/0/U0 10�� 0010.7bed.9b45 1������� no������������ 33.23
Cable4/0/U0 11�� 0001.64ff.e47d 10������ yes����������� 33.20
Cable4/0/U0 12�� 0004.2752.ddd5 10������ yes����������� 33.44

Note que el CPE máximo para el Cable módems con los alcances especiales es 1 y el resto son 10. Si usted ve el platinum.cm de la configuración de alcance, tiene 10 CPEs especificado, por otra parte, el alcance disable.cm tiene solamente 1 CPE. El archivo de configuración DOCSIS preconfigurado silver.cm también tiene sólo una CPE especificada.

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
7���� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0002.1685.b5db
8���� 00�������� modem���� up������� 10.1.4.10���� dhcp����� 0002.fdfa.0a63
9���� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
9���� 00�������� modem���� up������� 10.1.4.66���� dhcp����� 0010.7bed.9b23
10��� 00�������� modem���� up������� 10.1.4.65���� dhcp����� 0010.7bed.9b45
11��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0001.64ff.e47d
12��� 00�������� modem���� up������� 10.1.4.9����� dhcp����� 0004.2752.ddd5

Para verificar que los cable módems reciban el nivel de servicio correcto, observamos la salida del comando show cable qos profile.

7246VXR#show cable qos profile
ID� Prio Max������ Guarantee Max������� Max�� TOS� TOS�� Create� B���� IP prec.
�������� upstream� upstream� downstream tx��� mask value by����� priv� rate
�������� bandwidth bandwidth bandwidth� burst������������������� enab� enab
1�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� cmts(r) no��� no������
2�� 0��� 64000���� 0�������� 1000000��� 0���� 0x0� 0x0�� cmts(r) no��� no������
3�� 7��� 31200���� 31200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
4�� 7��� 87200���� 87200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
5�� 4��� 64000���� 0�������� 512000���� 0���� 0x0� 0x0�� cm����� no��� no������
6�� 0��� 1000����� 0�������� 1600000��� 0���� 0x0� 0x0�� cm����� no��� no������
7�� 0��� 128000��� 10000���� 10000000�� 1600� 0x0� 0x0�� cm����� no��� no������
8�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
10� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
12� 0��� 0�������� 100000000 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no

Observe que el ID 7 de qos coincide con la configuración en platinum.cm:

cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp

Lo mismo ocurre con la configuración DOCSIS de disable.cm.

7246VXR#show ip dhcp binding
IP address������ Hardware address������� Lease expiration������� Type
10.1.4.6�������� 0100.0164.ffe4.7d������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.7�������� 0100.0216.85b5.db������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.9�������� 0100.0427.52dd.d5������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.10������� 0100.02fd.fa0a.63������ Mar 08 2001 08:36 AM��� Automatic
10.1.4.65������� 0100.107b.ed9b.45������ Infinite��������������� Manual
10.1.4.66������� 0100.107b.ed9b.23������ Infinite��������������� Manual

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 28990