Servicios de redes de aplicaciones : Cisco LocalDirector de la serie 400

Resolución de problemas del equilibrio de carga de contenido en LocalDirector 4.1.1.

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Cisco ha anunciado la fin-de-venta para el Cisco LocalDirector. Para más información, refiera al fin de vida de las 400 Series de LocalDirector y los avisos y los boletines de productos del Fin de la Venta.


Contenido


Introducción

Este documento proporciona una configuración de muestra y los comandos adicionales de resolver problemas la característica del equilibrio de carga de contenido disponible en el Cisco LocalDirector 416 (versión 4.1.1).

Nota: Varios problemas con el Equilibrio de carga contento se han corregido en la mayoría de las versiones recientes del código para el LocalDirector. Se recomienda fuertemente que usted utiliza la versión 4.2.4 o posterior. Refiera a la página de descarga del software (clientes registrados solamente) para más información.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Esta configuración fue desarrollada y probada mediante las siguientes versiones de software y hardware:

  • LocalDirector 416 (versión 4.1.1), con los clientes ejecutándose Windows 2000 Server, el Service Pack 4.0 del Windows NT 4.0, y Windows 98

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Diagrama de la red

/image/gif/paws/28847/load_balancing.jpg

Configuración

La solicitud del cliente de páginas /index.htm va al servidor 172.18.124.205 ó 172.18.124.207. Obtenga peticiones con /rtp/local-director go to server 172.18.124.101. Todas las demás solicitudes van hacia 172.18.124.206.

LocalDirector 416 (Versión 4.1.1.)
Current configuration:
 syslog output 20.3
 no syslog console
 enable password 000000000000000000000000000000 encrypted
 hostname 38-ld416
 no shutdown ethernet 0
 no shutdown ethernet 1
 no shutdown ethernet 2
 interface ethernet 0 auto
 interface ethernet 1 auto
 interface ethernet 2 auto
 mtu 0 1500
 mtu 1 1500
 mtu 2 1500
 multiring all
 no secure  0
 no secure  1
 no secure  2
 ping-allow 0
 ping-allow 1
 no ping-allow 2
 ip address 172.18.124.209 255.255.255.0
 route 0.0.0.0 0.0.0.0 172.18.124.1 1
 arp timeout 30
 no rip passive
 rip version 1
 failover ip address 0.0.0.0
 no failover
 failover hellotime 30
 password cisco
 snmp-server enable traps
 snmp-server community public
 no snmp-server contact
 no snmp-server location
 no dns-boomerang enable
 content-rule nsteam depth 1024 "/index*.htm*"
 content-rule jahrule depth 1024 "/rtp/local-director/*"
 virtual 172.18.124.219:80:0:tcp:jahrule is
 virtual 172.18.124.219:80:0:tcp is
 virtual 172.18.124.219:80:0:tcp:nsteam is
 service 172.18.124.219:80:0:tcp clb-close
 real 172.18.124.205:80:0:tcp is
 real 172.18.124.101:80:0:tcp is
 real 172.18.124.206:80:0:tcp is
 real 172.18.124.207:80:0:tcp is
 bind 172.18.124.219:80:0:tcp:jahrule 172.18.124.101:80:0:tcp
 bind 172.18.124.219:80:0:tcp 172.18.124.206:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.205:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.207:80:0:tcp
end

Ejemplo de Resultado del Comando show

show real

Verifique el estado del servidor REAL.

LocalDirector# show real
  Real Machines:  
                                                       No Answer  TCP Reset   DataIn   Machine

                            Connect  State Thresh   Reassigns  Reassigns   Conns  
 172.18.124.205:80:0:tcp       0      IS      8         0          0         0
 172.18.124.101:80:0:tcp       0      IS      8         0          0         0
 172.18.124.206:80:0:tcp       0      IS      8         0          0         0
 172.18.124.207:80:0:tcp       0      IS      8         0          0         0

show server

Verifique la configuración de servicio.

LocalDirector# show service
  Virtual Machine(s)              Service
 172.18.124.219:80:0:tcp         clb-close

‘mostrar regla’

Reglas de visualización.

LocalDirector# show rule
  Name            Depth           Content-String
  nsteam          1024            "/index*.htm*"
  jahrule         1024            "/rtp/local-director/*"

Ver regla específica.

LocalDirector# show rule jahrule

  Name            Depth           Content-String
  jahrule         1024            "/rtp/local-director/*"

show bind

Verificar vinculaciones.

LocalDirector# show bind

 Virtual Machine(s)                      Real Machines/Urls
 172.18.124.219:80:0:tcp:jahrule(IS)
 172.18.124.101:80:0:tcp (IS)
 172.18.124.219:80:0:tcp (IS)
 172.18.124.206:80:0:tcp (IS)
 172.18.124.219:80:0:tcp:nsteam(IS)
 172.18.124.205:80:0:tcp (IS)
 172.18.124.207:80:0:tcp (IS)

Reglas de edición

  1. Desvincule mediante la utilización del comando no bind.

  2. Desactive los servidores virtuales que utilizan reglas por medio del comando no-inservice.

  3. Elimine los servidores virtuales mediante el comando no virtual.

  4. Edite la regla al tipear el comando no rule.


Información Relacionada


Document ID: 28847