Servicios de redes de aplicaciones : Software Cisco Application and Content Networking System (ACNS)

Cómo configurar un motor de caché para el almacenamiento en memoria caché proxy inversa mediante WCCP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios



Contenido


Introducción

Este documento describe cómo configurar el Cisco Cache Engine para el proxy inverso que oculta usando el protocolo web cache coordination (WCCP).

Versiones de hardware y software

Esta configuración fue desarrollada y probada utilizando las versiones de software y hardware indicadas a continuación.

  • Software Cisco Cache versión 2.3 del Cisco Cache Engine 560 y versión ACNS 4.0 y ACNS corrientes 5.0 en un ambiente de laboratorio con las configuraciones despejadas.

  • Cisco 2600 Router que funciona con el Software Release 12.1(2) de Cisco IOS®.
La información que se presenta en este documento se originó utilizando equipo en un entorno de laboratorio. Los dispositivos encendidos con una configuración despejada (predeterminada). Si está trabajando en una red activa, asegúrese de haber comprendido el impacto posible que puede tener un comando antes de ejecutarlo.

Diagrama de la red


Configuraciones

Motor 560 (versión de software del caché 2.3 o versión de software del ACNS 4.0 o 5.0) del caché
Current configuration:
!
!
user add admin uid 0 
password 1 "eeSdy9dcy" 
capability admin-access
!
!
!
hostname ce
!
interface ethernet 0
 ip address 10.0.0.2 255.255.255.0
!--- Important: If you configure the Cache Engine
!--- with a private address, it must get translated
!--- to a public address.
 ip broadcast-address 10.0.0.255 exit ! interface ethernet 1 exit ! ip default-gateway 10.0.0.1 ip name-server 171.70.168.183 ip domain-name cisco.com ip route 0.0.0.0 0.0.0.0 10.0.0.1 cron file /local/etc/crontab ! wccp router-list 1 10.0.0.1 wccp reverse-proxy router-list-num 1 wccp version 2 ! authentication login local enable authentication configuration local enable rule no-cache url-regex .*cgi-bin.* rule no-cache url-regex .*aw-cgi.* ! !

Router 2006 de Cisco (Versión 12.1[2] del software del IOS de Cisco)
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2611-5
!
enable secret 5 $1$9VQ.$BTPbq8xlE2dsKwKPDDmpL/
!
!
ip subnet-zero
ip wccp 99
!
!
interface Ethernet0/0
 description Interface to the Internet 
 ip address 172.17.63.194 255.255.255.192
 no ip redirects
!
interface Serial0/0
 no ip address
 no ip mroute-cache
 shutdown
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp 99 redirect out
!
interface Ethernet1/1
 no ip address
 shutdown
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Comandos debug y show

Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

Comandos Cache Engine debug y show:

  • show wccp cache - Muestre la información WCCP CE
  • show wccp flows - Muestre los flujos del paquete WCCP
  • show wccp routers - Muestre la lista del router WCCP
  • show wccp services - Show wccp services configurado
  • show wccp slowstart - Muestre a WCCP el comienzo lento
  • show wccp status - Muestre el estado de ejecución WCCP
  • show statistics http savings - Estadísticas de ahorro de las visualizaciones HTTP
  • debug wccp all - El WCCP gira todo el debugging
  • debug wccp events - Eventos wccp
  • debug wccp packets - Información relacionada a paquetes WCCP
Comandos debug and show del router:
  • show ip wccp 99 detail - Este comando visualiza las estadísticas del motor y del router WCCP del caché para un grupo de servicios.
  • show ip wccp 99 view - Información de la opinión del grupo de servicios
  • eventos wccp del IP del debug - Eventos wccp
  • paquetes del wccp del IP del debug - Información relacionada a paquetes WCCP

Verificación

Verifique que el almacenamiento en memoria inmediata de la representación inversa esté trabajando con estos comandos.

Publique este comando de marcar el estatus del caché/del Content Engine WCCP:

 
router#sh ip wccp 99 detail 
WCCP Cache-Engine information: 
       IP Address:            10.0.0.2 
       Protocol Version:      2.0 
       State:                 Usable                              
	   !--- This cache is active.
       Initial Hash Info:     00000000000000000000000000000000 
                              00000000000000000000000000000000 
       Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                              FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
       Hash Allotment:        256 (100.00%) 
       Packets Redirected:    93 
       Connect Time:          00:15:27

Publique este comando de marcar el redireccionamiento reverso transparente de WCCP en el router:

 
router#sh ip wccp 99 
Global WCCP information: 
    Router information: 
        Router Identifier:                   172.17.63.194 
        Protocol Version:                    2.0 
    Service Identifier: 99 
        Number of Cache Engines:             1 
        Number of routers:                   1 
        Total Packets Redirected:            93                   
		!--- The router is redirecting.
        Redirect access-list:                -none- 
        Total Packets Denied Redirect:       0 
        Total Packets Unassigned:            0 
        Group access-list:                   -none- 
        Total Messages Denied to Group:      0 
        Total Authentication failures:       0


Publique este comando de marcar las estadísticas de HTTP en el caché/el Content Engine:

 
cache#sh statistic http request 
                              Statistics - Requests 
                                                Total             % of Requests 
                            --------------------------------------------------- 
     Total Received Requests:                      23                         - 
              Forced Reloads:                       2                       8.7 
               Client Errors:                       0                       0.0 
               Server Errors:                       0                       0.0 
         URL Blocked (Reset):                       0                       0.0 
                 URL Blocked:                       0                       0.0 
      Sent to Outgoing Proxy:                       0                       0.0 
Failures from Outgoing Proxy:                       0                       0.0 
Excluded from Outgoing Proxy:                       0                       0.0 
             ICP Client Hits:                       0                       0.0 
             ICP Server Hits:                       0                       0.0 
               If-Range Hits:                       0                       0.0 
           HTTP 0.9 Requests:                       0                       0.0 
           HTTP 1.0 Requests:                       0                       0.0 
           HTTP 1.1 Requests:                      23                     100.0 
       HTTP Unknown Requests:                       0                       0.0 
           Non HTTP Requests:                       0                       0.0 
          Non HTTP Responses:                       0                       0.0 
      Chunked HTTP Responses:                       0                       0.0 
        Http Miss Due To DNS:                       0                       0.0 
     Http Deletes Due To DNS:                       0                       0.0 
  Objects cached for min ttl:                       4                      17.4

Publique este comando de verificar el almacenamiento en memoria inmediata de las peticiones:

 
cache#sh stat http sav 
                         Statistics - Savings 
                        Requests                          Bytes 
         ----------------------------------------------------------- 
  Total:                      23                          16481 
   Hits:                       6                           2205 
   Miss:                      17                          14276 
Savings:                    25.0 %                         13.4 %

Resumen de Comandos

Utilizaron a estos comandos cache engine en esta configuración.
  • versión del wccp {1 | 2}
  • Dirección de IP del número de lista de router wccp
  • router-list-num número del wccp
Utilizaron a estos comandos router en esta configuración.
  • wccp del IP {caché Web | número de servicio}
  • wccp del IP {caché Web | el número de servicio} reorienta hacia fuera
  • versión 2 del wccp del IP



Información Relacionada



Document ID: 28832