IP : Protocolo de puerta de enlace fronteriza (BGP)

Usando los valores de la comunidad BGP para controlar el política de ruteo en la red de proveedor ascendente

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento demuestra cómo el atributo de la comunidad del Border Gateway Protocol (BGP) se puede utilizar para controlar el policy�in de la encaminamiento su Red proveedora del servicio ascendente.

prerrequisitos

Requisitos

Este documento requiere una comprensión del Routing Protocol BGP y de su operación. Para más información, refiera a los casos prácticos de BGP.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware. Sin embargo, la información en este documento se basa en estas versiones de software y hardware:

  • Software Release 12.2(27) de Cisco IOS�

  • Cisco 2500 Series Routers

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

Mientras que las comunidades ellos mismos no alteran el proceso de toma de decisiones BGP, las comunidades pueden ser utilizadas como indicadores para marcar un conjunto de las rutas. Los routeres del proveedor de Upstream�service pueden entonces utilizar estos indicadores para aplicar la encaminamiento específica limpian (por ejemplo, preferencia local) el �within su red.

Los proveedores establecen una asignación entre los Valores comunitarios configurables del cliente y los valores correspondientes de la preferencia local dentro de la Red proveedora. La idea es que los clientes con las directivas específicas que requieren la modificación del LOCAL_PREF en la Red proveedora fijan los Valores comunitarios correspondientes en sus actualizaciones de ruteo.

Una comunidad es un grupo de prefijos que compartan una cierta propiedad en común y se puedan configurar con el atributo de la comunidad BGP. El atributo de la comunidad BGP es un atributo transitivo opcional de longitud variable. El atributo consiste en un conjunto de cuatro valores del octeto que especifiquen a una comunidad. Que siguen habiendo los valores de atributo de la comunidad se codifican con un número de Sistema autónomo (AS) en los primeros dos octetos, con los dos octetos definidos por COMO. Un prefijo puede tener más de un atributo de comunidad. Un BGP de conversación que observa atributos de comunidad múltiple en un prefijo puede actuar basado en uno, alguno o todos los atributos. Un router tiene la opción para agregar o para modificar un atributo de la comunidad antes de que el router pase el atributo encendido a otros pares. Para aprender más sobre el atributo de la comunidad, refiera a los casos prácticos de BGP.

El atributo de preferencia local es una indicación al COMO que la trayectoria se prefiere para alcanzar cierta red. Cuando hay trayectos múltiples al mismo destino, la trayectoria del �the con la preferencia más alta se prefiere (el valor predeterminado del atributo de preferencia local es 100). Para más información, refiera al atributo de preferencia local.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

Control de la política de ruteo

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Para la simplificación, esta asignación del atributo de la comunidad y el atributo de preferencia local se asume para ser establecida entre el proveedor del servicio ascendente (AS100) y el cliente (AS30).

Preferencia local Valores comunitarios
130 100:300
125 100:250

Si el cliente anuncia prefijos con un atributo de la comunidad igual a 100:300, el proveedor de servicio ascendente establece la preferencia local de esos routers en 130 y 125, si el atributo de la comunidad es igual a 100:250.

Esto le da el potencial para controlar el política de ruteo dentro de la red del proveedor de servicios si usted cambia los Valores comunitarios de los prefijos anunciados al proveedor de servicio.

En el diagrama de la red, el cliente AS30 desea alcanzar este política de ruteo con los atributos de la comunidad.

  • El tráfico entrante del AS100 destinado a la red 6.6.6.0/24 viene a través del link R1-R3. En caso de que el link R1-R3 falle, todo el tráfico viene adentro con el R2-R3.

  • El tráfico entrante del AS100 destinado a la red 7.7.7.0/24 viene a través del link R2-R3. En caso de que el link R2-R3 falle, todo el tráfico viene adentro con el R1-R3.

Para alcanzar este política de ruteo, el R3 anuncia sus prefijos como sigue:

Al r1:

  • 6.6.6.0/24 con un atributo de la comunidad 100:300

  • 7.7.7.0/24 con un atributo comunitario 100:250

A R2:

  • 6.6.6.0/24 con un atributo comunitario 100:250

  • 7.7.7.0/24 con un atributo de la comunidad 100:300

Una vez que el r1 y el r2 de los vecinos BGP reciben los prefijos del R3, el r1 y el r2 aplican la directiva preconfigurada basada en la asignación entre la comunidad y los atributos de preferencia locales (mostrados en esta tabla), y alcanzan así el política de ruteo dictada por el cliente (AS30). El r1 instala los prefijos en la tabla BGP.

  • 6.6.6.0/24 con una preferencia local de 130

  • 7.7.7.0/24 con una preferencia local de 125

El r2 instala el prefijo en su tabla BGP:

  • 6.6.6.0/24 con una preferencia local de 125

  • 7.7.7.0/24 con una preferencia local de 130

Dado que se prefiere una preferencia local mayor en el criterio de selección de ruta BGP, la ruta con una preferencia local de 130 (130 es mayor que 125) es seleccionada como la mejor ruta dentro de AS 100, y se instala en la tabla de IP Routing de R1 y R2. Para más información sobre el criterio de selección de trayecto BGP, refiera al algoritmo de selección del mejor trayecto BGP.

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/28784-bgp-community.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

R3
Current configuration : 2037 bytes
!
version 12.2
!
hostname R3
!
interface Loopback0
�ip address 6.6.6.1 255.255.255.0
!
interface Ethernet0/0
�ip address 7.7.7.1 255.255.255.0
!
interface Serial8/0
�ip address 10.10.13.3 255.255.255.0

!--- Interface connected to R1.

 !�
interface Serial9/0
�ip address 10.10.23.3 255.255.255.0

!--- Interface connected to R2.

!
router bgp 30
�network 6.6.6.0 mask 255.255.255.0
�network 7.7.7.0 mask 255.255.255.0

!--- Network commands announce prefix 6.6.6.0/24


!--- and 7.7.7.0/24.

�neighbor 10.10.13.1 remote-as 100

!--- Establishes peering with R1.

�neighbor 10.10.13.1 send-community

-
!--- Without this command, the community attributes
!--- are not sent to the neighbor.

�neighbor 10.10.13.1 route-map Peer-R1 out

!--- Configures outbound policy as defined by


!--- route-map "Peer-R1" when peering with R1.

�neighbor 10.10.23.2 remote-as 100

!--- Establishes peering with R2.

�neighbor 10.10.23.2 send-community

!--- Configures to send community attribute to R2.

�neighbor 10.10.23.2 route-map Peer-R2 out

!--- Configures outbound policy as defined by


!--- route-map "Peer-R2" when peering with R2.

�no auto-summary
!
ip classless
ip bgp-community new-format

!--- Allows you to configure the BGP community


!--- attribute in AA:NN format.

!
access-list 101 permit ip host 6.6.6.0 host 255.255.255.0
access-list 102 permit ip host 7.7.7.0 host 255.255.255.0
!
!
route-map Peer-R1 permit 10
�match ip address 101
�set community 100:300

!--- Sets community 100:300 for routes matching access-list 101.

!
route-map Peer-R1 permit 20
�match ip address 102
�set community 100:250

!--- Sets community 100:250 for routes matching access-list 102.

!
route-map Peer-R2 permit 10
�match ip address 101
�set community 100:250

!--- Sets community 100:250 for routes matching access-list 101.

!
route-map Peer-R2 permit 20
�match ip address 102
�set community 100:300

!--- Sets community 100:300 for routes matching access-list 102.

!
end

R1
Version 12.2
!
hostname R1
!
interface Loopback0
�ip address 200.200.200.1 255.255.255.0
!���������
interface Serial8/0
�ip address 10.10.13.1 255.255.255.0

!--- Connected to R3.
�
!���������
interface Serial10/0
�ip address 10.10.12.1 255.255.255.0

!--- Connected to R2.

!���������
router bgp 100
�no synchronization
�bgp log-neighbor-changes
�neighbor 10.10.12.2 remote-as 100

!--- Establishes peering with R2.

�neighbor 10.10.12.2 next-hop-self
�neighbor 10.10.13.3 remote-as 30

!--- Establishes peering with R3.

�neighbor 10.10.13.3 route-map Peer-R3 in

!--- Configures the inbound policy as defined by


!--- route-map "Peer-R3" when peering with R3.

�no auto-summary
!���������
ip bgp-community new-format

!--- Allows you to configure the BGP community


!--- attribute in AA:NN format.

ip community-list 1 permit 100:300
ip community-list 2 permit 100:250

!--- Defines community list 1 and 2.

!���������
route-map Peer-R3 permit 10
�match community 1
�set local-preference 130

!--- Sets local preference 130 for all routes


!--- matching community list 1.

!���������
route-map Peer-R3 permit 20
�match community 2
�set local-preference 125

!--- Sets local preference 125 for all routes


!--- matching community list 2.

!���������
route-map Peer-R3 permit 30


!--- Without this permit 30 statement, updates that do not 


!--- match the permit 10 or permit 20 statements are dropped.


!
end

R2
Version 12.2
!
hostname R2
!
interface Loopback0
ip address 192.168.50.1 255.255.255.0
!
interface Serial9/0
ip address 10.10.23.2 255.255.255.0

!--- Connected to R3.

!
interface Serial10/0
ip address 10.10.12.2 255.255.255.0

!--- Connected to R1.

!
router bgp 100
�no synchronization
�bgp log-neighbor-changes
�neighbor 10.10.12.1 remote-as 100

!--- Establishes iBGP peering with R1.

�neighbor 10.10.12.1 next-hop-self
�neighbor 10.10.23.3 remote-as 30

!--- Establishes peering with R3.

�neighbor 10.10.23.3 route-map Peer-R3 in

!--- Configures inbound policy as defined by


!--- route-map "Peer-R3" when peering with R3.

�no auto-summary
!
ip bgp-community new-format

!--- Allows you to configure the BGP community


!--- attribute in AA:NN format.

!
ip community-list 1 permit 100:300
ip community-list 2 permit 100:250

!--- Defines community list 1 and 2.

!
route-map Peer-R3 permit 10
�match community 1
�set local-preference 130

!--- Sets local preference 130 for all routes


!--- matching community list 1.

!�
route-map Peer-R3 permit 20
�match community 2
�set local-preference 125

!--- Sets local preference 125 for all routes


!--- matching community list 2.

!
route-map Peer-R3 permit 30


!--- Without this permit 30 statement, updates that do not 


!--- match the permit 10 or permit 20 statements are dropped.

!

end

Verificación

El r1 recibe los prefijos 6.6.6.0/24 y 7.7.7.0/24 con las comunidades 100:300 y 100:250, tal y como se muestra en de intrépido en la demostración resultado de ip bgp de esta sección.

Nota: Una vez que estas rutas están instaladas en la tabla BGP basada en la directiva configurada, los prefijos con la comunidad 100:300 se asignan la preferencia local 130 y los prefijos con la comunidad 100:250 se asignan la preferencia local 125.

R1# show ip bgp 6.6.6.0 
BGP routing table entry for 6.6.6.0/24, version 2
Paths: (1 available, best #1, table Default-IP-Routing-Table)
� Advertised to non peer-group peers:
� 10.10.12.2�
� 30
��� 10.10.13.3 from 10.10.13.3 (6.6.6.1)
����� Origin IGP, metric 0, localpref 130, valid, external, best
����� Community: 100:300

!--- Prefix 6.6.6.0/24 with community 100:300 received from


!--- 10.10.13.3 (R3) is assigned local preference 130.

R1# show ip bgp 7.7.7.0 
BGP routing table entry for 7.7.7.0/24, version 4
Paths: (2 available, best #1, table Default-IP-Routing-Table)
� Advertised to non peer-group peers:
� 10.10.13.3�
� 30
��� 10.10.12.2 from 10.10.12.2 (192.168.50.1)
����� Origin IGP, metric 0, localpref 130, valid, internal, best

!--- Received prefix 7.7.7.0/24 over iBGP from 10.10.12.2


!--- (R2) with local preference 130.

� 30
��� 10.10.13.3 from 10.10.13.3 (6.6.6.1)
����� Origin IGP, metric 0, localpref 125, valid, external
����� Community: 100:250

!--- Prefix 7.7.7.0/24 with community 100:250 received from


!--- 10.10.13.3 (R3) is assigned local preference 125.

R1# show ip bgp
BGP table version is 4, local router ID is 200.200.200.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

�� Network��������� Next Hop����������� Metric LocPrf Weight Path
*> 6.6.6.0/24������ 10.10.13.3�������������� 0��� 130����� 0 30 i
*>i7.7.7.0/24������ 10.10.12.2�������������� 0��� 130����� 0 30 i
*������������������ 10.10.13.3�������������� 0��� 125����� 0 30 i

El comando show ip bgp en el r1 confirma que el mejor trayecto seleccionado en el r1 está con el preference(LoclPrf) local = 130.

La semejanza, r2 recibe los prefijos 6.6.6.0/24 y 7.7.7.0/24 con las comunidades 100:250 y 100:300, tal y como se muestra en de intrépido en la salida del comando show ip bgp de esta sección.

Nota: Una vez que estas rutas están instaladas en la tabla BGP, sobre la base de la directiva configurada, los prefijos con la comunidad que 100:300 se asigna la preferencia local 130 y los prefijos con la comunidad 100:250 se asignan la preferencia local 125.

R2# show ip bgp 6.6.6.0
BGP routing table entry for 6.6.6.0/24, version 2
Paths: (2 available, best #2, table Default-IP-Routing-Table)
� Advertised to non peer-group peers:
� 10.10.23.3�
� 30
��� 10.10.23.3 from 10.10.23.3 (6.6.6.1)
����� Origin IGP, metric 0, localpref 125, valid, external
����� Community: 100:250

!--- Prefix 6.6.6.0/24 with community 100:250 received from


!--- 10.10.23.3 (R3) is assigned local preference 125.

� 30
��� 10.10.12.1 from 10.10.12.1 (200.200.200.1)
����� Origin IGP, metric 0, localpref 130, valid, internal, best

!--- Received prefix 6.6.6.0/24 over iBGP from 10.10.12.1


!--- (R1) with local preference 130.

R2# show ip bgp 7.7.7.0
BGP routing table entry for 7.7.7.0/24, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
� Advertised to non peer-group peers:
� 10.10.12.1�
� 30
��� 10.10.23.3 from 10.10.23.3 (6.6.6.1)
����� Origin IGP, metric 0, localpref 130, valid, external, best
����� Community: 100:300

!--- Prefix 7.7.7.0/24 with community 100:300 received from


!--- 10.10.23.3 (R3) is assigned local preference 130.

R2# show ip bgp
BGP table version is 3, local router ID is 192.168.50.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

�� Network��������� Next Hop����������� Metric LocPrf Weight Path
*� 6.6.6.0/24������ 10.10.23.3�������������� 0��� 125����� 0 30 i
*>i���������������� 10.10.12.1�������������� 0��� 130����� 0 30 i
*> 7.7.7.0/24������ 10.10.23.3�������������� 0��� 130����� 0 30 i

Esta salida del comando show ip bgp en el r2 confirma el mejor trayecto seleccionado en el r2 está con el preference(loclPrf) local = 130.

La ruta de IP al prefix� 6.6.6.0/24 prefiere el link R1-R3 que sale fuera del AS100 hacia el AS30. El comando show ip route en el r1 y el r2 confirma eso.

R1# show ip route 6.6.6.0
Routing entry for 6.6.6.0/24
� Known via "bgp 100", distance 20, metric 0
� Tag 30, type external
� Last update from 10.10.13.3 3d21h ago
� Routing Descriptor Blocks:
� * 10.10.13.3, from 10.10.13.3, 3d21h ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1

!--- On R1, the IP route to prefix 6.6.6.0/24 points


!--- to next hop 10.10.13.3 which is R3 serial 8/0


!--- interface on the R1-R3 link.

R2# show ip route 6.6.6.0
Routing entry for 6.6.6.0/24
� Known via "bgp 100", distance 200, metric 0
� Tag 30, type internal
� Last update from 10.10.12.1 3d21h ago
� Routing Descriptor Blocks:
� * 10.10.12.1, from 10.10.12.1, 3d21h ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1

!--- On R2, IP route to prefix 6.6.6.0/24 points


!--- to next hop R1 (10.10.12.1) on its iBGP link.


!--- Thus traffic to network 6.6.6.0/24 from R2


!--- exits through R2-R1 and then�R1-R3 link from


!--- AS 100 towards AS 30.

La ruta de IP a prefix�7.7.7.0/24 prefiere el link R2-R3 que sale fuera del AS100 hacia el AS30. El comando show ip route en el r1 y el r2 confirma eso.

R2# show ip route 7.7.7.0�
Routing entry for 7.7.7.0/24
� Known via "bgp 100", distance 20, metric 0
� Tag 30, type external
� Last update from 10.10.23.3 3d22h ago
� Routing Descriptor Blocks:
� * 10.10.23.3, from 10.10.23.3, 3d22h ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1

!--- On R2, IP route to prefix 7.7.7.0/24 points


!--- to next hop 10.10.23.3 which is R3 serial 9/0


!--- interface on R2-R3 link.

R1# show ip route 7.7.7.0
Routing entry for 7.7.7.0/24
� Known via "bgp 100", distance 200, metric 0
� Tag 30, type internal
� Last update from 10.10.12.2 3d22h ago
� Routing Descriptor Blocks:
� * 10.10.12.2, from 10.10.12.2, 3d22h ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1


!--- On R1, IP route to prefix 7.7.7.0/24 points


!--- to next hop R2 (10.10.12.2) on its iBGP link.


!--- Thus traffic to network 7.7.7.0/24�from�R1


!--- exits through R1-R2 and then�R2-R3 link


!--- from AS 100 towards AS 30.

En caso de error de un link, por ejemplo el link R1-R3, todo el tráfico debe seguir el link R2-R3. Usted puede simular eso si usted apaga el link entre el R1-R3.

R1# conf t
Enter configuration commands, one per line.�End with CNTL/Z.
R1(config)#int s8/0
R1(config-if)#shut
R1(config-if)#
3d22h: %BGP-5-ADJCHANGE: neighbor 10.10.13.3 Down Interface flap
3d22h: %LINK-5-CHANGED: Interface Serial8/0, changed state to
  administratively down
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial8/0,
  changed state to down

Observe la tabla de IP Routing para prefijar 6.6.6.0/24 y 7.7.7.0/24 en R1 y R2. Utilice el link R2-R3 para salir fuera del AS100.

R1# show ip route 6.6.6.0
Routing entry for 6.6.6.0/24
� Known via "bgp 100", distance 200, metric 0
� Tag 30, type internal
� Last update from 10.10.12.2 00:01:47 ago
� Routing Descriptor Blocks:
� * 10.10.12.2, from 10.10.12.2, 00:01:47 ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1
R1# show ip route 7.7.7.0
Routing entry for 7.7.7.0/24
� Known via "bgp 100", distance 200, metric 0
� Tag 30, type internal
� Last update from 10.10.12.2 3d22h ago
� Routing Descriptor Blocks:
� * 10.10.12.2, from 10.10.12.2, 3d22h ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1

Esta salida del comando show muestra que la ruta a las puntas de los prefijos 6.6.6.0/24 y 7.7.7.0/24 al salto siguiente 10.10.12.2, (r2), se espera que. Ahora heche una ojeada la tabla de IP Routing en el Next-Hop del control R2to del prefijo 6.6.6.0/24 y 7.7.7.0/24. El salto siguiente debe ser R3 para la directiva configurada para trabajar con éxito.

R2# show ip route 6.6.6.0
Routing entry for 6.6.6.0/24
� Known via "bgp 100", distance 20, metric 0
� Tag 30, type external
� Last update from 10.10.23.3 00:04:10 ago
� Routing Descriptor Blocks:
� * 10.10.23.3, from 10.10.23.3, 00:04:10 ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1
R2# show ip route 7.7.7.0
Routing entry for 7.7.7.0/24
� Known via "bgp 100", distance 20, metric 0
� Tag 30, type external
� Last update from 10.10.23.3 3d22h ago
� Routing Descriptor Blocks:
� * 10.10.23.3, from 10.10.23.3, 3d22h ago
����� Route metric is 0, traffic share count is 1
����� AS Hops 1

El salto siguiente 10.10.23.3 es R3 interfaz del serial 9/0 en el R2-R3 link.� que éste confirma los trabajos configurados de la directiva como se esperaba.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 28784