Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Uso de un adaptador de terminal ADTRAN con los routers de Cisco

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Los adaptadores de terminal ISDN de ADTRAN (TA) se pueden utilizar para proporcionar la Conectividad del Basic Rate Interface (BRI) al Routers sin las interfaces BRI. El TA (conectado con el puerto serial) termina la llamada BRI y transmite los datos al router mientras que los datos sincrónicos fluyen.

Este documento delinea cómo a ADTRAN ISU™ TA trabajar con los routeres Cisco. Recomendamos que usted refiere a la Documentación del Producto en el sitio webleavingcisco.com de ADTRAN antes del procedimiento.

prerrequisitos

Requisitos

Verifique que el circuito BRI esté funcionando correctamente. Usted puede desear utilizar el circuito en un router con un puerto BRI para probar el circuito antes de desplegarlo en esta configuración. También verifique y pruebe el dispositivo de peer para asegurarse de que funciona correctamente.

Para algunas aplicaciones, ADTRAN ISU debe soportar el Multilink PPP síncrono (MPPP). Los ISU que soportan el MP síncrono incluyen el ISU expreso (los numeros de parte 1200.081L5, 1200.081L6, y 1202.081 L6), ISU 2x64 (1200.051L1 y 1200.051L2), y la segunda generación ISU 128 (1202.029L2 y 1202.029L3.)

Para utilizar el MPPP en un router Cisco, la revisión del software del ISU debe ser actualizada. Una lista de revisiones del software mínimo se presenta el subproducto en la tabla abajo:

Unidad Número de Pieza Revisión del software
ISU 128 1202.029 E.00
ISU 2x64 1200.051 D.00 o G.00
ISU L6 expreso 1200.081L6 K.28
ISU L6 expreso 1202.081L6 D.43

Nota: Puesto que los requisitos pueden cambiar, verifique los requerimientos de firmware con usar ADTRAN ISU con los routeres Ciscoleavingcisco.com .

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Un router con una interfaz de serie sincrónico. La interfaz serial puede ser incorporada o en un módulo WIC/Network.

  • No hay restricciones del software del ½ del ¿Â de Cisco IOSï para esta configuración.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Método de marcado

Hay tres métodos que se pueden utilizar para iniciar un dial por el TA:

  • Marca V.25 o del V.25bis

  • Marca del terminal de datos preparado (DTR)

  • Marca del telclado numérico

Marcado V.25 o V.25bis

Usando este método, el router envía un número de teléfono al TA. Este método permite que el router ponga y reciba las llamadas ISDN. Para activar V.25/V,.25bis que marca, usted debe configurar el comando dialer in-band en la interfaz del router. Por ejemplo:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast 5551212&5551213
   ppp authentication chap
   dialer-group 1

Usted debe configurar el ISU para la marca del V.25bis y el MPPP.

Cuando el router recibe el tráfico interesante, aumenta el DTR y el Request To Send (RTS), que hace el TA iniciar un dial en el primer Canal B. Sin embargo, el router no pide el TA para iniciar la segunda conexión del Canal B. En este caso, ADTRAN se debe programar para marcar el segundo Canal B o para tener el segundo número pasajero dentro de la misma cadena del dialer. La interfaz del serial del router es una interfaz Point-to-Point y no tiene ninguna idea del número de Canales B configurados en ADTRAN.

No configure el comando ppp multilink en el router, puesto que el TA maneja realmente la conexión de links múltiples, mientras que el proceso de la necesidad del router solamente el flujo de datos síncrono del TA.

Nota: Usando las correspondencias del marcado múltiple (pues en las interfaces BRI) no ayuda para este problema del multilink.

Marcación DTR

Usando este método, el router puede poner solamente las llamadas a un número de teléfono determinado, él no puede recibir las llamadas entrantes. Con este método, los números de teléfono del sitio remoto se deben salvar en la memoria del TA. Cuando el TA ve el DTR pasar a ALTO, marca el número que se salva en el TA. Esto requiere el comando dialer dtr bajo interfaz serial. Por ejemplo:

Ejemplo:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer dtr
   dialer idle-timeout 300
   ppp authentication chap

ADTRAN se debe configurar para el marcado DTR, Multilink PPP, y así sucesivamente, y tiene el número de teléfono de destino programado.

Ambos Canales B son marcados por ADTRAN.

Marcado con teclado numérico

Algunos TA tienen telclados numéricos en ellos a tener en cuenta el marcado interactivo directamente del TA. Con este método, el usuario debe entrar el número para marcar en el teclado TA cada vez que una conexión debe ser hecha. Este método se utiliza sobre todo para comprobar para verificar la Conectividad. La configuración del router requerida se muestra abajo:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast
   ppp authentication chap

Cableado

Para conectar el puerto serial del router con el uso TA un cable de DTE V.35 (con el puerto serial DB-60 o el smart serial en un lado). El diagrama siguiente muestra un cable de la muestra:

adtran_ta1.gif

Si el TA tiene solamente un puerto RS-232, después usted también necesita un V.35 al cable RS-232 (DB-25) además del cable mostrado arriba. Alternativamente, usted puede utilizar apenas un cable DB-60-to-DB-25 RS-232.

Refiera a las secciones del catálogo de productos en los cables seriales para más información sobre el cableado.

Ejemplo de configuración mediante V.25bis

Esta sección muestra a ejemplo de configuración utilizando v.25bis.

/image/gif/paws/28080/adtran_ta2.gif

Configuración ADTRAN ISU

Esta sección incluye algunas extremidades en configurar ADTRAN ISU. Sin embargo, consulte por favor el sitio web de ADTRANleavingcisco.com antes de configurar el TA, como funciones, las características y los parámetros de la configuración pudieron haber cambiado.

  1. Conecte el ADTRAN TA con un PC. Este paso es necesario de modo que usted pueda acceder el TA y configurar los diversos parámetros antes de engancharlo hasta el router.

    Asocie una “terminal marcada adaptador” del RJ-45-to-DB-9 al puerto de las comunicaciones (COM) del PC. Desde el extremo RJ-45 del adaptador, conecte un cable satinado plano RJ-45-- RJ-45 enrollado (número de parte CAB-500RJ=), que se provee para las conexiones de la consola con todos los routers Cisco. Usted también necesita un RJ-45 a DB-25 “MODEM marcado adaptador” (numero de parte CAB-25AS-MMOD) conectar el cable enrollado con el puerto DB-25 etiquetado RS-232 en la parte de atrás de ADTRAN.

  2. ¡Ingrese EN! ¡V (o si está conectado con el puerto RS366/Maintenance, uso! V) para obtener el menú principal. Entonces presione el Ctrl+C para ingresar el menú de la configuración.

    Usted debe ver el menú similar al abajo (éste puede variar dependiendo del modelo TA):

     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
                             ISU 128 Configuration Menu
    
     1) Netw. options = Dial Line           17) RTS Options = 1 ms delay
     2) Switch Protocl = National ISDN1     18) CTS Options = Forced CTS
     3) Call type = Data 64Kbps             19) CD Options = Normal
     4) SPID 1 = 51255511110101             20) DTR Options = Idle when Off
     5) SPID 2 = 51255511120101             21) DSR Options = OFF Idle+Test
     6) LDN 1 = 5551111                     22) Transmit Clock = Normal
     7) LDN 2 = 5551112                     23) Protocol = PPP asyn-sync
     8) Dial options = V.25                 24) Method = Multilink
     9) V.25 = V.25 HDLC FLAGS              25) Quick setup
    10) Auto answer = Enabled
    11) Answer tone = No Answer tone
    12) Connect Timout = 30 sec (def)
    13) Call Screening = Answer any
    14) DTE options = Synchronous
    15) Bit Rate = 128000
    16) Connector Type = RS-232
    ____________________________________________________________________________
    
    Select =                                    Enter SELECT    Esc NO CHANGE
    ____________________________________________________________________________
    
     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
  3. Utilice los números de correspondencia para ingresar al modo de configuración para los diversos atributos.

    Los atributos siguientes (en un mínimo) deben ser configurados:

    • Protocolo del Switch: El tipo de switch especificado por la compañía telefónica.

    • Tipo de llamada: Especifique 64 datos k o 56K (dependiendo del tipo de circuito).

    • SPID1, SPID2, LDN1, LDN2: Si procede, asigne los SPID y los LDN proporcionados por la compañía telefónica.

    • Opciones del dial: V.25.

    • V.25: HDLC V.25 (si usa el serial síncrona) o ASYNC V.25 (si usa la serie asíncrona).

    • Opciones DTE: Síncrono (si usa el serial síncrona) o asíncrono (si usa la serie asíncrona).

    • Velocidad de bits: 128000 (o 112000 para las llamadas 56K).

    • Protocolo: El PPP asyn-sincroniza.

    • Método: Multilink.

    Recomendamos que usted refiere a la hoja de datos/a los manuales ISU en el sitio web de ADTRANleavingcisco.com para las opciones posibles para cada parámetro. El ejemplo mostrado arriba debe trabajar para la mayoría de las situaciones.

Configuración y prueba del router

Utilice el siguiente procedimiento para configurar y para probar al router.

  1. Conecte un cable de DTE V.35 o RS-232 con el puerto de serial del router. Refiera al cableado de la sección para más información sobre los Tipos de cable que usted debe utilizar.

  2. Utilice al regulador x serial (que de la demostración indica que el Tipo de cable el router está conectado con) para verificar que el cable en el lado del router es DTE. Por ejemplo:

    Router#show controller serial 1
    HD unit 1, idb = 0xCF6E8, driver structure at 0xD4A30
    buffer size 1524  HD unit 1, RS-232 DTE cable
    cpb = 0xE3, eda = 0x940, cda = 0x800
    ...
    ...

    Usted debe también verificar que la configuración del tipo de conector en ADTRAN (opción 16 en el ejemplo anterior) haga juego el cableado usado.

  3. Configure al router como sigue:

    username peer password 0 cisco
    !
    interface Serial1 
    ip address 192.168.180.2 255.255.255.0 
    encapsulation ppp 
    dialer in-band
     
    !--- Enable V.25bis dialing. 
    
    dialer map ip 192.168.180.22 name peer 5551111&5551112
     
    !--- Dialer map for the peer. 
    !--- Note the multiple numbers separated by "&"
     
    dialer-group 1 
    pulse-time 1 
    ppp authentication chap
    !
    ip classless
    ip route 192.168.180.22 255.255.255.255 Serial1
    dialer-list 1 protocol ip permit

    Nota: Para que el TA saque a colación ambos canales, usted tiene que salvar el segundo número en ADTRAN, o utilice [phonenumber1]&[phonenumber2] en la sentencia del mapa de marcado de Cisco (recomendada). La interfaz serial es apenas una interfaz Point-to-Point, así que tener correspondencias del marcado múltiple no afecta a las conexiones de links múltiples.

    ADTRAN marca el primer número, negocia y autentica, y después marca inmediatamente el segundo. Note que no configuran al comando ppp multilink en el router, puesto que el TA maneja el multilink

    Nota: Si usted desea utilizar la interfaz serial en el modo asincrónico, utilice el comando physical-layer async bajo configuración de la interfaz serial. Sin embargo, un poco de hardware de la interfaz serial no soporta la comunicación asíncrona. Para conectar un módem con esta interfaz, refiera a configurar el dialout usando un módem en el puerto auxiliar. Este documento utiliza el puerto auxiliar. Sin embargo, las configuraciones son muy similares.

  4. Inicie un ping al router remoto. El router envía las cadenas del dialer al TA, que entonces inicia el link ISDN. Una vez que el link ISDN está para arriba, el Routers negocia el PPP y y la autenticación ocurre. Usted debe poder pasar el tráfico ahora.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • debug dialer - Para visualizar la información de debugging sobre los paquetes recibidos en una interfaz capaz del marcador. Cuando el Dial-on-Demand Routing (DDR) se habilita en la interfaz, la información referente a la causa de cualquier llamada (llamada la causa de marcación) también se visualiza. Si desea obtener más información, consulte los datos sobre depuración de dialer en la documentación de comandos de depuración.

  • debug interface serial - Utilice el comando debug serial interface exec al mostrar información en una falla de la conexión en serie. Para más información, vea la información del debug interface serial en la documentación de los comandos Debug.

  • haga el debug de la negociación ppp - Visualiza la información sobre el tráfico y los intercambios PPP mientras que negocia a los componentes PPP incluyendo el (LCP), la autenticación, y el protocolo network control del Link Control Protocol (NCP). Una negociación PPP satisfactoria primero abrirá el estado LCP, después autentica, y finalmente negocia el NCP. Para más información sobre los resultados de la negociación ppp del debug de la lectura refiera por favor a los resultados de la negociación ppp del debug de la comprensión del documento.

  • debug ppp authentication – Muestra los mensajes del protocolo de autenticación PPP, entre ellos intercambio de paquetes de protocolo de autenticación por desafío mutuo (CHAP) e intercambios de protocolo de autenticación de contraseña (PAP). Si desea más información, consulte los siguientes documentos: Resolver problemas la autenticación PPP (GRIETA o PAP).

‘Resultado de debug’

Active el debug dialer y haga el debug de la negociación ppp, después inicie un ping al par. El router debe intentar marcar. Una vez que se establece la conexión ISDN la negociación PPP debe comenzar. La salida de los debugs siguiente muestra una llamada satisfactoria.

Router#show debug
Dial on demand:  Dial on demand events debugging is on
PPP:  
  PPP authentication debugging is on  
  PPP protocol negotiation debugging is on
Router#ping 192.168.180.22
  Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 192.168.180.22, timeout is 2 seconds:
 Serial1: Dialing cause ip (s=192.168.180.2,d=192.168.180.22)

!--- Dialing cause is ping to 192.168.180.22.

   Serial1: Attempting to dial 5551111&5551112
   
!--- Call is dialed out using Serial1 
   !---(which is connected to the ADTRAN).
   !--- Remember that ADTRAN handles the ISDN L1-L3, so ISDN messages
   !--- will not be visible on the router.

   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet.
   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet
   Se1 LCP: I CONFREQ [Closed] id 49 len 15

!--- PPP Negotiation begins.

   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: Lower layer not up, discarding packet
   %LINK-3-UPDOWN: Interface Serial1, changed state to up.
   Se1 PPP: Treating connection as a callout
   Se1 PPP: Phase is ESTABLISHING, Active Open
   Se1 LCP: O CONFREQ [Closed] id 47 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFACK [REQsent] id 48 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFREQ [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: O CONFACK [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: State is Open
   Se1 PPP: Phase is AUTHENTICATING, by both
   Se1 CHAP: O CHALLENGE id 11 len 42 from "Router"
   Se1 CH.AP: I CHALLENGE id 11 len 30 from "peer"
   Se1 CHAP: O RESPONSE id 11 len 42 from "Router"
   Se1 CHAP: I SUCCESS id 11 len 4
   Se1 CHAP: I RESPONSE id 11 len 30 from "peer"
   Se1 CHAP: O SUCCESS id 11 len 4 
   
!--- Authentication is successful.

   Se1 PPP: Phase is UP
   Se1 IPCP: O CONFREQ [Closed] id 16 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFREQ [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   Se1 IPCP: O CONFACK [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, 
   changed state to up
   Se1 IPCP: TIMEout: Time 0x476F808 State ACKsent
   Se1 IPCP: O CONFREQ [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFACK [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: State is Open
   Se1 IPCP: Install route to 192.168.180.22
   dialer Protocol up for Se1

Nota: Para más información sobre los resultados de la negociación ppp del debug de la lectura, refiera por favor a los resultados de la negociación ppp del debug de la comprensión del documento.

Procedimiento de Troubleshooting

Esta sección incluye algunos procedimientos deTroubleshooting comunes. Si usted encuentra los problemas en cualquier paso para referir a la Documentación técnica de ADTRAN para más información:

  1. Verifique que la visualización en el frente de ADTRAN lea como sigue:

    Adtran ISU 128
    [Switch-type] Ready

    Esto se asegura de que Configuración de isdn, por ejemplo el switchtypes, los identificadores del perfil de servicio (SPID) y el Número de directorio local (LDN) ha sido configurado y validado correctamente por la compañía telefónica.

  2. Inicie una conexión de prueba al par que usa el telclado numérico en ADTRAN. Esto puede ayudar a asegurarse de que el circuito ISDN, y la configuración relacionada ISDN en el TA está correctos.

  3. Inicie un ping al par. Usted debe ver el siguiente en la pantalla panel delantero de ADTRAN: “LLAMANDO [PHONENUMBER”. Esto indica que por lo menos el V.25bis está trabajando correctamente. Si usted no ve el mensaje, intente intercambiar los cables e incluso los TA. Esto puede ayudar a aislar los malos cables y interfaces V.35 en el TA.

  4. Active el debug dialer. Inicie un ping. Verifique que usted vea el siguiente en la salida de los debugs:

    Serial1: Dialing cause ip (s=192.168.180.2, d=192.168.180.22)
    Serial1: Attempting to dial 5551111&5551112

    Si usted no ve el mensaje, después el problema es DDR-relacionado. Verifique que la configuración del router esté como se muestra arriba. Aseegurese que la encaminamiento y la definición de tráfico interesante está configurada también.

  5. Active la interfaz serial del debug, inicie un ping y verifiquelo que el TA aumenta data set ready (DSR).

    Solamente cuando el router detecta un alto DSR, la tentativa del router de negociar el PPP. Si no sube el DSR, después debemos resolver problemas una capa inferior tal como ISDN, hardware y cableado.


Información Relacionada


Document ID: 28080