IP : Open Shortest Path First (OSPF)

Ruteo subóptimo al redistribuir entre los procesos OSPF

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento demuestra el problema de ruteo subóptimo al realizar redistribuciones entre procesos OSPF y ofrece soluciones.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Problema

Al redistribuir entre diferentes procesos OSPF en múltiples puntos en la red, es posible encontrarse con situaciones de ruteo inferior al óptimo o, peor aun, un loop de ruteo.

En la topología que se muestra abajo se muestran los procesos OSPF 1 y OSPF 2. Los routers 1 (R1) y 2 (R2) se redistribuyen desde OSPF 1 a OSPF 2.

/image/gif/paws/28025/2ospf-redis-1.jpg

El r1 y el r2 de las configuraciones para Routers se muestran abajo.

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0
 network 10.255.255.1 0.0.0.0 area 0 
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal
 
!--- Redistributing OSPF 1 into OSPF 2.
 
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
!  
ip classless  
!  
end

R2
hostname r2  
!  
ip subnet-zero  
!  
 
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0 
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal

!--- Redistributing OSPF 1 into OSPF 2. 

 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
!  
ip classless  
 
end

En la topología antedicha, el E1/0 R4 está en el área 1 y el E0/0 está en el área 0. Por consiguiente, R4 es un Router de borde de área (ABR) que anuncia la red 10.0.1.0/24 como la ruta entre áreas (IA) hacia R1 y R2. El r1 y el r2 están redistribuyendo esta información en el OSPF2. Resaltan a los comandos redistribute configuration en las configuraciones antedichas del r1 y del r2. Por lo tanto, el r1 y el r2 van a aprender cerca de 10.0.1.0/24 como IA vía el OSPF1 y como tipo-2 externo (E2) vía el OSPF2 porque los anuncios del estado del vínculo externos (LSA) se propagan en el dominio OSPF2.

Puesto que las rutas IA se prefieren siempre sobre el e1 o las rutas E2, la expectativa es considerar, en la tabla de ruteo de r1 y de r2, que 10.0.1.0/24 es una ruta IA con el Next-Hop R4. Sin embargo, al ver sus tablas de ruteo, algo diferente se considera - en el r1, 10.0.1.0/24 es una ruta IA con el Next-Hop R4 pero en el r2, 10.0.1.0/24 es una ruta E2 con el r1 del Next-Hop.

Ésta es la salida de comando del comando show ip route para el r1.

r1#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.
 
 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O E2    10.255.255.2/32 [110/1] via 192.168.0.2, 00:24:21, Ethernet1/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:23:49, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O IA    10.255.255.4/32 [110/11] via 10.0.0.4, 00:23:49, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:09, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:26:09, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:09, Ethernet1/0 

Ésta es la salida de comando del comando show ip route para el r2.

r2#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O E2    10.0.1.0/24 [110/20] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.1/32 [110/1] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.4/32 [110/11] via 192.168.0.1, 00:25:34, Ethernet1/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:45, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:26:45, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:45, Ethernet1/0 

¿Por qué ocurre este problema?

Al habilitar los procesos OSPF múltiples en un router, de la perspectiva del software, los procesos son independientes. El protocolo OSPF, dentro de un proceso OSPF, prefiere siempre la ruta interno sobre la ruta externo. Sin embargo, el OSPF no hace ninguna selección de la OSPF ruta entre los procesos (por ejemplo, no tienen en cuenta la métrica OSPF y a los tipos de la ruta, al decidir a la ruta cuyo el proceso se debe instalar en la tabla de ruteo).

No hay interacción entre diversos procesos OSPF, y los cortacircuítos del lazo son la distancia administrativa. Así, puesto que ambos procesos OSPF tienen una distancia administrativa predeterminada de 110, el primer intentar de proceso instalar que la ruta lo hace en la tabla de ruteo. Por lo tanto, la distancia administrativa para las rutas de diversos procesos OSPF se debe configurar, de modo que las rutas de ciertos procesos OSPF sean preferidas sobre las rutas de otro proceso por la intención humana, y no como cuestión de ocasión.

Para más información sobre la distancia administrativa, refiérase a cuál es distancia administrativa. Para más información sobre cómo un router Cisco selecciona que rutea para colocar en la tabla de ruteo, refiera a la selección de Route en los routeres Cisco.

Soluciones

Solución 1

Puesto que sabemos que en el caso antedicho, el Routers está seleccionando la mejor ruta basada en la distancia administrativa, la manera lógica de prevenir este comportamiento es aumentar la distancia administrativa de las rutas externo en el OSPF2. Esta manera, las rutas aprendidas vía el OSPF1 será preferida siempre sobre las rutas externo redistribuidas del OSPF1 en el OSPF2. Esto se hace usando el <value> externo OSPF de la distancia del comando sub-router configuration tal y como se muestra en de las configuraciones abajo.

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.1 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of external 
!--- routes to 115. 

!  
ip classless  
!  
end 

R2
hostname r2  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of 
!--- external routes to 115. 

!  
ip classless  
!  
end 

La tabla de ruteo resultante cuando el cambio de la distancia administrativa de las rutas externo en el OSPF2 se muestra abajo.

Ésta es la salida de comando del comando show ip route para el r1.

r1#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O       10.255.255.2/32 [110/11] via 10.0.0.2, 00:00:35, Ethernet0/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:00:35, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:00:35, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:00:35, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:00:35, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:00:35, Ethernet1/0 

Ésta es la salida de comando del comando show ip route para el r2.

r2#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O       10.255.255.1/32 [110/11] via 10.0.0.1, 00:01:28, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:01:28, Ethernet0/0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:01:28, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:01:28, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:01:28, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:01:28, Ethernet1/0 

Es importante observar ese en algunos casos, cuando hay también redistribución del OSPF2 en el OSPF1 y hay otros Routing Protocol que son redistribuidos en OSPF2 ([RIP] del Routing Information Protocol, statics del Enhanced Interior Gateway Routing Protocol (EIGRP), y así sucesivamente), esto puede llevar al ruteo subóptimo en el OSPF2 para esas rutas externo.

Solución 2

Si la última razón para implementar dos diversos procesos OSPF es filtrar ciertas rutas, hay una nueva función en el ABR con filtrado de tipo 3 LSA en OSPF llamado Software Release 12.2(4)T del ½ del ¿Â de Cisco IOSï que permite que usted haga el filtrado de Routes en el ABR.

En vez de configurar un segundo proceso OSPF, los links que son la parte de OSPF2, en el ejemplo anterior, se podrían configurar como otra área dentro del OSPF1. Entonces, usted puede implementar el filtrado de Routes requerido en el r1 y el r2 con esta nueva función. Para obtener más información acerca de esta función, consulte el Filtrado LSA Tipo 3 OSPF ABR.


Información Relacionada


Document ID: 28025