IP : Routing IP

Especificar un IP Address de Next Hop para las Static rutas

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (30 Octubre 2006) | Comentarios


Contenido


Introducción

Este documento presenta conceptos básicos sobre rutas estáticas. Este documento utiliza un recreación de un problema para demostrar las circunstancias bajo las cuales es conveniente especificar la interfaz a través de la cual se puede alcanzar la dirección IP de Next Hop al configurar una ruta estática.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Teoría Precedente

La capacidad de configurar una Static ruta fue introducida en la versión 10,0 del Cisco IOS ® Software. Las Static rutas se utilizan por una variedad de razones y son de uso frecuente cuando no hay ruta dinámico al destino, o cuando usted se ejecuta un Dynamic Routing Protocol no es posible.

Por abandono, las Static rutas tienen una distancia administrativa de una, que les da la precedencia sobre las rutas de los Dynamic Routing Protocol. Cuando usted aumenta la distancia administrativa a un valor mayor que el de un Dynamic Routing Protocol, la Static ruta puede ser una red de seguridad en caso que el Dynamic Routing falle. Por ejemplo, Interior Gateway Routing Protocol (IGRP) - las rutas derivadas tienen una distancia administrativa predeterminada de 100. Para configurar una Static ruta que sea reemplazada por una ruta IGRP, especifique una distancia administrativa mayor de 100 para la Static ruta.

Esta clase de Static ruta se llama los parásitos atmosféricos “flotantes”. Está instalada en la tabla de ruteo solamente cuando desaparece la ruta preferida. Por ejemplo, ruta de IP 172.31.10.0 255.255.255.0 10.10.10.2 101.

Nota: Una distancia administrativa de 255 se considera inalcanzable y las Static rutas con una distancia administrativa de 255 nunca se ingresan en la tabla de ruteo.

Si usted señala una Static ruta a una interfaz de broadcast, la ruta se inserta en la tabla de ruteo solamente cuando la interfaz de broadcast está para arriba. Esta configuración no se recomienda porque cuando el salto siguiente de una Static ruta señala a una interfaz, el router considera cada uno de los hosts dentro del rango de la ruta ser conectado directamente a través de esa interfaz. Por ejemplo, ethernet0 de 0.0.0.0 0.0.0.0 de la ruta de IP.

Con los este tipos de configuración, un router realiza el Address Resolution Protocol (ARP) en los Ethernetes para cada destino que el router encuentra a través de la ruta predeterminado porque el router considera todos estos destinos según lo conectado directamente con el ethernet0.

Esta clase de ruta predeterminado, especialmente si es utilizada por muchos paquetes a muchas diversas subredes de destino, puede causar la alta utilización del procesador y una memoria caché ARP muy grande (junto con las fallas de asignación de memoria acompañantes).

Especificar un salto siguiente numérico en una interfaz conectada previene directamente el router del ARP de ejecución o a cada dirección destino. Sin embargo, si va la interfaz con el salto siguiente abajo y el salto siguiente numérico es accesible a través de una ruta recurrente, usted debe especificar el IP Address de Next Hop y la interfaz a través de los cuales el salto siguiente debe ser encontrado. Por ejemplo, serial 3/3 192.168.20.1 de 0.0.0.0 0.0.0.0 de la ruta de IP.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Problema

En este diagrama de la red, hay dos Static rutas al mismo destino (172.31.10.0/24). Una ruta es una estática flotante, es el “respaldo” o trayecto redundante a la red de destino en el LAN. El problema en el escenario es que las Rutas estáticas flotantes nunca consiguen instaladas en la tabla de ruteo cuando se apaga el link principal.

El r1 tiene una ruta predeterminado esas puntas al router del Proveedor de servicios de Internet (ISP) para el acceso a internet. El r1 tiene dos links al r2. El T1 es el link principal y el 56K es el link de backup. El r1 tiene una Static ruta para 172.31.10.0/24 que señale a la dirección IP del serial0 del r2 (10.10.10.2) como el Next-Hop. El r1 también tiene las Rutas estáticas flotantes para 172.131.10.0/24 que señala a la dirección IP del Serial1 del r2 (192.168.20.2), la distancia administrativa para las Rutas estáticas flotantes es 250. La idea está para que los paquetes fluyan sobre el 56K Line en las ambas direcciones solamente si el link principal falla.

/image/gif/paws/27082/ip_static_routes_01.gif

Este ejemplo muestra la configuración del r1:

R1
hostname R1

!
ip subnet-zero
no ip domain-lookup
!
controller E1 2/0
!
controller E1 2/1
!
interface Serial3/0
 description ISP Link
 ip address 192.168.10.1 255.255.255.252
 clockrate 64000
!
interface Serial3/1
 no ip address
 shutdown
!
interface Serial3/2
 description Primary Link to R2
 ip address 10.10.10.1 255.255.255.252
!
interface Serial3/3
 description Backup Link to R2
 ip address  192.168.20.1 255.255.255.252
 clockrate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3/0

!---This is the default route to ISP router.

ip route 172.31.10.0 255.255.255.0 10.10.10.2

!---This is the preferred route to the LAN.

ip route 172.31.10.0 255.255.255.0 192.168.20.2 250

!---This is the floating route to the LAN.

Este ejemplo muestra la tabla de ruteo del r1:

Tabla de ruteo del r1
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

!--- The preferred static route to the LAN through the T1.

S*   0.0.0.0/0 is directly connected, Serial3/0

!--- The static default route to the Internet.

Este ejemplo muestra la configuración del r2:

R2
hostname R2
!
enable password ww
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
 description Local LAN
 ip address 172.31.10.2 255.255.255.0
!
interface Serial0
 description Primary Link to R1
 ip address 10.10.10.2 255.255.255.252
 clockrate 56000
!
interface Serial1
 description Backup Link to R1
 ip address 192.168.20.2 255.255.255.252
!
interface TokenRing0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1

!--- This is the primary default route.

ip route 0.0.0.0 0.0.0.0 192.168.20.1 250

!--- The floating default route to be used if the T1 fails.

no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

El r2 tiene la ruta predeterminado instalada con 10.10.10.1 y cuando usted utiliza el comando traceroute del r2 al router del ISP, los paquetes utilizan el link T1. El r2 puede enviar los ping al host de Internet 192.168.30.1 originado de 172.31.10.2. La ruta a 192.168.30.1 está a través de la ruta predeterminado 0.0.0.0 0.0.0.0.

Tabla de ruteo del r2
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.10.10.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/30 is directly connected, Serial0
S*   0.0.0.0/0 [1/0] via 10.10.10.1

!--- This is the primary default route.

R2#traceroute 192.168.10.2

Type escape sequence to abort.
Tracing the route to 192.168.10.2

  1 10.10.10.1 16 msec 20 msec 16 msec
  2 192.168.10.2 32 msec *  32 msec

R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Si usted apaga el serial 3/2 en el r1 para probar la Conmutación por falla, usted debe esperar que el r1 instale las Rutas estáticas flotantes al LAN local 172.31.10.0 y para que el r2 instale las Rutas estáticas flotantes a 0.0.0.0 con 192.168.20.1. Usted esperaría que el tráfico fluyera sobre el link 56K.

R1
R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s3/2
R1(config-if)#shut
R1(config-if)#end
2d21h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
2d21h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up&                   up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

!--- The static route through the T1 remains in the routing table.
!--- This is not what was expected to happen when Serial 3/2 was shut.

S*   0.0.0.0/0 is directly connected, Serial3/0

!--- The static default route to the Internet.

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.20.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
S*   0.0.0.0/0 [250/0] via 192.168.20.1

!--- It is no longer possible to ping the Internet host 192.168.20.1 if the ping 
!--- is sourced from the LAN on R2 because R1 tries to send the replies
!--- via the Serial 3/2, which is down.

R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Las Rutas estáticas flotantes no fueron instaladas en el r1 y la Static ruta primaria todavía está en la tabla de ruteo de r1 aunque se apaga el link del serial 3/2. La razón que sucede ésta es porque las Static rutas son recurrentes en la naturaleza. Usted mantiene siempre la Static ruta la tabla de ruteo mientras usted tenga una ruta al salto siguiente. En este caso, el r1 piensa que puede conseguir a 10.10.10.2 con 192.168.10.2 porque 192.168.10.2 es el salto siguiente para 0.0.0.0 0.0.0.0.

La ruta a un salto siguiente puede ser una más específica, una menos específica, o una ruta predeterminado. En este recreación de un problema, usted pensaría que puesto que el link está abajo de usted no debe tener una ruta a 10.10.10.2, pero si usted mira la tabla de ruteo en el r1, usted ve que hay una Static Default ruta que señala al router del ISP. El r1, por lo tanto cree que puede alcanzar el salto siguiente (10.10.10.2) para 172.31.10.0/24 a través de esta ruta predeterminado, así que sigue habiendo la Static ruta a 172.31.10.0/24 con 10.10.10.2 en la tabla de ruteo y las Rutas estáticas flotantes nunca consiguen instaladas.

Hay una mejor manera de configurar las Static rutas que permitirían que usted evitara este problema. Si usted especifica la interfaz a través de la cual el salto siguiente debe ser encontrado, usted instalará las Rutas estáticas flotantes solamente si el IP Address de Next Hop es accesible a través de la interfaz especificada. Antes de que la solución a este problema se presente, usted traerá a serial 3/2 interfaz en la salvaguardia del r1 otra vez.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#no shut
R1(config-if)#end
R1#
2d22h: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
2d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up
2d22h: %SYS-5-CONFIG_I: Configured from console by console


R1#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0&             192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Solución

La solución es quitar las viejas Static rutas al LAN (172.31.10.0) y configurar las nuevas Static rutas, este vez que especifica la interfaz a través de la cual el salto siguiente debe ser alcanzado. Esto permite que las Rutas estáticas flotantes en el r1 consigan instaladas cuando se cierra la interfaz del serial 3/2.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#no ip route 172.31.10.0 255.255.255.0 10.10.10.2
R1(config)#no ip route 172.31.10.0 255.255.255.0 192.168.20.2 250
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/2 10.10.10.2
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/3 192.168.20.2 250
R1(config)#end
R1#
2d22h: %SYS-5-CONFIG_I: Configured from console by console

La Static ruta a 172.31.10.0 con 10.10.10.2 está instalada en la tabla de ruteo de r1 si 10.10.10.2 se ve con el serial 3/2. Si esta condición no se cumple, la Static ruta con 10.10.10.2 se quita de la tabla de ruteo y las Rutas estáticas flotantes a 172.31.10.0 con el serial 3/3 con el salto siguiente 192.168.20.2 están instaladas.

Para probar cómo esto trabaja y derribe el link T1, apague el serial 3/2 y vea si las Rutas estáticas flotantes consiguen instaladas en la tabla de ruteo.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#shut
R1(config-if)#end
R1#
3d00h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
3d00h: %SYS-5-CONFIG_I: Configured from console by console
3d00h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [250/0] via 192.168.20.2, Serial3/3
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Ahora el r1 puede hacer ping el host de Internet 192.168.20.1 con los paquetes originados del LAN.

R2
R2#ping
Protocol [ip]:
Target IP address: 192.168.20.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Las Rutas estáticas flotantes consiguen instaladas como se esperaba.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 27082