Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Symmetrical High-Data-Rate DSL (G.SHDSL)

Configuración adosada de CPE a través de puertos G.SHDSL

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento provee una configuración de ejemplo para dos routers adosados a través de los puertos Multirate Symmetric High-Speed Digital Subscriber Line (G.SHDSL). Describe cómo un router del ½ del ¿Â G.SHDSL Ciscoï puede ser configurado para trabajar el ½ del ¿Â del asï un dispositivo DSL de la oficina que termine una conexión de otro dispositivo CPE del telecontrol G.SHDSL.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • 828 Software Release 12.2(8)T1 del ½ del ¿Â de Cisco IOSï del Customer Premises Equipment que se ejecuta (CPE)

  • Cisco IOS Software Release 12.2(8)T corriente del 2612 Router

  • 2612 Router que usa un tarjeta de interfaz WAN (WIC)-1SHDSL

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/25900/dsl_cpe_config1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Nota: En esta configuración el 828A se configura con el tipo de equipo “CO,” que simula la señalización del CO. Mientras que los 2612 con el G.SHDSL WIC se configura con el tipo de equipo “CPE.”

CPE DSL5-828A(Cisco 828 que actúa como CO)
DSL5-828A#show run
Building configuration...

Current configuration : 769 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSL5-828A
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Dialer0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!         
dialer-list 1 protocol ip permit
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

DSL4-2612A (Cisco 2612 Router que actúa como CPE)
dsl4-2612a#show run
Building configuration...

Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dsl4-2612a
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/0
 ip address 172.16.1.2 255.255.255.0
 shutdown
 half-duplex
!         
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Dialer0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!         
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Referencia de Comandos

Esta sección documenta los comandos modificados. El resto de los comandos usados con esta característica se documentan en las publicaciones de referencias de comandos del Cisco IOS Software Release 12.2.

Comandos Modificados

  • dsl equipment-type

  • dsl linerate

  • modo de operación dsl (g.shdsl)

dsl equipment-type

Publique el comando dsl equipment-type en el modo de la interfaz ATM de configurar la interfaz ATM DSL para funcionar como el equipo o el CPE CO. No utilice la ninguna forma de este comando de restablecer el tipo de equipo predeterminado.

  • tipo de equipo dsl {co | cpe}

  • ningún tipo de equipo dsl

Las descripciones de la sintaxis para estos comandos son:

  • co — Configura la interfaz ATM DSL para funcionar como el equipo CO.

  • cpe — Configura la interfaz ATM DSL para funcionar como el CPE.

Valores predeterminados

Las funciones de la interfaz ATM DSL como el CPE.

Modo de comando interface

La interfaz ATM para el G.SHDSL WIC era integrada en estas versiones de Cisco IOS Software:

  • 12.2(4)XL — en los Cisco 2600 Series Router

  • 12.2(8)T — en las Cisco 2600 Series y los Cisco 3600 Series Router

Pautas de uso

Este comando configuration se aplica a una interfaz ATM específica. Usted debe especificar la interfaz ATM antes de que usted publique este comando. La interfaz ATM debe también estar en el estado de cierre normal antes de que usted publique este comando. Este ejemplo muestra cómo configurar la interfaz ATM 1/1 DSL para funcionar como el equipo CO.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 1/1 
Router(config-if)#dsl equipment-type co 

Router(config-if)#end 
Router# clear interface atm 0/1 

Router#

Comandos relacionados

  • linerate dsl — Especifica una línea tarifa para la interfaz ATM DSL.

  • modo de operación dsl (g.shdsl) — Especifica a un modo de operación de la interfaz ATM DSL.

dsl linerate

Publique el comando dsl linerate en el modo de la interfaz ATM de especificar una línea tarifa para la interfaz ATM DSL. No utilice la ninguna forma de este comando de restablecer la tarifa de la línea predeterminada.

  • linerate dsl {kbps | auto}

  • ningún linerate dsl

Las descripciones de la sintaxis para estos comandos son:

  • kbps — Especifica una línea tarifa en los kilobites por segundo para la interfaz ATM DSL. Las Entradas permitidas son 72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056, y 2312.

  • auto — Configura la interfaz ATM DSL para entrenar automáticamente para una línea óptima tarifa negociando con el Multiplicador de acceso DSL del otro extremo (DSLAM) o el WIC.

Valores predeterminados

La interfaz ATM DSL sincroniza automáticamente su línea tarifa con el otro extremo DSLAM o WIC.

Modo de comando interface

La interfaz ATM para el G.SHDSL WIC era integrada en estas versiones de Cisco IOS Software:

  • 12.2(4)XL — en los Cisco 2600 Series Router

  • 12.2(8)T — en las Cisco 2600 Series y los Cisco 3600 Series Router

Pautas de uso

Este comando configuration se aplica a una interfaz ATM específica. Usted debe especificar la interfaz ATM antes de que usted publique este comando. La interfaz ATM debe también estar en el estado de cierre normal antes de que usted publique este comando. Este ejemplo muestra cómo configurar la interfaz ATM 0/1 DSL para actuar a una velocidad de línea de 1040 kbps:

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/1 
Router(config-if)#dsl linerate 1040 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router# 

Comandos relacionados

  • tipo de equipo dsl — Configura la interfaz ATM DSL para funcionar como el equipo o el CPE CO.

  • modo de operación dsl (g.shdsl) — Especifica a un modo de operación de la interfaz ATM DSL. Utilice el noform de este comando de restablecer al modo de operación predeterminado.

modo de operación dsl (g.shdsl)

Publique el comando de la interfaz ATM del modo de operación dsl de especificar a un modo de operación del DSL para una interfaz ATM. No utilice la ninguna forma de este comando de restablecer al modo de operación predeterminado.

  • anexo simétrico del gshdsl del modo de operación dsl {A | B}

  • ningún modo de operación dsl

Las descripciones de la sintaxis para estos comandos son:

  • gshdsl — Configura la interfaz ATM DSL para actuar en el modo de alta velocidad del multirate por ITU G.991.2.

  • simétrico — Configura la interfaz ATM DSL para actuar en el modo simétrico por ITU G.991.2.

  • anexo {A | B} — especifica los parámetros de funcionamiento regionales. Ingrese A para Norteamérica y B para Europa. El valor por defecto es A.

Valores predeterminados

El modo de operación predeterminado es el anexo simétrico A.G.SHDSL.

Modo de comando interface

La interfaz ATM para el G.SHDSL WIC fue introducida en el Cisco IOS Software Release 12.1(3)X, e integrada en estas versiones de Cisco IOS Software.

  • 12.2(2)T — en los Cisco 1700 Series Router

  • 12.2(4)XL — en los Cisco 2600 Series Router

  • 12.2(8)T — en las Cisco 2600 Series y los Cisco 3600 Series Router

Pautas de uso

Este comando configuration se aplica a una interfaz ATM específica. Usted debe especificar la interfaz ATM antes de que usted publique este comando. La interfaz ATM debe también estar en el estado de cierre normal antes de que usted ingrese este comando. Este ejemplo muestra cómo configurar la interfaz ATM 0/0 DSL para actuar en el modo G.SHDSL.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/0 
Router(config-if)#dsl operating-mode gshdsl symmetric annex A 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router#

Comandos relacionados

  • tipo de equipo dsl — Configura la interfaz ATM DSL para funcionar como el equipo o el CPE CO.

  • linerate dsl — Especifica una línea tarifa para la interfaz ATM DSL.

Verificación

Usted debe ver esta salida el ir a través de la sesión de consola. Publique el comando term mon, si usted es telnetted en el Routers, de ver los mensajes de la consola.

00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. 
It may take several seconds for the line to be active. 
00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • ejecutar-config de la demostración — Verifica la configuración actual, y ve el estatus para todos los reguladores.

  • muestre a reguladores el slot /puerto ATM — Estadísticas del regulador atmósfera de las opiniones.

  • muestre el VC ATM — Verifica el estatus del circuito virtual permanente (PVC).

  • muestre la interfaz ATM dsl — Ve el estatus del módem G.SHDSL

  • muestre la interfaz ATM — Ve el estatus de la interfaz ATM.

Ésta es salida de ejemplo del comando show atm vc. Aseegurese que los PVC activos están para arriba.

dsl4-2612a#show atm vc 
           VCD /                                        Peak  Avg/Min Burst 
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
0/0        2              8    35  PVC    MUX      UBR    2304                UP

Ésta es salida de ejemplo del comando show dsl interface atm. Si la línea está abajo, la línea no es activa. Algunos de los valores pueden no ser exactos. la declaración aparece. Usted puede también verificar si la configuración del tipo de equipo y del modo de operación esté correcta para su aplicación.

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Data (0x1) 
 Received SNR:           39 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5 

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

Line is not active. Some of the values printed may not be accurate. 
 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Idle (0x0) 
 Received SNR:           38 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5

Si usted no puede hacer ping a través del circuito atmósfera, verifique que la interfaz ATM sea UP/UP publicando el comando show interface para la interfaz ATM en ambo Routers. Publique el comando show interface atm de ver el estatus de la interfaz ATM. Aseegurese que el slot atmósfera, el puerto, y el Line Protocol están para arriba, pues este ejemplo muestra.

DSL5-828A#show interfaces atm0 
ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
  MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ATM, loopback not set 
  Encapsulation(s): AAL5, PVC mode 
  10 maximum active VCs, 2 current VCCs 
  VC idle disconnect time: 300 seconds 
  Last input never, output 00:00:08, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: None 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     261 packets input, 11170 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     264 packets output, 11388 bytes, 0 underruns 
     0 output errors, 0 collisions, 2 interface resets 
     0 output buffer failures, 0 output buffers swapped out

Resolución de problemas

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • haga el debug de los eventos ATM — Identifica los eventos relacionados atmósfera mientras que se generan.

  • errores del debug ATM — Indica qué interfaces tienen problema.

Ésta es información del debug de la muestra de una interfaz ATM, ejecutando los debugs enumerados en esta sección, y viniendo en línea (tenga presente que puede ser que tome 30 segundos o a más para que suba el circuito).

01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
01:07:15: dslsar disable ATM0/0 

01:07:15: %GSI-6-RESET: Interface ATM0/0, bringing up the line.
It may take several seconds for the line to be active. 
01:07:15: Resetting ATM0/0 
01:07:15:  dslsar_1a_config(ATM0/0) 
01:07:15:  dslsar_1a_enable(ATM0/0) 
01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 
01:07:15: dslsar disable ATM0/0 

01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 

01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C 
dsl4-2612a# 
dsl4-2612a# 
01:07:16: %SYS-5-CONFIG_I: Configured from console by console 
01:07:19: dslsar disable ATM0/0 

01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 
01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 
01:08:09:  dslsar_periodic: ENABLING DSLSAR 

01:08:09: dslsar enable ATM0/0 

01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15, max_pkt_len = 4470, 
max_tx_time = 1862ATM0/0 last_address 0x12E14 

01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
01:08:11:  dslsar_atm_lineaction(ATM0/0): state=4 
01:08:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
01:08:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

Información Relacionada


Document ID: 25900