IP : Open Shortest Path First (OSPF)

Los efectos de la dirección de reenvío en una selección de ruta LSA del tipo 5

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El propósito de este documento es demostrar el comportamiento de selección de trayectoria de Open Shortest Path First (OSPF) cuando un router dos anuncios de estado de vínculo de tipo 5 (LSA) para una red externa dada. En este ejemplo, una LSA tiene la dirección de reenvío configurada en cero (0.0.0.0), y la otra tiene una dirección de reenvío configurada en un valor distinto de cero.

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de lo siguiente:

  • IP Routing General

  • Conceptos y términos del Protocolo de ruteo OSPF

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Cisco 2503 Router

  • Software Release 12.2(24a) del � del Cisco IOS que se ejecuta en todo el Routers

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Qué efectos puede tener el reenvío de direcciones LSA del tipo 5 en la selección de trayecto

Las direcciones de reenvío no están configuradas para ambos LSA

La topología mostrada a continuación se utiliza para demostrar el modo en que la dirección de reenvío OSFP de una LSA de tipo 5 puede afectar la selección del trayecto de la LSA de tipo 5.

/image/gif/paws/25493/type5_lsa_01.gif

En el diagrama arriba, todo el Routers, con excepción del router 8, está ejecutando el OSPF en el área 0. con el fin este documento, las configuraciones del router 3 y el Router4 sean los más importantes porque son el Autonomous System Boundary Router (ASBR) que genera el tipo 5 LSA. Tal como aparece debajo, Router 3 y Router 4 poseen una ruta estática a la red 200.200.200.0 255.255.255.0, la cual se redistribuye en OSPF.

Router 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Router 4
interface Ethernet0
 ip address 172.16.3.4 255.255.255.0
!
interface Serial0
 ip address 172.16.7.4 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.7.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Nota: El router3 y el Router4 no incluyen la red 172.16.3.0 255.255.255.0 en el proceso OSPF; por lo tanto, el tipo 5 LSA generado por ambo Routers tiene las direcciones de reenvío fijadas a 0.0.0.0

En este ejemplo, el router 5 puede ser utilizado para ver el LSA externo. Para ver el LSA externo, publique el comando show ip ospf database external en el router 5. A continuación, se muestra el resultado de este comando:

Router 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 1514
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000030
  Checksum: 0x93C0
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 1922
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000027
  Checksum: 0x83D4
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

Lo que puede ver más arriba es que las direcciones de reenvío para los LSA tipo 5 generados por los routers 3 y 4 están configuradas en 0.0.0.0. En este caso, el LSA que se debe instalar en la tabla de ruteo del Router 5 se determina comparando las mediciones con los ASBR que generan los LSA. Publicando el comando show ip ospf border-routers en el router 5, usted puede ver la métrica que el router 5 tiene para los ASBR. A continuación, se muestra el resultado de este comando:

Router 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 14
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 14
router-5#

Como se muestra arriba, 64 es el router 5 métrico alcanzar ASBR 172.16.3.3, mientras que el métrico para alcanzar ASBR 172.16.7.4 es 74; por lo tanto, el router 5 elige el LSA generado por ASBR 172.16.3.3 para colocar en su tabla de ruteo (mostrada abajo).

Router 5
router-5# 
show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.2.3, 19:59:25, Serial0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 19:59:25, Ethernet0
C       172.16.2.0 is directly connected, Serial0
router-5#

Dirección de reenvío configurada para un LSA pero no para el otro

Para esta parte del documento se usa la misma topología mencionada anteriormente. La configuración del Router 4 tampoco presenta cambios, pero la configuración del Router 3 ha cambiado para incluir la red 172.16.3.0 255.255.255.0 en el área 0 del proceso OSPF. La configuración del router3 se muestra abajo con el cambio resaltado en intrépido.

Router 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

El resultado del cambio de configuración anterior es que el tipo 5 generado mediante LSA por el router 3 ahora tiene la dirección de reenvío establecida hacia la dirección IP del router 8, como se muestra en el resultado de la base de datos tomado del siguiente router 5.

Router 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 270
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000033
  Checksum: 0x5138
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 172.16.3.8
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 258
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000029
  Checksum: 0x7FD6
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

Puede observar anteriormente el LSA tipo 5 generado por el Router 3 ahora tiene la dirección de reenvío configurada en 172.16.3.8, mientras que el LSA tipo 5 generado por el Router 4 aún tiene una dirección de reenvío 0.0.0.0.

En este caso, el LSA que se instalará en la tabla de ruteo del router 5 es determinado comparando al router 5 métrico al ASBR (el router 4) que generó el LSA con una dirección de reenvío de 0.0.0.0 al router 5 métrico para alcanzar a la dirección de reenvío de 172.16.3.8, que fue fijada para el LSA generó por el ASBR (router 3).

Para ver la métrica a los ASBR, publique el comando de la frontera OSPF del IP de la demostración en el router 5. A continuación se muestran los resultados.

Router 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 15
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 15
router-5#

En la salida antedicha, el métrico al Router4 es 74. Esto se compara al router 5 métrico para alcanzar a la dirección de reenvío de 172.16.3.8, que puede ser considerada usando el comando de 172.16.3.8 de la ruta de IP de la demostración. A continuación, se muestra el resultado de este comando.

Router 5
router-5# show ip route 172.16.3.8
Routing entry for 172.16.3.0/24
  Known via "ospf 7", distance 110, metric 79, type intra area
  Last update from 172.16.2.3 on Serial0, 00:30:49 ago
  Routing Descriptor Blocks:
  * 172.16.2.3, from 172.16.3.3, 00:30:49 ago, via Serial0
      Route metric is 79, traffic share count is 1

router-5#

Así pues, el métrico para alcanzar el router ASBR 4, que es 74, se compara al métrico para alcanzar a la dirección de reenvío de 172.16.3.8 (generado por el router 3), que es 79. Por lo tanto, el LSA instalado en la tabla de ruteo es el LSA generado por el Router4, tal y como se muestra en de la salida del router 5 de la ruta de IP de la demostración abajo.

Router 5
router-5# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.6.6, 00:35:14, Ethernet0
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 00:35:14, Ethernet0
C       172.16.2.0 is directly connected, Serial0
O       172.16.3.0 [110/79] via 172.16.2.3, 00:35:14, Serial0
router-5#

Cuando el métricos de la ruta redistribuido de los ASBR múltiples son iguales como se ilustra en el documento, la dirección de reenvío cambia el comportamiento de la selección de trayecto del tipo 5 LSA. Cuando un router recibe dos el tipo 5 LSA al mismo destino con las direcciones de reenvío fijadas en ambos LSA, el router hace una comparación basada en el métrico a las direcciones de reenvío. El LSA con una dirección de reenvío que ofrezca el métrico más pequeño se coloca en la tabla de ruteo.

Si el métricos de las rutas redistribuido son diferentes, el Routers prefiere la ruta con el métrico más bajo y no el métrico más bajo a la dirección de reenvío.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 25493