IP : IP versión 6

Túnel IPv6 a través de una Red IPv4

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo para tunelizar un RIP (Routing Information Protocol) IPv6, y una red y tráfico BGP (Border Gateway Protocol) IPv6 a través de una red IPv4 preexistente. Esta técnica permite conectar sitios IPv6 sobre la estructura básica IPv4 existente.

El Tunelización del recubrimiento encapsula los paquetes del IPv6 en los paquetes para entrega del IPv4 a través de una infraestructura del IPv4. Esto es similar a cómo usted crea un túnel del Generic Routing Encapsulation (GRE) para transportar el tráfico del Intercambio de paquetes entre redes (IPX) a través de una red del IP. En el centro distribuidor del túnel, un paquete del IPv6 se encapsula en paquete IPV4 y se envía al destino del túnel remoto. Aquí es adonde paquete IPV4 la encabezado se elimina, y el paquete original del IPv6 se remite más lejos en una nube del IPv6.

Éstos son los cinco métodos de tráfico del IPv6 del Tunelización:

  • Túneles de IPv6 manual

  • Túneles compatibles con IPv4 automáticos

  • GRE

  • Túneles automáticos del 6to4

  • Túnel automático del Intra-sitio que dirige los túneles del protocolo (ISATAP)

La diferencia principal en estas técnicas de tunelización es el método en el cual se determina el origen y destino del túnel. En este documento, describen a los tipos de túnel compatibles del IPv4 manual y automático. Refiera a implementar el Tunelización para el IPv6 para la información sobre otras técnicas de tunelización y sus características.

Nota: Los túneles del recubrimiento reducen la Unidad máxima de transmisión (MTU) (MTU) de una interfaz de 20 octetos. Esto asume que paquete IPV4 la encabezado básica no contiene los campos opcionales. Una red que utiliza los túneles del recubrimiento es difícil de resolver problemas. Por lo tanto, los túneles cubiertos que conectan las redes aisladas del IPv6 no se deben considerar como arquitectura de red final del IPv6. El uso de los túneles del recubrimiento se debe considerar como técnica de transición hacia una red que soporte las pilas del protocolo del IPv4 y del IPv6, o apenas la pila del protocolo del IPv6.

prerrequisitos

Requisitos

Cisco recomienda que usted tiene conocimiento del IPv6 antes de que usted intente esta configuración. Refiera a implementar la dirección y la conectividad básica del IPv6 para la información sobre el IPv6.

Componentes Utilizados

La información en este documento se basa en los Cisco 36xx Series Router que funcionan con el Software Release 12.3(13) del � del Cisco IOS.

Nota: Cualquier plataforma de hardware que soporte el Cisco IOS Software Releases 12.2(2)T o 12.0(21)ST y posterior también soporta el IPv6.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/25156/ipv6tunnel.gif

Configuraciones (Modo Ipv6 manual)

La configuración de los Túneles configurados para el IPv6 es manualmente que se explica por sí mismo. Requiere la especificación definida de la fuente del IPv4 del túnel y del destino del IPv4 del túnel. La única desventaja de cuando usted utiliza esta técnica es la cantidad de la administración que usted debe realizarse cuando el número de túneles crece.

Este documento utiliza estas configuraciones para el modo manual del IPv6:

R1-IPv6 (Cisco 3640 Router)
R1-ipv6#show run
Building configuration...
 
Current configuration : 916 bytes
!
version 12.3
hostname R1-ipv6
!
boot system flash 
logging buffered 4096 debugging
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 ipv6 address 2000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone 
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
!
end

R2-IPv6-IPv4 (router 3640 de Cisco)
R2-ipv6-ipv4#show run
Building configuration...
 
Current configuration : 1079 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
ip subnet-zero
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::1/112
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel destination 192.34.1.4
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!--- In some cases, user would require a Data License  
!--- in order to issue "tunnel mode ipv6ip"


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R3-IPv4 (Router Cisco 2621)
R3-ipv4#show run
Building configuration...
 
Current configuration : 865 bytes
!
version 12.3
!
hostname R3-ipv4
!
!
memory-size iomem 15
ip subnet-zero
!
!
interface Serial0/0
 ip address 192.23.1.3 255.255.255.0
!
interface Serial0/1
 ip address 192.34.1.3 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
!
!
end

R4-IPv4-IPv6 (router Cisco 3640)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1413 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::2/112
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel destination 192.23.1.2
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!         
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R5-IPv6 (Cisco 7500 Router)
R5-ipv6#show run
Building configuration...
 
Current configuration : 1001 bytes
!
version 12.3
!
hostname R5-ipv6
!
ip subnet-zero
ip cef distributed
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Ethernet1/2
 no ip address
 ipv6 address 4000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Configuraciones (modo compatible con IPv4 automático)

Las configuraciones para el r1, el R3, y el R5 son lo mismo que los ejemplos manuales del modo del IPv6. Sólo cambian las configuraciones R2 y R4. Cuando usted configura el túnel compatible con IPv4, no especifique explícitamente el direccionamiento del IPv4 del destino del túnel. El destino del túnel se calcula automáticamente de la dirección del salto siguiente del IPv6 de la ruta del IPv6. Para proporcionar la ruta sobre tal túnel, el Routing Protocol con la definición de direccionamiento del vecino explícito, tal como BGP o estático, se requiere. En este caso, usted necesita utilizar un direccionamiento compatible del IPv6 del IPv4 como el direccionamiento del IPv6 del vecino BGP o la dirección del salto siguiente de la Static ruta.

Estos ejemplos utilizan la interfaz serial en el r2 y el R4 como el direccionamiento compatible con IPv4 del IPv6. El mismo serial es el origen de túnel. Por ejemplo, el direccionamiento 192.23.1.2 del IPv4 en el r2 S0/0 se convierte a:: 192.23.1.2 en la notación del IPv6. Este direccionamiento se utiliza como el direccionamiento del IPv6 del peer BGP y Next-Hop BGP. Con todo las rutas BGP del IPv6 se redistribuyen en el RIP del IPv6 de modo que los extremos remotos de la red reciban la información.

Esta técnica de tunelización se desaprueba actualmente. Cisco recomienda que usted utiliza la técnica de tunelización del ISATAP del IPv6. Refiera a los túneles del ISATAP para más información sobre esta técnica.

Nota: No es necesario configurar un destino de túnel con el modo automático IPv6.

R2-IPv6-IPv4 (router 3640 de Cisco)
R2-ipv6-ipv4#show run
Building configuration...
Current configuration : 1394 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
!
ip subnet-zero
!
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.34.1.4 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.34.1.4 activate
 neighbor ::192.34.1.4 next-hop-self
 network 2000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!         
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R4-IPv4-IPv6 (router Cisco 3640)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1697 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.23.1.2 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.23.1.2 activate
 neighbor ::192.23.1.2 next-hop-self
 network 4000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
!         
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • ping — Determina si un host remoto está activo o inactivo, y el retardo de ida y vuelta en la comunicación con el host.

  • show ipv6 route — Verifica si una ruta existe en el IPv6.

  • show bgp ipv6 — Verifica si el BGP se está ejecutando.

  • show bgp ipv6 summary – Muestra información de resumen de la ejecución de BGP en el IPv6.

  • show ipv6 int tunnel 0 — Verifica que el túnel esté para arriba en el IPv6, y verifica el MTU configurado en la interfaz.

Verificación de salida de comando para el modo IPv6 manual

Del r1, haga ping el direccionamiento del IPv6 en el R5 para verificar si el túnel transporta el IPv6 a través de la red del IPv4.

R1-ipv6#ping ipv6 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#

Del R5, haga ping el direccionamiento del IPv6 en el r1.

R5-ipv6#ping  2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#

Resultado del comando Verification para el modo automático IPv6

Utilice Ping en la red IPv6 remota para verificar la conectividad a través del túnel.

R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/72 ms 
R1-ipv6# 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms 
R5-ipv6#

Si el ping falla, mire la tabla de ruteo del IPv6 para verificar si existe la ruta. Marque la tabla de ruteo en el otro lado también. La ruta en el router del extremo, tal como R5 y r1, se debe aprender como RIP Route. Esta ruta se redistribuye del BGP en el RIP en el r2 y el R4. El r2 y el R4 es donde el túnel termina y se configura el peering BGP.

R5-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
R   ::/96 [120/2] 
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
R   2000:1:1:1:1:1:1:0/112 [120/3]
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
L   4000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet1/2
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet1/2
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R5-ipv6#

Si la red remota del IPv6 no está en el router del extremo, marque al router donde el túnel termina.

R4-ipv4-ipv6#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   ::192.34.1.4/128 [0/0] 
     via ::, Tunnel0
C   ::/96 [0/0] 
     via ::, Tunnel0
B   2000:1:1:1:1:1:1:0/112 [200/0]
     via ::192.23.1.2, Null
L   4000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, Ethernet3/0
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet3/0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R4-ipv4-ipv6#

Debido a que está utilizando IPv6 BGP para compartir información entre dos redes IPv6 diferentes, verifique que BGP esté funcionando.

R4-ipv4-ipv6#show bgp ipv6 
BGP table version is 3, local router ID is 192.34.1.4 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure 
Origin codes: i - IGP, e - EGP, ? - incomplete 
   Network          Next Hop            Metric LocPrf Weight Path 
*>i2000:1:1:1:1:1:1:0/112 
                    ::192.23.1.2                  100      0 i 
*> 4000:1:1:1:1:1:1:0/112 
                    ::                                 32768 i 
R4-ipv4-ipv6#show bgp ipv6 summary 
BGP router identifier 192.34.1.4, local AS number 100 
BGP table version is 3, main routing table version 3 
2 network entries and 2 paths using 394 bytes of memory 
2 BGP path attribute entries using 120 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
BGP activity 2/8 prefixes, 2/0 paths, scan interval 60 secs 
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
::192.23.1.2    4   100      24      24        3    0    0 00:19:00        1 
R4-ipv4-ipv6# 
R4-ipv4-ipv6#show ipv6 int tunnel 0 
Tunnel0 is up, line protocol is up 
  IPv6 is enabled, link-local address is FE80::C022:104 
  Global unicast address(es): 
    ::192.34.1.4, subnet is ::/96 
  Joined group address(es): 
    FF02::1 
    FF02::2 
    FF02::9 
    FF02::1:FF22:104 
  MTU is 1480 bytes 
  ICMP error messages limited to one every 100 milliseconds 
  ICMP redirects are enabled 
  ND DAD is not supported 
  ND reachable time is 30000 milliseconds 
  Hosts use stateless autoconfig for addresses. 
R4-ipv4-ipv6#

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • show ipv6 route — Verifica si una ruta existe en el IPv6.

  • show ip ospf neighbor - Muestra el ID del router, la prioridad y el estado del router vecino. También, este comando visualiza la cantidad de tiempo que sigue siendo que el router espera para recibir un paquete de saludo del Open Shortest Path First (OSPF) del vecino antes de declarar al vecino abajo. También visualiza la dirección IP de la interfaz con la cual este vecino está conectado directamente y de la interfaz en la cual el vecino OSPF forma la adyacencia.

  • show ipv6 interface brief — Verifica que la interfaz del túnel esté para arriba.

  • show interfaces tunnel 0 — Verifica que el destino del túnel configurado esté sabido en la tabla de ruteo.

  • show ipv6 rip — Información del RIP del IPv6 de las visualizaciones.

  • show ipv6 protocols — Visualiza el estatus del Routing Protocol del IPv6.

Si el ping a la red remota del IPv6 falla, verifique que las rutas del IPv6 sean doctas vía el RIP del IPv6.

R1-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet0/1
R   3000::/112 [120/2]
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
R   4000:1:1:1:1:1:1:0/112 [120/3] 
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R1-ipv6#

En R2, verifique que las rutas de IPv6 RIP se aprendan de la interfaz Túnel0.

R2-ipv6-ipv4#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, FastEthernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, FastEthernet0/1
L   3000::1/128 [0/0] 
     via ::, Tunnel0
C   3000::/112 [0/0] 
     via ::, Tunnel0
R   4000:1:1:1:1:1:1:0/112 [120/2]
     via FE80::230:80FF:FEF3:4701, Tunnel0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R2-ipv6-ipv4#

Si hay problemas con la Conectividad, primero verifique que la red del IPv4 esté intacta. También, verifique el adjacenciesand del vecino OSPF que haya rutas al direccionamiento del IPv4, que es el origen de túnel de la interfaz del túnel remota. Entonces verifique que usted pueda hacer ping entre los orígenes de túnel con el ping del IPv4.

R2-ipv6-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:36    192.23.1.3      Serial0/0 
R2-ipv6-ipv4# 
R3-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
1.1.1.1           1   FULL/  -        00:00:30    192.34.1.4      Serial0/1 
192.23.1.2        1   FULL/  -        00:00:35    192.23.1.2      Serial0/0 
R3-ipv4# 
R4-ipv4-ipv6#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:35    192.34.1.3      Serial1/5 
R4-ipv4-ipv6#

En el r2, verifique que la interfaz del túnel del IPv6 sea ascendente y que usted puede ping del IPv6 el origen de túnel remoto con el direccionamiento compatible con IPv4 del IPv6. Si la interfaz del túnel está abajo, verifique que el destino del túnel configurado esté sabido en la tabla de ruteo. Este es un problema en la porción IPv4 de la red porque el destino del túnel no está en la tabla de ruteo.

R2-ipv6-ipv4#show ipv6 interface brief 
FastEthernet0/0            [up/up] 
    unassigned 
Serial0/0                  [up/up] 
    unassigned 
FastEthernet0/1            [up/up] 
    2000:1:1:1:1:1:1:1111 
Tunnel0                    [up/up] 
    3000::1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show interfaces tunnel 0 
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel 
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation TUNNEL, loopback not set 
  Keepalive not set 
  Tunnel source 192.23.1.2 (Serial0/0), destination 192.34.1.4 
  Tunnel protocol/transport IPv6/IP, key disabled, sequencing disabled 
  Tunnel TTL 255 
  Checksumming of packets disabled 
  Last input 00:00:09, output 00:00:19, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/0 (size/max) 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     3119 packets input, 361832 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     3117 packets output, 361560 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
R2-ipv6-ipv4#

Si todavía hay problemas con las rutas del IPv6 y se verifica la red del IPv4, usted necesita marcar la configuración de RIP del IPv6.

R2-ipv6-ipv4#show ipv6 rip 
RIP process "6bone", port 521, multicast-group FF02::9, pid 111 
     Administrative distance is 120.  Routing table is 0 
     Updates every 30 seconds, expire after 180 
     Holddown lasts 180 seconds, garbage collect after 120 
     Split horizon is on; poison reverse is off 
     Default routes are not generated 
     Periodic updates 176, trigger updates 1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show ipv6 protocols 
IPv6 Routing Protocol is "connected" 
IPv6 Routing Protocol is "static" 
IPv6 Routing Protocol is "rip 6bone" 
  Interfaces: 
    FastEthernet0/1 
    Tunnel0 
  Redistribution: 
    Redistributing protocol rip 6bone

Asegúrese de que los temporizadores sean los mismos si no se utilizan los valores predeterminados. En este ejemplo, el valor por defecto se utiliza en todo el Routers del RIP del IPv6. Verifique la configuración para asegurarse que todas las interfaces RIP activadas están configuradas correctamente. También, verifique que el mismo nombre del proceso del RIP sea constante en la red. Si es necesario, puede fijarse en el resultado del debug ipv6 rip. Como con todos los debugs, la precaución se debe utilizar para no sobrecargar el buffer CPU y del registro de la consola.

Resumen

Este documento demuestra cómo los túneles se pueden utilizar para que el IPv6 y el IPv4 coexistan en la misma red. Esto pudo ser necesario en tiempos de la transición. Una cosa a recordar sobre las configuraciones del IPv6 es ésa con el RIP del IPv6, las declaraciones de la red no se utiliza. El RIP del IPv6 se habilita global y cada interfaz participa en el RIP, y se habilita para el RIP del IPv6. En el ejemplo de BGP IPv6, la sección Túnel automático requiere el uso del conjunto de comandos address-family ipv6 para ingresar los enunciados BGP.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 25156