Voz : H.323

Configuración y troubleshooting del Cisco IOS Telephony Service (ITS)

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (12 Noviembre 2015) | Comentarios


Contenido


Introducción

El Cisco IOS Telephony Service (ITS), conocido antes como IP Keyswitch, es una solución del Procesamiento de llamadas de la Telefonía IP integrada en el software del � del Cisco IOS que cabe en la arquitectura Cisco para la Voz, el vídeo, y los datos integrados (AVVID). El concepto básico es proveer una mínima funcionalidad PBX/key-switch a una pequeña cantidad de teléfonos IP directamente conectados al gateway de voz. Cisco ITS puede desplegarse en instancias en las cuales una sucursal no cuenta con una WAN o tiene conectividad WAN a través de links satelitales.

El Cisco ITS tiene sentido en las situaciones donde un cliente quisiera agregar un servicio de telefonía en tal sitio sin necesariamente requerir todas las Funciones de telefonía encontradas en el Cisco CallManager. Este documento describe un ejemplo de despliegue de la función ITS en una red de ejemplo.

Nota: El Cisco ITS no es lo mismo, ni están las características lo mismo, como la característica del Survivable Remote Site Telephony (SRST) que se utiliza conjuntamente con el Cisco CallManager.

prerrequisitos

Requisitos

Antes de utilizar esta configuración, asegúrese de que cumple con los siguientes requisitos previos:

  • Familiaridad con la versión 2.01 del Sevicio Cisco IOS Telephony.

  • Una comprensión básica de los fundamentales TCP/IP, tales como IP Addressing, DHCP, Network Time Protocol (NTP), TFTP, y HTTP

  • Una comprensión básica de los fundamentales del Cisco IOS Software, tales como configuración del comando line interface(cli)

  • Una comprensión básica de los fundamentales de la voz sobre IP (VoIP), tales como configurar el dial-peers, los puertos de voz, y el Calidad de Servicio (QoS)

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco IOS Software Release 12.2(8)T o Posterior, con un mínimo de conjunto de características del IP Plus (más IP/VOX en las 1700 Series). Este documento presupone que se admite el ITS 2.0 de Cisco en el software del IOS de Cisco.

  • El gateway del Cisco 3660 con la versión de software IOS 12.2(11)T con el conjunto de características del IP PLUS se utiliza en el ejemplo de configuración, aunque la mayoría del IAD2400, de los 1700, de los 2600, de los 3600, y de los 3700 Series Router sean actualmente aplicables. Marque por favor las notas de versión de Cisco IOS Software para la información de servicio técnico de la versión actual y del software.

  • Utilizaron al conjunto del software del Cisco ITS 2.0.3 en este ejemplo. Usted puede descargar a este conjunto de la descarga del software: Cisco CallManager Express/ITS y SRST (clientes registrados solamente).

  • Para soportar el Cisco ITS, se recomienda que usted tiene la cantidad máxima de memoria para cada plataforma, especialmente si se van el número máximo de teléfonos y los nombres distintivos (DN) para la plataforma a ser configurados.

  • En este ejemplo, un Catalyst 3500 Series XL Switch se utiliza como el Switch de la sucursal. Configure los VLAN distintos para la Voz y los datos para calidad y los motivos de seguridad.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/25100/config_troubleshoot_its1.gif

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

La tabla abajo especifica la información sobre la Voz y la Transferencia de datos con los VLAN distintos. También especifica la red y los direccionamientos y los puertos de la interfaz.

Propósito VLAN Red Interfaz Dirección de la interfaz
Datos 50 10.1.50.0/24 Fa0/0.50 10.1.50.1/24
Voice 150 10.1.150.0/24 Fa0/0.150 10.1.150.1/24

El router del Cisco ITS es un Cisco IOS Software Release 12.2(11)T corriente 3660 con el conjunto de características del IP Plus. Los archivos del Cisco ITS se deben descargar en .tar o el formato del .zip de la descarga del software: Cisco CallManager Express/ITS y SRST (clientes registrados solamente).

Una vez que está extraído, cada archivo se debe transferir al flash del router con el TFTP. No borre el flash cada vez que se copia un archivo individual. Lo que sigue es un anuncio de los archivos encontrados en el Cisco ITS 2.0.3 (no todos estos archivos son necesarios).

Nombre de archivo Descripción
P003G302.bin La carga del teléfono que se utilizará con el Cisco ITS para el teléfono del IP del Cisco 7910. La carga telefónica tiene incluida una nota de la versión separada que explica algunas correcciones con respecto a las versiones anteriores. (Obligatorio)
P004G302.bin La carga del teléfono que se utilizará con el Cisco ITS para el teléfono del IP del Cisco 7960. La carga telefónica tiene incluida una nota de la versión separada que explica algunas correcciones con respecto a las versiones anteriores. (Obligatorio)
admin_user.html La página Web del administrador para configurar el sistema
ephone_admin.html La página Web de administración de teléfonos.
normal_user.html La página web del usuario (no administrador) para administrar los teléfonos para remitir y las otras funciones.
telephony_service.html La página web a nivel superior que cada usuario visita para configurar los teléfonos o para configurar el sistema como administrador. (Opcional)
logohome.gif
en_dest_busy.au Un aviso de audio de muestra para una extensión ocupada. Utilizado por la secuencia de comandos its_Cisco.2.0.0.tcl
en_dest_unreachable.au Un aviso de audio de muestra para una extensión inalcanzable. Utilizado por la secuencia de comandos its_Cisco.2.0.0.tcl
en_disconnect.au Un prompt de audio de la muestra para un disconnected o una extensión no registrada. Utilizado por la secuencia de comandos its_Cisco.2.0.0.tcl
en_enter_dest.au Un mensaje de solicitud de audio de ejemplo para que el usuario ingrese el destino. Utilizado por la secuencia de comandos its_Cisco.2.0.0.tcl
en_reenter_dest.au Un aviso de audio de muestra para que el usuario ingrese nuevamente el destino. Utilizado por la secuencia de comandos its_Cisco.2.0.0.tcl
en_welcome.au Un aviso de audio de muestra para el saludo del usuario. Utilizado por la secuencia de comandos its_Cisco.2.0.0.tcl
its_Cisco.2.0.0.tcl La secuencia de comandos TCL para un Automated Attendant que puede rutear las llamadas hacia una extensión. Utiliza los archivos del .au de la muestra para saludar al usuario, para indicar para un número, y para rutear la llamada al destino deseado.
music-on-hold.au Un archivo de audio de ejemplo para música en espera.

El archivo siguiente es también parte del archivo de Cisco ITS-2.0.3.zip, pero no necesita ser colocado en el flash del SU router.

Nombre de archivo Descripción
CiscoIOSTSP.zip Este proveedor de servicio de la interfaz de programación de aplicación de telefonía (TAPI) (TSP) fue desarrollado para el Cisco ITS y actúa como interfaz entre TAPI (parte del sistema operativo del Windows 2000) y el SU. ¡El TSP permite las aplicaciones TAPI-basadas tales como marcador y ACTO del teléfono! software para proporcionar el Control de llamadas a los Teléfonos IP en el Cisco ITS. La implementación de TAPI en el Cisco ITS es un no stack lleno TAPI, sino una implementación “TAPI Lite”. Soporta las características siguientes:
  • Múltiples direcciones en una sola línea.
  • Poner las llamadas usando la libreta de direcciones que marca de la aplicación.
  • Contestando o rechazando a las llamadas de la aplicación.
  • Llevar a cabo las llamadas usando las pantallas emergentes.
  • Poniendo la información de identidad de la persona que llama a disposición la aplicación.
  • La colocación invita al control y a conmutar entre las llamadas en diversos direccionamientos de la misma línea.
El TSP proporciona una interfaz que habilite el Control remoto uno por de un teléfono del IP. Aunque es múltiple los TSP pueden ejecutarse en el mismo ordenador, sólo un teléfono del IP se puede asociar a cada TSP. Dado que MSP (Proveedor de servicios de medios) no se admite en este TSP, las aplicaciones como Cisco SoftPhone tampoco se admiten.

Nota: El TSP que se incluye con Cisco CallManager no está admitido en ITS.

Configuraciones

Configuración de VLAN en el Catalyst 3500XL

El Cisco ITS se ejecuta en el LAN donde los Teléfonos IP y los Ciscos CallManageres están conectados con el Gateways de voz a través de los switches de Catalyst. Es muy importante configurar estos dispositivos correctamente en cuanto al VLANS que lleven los datos de voz. Esta sección proporciona una descripción de la configuración del Catalyst 3500XL y de la conexión LAN correspondiente en el 3660 Router del gateway de voz.

  1. La Voz y el VLAN de dato se deben configurar con un Switch del unconfigured, tal y como se muestra en del siguiente ejemplo:

    Cat3500BranchSwitch# vlan database
    Cat3500BranchSwitch(vlan)# vlan 50 name corporate-data-vlan
    VLAN 50 added:
    Name: corporate-data-vlan
    Cat3500BranchSwitch(vlan)# vlan 150 name corporate-voice-vlan
    VLAN 150 added:
    Name: corporate-voice-vlan
    Cat3500BranchSwitch(vlan)#
    Cat3500BranchSwitch(vlan)# exit
    APPLY completed.
    Exiting....
    Cat3500BranchSwitch#
  2. El siguiente ejemplo es una configuración de muestra de la interfaz entre el Catalyst 3500XL y el 3660 Router:

    interface FastEthernet0/1
     description Port to 3660 (supports Dot1q)
     duplex full
     speed 100
     switchport trunk native 50
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,50,150,1002-1005
     switchport mode trunk
    !
    
  3. El siguiente ejemplo es un puerto que se utilizará para una conexión telefónica:

    interface FastEthernet0/2
     description DOT1Q port to IP Phone
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 50
     switchport mode trunk
     switchport voice vlan 150
     spanning-tree portfast
    !
    

Para más información, refiera al Catalyst 2900 Series XL y a los Catalyst 3500 Series XL Switch.

Configuración de VLAN en el router del Cisco ITS

Siga los pasos abajo para configurar los VLA N en el router del Cisco ITS.

  1. El primer paso es configurar los parámetros de QoS y los VLA N en la interfaz 3660, como se muestra abajo.

    ! 
    class-map match-all L3-to-L2_VoIP-Cntrl
     match ip dscp af31 
    class-map match-all L3-to-L2_VoIP-RTP
     match ip dscp ef 
    !
    !
    policy-map output-L3-to-L2
     class L3-to-L2_VoIP-RTP
      set cos 5
     class L3-to-L2_VoIP-Cntrl
      set COs 3
    !
    
  2. Ahora aplique estas directivas a la interfaz y cree los VLA N.

    interface FastEthernet0/0
     description Catalyst 3500 Branch Office Switch
     no ip address
     no ip mroute-cache
     load-interval 30
     speed 100
     full-duplex
    !
    interface FastEthernet0/0.50
     encapsulation dot1Q 50
     ip address 10.1.50.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    interface FastEthernet0/0.150
     description native subnet 10.1.150.0 voice
     encapsulation dot1Q 150
     ip address 10.1.150.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    

Para más información, refiera al Catalyst 2900 Series XL y a los Catalyst 3500 Series XL Switch.

Configuración del servidor DHCP en el router del Cisco ITS

El paso siguiente es necesario configurar a un servidor DHCP en el 3660 Router. Usted necesita este paso solamente si usted tiene un servidor DHCP externo, no si sus IP Addresses se configuran estáticamente. El ejemplo abajo muestra un alcance de DHCP para los Teléfonos IP y para los otros dispositivos en el otro VLA N.

ip dhcp excluded-address 10.1.50.1 10.1.50.10
ip dhcp excluded-address 10.1.150.1 10.1.150.10
!
ip dhcp pool ip-phones
 network 10.1.150.0 255.255.255.0  

!--- This defines the range of IP addresses to be assigned.

 default-router 10.1.150.1
 option 150 ip 10.1.150.1   

!--- This must be the IP address of the ITS router.  

!
ip dhcp pool Data-clients
 network 10.1.50.0 255.255.255.128
 default-router 10.1.50.1 
 domain-name cisco.com
 dns-server 10.1.50.100 
 netbios-name-server 10.1.50.100 
!

Nota: Si usted quiere habilitar el DHCP solamente para los dispositivos específicos, usted puede crear un alcance de DHCP con el comando host (en vez de un comando network, como se muestra arriba). Usted debe también configurar un cliente-identificador y a una dirección de hardware para el teléfono del IP que usted desea dar una dirección IP a. Para el identificador de cliente, debe especificar 01+ dirección MAC de teléfono, y la dirección del hardware debe incluir la dirección MAC del teléfono como parámetro.

Para más información, refiera al Cisco IOS DHCP Server.

Mida el tiempo de la configuración en el router del Cisco ITS

Como los teléfonos IP reciben sus configuraciones de fecha/hora desde el router ITS de Cisco, es importante asegurarse de que el reloj esté configurado correctamente en el router. Se recomienda altamente que usted configura el NTP, si es posible. Especifique el huso horario y, en caso necesario, el tiempo de los ahorros de luz diurna, y configure al servidor NTP. Se presenta un ejemplo a continuación:

its-router(config)# clock time EST -5
its-router(config)# clock summer-time EST recurring 
its-router(config)# ntp server 172.18.106.15

Para más información sobre NTP, consulte la sección Administración básica del sistema.

Configuración del Cisco ITS en los 3660

Configuración Básica

La configuración siguiente se debe ingresar para configurar el Cisco ITS en los 3660:

telephony-service
 load 7910 P004G302       

!--- This is the load file minus the .bin extension. 
!--- Only the 7910, 7940/7960, and 7935 IP Phones are supported.


 load 7960-7940 P003G302  

!--- This is the load file minus the .bin extension.

 ip source-address 10.1.150.1 port 2000  

!--- This is the ip address of the Cisco ITS router on the voice subnet.

 max-ephones 48  

!--- This is the total number of phones that will be allowed to register.
!--- The maximum varies by platform and sometimes by software level.


 max-dn 192      

!--- This is the maximum number of directory numbers that can be configured 
!--- on this gateway (maximum varies by platform and sometimes by software level).

 voicemail 52222 

!--- This is the number that will be dialed when the "Messages" 
!--- button is pressed on the phone (optional).

!

La mayor parte de los comandos remaining son opcionales. Los únicos obligatorios son las declaraciones de la “carga” (no que son necesarios para todos los teléfonos), que son los comandos ip source-address, max-ephones, y max-dn.

Nota: Diseñan al router del Cisco ITS para trabajar con los archivos de la carga de las versiones del Cisco CallManager anterior de 3.1; por ejemplo, archivos de la carga que consiguen su configuración del archivo del SEPDEFAULT.cnf, bastante que de un archivo XML. Aseegurese este comando está en la configuración:

tftp-server 
  flash:XMLDefault.cnf.xml

Otras opciones del telefonía-servicio se muestran en el siguiente ejemplo:

Its-router(config-telephony)# telephony-service
its-router(config-telephony)# ? 
  Cisco IOS Telephony Service configuration commands:
  admin-password      define password for admin user
  admin-username      define username for admin user
  date-format         Set date format for IP Phone display 
  default             Set a command to its defaults
  dialplan-pattern    Define E.164 telephone number prefix
  directory           Define directory naming order
  dn-webedit          enable Edit DN through Web
  exit                Exit from telephony-service configuration mode
  ip                  Define IP address and port for Telephony-Service/Fallback
  keepalive           Define keepalive timeout period to unregister IP phones
  load                Select the IP phone firmware load file
  max-conferences     Define max number of 3 party G.711 conferences
  max-dn              Maximum directory numbers supported 
  max-ephones         Define max number of IP phones
  moh                 Define music-on-hold filename
  mwi                 Define IP address and port for MWI Server
  no                  Negate a command or set its defaults
  reset               reset ethernet phone
  time-format         Set time format for IP Phone display 
  time-webedit        enable Edit Time through Web
  timeouts            Define timeout value for IP phone
  transfer-pattern    Define valid call transfer destinations
  url                 Define Ephone URL's
  voicemail           Set the voicemail access number called when the MESSAGES IP
                      phone button is pressed

its-router(config-telephony)#

precaución Precaución: Muchos de los cambios al servicio de telefonía, tal como cambio de la fecha o del formato de hora, requieren los teléfonos reajustar. Algunas opciones, tales como cambio del MAX-ephones o de las configuraciones del máximo abajo, requieren una recarga de router completa. Para reiniciar todos los teléfonos ingrese lo siguiente:

its-router(config-telephony)# telephony-service
its-router(config-telephony)# reset all

Algunas de estas opciones serán discutidas en las secciones siguientes; otros pueden ser encontrados refiriendo a la versión 2.01 del Sevicio Cisco IOS Telephony.

Configuración de TFTP en el SU router

Siga los pasos abajo para configurar el TFTP en el SU router.

  1. Aseegurese que todos los archivos se han transferido correctamente al flash del router. Por lo menos, los archivos P003G302.bin de la carga y P004G302.bin deben ser cargados. Una vez que está cargado, el flash debe asemejarse al siguiente ejemplo:

    Its-router# show flash
    System flash directory:
    File Length    Name/status
    1    16084816  c3660-is-mz.122-11.T 
    2    229542    admin_user.html 
    3    42484     en_dest_busy.au 
    4    26376     en_dest_unreachable.au 
    5    14352     en_disconnect.au 
    6    19512     en_enter_dest.au 
    7    17167     en_reenter_dest.au 
    8    17486     en_welcome.au 
    9    4152      ephone_admin.html 
    10   5968      its_Cisco.2.0.0.0.tcl 
    11   29092     logohome.gif 
    12   496521    music-on-hold.au 
    13   35138     normal_user.html 
    14   268008    P003G302.bin 
    15   258360    P004G302.bin 
    16   522       telephony_service.html 
    17   54        SEPDEFAULT.cnf     
    
    !--- This file will not show up until telephony-service is configured.
    
    18   249       XMLDefault.cnf.xml 
    
    !--- This file will not show up until telephony-service is configured.
    
    [17551227 bytes used, 49033349 available, 66584576 total]
    65536K bytes of processor board System flash (Read/Write)
    
    its-router#
    
  2. En la configuración, usted debe permitir que los Teléfonos IP descarguen los archivos de la carga por el TFTP del router del Cisco ITS. Tenga en cuenta que los nombres de estos archivos distinguen entre minúsculas y mayúsculas.

    tftp-server flash:P003G302.bin
    tftp-server flash:P004G302.bin
    tftp-server flash:SEPDEFAULT.cnf
    tftp-server flash:XMLDefault.cnf.xml
    
  3. Los archivos del SEPDEFAULT.cnf y del XMLDefault.cnf.xml se crean automáticamente una vez que el commandsare del telefonía-servicio y del fuente-direccionamiento del IP publicó.

  4. El archivo del XMLDefault.cnf.xml contiene la dirección IP de uno de los accesos de Ethernet del router a quien el adaptador ATA debe registrarse. Estos archivos son específicos al router y no se pueden compartir por los routeres múltiples.

Configuración del teléfono IP en el SU router

Siga los pasos abajo para configurar los Teléfonos IP en el SU router.

  1. En este momento, si los teléfonos de IP están conectados y han recibido una dirección DHCP, pueden registrarse con el router ITS de Cisco. No tendrán ninguna línea configurada. Usted puede verificar que los teléfonos sean registrados publicando el comando show ephone y mirando la salida, que debe asemejarse al siguiente:

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[1] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.10 50568 Telecaster 7960 keepalive 889 max_line 6
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 52397 Telecaster 7960 keepalive 872 max_line 6
    
    
    ephone-3 Mac:0006.D74B.107C TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.12 51116 Telecaster 7960 keepalive 871 max_line 6
    
    
    ephone-4 Mac:0008.E31B.7A8A TCP socket:[5] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.13 50321 Telecaster 7960 keepalive 867 max_line 6
    
    its-router#
  2. Usted puede ahora configurar estos teléfonos con el CLI o con la administración Web. (Refiera a la administración Web que configura de la sección del router del Cisco ITS de este documento.) Una cierta información de configuración especial está disponible para el teléfono del IP del Cisco 7910 en la configuración del Cisco ITS para la sección de 7910 teléfonos del IP.

    !
    ephone-dn 1
     number 1000
     name George P Burdell
     call-forward noan 52222 timeout 10
     no huntstop
    !
    ! 
    ephone-dn 2
     number 1000
     name George P Burdell
     preference 1
     call-forward busy 52222
     call-forward noan 52222 timeout 10
    !
    !
    ephone-dn 10
     number 1111
     name Helpdesk
     no huntstop
    !
    !
    ephone-dn 11
     number 1111
     name Helpdesk
     preference 1
    !
    !
    ephone-dn 12
     number 1111
     name Helpdesk
     preference 2
    !
    !
    ephone-dn 13
     number 1111
     name Helpdesk
     preference 3
    !
    
  3. Cada ephone abajo representa una línea. Usted puede asignar las líneas a los teléfonos múltiples, si está deseado. En este ejemplo, han configurado a un usuario quién tiene extensión 1000 en dos líneas. Una línea del servicio de ayuda, que es un grupo Hunt de cuatro líneas, se ha agregado también. Ahora configure los teléfonos electrónicos, que asignan las líneas a los dispositivos de teléfono reales.

    !
    ephone 1
     username "gpburdell" password letmein
     mac-address 0006.D74B.0F46
     button 1:10 2:11 3:12 4:13 5:1 6:2
    !
    !
    !
    ephone 2
     Mac-address 0006.D74B.1361
     button 1:15 2:10 3:11 4:12 5:13
     speed-dial 1 1000
    !
    
  4. Las etiquetas del botón se refieren de nuevo a las etiquetas del ephone abajo. La salida del comando show ephone debe asemejarse a la salida abajo.

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.14 52311 Telecaster 7960 keepalive 6 max_line 6
    button 1: dn 10 number 1111 IDLE 
    button 2: dn 11 number 1111 IDLE 
    button 3: dn 12 number 1111 IDLE 
    button 4: dn 13 number 1111 IDLE 
    button 5: dn 1 number 1000 IDLE 
    button 6: dn 2 number 1000 IDLE 
    Username: gpburdell Password: letmein 
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 50512 Telecaster 7960 keepalive 7 max_line 6
    button 1: dn 15 number 1001 IDLE 
    button 2: dn 10 number 1111 IDLE 
    button 3: dn 11 number 1111 IDLE 
    button 4: dn 12 number 1111 IDLE 
    button 5: dn 13 number 1111 IDLE 
    speed dial 1:1000
    
    its-router#
    Ephone 1 Ephone 2
    Línea 1 1111 Línea 1 1001
    Línea 2 1111 Línea 2 1111
    Línea 3 1111 Línea 3 1111
    Línea 4 1111 Línea 4 1111
    Línea 5 1000 Línea 5 1111
    Línea 6 1000 Línea 6 George P Burdell

  5. Cuando una llamada viene adentro a 1111, suena hasta que alguien la coja (ningún reenvío de llamada configurado). Si ephone abajo 10 (la línea 1 en el ephone 1 o la línea 2 en el ephone 2) es funcionando, después la llamada siguiente a 1111 va automáticamente al ephone abajo 10, porque no se configura ningún huntstop y la preferencia es más alta (la preferencia predeterminada es 0). Si las preferencias fueran lo mismo, después ambas líneas sonarían.

  6. Si una llamada se pone a 1000 y nadie coge, rodará al voicemail (extensión 5222 en este reenvío de llamada puesto). Si el ephone abajo 1 es funcionando, la llamada siguiente consigue ruteada al ephone abajo 2. Esto está debido al ruteo de dial-peer regular y el hecho de que no se configura ningún huntstop. No es necesario tener una configuración de reenvío ocupado en este caso, a menos que usted quisiera que la llamada remitiera a un diverso DN en conjunto cuando está ocupado (por ejemplo, si 1000 está ocupados, entonces remita a 1001). En el ephone abajo 2, usted debe configurar el reenvío de llamada para ocupado y ninguna respuesta, porque no hay otra extensión 1000 con una preferencia más alta a rutear a (incluso si había, usted hace el huntstop configurar implícito, así que la llamada terminaría allí).

Para más información sobre el ruteo de dial-peer normal, refiera al soporte de tecnología por voz.

El ephone 1 también tiene un nombre de usuario y contraseña para el “gpburdell.” Esto permitirá que el usuario acceda y inicie sesión a la misma página web de telephony_service.html y cambie su expedición (ocupada, ninguna respuesta, todos) y los marcados rápidos, así como realiza las búsquedas en directorio local.

El ephone 2 tiene un marcado rápido en la línea 6. Si se presiona ese botón, 1001 marcan 1000. El comando speed-dial sí mismo no especifica la ubicación del botón. Dice, en este caso, que la primera línea libre será un marcado rápido para numerar 1000. El hecho de que sea la línea 6 no está configurado directamente. Si otro marcado rápido fuera configurado (el “marcado rápido 2 el 1004," por ejemplo), no generaría un error, sino que no visualizaría, tampoco.

Algunos otros comandos configuration para los ephones abajo enumerados abajo.

its-router(config-ephone-dn)# ?
Ephone DN configuration commands:
  application   The selected application
  call-forward  Define E.164 telephone number for call forwarding
  caller-id     Configure port caller id parameters
  cor           Class of Restriction on dial-peer for this dn
  default       Set a command to its defaults
  description   dn desc, for DN Qualified Display Name
  exit          Exit from ephone-dn configuration mode
  hold-alert    Set Call On-Hold timeout alert parameters
  huntstop      Stop hunting on Dial-Peers
  intercom      Define intercom/auto-call extension number
  loopback-dn   Define dn-tag to create loopback dn pair with this ephone-dn
  mwi           set message waiting indicator options (mwi)
  name          Define dn user name
  no            Negate a command or set its defaults
  number        Define E.164 telephone number 
  paging        set audio paging mode
  preference    Preference for the attached dial-peer for the primary dn number
  translate     Translation rule

its-router(config-ephone-dn)#

A continuación se muestran los otros comandos de configuración para teléfonos.

Its-router(config-ephone-dn)# ephone 1
its-router(config-ephone)# ?
Ethernet phone configuration commands:
  button        define button to dn map
  default       Set a command to its defaults
  exit          Exit from ephone configuration mode
  Mac-address   define ethernet phone MAC address
  no            Negate a command or set its defaults
  paging-dn     set audio paging dn group for phone
  reset         reset ethernet phone
  speed-dial    Define ip-phone speed-dial number
  username      define username to access ethernet phone from Web
  vm-device-id  define voice-mail id string

its-router(config-ephone)#

precaución Precaución: Después de cualquier cambio al ephone o al ephone abajo, los teléfonos a los cuales los cambios se aplican debe ser reajustado. Esto se puede hacer bajo el ephone sí mismo con el comando reset, o global bajo menú de la configuración del telefonía-servicio según lo descrito anterior.

Configuración del Cisco ITS para el teléfono del IP 7910

A diferencia del teléfono del IP 7960, los 7910 tiene solamente un botón Line Button. A esperar y a la transferencia de llamada al servicio técnico en este teléfono, se requieren dos líneas. Entonces, para este teléfono, puede configurar dos líneas con el mismo DN de la siguiente manera:

ephone-dn  20
 number 1020
 no huntstop
!
!
ephone-dn 21
 number 1020
 preference 1
!
...
ephone 10
 button 1:20 2:21
!

Aunque éstas son dos apariciones de línea, no es posible poner ambas líneas en el control al mismo tiempo. Cuando la línea primaria está en espera, presione el botón de línea para seleccionar la segunda línea y poder efectuar una segunda llamada (o responderla). Al presionar el botón Hold (Retener) cuando se conecta la segunda llamada, ésta se colocará en espera y se vuelve a conectar la primera línea. Presionar nuevamente el botón hold (mantener) alternará entre las líneas primaria y secundaria. Presionar el botón Line Button desconectará otra vez el partido actualmente conectado.

Configurar a la administración Web del router del Cisco ITS

Para administrar correctamente el servidor del Cisco ITS con la red, así como permitir que los usuarios finales administren sus teléfonos con la red, los archivos siguientes deben estar presentes en el flash:

  • admin_user.html

  • ephone_admin.html

  • logohome.gif

  • normal_user.html

  • telephony_service.html

Para permitir la administración de los Web pages con la red, los comandos global configuration siguientes deben ser ingresados:

ip http server
  ip http path flash

Otros comandos se deben ingresar conforme a la sección de configuración del telefonía-servicio.

telephony-service
 admin-username administrator 

 !--- This sets up the administrator account used to access the web page.

 admin-password cisco  

 !--- This sets up the password for the admin account.

 dn-webedit    

 !--- (optional) This permits the editing of DNs through the web interface.

 time-webedit  

 !--- (optional) This permits editing of the system time through the web interface.

!

Para acceder al router del Cisco ITS con la red, señale a su navegador al URL siguiente:

http://ITSrouter_ipaddr/telephony_service.html

El URL es lo mismo para todo el mundo. Otros archivos de .html se consideran los archivos internos llamados por la página web de telephony-service.html. La llamada de otros archivos puede llevar directamente a los errores de JAVASCRIPT. Los usuarios que deben utilizar la página web deben ser configurados primero en el ephone, como se muestra abajo.

ephone 1
 username "gpburdell" password letmein

El usuario (en este ejemplo, “gpburdell”) puede iniciar sesión y cambiar su información de reenvío, realiza las Búsquedas de directorio, e incluso configura sus propias configuraciones del marcado rápido. Hay ayuda en línea disponible, también.

Los administradores pueden realizar el teléfono o el DN agrega, borra, y los cambios, así como algunos sistemas cambia. Observe que puede haber problemas si usted configura con la red así como por la línea de comando, porque la página web no sondea la configuración del Cisco IOS Software periódicamente, ni lo hace el botón Refresh Button en la actualización del navegador esta información. De hecho, al intentar restaurar de esa manera, usted será página registrada de los GUI y considerar el “cambio de configuración fallado, el cambio de configuración se prohibe” el cuadro de mensaje de error. Sólo el botón Actualizar del menú principal recupera los últimos cambios del router ITS de Cisco.

De la página web, el botón de la configuración del sistema de la escritura hace los cambios ser escrito inmediatamente al NVRAM. Sin embargo, para los usuarios comunes, los cambios se escriben cada 10 minutos mientras no haya sesión activa en el vty, la consola, y las líneas aux.

Nota: Para que la actualización trabaje, satisfacer aseegurese que por lo menos cuatro líneas libres del vty están disponibles en el Cisco ITS, aunque una línea libre del vty es bastante para los cambios de configuración normal.

La información del Historial de llamadas también está disponible para los administradores. Primero debe ser habilitada configurando como sigue:

call-history-mib retain-timer 500
call-history-mib max-size 500

A lo más, 500 entradas y 500 minutos de historial de llamadas se conservan en la tabla MIB.

Usted puede ver los registros de llamada eligiendo la configuración del sistema de la visión del GUI después de abrir una sesión, y después eligiendo la información del historial de llamadas de la visión.

Configuración de conexión PSTN en el router Cisco ITS

Si se asume que el SU router tiene placas interfaz de voz, usted ahora querrá configurar esos indicadores luminosos LED amarillo de la placa muestra gravedad menor para poder poner las llamadas a y desde los Teléfonos IP. Esto no es perceptiblemente diferente que otras conexiones de voz en un router. Usted puede pensar en el ephones con los números que fueron asignados a cada ephone abajo como puertos de la Estación de intercambio remota (FXS) en el Routers.

Configuración de otras características de ITS

Configuración de la función de espera

Una característica adicional para los llamadores exteriores es música en el control (moh) /Tone del control (ToH). El ToH está siempre encendido por abandono y no puede ser inhabilitado. El moh se puede proporcionar al Public Switched Telephone Network (PSTN) o a las llamadas en red de G.711 que se ponen en el control. Llama del teléfono del IP al teléfono del IP en el mismo SU router que se coloca en el control oye siempre solamente la señal acústica del ToH. Para el moh, después de aseegurarse que el archivo de audio existe en el flash, configure como sigue:

telephony-service
 moh music-on-hold.au

El .au o el archivo del .wav jugado para el moh necesita estar en la Ley u G.711 o el formato de la uno-ley. Para distinguir la llamada en espera del ToH, el Tono de llamada en espera se oye como señales acústicas periódicas, con un intervalo de 10 segundos entre las señales acústicas. Si hay líneas múltiples de llamada en espera, sólo un tono se envía cada 10 segundos. El ToH, sin embargo, se oye en los intervalos periódicos de cada 8 segundos y consiste en tres señales acústicas (un solo tono relanzado tres veces). Precedencia más alta de las tomas del ToH que el Tono de llamada en espera. Si ambos tonos se juegan en exactamente el mismo tiempo, un usuario primero, después oirá el ToH en 8 segundos, otro ToH, y finalmente en dos más segundos, un Tono de llamada en espera.

Las llamadas se ponen una vez en el control, allí son varias opciones, mostradas abajo, para enviar las notificaciones audibles a los usuarios que una llamada sigue siendo encendido control.

Its-router(config-ephone-dn)# hold-alert 15 ?
  idle        alert on-hold originator only if idle
  originator  alert on-hold originator always
  shared      alert all phones that share the line

Una alerta del timbre del segundo en el intervalo configurado (cada 15 a 300 segundos) se puede configurar para ser enviado siempre al partido que puso la llamada en el control, o para ser enviado solamente si ese partido está ocioso. Otra opción es configurar la alerta que se enviará a todos los teléfonos que compartan la misma línea. La configuración predeterminada está para ninguna alerta, no importa cómo una llamada ha estado de largo en el control.

Configuración de conferencia

Se soporta la Conferencia de tres vías mientras los partidos sean todos los usuarios de G.711 y los recursos de conferencia están disponibles. Configuran a los recursos de conferencia como sigue:

telephony-service
 max-conferences 10

Si uno de los partidos en una conferencia presiona el control, los otros dos partidos oirán el moh o el ToH. Sin embargo, también podrán hablar el uno al otro, con la música o el tono jugando en el fondo.

Configuración de la transferencia

La capacidad de transferir llamadas entrantes suele requerir configuración adicional. De manera predeterminada, los teléfonos IP registrados ITS de Cisco pueden transferir a otros teléfonos IP registrados en el mismo router ITS. Otras transferencias, al PSTN o a los destinos de VoIP, se niegan. Para habilitar estos tipos de transferencias, los transferencia-modelos se deben configurar bajo telefonía-servicio como sigue:

Telephony-service
 transfer-pattern 9.......

Ahora, si se asume que hay un dial-peer de los crisoles para rutear las llamadas al PSTN, un teléfono del IP puede ahora transferir las llamadas a cualquier número siete dígitos marcando 9 primer. No hay opción para un tono de marcación secundario con ITS.

precaución Precaución: Sea especialmente prudente cuando las transferencias de llamada que vinieron adentro por un puerto de Oficina de intercambio remoto (FXO) en el SU router y salieron por otras puerto FXO, porque ésta puede hacer ambos puertos seguir siendo funcionando incluso después ambas partes han colgado para arriba. Refiera comprensión del problema de la desconexión FXO. Si su proveedor no puede soportar una forma de Desconectar la supervisión con el FXO, después no permita las transferencias de nuevo al PSTN.

Para transferir/reenviar llamadas que lleguen de otro destino de VoIP (por ejemplo, otro router ITS), se necesita un loopback dn. Esto es un tema más complejo fuera del ámbito de este documento.

Configuración del intercom

La característica del intercomunicador permite una característica de la prensa-a-charla entre dos Teléfonos IP. No se admite en líneas compartidas, lo que significa que un DN de teléfono configurado para una operación de intercomunicación sólo se asocie a un teléfono IP.

!
ephone-dn 30
number A1234
name "Intercom"
intercom A4321 label "Office A"
!
!
ephone-dn 31
number A4321
name "Intercom"
intercom A1234 label "Office B"
!
...
!
ephone 3
Mac-address 0006.D74B.107C
button 1:16 6:30
!
!
!
ephone 4
Mac-address 0008.E31B.7A8A
button 1:17 6:31
!

Ahora, cuando el ephone 4 presiona la línea 6, una llamada se pone para alinear 6 del ephone 3 (por ejemplo, llama el A1234 automáticamente). Por abandono, si el teléfono de destino es en-gancho, después va descolgado, va al modo del altavoz, y silencia su micrófono. Otras opciones en el comando intercom son barge-in y no-auto-answer. La opción de la entrada abrupta permite que la llamada de intercomunicación entrante fuerce una llamada existente en el estado de control. El teléfono entonces contesta a la llamada de intercomunicación inmediatamente. La opción del No-auto-answer hace la llamada de intercomunicación sonar simplemente, en vez automáticamente de ser cogido.

Con todas las llamadas de intercomunicación, la escritura de la etiqueta configurada con el enunciado de intercomunicación aparece a la derecha de la visualización, como un marcado rápido. Sin la opción de etiqueta, el nombre (si está configurado en el ephone-dn) aparece en el lado izquierdo del visor de línea mientras que el número de intercomunicación aparece en la derecha.

Nota: Cisco no recomienda el uso del Cisco 7910 para la funcionalidad de intercomunicación, porque el teléfono no tiene un micrófono y el altavoz no puede ser desilenciado, así que el microteléfono se debe escoger hasta la respuesta.

Paginar la configuración

La característica de paginación trabaja como la característica del intercomunicador descrita previamente, salvo que proporciona solamente una secuencia de la Voz unidireccional sin la opción de la prensa-a-respuesta. Solamente los teléfonos ociosos son alcanzados paginando; los teléfonos funcionando no recibirán la página. El paginar soporta la distribución audio usando el unicast, el Multicast (hasta diez dispositivos), o ambos (de modo que el audio pueda alcanzar los teléfonos que no se pueden alcanzar con el Multicast). Se recomienda la paginación del Multicast. Cada extensión de la paginación requiere un IP Multicast Address único.

Por ejemplo, diga que crean a tres grupos que paginan: “Gente fresca,” “gente desagradable,” y “todas las personas,” que es simplemente la suma de los primeros dos grupos. El Multicast es el método de entrega audio, así que usted configuraría el siguiente:

!
ephone-dn 40
 number 4001
 name "Cool People"
 paging ip 239.0.1.20 port 2000
!
!
ephone-dn 41
 number 4002
 name "Uncool People"
 paging ip 239.0.1.21 port 2000
! 
!
ephone-dn 42
 number 4000
 name "All People"
 paging ip 239.0.1.22 port 2000
 paging group 40,41
!

Nota: Los Teléfonos IP no soportan el Multicast en los direccionamientos 224.x.x.x.

Ahora configure y asigne cada ephone a un DN que pagina como se muestra abajo (configuración adicional en cada ephone omitido). Recuerde que cada teléfono del IP puede pertenecer a solamente un grupo que pagina. También, el ephone abajo configurado para paginar no se debe asignar a un botón Phone Button.

!
ephone 1
 paging-dn 40
!
ephone 2
 paging-dn 40
!
ephone 3
 paging-dn 41
!
ephone 4
 paging-dn 41
!
ephone 5
 paging-dn 42
!

Con esta configuración, usted ha asignado la página 4001 (“gente fresca”) al ephones 1 y 2, la página 4002 (“gente desagradable”) al ephones 3 y 4, y la página 4000 (“todas las personas”) al ephones 1 a 5.

Cualquier llamada a 4001 conecta con el ephones 1 y 2 (si no están ocupada) por ejemplo.

Nota: Se admite paginación hasta una distancia máxima de un salto de ruteo del router ITS.

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Los comandos show telephony-service enumerados abajo (especialmente todos) le darán una foto de la configuración.

its-router# show telephony-service ?
  admin        Show telephony-service admin username and password
  all          Show telephony-service details
  dial-peer    Show telephony-service dialpeers 
  ephone       Show ephone configuration
  ephone-dn    Show ephone-dn configuration
  voice-port   Show telephony-service voice ports
  |            Output modifiers
<cr>

Los comandos show ephone enumerados abajo le dan el estado actual de los Teléfonos IP. Generalmente, todo lo que se necesita es show ephone por sí mismo.

Its-router# show ephone ?
  7910              7910 phone status
  7940              7940 phone status
  7960              7960 phone status
  H.H.H             mac address
  dn                Dn with tag assigned
  offhook           Offhook phone status
  registered        Registered ephone status
  remote            non-local phones (with no arp entry)
  ringing           Ringing phone status
  summary           Summary of all ephone
  tapiclients       Ephone status of tapi client
  telephone-number  Telephone number assigned
  unregistered      Unregistered ephone status
  |                 Output modifiers
  <cr>

La salida del comando show ephone-dn parecerá muy similar a la salida del comando show voice port. Por problemas más comunes, este comando no es tan útil como algunas de las otras herramientas.

Its-router# show ephone-dn ? 
  <1-960>   dn tag
  loopback  Show ephone-dn in loopback mode
  summary   Summary of all ephone-dn
  |         Output modifiers
  <cr>

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

ITS de Cisco ofrece algunos comandos adicionales para la resolución de problemas y depuraciones que pueden facilitar la obtención de información en gran medida.

Hay algunos debugs que pueden ser útiles al resolver problemas los problemas. El comando debug ephone es el único comando Su-específico de Cisco a este respecto.

Its-router# debug ephone ?
  alarm       Enable ephone alarm message debugging
  detail      Enable ephone detail debugging
  error       Enable ephone error debugging
  keepalive   Enable ephone keepalive debugging
  loopback    Enable ephone loopback debugging
  moh         Enable ephone music-on-hold debugging
  mwi         Enable ephone mwi debugging
  pak         Enable ephone packet debugging
  raw         Enable ephone raw protocol debugging
  register    Enable ephone registration debugging
  state       Enable ephone state debugging
  statistics  Enable ephone statistics debugging

Para la mayoría de las situaciones, al resolver problemas un problema entre uno o dos teléfonos, es útil publicar los comandos debug ephone error y debug ephone state, a menos que el problema implique específicamente el registro, el indicador de mensaje en espera (MWI), o el moh. Si hay muchos teléfonos, entonces es una buena idea limitar la salida sólo a las direcciones MAC relevantes. Por ejemplo:

its-router# debug ephone state Mac-address 0009.433C.E5EC
EPHONE state debugging is enabled for phone 0009.433C.E5EC

Los problemas tales como llamada de los destinos del VoIP remoto pueden requerir los comandos debug adicionales que son más generales al VoIP en los routeres Cisco, tales como los comandos debug voip ccapi inout y debug vtsp all. Los específicos para resolver problemas la señalización PSTN y otros elementos específicos de la puesta en práctica no se cubren en este documento. Si desea más información, consulte los siguientes documentos:

Aquí está una salida del comando debug ephone state de la muestra para una llamada a partir de 1004 a 1002. La porción pertinente de la salida del comando show ephone se muestra abajo.

ephone-3 Mac:0006.D74B.107C TCP socket:[5] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.12 51718 Telecaster 7960 keepalive 92 max_line 6
button 1: dn 16 number 1002 IDLE 


ephone-4 Mac:0008.E31B.7A8A TCP socket:[2] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.13 50396 Telecaster 7960 keepalive 96 max_line 6
button 1: dn 17 number 1004 IDLE

Ahora usted puede examinar el debug. Se considera el mensaje OFFHOOK (Descolgado), se pone la llamada (usted no ve los dígitos individuales capturados en esta traza), y se contesta. Los mensajes del canal OpenReceives se envían a cada teléfono y se reconocen más adelante; a mensaje StartMedia dice a cada teléfono qué dirección IP y puerto para enviar el audio. Al final, aparece el mensaje ONHOOK.

Its-router# debug ephone state
EPHONE state debugging is enabled
its-router#
Sep 26 18:39:40.837: ephone-4[2]:OFFHOOK
Sep 26 18:39:40.837: ephone-4[2]:SIEZE on activeline 0
Sep 26 18:39:40.837: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOffHook
Sep 26 18:39:40.837: DN 17 Voice_Mode
Sep 26 18:39:40.837: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:42.349: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:42.853: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.105: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-4[2]:Skinny-to-Skinny call DN 17 to DN 16 instance 1
Sep 26 18:39:43.609: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsRingOut
Sep 26 18:39:43.609: ephone-4[2]:Call Info DN 17 line 1 ref 52 called 1002 calling 1004 
origcalled calltype 2
Sep 26 18:39:43.609: ephone-4[2]: John Doe calling 
Sep 26 18:39:43.609: ephone-4[2]: Jane Doe
Sep 26 18:39:43.609: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsRingIn
Sep 26 18:39:43.613: ephone-3[5]:Call Info DN 16 line 1 ref 53 called 1002 calling 1004 
origcalled calltype 1
Sep 26 18:39:43.613: ephone-3[5]: John Doe calling 
Sep 26 18:39:43.613: ephone-3[5]: Jane Doe
Sep 26 18:39:43.613: ephone-3[5]:Ringer Inside Ring On
Sep 26 18:39:43.613: dn_tone_control DN=17 tonetype=36:DtAlertingTone onoff=1 pid=113
Sep 26 18:39:51.926: ephone-3[5]:OFFHOOK
Sep 26 18:39:51.926: ephone-3[5]:Ringer Off
Sep 26 18:39:51.926: ephone-3[5]:ANSWER call
Sep 26 18:39:51.926: ephone-3[5]:Answer Incoming call from ephone-(4) DN 17
Sep 26 18:39:51.926: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:OpenReceive DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: ephone-3[5]:OpenReceive DN 16 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:51.930: DN 17 End Voice_Mode
Sep 26 18:39:51.930: DN 17 Voice_Mode
Sep 26 18:39:51.930: DN 16 Voice_Mode
Sep 26 18:39:51.930: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:52.182: ephone-4[2]:OpenReceiveChannelAck:IP 10.1.150.13, port=23094, 
dn_index=17, dn=17
Sep 26 18:39:52.182: ephone-3[5]:StartMedia 10.1.150.13 port=23094
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:52.182: ephone-3[5]:OpenReceiveChannelAck:IP 10.1.150.12, port=22778, 
dn_index=16, dn=16
Sep 26 18:39:52.182: ephone-4[2]:StartMedia 10.1.150.12 port=22778
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:40:01.254: ephone-3[5]:ONHOOK
Sep 26 18:40:01.254: ephone-4[2]:CloseReceive
Sep 26 18:40:01.254: ephone-4[2]:StopMedia
Sep 26 18:40:01.254: ephone-3[5]:call clean up this DN 16 was called by other DN 17
Sep 26 18:40:01.254: this ephone-3 other ephone-(4) other DN state CONNECTED
Sep 26 18:40:01.254: ephone-3[5]:CloseReceive
Sep 26 18:40:01.254: ephone-3[5]:StopMedia
Sep 26 18:40:01.254: DN 16 End Voice_Mode
Sep 26 18:40:01.254: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsOnHook
Sep 26 18:40:01.254: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.254: DN 17 End Voice_Mode
Sep 26 18:40:01.254: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOnHook
Sep 26 18:40:01.254: ephone-4[2]:SpeakerPhoneOnHook
Sep 26 18:40:01.258: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.354: DN 16 Voice_Mode
Sep 26 18:40:01.354: DN 16 End Voice_Mode
Sep 26 18:40:01.354: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:40:01.366: SkinnyReportDnState DN 17 ONHOOK
Sep 26 18:40:01.366: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 25100