IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Aplicaciones de la sobrecarga mordida con el IS-IS

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento hace una introducción al comando de configuración set-overload-bit Intermediate System-to-Intermediate System (IS-IS); cómo y cuándo utilizarlo con las palabras clave wait-for-bgp y suppress. En este documento, el término Sistema intermedio (IS) y router son intercambiables.

prerrequisitos

Requisitos

Los Quien lea este documento deben tener los conocimientos básicos de:

  • Border Gateway Protocol (BGP) y Routing Protocol IS-IS.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.1(9) de Cisco IOS�

  • Cisco 2500 y 3600 Series Router

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Uso tradicional del bit sobrecargado

Cuando un router se queda sin recursos de sistema (memoria o CPU), no puede almacenar la base de datos de estado de los links o ejecutar el trayecto más corto primero (SPF). En esta situación, el router debe alertar a los otros routers dentro de su área configurando un bit específico en sus paquetes de estado de link. (LSPs). Cuando otros routers detectan que se configuró este bit, no usarán este router para el tráfico de tránsito pero sí lo usarán para los paquetes destinados a las redes conectadas directamente a routers sobrecargados y a los prefijos IP.

En IS-IS, un router inmediatamente satura su propio LSP aun antes de enviar los paquetes con la secuencia de números PDU (CSNP) completa. El bit de sobrecarga se utiliza para advertir al resto de la red que no enrute tráfico de tránsito a través del router recientemente recargado.

Para cada LSP, el ISO/IEC 10589:1992leavingcisco.com define un bit especial llamado bit de la sobrecarga de las bases de datos LSP. El diseño preliminar menciona la condición de sobrecarga (sección 7.3.19): “Como resultado de la red mis configuration, o de ciertas condiciones transitorias, es posible que puede haber recursos de memoria insuficiente disponibles salvar un estado recibido PDU del link. Cuando ocurre esto, SON las necesidades de tomar ciertas medidas para asegurarse de que si sus bases de datos LSP llegan a ser contrarias con los otros ISs, que este el ISs no confía en los trayectos de reenvío con sobrecargados ES.”

Cuando un IS se encuentra en esta condición, configura este bit del fragmento 0 del no seudonodo LSP que genera.

También, en el borrador, la sección 7.2.8.1 hace una nota según la cual otros IS no deberían usar la IS sobrecargada como un router de tránsito, pero puede alcanzar sistemas finales (ES) que están conectados directamente. Durante este tiempo, aún se puede acceder a las interfaces conectadas directamente, así como los prefijos IP. El Cisco IOS no utiliza la sobrecarga mordido para estas funciones, aunque la capacidad de fijar permanentemente el sobrecarga-bit fuera introducida en el IOS con el Id. de bug Cisco CSCdj18100. En la implementación Cisco, cuando se configura el conjunto de bits de sobrecarga, se alcanzan las interfases/prefijos IP conectados directamente.

Uso ampliado del bit de sobrecarga

La técnica del bit de la sobrecarga IS-IS fue ampliada con el Id. de bug Cisco CSCdp01872 (clientes registrados solamente). Puede configurar un router para anunciar su LSP con el bit de sobrecarga para un periodo de tiempo específico luego de una recarga. Cuando expira el temporizador, se borra el bit de la sobrecarga y re-se inunda el LSP.

Esta nueva funcionalidad es útil para los Proveedores de servicios de internet (ISP) quienes ejecutan tanto Border Gateway Protocol (BGP) e IS-IS para evitar escenarios de un par de “agujeros negros”. Al establecer el bit de sobrecarga para una cantidad específica de tiempo inmediatamente después de una recarga se asegura que el router no reciba tráfico de tránsito mientras el protocolo de ruteo aún esté convergiendo.

La técnica para establecer este bit para un determinado período de tiempo luego de una recarga se implementa mediante el siguiente comando. Este comando toma un rango de tiempo de 5 a 86400 segundos para que el bit de sobrecarga permanezca configurado después de la recarga.

router isis
set-overload-bit [on-startup [<timeout> | wait-for-bgp] ]

Por ejemplo:

Router(config-router)#set-overload-bit on-startup 3500 wait-for-bgp

!--- Set the overload bit for 5 minutes (default is 10 minutes).

Esta característica también permitió configurar a un router para inhabilitar automáticamente la sobrecarga mordida cuando convergió el BGP. Para más información sobre para el BGP que espera, vea por favor la prevención de agujero negro transitorio del Intermediate System to Intermediate System del RFC3277 (IS-IS)leavingcisco.com .

Según la especificación BGP, un router BGP no necesita enviar señales de mantenimiento mientras envíe actualizaciones. Entonces, keepalives será enviado sólo después que se hayan enviado todas las actualizaciones. El BGP se considera haber convergido cuando el Keepalives se recibe de todos los vecinos BGP.

Si no se reciben señales de mantenimiento de BGP de todos los vecinos BGP y está configurada la opción wait-for-bgp, IS-IS desactivará el bit de sobrecarga luego de 10 minutos.

Los ISP pueden querer suprimir ciertos prefijos IP de la publicidad en los propios LSP del router cuando se configura el conjunto-sobrecarga-bit. Por ejemplo, tal vez no desee permitir la propagación de prefijos IP de Nivel 1 a Nivel 2, ya que haría del router un nodo de tránsito para el tráfico IP.

El Id. de bug Cisco CSCdr98046 (clientes registrados solamente) da más control sobre qué sucede cuando el bit de la sobrecarga se está utilizando en su capacidad ampliada. Esta mejora permite un router IS-IS Nivel 1 - Nivel 2 (L1L2), que está redistribuyendo rutas IP del Nivel 1 al Nivel 2 o del Nivel 2 al Nivel 1 para continuar anunciando estas rutas redistribuidas en su LSP cuando el bit de sobrecarga haya sido configurado.

Usando la palabra clave de la supresión, usted puede configurar a un router L1L2 para redistribuir y para hacer publicidad de las rutas de IP del nivel 1 en el nivel 2 o vice versa incluso cuando se configura el conjunto-sobrecarga-bit. La sintaxis de los comandos es la siguiente:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

La palabra clave entre niveles de la supresión dice al router no hacer publicidad de los prefijos IP aprendidos de otro nivel IS-IS si se fija el bit de la sobrecarga. La palabra clave externa de la supresión dice al router no hacer publicidad de los prefijos IP aprendidos de otros protocolos si se fija el bit de la sobrecarga. El valor por defecto no es suprimir y mantener el comportamiento del Id. de bug Cisco CSCdp01872 (clientes registrados solamente).

La opción de eliminación solo entra en efecto cuando se establece su propio bit de sobrecarga y no cuando este es recibido o configurado (por ejemplo, puede haber establecido el bit de sobrecarga al inicio y el bit no está configurado).

router isis
set-overload-bit on-startup 40 suppress interlevel

En el caso antedicho, el bit de la sobrecarga no se fija realmente hasta que recarguen al router, y así que usted debe continuar escapándose los prefijos IP entre los niveles. Cuando usted recarga y fija realmente el bit, usted debe suprimir los anuncios entre niveles.

Ejemplo de configuración

El siguiente diagrama de red se utiliza para demostrar el comando set-overload-bit y las opciones wait-for-bgp y suppress.

/image/gif/paws/24509/TOPO.gif

Ésta es la configuración que contiene la opción wait-for-bgp en el Router 2.

Configuración del router 2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis
passive-interface Loopback0
net 12.0020.0200.2002.00
set-overload-bit on-startup wait-for-bgp
!

!--- Enables the IS-IS process on the router.
!--- Makes loopback interface passive 
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.
!--- Sets the overload bit on startup to wait for BGP
!--- using the default timeout of 10 minutes.

El router se recargó recientemente y antes de que el eBGP converja podemos ver que el bit de sobrecarga está configurado en el LSP del Router 2 en la base de datos del Nivel 1 IS-IS.

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000017   0x2372        284               0/0/1

A continuación, se muestra el resultado de debug isis update que el BGP ha convergido en el Router 2:

*Mar 1 00:00:51.015 UTC: BGP(0): Revise route installing 1.1.1.1/32 
-> 135.8.1.1 to main IP table

El Router 2 vuelve a crear su LSP de Nivel 1 porque el BGP ha convergido y se ha limpiado el bit de sobrecarga. Por eso ve "Important fields changed" en el resultado de la actualización de la depuración isis a continuación.

*Mar 1 00:00:51.087 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Important fields changed
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Full SPF required

Ahora podemos ver que el router 2 ha completado su sesión de actualización BGP con el vecino:

*Mar 1 00:00:52.127 UTC: BGP: 135.8.1.1 initial update completed

Cuando volvemos a observar el Nivel 1 LSP del Router 2, vemos que el Router 2 ha eliminado el bit de sobrecarga (porque BGP ha convergido) y que el campo LSP Seq Num (Número de secuencia de LSP) aumenta de a 1 (porque se creó un nuevo LSP).

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000018   0xAD87        287               0/0/0

Ésta es la configuración del router 2 con la fuga de ruta L1 L2 configurada y el bit de sobrecarga establecido.

Configuración del router 2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis 
redistribute static ip metric 11 level-1
redistribute isis ip level-2 into level-1 distribute-list 100
passive-interface Loopback0
net 12.0020.0200.2002.00
!

!--- Enables the IS-IS process on the router.
!--- Configured L2 to L1 route leaking
!--- Makes loopback interface passive
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.

!
ip route 200.200.200.200 255.255.255.255 loopback0 

!--- Static route to 200.200.200.200 via loopback0.

access-list 100 permit ip any any

!--- Access list 100 is used to control which route
!--- gets leaked from Level 2 to Level 1.

Observe que la base de datos del Nivel 1 del Router 2 muestra que el bit de sobrecarga está limpio en el LSP del Nivel 1 del Router 2.

IS-IS Level-1 LSP r2.00-00        
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL        
r2.00-00 * 0x0000005D   0xC252        180           0/0/0        
Area Address: 12        
NLPID: 0xCC         
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric:  0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01
Metric: 11 IP-External 200.200.200.200 255.255.255.255
Metric:138 IP-Interarea 1.1.1.1 255.255.255.255

Cuando se observan en las rutas IP que el router 3 está adquiriendo, podemos ver la dirección 1.1.1.1 del loopback, adquirida por el router 1 desde la fuga de ruta L2L1. Note también que el router3 también está recibiendo la Static ruta redistribuida 200.200.200.0/32.

r3#show ip route isis
200.200.200.0/32 is subnetted, 1 subnets
i L1 200.200.200.200 [115/21] via 135.8.2.2, Ethernet0/0
1.0.0.0/32 is subnetted, 1 subnets
i ia 1.1.1.1 [115/148] via 135.8.2.2, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Configuremos set-overload-bit en el Router 2 con la opción de supresión. Suprimiremos ambo Routes interno y externo. La sintaxis del comando es la siguiente:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

suprima el interlevel previene al router de los prefijos de la publicidad aprendidos del nivel 2. suprimen el externo previene la redistribución.

r2(config-router)#set-overload-bit suppress interlevel external

Si examinamos la base de datos del Router 2 Nivel 1, podemos observar que el bit de sobrecarga está configurado ahora en el LSP del Nivel 1 del Router 2. Se suprimieron tanto 200.200.200.200/32 como 1.1.1.1/32. No se insertan en la base de datos de Capa 1.

IS-IS Level-1 LSP r2.00-00
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r2.00-00 * 0x0000005F   0x23C6       266            0/0/1
Area Address: 12
NLPID: 0xCC 
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric: 0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01

Cuando habilitamos debug isis update-packets en el Router 2, vemos "Important fields changed" (Han cambiado campos importantes) en el resultado cuando se construyen los niveles 1 y 2 de LSP. Esto indica que el contenido LSP ha cambiado; en otras palabras, hemos recibido un LSP que tiene configurado el bit de sobrecarga. Un nuevo LSP requiere un SPF lleno ser ejecutado.

*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L2 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:09.035 UTC: ISIS-Upd: Sending L1 LSP 0020.0200.2002.00-00, seq 61, ht 299 on Ethernet0/0
*Mar 1 03:16:09.095 UTC: ISIS-Upd: Sending L2 LSP 0020.0200.2002.00-00, seq 65, ht 299 on Ethernet1/0

La tabla del ruteo actualizada del Router 3 ya no incluye las redes de IP 200.200.200.200 y 1.1.1.1.

r3#show ip route isis
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Información de DDTS

  • Id. de bug Cisco CSCdj18100 (clientes registrados solamente) - Introdujo la capacidad de fijar la sobrecarga mordida manualmente.

  • Id. de bug Cisco CSCdp01872 (clientes registrados solamente) - Introdujo la capacidad de fijar la sobrecarga mordida en el lanzamiento. Espere hasta que el BGP haya señalado la convergencia o fije un temporizador para borrar el bit de la sobrecarga.

  • Id. de bug Cisco CSCdr98046 (clientes registrados solamente) - Un router IS-IS L1L2 que está redistribuyendo las rutas de IP del nivel 1 en el nivel 2 o el nivel 2 en el nivel 1 puede continuar haciendo publicidad de estas rutas redistribuido en su LSP cuando se ha fijado el bit de la sobrecarga.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 24509