Voz : H.323

Información sobre el ruteo de llamadas de Cisco IOS Gatekeeper

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Los gatekeepers de Cisco se utilizan para agrupar gateways en zonas lógicas y para realizar el ruteo de llamadas entre ellas. Las gateways son responsables de las decisiones de Edge Routing entre la Red de telefonía pública conmutada (PSTN) y la red H.323. Los gatekeepers de Cisco gestionan el ruteo de llamadas base entre los dispositivos de la red H.323 y proporcionan la administración centralizada del plan de marcación. Sin un gatekeeper de Cisco, las direcciones IP explícitas de cada gateway de terminación tendrían que ser configuradas en el gateway de origen y corresponder con un dial-peer de Voz sobre IP (VoIP). Con un gatekeeper de Cisco, las gateways consultan al gatekeeper cuando intentan establecer llamadas VoIP con las gateways VoIP remotas.

Por ejemplo, cuando está presentado con una llamada, el gateway determina si enviarla al tramo de telefonía o a la pierna IP según su Plan de marcado. En el caso de la pierna IP, el gateway pregunta al gatekeeper de Cisco para seleccionar el mejor punto final. Entonces, el gatekeeper de Cisco determina si el punto final llamado es un dispositivo dentro de sus zonas locales o está situado en las zonas remotas controladas por un gatekeeper de Cisco alejado.

prerrequisitos

Requisitos

Cisco recomienda que usted tiene conocimiento de entender Gatekeepers H.323.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco2500, 2600, 3600, 3700, 7200, y Routers de las MC3810 Series

  • Este documento no es específico a ninguna versión de Cisco IOS�. Sin embargo, las configuraciones en este documento fueron probadas en el Cisco IOS Software Release 12.2(19). Refiera al Software Advisor (clientes registrados solamente) para confirmar el conjunto de características de Cisco IOS necesario para soportar la funcionalidad de gatekeeper de H.323.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Mensajes ARQ y LRQ

El pedido de admisión (ARQ) y el Location Request (LRQ) son el registro dos H.225, admisión, los mensajes del estatus (RAS) que accionan a un portero para iniciar el proceso de decisión de ruteo de llamadas.

  • ARQ — Mensajes de las zonas locales que son enviados por los puntos finales de H.323 (generalmente gatewayes) al gatekeeper de Cisco. Los porteros reciben los ARQ de un punto final si:

    • Un punto final de las zonas locales inicia una llamada. O

    • Permisos de petición de punto final de las zonas locales para admitir una llamada entrante.

    Los porteros contestan a los mensajes ARQ con un Admission Confirm (ACF) o un mensaje del Admission Reject (ARJ). Si configuran al gatekeeper de Cisco para admitir la llamada, contesta con un mensaje ACF (que incluya la información tal como dirección IP del gateway de destino). Si no, contesta con un mensaje ARJ.

  • LRQ — Estos mensajes se intercambian entre los porteros y se utilizan para las llamadas de la inter-zona (zonas remotas). Por ejemplo, el portero A recibe un ARQ de un gateway de las zonas locales que pide la admisión de llamadas para un dispositivo de las zonas remotas. El portero A entonces envía un mensaje LRQ al portero B. Gatekeeper B que las contestaciones al mensaje LRQ con una ubicación el mensaje confirman (LCF) o que del Location Reject (LRJ), que depende encendido si está configurado para admitir o para rechazar la petición de llamada entre zonas y si el recurso solicitado está registrado.

Refiera comprensión de Gatekeepers H.323: Flujo de llamadas del gatekeeper a las gateways para más información.

Mensajes RAS relacionados H.225
ARQ Pedido de admisión LRQ Petición de ubicación
ACF Admission Confirm LCF La ubicación confirma
ARJ Admission Reject LRJ Location Reject

Conceptos de configuración importantes: Prefijos de zona y tecnológicos

Para entender al gatekeeper de Cisco proceso de decisión de ruteo de llamadas, es esencial entender la zona y los prefijos de tecnología. En general (con algunas excepciones), el prefijo de zona determina la encaminamiento a una zona, mientras que el prefijo de tecnología determina el gateway en esa zona.

Prefijos de zona

Un prefijo de zona es la parte de número al que se llamó que identifica la zona a la cual los saltares de una llamada. Los prefijos de zona se utilizan generalmente para asociar un código de área a una zona configurada.

El gatekeeper de Cisco determina si una llamada se rutea a las zonas remotas o se maneja localmente. Por ejemplo, según este fragmento de configuración, el portero (GK) A adelante 214 ....... llama al GK-B. Las llamadas al código de área (512) se manejan localmente.

gatekeeper
     zone local GK-A abc.com
     zone remote GK-B abc.com 172.22.2.3 1719
	
!--- The IP address configured above should be the RAS 
 !--- address of the remote gatekeeper.    
 !--- and should be reachable from the local gateway. 
 !--- In order to find out the RAS address on the remote gatekeeper,
 !--- issue the 
show gatekeeper zone status
 command 
 !--- on the remote gateway.
 
     zone prefix GK-B 214.......
     zone prefix GK-A 512.......

Prefijos tecnológicos

Un prefijo de tecnología es una característica estándar basada opcional de H.323, soportada por los gatewayes de Cisco y los porteros, que habilita más flexibilidad en el ruteo de llamadas dentro de una red VoIP de H.323. El gatekeeper de Cisco utiliza los prefijos de tecnología para agrupar los puntos finales del mismo tipo juntos. Los prefijos de tecnología se pueden también utilizar para identificar un tipo, una clase, o un pool de los gatewayes.

Los gatekeeperes de Cisco prefijos de tecnología del uso para rutear las llamadas cuando no hay (por un gateway) ese registrado los direccionamientos E.164 hacen juego número al que se llamó. De hecho, esto es un escenario frecuente porque la mayoría de los gatewayes del Cisco IOS registran solamente su H.323 ID (a menos que hacen los puertos de la Estación de intercambio remota (FXS) configurar). Sin los direccionamientos E.164 registradoes, el gatekeeper de Cisco confía en dos opciones para tomar la decisión de ruteo de llamadas:

  • Con la opción de las coincidencias del prefijo de tecnología, el gatekeeper de Cisco utiliza el prefijo de tecnología añadido al final del fichero en número al que se llamó para seleccionar el gateway de destino o la zona.

  • Con la opción predeterminada de los prefijos de tecnología, el gatekeeper de Cisco asigna el default gateway para rutear a las direcciones de llamada sin resolver. Esta asignación se basa en el prefijo de tecnología registrado de los gatewayes.

Esta tabla resume la opción de configuración disponible:

En el gateway
Interfaz de VoIP Este comando registra el gateway de Cisco con el prefijo de tecnología definido. La información de registro del prefijo de tecnología se envía al gatekeeper de Cisco en el mensaje del Solicitud de Inscripción (RRQ) RAS. Por ejemplo:
GWY-B1(config)#interface ethernet 0/0
GWY-B1(config-if)#h323-gateway voip tech-prefix ?
     WORD: A technology prefix that the interface will register
     with the Gatekeeper.
VoIP dial-peer Este comando prepends un prefijo de tecnología al número al que se llamó correspondido con por el dial-peer. No se utiliza para el registro, sino para la configuración de la llamada con el gatekeeper de Cisco. Por ejemplo, número al que se llamó 5551010 se convierte en 1#5551010.
GWY-B1(config)#dial-peer voice 2 voip
GWY-B1(config-dial-peer)#tech-prefix ?
     WORD: A string.

Nota: Modificado número al que se llamó también se envía al gateway de terminación en la configuración de la llamada. Asegúrese que pongan al día al dial-peers del Servicio telefónico sencillo antiguo (POTS) del gateway de terminación para completar la llamada.

En el portero
Prefijo de tecnología predeterminado del portero Este los comandos estableces registraron los gatewayes con el prefijo de tecnología especificado como valor por defecto para los direccionamientos de llamada de ruteo que son sin resolver. Por ejemplo, si la mayoría de los gatewayes en su zona rutean el mismo tipo de llamadas y se registran con el prefijo de tecnología 1#, usted puede configurar al gatekeeper de Cisco para utilizar 1# como el prefijo de tecnología predeterminado. Por lo tanto, es no más necesario que los gatewayes de origen prepend número al que se llamó con 1#. Los números llamados sin un prefijo de tecnología válido se rutean a uno de los gatewayes registradoes con 1#.
GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# default-technology

Nota: Si hay más de un default gateway, usted puede afectar al uso de prioridad de la gateway con el comando de la GW-prioridad del prefijo de zona <gk_id> <e.164_pattern> <0-10>.

Zona del saltar del portero Las configuraciones del saltar se utilizan para reemplazar la selección del prefijo de zona y para forzar la llamada para ser saltado-offed a una zona especificada, sin importar número al que se llamó el prefijo de zona. Por ejemplo, con esta configuración, todas las llamadas con el prefijo de tecnología 2# serán remitidas a la zona del GK-A.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 2# hopoff GK-A
Gateway estática del gatekeeper registro del prefijo de tecnología Utilizado para registrar estáticamente un prefijo de tecnología para un gateway. Logra los mismos resultados en el portero que la configuración de la interfaz de VoIP del gateway alcanza en el gateway. Se recomienda para configurar esto en los gatewayes si usted tiene un gran número de gatewayes. Generalmente, es más fácil configurar cada gateway con un prefijo de tecnología que configurar al portero con todos los prefijos de tecnología para cada gateway.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 1# gw ipaddr ?
     A.B.C.D  Gateway's call signaling IP address

Algoritmo de ruteo de llamadas de Gatekeeper / Proceso de decisión

Estos diagramas visualizan el proceso de decisión del Gatekeeper Call Routing después de recibir el ARQ y los mensajes LRQ en las versiones de Cisco IOS Software antes de 12.4:

gk-call-routing-1.gif

gk-call-routing-2.gif

Ruteo de llamadas Alias-basado

El Gatekeeper Call Routing ha cambiado en el Cisco IOS Software Release 12.4 y Posterior. H.323-ID y el corresponder con basado correo electrónico-ID se realiza antes de procesar los números del destino E.164 (DNIS). Si cualquier punto final se encuentra para haber registrado el H.323-ID/email-ID especificado, después se envía el ACF. Este diagrama explica el nuevo proceso de ruteo de llamadas alias-basado:

/image/gif/paws/24462/gk-call-routing-2a.gif

Las funciones de la infraestructura y de la aplicación de The Voice (VÍA) son mejoras del software al gatekeeper de Cisco existente imagen. Con esta mejora, el gatekeeper de Cisco puede reconocer dos tramos de llamada en la misma plataforma (IP-to-IP gateway) y también el tráfico del balance de la carga a través del múltiplo de los gatewayes IP-to-IP, que se incluyen (los gatewayes y los porteros) en predefinido VÍA la zona. Estos porteros se sientan en el borde de la red del proveedor de servicio de la telefonía por Internet (ITSP) y son como un punto de transferencia del voip, o transite la zona, en donde el tráfico de VoIP se canaliza a través en la manera al destino de las zonas remotas. IP-to-IP los gatewayes en VÍA la zona terminan las llamadas entrantes y el reoriginate ellos hacia sus destinos finales. Refiera al telecontrol a la red local con la función del gateway multiservicio de Cisco IP-to-IP para más información encendido VÍA la zona.

/image/gif/paws/24462/gk-call-routing-2b.gif

Nota: Si el invia o la zona especificado del outvia no se encuentra en el configs (es decir no se define como un local o zonas remotas), después se envía un mensaje ARJ.

Para seleccionar un IP-IP GW registrado al viazone seleccionado se utiliza este algoritmo:

  1. Si se encuentra un tecnología-prefijo (en corresponder con alias-basado), mire a través de la lista de gatewayes en el viazone especificado que han registrado este tecnología-prefijo.

  2. Si no se encuentra ningún tecnología-prefijo, mire a través de la lista entera de gatewayes registradoes al viazone especificado.

  3. Seleccione el primer IP-IP GW encontrado en el paso 1 o 2 que tiene recursos disponibles.

  4. Si todo el IP-IP GW en la lista está fuera de los recursos, seleccione el primer IP-IP GW se encuentra que (aunque puede ser que esté fuera de los recursos).

  5. Si no se encuentra ningún IP-IP GW, vuelva el error.

Ejemplos de llamada de zona local

En los ejemplos proporcionados en esta sección, los dos gatewayes se registran con el gatekeeper de Cisco con su H.323 respectivo ID. Además, el a2 del gateway (GWY) se registra con un direccionamiento E.164. Este diagrama se utiliza para todos los ejemplos en esta sección:

gk-call-routing-3.gif

Los tres escenarios en esta sección explican el proceso de decisión gradual las aplicaciones del portero de rutear las llamadas basaron en los mensajes ARQ.

Nota: Solamente la salida relevante se muestra en estas capturas de la configuración.

Escenario 1: No hay prefijos tecnológicos configurados

GK-A
!
gatekeeper
zone local GK-A abc.com
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718 

!--- The IP address configured here should 
!--- be the RAS address of GK-A
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status
 
!--- command on GK-A.
 
h323-gateway voip h323-id GW-A1@abc.com 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512

!--- On outgoing calls through POTS dial-peers,
!--- all explicit digit matches are dropped, 
!--- which is the reason
!--- for adding the prefix 512. This has nothing to  
!--- do with technology prefixes.

!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras

!--- Uses RAS messages (GK) to get 
!--- call setup information.


!
gateway
!
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718

!--- The IP address configured here  
!--- should be the RAS address of GK-A.
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status

!--- command on GK-A.
 
h323-gateway voip h323-id GW-A2@abc.com
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0

!--- This is the FXS port.

!
gateway
!

Esta salida capturada en el GK-A visualiza los registros reales. El aviso GWY-A2 también registra el E.164 ID del puerto FXS.

GK-A#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.22.1.1      1720  172.22.1.1      49317 GK-A              VOIP-GW
    H323-ID: GW-A1@abc.com
172.22.1.2      1720  172.22.1.2      58196 GK-A              VOIP-GW
    E164-ID: 9725551010
    H323-ID: GW-A2@abc.com
Total number of active registrations = 2

Acción de la primera llamada: El usuario A1 llama el a2 del usuario en 972-555-1010. Utilice el diagrama ARQ para completar el proceso de decisión.

El GK-A recibe el ARQ del GWY-A1.

  1. ¿El prefijo de tecnología hace juego? No

  2. ¿El prefijo de zona hace juego? No

  3. ¿Fijan al comando arq reject-unknown-prefix? No, las zonas del blanco iguala las zonas locales.

  4. ¿Son las zonas del blanco locales? Sí

  5. ¿Un prefijo de tecnología fue encontrado en el paso 1? No

  6. ¿Registran a la dirección objetivo? Sí. Envíe el ACF.

Configuración de la llamada acertada.

Nota: El GWY-A2 tiene el destino E.164 ID registrado (puerto FXS). Por lo tanto, el portero podía admitir la llamada.

Acción de la segunda llamada: El a2 del usuario marca 512-555-1212 para llamar al usuario A1.

El GK-A recibe el ARQ del GWY-A2.

  1. ¿El prefijo de tecnología hace juego? No

  2. ¿El prefijo de zona hace juego? No

  3. ¿Fijan al comando arq reject-unknown-prefix? No, las zonas del blanco iguala las zonas locales.

  4. ¿Son las zonas del blanco locales? Sí

  5. ¿Un prefijo de tecnología fue encontrado en el paso 1? No

  6. ¿Registran a la dirección objetivo? No

  7. ¿Se fija el prefijo de tecnología predeterminado? No Envíe el ARJ.

Configuración de la llamada fallada.

Nota: El escenario 2 explica cómo reparar este problema del ruteo de llamadas con los prefijos de tecnología.

Escenario 2: Prefijos de tecnología configurados

En este escenario, se realizan estos cambios de configuración:

  • GWY-A1 — Agregó el comando h323-gateway voip tech-prefix 1-. El GWY-A1 se registra al GK-A con el prefijo de tecnología 1#.

  • GWY-A1 — Agregó a un POTS dial peer con un comando destination-pattern que hace juego el entrante número al que se llamó del GWY-A2 con el prefijo de tecnología 1#.

  • GK-A — Agregó el comando del GK-A del prefijo de zona. Define los prefijos de las zonas locales que el GK-A maneja.

  • GK-A — Agregó el comando arq reject-unknown-prefix. Esto aplica el GK-A para validar solamente las llamadas ARQ para los prefijos de zona que maneja. En el escenario 1, esto no fue configurada. Por lo tanto, la zona de la blanco fue fijada a las zonas locales como valor por defecto.

  • GWY-A2 — Agregó el comando del tecnología-prefijo 1# bajo configuración del VoIP dial-peer. Esta manera, GWY-A2 prepends los dígitos 1# a las llamadas VoIP salientes. El GK-A identifica el modelo 1# para seleccionar el GWY-A1 como el gateway de destino.

GK-A
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
arq reject-unknown-prefix
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 3 pots
incoming called-number 972.......
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
tech-prefix 1#
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Esta salida capturada en el GK-A visualiza los prefijos de tecnología registradoes:

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#*
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Nota: En vez de configurar el GW-A1 con el comando h323-gateway voip tech-prefix 1-, puede ser lograda la misma manera manualmente configurando esta información en el GK-A con el comando.

GK-A(config-gk)#gw-type-prefix 1#* gw ipaddr 172.22.1.1

Acción de la llamada: El a2 del usuario marca 512-555-1212 para llamar al usuario A1.

El GK-A recibe el ARQ del GWY-A2.

  1. ¿El prefijo de tecnología hace juego? Sí

    Nota: Después de que la coincidencia del prefijo de tecnología, el portero la elimine para analizar el prefijo de zona. Esta tira es realizada solamente por la análisis de gatekeeper. El gateway de origen todavía la añade al final del fichero en la configuración de la llamada al gateway de terminación.

  2. ¿El prefijo de zona hace juego? Sí. Fije las zonas del blanco para igualar las zonas locales.

  3. ¿Hace la coincidencia del nombre de alias (después de la tecnología que elimina prefijaron) con GW registrado? No (si sí, envíe el ACF).

  4. ¿Son las zonas del blanco locales? Sí

  5. ¿Un prefijo de tecnología fue encontrado en el paso 1? Sí

  6. ¿Un gateway local con un prefijo de tecnología fue encontrado? Sí. Envíe el ACF.

    Éxito de la configuración de la llamada.

Este resultado del comando de debug del GK-A ilustra el comportamiento antedicho.

Nota: Este comando debug es un útil, pero ocultado, debug. Por lo tanto, el analizador de sintaxis no muestra el debug.

GK-A#debug gatekeeper main 5
      
    *Jun 19 09:50:10.086: gk_rassrv_arq: arqp=0x631CC400, crv=0x82, answerCall=0
    *Jun 19 09:50:10.086: gk_dns_locate_gk(): No Name servers
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched tech-prefix 1#
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched zone prefix 512
    *Jun 19 09:50:10.118: gk_rassrv_arq: arqp=0x631CC400, crv=0x1A, answerCall=1

Nota: Ésta es una configuración alternativa que puede ser más intuitiva:

  • Publique el comando del tecnología-prefijo 512 del H323-gateway voip para configurar el GWY-A1 para registrarse con el prefijo de tecnología 512.

  • Esta manera, GWY-A2 no tiene que pasar el prefijo en el tramo de llamada del VoIP dial-peer porque el destino-modelo incluye ya 512. Por lo tanto, saque el comando del tecnología-prefijo 1# en la configuración GWY-A2 y también quite 1# del destino-modelo bajo el dial peer de los crisoles en el GWY-A1.

Escenario 3: Prefijos de tecnología configurados como predeterminados

En este escenario, el GWY-A1 se registra con el prefijo de tecnología 1# y el GK-A se configura para rutear las llamadas sin una coincidencia del prefijo de tecnología a los gatewayes predeterminados del prefijo de tecnología. Por lo tanto, el GWY-A2 no necesita ser configurado para pasar el prefijo de tecnología del destino.

GK-A
!
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix 
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0 
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com 
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Esta salida capturada en el GK-A visualiza los prefijos de tecnología registradoes:

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#* (Default gateway-technology)
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Acción de la llamada: El a2 del usuario marca 512-555-1212 para llamar al usuario A1.

El GK-A recibe el ARQ del GWY-A2.

  1. ¿El prefijo de tecnología hace juego? No

  2. ¿El prefijo de zona hace juego? Sí. Fije las zonas del blanco para igualar las zonas locales.

  3. ¿Son las zonas del blanco locales? Sí

  4. ¿Un prefijo de tecnología fue encontrado en el paso 1? No

  5. ¿Registran a la dirección objetivo? No

  6. ¿Se fija el prefijo de tecnología predeterminado? Sí. Seleccione el gateway local con el prefijo de tecnología (solamente uno disponible).

  7. Envíe el ACF.

    Configuración de la llamada acertada.

Ejemplos de llamada de zona remota

En estos ejemplos, hay dos zonas de H.323: uno controlado por el GK-A y otro por el GK-B.

/image/gif/paws/24462/gk-call-routing-4.gif

Los escenarios en esta sección explican el proceso de decisión gradual el uso de los porteros de rutear las llamadas basaron en el ARQ y los mensajes LRQ.

Nota: Solamente la salida relevante se muestra en estos ejemplos de configuración.

Escenario 1: Controladores de acceso de zona configurados con prefijos de tecnología predeterminados

En este escenario, el GWY-A1 se registra al GK-A con los registros 1# y GWY-B1 del prefijo de tecnología al GK-B con el prefijo de tecnología 2#. Configuran a ambos porteros con los gatewayes predeterminados del prefijo de tecnología.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com 172.22.1.3
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
no shutdown
! 
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 2#* default-technology
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern ..........
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
!
gateway
!

Acción de la llamada: El usuario A1 marca 214-555-1111 para llamar al usuario B1.

El GK-A recibe el ARQ del GWY-A1.

  1. ¿El prefijo de tecnología hace juego? No

  2. ¿El prefijo de zona hace juego? Sí. Fije las zonas del blanco para igualar la zona del telecontrol GK-B (214).

  3. ¿Es la zona de la blanco local? No

  4. Envíe el LRQ al GK-B.

El GK-B recibe el LRQ del GK-A.

  1. ¿El prefijo de tecnología hace juego? No

  2. ¿El prefijo de zona hace juego? Sí. Fije las zonas del blanco para igualar las zonas locales.

  3. ¿Es la zona de la blanco local? Sí

  4. ¿Un prefijo de tecnología fue encontrado en el paso 1? No

  5. ¿Registran a la dirección objetivo? No

  6. ¿Se fija el prefijo de tecnología predeterminado? Sí. Seleccione el gateway local con el prefijo de tecnología (2#).

  7. Envíe el LCF al GK-A.

    El GK-A recibe el LCF del GK-B con la información del gateway de terminación.

    El GK-A envía el ACF al GWY-A1.

    La configuración de la llamada es acertada.

Escenario 2: Gatekeepers de zona configurados sin prefijos de tecnología predeterminados

En este escenario, el GWY-A1 se registra al GK-A con los registros 1# y GWY-B1 del prefijo de tecnología al GK-B con el prefijo de tecnología 2#. El GWY-A1 agrega el prefijo de tecnología 2# a la cadena de número llamado al hacer llama (a 214) y el GWY-B1 agrega el prefijo de tecnología 1# a la cadena de número llamado al hacer llama a (512).

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
gateway
!

Acción de la primera llamada: El usuario B1 marca 512-555-1212 para llamar al usuario A1.

El GK-B recibe el ARQ del GWY-B1.

  1. ¿El prefijo de tecnología hace juego? No

  2. ¿El prefijo de zona hace juego? No

    Nota: Porque el GK-B no es consciente de un prefijo de tecnología 1#, la asume que es parte de número al que se llamó y lee como prefijo de zona.

  3. ¿Es la zona de la blanco local? Sí

    Nota: El GK-B toma a iguales predeterminados de la zona de la blanco las zonas locales porque no fijan al comando arq reject-unknown-prefix.

  4. ¿Un prefijo de tecnología fue encontrado en el paso 1? No

  5. ¿Registran a la dirección objetivo? No

  6. ¿Se fija el prefijo de tecnología predeterminado? No

  7. Envíe el ARJ al GWY-B1.

    Configuración de la llamada fallada.

Esta salida fue capturada en el GK-B para ilustrar más lejos este comportamiento:


!--- From debug gatekeeper main 5.

      
GK-B#
gk_rassrv_arq: arqp=0x62F6A7E0, crv=0x22, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Tech-prefix match failed
rassrv_get_addrinfo(1#5125551212): unresolved zone prefix, using source zone GK-B
rassrv_get_addrinfo(1#5125551212): unknown address and no default technology defined
gk_rassrv_sep_arq(): rassrv_get_addrinfo() failed (return code = 0x103)

!--- From debug ras.


GK-B#
RecvUDP_IPSockData successfully rcvd message of length 156 from 172.22.2.1:51141
ARQ (seq# 1796) rcvdparse_arq_nonstd: ARQ Nonstd decode succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 4 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendARJ: ARJ (seq# 1796) sent to 172.22.2.1

Configure a los porteros para identificar los prefijos de tecnología de las zonas remotas para reparar este problema.

  • Agregue esto al GK-B:

    GK-B(config-gk)#gw-type-prefix 1# hopoff GK-A
    
  • Agregue esto al GK-A:

    GK-A(config-gk)#gw-type-prefix 2# hopoff GK-B
    

Note que el POTS dial peer en los gatewayes de terminación necesarios para ser puesto al día para hacer juego las cadenas de marcado entrantes con los prefijos de tecnología.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
gw-type-prefix 2# hopoff GK-B
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
gw-type-prefix 1# hopoff GK-A
no shutdown
!
GK-B GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!

!--- This dial-peer is used for 
!--- incoming calls from the PSTN.

dial-peer voice 1 pots
incoming called-number 512.......
direct-inward-dial
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!

!--- This dial-peer is used to 
!--- terminate (512) calls coming
!--- from the VoIP network. Notice 
!--- that the technology prefix 
!--- is matched to select the dial-peer 
!--- but does not pass it to 
!--- the PSTN.
 
dial-peer voice 3 pots
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 4 voip
destination-pattern 972.......
session target ras
! 
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
incoming called-number 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
dial-peer voice 3 pots
destination-pattern 2#214....... 
port 3/0:23
prefix 214 
! 
gateway
!

Acción de la segunda llamada: El usuario B1 marca 512-555-1212 para llamar al usuario A1.

El GK-B recibe el ARQ del GWY-B1.

  1. ¿El prefijo de tecnología hace juego? Sí

  2. ¿Hay un prefijo de tecnología del saltar? Sí

  3. Envíe el LRQ al GK-A.

    Nota: El LRQ incluye el prefijo de tecnología en número al que se llamó para el análisis del GK-A.

El GK-A recibe el LRQ del GK-B.

  1. ¿El prefijo de tecnología hace juego? Sí

  2. ¿Hay un prefijo de tecnología del saltar? No

    Nota: Para continuar el análisis del ruteo de llamadas, el GK-A elimina el prefijo de tecnología. Sigue habiendo el prefijo de tecnología en la cadena de número llamado cuando los gatewayes configuran los tramos de llamada.

  3. ¿El prefijo de zona hace juego? Sí. Fije las zonas del blanco para igualar las zonas locales.

  4. ¿Son las zonas del blanco locales? Sí

  5. ¿Un prefijo de tecnología fue encontrado en el paso 1? Sí

  6. ¿Usted encontró un gateway local con un prefijo de tecnología? Sí

  7. Envíe el LCF al GK-B.

    El GK-B recibe el LCF del GK-A con la información del gateway de terminación.

    El GK-B envía el ACF al GWY-B1.

    Configuración de la llamada acertada.

Capturaron a esta salida de comando en el GK-B para ilustrar más lejos este comportamiento:


!--- From debug gatekeeper main 5.


GK-B#
gk_rassrv_arq: arqp=0x62ED2D68, crv=0x24, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Matched tech-prefix 1#
rassrv_put_remote_zones_from_zone_list() zone GK-A
gk_rassrv_irr: irrp=0x62F0D8FC, from 172.22.2.1:51141
GK-B#
GK-B#

!--- From debug ras.


RecvUDP_IPSockData successfully received message of 
length 156 from 172.22.2.1:51141
ARQ (seq# 1809) rcvdparse_arq_nonstd: ARQ Nonstd decode 
succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 104 from 
172.22.2.3:1719 to 172.22.1.3: 1719
RASLib::RASSendLRQ: LRQ (seq# 1042) sent to 172.22.1.3
IPSOCK_RAS_sendto: msg length 7 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendRIP: RIP (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
131 from 172.22.1.3:1719
LCF (seq# 1042) rcvdparse_lcf_nonstd: LCF Nonstd 
decode succeeded, remlen= 131
IPSOCK_RAS_sendto: msg length 34 from 172.22.2.3:1719 
to 172.22.2.1: 51141
RASLib::RASSendACF: ACF (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
76 from 172.22.2.1:51141

Comandos de verificación y resolución de problemas

Esta sección proporciona una lista de comandos show and debug que se utilicen para verificar y para resolver problemas los problemas del ruteo de llamadas del gatekeeper y gateway.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • gateway de la demostración — Utilizado para verificar el registro E.164 y de H.323 alias para el gateway.

  • muestre los puntos finales del portero — Utilizado para verificar el E.164 y H.323 alias registradoes con el portero.

  • muestre el GW-tipo-prefijo del portero — Utilizado para verificar los registros del prefijo E.164 en el portero.

  • muestre el prefijo de las zonas de gatekeeper | estatus — Utilizado para verificar el estatus y los parámetros de la configuración de la zona.

  • ras del debug — Aplicable para los gatewayes y los porteros.

  • asn1 del h225 del debug — Aplicable para los gatewayes y los porteros.

  • voz de dial-peer de la demostración — Utilizado para verificar configuró los prefijos de tecnología bajo el dial-peers.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 24462