Voz : Calidad de voz

Voz QoS: Marca del paquete de TOS-CoS para el uso con el LLQ

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento describe la Calidad de Servicio (QoS) para Voz sobre IP (VoIP) en un entorno LAN asociando el Tipo de Servicio (ToS) a los parámetros de Clase de Servicio (CoS).

Hasta hace poco tiempo, el consenso general era que QoS nunca sería un problema en el lado corporativo debido a la naturaleza de congestión del tráfico de la red y a la capacidad del desbordamiento de búfer. La razón de QoS en el lado LAN es debido a mitigar, no falta de ancho de banda. Por este motivo, las herramientas de QoS se requieren manejar estos buffers para minimizar la pérdida, el retardo, y la variación de retraso. Transmita los buffers tienen una tendencia a llenar a la capacidad en las redes de alta velocidad debido a la naturaleza de congestión de las redes de datos combinadas con el volumen alto de paquetes más pequeños del Transmission Control Protocol (TCP). Si un búfer de salida llena, las interfaces de ingreso no pueden poner inmediatamente el nuevo tráfico del flujo en el búfer de salida. Una vez que la memoria intermedia de ingreso llena (puede suceder rápidamente), las caídas de paquetes ocurren. Aquí es donde la Calidad de voz puede degradar posiblemente debido a la pérdida del paquete.

El tráfico de VoIP es sensible a los paquetes con retardo y a los paquetes perdidos. El retardo debe nunca ser un factor, sin importar los tamaños del búfer de cola, debido a la velocidad en los links LAN. Sin embargo, los descensos afectan siempre al contrario a la Calidad de voz en todas las redes. El uso de las colas múltiples en las interfaces de transmisión es la única forma de eliminar el potencial para el tráfico interrumpido causado por los buffers que actúan en la capacidad del 100%. La separación de la Voz y del vídeo (ambos sensibles a los retardos y a los descensos) en sus propias colas de administración del tráfico puede evitar que los flujos sean caídos en la interfaz de ingreso, incluso si los flujos de datos llenan para arriba los datos transmiten el buffer.

En las redes con las altas cargas de tráfico, es crítico manejar la salida del tráfico de control para asegurar una experiencia positiva del usuario con el VoIP. Esto se ilustra fácilmente. Por ejemplo, cuando va un teléfono del IP descolgado, pide a Cisco CallManager qué hacer. El Cisco CallManager entonces da instrucciones el teléfono del IP para jugar el tono de discado. Si se cae o se retrasa la administración del protocolo cliente Skinny y el tráfico de control, la experiencia del usuario se afecta al contrario. Para proporcionar QoS, marque los encabezados de paquete con una precedencia más alta y asocíelos correctamente a los encabezados para Catalysts de la capa 2 para entender. Esto asegura la priorización apropiada en los paquetes de voz a través del LAN.

prerrequisitos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en estas versiones de software y hardware.

  • Gateway de voz del Cisco 3725 con el Software Release 12.3(4)T de Cisco IOS�.

  • Catalyst 4000 Switch

  • CallManageres y Teléfonos IP de Cisco

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/23442/tos-cos-1.gif

Configuraciones

Este documento usa estas configuraciones.

Esta configuración muestra cómo asociar la TOS/los valores del Differentiated Services Code Point (DSCP) en un valor de CoS en la porción de encabezado 802.1p. Hay muchas maneras de implementar esto y las leves diferencias varían dependiendo de su diseño. Los dos ejemplos de configuración aquí son equivalentes y cualquiera uno se puede utilizar para alcanzar el mismo resultado. Esté seguro de permitir solamente los paquetes de VoIP que tienen una Prioridad IP de (5) crítico en el bit TOS. Ningún otro tráfico debe tener este conjunto de bits a crítico. Esto causa la coincidencia del tráfico no deseado en la cola de la Voz.

Nota: La configuración de LLQ se hace en los otros dispositivos en la red tal como el Catalyst 4000, que no se discute en este documento.

En este primer ejemplo, solamente se marcan con etiqueta las secuencias RTP que hacen juego la Prioridad IP 5, y no RTCP o cualquier señalización H.225/245 y paquete de mensajería.

Cisco 3660 (ejemplo 1)
!
ip cef
!

!--- The Cisco Express Forwarding (CEF) mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".

! 
class-map match-all RTP
match ip precedence 5 

!--- This command matches on all packets with the IP precedence of 5.
 
!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all packets which previously matched on class-map RTP for 
!--- having precedence of 5, the CoS bit is now set to 5.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and 
!--- carries a lower priority of delivery.

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816

!--- There must be subinterfaces for FastEthernet to enable trunking, 
!--- as well as either dot1q or isl encapsulation.

ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply the QoS to the interface that connects to the LAN
!--- via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Nota: Presentaron al comando ip qos dscp en el Cisco IOS Software Release 12.2(2)T. Substituye el comando ip precedence (dial-peer). Todo el Routers que se ejecuta en el Cisco IOS Software Release 12.2(2)T y Anterior puede utilizar la Prioridad IP en la configuración de dial-peer.

El segundo ejemplo tiene diversos parámetros que corresponden con para las clases de directiva-mapa. La configuración del Cisco 3660 hace juego en los paquetes de la configuración de la llamada H.225 así como las secuencias RTP. Los criterios concordantes para la secuencia RTP son también levemente diferentes. No mire las encabezados IP, sólo mirada el rango de puertos UDP. Si baja entre 16384 y 32767, marqúelos con etiqueta y envíeles el directiva-mapa.

Cisco 3660 (ejemplo 2)
!
ip cef
!

!--- The CEF mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".
!
class-map match-all Call-Control
match access-group 101
!
class-map match-all RTP
match ip rtp 16384 16383

!--- Match on UDP port range 16384-32767 to single out 
!--- VoIP packets for policy-map.

!
access-list 101 permit tcp host 10.120.16.112 any eq 1720

!--- Match on all packets using TCP port 1720 which is 
!--- dedicated for H.225 call setup. 

!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all VoIP packets that match the  UDP port range listed above,
!--- set the CoS bit to 5.

class Call-Control
set CoS 3
set ip precedence 3

!--- For all signaling and control packets that match access-list 
!--- 101, set the CoS bit to 3 and IP precedence to 3.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and carries a 
!--- lower priority of delivery. 

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply your QoS to the interface that connects to the 
!--- LAN via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media 
no vad
!

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show policy-map interface — Visualiza los contadores de coincidencias para todas las clases de una correlación de políticas de servicio especificada.

Ahora configuran al Routers para asociar la TOS mordida al bit de CoS. Utilice el comando show policy-map interface de aseegurar el tráfico es realmente marcado según la configuración.

En esta primera salida de ejemplo, los 539 paquetes de VoIP hacen juego el clase-mapa y los 539 paquetes tienen CoS mordidos marcados a un valor de crítico como consecuencia. Este tipo cola no tiene que esperar la congestión para ser activo. Mientras haya el tráfico de voz que atraviesa link FastEthernet, marca todos los paquetes por consiguiente. En el segundo ejemplo, todos los paquetes de VoIP marcaron a CoS el valor de 5 y todos los paquetes de la señalización se marcan a un valor de CoS de 3 según la configuración.

Del primer ejemplo de configuración 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816  
  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      539 packets, 42042 bytes
      5 minute offered rate 2000 bps, drop rate 0 BPS
      Match: ip precedence 5 
      QoS Set
        CoS 5
          Packets marked 539

    Class-map: class-default (match-any)
      13 packets, 1803 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 13

Del segundo ejemplo de configuración 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816 

  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      370 packets, 28860 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip rtp 16384 16383
      QoS Set
        CoS 5
          Packets marked 370

    Class-map: Call-Control (match-all)
      26 packets, 2697 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: access-group 101
      QoS Set
        ip precedence 3
          Packets marked 26
        CoS 3
          Packets marked 26

    Class-map: class-default (match-any)
      4363 packets, 515087 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 4363
vdtl-3660-16a#

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 23442