Marcado y acceso remotos : Dial-on-Demand Routing (DDR)

Información y solución de problemas acerca de tiempos de espera agotados por inactividad

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Un problema común que afecta a los links de marcado son las caídas inesperadas de llamadas. Las razones varían desde fallas de hardware hasta problemas con la compañía de telecomunicaciones. Sin embargo, una de las causas más frecuentes de las caídas de llamadas inesperadas es el vencimiento del tiempo de espera agotado inactivo.

Otro problema de agotamiento del tiempo inactivo común es que el link no desconecta puesto que nunca expira el tiempo de inactividad. Esto puede traer como consecuencia gastos altos de conexión que son cobrados según el tiempo durante el cual la llamada está conectada.

Este documento se centra en la configuración y solución de problemas de tiempo de espera de inactividad.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Problemas y síntomas comunes

Los síntomas siguientes pueden indicar los problemas relacionados con el tiempo de inactividad:

  • Las llamadas se desconectan cada dos minutos (120 segundos) después que se establece la conexión.

    Esta desconexión normalmente se debe a que el tiempo de espera inactivo predeterminado de 120 segundos está habilitado, mientras que la definición de tráfico interesante no está determinada o no está aplicada a la interfaz. Aunque el comando dialer in-band habilite un tiempo de espera ocioso predeterminado de 120 segundos en la interfaz, este valor no aparece en la salida de la ejecutar-configuración de la demostración. Debido a que el tiempo de espera inactivo predeterminado no está visible, a menudo se diagnostica erróneamente una desconexión de 120 segundos.

  • Las llamadas se desconectan cada x minutos una vez establecida la conexión.

    Esta desconexión es normalmente debido al ocioso-descanso que es configurado (usando el comando dialer idle-timeout), mientras que la definición de tráfico interesante no se define ni se aplica a la interfaz.

  • Las llamadas se desconectan en forma prematura. Probablemente, esto se debe a un valor bajo de descanso ocioso del marcador combinado o a una definición restrictiva del tráfico interesante.

  • Las llamadas no se desconectan. Esto se debe probablemente a un valor elevado del tiempo de espera inactivo del marcador junto a una definición deficiente de tráfico interesante.

Tiempos de espera agotados por inactividad

El comando de tiempo de espera de inactividad clave es el dialer idle-timeout, que es un comando de configuración de interfaz para interfaces asíncronas, asíncronas de grupo, ISDN y de marcador. (Otro comando usado comúnmente, ppp timeout idle, que se utiliza en interfaces de acceso virtual, se encuentra fuera del alcance de este documento. Pautas de configuración del MSN dual

El comando dialer idle-timeout {x} puede ser configurado en cualquier interfaz habilitada para dialer. Los controles de contador ociosos cuánto tiempo la conexión puede estar ociosa (en los segundos) antes de que se termine. El conector se reinicia o cuenta de manera regresiva en base a lo que el router determina como "tráfico interesante". Si el router ve el tráfico interesante (según lo definido en la marcador-lista), reajusta el temporizador de inactividad, o bien el temporizador de inactividad continúa contando abajo. Cuando el temporizador alcanza cero, la llamada es disconnected.

A continuación se detallan algunos puntos que debe tener en cuenta sobre este comando.

  • Este comando sólo puede aplicarse a interfaces que sean capaces de utilizar el marcador. Por abandono, todas las interfaces de ISDN (interfaz de velocidad básica [BRI] y interfaz de la velocidad primaria [PRI]) son dialer capaz, así que este comando se pueden agregar sin los problemas.

  • Las interfaces asincrónicas (por ejemplo, interfaz asincr. x o grupo de intefaz asincr. x) no son capaces de marcar de manera predeterminada. Debe hacerlos con capacidad de marcador ingresando el marcador del comando en banda. Observe que las plantillas virtuales (y por lo tanto las interfaces de acceso virtual) no son dialer capaz, pero sea de punto a punto solamente. Por lo tanto, no pueden utilizar este comando a menos que funcionen con la versión de software 12.2(4)T de Cisco IOS�, cuando las mejoras a la estructura del tiempo de inactividad eran incluidas.

  • Usted puede configurar solamente el ocioso-descanso del marcador después de ingresar el comando dialer in-band en la interfaz asincrónica.

  • En una interfaz con capacidad de marcador (es decir, ISDN o asíncrono con marcador en banda), el tiempo de espera inactivo predeterminado es 120 segundos (dos minutos). Se usa el valor predeterminado a menos que configure explícitamente el comando dialer idle-timeout con un valor diferente del tiempo de espera inactivo.

    Nota: El tiempo de espera ocioso predeterminado no se muestra en la configuración porque es el valor por defecto. Utilice el comando show dialer de determinar si un tiempo de inactividad se hace cumplir en la interfaz.

  • Si usted quisiera que los usuarios pudieran permanecer conectado hasta que elijan desconectar, utilice el comando dialer idle-timeout 0. La opción cero para el ocioso-descanso del marcador fue introducida en el Cisco IOS Software Release 12.1(3)T, y fija un tiempo de espera infinito.

Tráfico interesante

Con el Dial-on-demand Routing (DDR), todo el tráfico se clasifica como interesante o no interesante. Si el tráfico es interesante, después el router conecta con el par. Si el tráfico no es interesante, la llamada no se conecta. Sin embargo, para las conexiones que están conectadas ya, el tráfico interesante tiene un diverso propósito. Se utiliza para reajustar el tiempo de inactividad de nuevo al valor máximo (configurado con el comando dialer idle-timeout). En el momento en que se realiza la conexión, el temporizador de inactividad comienza a disminuir. Una vez que el router recibe un paquete que se ajusta a la definición de tráfico interesante, el temporizador de inactividad vuelve a su valor máximo.

Trafique que se considera ser interesante es definido por el comando dialer-list {n} (en el modo de configuración global), donde el {n} hace juego el número en la declaración de comando dialer-group {n} bajo configuración de la interfaz.

Hay dos métodos para definir el tráfico interesante. El método simple (mediante el comando dialer-list) especifica un protocolo completo (como IP o IPX) como interesante o no interesante. Sin embargo, si usted necesidad da una definición de tráfico interesante granular (por ejemplo, si el tráfico HTTP es interesante, solamente tráfico de Telnet no es) que usted necesita utilizar el comando dialer-list conjuntamente con una lista de acceso.

Refiera a la sección que configura el tiempo de inactividad y el tráfico interesante para más información sobre configurar el tráfico interesante.

Especificación de la dirección del tráfico interesante

Por abandono, el ocioso-descanso del marcador es reajustado de nuevo al máximo por el tráfico interesante en la dirección saliente. Si únicamente el tráfico entrante debiera reiniciar el tiempo inactivo, entonces utilice la entrada de la palabra clave adicional. Utilice la cualquier palabra clave para que el tráfico entrante y saliente reajuste el ocioso-descanso. Esto fue implementando en la versión 12.1 (1)T del software Cisco IOS.

Beneficios: Especificando que solamente el tráfico entrante reajustará el temporizador de inactividad del dialer, usted puede evitar que el tráfico de Internet inesperado guarde una conexión inactiva de ser disconnected.

Definición del tráfico interesante y del descanso ocioso

El tráfico interesante se debe definir en los ambos extremos de un link DDR. Incluso si el router que recibe la llamada sólo maneja llamadas entrantes y no realiza llamadas salientes, aún debemos definir el trafico interesante.

La definición de tráfico interesante tiene un objetivo diferente para llamadas entrantes Async e ISDN.

Para los usuarios de ISDN (correspondientes a la interfaz de marcador X)

Requieren a los comandos dialer-group and dialer-list en la interfaz del dialer, sin importar si usted quiera aplicar el tiempo de inactividad o no. Los comandos dialer-group and dialer-list son necesarios en la interfaz del dialer evitar las fallas de encapsulación. Este requisito es sólo para usuarios ISDN y no para usuarios asíncronos y la interfaz asíncrona de grupo.

Para aplicar un tiempo de inactividad, agregue los comandos dialer in-band and dialer idle-timeout. Sin embargo, si configuran al dialer dentro de la banda pero no es el ocioso-descanso del marcador, después el tiempo de inactividad omitirá dos minutos para los usuarios ISDN.

Si usted quisiera que sus usuarios ISDN permanecieran conectados hasta que elijan desconectar, utilice el comando dialer idle-timeout 0. La opción cero para el tiempo de espera inactiva del marcador es un lanzamiento que se hizo a través de la versión 12.1(3)T del software IOS de Cisco, la cual fija un tiempo de espera infinito.

Para los usuarios ISDN (correspondiente a la interfaz BRI x y a la interfaz x:23 seriales)

Todas las interfaces físicas de ISDN están habilitadas para DDR de manera predeterminada. Esto significa que habilitan al dialer dentro de la banda ya en esa interfaz. Para imponer un tiempo de espera inactivo, agregue el comando dialer idle-timeout. Sin embargo, si configuran al dialer dentro de la banda pero no es el ocioso-descanso del marcador, después el tiempo de inactividad omite dos minutos para los usuarios ISDN.

Requieren a los comandos dialer-group and dialer-list en esa interfaz, sin importar si usted quiera aplicar el ocioso-descanso o no. Los comandos dialer-group y dialer-list son necesarios en la interfaz para evitar fallas de encapsulación. Este requisito está solamente para los usuarios ISDN, no para los usuarios asincrónicos y la interfaz asincrónica del grupo.

Si usted quisiera que sus usuarios ISDN permanecieran conectados hasta que elijan desconectar, utilice el comando dialer idle-timeout 0. La opción cero para el tiempo de espera inactiva del marcador es un lanzamiento que se hizo a través de la versión 12.1(3)T del software IOS de Cisco, la cual fija un tiempo de espera infinito.

Para los usuarios asincrónicos (correspondiente al grupo async de la interfaz X)

Para imponer un tiempo de espera inactivo para los usuarios de Asyn, configure los siguientes comandos en la interfaz de grupo asincrónico:

  • dialer in-band

  • dialer idle-timeout

  • dialer-group

La lista del marcado correspondiente también es necesaria. Los comandos dialer-group y dialer-list especifican el tráfico interesante en la interfaz asíncrona de grupo.

Para usuarios asincrónicos, el tráfico interesante sólo se utiliza para reiniciar el tiempo de espera ocioso. Si no se define el tráfico interesante, entonces se desconectará a los usuarios luego de que el tiempo de espera inactivo del marcador (120 segundo predeterminados) expire, sin importar si están transmitiendo tráfico por el link. Con una definición de tráfico interesante, el servidor de acceso a la red (NAS) reconocerá esos paquetes y restablecerá el tiempo de espera inactivo desconectando así al usuario sólo cuando existe un link verdaderamente inactivo.

Es posible modificar el tráfico interesante tal que, por ejemplo, sólo el tráfico HTTP (web) sea interesante. En una situación semejante, si el usuario no hojea la red por 300 segundos (o para el agotamiento del tiempo de espera de inactividad del dialer especificado), son disconnected. Configure el tráfico interesante dependiendo de los patrones de tráfico de sus usuarios.

Si usted quisiera que sus usuarios asincrónicos pudieran permanecer conectado hasta que elijan desconectar, después quite los siguientes comandos de la interfaz asincrónica de grupo, tal y como se muestra en de la configuración:

  • dialer in-band

  • dialer idle-timeout

  • dialer-group

Usted puede también fijar el tiempo de inactividad al infinito usando el comando dialer idle-timeout 0. La opción cero para el tiempo de espera inactiva del marcador es un lanzamiento que se hizo a través de la versión 12.1(3)T del software del IOS de Cisco, la cual configura un tiempo de espera con el valor infinito.

Configuración de los tiempos de espera inactivos y del tráfico interesante

Esta sección discute cómo usted puede configurar el tiempo de inactividad y el tráfico interesante en el router. Usted puede aplicar esta configuración a todas las interfaces DDR-habilitadas, por ejemplo:

interface BRI
interface async x
interface dialer x
interface group-async x
interface serial x:23

Para proporcionar tiempos de espera por usuario, también puede utilizar un servidor de Autenticación, autorización y contabilidad (AAA). Consulte el documento Tiempos de espera PPP por usuario para obtener más información.

Configuración de muestra:

El siguiente ejemplo de configuración incluye una definición sencilla de tráfico interesante. Este ejemplo particular designa a todo el tráfico IP como interesante:

interface BRI0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 900
!--- Idle-timeout is set at 900 seconds (15 minutes)
dialer-group 1
!--- Apply interesting traffic definition from dialer-list 1
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
dialer-list 1 protocol ip permit
!--- Designate all IP traffic as interesting.  
This definition was applied to BRI0/0 using dialer-group 1.   
Note that the dialer-list and dialer-group numbers match

La configuración anterior mantiene activa la conexión durante 900 segundos (15 minutos) como mínimo, y permite que el tráfico IP en cada dirección (la predeterminada) reinicie el tiempo de espera agotado por inactividad en 900 segundos. Por lo tanto, si ningún tráfico IP pasa en cualquier dirección por 15 minutos, el router desconecta la línea porque ha expirado el tiempo de inactividad.

Nota: Si usted funciona con un Routing Protocol sobre este link DDR, el tráfico periódico guarda el link para arriba indefinidamente. Por lo tanto, la definición de tráfico interesante mostrada arriba no se recomienda para los links con los Routing Protocol (o el otro tráfico periódico) que se ejecutan a través de ella.

Uso de las listas de acceso

El siguiente ejemplo muestra un router con la interfaz de velocidad básica (BRI) que recibe la llamada y ha activado el comando dialer idle-timeout con la palabra clave entrante. Este comando permite sólo tráfico entrante que se ajuste a la lista de marcadores a fin de reiniciar el temporizador de inactividad del marcador. Aquí, sólo el tráfico TCP en el puerto 80 (tráfico HTTP) tiene permitido restablecer el tiempo de espera inactivo nuevamente a diez minutos (600 segundos). Por lo tanto, si el usuario final no hojea la red por diez minutos, la conexión es disconnected.

Utilización de interfaces ISDN

interface BRI0/0   
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 600 inbound

!--- Idle timeout is 600 seconds.  Only inbound interesting traffic will reset 
the idle timeout

dialer-group 1

!--- Apply the interesting traffic defintion from dialer-list 1

peer default ip address pool dialin
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http) from any host to any other host

access-list 101 deny ip any any

!--- All other IP traffic is uninteresting

dialer-list 1 protocol ip list 101

!--- Use list 101 for granular interesting traffic definition
ip local pool dialin 10.1.1.2 10.1.1.254

Usando las interfaces asincrónicas

Las interfaces asincrónicas DDR-no se habilitan por abandono, así que usar al dialer dentro de la banda las rinde DDR-habilitadas.

Interface group-async 1
ip unnumbered ethernet 0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
peer default ip address pool dialin
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80
access-list 101 deny ip any any

!--- Access-lists have an implicit deny.  However, we are explicitly denying IP 
here for clarity.


dialer-list 1 protocol ip list 101
ip local pool dialin 10.1.1.2 10.1.1.254

Mejoras en el tiempo de espera

Antes de que se lanzara el software Cisco IOS versión 12.2(4)T, el temporizador de tiempo ocioso del marcador sólo podía reiniciarse para tráfico interesante en las interfaces que contaban con habilitación de marcador (por ejemplo, BRI, PRI y asincrónicas de grupo con el comando dialer in-band). Los descansos ociosos no pueden aplicarse a los usuarios conectados a interfaces de plantilla virtual.

A partir del Cisco IOS Software Release 12.2(4)T, la característica del Mejoras al temporizador de inactividad del perfil de clientes para tráfico de interés proporciona los comandos new y las funciones que abordan los problemas del temporizador de inactividad para las sesiones de la Red de acceso telefónico virtual (VPDN), que utilizan las interfaces del acceso virtual (proyectado) y confían en el mecanismo del temporizador de inactividad PPP.

Verificación del descanso ocioso

Realice los pasos siguientes para verificar y para resolver problemas la conducta del agotamiento del tiempo inactivo:

  1. Utilice el comando show user para asegurarse de que la llamada esté conectada.

  2. Utilice el descanso del llamante de la demostración, muestre el marcador, y muestre al caller user para determinar si el tiempo de inactividad está asignado correctamente a la interfaz conectada. Si ejecuta los comandos show varias veces, debe observar un descenso en el tiempo para desconectar.

  3. Inicie el tráfico interesante (según la definición de la lista de marcadores x) sobre el link. Debe observar la configuración en ejecución para determinar la definición de tráfico interesante.

  4. Ejecute el descanso del llamante de la demostración, muestre el marcador, y muestre al caller user de nuevo para determinar si se ha reajustado el tiempo de inactividad. Si no sucede esto, después o el tráfico interesante no se define correctamente (usando la marcador-lista) o no se ha aplicado a la interfaz (usando el marcador-grupo).

Los comandos usados para verificar la conducta del agotamiento del tiempo inactivo son mencionados abajo:

  • Comando show caller timeout: muestra los tiempos de espera absolutos e inactivos instalados y el tiempo antes de que el usuario sea desconectado por cualquier tiempo de espera.

  • show dialer [número de tipo de la interfaz] – Muestra información general de diagnóstico para interfaces configuradas para DDR. Si ha subido el marcador correctamente, el estado del dialer es capa del link de datos encima del mensaje aparece. Si la capa física aparece, significa que el protocolo de línea surge, pero no así el Protocolo de control de red (NCP). Las direcciones de origen y destino del paquete que inició el marcado se ven en la línea de motivo del marcado. Este comando también visualiza el tiempo del temporizador la configuración y antes del tiempo de conexión hacia fuera.

  • show caller user username detail – Muestra parámetros específicos para un usuario en particular, como la dirección de IP asignada, los parámetros PPP y de agrupamiento PPP, etc. Si su versión del Cisco IOS Software no soporta este comando, utilice el comando show user.

Para llamadas ISDN

Aquí está la configuración para el router del lado de recepción con una interfaz BRI conectada al interface dialer 1 con el comando dialer rotary-group 1. Tenga en cuenta que el marcador de la interfaz 1 tiene DDR habilitado por medio del comando dialer in-band.

interface BRI0
   description 96665500
   no ip address
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer rotary-group 1
   dialer-group 1
   isdn switch-type basic-5ess
   no cdp enable
   ppp authentication pap
 !
 interface Dialer1
   ip address 10.1.1.1 255.255.255.0
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer in-band
   dialer idle-timeout 600
   dialer-group 1
   peer default ip address pool dialin
   no cdp enable
   ppp authentication chap callin
   ppp chap hostname cisco
   ppp chap password 7 <deleted>
 !
 ip local pool dialin 10.1.1.2 10.1.1.255
 dialer-list 1 protocol list 101
 access-list 101 permit icmp any any
 access-list 101 permit tcp any any eq 80
 access-list 101 deny ip any any

!--- Only http traffic and icmp traffic are interesting
 
 !

Realice los pasos siguientes para verificar el tiempo de inactividad:

  1. Asegúrese de que se conecte la llamada. Usted puede utilizar el comando show user de verificar que el usuario está conectado. Por ejemplo:

    isdn2-4#show user
    
    Line   User  Host(s)       Idle     Location
    * 2 vty 0  idle         00:00:00 172.22.88.109
    
    Interface   User  Mode     Idle      Peer Address
    BR0:1       Preet Sync PPP 00:00:51  PPP: 10.1.1.2
    
  2. Verifique que el tiempo de espera ocioso se aplique a la conexión. En el ejemplo abajo, el usuario Preet marcó en y terminó en el interface dialer 1, y obtuvo a la dirección IP 10.1.1.2 del dialin del pool. Ahora verifiquemos que la conexión esté implementando un tiempo de espera ocioso de 600 segundos (10 minutos).

    isdn2-4#show dialer interface dialer1
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The idle timeout value configured on int dialer 1.   If the default 
    is in use, this value will be 120.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The user Preet obtained the idle timeout of 600 seconds.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 557 secs
    

    Se está descontando el tiempo para la desconexión ya que no hay tráfico interesante pasando al link. No hubo tráfico interesante que pasara en cualquier sentido durante los últimos 43 segundos. Por lo tanto, desconectan al usuario en 600 - 43 = 557 segundos. El tiempo hasta que el campo de la desconexión comience a contar abajo una vez al usuario está conectado y reajustado al máximo cuando se recibe el tráfico interesante.

    Connected to 4086666700 (Preet)
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle

    Otro comando que se puede utilizar para verificar el tiempo de inactividad es descanso del llamador de la demostración:

    isdn2-4#show caller timeout
    Line    User   Limit     Remaining   Timer  Type
    vty 2    -     00:10:00  00:09:59    Idle   Exec
    BR0:1   Preet  00:10:00  00:09:13    Dialer idle
    

    El campo limit (límite) muestra el tiempo de espera de inactividad máximo (en minutos) configurado y el campo remaining (restante) muestra el tiempo hasta la desconexión.

  3. Iniciación de tráfico interesante al par. Ahora iniciaremos tráfico interesante para el par. Aseegurele mirar la ejecutar-configuración para determinar la definición de tráfico interesante exacta. La lista de acceso 101 define el tráfico TCP y de Protocolo de mensajes de control de Internet (ICMP) al puerto 80 como interesante. Por lo tanto, ahora haremos ping 10.1.1.2 (dirección IP que el usuario Preet ha negociado) del router.

    isdn2-4#ping 10.1.1.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 36/37/40 ms
    isdn2-4#
  4. Verifique que el tiempo de espera inactivo se ha restaurado. Utilice los comandos show caller timeout, show dialer, y show caller user de verificar que se ha reajustado el tiempo de inactividad:

    isdn2-4#show caller timeout 
     Line     User      Limit    Remaining  Timer Type 
     vty 2    -         00:10:00 00:09:59   Idle Exec 
     BR0:1    Preet     00:10:00 00:09:59   Dialer idle
    !--- Idle-timout is reset back to maximum
    
    
    isdn2-4#show dialer interface dialer1
    
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 599 secs
    
    !--- Idle timeout is reset back to maximum.
    
    
    Connected to 4086666700 (Preet)
    
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle
    isdn2-4# 
    

Otro comando útil que se puede utilizar para considerar que la información de tiempo de espera basó en el nombre de usuario, es el comando show caller user.

isdn2-4#show caller user Preet
 User: Preet, line BR0:1, service PPP 
 Connected for 00:05:36, Idle for 00:02:37
!--- Shows the inactivity for the last two minutes and 37 seconds. 
This counter increments to ten minutes and then the call is disconnected.


Timeouts: Limit    Remaining Timer  Type
          00:10:00 00:07:22  Dialer idle
!--- Time until idle disconnect.


PPP: LCP Open, PAP (<- none), IPCP
Dialer: Connected to 4086666700, inbound
        Type is ISDN, group Di1
IP: Local 10.1.1.1/24, remote 10.1.1.2
Counts: 215 packets input, 5392 bytes, 0 no buffer
        0 input errors, 0 CRC, 0 frame, 0 overrun
        230 packets output, 5603 bytes, 0 underruns
        0 output errors, 0 collisions, 7 interface resets

Si el tiempo de inactividad no se reajusta, proceda a los problemas de agotamiento del tiempo inactivo del troubleshooting de la sección.

Para llamadas asincrónicas

A continuación se proporciona una configuración típica para las llamadas Async que se pueden observar en el entorno ISP.

 interface Group-Async0
   ip unnumbered Loopback0
   encapsulation ppp
   dialer in-band

!--- Make this interface dialer capable
 
   dialer idle-timeout 600

!---  Idle timeout of 600 seconds (10 minutes)

   dialer-group 1

!--- Interesting traffic definition from dialer-list 1

   async mode interactive
   peer default ip address pool dialin
   ppp authentication pap chap callin
   group-range 1/3/00 1/3/71
   !
   ip local pool dialin 10.1.1.3 10.1.1.255
 dialer-list 1 protocol list 101

!--- Interesting traffic definition is defined by access-list 101

access-list 101 permit icmp any any

!--- Permit icmp from any host to any other host

 access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http traffic)

access-list 101 deny ip any any

!--- Deny all other IP traffic.  This interesting traffic definition 
will allow icmp and http traffic to reset the idle timeout. All other IP traffic will not 
affect the timeout.

Igual que con el ISDN, utilice a los usuarios de la demostración, muestre el marcador, y muestre el descanso del llamador para verificar el tiempo de inactividad.

Utilice el comando show users para hallar la interfaz y dirección IP a la que la entidad par está conectada.

c5800#show users
      Line      User  Host(s)         Idle     Location
   * 0 con 0          idle            00:00:00 
     tty 1/3/01 Preet Async interface 00:00:09 PPP: 10.1.1.3
!--- User Preet is connected to async interface 1/3/01 and has IP address 10.1.1.3

Interface    User Mode             Idle     Peer          Address

Use el comando show dialer (especificando la interfaz determinada recientemente) para observar los valores del temporizador:

c5800#show dialer interface async 1/3/01
As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (600 secs), Fast idle timer (20 secs)
!--- Idle timeout of 600 seconds is applied to the interface if this value 
is 120 seconds.


!--- Verify that dialer in-band is configured under the group-async interface.

Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Time until disconnect 574 secs (Preet)
!--- Call will be disconnected in 574 seconds unless it receives interesting traffic.
Dial String     Successes    Failures    Last DNIS     Last status

El comando show caller timeout también puede mostrar el tiempo para desconectar.

c5800#show caller timeout
                        Session    Idle      Disconnect
   Line        User     Timeout    Timeout     User in
   con 0        -        -          -           - 
   tty 1/3/01  Preet     -          -           - 
   As1/3/01    Preet     -         00:10:00    00:09:19 

Ahora iniciaremos el tráfico interesante. La lista de acceso 101 define el tráfico ICMP y TCP al puerto 80 (tráfico HTTP) como interesante. Haga ping a 10.1.1.3 (dirección IP que el usuario Preet ha negociado) desde el router para restablecer el tiempo de espera inactivo.

c5800#ping 10.1.1.3
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 108/113/124 ms

Verifique que se haya reajustado el descanso:

   c5800#show caller timeout
                      Session Idle    Disconnect
   Line       User    Timeout Timeout User in
   con 0      -        -       -      - 
   tty 1/3/01 Preet    -       -      - 
   As1/3/01   Preet    -     00:10:00 00:09:58
!--- Time to disconnect is close to 10 minutes

Esto prueba que el tráfico interesante está definido correctamente y se aplica correctamente. Alternativamente, usted puede utilizar el comando show dialer de verificar los valores de agotamiento del tiempo:

c5800#show dialer interface async 1/3/01
   As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (600 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 594 secs (Preet)
   Dial String   Successes    Failures   Last DNIS    Last status

Usted puede también utilizar el comando show caller user {username} detailed de verificar los parámetros específicos al usuario:

c5800#show caller user preet detailed 
User:   Preet, line tty 1/3/01, service Async
        Active time 00:01:14, Idle time 00:00:18
Timeouts:          Absolute   Idle      Idle
                              Session   Exec
Limits:            -          -         00:10:00
Disconnect in:     -          -         -    
TTY: Line 1/3/01, running PPP on As1/3/01   
Location: PPP: 10.1.1.3   
DS0: (slot/unit/channel)=1/4/0   
Status: Ready, Active, No Exit Banner, Async Interface Active
        HW PPP Support Active   
Capabilities: No Flush-at-Activation, Hardware Flowcontrol In
              Hardware Flowcontrol Out, Modem Callout, Modem RI is CD                 
              Line usable as async interface, Telnet Faststream   
Modem State: Ready

User: Preet, line As1/3/01, service PPP
      Active time 00:01:11, Idle time 00:00:18   
Timeouts:        Absolute Idle
Limits:          -        00:10:00    
Disconnect in:   -        00:09:41 
!--- Idle timeout of 10 minutes. The call will be disconnected in 9 minutes 41 secs 
unless it receives interesting traffic during that time. If the absolute column has a 
value, then the call will be disconnected at that time regardless of the idle timeout.

PPP: LCP Open, CHAP (<- local), IPCP
LCP: -> peer, ACCM, AuthProto, MagicNumber, PCompression, ACCompression          
     <- peer, ACCM, MagicNumber, PCompression, ACCompression   
NCP: Open IPCP   
IPCP: <- peer, Address
      -> peer, Address   
Dialer: Connected, inbound
        Idle timer 600 secs, idle 20 secs
        Type is IN-BAND ASYNC, group As1/3/01   
IP: Local 10.1.1.251, remote 10.1.1.3   
Counts: 12 packets input, 651 bytes, 0 no buffer 
        0 input errors, 0 CRC, 0 frame, 0 overrun           
        13 packets output, 666 bytes, 0 underruns           
        0 output errors, 0 collisions, 0 interface resets

Solución de problemas de tiempo de espera de inactividad

Síntoma: La llamada se desconecta antes de tiempo o la llamada no se desconecta en absoluto

Si las desconexiones de la llamada inesperado, o de la llamada las desconexiones nunca, marcan el dialer idle timeout y la definición de tráfico interesante. Puede usar el comando debug dialer packet para verificar si un paquete en particular es o no interesante. Por ejemplo:

Apr 26 01:57:24.483: Di1 DDR: ip (s=192.168.1.1, d=224.0.0.5), 
64 bytes, outgoing uninteresting (list 101)
Apr 26 01:57:26.225: Di1 DDR: ip (s=192.168.1.1, d=10.1.1.1), 
100 bytes, outgoing interesting (list 101)

En el ejemplo anterior, los hellos OSPF no son interesantes por access-list 101, mientras que el segundo paquete es interesante por access-list 101. Troubleshooting como sigue:

  1. Modifique el descanso ocioso del marcador en la configuración de la interfaz del marcador. El valor predeterminado es 120 segundos, pero es posible que desee incrementar o disminuir este valor según sus necesidades.

    router(config-if)#dialer idle-timeout 

    Nota: Si la llamada no desconecta, verifique que la opción cero para el dialer idle timeout (introducido en el Cisco IOS Software Release 12.1(3)T) no esté fijada.

  2. Cambie la definición de tráfico interesante (que se configura con el comando dialer-list). Si la llamada se desconecta antes de tiempo, usted querrá definir el tráfico interesante de un modo más amplio (negar el acceso a algunos y permitirlo al resto). Si la llamada nunca desconecta, cambie su definición de tráfico interesante para ser más restrictivo (permita algunos y niegue todo lo demás).

    Consejo: Si su link no está desconectado, asegúrese de definir el tráfico del protocolo de ruteo (u otro tráfico periódico) como poco interesante. Esto evita que los saludos periódicos reinicien el tiempo de espera inactivo. El siguiente es un ejemplo de una definición de tráfico interesante:

    access-list 101 remark Interesting traffic for dialer-list 1   
    access-list 101 deny ospf any any
    !--- Mark OSPF as uninteresting.  This will prevent OSPF hellos from 
    keeping the link up.
    
    
    access-list 101 deny udp any any eq ntp
    
    !--- Define ntp traffic as NOT interesting.  This will prevent periodic ntp 
    traffic from keeping the link up indefinitely.
    
    
    access-list 101 permit ip any any
    !--- All other IP traffic is interesting. Change this depending on your 
    traffic needs.
    
    dialer-list 1 protocol ip list 101
    !--- This interesting traffic is applied to the dialer interface using 
    dialer-group 1.
    
    

    Para más información, refiera al documento Tecnología de marcación manual: Descripciones y explicaciones.

Síntoma: La llamada se desconecta cada pocos segundos

Otro problema es que la llamada se desconecta cada "x" segundos (en la mayoría de los casos, 120 segundos). En ciertas situaciones, aun si el tráfico transfiere el link, DDR no reinicia el tiempo de espera agotado inactivo. Probablemente esto se deba a:

  • el tráfico interesante que no es definido

  • la definición de tráfico interesante no se aplica a la interfaz

  • el dialer capaz no hecho de la interfaz

Para resolver esto:

  1. Verifique que la lista de marcador esté definida y que el grupo de marcador (que señala a la lista de marcador) esté configurado en la interfaz. Configure una definición simple del tráfico interesante:

    router(config)#interface dialer 1
    router(config-if)#dialer-group 1
    router(config-if)#exit
    router(config)#dialer-list 1 protocol ip permit
    

    Una vez solucionado el problema de desconexión frecuente, puede ajustar la definición del tráfico interesante para que se adapte a sus necesidades.

  2. Asegúrese de que configuren al dialer dentro de la banda en el grupo async y las interfaces del dialer. Este comando no se necesita en las interfaces habilitadas para dialer como la interfaz BRI x y la interfaz x:23 serial (para los PRI).

  3. Ajuste el dialer idle timeout al valor deseado.

    router(config-if)#dialer idle-timeout 900
    

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 23423