Switching de LAN : EtherChannel

Configuración de FEC y Conexión troncal ISL/802.1q entre un switch CatOS y un router externo.

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Noviembre 2015) | Comentarios


Contenido


Introducción

Este documento aporta configuraciones de muestra para Fast EtherChannel (FEC), Inter-Switch Link (ISL) y trunking de 802.1Q entre un switch Catalyst 6500 que ejecute CatalystOS (CatOS) y un Cisco 7500 Router. Los resultados de cada comando se muestran a medida que se ejecutan. Aunque se utilice un switch Catalyst 6000 en esta configuración, se puede sustituir por un switch de la familia Catalyst 4000 o Catalyst 5000 que ejecuten CatOS.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Catalyst 6000 Series Switches

    • La versión de CatOS 5.1(1) se requiere CSX o más adelante para soportar el EtherChannel

  • Routers series Cisco 7000 ó 7500

    • Cisco 7000 Series Router con el Route Switch Processor de las 7000 Series (RSP7000) o el Chassis Interface (RSP7000CI), o Cisco 7500 Series Router con los adaptadores de puerto de los Procesadores de interfaz Fast Ethernet (FEIP) o del procesador de interfaz versátil (VIP2)

    • Si usted está utilizando el adaptador de puerto PA-2FEISL, usted debe tener la revisión de hardware 1.2 o más adelante.

      Consulte Notificación: *Expired* FN - 8791_11301999 - recomendación para reemplazo del 2-Port Fast Ethernet ISL PA-2FEISL para más información.

    • Presentaron al comando encapsulation dot1Q native en el Software Release 12.1(3) T. de Cisco IOS�. Este comando cambia la configuración.

      Vea la configuración del 802.1Q del Cisco 7500 para las versiones de Cisco IOS Software anterior que la sección 12.1(3)T de este documento para más información.

    • Cisco Express Forwarding está habilitado de manera predeterminada en los routers Cisco de la serie 7500. Sin embargo, el soporte del Cisco Express Forwarding para el Routing IP entre los VLA N del IEEE 802.1Q no estaba disponible hasta el Cisco IOS Software Release 12.2 y 12.2T. Es todavía posible configurar la encapsulación del 802.1Q en las versiones anteriores, pero usted debe primero publicar el comando global no ip cef de inhabilitar el Cisco Express Forwarding.

    • Cuando configuran a un 7500 Series Router para el Multiprotocol Label Switching (MPLS) y el FEC, el soporte es actualmente inasequible para rutear (del � MPLS) los paquetes IP que fluyen de la interfaz MPLS a la interfaz FEC. Por lo tanto, no se recomienda que un MPLS y una configuración FEC coexisten en un único router.

    • El Cisco IOS Software Release 11.1(14)CA o Posterior se requiere para soportar el EtherChannel.

      El Cisco IOS Software Release 11.3(1)T (ninguno más el conjunto de características) o se requiere más adelante para soportar la conexión troncal de ISL.

      El Cisco IOS Software Release 12.0(1)T (ninguno más el conjunto de características) o se requiere más adelante para soportar el enlace del IEEE 802.1Q.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Catalyst 6500 que funciona con la versión CatOS 5.5.14

  • Cisco 7500 que funciona con el Cisco IOS Software Release 12.2.7b

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Notas importantes

  • Tenga presente que los Catalyst 4000 Series Switch no soportan la conexión troncal de ISL. Además, algunos módulos de switching en los switches Catalyst 5000 no son aptos para EtherChannel. Publique el comando show port capabilities module de determinar si un módulo particular es EtherChannel capaz y qué encapsulado de conexión de troncal soporta.

  • Hay ciertas guías de consulta para la configuración del EtherChannel y del enlace. Refiera siempre a la documentación sobre el software de su Switch.

    Por ejemplo, si usa la versión 5.5.x del software en un Catalyst 5000, debe consultar la Guía de configuración del software (5.5) y observar cuidadosamente toda pauta y restricción en la sección Configuración de Fast EtherChannel y Gigabit EtherChannel.

EtherChannel

La característica FEC o del Gigabit EtherChannel (GEC) permite que los links Point-to-Point múltiples sean liados en un link lógico. El Catalyst 6000 soporta un máximo de ocho puertos en el modo dúplex completo, que ofrece el 1600 Mbps o la producción del 1.6 Gbps para el FEC y el 16 Gbps para el GEC. Las Cisco 7500 Series soportan un máximo de cuatro puertos por el FEC, para el 800 Mbps. La capacidad y desempeño de EtherChannel es diferente según el switch o router. Consulte los requisitos del sistema para implementar EtherChannel en switches Catalyst para obtener más información.

El EtherChannel distribuye el tráfico a través de todos los links y proporciona la Redundancia si uno o más links fallan. Refiera comprensión del equilibrio y de la Redundancia a la carga EtherChannel en los switches de Catalyst para más información y configuraciones de muestra relacionadas con el EtherChannel.

Refiera a la página del EtherChannel del Soporte técnico y de la documentación de Cisco para más información.

Trunking

El enlace es una manera de llevar el tráfico de los VLAN múltiples sobre un enlace punto a punto o un agrupamiento de EtherChannel entre dos dispositivos. Éstas son dos maneras de las cuales los troncales Ethernet pueden ser implementados:

  • ISL (Encapsulación de troncales de propiedad de Cisco)

  • 802.1q (encapsulado de troncales de norma IEEE)

Refiera a la página de los protocolos VLAN trunking del Soporte técnico y de la documentación de Cisco para más información.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Estas configuraciones de muestra le muestran cómo hacer estas cosas:

  • Configure dos puertos de acceso para el workstation1 en el VLAN1 y para el workstation2 en el VLAN2 en el Catalyst 6500.

  • Configure el default gateway para que el workstation1 sea 10.10.10.1 /24 y para que el workstation2 sea 10.10.11.1/24 en el Cisco 7500.

  • Configure el ISL y los trunks del 802.1Q sobre un FEC cuadripolo entre un Catalyst 6500 Switch y el Cisco 7500 Router.

  • Configure dos subinterfaces del canal del puerto con los IP Addresses para el InterVLAN Routing.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

VLAN1 del enlace y VLAN2 sobre 2-Port FEC

141.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Catalyst 6500 Switch

!--- Set the IP address and default gateway for VLAN 1 for management purposes.

Catalyst6500> (enable) set interface sc0 10.10.10.2 255.255.255.0

Interface sc0 IP address and netmask set.

Catalyst6500> (enable) set ip route default 10.10.10.1

Route added.

!--- Set the VTP mode. In this example, the mode is set to be transparent. Depending on your
!--- network, set the VTP mode accordingly.
!--- For details on VTP, refer to Understanding and Configuring VLAN Trunk Protocol (VTP).

Catalyst6500> (enable) set vtp mode transparent

VTP domain modified

!--- Add VLAN 2. VLAN 1 already exists by default.

Catalyst6500> (enable) set vlan 2

VLAN 2 configuration successful

!--- Add port 3/4 to VLAN 2. Port 3/3 is already in VLAN 1 by default.

Catalyst6500> (enable) set vlan 2 3/4

VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     3/4

!--- Set the port speed to 100 and duplex to full. One of the requirements for EtherChannel
!--- to work is for speed and duplex to be the same on both sides. To guarantee this, hard
!--- code both speed and duplex on ports 3/1 and 3/2.

Catalyst6500> (enable) set port speed 3/1-2 100

Ports 3/1-2 transmission speed set to 100Mbps.

Catalyst6500> (enable) set port duplex 3/1-2 full

Ports 3/1-2 set to full-duplex.

!--- Enable FEC on ports 3/1 and 3/2. Because routers do not understand Port Aggregation
!--- Protocol (PAgP), set the channel mode to one which causes ports to channel but which
!--- does not generate PAgP frames.

Catalyst6500> (enable) set port channel 3/1-2 on

Port(s) 3/1-2 are assigned to admin group 105.
Port(s) 3/1-2 channel mode set to on.

!--- Enable trunking on ports 3/1 and 3/2. Because routers do not understand Dynamic
!--- Trunking Protocol (DTP), set the trunking mode to nonegotiate, which causes ports to
!--- trunk but which does not generate DTP frames.
!--- Note: Because EtherChannel is configured first, any trunk settings that are applied
!--- now to one port automatically apply to all other ports in the channel.
!--- Enter the trunking encapsulation as either ISL…

Catalyst6500> (enable) set trunk 3/1 nonegotiate isl

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to isl.

!--- …or as dot1q.
!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

Catalyst6500> (enable) set trunk 3/1 nonegotiate dot1q

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to dot1q.

Catalyst6500> (enable) show config

This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
.........
..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu May 2 2002, 01:26:26
!
#version 5.5(14)
!
!
#system
set system name  Catalyst6500
!
#!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 name VLAN0002 type ethernet mtu 1500 said 100002 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active
mode srb aremaxhop 7 stemaxhop 7
backupcrf off
!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

set ip route 0.0.0.0/0.0.0.0 10.10.10.1
!
#set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat6000-sup.5-5-14.bin
!
#port channel
set port channel 3/1-2 105
!
# default port status is enable
!
!
#module 1 empty
!
#module 2 : 2-port 1000BaseX Supervisor
!
#module 3 : 48-port 10/100BaseTX Ethernet
set vlan 2    3/4
set port disable    3/5

set port speed      3/1-2  100
set port duplex     3/1-2  full
set trunk 3/1  nonegotiate isl 1-1005
set trunk 3/2  nonegotiate isl 1-1005

!--- If IEEE 802.1Q is configured, you will see this output instead:
set trunk 3/1  nonegotiate dot1q 1-1005
set trunk 3/2  nonegotiate dot1q 1-1005


set port channel 3/1-2 mode on
!
#module 4 : 24-port 100BaseFX MM Ethernet
!
#module 5 empty
!
#module 6 empty
!
#module 15 empty
!
#module 16 empty
end

Router Cisco 7500

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- If you are using ISL trunking, configure two port-channel sub-interfaces and issue the
!--- encapsulation isl <VLAN> command to enable ISL trunking.
!--- Configure IP addresses for InterVLAN routing.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation isl 1

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation isl 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- If you are using 802.1Q trunking, issue the encapsulation dot1Q <vlan> native
!--- command to configure two port-channel sub-interfaces and enable 802.1Q trunking.
!--- Configure the IP addresses for InterVLAN routing.

!--- Note: The encapsulation dot1Q 1 native command was added in Cisco IOS Software
!--- Release 12.1(3)T. If you are using an earlier version of Cisco IOS, see the
!--- Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T
!--- section of this document, to configure 802.1Q trunking on the router.




!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation dot1Q 1 native

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command, to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: To make this setup work and to successfully ping between Workstation 1 and
!--- Workstation 2, you must ensure that the default gateways on the workstations are setup
!--- properly. For Workstation 1, the default gateway should be 10.10.10.1; and for 
!--- Workstation 2, the default gateway should be 10.10.11.1.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname 7500
!
boot system disk1:rsp-jsv-mz.122-7b.bin
!
ip subnet-zero
!
ip cef
call rsvp-sync
!
!
!
interface Port-channel1
 no ip address
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0

!--- If 802.1Q trunking is configured, you will see this output instead:
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0


!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Configuración del 802.1Q del Cisco 7500 para las versiones de Cisco IOS Software anterior que 12.1(3)T
En las versiones anteriores al 12.1(3)T del IOS de Cisco, el comando encapsulation dot1Q 1 native no estaba disponible bajo la subinterfaz. Sin embargo, aún es necesario hacer coincidir la red VLAN original a través del link, como se describió anteriormente. Para configurar el enlace del 802.1Q en las versiones de software anterior que 12.1(3)T, configure la dirección IP para el VLAN1 en la interfaz del canal de puerto principal 1, no una subinterfaz del canal del puerto.
 

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- Do not configure an interface port-channel 1.1
!--- Instead, create a port-channel 1 main interface and configure the IP address
!--- for VLAN 1 here.

7500(config)# interface port-channel 1

7500(config-if)# full-duplex

7500(config-if)# ip address 10.10.10.1 255.255.255.0

7500(config-if)# exit

7500(config)#

!--- It is still necessary to create a subinterface for VLAN 2.

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: Remember also that—in any version of software previous to 12.2 or 12.2T for the
!--- 7000/7500 series—you will have to issue the no ip cef command globally before you
!--- configure 802.1Q trunking on a subinterface. Otherwise, you will see this error
!--- message: 802.1q encapsulation not supported with CEF configured on the interface.
!--- See the Components Used section of this document for more information.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 7500
!
!
ip subnet-zero
!
no ip cef
!
!
!
interface Port-channel1
ip address 10.10.10.1 255.255.255.0
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

7500#

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Comandos show de Catalyst 6500

  • interfaz de la demostración — Muestra la dirección IP y el VLA N de la interfaz de administración del sc0. En este ejemplo, se utiliza el VLAN predeterminado (el VLA N 1).

    Catalyst6500> (enable) show interface
    
    sl0: flags=51<UP,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            VLAN 1 inet 10.10.10.2 netmask 255.255.255.0 broadcast 10.10.10.255
    Catalyst6500> (enable)
  • show ip route – muestra la gateway predeterminada. En este ejemplo, 10.10.10.1 es la dirección IP del canal del puerto 1 (para el enlace del 802.1Q) o del canal del puerto 1.1 (para la conexión troncal de ISL).

    Catalyst6500> (enable) show ip route
    
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled
    
    The primary gateway: 10.10.10.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.10.10.1       0x0          UG      0           sc0
    10.10.10.0       10.10.10.2       0xffffff00   U       8           sc0
    default          default          0xff000000   UH      0           sl0
    Catalyst6500> (enable)
  • show port capabilities mod/port — Da un panorama general en las capacidades del hardware de módulos de la transferencia. En este ejemplo, usted puede ver que el puerto 3/1 (y 3/2) es el EtherChannel capaz, que los encapsulados de conexión de troncal él soportan, y la otra información.

    Catalyst6500> (enable) show port capabilities 3/1
    
    Model                    WS-X6248-RJ-45
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  yes
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(1q4t),tx-(2q2t)
    CoS rewrite              yes
    ToS rewrite              DSCP
    UDLD                     yes
    Inline power             no
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
    COPS port group          not supported
    Catalyst6500> (enable)
  • /port Mod del show port counters — Da un panorama general en los errores de puerto posibles. En este ejemplo, este puerto está libre de errores. Si usted experimenta los errores en el puerto, refiera al puerto del switch del troubleshooting e interconecte los problemas para más información.

    Catalyst6500> (enable) show port counters 3/1
    
    Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
    ----- ---------- ---------- ---------- ---------- ---------
     3/1           0          0          0          0         0
    
    Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
    ----- ---------- ---------- ---------- ---------- --------- --------- ---------
     3/1           0          0          0          0         0         0         -
    
    Last-Time-Cleared
    --------------------------
    Thu May 2 2002, 02:11:55
    Catalyst6500> (enable)
  • muestre la Mod del puerto — Muestra el estado del puerto, el VLA N, el trunk, y la información de la velocidad y dúplex. En este ejemplo, el puerto de acceso para el workstation1 es 3/3, que está en el VLAN1. El puerto de acceso para el workstation2 es 3/4, que es VLA N 2. puertos 3/1 y 3/2 es el enlace y puertos FEC.

    Catalyst6500> (enable) show port 3
    
    Port  Name                 Status     VLAN       Duplex Speed Type
    ----- -------------------- ---------- ---------- ------ ----- ------------
     3/1                       connected  trunk        full   100 10/100BaseTX
     3/2                       connected  trunk        full   100 10/100BaseTX
     3/3                       connected  1          a-half  a-10 10/100BaseTX
     3/4                       connected  2          a-full a-100 10/100BaseTX
    
    !--- Output suppressed.
    
    
  • demostración vlan — Muestra qué puertos se asignan a los VLA N específicos. Note que los puertos troncales en este ejemplo (3/1 y 3/2) no aparecen en esta salida, que es normal.

    Catalyst6500> (enable) show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    119     2/1-2
                                                            3/3,3/5-48
                                                            4/1-24
    2    VLAN0002                         active    124     3/4
    
    !--- Output suppressed.
    
    
  • trunk de la demostración — Muestra al modo de concentración links, tipo de encapsulación, no prohibido los VLA N, y los VLAN activos. En este ejemplo, VLAN 1 (siempre habilitada y activa en forma predeterminada) y VLAN 2 son las VLAN actuales activas para el tronco. Note que ambos puertos troncales están en el VLAN1.

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  isl            trunking      1
     3/2      nonegotiate  isl            trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2

    Para el enlace del 802.1Q, la salida del comando anterior cambia a esto:

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native VLAN
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  dot1q          trunking      1
     3/2      nonegotiate  dot1q          trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    Catalyst6500> (enable)
  • show port channel – Muestra el estado del Etherchannel. En este ejemplo, hay 2-port FEC (puertos 3/1 y 3/2) en que está, para evitar que las tramas de PAgP sean transmitidas. Usted puede también ver la interfaz de canal de puerto remota del 7500 Router.

    Catalyst6500> (enable)  show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1  connected  on                     105   833
     3/2  connected  on                     105   833
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
    3/1  7500                            Port-channel1.1           cisco RSP4
    3/2  
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

    Para un FEC con el enlace del 802.1Q, la salida del comando anterior cambia a esto:

    Catalyst6500> (enable) show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1   connected  on                    257   769
     3/2   connected  on                    257   769
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
     3/1       7500                            FastEthernet5/1/0         cisco RSP4
     3/2       7500                            FastEthernet5/1/1         cisco RSP4
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

Si usted tiene la salida de un comando show-tech support de su dispositivo de Cisco, usted puede utilizar la herramienta del Output Interpreter (clientes registrados solamente) para visualizar los problemas potenciales y los arreglos.

Comandos show del router 7500 de Cisco

  • muestre el número de canal del canal del puerto de la interfaz — Da el estado del miembro para las interfaces físicas. En este ejemplo, un 2-port FEC se configura entre los puertos 3/1 y 3/2 en el Catalyst 6000 y entre el FastEthernet 5/1/0 y 5/1/1 de la interfaz en los 7500. Demostraciones del canal del puerto 1 como up/up.

    Hace una dirección IP configurar, que en este caso significa que es la dirección IP del VLAN nativo para el enlace del 802.1Q. Vea la configuración del 802.1Q del Cisco 7500 para las versiones de Cisco IOS Software anterior que la sección 12.1(3)T de este documento para más información. La salida también se muestra para la subinterfaz del 802.1Q VLAN2, del comando show interface port channel 1.2.

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:14, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         6720 packets input, 923310 bytes, 0 no buffer
         Received 5010 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         1902 packets output, 573088 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1q Virtual LAN, Vlan ID  2.
      ARP type: ARPA, ARP Timeout 04:00:00

    Ésta es la salida para la conexión troncal de ISL y el FEC:

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2 
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:01, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         113 packets input, 7278 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
      13 packets output, 2264 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    
    7500# show interface port-channel 1.1
    
    Port-channel1.1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
  • muestre el /port slot/puerto-ADAPTER del FastEthernet de las interfaces — muestra el estatus de las interfaces físicas del router y si algunos errores existen en las interfaces. En este ejemplo, es sin error.

    7500# show interface fastethernet 5/1/0
    
    FastEthernet5/1/0 is up, line protocol is up
      Hardware is cyBus FastEthernet Interface, address is 0001.6490.f8a8
      (bia 0001.6490.f8a8)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 1d00h, output 00:00:07, output hang never
      Last clearing of "show interface" counters 1d00h
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         2929 packets input, 425318 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         12006 packets output, 1539768 bytes, 0 underruns
         0 output errors, 0 collisions, 6 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 23307