Voz y Comunicaciones unificadas : Gateways universales Cisco de la serie AS5300

Usando Dialout/EZ con un Cisco Access Server

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Con el producto DialOut/EZ de software táctico, los usuarios con una LAN de escritorio podrán compartir los puertos del servidor de acceso a la red (NAS) como un conjunto de comunicaciones asíncronas de salida. Los usuarios de DialOut/EZ necesitan no más los módems dedicados y las líneas telefónicas en sus escritorios, sino que por el contrario utilizan el software del redireccionador de puerto de la comunicación (COM:) para permitir que los puertos de marcado en el Access Servers aparezcan como módems locales a las Aplicaciones de comunicaciones de escritorio. Los usuarios de Windows pueden marcar a través de un servidor central NAS/access para acceder los servicios en línea remotos e incluso para enviar los faxes de sus PC. La versión de software del ½ del ¿Â de Cisco IOSï que se ejecuta en el NAS debe soportar el Control Protocol del puerto COM (RFC 2217). Usted puede descubrir más información sobre el DialOut/EZ del Software táctico del sitio web de la compañía en: http://www.tacticalsoftware.comleavingcisco.com .

Nota: DialOut/EZ es un reemplazo para el utilitario de discado de salida Cisco.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • El Software táctico requiere que el Cisco IOS Software Release 12.0(9) o Posterior esté instalado en el NAS para interoperar con DialOut/EZ.

  • Debido al Id. de bug Cisco CSCds28071, Cisco recomienda que usted funciona con el Cisco IOS Software Release 12.1(8) o Posterior.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Instalación y configuración

Instalación de los controladores de módem apropiados del puerto COM virtual para Dialout/EZ

  1. Instale DialOut/EZ.

    Para la información de la instalación completa DialOut/EZ en una estación de trabajo del cliente, refiera al guía del usuario en el sitio web del Software táctico: DialOut/EZ.

  2. Descargue los driveres del módem.

    Los puertos COM virtuales DialOut/EZ no tienen ninguna dispositivos de módem asociada a él. El usuario DialOut/EZ debe utilizar un archivo apropiado del .inf para los módems (instale un driver del módem en los puertos COM virtuales). Los archivos del .inf MICA, del NextPort y del Microcom están disponibles para la descarga del sitio Web de Cisco. Para las otras Plataformas utilice los archivos especificados del .inf.

    ‘Tipo de módem’ Plataforma archivo del .inf
    MICA 3600, AS5200,AS5300,AS5800 mdcsmica.inf
    Nextport AS5350,AS5400 AS5800, AS5850
    Microcom AS5200 mnpv90.inf
    NM-xAM 2600, 3600 El Microcom DeskPorte V.34 AYUNA
    WIC-xAM 2600, 3600 mdmrock5.inf (o el estándar 28800 BPS de archivo del módem)

    Nota: Para Windows XP, Cisco proporcionó a los archivos del .inf puede no trabajar. El intento usando un .inf incorporado de Windows clasifía en lugar de otro.

  3. Instale los driveres del módem.

    Para instalar un driver del módem en el PC de Windows, utilice el siguiente procedimiento:

    1. Start (Inicio) > Settings (Configuración) > Control Panel (Panel de control) > Phone and Modem Options (Opciones de teléfono y módem).

    2. Seleccione el módem y agregue para agregar un nuevo módem.

    3. Select no detecta mi módem; La seleccionaré de una lista, después hago clic después.

    4. Seleccione el fabricante y el modelo de su módem. La selección de Cisco en la ventana izquierda visualiza la mica en la ventana de la derecha.

    5. Select tiene disco y hojea a la ubicación en donde se guarda el archivo del .inf.

    6. En la opción de los puertos seleccionados, utilice el puerto COM seleccionado durante la instalación del marcado de salida EZ (por ejemplo, COM 5).

Configuración del servidor de acceso

La configuración de software IOS necesaria para las aplicaciones de discado de salida del módem del modo de carácter solamente (por ejemplo con DialOut/EZ) va bajo configuración de línea:

line starting_line_number ending_line_number
     modem dtr-active  
     
! -- If the router is for dialin and dialout use "modem inout" instead

     transport input telnet
     
! -- Or transport input all could be used

     escape-character NONE 
     
! -- Due to Bug CSCdv12194 for the AS5350/AS5400.

     rotary 1 
     
! -- Specifies the use of TCP port 7001 in the Dialout/EZ manager 
     ! -- window to dial out rotary 1

Si se utilizan los Módems externos, después agregue la Capa física RS232 y los parámetros de entramado bajo configuración de línea según lo deseado:

speed 115200 
    
 ! --  Set to the highest speed supported by the modems

     flowcontrol hardware
     parity even 
     databits 7 
     
! -- Or databits 8

     stopbits 1 
     
! -- Recommended for best throughput

Si usted quiere controlar el acceso a las líneas del dialout, agregue el siguiente en el modo de configuración de línea:

password password

Alternativamente, el Authentication, Authorization, and Accounting (AAA) de la configuración y aplica la lista a la línea con:

login authentication listname

Si usted desea controlar qué trunks se utilizan para las llamadas del dialout, utilice el comando modem dialout controller presentado en el Cisco IOS Software Release 12.1(T) (a partir de ahora, soportado en el AS5300 solamente). Para más información, refiera a configurar a interfaz T1 o E1 para las llamadas análogas salientes usando el comando modem dialout controller.

Consejo: DialOut/EZ puede conseguir a veces confuso por el mensaje de la AUTORIZACIÓN de la contraseña del software IOS. Para evitar este problema, configuración AAA (local o basado en el servidor) en el router. Refiera al AS5xxx con la sección AAA de este documento para una configuración de muestra.

Opcional: Usted puede también configurar un modemcap para reajustar el módem a la configuración predeterminada después de cada llamada. Utilice el comando modem autoconfigure type mica bajo configuración de línea. Este modemcap (que fija el &F) del valor predeterminado de fábrica se puede aplicar a todo el Routers sin importar el tipo de módem (MICA, NextPort, Microcom, etc.). Para más información sobre el modemcaps, refiera a los Modemcap recomendados para los Módems analógicos y digitales internos en los Cisco Access Servers.

El mismo servidor de acceso se puede utilizar para el dialin así como el dialout (aplicación). Para las configuraciones de muestra completas refiera a las Configuraciones de NAS de la muestra de la sección para utilidad de marcación de salida/EZ.

Resolución de problemas de Marcado de salida/EZ

Siga el método delineado abajo para resolver problemas los asuntos relacionados DialOut/EZ:

  1. Invierta Telnet al módem NAS del prompt exec NAS. Asegure el usted puede conectarse al módem publicando EN el comando que debe volver una respuesta ACEPTABLE. Si el usted puede conectarse al módem, intenta marcar el número del dispositivo remoto usando el comando del ######## del atdt. Si la conexión es acertada, después la configuración del router está correcta y el hardware está funcionando correctamente.

    Nota: Utilice el rango del puerto TCP de la telnet binario: rotary_number 6000+line para utilizar una línea específica, o 7000+ para un dialout rotatorio.

    El ejemplo abajo muestra una llamada satisfactoria:

    maui-nas-03#telnet 172.22.53.150 7001
    
    ! -- Reverse Telnet to an up/up interface on the router 
    ! -- and use port 7000+rotary
    
    Trying 172.22.53.150, 7001 ... Open
    User Access Verification
    !
    Username: admin
    Password:
    at
    OK
    
    ! -- Modem is responding
    
    atdt 81560
    
    ! -- Dial number 81560 to connect to remote device. 
    ! -- This may take up to 30 seconds.
    
    CONNECT 33600 /V.42/V.42bis
    
    ! -- Call is connected to the remote device.
    
      User Access Verification
    
    ! -- Username prompt by remote device
    
      Username: cisco
      Password: maui-nas-01>

    Si Telnet reverso no alcanza el modo de comando modem at, después se configura mal el NAS. Verifique lo siguiente:

    1. La interfaz cuya dirección IP que usted es Telnetting al debe ser up/up y pingable del host PC en el LAN. Si usted no puede hacer ping el Troubleshooting de la interfaz del router su LAN por problemas relacionados con el routing.

    2. La línea del módem debe tener el módem entrada/salida del módeminout (para el dialin/dialout) o módem DTR-activo (para el dialout solamente).

    3. La línea se debe configurar con telnet o la entrada de transporte todo de la entrada de transporte.

    Si Telnet reverso tiene éxito en alcanzar el modo de comando modem at, pero la llamada manual falla, después el problema podría ser un problema de la compañía telefónica o del router remoto. Resuelva problemas al router remoto, la línea y reexamine la conexión antes de progresar. Refiera a la Conectividad de la tecnología de marcación del troubleshooting - Llamada saliente no DDR para más información.

  2. Intente Telnet reverso de un host PC en el LAN. Ventanas abiertas hyper terminal (o Telnet de Windows) y Telnet a la dirección IP y al puerto del router que usted está utilizando para DialOut/EZ (por ejemplo 7001). Si usted puede alcanzar el módem y el dialout, después no hay nada mal con el LAN (habíamos verificado previamente que el dialout del NAS está trabajando).

  3. Si Telnet reverso no alcanza el modo de comando modem at, después se configura mal el NAS o la red del IP no está funcionando. Verifique lo siguiente:

    1. La interfaz cuya dirección IP que usted es Telnetting al debe ser up/up y pingable del host PC en el LAN. Si usted no puede hacer ping el Troubleshooting de la interfaz del router su LAN por problemas relacionados con el routing.

    2. No debe haber acceso-clase que está bloqueando la conexión Telnet.

    Las capturas de pantalla siguientes muestran a una sesión HyperTerminal acertada:

    hyperterm1.gif

    hyperterm2.gif

    Nota: Si usted está utilizando al cliente Telnet de Microsoft Windows y el AAA se configura en el NAS, el login de la Telnet de Windows puede fallar. Este incidente es causado por las configuraciones de aplicaciones y caracterizado por una incapacidad para ingresar la contraseña, así el login falla. Para corregir la configuración de la aplicación Telnet para esta sesión, siga el procedimiento abajo en el host PC:

    1. Start (Inicio) > Run (Ejecutar) > telnet del tipo, AUTORIZACIÓN del tecleo.

    2. Teclee el comando unset crlf. (Esto se asegura de que usted envíe los retornos de carro como Telnet <CR><NUL> bastante que el <CR><LF>.)

    3. Utilice <ip_address> el <port> abierto a Telnet al módem.

    4. Usted debe ahora ser conectado con los módems y puede ahora iniciar el marcado manual usando el atdt igual que con las demostraciones del ejemplo del hyperterminal arriba. La captura de pantalla siguiente es un ejemplo:

      wintelnet1.gif

  4. El hyperterminal del uso a conectar directamente con los módems NAS vía DialOut/EZ emuló al puerto COM. Refiera al capítulo del Guía del Usuario sobre discado saliente/EZ en la instalación en http://www.tacticalsoftware.comleavingcisco.com para más información. Esto verificará que esté funcionando el puerto COM emulado DialOut/EZ.

    Si el hyperterminal sobre el puerto COM emulado DialOut/EZ no trabaja, después el problema parecería ser peculiar a la comunicación DialOut/EZ con el IOS. Recopile la siguiente información:

    • Estos debugs determinan si el NAS está recibiendo la conexión Telnet.

      debug telnet 
      debug modem
      
    • El registro de la traza DialOut/EZ: La selección de la opción del Menú de ventana de la traza abre la ventana del 3.0 del monitor de puerto DialOut/EZ, con la lengueta de la ventana de la traza habilitada. Para comenzar a localizar, marque el cuadro de la traza del permiso en la parte inferior de esta ventana. Aseegurese le salvan el registro para el análisis adicional. Refiera a la sección de Troubleshooting del guía del usuario en el sitio web del Software táctico para más información.

  5. Puesto que hemos verificado que DialOut/EZ puede conectar con los módems, tenga después el iniciado de la aplicación final una conexión. Si las aplicaciones finales no pueden hablar el uno al otro usando la conexión DialOut/EZ, después el problema podría ser al final aplicación peculiar. El registro de la traza DialOut/EZ puede ser útil en resolver problemas este problema. También gire el registro del módem de Windows TAPI, y también cualquier registración disponible desde de la aplicación. Refiera al sitio web de Microsoftleavingcisco.com para el artículo de Microsoft siguiente: Cómo crear y utilizar el archivo de Modemlog.txt (Q142730) para más información.

    Si la operación todavía no trabaja según lo deseado, recopile los debugs IOS, el registro de la traza DialOut/EZ, y (si procede) el registro del módem de Windows, y analice los resultados para determinar donde la aplicación está fallando.

    Refiera al Software táctico: Preguntas frecuentesleavingcisco.com para la información adicional.

Configuraciones NAS de muestra para la Utilidad de marcado de salida/EZ

AS25xx, NM-xAM, WIC-xAM

Lo que sigue es un ejemplo de archivo de configuración para el Routers con los módems analógicos externos, tales como Cisco AS2509, Cisco AS2510, Cisco AS2511, o servidor de acceso así como Routers de Cisco AS2512 con los módems analógicos internos (NM-xAM y el WIC-xAM) por ejemplo el 26xx, y los 36xx Series Router.

El ejemplo abajo muestra al router capaz de las llamadas entrante y saliente. Si el router está para el uso saliente solamente, después la configuración de línea es toda la que es necesaria.

interface Group-Async1
   
! -- Group-Async interface used for dialin calls
   ! -- This is not used for dialout

    ip unnumbered Ethernet0
    no ip mroute-cache
    encapsulation ppp
    no ip route-cache
    async default routing
    async dynamic address
    async mode interactive
    peer default ip address pool local
    dialer in-band
    no cdp enable
    ppp authentication chap
    group-range 1 8
    
! -- Range of lines include 1 through 8
    ! -- Modems 1 through 8 can now be used for incoming or outgoing calls

   !
   line 1 8
    
! -- Line configuration used for Dialout/EZ

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only use "modem dtr-active"

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

    rxspeed 115200
    txspeed 115200
    
! -- Speed for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM)
 
    flowcontrol hardware
    
! -- Flowcontrol for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM

AS5xxx sin AAA

Lo que sigue es un ejemplo de archivo de configuración para un servidor de acceso de las AS5xxx Series de Cisco sin el AAA.

Este ejemplo muestra al router que valida las llamadas entrantes y que hace las llamadas de salida:

controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 6661210
    dialer-group 1
    isdn incoming-voice modem
    
! -- Incoming analog calls will be switched to the modems

    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap
    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   line 1 48
   
! -- Line configuration for Dialout/EZ

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout if the line is used for
    ! -- dialout only use, modem dtr-active transport preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport input all
    transport input telnet
    
! -- Configure one or both of the above commands

AS5xxx con AAA

Lo que sigue es un ejemplo de archivo de configuración para el Access Servers de las AS5xxx Series de Cisco con el subsistema AAA basado en servidor configurado.

El siguiente ejemplo, muestra un servidor de acceso configurado para el dialin y las llamadas del dialout:

aaa new-model
   aaa authentication login default radius
   
! -- Use the radius server for login on the default list
   ! -- for local AAA replace "radius" with "local" 
   ! -- (make sure to configure the username/password locally as well

   aaa authentication ppp ppptac radius
   
! -- Use the radius server for ppp on the list named ppptac
   ! -- This is used for incoming ppp calls and is not used for outgoing 
   ! -- Dialout/EZ calls
   !

   controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 name test 5551210
    dialer-group 1
    isdn incoming-voice modem
    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap ppptac
    ppp multilink
   !
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap ppptac
    
! -- Use list named ppptac for authentication

    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   !
   radius-server host 10.4.1.10
   radius-server timeout 20
   radius-server key nas1
   
! -- Radius server configuration

   !
   line 1 48
    
! -- Line configuration for Dialout/EZ as well as dialin calls

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only, use modem dtr-active transport 
    ! -- preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead


Información Relacionada


Document ID: 23241