IP : Resolución y asignación dinámica de direcciones

Configuración dinámica de las opciones del servidor DHCP

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (29 Abril 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

DHCP le permite asignar automáticamente direcciones IP reutilizables a clientes DHCP. Este documento proporciona un ejemplo de cómo configurar las opciones DHCP como direcciones del Sistema de nombres de dominio (DNS) y Windows Internet Name Service (WINS), para responder a las solicitudes DHCP de los clientes locales detrás del Equipo en las instalaciones del cliente (CPE).

Previamente, los administradores de la red tuvieron que configurar manualmente el servidor DHCP de Cisco IOS� en cada dispositivo habilitado con esta característica. Luego de implementado un router, ir a cada ubicación y realizar modificaciones es una tarea trabajosa, costosa y que requiere tiempo.

Por lo tanto, el Cisco IOS DHCP Server fue aumentado para permitir que la información de la configuración sea puesta al día automáticamente. Los administradores de red pueden configurar uno o más servidores DHCP centralizados para actualizar opciones DHCP específicas dentro de los agrupamientos DHCP. Los servidores remotos pueden pedir o importar estos parámetros de opciones de los servidores centralizados.

prerrequisitos

Requisitos

Cisco recomienda los Quien lea este documento tiene conocimiento de estos temas:

  • DHCP

  • Domain Name System (DNS)

  • Windows Internet Name Service (TRIUNFOS)

Componentes Utilizados

Esta configuración fue desarrollada y probada con estas versiones de software y hardware:

  • Software Release 12.2(27) de Cisco IOS�

  • Dos Cisco 3660 Router con el NM-1E usado para el PC y la conexión cliente

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Nota: La característica del Cisco IOS DHCP Server se introduce en el Cisco IOS Software Release 12.0(1)T. Usted necesita el Software Release 12.0(2)T o Posterior de Cisco IOS� para el uso con los Cisco 1700 Series Router. Para más información sobre el Routers que soporta la característica del servidor DHCP, vea la sección de las plataformas admitidas del documento sobre el Cisco IOS DHCP Server.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección, le presentan con la información para configurar las opciones del servidor DHCP para el DNS y los TRIUNFOS. Configuran al router “central” para esta opción del servidor y el router “remoto” importa estas opciones. La PC remota o el cliente recibe estas opciones importadas del router “remoto” durante su etapa DHCPACK.

Nota: Para encontrar la información adicional en los comandos usados en este documento, refiera a los comandos del DHCP o utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

/image/gif/paws/22920/dhcp_ser_01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Central (3660)
Central# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- This range must not be assigned to DHCP clients.

!
ip dhcp pool Central   
   network 10.0.0.0 255.255.255.0

!--- Specify the network number and mask for DHCP clients.
   
   domain-name Central

!--- Specify the domain name for the client.
   
   dns-server 10.0.0.2

!--- Specify the DNS server you want to respond to DHCP clients who


!--- need to correlate the host name to the IP address.
   
   netbios-name-server 10.0.0.2

!--- Specify the Network Basic Input/Output System (NetBIOS)


!--- WINS server (for Microsoft DHCP clients)
 
!
.
.
!
interface FastEthernet0/0 
 ip address 10.0.0.1 255.255.255.0 
 duplex auto 
 speed auto
!
.
.
!
end

Nota: Cuando usted utiliza a un router Cisco como servidor DHCP, sólo un dominio se permite por el agrupamiento DHCP, es decir el router no puede enviar los arriendos del DHCP a los clientes que incluyen dos Domain Name. No es posible mezclar la correlación estática en una agrupación dinámica. Si es mezclado, los % este comando no se pueden utilizar con la red, origen, vrf, o el mensaje de error de los pools de la retransmisión aparece.

Remota (3660)
Remote# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- This ip address must not be assigned to DHCP clients.

!
ip dhcp pool Client   
   import all

!--- Import DHCP option parameters into the database.
   
   network 192.168.1.0 255.255.255.248

!--- Specify the network number and mask for DHCP clients.

   default-router 192.168.1.1

!--- Specify the default gateway for DHCP clients.
	
!
.
.
!
interface FastEthernet0/0 
 ip address dhcp 
 duplex auto 
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

Utilizan al comando service config conjuntamente con el host o el comando boot network del inicio. Ingresan al comando service config de permitir al router para configurar automáticamente el sistema del archivo especificado por el host o el comando boot network del inicio.

El comando service config puede también ser utilizado sin el host o el comando boot network del inicio. Si usted no especifica los nombres de fichero del host o de la configuración de red, el router utiliza los archivos de configuración predeterminada. El archivo de configuración de la red predeterminada es red-config. El archivo de configuración predeterminado del host es host-config, donde está el nombre del host el host del router. Si el Cisco IOS Software no puede resolver su nombre del host, el archivo de configuración predeterminado del host es router-config.

Utilice el comando boot host junto con el comando service config. Sin el comando service config, el router ignora el comando boot host y utiliza la información de la configuración en el NVRAM. Si la información de la configuración en el NVRAM falta inválida o, habilitan al comando service config automáticamente. El servidor de red intentará cargar dos archivos de configuración de los host remotos. El primer es el archivo de configuración de red que contiene los comandos que se aplican a todos los servidores de red en una red. Utilice el comando boot network de identificar el archivo de configuración de red. El segundo es el archivo de configuración del host que contiene los comandos que se aplican a un servidor de red particularmente. Utilice el comando boot host de identificar el archivo de configuración del host.

El cliente envía un broadcast a pesar de que la opción 150 se configura debido a su naturaleza predeterminada para mirar hacia fuera para el servidor TFTP y la opción 150 se define en el lado del servidor no el lado del cliente. Con excepción del TFTP, la opción 150 está también disponible para éstos:

  • 150 Etherboot

  • Nombre de trayecto de configuración de 150 COMIDAS

La opción DHCP se puede configurar con el comando del tftp-servidor-nombre de la cadena de ASCII del código de opción. Si usted no tiene el nombre del servidor y si el servidor se configura solamente con la dirección IP, después utilice el comando ip address del IP del código de opción.

Verificación

Esta sección proporciona información que puede utilizar para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

La salida tomada de un PC o de un cliente con un sistema operativo de Microsoft Windows con el comando de /all del ipconfig da los valores de configuración TCP/IP configurados por el DHCP. Refiera al RFC 2132leavingcisco.com para más información sobre la opción DHCP.

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
	 
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 22920