Modo de transferencia asíncrona (ATM) : Clase de servicio IP a ATM

Aplicación de políticas de servicio QoS y CBWFQ/LLQ en PVC ATM conectados en puente.

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de configuración para opciones de colocación en cola elaborada, tales como la colocación en cola equilibrada ponderada en función de la clase (CBWFQ) y la colocación en cola de tiempo de latencia bajo (LLQ), en interfaces ATM configuradas para aceptar unidades de datos de protocolo (PDU) con formato de puente de RFC 1483.

Software support del ½ del ¿Â de Cisco IOSï tres protocolos para el ruteo fuera de red (a un diferente número de red IP) en las aplicaciones interligadas del RFC 1483. Estos protocolos son Conexión en puente y ruteo integrados (IRB), Encapsulación de puente y ruta (RBE) y Circuitos virtuales permanentes (PVC) de conexión en puente. Todos estos protocolos permiten que el PVC ATM reciba PDU de formato conectado en puente. Este documento refiere a los PVC configurados con un bridging protocol tal como PVC interligados.

Una política de servicio configurada con la interfaz de línea de comandos de calidad de servicio modular (CLI) (MQC) aplica mecanismos de QoS a una interfaz, una subinterfaz o un VC. En los PVC con puente, las políticas de servicios que aplican un mecanismo de formación en cola elaborado son admitidas sólo con RBE. No se admiten las políticas de servicio en los VC de ATM configurados para ejecutar IRB. En tal VCs, si usted define un clase-mapa que haga juego en una lista de acceso por IP (ACL), ningunas coincidencias del paquete a esta clase ocurren, y todos los paquetes se clasifican a la clase predeterminada.

prerrequisitos

Requisitos

Los Quien lea este documento deben tener conocimiento de estos temas::

Nota: La Configuración de IRB no soporta Per-VC el CBWFQ o el LLQ. La configuración se debe emigrar al RBE o al pppoe sobre la configuración de ATM antes de que usted intente implementar el CBWFQ o el LLQ.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 2620 Router con la interfaz ATM NM-1A-OC3

  • Cisco IOS Software Release 12.2(27)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

La política de servicio QoS gestiona la profundidad de la cola, marca el tráfico e identifica el tráfico no crítico por VC. Específicamente, esta directiva alcanza estos objetivos:

  • Aplicaciones NBAR para clasificar el tráfico NON-negocio-crítico, tal como Napster.

  • Utiliza la característica del class-based policing para marcar el valor de precedencia de la conformación, de exceder y de violar el tráfico.

  • Aplica el WRED basado en la clase para manejar la profundidad de espera en cola.

    Nota: Es mutuamente - la exclusiva en el nivel PVC. Usted no puede aplicar a un grupo WRED a un VC para las cuales usted ha habilitado el CBWFQ con la aplicación de una política de servicio. Sin embargo, usted puede aplicar ambas características si usted configura el comando random-detect en una clase dentro del directiva-mapa.

  • Aplica el Marcado basado en clases con el comando set para marcar estos valores de precedencia IP del tipo de tráfico.

Valor de precedencia ‘Tipo de tráfico’
1 NON-negocio-crítico, por ejemplo Napster
4 Valor por defecto, usado para el tráfico normal
5 Reservado para tráfico en tiempo real futuro, como por ejemplo voz sobre IP (VoIP).
6 y 7 Reservado para el tráfico del control de red

Los puntos de congestión potenciales son los ATM VC que alimentan a los usuarios conectados a DSL. Los flujos IP llegan a la interfaz Fast Ethernet a una velocidad de hasta 100 Mbps y salen de los VC de ATM. Éstos están configurados para la categoría de servicio ATM de velocidad de bits sin especificar con una Velocidad máxima de celda (PCR) predeterminada de la interfaz T1 (1.544 Mbps). Así, la servicio-directiva de QoS marca el tráfico que llega en la interfaz Fast Ethernet. Los valores observados entonces son utilizados por el WRED para crear las clases de servicio basadas en la Prioridad IP y proporcionar el servicio diferenciado a través de los niveles únicos del descenso por la clase.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/22820/bridging_cbwfq1.gif

Nota: Las atmósferas VCs de la categoría de servicio UBR no proporcionan ningún ancho de banda mínima por definición. Así, usted no puede aplicar el CBWFQ o el LLQ y garantizar el ancho de banda a un VC UBR. Para hacer así pues, usted debe cambiar la categoría de servicio ATM algo con excepción del UBR, tal como VBR-NRT o ABR. Para más detalles en esto, refiera a entender la categoría de servicio UBR para los circuitos virtuales ATM.

Configuraciones

Este documento usa esta configuración:

Router 2600 de Cisco
class-map match-any HTTP-HACKS 

!--- Use the class-map command in global configuration mode
!--- in order to match packets to a specified class.


   match protocol http url "*.ida*"  
   
!--- In order to configure NBAR to match HTTP traffic 
!--- by URL, HOST, or Multi-purpose Internet Mail Extension (MIME)-type, use the
!--- match protocol http command in class-map configuration mode.

   match protocol http url "*cmd.exe*"  
   match protocol http url "*root.exe*"  
   match protocol http url "*Admin.dll*"  
   match protocol http url "*readme.eml*"  
class-map match-any JUNK  
   match protocol napster 
   match protocol fasttrack
class-map match-all IP-PREC-4  match ip precedence 4class-map match-all DEFAULT  
match any
! 
policy-map DSL-OUT-C

!--- Use this command
!--- in order to create or modify a policy map that can be attached to one or more 
!--- interfaces to specify a service policy.

  class IP-PREC-4
   police 32000 250000 5000000 conform-action set-prec-transmit 4 exceed-action
 set-prec-transmit 3 violate-action set-prec-transmit 2
  
!--- Use this command to mark a packet with different quality of service (QoS) 
!--- values based on conformance to the service-level agreement.

! 
policy-map LAN-IN  
  class HTTP-HACKS  
     police 8000 1000 1000 conform-action drop exceed-action
       drop  
  class JUNK  
   set ip precedence 1  
  class DEFAULT  
   set ip precedence 4  
! 
policy-map DSL-OUT  
   class class-default
    
!-- Used to make class-default a single FIFO queue 
!-- inside the WFQ system. 
 
    bandwidth percent 1 
    
    random-detect  
    random-detect exponential-weighting-constant 7  
    random-detect precedence 0   20    40    10  
    random-detect precedence 1   22    40    10 
    random-detect precedence 2   24    40    10 
    random-detect precedence 3   26    40    10 
    random-detect precedence 4   28    40    10  
    random-detect precedence 5   31    40    10  
    random-detect precedence 6   33    40    10  
    random-detect precedence 7   35    40    10  
    random-detect precedence rsvp   37    40    10 
    service-policy DSL-OUT-C
    
!--- In order to use a service policy as a QoS policy within a policy map
!--- (called a hierarchical service policy), use the service-policy command
!--- in policy-map class configuration mode.

! 
interface Loopback1  
  ip address 172.16.1.1 255.255.255.0  
!  
interface FastEthernet0/0  
  ip address 10.1.1.1 255.255.255.192  
  service-policy input LAN-IN  
  
!--- Use this command in order to attach a policy map to an input interface
!--- or virtual circuit (VC), or an output interface or VC, to be used as 
!--- the service policy for that interface or VC.

!  
interface ATM1/0  
  no ip address  
  no atm ilmi-keepalive 
!  
interface ATM1/0.4 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
  no ip mroute-cache  
  atm route-bridged ip  
  pvc 1/35  
   service-policy output DSL-OUT  
  ! 
!  
interface ATM1/0.5 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
 no ip mroute-cache  
  atm route-bridged ip 
 
!--- Use in order to configure an interface to use ATM RBE.

  pvc 1/36
   service-policy output DSL-OUT 
!
ip route 172.16.1.2 255.255.255.255 ATM1/0.4
ip route 172.16.1.3 255.255.255.255 ATM1/0.5
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre la interfaz para colocación en cola ATM — Visualiza las estadísticas de espera de un VC específico en una interfaz. Un valor sin cero para las “conversaciones activas” se visualiza durante los períodos de congestión en que los flujos IP se hacen cola a las colas de administración del tráfico de la capa 3.

    2600# show queueing interface atm1/0.4
            Interface ATM1/0.4 VC 1/35
            Queueing strategy: weighted fair
            Total output drops per VC: 0
            Output queue: 0/512/64/0 (size/max total/threshold/drops)
               Conversations  0/1/64 (active/max active/max total)
               Reserved Conversations 1/1 (allocated/max allocated)
               Available Bandwidth 0 kilobits/sec
  • show policy-map interface ATM — Utilice este comando de marcar estas estadísticas cuando usted monitorea su política de servicio:

    • Incrementando los valores para los paquetes que hacen juego la clase. Si esto no trabaja, asegúrese de que el CEF esté habilitado y de que los paquetes están siguiendo la trayectoria del CEF Switching. Publique el comando show interface stats para ver si los paquetes son CEF-Switched.

    • Compare el valor "paquetes" con el valor "pkts coincidentes". El valor "pkts matched" aumenta sólo durante momentos de congestión. Para más información, refiera comprensión de los contadores de paquetes en la salida del show policy-map interface.

    • Número correcto de caídas aleatorias. Monitorea el valor del campo "profundidad de la cola intermedia" y lo determina si este campo alcanza un valor sobre el umbral mínimo. El WRED comienza a caer aleatoriamente los paquetes cuando la profundidad de espera en cola mala sube sobre el umbral mínimo para una Prioridad IP determinada llana.

2600# show policy-map interface atm1/0.4
ATM1/0.4: VC 1/35 -
 Service-policy output: DSL-OUT
 Class-map: class-default (match-any)
     29121 packets, 41550530 bytes
     5 minute offered rate 0 bps, drop rate 0 bps
     Match: any
     Queueing
       Output Queue: Conversation 73
       Bandwidth 1 (%)
       (pkts matched/bytes matched) 59/8894
       (depth/total drops/no-buffer drops) 0/0/0
        exponential weight: 7
        mean queue depth: 0

 class    Transmitted      Random drop   Tail drop    Minimum   Maximum   Mark
          pkts/bytes       pkts/bytes    pkts/bytes   thresh    thresh    prob
 0        15791/22456790       0/0           0/0          20        40    1/10
 1           0/0               0/0           0/0          22        40    1/10
 2         8555/13041140       0/0           0/0          24        40    1/10
 3         3417/5207580        0/0           0/0          26        40    1/10
 4         1358/845020         0/0           0/0          28        40    1/10
 5           0/0               0/0           0/0          31        40    1/10
 6           0/0               0/0           0/0          33        40    1/10
 7           0/0               0/0           0/0          35        40    1/10
 rsvp        0/0               0/0           0/0          37        40    1/10
     Service-policy : DSL-OUT-C
 Class-map: IP-PREC-4 (match-all)
   13330 packets, 19093740 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: ip precedence 4
   police:
     32000 bps, 250000 limit, 5000000 extended limit
     conformed 1358 packets, 845020 bytes; action: set-prec-transmit 4
     exceeded 3417 packets, 5207580 bytes; action: set-prec-transmit 3
     violated 8555 packets, 13041140 bytes; action: set-prec-transmit 2
     conformed 0 bps, exceed 0 bps, violate 0 bps
 Class-map: class-default (match-any)
   15791 packets, 22456790 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: any 

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 22820