WAN : Frame Relay

Ejemplo de configuración del Distributed Traffic Shaping

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento discute el Control de tráfico distribuido (dTS) y consolida mucha de la información que está disponible hoy.

El modelado de tráfico (TS) proporciona un mecanismo para controlar el flujo de tráfico en una interfaz particular. el TS “distribuido” es un específico de la característica a las plataformas de alto nivel tales como el Cisco 7500 o el 12000 Series Internet Router. Estas Plataformas tienen la capacidad de descargar el modelado de tráfico del procesador principal (Route Switch Processor - RSP o Gigabit Route Processor - GRP) a los procesadores de la interfaz individual (Versatile Interface Processor - VIP o linecard - LC). En las redes donde está el modo preferido el Distributed Cisco Express Forwarding (dCEF) de transferencia, el DTS en el VIP o el linecard es la elección lógica para el modelado de tráfico.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

¿Por qué tráfico de la dimensión de una variable con el DTS?

Si usted está leyendo este documento, después, muy probablemente, usted tiene ya una idea de porqué usted quiere formar el tráfico. La pieza del rompecabezas distribuida debe estar bastante clara, también - usted está distribuyendo los deberes del procesador principal a los procesadores de placa individuales. En cuanto al shaping, muchos clientes están intentando simplemente evitar exceder la tarifa garantizada del circuito basado en el acuerdo con el proveedor. Esto previene los descensos en la nube y, como consecuencia, reduce las retransmisiones (con el TCP/IP) cuando los proveedores descarta paquetes. Un escenario frecuente donde usted necesita formar el tráfico se representa abajo. En este ejemplo, no hay necesidad del sitio central de remitir el tráfico a la tarifa T1 si la sucursal tiene solamente un circuito 128K:

dts-config-01.gif

Hay muchas razones adicionales de usar el DTS. Las ventajas incluyen un surtido de funciones relacionadas del Calidad de Servicio (QoS), y la unidad para utilizar el ancho de banda tan eficientemente como sea posible a través de los tipos de tráfico variados. El DTS configura el modelado de tráfico en el nivel de la interfaz, la subinterfaz llana, o el nivel de interfaz lógica para la atmósfera o los circuitos virtuales permanentes de Frame Relay (PVC).

El shaping puede alcanzar un arsenal de las metas de la red y puede cerrar en los criterios siguientes:

  • Todo el tráfico en la comprobación o la interfaz lógica

  • Tráfico clasificado a través de simple y de las listas de control de acceso IP ampliada (ACL) (IP Addresses, puertos TCP/UDP, Prioridad IP)

  • Tráfico clasificado por el grupo de QoS (una conexión en sentido ascendente aplicada de la etiqueta de paquetes interna por la velocidad comprometida de acceso - CAR, o QoS Policy Propagation - QPPB)

El DTS soporta hasta 200 colas de administración del tráfico de la dimensión de una variable por el VIP, soportando hasta las tarifas OC-3 cuando los tamaños promedios de los paquetes son 250 bytes o mayor, y cuando usa un VIP2-50 o mejor con los 8M RAM estática (SRAM). El modelado de tráfico del distinto a lo regular (GTS), DTS no requiere que la feria cargada que hace cola (WFQ) esté habilitada. En lugar, el DTS utiliza las colas justas o el primero en entrar distribuido, el primero en salir ((Primero en Salir FIFO)) para la cola modelada.

Específicos de la plataforma

Esta tabla describe cómo configurar el TS dependiendo de la plataforma - principalmente ilustrando que la característica es significativa para las plataformas de alto nivel:

  12000 Series Serie 7500 7200, 3600, 2600 y otras plataformas no VIP
Mecanismos de modelado compatibles DTS DTS GTS o TS de Frame Relay
Comando de configuración comando shape en una correspondencia de políticas comando shape en una correspondencia de políticas relaciones del tráfico o formar EL tráfico del Frame Relay en una interfaz principal, y con el FRTS - comandos de configuración de la clase correspondiente de especificar los parámetros de modelado
Requiere el Distributed Cisco Express Forwarding (el dCEF) El valor por defecto es CEF Sí (verifique con el comando show cef linecard) No

Notas del DTS de las 7500 Series

En las Cisco 7500 Series, la capacidad de configurar el Control de tráfico de Frame Relay (FRTS) usando el comando frame-relay traffic-shaping ahora se bloquea puesto que el FRTS ejecuta en el RSP en un modo no distribuido. Con el dCEF y el FRTS, una adyacencia de la “batea” CEF hace todos los paquetes ser conmutados rápido por el RSP, que es subóptimo para el rendimiento de reenvío máximo.

A partir del Software Release 12.1(5)T del � del Cisco IOS, las directivas de QoS deben ejecutarse en el modo distribuido en el VIP; La ruta/el Procesador del switch (RSP) - QoS basado se soporta no más. Por lo tanto, usted debe utilizar el comando shape y otros comandos de la interfaz de línea del comando modular qos (MQC) de implementar el DTS para las interfaces en los VIP en las Cisco 7500 Series.

Mientras que el Cisco IOS Software Release 12.1(2)T introdujo el soporte para el low latency queueing (LLQ) en las Plataformas con excepción de las Cisco 7500 Series, el LLQ distribuido (dLLQ) fue introducido en 12.1(5)T en el VIP. La versión distribuida aumenta el funcionamiento de esta característica. Usted puede configurar una directiva de servicio único por el identificador de conexión de link de datos (DLCI). Usted no necesita utilizar un map class y puede aplicar el comando service-policy directamente a la subinterfaz o al DLCI. Sin embargo, Cisco recomienda que usted configura el dLLQ dentro de un map class.

Al aplicar FRF.12 distribuido (fragmentación) a una interfaz de Frame Relay, usted debe definir un map class y aplicar la política de servicio bajo el map class. El FRF.12 fue introducido en la versión del Cisco IOS Software 12.0(4)T y se amplía al Cisco 805, 1600, 1700, 2500, 4500, y las Plataformas del 4700 Router como de la versión del Cisco IOS Software 12 1(2)T. Para los detalles adicionales, refiera al soporte FRF.12 en las Plataformas adicionales.

Notas del DTS del 12000 Series Internet Router

En las 12000 Series, la transferencia y el process switching rápidos no son opciones. Si un prefijo de destino no se puede resolver a una entrada de reenvío en las tablas entrantes del linecard (LC), se cae el paquete. Solamente los paquetes que corresponden con una adyacencia de recolección se llevan en batea al Gigabit Routing Processor (GRP). Además, en los 12000, el LC CPU no llevará en batea los paquetes al GRP para las características, y el LC envía un Internet Control Message Protocol (ICMP) inalcanzable (mientras no configuran al comando no ip unreachables). En los 12000, el único tráfico llevado en batea al GRP es paquetes destinados a una interfaz en el router o a los paquetes originados del router. ¿Para más información, refiérase a qué características del Calidad de Servicio (QoS) están disponibles para el 12000 Series Internet Router?

Configurar

Utilice los primeros dos pasos para configurar el DTS en las interfaces de Frame Relay VIP basadas (7500 Series):

  1. Utilice este comando para habilitar el dCEF:

    router(config)#ip cef distributed
    
  2. Asegúrese de que la interfaz de Frame Relay esté habilitada para el Distributed Switching:

    router(config-if)#interface serial 2/0/0
    router(config-if)#ip route-cache distributed
    router#show ip interface serial 2/0/0
    Serial8/0/0 is up, line protocol is up
      Internet address is 64.0.0.2/24
      Broadcast address is 255.255.255.255
      ICMP redirects are always sent
      ICMP unreachables are always sent
      ICMP mask replies are never sent
      IP fast switching is enabled
      IP fast switching on the same interface is disabled
      IP Flow switching is disabled
      IP CEF switching is enabled
      IP Distributed switching is enabled
      IP Fast switching turbo vector
      IP CEF switching with tag imposition turbo vector
      IP multicast fast switching is enabled
      IP multicast distributed fast switching is disabled
      IP route-cache flags are Fast, Distributed, CEF
      Router Discovery is disabled
      IP output packet accounting is disabled
  3. Cree una clase de tráfico. (Obligatorio)

  4. Configure una política de tráfico del DTS. (Obligatorio)

  5. Asocie la política de tráfico y habilite el DTS. (Obligatorio)

  6. Monitoree y mantenga el DTS. (Opcional)

Nota: Utilice la herramienta de búsqueda de comandos (clientes registrados solamente) para más información sobre los comandos usados en este documento.

Cree una clase de tráfico

El primer paso a habilitar cualquier característica usando el Modular QoS CLI es crear una clase de tráfico.

Router(config)#class-mapa [match-any | ] nombre de la clase corresponda con todos — especifica el nombre y si cualquiera o todo el de los criterios constituirá una coincidencia.

Para la información sobre el Modular QoS CLI y el procedimiento para crear una clase de tráfico, refiera a la descripción de la interfaz de línea de comando de calidad de servicio modular.

Configure una política de tráfico del DTS

Usted debe configurar una política de tráfico para habilitar el DTS. Usted puede configurar las políticas de tráfico para tantas clases como se definen en el router hasta el máximo del 256.

Para configurar una política de tráfico, utilizar el principio del comando policy-map en el modo de configuración global para especificar el nombre de la política de tráfico, después utilizar los comandos configuration de la clase y de la dimensión de una variable para configurar el nombre y el modelado de tráfico de clase de tráfico.

  1. directiva-nombre del Router(config)#policy-mapa — Especifica el nombre de la política de tráfico que se creará.

  2. Nombre de la clase de los #class del router (config-pmap) — Especifica el nombre de una clase de tráfico predefinida incluida en la política de tráfico. La clase fue definida en el paso anterior de este proceso.

  3. #shape del router (config-pmap-c) {media | [be] del [bc] círculo del pico} — especifica el modelado de tráfico de la media o de la velocidad pico.

El tráfico se dirige a la clase predeterminada de la política de tráfico si no satisface los criterios de concordancia de ninguna otra clases cuyas directivas se definan en la política de tráfico.

Asocie la política de tráfico y habilite el DTS

Utilice este comando en el modo de configuración de la interfaz (o map-class) para asociar una política de tráfico a la interfaz, a la subinterfaz, o al map-class y para habilitar el DTS en la interfaz:

  • La #service-directiva del router (config-if) hizo salir el directiva-nombre — DTS de los permisos y asocia la directiva del tráfico especificado a la interfaz o al map-class.

Nota: Las aplicaciones del dLLQ y el FRF.12 se recomiendan fuertemente para tener la política de servicio aplicada a la clase de correspondencia de Frame Relay.

Refiera al Control de tráfico de Frame Relay con el calidad del servicio (QoS) distribuida en las Cisco 7500 Series para más información sobre la fragmentación.

Monitoree y mantenga el DTS

Utilice estos comandos en el modo EXEC para monitorear y mantener la característica del DTS:

  • Del Router- de la demostración de la interfaz dimensión de una variable [interface-name] — Estatus del detalle de las visualizaciones del modelado de tráfico.

  • Directiva-nombre de la directiva de la demostración del Router- — Visualiza la configuración de todas las clases que componen la directiva del tráfico especificado.

  • Nombre de la clase de la clase del directiva-nombre de la directiva de la demostración del Router- — Visualiza la configuración de la clase especificada de la directiva del tráfico especificado.

Para más información sobre los comandos de monitoreo de QoS, refiera comprensión de los contadores de paquetes en la salida del show policy-map interface.

Configuraciones de Ejemplo

DTS en la interfaz principal

En este ejemplo, el tráfico que sale en la interfaz pos1/0/0 se forma al índice de 10Mbits/sec.

router(config)#class-map class-interface-all

router(config-cmap)#match any

router(config-cmap)#exit

router(config)#policy-map DTS-interface-all-action
router(config-pmap)#class class-interface-all

router(config-pmap-c)#shape average 10000000 
router(config-pmap-c)#exit

router(config)#interface pos1/0/0

router(config-if)#service-policy output DTS-interface-all-action

DTS basado en la clase en la interfaz principal

En este ejemplo, se crean dos clases, y los criterios de concordancia se definen sobre la base del número de lista de acceso. Trafique que sale en la interfaz fd4/0/0 y hace juego los criterios en la lista de acceso 10 se forma a 16Mbps. Trafique que hace juego los criterios en la lista de acceso 20 se forma al 8 Mbps.

router(config)#access-list 10 permit 171.69.0.0

router(config)#access-list 20 permit 192.168.0.0

router(config)#class-map class1

router(config-cmap)#match access-group 10

router(config-cmap)#exit

router(config)#class-map class2

router(config-cmap)#match access-group 20

router(config-cmap)#exit

router(config)#policy-map DTS-interface-class-action
router(config-pmap)#class class1

router(config-pmap-c)#shape average 16000000

router(config-pmap-c)#exit

router(config-pmap)#class class2

router(config-pmap-c)#shape average 8000000

router(config-pmap-c)#exit

router(config-pmap)#interface fd4/0/0

router(config-if)#service-policy output DTS-interface-class-action

Nota: Los IP Addresses en esta configuración son ejemplos solamente.

Para los ejemplos de configuración adicionales, refiera a configurar el Distributed Traffic Shaping.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Una interfaz VIP configurada con la Encapsulación de Frame Relay pudo causar un crash con error de bus si aplica una servicio-directiva mientras que la interfaz pasa el tráfico. Este problema se resuelve en las diversas versiones del Cisco IOS Software (Id. de bug Cisco CSCdt88568). Para más información sobre este los ddts y los bug adicionales, se refieren

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 22600