Switching de LAN : EtherChannel

Configurando el Layer 2 Etherchannel y Conexión Troncal entre los switches de la serie 2900XL/3500XL/2950 y los switches de Catalyst que funcionan con el Cisco IOS Software

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (20 Octubre 2015) | Comentarios


Contenido

DTP

Introducción

Este documento proporciona las configuraciones de muestra en el enlace del link de IEEE 802.1Q/Inter-Switch (ISL) y acoda 2 el EtherChannel (L2) entre el Cisco Catalyst 2900 XL/3500 XL o los Catalyst 2950 Series Switch y un Switch del Catalyst 6500/6000 que funcione con el software de Cisco IOS�. También puede utilizar un switch Catalyst 4500/4000 que ejecute Cisco IOS Software en vez del switch Catalyst 6500/6000 para este ejemplo. Este documento aborda la mayoría de los factores importantes que se deben considerar al configurar el trunking y la canalización entre los switches. El documento también incluye ejemplos de configuración.

En este documento, cuatro puertos Fast Ethernet de cada uno del Switches han sido trunked y unidos en los Fast EtherChannels (FEC). El Trunking Protocol fue utilizado para los 3500 XL ISL, y el 802.1Q fue utilizado para el ejemplo 2950.

Nota: El Catalyst 2950 no soporta la conexión troncal de ISL. Utilice el enlace del 802.1Q en lugar de otro.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Para crear los ejemplos en este documento, este Switches fue utilizado en un ambiente de laboratorio, con las configuraciones despejadas:

  • Catalyst 3548XL Switch que funciona con el Cisco IOS Software Release 12.0(5)WC2

  • Catalyst 2950-24 Switch que funciona con el Cisco IOS Software Release 12.1(6)EA2c

  • Catalyst 6509 Switch con el Supervisor Engine II que funciona con el Cisco IOS Software Release 12.1(11b)E

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

DTP

Los links troncales entre los dispositivos se pueden configurar estáticamente o con el uso del Dynamic Trunking Protocol (DTP). DTP le permite a ambos dispositivos conectados negociar las configuraciones de conexión troncal antes de que se establezca dicha conexión. Los modos configurables del puerto del switch del Cisco IOS Software (enlace) incluyen: dinámico (el puerto negocia el acceso o al modo tronco), trunk (incondicional fija el puerto al enlace), y acceso (puerto de acceso del NON-trunk). Las configuraciones más de uso general de la combinación del modo en dos lados (NON-DTP negociado) de un trunk estático son trunk-trunk. Para troncos dinámicos (DTP negociados), las configuraciones usuales son dinámico-dinámico. Otras combinaciones pueden producir los resultados válidos pero están fuera del ámbito de este documento. Una conexión de tronco entre un Port Aggregation Protocol (PAgP) - el Switch capaz y un dispositivo sin PAgP requiere al modo tronco estar prendido.

Nota: La mayoría de los routeres Cisco y algunos switches de Catalyst no soportan el DTP y requieren la configuración estática troncal. Por ejemplo, las series del Catalyst XL, Catalyst 2948G-L3, Catalyst 4908G-L3, las Catalyst 8500 Series, los routeres Cisco de las 2/3/4/7xxx Series, y así sucesivamente no soportan el DTP y requieren la configuración estática troncal.

Consideración de VLAN nativa 802.1q

el enlace del 802.1Q inserta un campo de la etiqueta del 802.1Q 4-byte en las tramas enviadas sobre el trunk, que contienen la información de VLAN. La etiqueta 802.1q se inserta en cada trama transferida sobre el troncal excepto para las tramas transmitidas en la VLAN de origen las cuales se envían sin etiquetar. En la mayoría de los casos, el VLAN nativo tiene que hacer juego a ambos lados del trunk a menos que haya un requisito de configuración inusual específico, que está fuera del ámbito de este documento. Si los VLAN nativos no hacen juego, los mensajes del Cisco Discovery Protocol (CDP) de los registros del switch seleccionar que exponen la discordancía. Esta configuración, si bien no es catastrófica, provoca de manera eficaz que las dos VLAN nativas diferentes se fusionen en un dominio de transmisión L2 más grande (VLAN). Estos dos VLA N intentan calcular una topología del protocolo del Common Spanning Tree (STP) para tales VLAN nativos interligados, con el riesgo eventual de exceder al máximo diámetro STP admitido.

Nota: Hay un caso especial cuando un vecino o un dispositivo de terceros requiere todos los VLA N ser marcado con etiqueta. Si esto ocurriera, puede implementar una solución alternativa para crear una VLAN ficticia y configúrela como VLAN nativa. Esto hará que se coloque una etiqueta en todas las demás VLAN necesarias y el tráfico pasará por el tronco al vecino o dispositivo de terceros. En el Cisco IOS Software Release 12.1.11bEX, 12.1.13E, y posterior, el Catalyst 6500 que funciona con el Cisco IOS Software soporta la opción de conexión troncal del 802.1Q que marcará todo el tráfico VLAN con etiqueta incluyendo el VLAN nativo. Publique el comando vlan dot1q tag native bajo modo de configuración global. En el Catalyst que 4500/4000 eso funciona con el Cisco IOS Software, el comando vlan dot1q tag native primero fue introducido en el Cisco IOS Software Release 12.2(18)EW.

PAgP

Los Gigabit EtherChannels (GEC) y los FEC entre el Switches se pueden también configurar estáticamente o dinámicamente con el uso del PAgP. El PAgP permite ambos dispositivos conectados para negociar las configuraciones antes realmente de formar el canal. Los modos del canal del PAgP incluyen: deseable (el puerto inicia activamente el Channel Negotiation), auto (el valor por defecto, en los cuales el puerto no inicia la negociación pero responde a las tentativas de la negociación comenzadas por el otro lado), y en (incondicional fija el puerto para canalizar y no intercambia las tramas de PAgP). Una conexión entre un Switch PAgP capaz y un dispositivo sin PAgP requiere encendido el modo formar un canal.

La combinación del modo más de uso general en dos lados (no PAgP negociado) de un canal estático es on-on. Para los canales (negociados por PAgP) dinámicos, las configuraciones frecuentes son deseable-deseable o deseable-automático. Los puertos conectados configurados para el desirable mode realizan el Channel Negotiation y la verificación antes de comenzar la canalización y también guardan el verificar del canal cuando es en funcionamiento. Debido a la protección agregada ofrecida por PAgP, ésta configuración es usualmente la recomendada si los dos switches conectados admiten PAgP.

Nota: El PAgP tiene algunas limitaciones de la configuración deliberadas. Los puertos para negociar un canal deben tener la misma velocidad, duplex, encapsulado de conexión de troncal, y VLA N fijado. También, el algoritmo de equilibrio de la carga de canal a través de los links puede ser configurable en ciertas Plataformas.

Nota: Un EtherChannel se considera ser un puerto único STP tan pronto como esté para arriba. Por lo tanto, para evitar las inconsistencias STP al configurar un canal NON-negociado, siga de la forma siguiente:

  1. Apague todos los puertos del canal para configurar en los ambos lados.

  2. Emplee esta configuración en ambos extremos.

  3. Vuelva a activar todos los puertos.

Si se intenta configurar tal canal mientras los puertos están abiertos, pueden producirse inconsistencias temporales de STP y/o loops. Los pasos se aplican solamente si el PAgP no se utiliza.

Catalyst 2900XL/3500XL

Los Catalyst 2900 XL/3500 XL Series Switch no soportan el DTP y el PAgP, y por lo tanto requieren la configuración del tronco estático y del canal. Refiera a la nota arriba para más información. Los Catalyst 2900 XL/3500 XL Series Switch soportan actualmente los encapsulados de conexión de troncal ISL y del 802.1Q. Para más información, refiera a este documento:

El ISL se soporta en el Cisco IOS Software Release 11.2(8)SA4 y Posterior, y el 802.1Q se soporta en el Cisco IOS Software Release 11.2(8)SA5 y Posterior.

Con un Catalyst 2900 XL que ejecuta el Cisco IOS Software Releases 11.2(8)SA1 o 11.2(8)SA2, le no prohiben cuatro EtherChanneles (grupos de puertos) por el Switch con un número sin límite de puertos por el grupo. El Equilibrio de carga a través de los links en el canal es siempre direccionamiento basado del destino. Las características de seguridad de puerto y analizador de puerto conmutado (SPAN) no están admitidas.

En un Catalyst 2900 XL que ejecuta el Cisco IOS Software Release 11.2(8)SA3 o Posterior, un Catalyst 3500 XL que funciona con el Cisco IOS Software Release 11.2(8)SA6 o Posterior, y un Catalyst 2950, el Equilibrio de carga a través de los links en el canal es configurable ser basado en la fuente o la dirección MAC del destino. La fuente es el valor por defecto. El reenvío basado en el origen permite hasta ocho puertos en FEC (grupo de puertos). El reenvío basado en el destino permite puertos ilimitados por grupo de puertos. Usted puede configurar a hasta 12 grupos de puertos por el Switch y puede tener una mezcla de grupos source-/destination-based. SPAN y la seguridad del puerto no son compatibles.

Catalyst 2950

El enlace del 802.1Q del soporte de los Catalyst 2950 Switch solamente y no soporta la conexión troncal de ISL. Soporte DTP de los Catalyst 2950 Switch y concentración de links dinámica y Channel Negotiation del PAgP con las versiones y los modos estáticos del Cisco IOS Software Release 12.1 solamente con las versiones del Cisco IOS Software Release 12.0. El balanceo de carga EtherChannel puede utilizar el reenvío de la dirección MAC de origen o MAC de destino. Puede configurar el método de equilibrio de carga mediante el comando de configuración global port-channel load-balance. Estos switches admiten hasta ocho puertos de switch por canal.

Catalyst 6500 que funciona con el Cisco IOS Software

Catalyst 6500 Switch que ejecutan el soporte L2 (switchport) del Cisco IOS Software y la capa 3 (L3) (puerto ruteado) las configuraciones de EtherChannel. Un Catalyst 6500/6000 Series Switch soporta un máximo de 64 EtherChanneles (256 con el Cisco IOS Software Release 12.1(2)E y Anterior). Usted puede formar un EtherChannel con hasta ocho puertos LAN compatible configurados en cualquier módulo en un Catalyst 6000 Series Switch, a excepción de la placa de función de Digitaces (DFC) - los módulos equipados (tales como WS-X6816 y así sucesivamente) que permiten actualmente un canal L2 solamente usando los puertos en el mismo módulo DFC. Sin embargo, un canal L3 se puede configurar a través de diversos módulos equipados con DFC. Esta limitación se ha quitado en el Cisco IOS Software Release 12.1(11b)EX y Posterior del Catalyst 6500/6000. Este documento configura un EtherChannel L2.

El Catalyst 6500/6000 que funciona con el Cisco IOS Software permite que usted configure la carga EtherChannel que equilibra para utilizar las direcciones MAC, los IP Addresses, o acoda 4 la información de puerto (el L4) adentro cualquier origen, destino y combinación de origen-destino publicando el comando port-channel load-balance global configuration. El valor por defecto es utilizar una función de troceo entre los IP Address de origen y de destino.

El Switches del Catalyst 6500/6000 soporta los encapsulados de conexión de troncal ISL y del 802.1Q y el DTP. La información detallada en las capacidades de puerto está disponible publicando el comando show interface interface_id capabilities.

Catalyst 4000 que funciona con el Cisco IOS Software

Catalyst 4000 Switch que funcionan con el Cisco IOS Software (con el Supervisor Engine III e IV) las configuraciones de EtherChannel L2 (switchport) y L3 (puerto ruteado) del soporte. Un Catalyst 4000 Series Switch soporta un máximo de 64 EtherChanneles. Usted puede formar un EtherChannel con hasta ocho compatible interfaces Ethernet configurada en cualquier módulo, y a través de los módulos en un Catalyst 4000 Series Switch. Todas las interfaces en cada EtherChannel deben ser la misma velocidad y se deben todos configurar que las interfaces L2 o L3.

El Cisco IOS Software del Catalyst 4000 que se ejecuta permite que usted configure la carga EtherChannel que equilibra para utilizar las direcciones MAC, la dirección IP, o la información de puerto L4 adentro cualquier origen, destino y combinación de origen-destino publicando el comando port-channel load-balance global configuration. El valor por defecto es utilizar una función de troceo entre los IP Address de origen y de destino.

El Catalyst 4000 que funciona con los soportes ISL del Cisco IOS Software y los encapsulados de conexión de troncal del 802.1Q y DTP. El ISL no está disponible en los módulos determinados. Para una lista completa de tales módulos, refiera comprensión de la sección de los troncales VLAN de configurar las interfaces de Ethernet de la capa 2. En una versión de software futuro, la información detallada en las capacidades de puerto estará disponible publicando el comando show interface capabilities. Este comando no está actualmente disponible.

Configuración 1: ISL Trunking y EtherChannel entre el Catalyst 3500 XL y el Catalyst 6500 que funciona con el Cisco IOS Software

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Esta configuración utiliza esta configuración de red:

/image/gif/paws/22422/144-a.gif

Catalyst 3524 XL

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel 
!--- and then enable them back when the configuration is complete on both switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Output suppressed.


!
interface FastEthernet0/17
port group 1

!--- Assigned port to port channel 1.


switchport trunk encapsulation isl

!--- Configured the port to use the trunking encapsulation ISL.


switchport mode trunk

!--- Configured the port to be in trunking mode.


!
interface FastEthernet0/18

!--- Repeated the trunk and channel configuration.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Output suppressed.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500 (Cisco IOS Software)

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel, 
!--- and then enable them back when the configuration is complete on both switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q

!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


no ip address 
channel-group 1 mode on

!--- Configured the port to participate in port channel 1 with channel mode on.


! 
Interface FastEthernet4/3

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4

!--- Repeated the trunk and channel configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

Configuración 2: enlace y EtherChannel del 802.1Q con el uso del DTP y el PAgP entre el Catalyst 2950 y el Catalyst 6500 que funciona con el Cisco IOS Software

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Esta configuración utiliza esta configuración de red:

/image/gif/paws/22422/144-b.gif

Catalyst 2950

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk

!--- Configured port to be in trunking mode.


channel-group 1 mode desirable

!--- Configured port to participate in PAgP-negotiated port channel 1.


!
interface FastEthernet0/3

!--- Repeated trunk and channel configuration.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Output suppressed.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500 (Cisco IOS Software)

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q


!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


No ip address 
channel-group 1 mode desirable

!--- Configured port to participate in port channel 1 with channel mode desirable.


! 
Interface FastEthernet4/3

!--- Repeated trunk and channel configuration. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4

!--- Repeated trunk and channel configuration.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5

!--- Repeated trunk and channel configuration. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

Verifique: Conexión troncal ISL

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Catalyst 3500 XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

Nota: Si usted tiene un EtherChannel ocho puertos, la publicación del comando show etherchannel summary puede causar un crash el Switch si usted funciona con una versión de Cisco IOS Software que sea anterior que el Cisco IOS Software Release 12.0(5)WC5.

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500 (Cisco IOS Software)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

Verifique: Enlace troncal 802.1q

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Cisco IOS Software del Catalyst 6500

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

Troubleshooting

Use esta sección para resolver problemas de configuración.

El tráfico no está pasando en un tronco 802.1q

Una de estas causas puede dar lugar al problema:

  • Hay una discordancía de la configuración de VLAN nativa en los puertos que están conectados entre dos Switches.

    Verifique la configuración de VLAN nativa en ambo el Switches. Publique el comando show trunk en el switch CatOS para ver la configuración del VLAN nativo. Publique el comando show interface interface_id switchport en el switch XL para ver la configuración del VLAN nativo. Si hay una discrepancia de VLAN nativa entre el dos Switches, configure el Switches con el mismo VLAN nativo. Publique el comando interface configuration del VLAN nativo del switchport trunk para cambiar el VLAN nativo en el switch XL. Publique el comando set vlan para cambiar el VLAN nativo en el switch CatOS.

  • Las tramas DTP no se soportan en los switches XL.

    Los switches CatOS envían las tramas DTP sobre el link de troncal, pero los switches XL no soportan las tramas DTP. El DTP no se soporta en los switches XL. Para evitar este problema, fije el estado del puerto del switch CatOS a ningún negocian. Publique el comando set trunk mod/port nonegotiate dot1q para fijar al modo tronco para nonegociar para el modo de concentración links del dot1q.

  • Hay una discordancia de encapsulado en el switch XL.

    En el switch XL, verifique que la encapsulación del tronco esté fijada al dot1q. Publique el comando show interface interface_id switchport para ver la configuración actual. Publique el comando interface configuration del dot1q del switchport trunk encapsulation para cambiar la encapsulación al dot1q.

  • Una versión temprana de CatOS no soporta el enlace del dot1q.

    La versión temprana de CatOS que fue utilizado en el Switches no soporta el enlace del dot1q. Actualice el CatOS del Switch a una versión posterior que soporte el trunk y el troncal ISL del dot1q.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 22422