Voz : H.323

VoIP (Voz sobre IP) QoS (Calidad de servicio) para el Frame Relay para la interconexión ATM con LLQ (Cola de baja latencia), PPP LFI y cRTP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento brinda un ejemplo de configuración de voz sobre IP mediante el PPP de links múltiples sobre ATM y la interconexión de red de Frame Relay (VoIP mediante MLPoATM / MLPoFR). El foco central de los ejemplos de configuración es la disposición del Calidad de Servicio (QoS) para soportar correctamente la Voz a través de un ATM/Frame WAN intertrabajado retransmisión. Los ejemplos de configuración también hacen uso del Compressed Real-Time Protocol (CRTP), que se ha soportado en la atmósfera desde el Software Release 12.2(2)T del½ del¿Â del Cisco IOSïÂ.

El documento puede ser independiente leído para el guía para la configuración, los ejemplos de configuración, y los Comandos de verificación para ser utilizado en la construcción de la red. La información de origen también se provee para problemas específicos relacionados con el uso de interconexión ATM/ Frame Relay. Refiera a estos documentos para más información sobre QoS para el VoIP over Frame Relay o el PPP:

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

Usted debe ser familiar con estas áreas de tecnología:

  • Listas de control de acceso

  • Circuitos virtuales permanentes (PVC) de ATM

  • Circuitos virtuales permanente de Frame Relay (identificador de conexión de link de datos (DLCI))

  • Administración del ancho de banda

  • LLQ

  • LFI

  • Plantillas virtuales e interfaces de acceso virtual

  • MLPPP

  • cRTP

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 3640 como el router de ATM

  • Cisco 2620 como el router de Frame Relay

  • Cisco IOS Software Release 12.2(8)T (IP Plus)

Nota:  Como Pautas generales, la última versión de mantenimiento del mainline del Cisco IOS 12.2 es la versión de Cisco IOS Software recomendada a utilizar para el MLPoATM/el Cisco IOS Software Release 12.2T del MARCO se requiere en el router de ATM si se utiliza el cRTP.

Las características relevantes fueron introducidas en estas versiones de Cisco IOS Software:

  • LFI se presentó en la versión 11.3 del Software del IOS de Cisco.

  • Se introdujo el LLQ en la versión 12.0(7)T del IOS de Cisco.

  • En la versión 12.1(2)T del software Cisco IOS se introdujo la LLQ sobre retransmisión de tramas y ATM por PVC.

  • El LFI de PPP de links múltiples para Frame Relay y Circuitos virtuales ATM fue introducido en la versión 12.1(5)T de software del IOS de Cisco.

  • El cRTP sobre ATM fue introducido en la versión 12.2 (2)T de software del IOS de Cisco.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

Los problemas claves en proporcionar a la prevención de retraso y fluctuación de extremo a extremo minimizada para el VoIP a través de una red intertrabajada retransmisión del ATM/Frame son:

  • Prioridad estricta para el tráfico de voz (cola de tiempo de latencia bajo (LLQ)

  • Fragmentación y entrelazado de link (LFI)

  • Modelado del tráfico de Frame Relay (FRTS) para voz

  • Modelado del tráfico ATM

Estos documentos proporcionan las fuentes útiles de información previa adicional:

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta de búsqueda de comandos (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/22383/voip-qos-fr-atm-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Nota: Es importante observar que en esta configuración, el dos Routers está conectado continuamente sobre un Frame Relay con el switch interconectado atmósfera. En la mayoría de las topologías sin embargo, los routeres habilitados de la Voz pueden existir dondequiera. Generalmente, el Routers de la Voz utiliza la conectividad LAN al otro Routers, que están conectados con el ATM/Frame WAN. En esos casos, el Routers conectado con WAN, el Frame Relay, y las atmósferas tienen que ser configurados para el LLQ, el LFI, y el MLPPP así que pueden proporcionar QoS, y no el Gateways de voz tal y como se muestra en de estas configuraciones.

Router conectado con retransmisión de tramas

!--- Note: This configuration is commented and numbered 
!--- in the order that commands should be entered.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname FR
!
enable password cisco
!
username ATM password 0 cisco
voice-card 0
dspfarm
!
ip subnet-zero
!
!
!
!


!--- access-list 105 permit ip any any dscp ef specifies 
!--- that all traffic with Differentiated Services Code Point (DSCP)
!--- are set to 40 falls into this access-list.
!--- This class-map command defines a class of traffic called "voice".


access-list 105 permit ip any any dscp ef 
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice 
match access-group 105
!

!         
!

!--- This policy-map command defines a policy for LLQ called "VoIP" and 
!--- maps the "voice" class to the "VOIP" policy.
!--- "priority" defines the amount of bandwidth reserved for the priority queue.
!--- "class-default" specifies that the default class is also mapped to this policy.  
!--- "fair-queue" specifies that all other traffic is served in the WFQ.


policy-map VOIP 
  class voice 
    priority 48 
  class class-default  
   fair-queue 


!--- Note: Although it is possible to queue various types of 
!--- real-time traffic to the priority queue, 
!--- Cisco recommends that you direct only voice traffic 
!--- to it. Real-time traffic such as video or voice
!--- could introduce variations in delay. Please note voice and 
!--- video should not be combined in the same PVC.
!--- (the priority queue is a First In First Out (FIFO) 
!--- queue). Voice traffic requires that delay be 
!--- nonvariable in order to avoid jitter.

!--- Note: The sum of the values for priority and 
!--- bandwidth statements needs to be less 
!--- than or equal to 75% of the link bandwidth. 
!--- Otherwise service-policy cannot be 
!--- assigned to the link. When configuring VoIP over a 
!--- 64 Kbps link to support two 
!--- voice calls, it is common to allocate more than 75% 
!--- (48 Kbps) of the link bandwidth to 
!--- the priority queue. In such cases, you can use the  
!--- max-reserved-bandwidth <#%> command in order to raise 
!--- available bandwidth to a value more than 75%.


!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.0
!
!
interface FastEthernet0/0
 ip address 172.17.111.16 255.255.255.224
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 no ip mroute-cache
 frame-relay traffic-shaping
!

!--- Choose the frame relay interface to be 
!--- associated with the virtual interface. The
!--- virtual template could equally have been associated 
!--- with the physical interface. 
!--- The "class mlp" associates the virtual template interface 
!--- defined in "interface Virtual-Template1" with a Frame Relay DLCI.
!--- Associates a Frame Relay map class with a DLCI.


interface Serial0/0.1 point-to-point 
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 16 ppp Virtual-Template1 
  class mlp 


!--- The interface command creates a virtual 
!--- template called Virtual-Template1. 
!--- A bandwidth of 64 Kbps is assigned to this 
!--- template interface. This bandwidth is used
!--- by Cisco IOS to calculate the data fragment size as noted regarding
!--- interleaving of PPP segments.

!--- "ip rtp header-compression"—cRTP is supported in an ATM/Frame Relay Interworking 
!--- environment. It requires Cisco IOS Software Release 12.2(2)T on the 
!--- ATM router.

!--- "service-policy output VOIP"—The VoIP policy created earlier is assigned 
!--- to this interface in the outbound direction.
 
!--- PPP multilink is enabled and the 
!--- maximum delay per segment is specified. This bandwidth is   
!--- used by Cisco IOS to calculate the data fragement size as noted.

!--- Interleaving of PPP segments is enabled, which allows 
!--- voice packets to be expedited. Voice  
!--- packets need only wait behind a single segment of 
!--- a previously queued data packet (for example, 10 ms 
!--- delay) rather than wait until the end of the 
!--- entire data packet. Cisco IOS calculates the  
!--- data fragment size using the following formula: 
!--- fragment size = delay x bandwidth/8

!
interface Virtual-Template1 
 bandwidth 64 
 ip unnumbered loopback0
 ip rtp header-compression 
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP 
 ppp multilink 
 ppp multilink fragment-delay 10 
 ppp multilink interleave 
!


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
no ip http server
ip pim bidir-enable
!
!
!

!--- A map class called mlp is created.
!--- With "no frame-relay adaptive-shaping", adaptive
!--- shaping is disabled. You do not 
!--- want to exceed CIR and have voice packets
!--- possibly queued within the Frame Relay network. 
!--- Waiting for a BECN to resolve this 
!--- situation could result in poor voice quality.
!--- The frame-relay cir 64000 command forces the router to transmit 
!--- at the desired CIR rate rather than line
!--- rate for the port.
!--- "frame-relay bc 640" configures the Bc value to force the desired 
!--- Tc (shaping interval) value is 10 ms. 
!--- This formula should be used to determine 
!--- the Bc value to use: Tc = Bc/CIR. A 
!--- smaller Tc value reduces the interval a voice 
!--- packet has to wait to be sent.
!--- As in "frame-relay be 0", the Be value should be set to zero
!--- in order to avoid voice being sent as part of a burst
!--- that is not guaranteed by the Frame Relay network.


map-class frame-relay mlp

 no frame-relay adaptive-shaping
 frame-relay cir 64000  
 frame-relay bc 640 
 frame-relay be 0 


!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 123 voip
 destination-pattern 123
 session target ipv4:10.1.1.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
dial-peer voice 456 pots
 destination-pattern 456
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

Router ATM conectado

!--- Note: This configuration is commented only 
!--- where additional consideration is required from the 
!--- above configuration of the Frame Relay router.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname ATM
!
enable password cisco
!
username FR password 0 cisco
memory-size iomem 25
ip subnet-zero
!
!
!
access-list 105 permit ip any any dscp ef
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice
 match access-group 105
!
!

!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
policy-map VOIP
  class voice
    priority 48
  class class-default
   fair-queue


!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 2/0
 framing sf
 linecode ami
!
!
!
!
interface ATM0/0
 no ip address
 ip route-cache
 no atm ilmi-keepalive
!

!--- "interface ATM0/0.1 point-to-point" chooses the ATM subinterface.
!---  The physical interface could equally have been used.
!--- "pvc 10/100" creates an ATM PVC. 
!--- "cbr 64"—A VBR PVC has been defined on this example.
!--- This exapmle uses VBR non-realtime and the sustained 
!--- cell rate (SCR) should be equal to the peak
!--- cell rate (PCR)  in order to avoid bursting. 
!--- ATM cell tax and the possibility
!--- of ATM bandwidth expansion due to poor 
!--- fragment/cell alignment, means that it  
!--- cannot be assumed that the PCR/SCR on the ATM 
!--- side should equal the CIR of the Frame Relay side.
!--- Maintain the value of CIR on the Frame-Relay side to define 
!--- our SCR, in this case, 64 kbps. This value may in some networks
!--- require some fine-tuning as the CIR on the Frame side does not
!--- exactly match the SCR on the ATM but makes for a good-enough estimation
!--- for most purposes.
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM
!--- for more information. 
!--- "encapsulation aal5snap" is required.
!--- "protocol ppp Virtual-Template1" associates the virtual 
!--- template with the ATM PVC.


interface ATM0/0.1 point-to-point
 ip route-cache
 pvc 10/100 
  cbr 64 
  encapsulation aal5snap 
  protocol ppp Virtual-Template1 


!
!
interface loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet3/0
 ip address 172.17.111.15 255.255.255.224
 half-duplex
!
interface Ethernet3/1
 no ip address
 shutdown
 half-duplex
!
interface Virtual-Template1
 bandwidth 64
 ip unnumbered loopback0
 ip rtp header-compression
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave


!--- Note: The virtual template is created in 
!--- exactly the same way as for the
!--- Frame Relay router side of the network. 
!--- An additional consideration for
!--- the ATM router is that the fragment size 
!--- should be optimized to fit into
!--- an integral number of ATM cells. 
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM 
!--- for more information on this issue.


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
ip http server
ip pim bidir-enable
!
!
call rsvp-sync
!
voice-port 1/0/0
 description FXS
!
voice-port 1/0/1
!
voice-port 1/1/0
 description FXO
!
voice-port 1/1/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 456 voip
 destination-pattern 456
 session target ipv4:10.1.1.2
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad   
!
dial-peer voice 123 pots
 destination-pattern 123
 port 1/1/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Estos comandos show son útiles en la verificación del estado operacional del entorno que intertrabaja de la retransmisión del ATM/Frame, que incluye el DLCI y los estáticos de PVC, estatus de la comprobación y de la interfaz virtual, aplicación de la directiva (QoS), y información sobre cRTP:

  • show ppp multilink interface interface-name - Verifica si el agrupamiento está activo/inactivo, qué interfaz de acceso virtual es el agrupamiento (agrupamiento MLPPP) y cuáles son miembros (enlace PPP). Este comando también verifica si las células de las caídas de portadora/las tramas (<> perdido 0 de los fragmentos). La única pérdida de fragmento aceptable es aquella causada por errores de verificación por redundancia cíclica (CRC).

  • show user - Muestra el número relacionado con la interfaz de acceso virtual. Puede utilizar información sobre este comando o sobre el comando show ppp multilink para mostrar estadísticas sobre la interfaz o borrar la interfaz.

  • show frame-relay pvc dlci — Visualiza la información tal como parámetros de modelado del tráfico, valores de fragmentación, y paquetes perdidos. Este comando también muestra si la interfaz física se unió a la interfaz virtual.

  • show atm pvc pvc - Muestra todos los PVC ATM activos e información sobre el tráfico.

  • show policy-map interface interface-name – Muestra todo el funcionamiento LLQ y cualquier pérdida en el PQ. Refiera comprensión de los contadores de paquetes en el comando show policy-map interface hecho salir para más información sobre los diversos campos de este comando.

    Nota: El envío a cola elaborado siempre se aplica a la interfaz de acceso virtual2. Las otras interfaces utilizan colas primero en entrar, primero en salir.

  • show ip rtb header-compression - Muestra las estadísticas de compresión del encabezado RTP, si es que fueron configuradas. Note que las estadísticas están asociadas a la interfaz virtual-access2, que es el bundle interface.

Los ejemplos de estos comandos se muestran aquí:

FR#show ppp multilink interface virtual-access 2
Virtual-Access2, bundle name is ATM
Bundle up for 00:22:42
0 lost fragments, 0 reordered, 0 unassigned
0 discarded, 0 lost received, 231/255 load
0x2E5 received sequence, 0x10C31 sent sequence
Member links: 1 (max not set, min not set)
Virtual-Access1, since 00:22:42, last rcvd seq 0002E4 160 weight

Esta salida muestra a los usuarios de la demostración en el router de Frame Relay.

FR#show users
Line User Host(s) Idle Location
67 vty 1 idle 00:00:00 10.1.1.1
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (FR ) - 
Vi2 Virtual PPP (Bundle) 00:00:00 10.1.1.1
FR#

Esta salida muestra a los usuarios de la demostración en el router de ATM.

ATM#show users 
Line User Host(s) Idle Location
131 vty 1 idle 00:00:00 64.104.207.95
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (ATM ) - 
Vi2 Virtual PPP (Bundle) 00:00:02 10.1.1.2
ATM#

Esta salida muestra el comando show frame-relay pvc.

FR#show frame-relay pvc 16
 PVC Statistics for interface Serial0/0 (Frame Relay DTE)
 DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1
  
     input pkts 2301 output pkts 2295 in bytes 152266 
     out bytes 151891 dropped pkts 0 in FECN pkts 0 
     in BECN pkts 0 out FECN pkts 0 out BECN pkts 0 
     in DE pkts 0 out DE pkts 0 
     out bcast pkts 0 out bcast bytes 0 
     5 minute input rate 9000 bits/sec, 9 packets/sec
     5 minute output rate 9000 bits/sec, 9 packets/sec
     pvc create time 23:46:56, last time pvc status changed 00:22:56
     Bound to Virtual-Access1 (up, cloned from Virtual-Template1) 
     
!--- PPP link interface.

     cir 64000 bc 640 be 0 byte limit 80 interval 10 
     mincir 64000 byte increment 80 Adaptive Shaping none
     pkts 2296 bytes 152053 pkts delayed 9 bytes delayed 375
     shaping active 
     traffic shaping drops 0
     Queueing strategy: fifo
     Output queue 0/40, 0 drop, 0 dequeued
FR#

Esta salida muestra el comando show atm pvc 10/100 en el router de ATM.

ATM#show atm pvc 10/100 
     ATM0/0.1: VCD: 1, VPI: 10, VCI: 100
     CBR, SusRate: 128
     AAL5-LLC/SNAP, etype:0x0, Flags: 0x820, VCmode: 0x0
     OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)
     OAM up retry count: 3, OAM down retry count: 5
     OAM Loopback status: OAM Disabled
     OAM VC state: Not Managed
     ILMI VC state: Not Managed
     InARP frequency: 15 minutes(s)
     Transmit priority 1
     InPkts: 729, OutPkts: 729, InBytes: 49700, OutBytes: 51158
     InPRoc: 0, OutPRoc: 729
     InFast: 729, OutFast: 0, InAS: 0, OutAS: 0
     InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)
     CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, 
     CPIErrors: 0
     OAM cells received: 0
     F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
     F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
     OAM cells sent: 0
     F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
     F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
     OAM cell drops: 0
     Status: UP
   PPP: Virtual-Access2 from Virtual-Template1 
    
!--- MLPPP bundle interface.

ATM#

Éste es el directiva-mapa de la demostración en el router de Frame Relay.

FR#show policy-map interface Virtual-Access2
Service-policy output: VoIP
Class-map: voice (match-all)
15483 packets, 959502 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing 
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48(kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 15536/962784
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
139 packets, 19481 bytes
30 second offered rate 1000 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0

Esta salida muestra el comando show policy map en el router de ATM.

ATM#show policy-map interface Virtual-Access2 
Service-policy output: VOIP
Class-map: voice (match-all)
11293 packets, 699718 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48 (kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 11352/703376
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
63 packets, 9772 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0
ATM#

Esta salida muestra el comando show ip rtp header-compression en el router de Frame Relay.

FR#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Access2:
Rcvd: 23682 total, 23681 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 327 total, 233 compressed,
8821 bytes saved, 5159 bytes sent
2.70 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 94 misses 0 collisions
71% hit ratio, five minute miss rate 0 misses/sec, 0 max

Esta salida muestra el comando show ip rtp header-compression en el router de ATM.

ATM#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Access2:
Rcvd: 283 total, 233 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 25341 total, 25340 compressed,
955537 bytes saved, 564463 bytes sent
2.69 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 1 misses 0 collisions, 100 negative cache hits
99% hit ratio, five minute miss rate 0 misses/sec, 0 max

Troubleshooting

Use esta sección para resolver problemas su configuración.

Esta sección proporciona algunos debugs del ejemplo previstos para aclarar MLP LFI y para servir como Ejemplos de funcionamiento resolver problemas su configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • debug ppp negotiation - Ilustra el proceso de clonación de dos interfaces de acceso virtual para representar los links PPP y PPP de agrupamiento. La interfaz de acceso virtual 1 (Vi1) es el link PPP al cual (atmósfera o trama) el PVC está limitado. La Interfaz virtual 2 (Vi2) es el link de agrupamiento PPP al que se adjuntan las políticas de envío a cola.

  • debug ppp multilink fragment - Ilustra el concepto de paquetes de datos grandes que se entrelazan con paquetes de voz más pequeños. La interpolación ocurre en la interfaz Vi2 (el nivel MLP) puesto que el bundle interface tiene el envío a cola elaborado asignado.

Ésta es la salida de comando para el comando debug ppp negotiation.

FR(config-if)#no shut
FR(config-if)#^Z
FR#
FR#
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Mar 7 23:20:42.842: Vi1 PPP: Treating connection as 
a dedicated line 

!--- Vi1 is the PPP link to which the PVC is bound.

*Mar 7 23:20:42.842: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:42.842: Vi1 LCP: O CONFREQ [Closed] id 197 len 19
*Mar 7 23:20:42.842: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.842: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.842: Vi1 LCP: EndpointDisc 1 FR (0x1305014652) 

!--- Router FR at one end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: I CONFREQ [REQsent] id 14 len 20
*Mar 7 23:20:42.858: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.858: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.858: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D) 

!--- Router ATM at the other end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: O CONFACK [REQsent] id 14 len 20

*Mar 7 23:20:42.862: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.862: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.862: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D)
*Mar 7 23:20:42.870: Vi1 LCP: I CONFACK [ACKsent] id 197 len 19
*Mar 7 23:20:42.870: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.870: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.870: Vi1 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:42.870: Vi1 LCP: State is Open
*Mar 7 23:20:42.870: Vi1 PPP: Phase is FORWARDING, Attempting Forward
*Mar 7 23:20:42.874: Vi1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 7 23:20:42.874: Vi1 PPP: Phase is VIRTUALIZED
*Mar 7 23:20:42.942: Vi2 PPP: Phase is DOWN, Setup
*Mar 7 23:20:43.222: Vi1 IPCP: Packet buffered while building MLP bundle interface
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up 

!--- MLP level queuing.

*Mar 7 23:20:43.226: Vi2 PPP: Treating connection as a dedicated line
*Mar 7 23:20:43.226: Vi2 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:43.226: Vi2 LCP: O CONFREQ [Closed] id 1 len 19
*Mar 7 23:20:43.226: Vi2 LCP: MagicNumber 0xF4412A53 (0x0506F4412A53)
*Mar 7 23:20:43.226: Vi2 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:43.230: Vi2 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:43.230: Vi2 MLP: 
Added first link Vi1 to bundle ATM 

!--- PVCs make up the bundle.

*Mar 7 23:20:43.230: Vi2 PPP: Phase is UP
*Mar 7 23:20:43.230: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.234: Vi2 PPP: Pending ncpQ size is 1
*Mar 7 23:20:43.234: Vi1 IPCP: Redirect packet to Vi1
*Mar 7 23:20:43.234: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.234: Vi2 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.266: Vi2 IPCP: I CONFACK [ACKsent] id 1 len 10
*Mar 7 23:20:43.266: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.266: Vi2 IPCP: State is Open
*Mar 7 23:20:43.266: Vi2 IPCP: Install route to 10.1.1.1
*Mar 7 23:20:43.270: Vi2 IPCP: Add link info for cef entry 10.1.1.1

Esta salida de comando es del comando debug ppp multilink fragment.

*Mar 7 23:16:08.034: Vi2 MLP: 
Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi1 MLP: O frag 0000829B size 160 
*Mar 7 23:16:08.042: Vi1 MLP: I ppp IP (0021) size 64 direct
*Mar 7 23:16:08.046: Vi1 MLP: I ppp IP (0021) size 64 direct

Información Relacionada


Document ID: 22383