IP : Protocolo mejorado de routing de gateway interior (EIGRP)

El mensaje de error y los vecinos EIGRP/OSPF/BGP inestables del "%TUN-5-RECURDOWN" sobre un túnel GRE

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El %TUN-5-RECURDOWN: El tunnel0 inhabilitó temporalmente debido al mensaje de error del ruteo recursivo significa que el router del túnel del Generic Routing Encapsulation (GRE) ha descubierto un problema de ruteo recursivo. Esta condición es generalmente debido a una de estas causas:

  • Un misconfiguration que hace al router intentar rutear a la dirección de destino del túnel que usa la interfaz del túnel sí mismo (ruteo recursivo)

  • Una inestabilidad temporal causada por la inestabilidad de ruta a otra parte en la red

El estado de la interfaz del túnel depende del alcance de IP al destino del túnel. Cuando el router detecta una falla de ruteo recurrente para el destino del túnel, cierra la interfaz del túnel durante unos minutos de modo que la situación que causa el problema pueda resolverse mientras que convergen los Routing Protocol. Si el problema es causado por el misconfiguration, el link puede oscilar indefinidamente.

Otro síntoma de este problema es que vuelve inestables de manera continua a los vecinos del Protocolo de ruteo de gateway interior mejorado (EIGRP), de Abrir la ruta más corta primero (OSPF), o del Protocolo de la gateway marginal (BGP), cuando los vecinos se encuentran en un túnel GRE.

Este documento muestra un ejemplo de localizar averías una interfaz del túnel oscilante que sea EIGRP corriente.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no se limita a una versión específica de software o de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Diagrama de la red

El router1 (r1) y el router3 (R3) están conectados con el router2 (r2). La conectividad de la red es tal que el R1 puede alcanzar la interfaz de loopback del R3’ por medio del R2 y viceversa. EIGRP se ejecuta sobre la interfaz del túnel en R1 y R3. R2 no forma parte del dominio EIGRP.

/image/gif/paws/22327/gre_flap_01.gif

Configuraciones

R1
hostname R1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.1 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.3.3.3
!
interface Serial0
 ip address 172.16.15.1 255.255.255.0
 encapsulation ppp
!
router eigrp 1
 network 10.1.1.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.15.2

R3
hostname R3
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.3 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.1.1.1
!
interface Serial1
 ip address 172.16.25.3 255.255.255.0
!
router eigrp 1
 network 10.3.3.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.25.2

Observación

Observe estos mensajes de error en el r1 y el R3. El estado de la interfaz del túnel está oscilando continuamente en medio hacia arriba y hacia abajo.

01:11:39: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to up
01:11:48: %TUN-5-RECURDOWN:
          Tunnel0 temporarily disabled due to recursive routing
01:11:49: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to down
01:12:49: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to up
01:12:58: %TUN-5-RECURDOWN:
          Tunnel0 temporarily disabled due to recursive routing
01:12:59: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to down

Nota: Cada línea con impresión horaria de salida anterior del ejemplo aparece en una línea en la salida real.

Resolución de problemas

Ésta es la ruta al destino del túnel 10.3.3.3 en el r1 antes de que suba la interfaz del túnel:

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

El destino del túnel 10.3.3.3 extrae la ruta predeterminada a través de 172.16.15.2 (Serial 0).

Ahora, observe la tabla de ruteo después de que suba la interfaz del túnel, mostrada aquí:

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:00:00, Tunnel0
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.3.3.0 [90/297372416] via 192.168.1.3, 00:00:00, Tunnel0
C       10.1.1.0 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

La ruta al destino del túnel 10.3.3.3 es docta con el EIGRP, y su salto siguiente es interface tunnel 0.

En esta situación, el mejor trayecto al destino del túnel está a través de la interfaz del túnel; sin embargo, esto ocurre:

  1. El paquete se coloca en la cola de salida de la interfaz de túnel.

  2. La interfaz de túnel agrega un encabezado GRE al paquete y lo almacena en cola en el protocolo de transporte destinado a la dirección de destino de la interfaz del túnel.

  3. El IP mira para arriba la ruta a la dirección destino y aprende que está a través de la interfaz del túnel, que vuelve el paquete al paso 1 antedicho; por ello, hay un loop de ruteo recursivo.

Solución

Configure las Static rutas para el destino del túnel en el r1 y el R3.

R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0
R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1

Ahora, observe la ruta de IP en el r1, mostrado abajo.

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:01:08, Tunnel0
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
S       10.3.3.3/32 is directly connected, Serial0
D       10.3.3.0/24 [90/297372416] via 192.168.1.3, 00:01:08, Tunnel0
C       10.1.1.0/24 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

Una ruta estática más específica (10.3.3.3/32) es preferible a una ruta aprendida EIGRP menos específica (10.3.3.0/24) para el destino del túnel. La ruta estática más específica evita el loop de ruteo recursivo, la interfaz de túnel inestable y, como consecuencia, la inestabilidad de los vecinos EIGRP.

R1# show interfaces tunnel 0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  Internet address is 192.168.1.1/24
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive set (10 sec)
  Tunnel source 10.1.1.1 (Loopback0), destination 10.3.3.3

%Warning: Característica no soportada en hardware. Los paquetes del túnel serán conmutados por software

Se considera el mensaje cuando utilizan el mismo loopback o dirección física como la fuente para dos diversos túneles. Debido a esto, cada paquete va al procesador, en vez de ser hardware conmutado.

Este problema puede ser solucionado si usted utiliza a las direcciones secundarias en un Loopback Interface o si usted utiliza las interfaces múltiples del loopback para los direccionamientos de origen de túnel.

El paquete OSPF de saludo es enviado por un router sobre el túnel GRE pero no hace llega en el otro extremo del túnel.

En un OSPF habilitado la red, el r1 del router envía el paquete OSPF de saludo sobre el túnel GRE pero no es recibida por el router R3. Utilice el comando OSPF del IP del debug hola para hacer el debug de hola los eventos.

R1#debug ip ospf hello
May 31 13:58:29.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1
May 31 13:58:39.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1
May 31 13:58:49.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1


R3#debug ip ospf hello
May 31 15:02:07 ADT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.3
May 31 15:02:09 ADT: OSPF: Rcv hello from 172.16.15.1 area 0.0.0.12 from Tunnel0 192.168.1.1
May 31 15:02:09 ADT: OSPF: Send immediate hello to nbr 172.16.15.3, src address 192.168.1.3, on Tunnel0
May 31 15:02:09 ADT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.3

!--- The previous output shows that the hello packets
!--- re sent by R1 but not received by R3.

Solución

Configure el comando tunnel key en el túnel 10 de la interfaz en ambo el Routers. Este comando habilita el Multicast en el GRE.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 22327