Banda ancha por cable : Especificación de interfaz para servicios de datos por cable (DOCSIS)

Usando el comando cpe máximo en el DOCSIS y el CMTS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento explica la relación entre el nuevo comando cable modem max-cpe n y el parámetro MAX-CPE especificados en el archivo de configuración de Data-over-Cable Service Interface Specifications (DOCSIS). El archivo de configuración de DOCSIS se carga en el módem de cable, y se puede cifrar en el Routers de las uBR7200 Series que funciona con el Software Release 12.1(2)EC1 o Posterior del ½ del ¿Â de Cisco IOSïÂ.

Antes de comenzar

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

prerrequisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • La información en este documento se basa en el hardware procesador de Cisco uBR7246 (NPE150) (revisión B) y en el software del IOS de Cisco (UBR7200-IST-M), versión 12.1(2)EC1.

  • Este documento solamente hace referencia a cablemódems en modo de conexión en puente.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Antecedentes

Hay un pedido de los clientes de cable para que el Sistema de terminación del cablemódem (CMTS) permita que más CPE se conecten al cablemódem a pesar de que el valor en el archivo de configuración limita la cantidad de hosts. El cambio necesario para permitir que más CPE se conecten al cablemódem se hizo en CSCdp52029 (sólo para clientes registrados) en la versión 12.0(9.5)SC del software del IOS de Cisco y en los trenes IOS de la versión 12.1(1.0.3)EC1 del software del IOS de Cisco.

Esta demanda era creado debido al módem de cable que no podía guardar la cuenta de CPEs afectó un aparato en el synch con la cuenta CMTS. Cuando se inicia el cablemódem, éste sólo puede sincronizar MAX-CPE con el CMTS cuando envía el conteo del CEP de MAX al CMTS en el flujo de peticiones de registro.

Si el cablemódem se recarga, no hay flujo al CMTS para informarle que reduzca el conteo asignado de CPE a cero. Sin embargo, el cablemódem volverá a empezar de cero. Si un nuevo CPE detrás de las peticiones del módem de cable de venir en línea, el módem de cable lo permite a pues su cuenta MAX-CPE es cero ahora. El CMTS con una cuenta MAX-CPE sin ceros, sin embargo, fallará en el pedido y aparecerá el siguiente mensaje en el CMTS:

 
%UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
 and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

Esto es intensificada por el hecho de que, si está sin especificar, la entrada del valor por defecto MAX-CPE en el archivo de configuración de DOCSIS está fijada a uno.

Un ejemplo de esto es cuando el módem de cable informa al CMTS que tiene un conteo MAX-CPE igual a uno en su solicitud de registro. Un cliente de cable quiere la funcionalidad de restauración del ciclo de energía del cablemódem para permitir la extracción de la laptop de su instalador, y que luego la PC del usuario final sea vuelta a colocar en el cablemódem. Esto fallará porque. Después de que la recarga el módem de cable tenga la cuenta MAX-CPE fijada a cero, sin embargo, el CMTS todavía recordará la entrada de laptop del instalador, y que iguala la cuenta MAX-CPE de una.

Hay una solución alternativa disponible publicando el comando clear cable host x.x.x.x, donde x.x.x.x iguala el IP o la dirección MAC del host que se borrará en el CMTS. Sin embargo, esta solución alternativa no es muy popular entre los clientes de cable.

Instrumentación

Se ha agregado un nuevo comando de configuración al CMTS. Para especificar a un número máximo de host permitidos por el módem (que reemplaza el valor MAX-CPE en el archivo de configuración de cablemódem), publique el comando cable modem max-cpe n en el modo de configuración de la interfaz del cable. n iguala 1 a 255.

El CMTS habilita hasta una cantidad n de host para un cable módem. Cuando el conjunto a ilimitado, o a n es más grande que el valor MAX-CPE en el archivo de configuración de un módem de cable, este comando reemplaza el valor del archivo de configuración. El servidor DHCP controla la cantidad de direcciones IP asignadas a los host detrás de un único cable módem.

Si el archivo de configuración del cable módem especifica un número de host mayor que n, el valor del archivo de configuración tendrá precedencia. Están hasta el módem de cable para controlar el número de host activos.

Al ejecutar el comando cable modem max-cpe unlimited, el CMTS no exigirá un límite en la cantidad de CPE conectados a un único cable módem. Con esta configuración, el cable módem debe controlar la cantidad máxima de CPE y el servidor DHCP debe controlar la cantidad de direcciones IP asignadas a los CPE detrás de un mismo cable módem.

precaución Precaución: Si se lo usa sin cuidado el comando cable modem max-cpe unlimited puede provocar un agujero de seguridad en el sistema al habilitar los ataques de denegación del servicio. Específicamente, puede permitir a un usuario obtener un gran número de direcciones IP, tomando así toda la red luego de que todas las direcciones IP disponibles hayan sido reservadas por este sólo usuario. Por lo tanto, se recomienda que, si el comando ilimitado max-cpe del cablemódem está habilitado, el número de direcciones IP asignado a los CPE conectados a un único cablemódem esté estrictamente controlado por el servidor DHCP.

Publicando el comando no cable modem max-cpe, se habilita la configuración predeterminada. El valor MAX-CPE que se proporciona en el archivo de configuración será utilizado por CMTS para limitar la cantidad de CPE que se conectan a un único cablemódem.

El comando show cable modem detail visualiza el valor MAX-CPE como está configurado en el archivo de configuración de DOCSIS para el módem de cable, y si es posible, el valor configuró cuando se publica el módem de cable n cpe máxima.

Consulte el resultado del ejemplo de registro a continuación. CMTS está configurado para MAX-CPE en cuatro y MAX-CPE en ilimitado.

test-cmts#show cable modem detail 
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe 4
test-cmts(config)#end
test-cmts#
00:05:11: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe unli
test-cmts(config)#cable modem max-cpe unlimited 
test-cmts(config)#^Z 
test-cmts#
00:06:06: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95

test-cmts#wr t
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test-cmts
!
boot system flash ubr7200-ist-mz.121-2.EC1
no logging buffered
!
cable modem max-cpe 4
ip subnet-zero 
!
interface FastEthernet0/0
ip address 10.200.68.4 255.255.255.0
half-duplex
!
interface Cable4/0
ip address 10.200.69.49 255.255.255.240 secondary
ip address 10.200.69.33 255.255.255.240
ip accounting precedence input
ip accounting precedence output
no keepalive
cable max-hosts 10
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 rate-limit
cable upstream 5 shutdown
cable dhcp-giaddr policycable
helper-addrress 10.200.68.11
! 
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
ip route 10.200.32.0 255.255.224.0 10.200.68.2
no ip http server
!
line con 0
exec-timeout 0 0
password ww
login
transport input none
line aux 0
line vty 0 4
password ww
login
!
end

test-cmts#

Nota: Aunque el CMTS, permita al número especificado de host a través del Cable módems, el Cable módems ellos mismos todavía será restringido para permitir solamente el número de CPEs permitió en el archivo de configuración de DOCSIS.


Información Relacionada


Document ID: 22177