Calidad de servicio (QoS) : Marcación de paquetes QoS

Orden de Operación de Calidad de Servicio

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento ilustra la orden en la cual se ejecutan las características del Calidad de Servicio (QoS) cuando entrante o saliente aplicado a una interfaz en un router que funciona con el software del ½ del ¿Â de Cisco IOSïÂ. Las políticas de calidad de servicio (QoS) se configuran con la Interfaz de línea de comando modular QoS (MQC). Este documento también discute la marca del encabezado IP, tal como DSCP y Prioridad IP, y la orden en la cual los componentes de a política de calidad de servicio (QoS) son evaluados por el router.

prerrequisitos

Requisitos

Los Quien lea este documento deben tener conocimiento de:

  • Metodologías básicas de calidad del servicio

Componentes Utilizados

Capturaron a la salida de ejemplo en la sección de configuraciones de este documento en una plataforma de las Cisco 7513 Series que funciona con el Cisco IOS Software Release 12.2.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

clasificación típica

La clasificación es el proceso de definir las clases de tráfico que tráfico de la clase en los grupos de las categorías de flujos. La clasificación define los “criterios de concordancia” para cada clase de tráfico que deba ser tratada por a política de calidad de servicio (QoS). Más concretamente, define el “filtro de tráfico” ese los paquetes se marca contra cuando una servicio-directiva es aplicada.

Distribuido y las plataformas no distribuidas hacen juego los paquetes a una sola clase en un directiva-mapa. El corresponder con termina en la primera clase concordante. Si dos clases dentro de un directiva-mapa hacen juego la misma Prioridad IP o alcance del IP Address, el paquete pertenece siempre a la primera clase concordante. Por este motivo, la orden de la clase dentro de un directiva-mapa es muy importante.

Este método de clasificación se llama “clasificación típica” y tiene estas ventajas:

  • Contabilidad precisa y la evitación de los problemas de la Contabilidad doble que fueron considerados antes de la “clasificación típica”.

  • Reduce el impacto de las listas de control de acceso (ACL) en la CPU, debido a que la ACL se comprueba una vez por clase y no una vez por función.

  • Búsqueda más rápida de los encabezados de paquete debido al almacenamiento en memoria inmediata.

La clasificación típica se habilita automáticamente cuando usted asocia correspondencia de políticas (policy-map) de entrada o salida con el comando service-policy.

Esta tabla ilustra el orden de funcionamiento con la clasificación típica. Es importante entender de la tabla cuando la clasificación ocurre en el contexto de las características de QoS. En el trayecto entrante, un paquete se clasifica antes de ser conmutado. En el trayecto de salida, un paquete se clasifica luego de estar conmutado.

Entrante Saliente
  1. Propagación de la política de QoS a través del Protocolo de puerta de enlace de frontera (BGP) (QPPB)
  2. Clasificación de entrada común
  3. Entradas ACL
  4. Marcado de entrada (marcado basado en la clase o Velocidad de acceso comprometida (CAR))
  5. Regulación de tráfico de entrada (a través de un vigilante basado en la clase o CAR)
  6. Seguridad IP (IPSec)
  7. Cisco Express Forwarding (CEF) o Fast Switching
  1. CEF o Fast Switching
  2. Clasificación común de resultados
  3. ACL de salida
  4. Marca de la salida
  5. Regulación de tráfico de salida (a través de un vigilante basado en la clase o CAR)
  6. Espera (Mecanismo de cola de espera equitativo y ponderado basado en clases (CBWFQ) y low latency queueing (LLQ)), y Weighted Random Early Detection (WRED)

Nota: El Network-Based Application Recognition (NBAR) entrante sucede después de los ACL y antes del Policy-Based Routing.

Los cambios importantes se han implementado con respecto al uso del ordenamiento de las características y del valor observado. Estos cambios comprenden mover las funciones de contabilización CAR de entrada, MAC de entrada y precedencia IP para que se ejecuten antes de la clasificación de salida de MQC:

  • El límite de velocidad de ingreso, o CAR, se aplica a los paquetes que siguen la ruta de conmutación de procesos y que se dirigen hacia el router. Anteriormente, sólo los paquetes conmutados a través del router utilizando CEF podrían ser de velocidad limitada.

  • Los valores de precedencia IP nuevos establecidos por CAR o QPPB de entrada pueden utilizarse para seleccionar un circuito virtual (VC) en un conjunto ATM VC.

  • Se pueden utilizar para la clasificación de paquetes de salida MQC la precedencia IP, los Puntos de código de servicios diferenciados (DSCP) y los valores del grupo QoS (Calidad de servicio) configurados por CAR o QPPB de entrada.

Marcación y otras acciones de calidad de servicio (QoS) en el mismo router

Una aplicación frecuente de QoS es la de remarcar un paquete y luego aplicar una acción que considera el valor remarcado en la misma interfaz o en el mismo router. Usted puede configurar la marca y las otras acciones QoS con la clasificación típica.

Puede marcar nuevamente los paquetes con estas funciones QoS:

  • comando set con el Marcado basado en clases

  • comando police con el class-based policing

  • CAR

Esta tabla indica si un valor remarcado será considerado o no por una acción de Calidad de servicio (QoS) en una política de servicio.

Ubicación de la política Valor usado por las acciones de política de salida.
Marque y aplique la acción de QoS en la misma directiva. Las acciones QoS usan el valor original del paquete cuando se clasifica comúnmente. El paquete transportará el valor nuevo cuando se transmita y el próximo router utiliza el valor nuevo.
Marcar con políticas de entrada y aplicar acciones de Calidad de servicio (QoS) con políticas de salida. Las acciones de QoS utilizan el nuevo o el valor observado al clasificar el tráfico contra la política de salida.

En el trayecto de salida, se produce la clasificación común antes de aplicar cualquiera de las características QoS. Un resultado de este enfoque es que cualquier función de QoS aplicada a la política de salida actúa sobre el valor de prioridad original. Si quiere tomar medidas que se basan en un valor observado en el mismo router, entonces deberá marcar los paquetes en la interfaz de entrada y aplicar otras medidas de Calidad de servicio (QoS) que se basen en esta nueva prioridad en la interfaz saliente.

Diagrama de la red

La configuración en esta sección utiliza este diagrama de red:

/image/gif/paws/22141/qos_orderofop_3b.gif

Nota: El (MSFC) de la Multilayer Switch Feature Card está actuando como host.

Configuraciones

Este ejemplo demuestra cómo la orden de operaciones puede afectar la marcación de un paquete.

Configuración de la marcación diferenciada y la política de modelado
class-map match-all In_Mark
   match any 
policy-map In_Bound
  class In_Mark
    set ip precedence 5 

!--- Use Private address below:

interface FastEthernet4/0/0 
 ip address  10.20.3.2 255.255.255.0
ip route-cache distributed  
 service-policy input In_Bound

!--- Apply the input policy for class-based marking.

  
class-map match-all Out_Shaper
match ip precedence 5 
! 
policy Map Outbound_Shaper
class  Out_Shaper 
    shape average 64000 256 256 

!--- Use Private address below:

interface Serial2/0/0 
 ip address 172.16.20.1 255.255.255.252
ip route-cache distributed 
 service-policy output Outbound_Shaper

!--- Apply the output policy for class-based shaping.

Complete estos pasos para confirmar la marca y las políticas de modelado:

  1. Use el comando ping hacia la dirección de destino 172.16.20.2. El ping hace juego los criterios del clase-mapa nombrado “In_Mark”.

    msfc#ping 172.16.20.2
      
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 40.1.44.2, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
  2. Use el comando show policy-map interface fast 4/0/0 para visualizar los contadores de concordancia de las políticas de marcación basada en la clase de entrada. El mecanismo de clasificación es igualado con éxito en los paquetes de IP y el valor de precedencia IP se remarca a cinco.

    7513#show policy-map interface fast 4/0/0 
     FastEthernet4/0/0 
      Service-policy input: In_Bound
     
        Class-map: In_Mark (match-all) 
          5 packets, 570 bytes 
          5 minute offered rate 0 bps, drop rate 0 bps 
          Match: any 
          QoS Set 
            ip precedence 5 
              Packets marked 5
     
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any
  3. Use el comando show policy-map interface serial 2/0/0 para visualizar los contadores de concordancia de las políticas de moldeado basado en la clase de salida. El mecanismo de clasificación está igualado exitosamente en el valor de precedencia cinco en el IP remarcado del encabezado del paquete y colocó los paquetes en la cola de la clase correcta.

    7513#show policy-map interface serial 2/0/0 
     Serial2/0/0 
    
      Service-policy output: Outbound_Shaper
    
        Class-map: Out_Shaper(match-all) 
          5 packets, 520 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPSMatch: ip precedence 5 
          queue size 0, queue limit 16 
          packets output 5, packet drops 0 
          tail/random drops 0, no buffer drops 0, other drops 0 
          Shape: cir 64000,  Bc 256,  Be 256 
            output bytes 520, shape rate 0 BPS 
    
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any  (1327)

Usted puede ver qué sucede cuando configuramos una sola servicio-directiva que aplique el shaping y la marca a una clase de tráfico, como en este ejemplo.

Configuración de la política de modelado y marcación única
class-map match-all prec5 
  match any 
! 
policy-map shape_five
  class prec5 
    set ip precedence 5 
    shape average 64000 256 256
int serial1/0/0
  service-policy out shape_five

El resultado del comando show policy-map interface serial 2/0/0 muestra que el router remarcó los últimos cinco paquetes ping, pero los paquetes estuvieron en cola para la clase class-default. Los mecanismos de clasificación de calidad de servicio (QoS) en este router no tomaron en cuenta el valor remarcado en el campo de precedencia IP.

7513#show policy-map interface serial 2/0/0 
 Serial2/0/0
  
  Service-policy output: shape_five
 
    Class-map: prec5 (match-all) 
      0 packets, 0 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match:  any
      queue size 0, queue limit 16 
      packets output 0, packet drops 0 
      tail/random drops 0, no buffer drops 0, other drops 0 
      QoS Set 
        ip precedence 5 
          Packets marked 5 
      Shape: cir 64000,  BC 256,  Be 256 
        output bytes 0, shape rate 0 BPS 

    Class-map: class-default (match-any) 
      5 packets, 520 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match: any

Información Relacionada


Document ID: 22141