Switches : Switches Cisco Catalyst de la serie 4500

Procedimiento para recuperación de contraseña para el módulo del Supervisor Engine II+/II+TS/II+10GE/III/IV/V/V 10GE del Catalyst 4500/4000 y Catalyst 4900 Switch que funcionan con el Cisco IOS Software

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo recuperar un perdido o una contraseña desconocida en un Switch del Catalyst 4500/4000 con el módulo del V-10GE de un Supervisor Engine II-Plus (WS-X4013+), del Supervisor Engine Ii-Más-TS (WS-X4013+TS), del Supervisor Engine II-Plus-10GE (WS-X4013+10GE), del Supervisor Engine III (WS-X4014), del Supervisor Engine IV (WS-X4515), del Supervisor Engine V (WS-X4516), del Supervisor Engine (WS-X4516-10GE), el Cisco Catalyst 4948, Cisco Catalyst 4948 10GE, y los Cisco Catalyst 4900M Switch.

Nota: En el Switches de las 4500/4000 Series del Catalyst, los motores II+ del supervisor, II+10GE, II+TS, III, IV, V, y motores solamente de Cisco IOS� del soporte del V-10GE del software y del supervisor I e II soporte solamente el software OS Catalyst. Para recuperar la contraseña en los motores del supervisor I o II, refiere al procedimiento para recuperación de contraseña para el Catalyst 1200, 1400, 2901, 2902, 2926T/F, 2926GS/L, 2948G, 2980G, 4000, 5000, 5500, 6000, 6500 CatOS que se ejecuta.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Procedimiento Paso a Paso

Complete estos pasos para recuperar su contraseña:

Nota: Aseegurese que usted tiene acceso físico al Switch y que usted utiliza el acceso a la consola al módulo de Supervisor Engine mientras que usted realiza estos pasos. Para los detalles en la conexión de consola del Switch, refiera a conectar un módem con el puerto de la consola en los switches de Catalyst.

Consejo: La configuración del Switch no se pierde si el procedimiento se sigue según lo mencionado. Como mejor práctica, Cisco recomienda que usted tiene una copia de backup de la configuración de todos los dispositivos de Cisco en el servidor TFTP o un Network Management Server.

  1. Ciclo del poder el dispositivo.

    Para accionar el ciclo, apague el dispositivo, entonces detrás encendido.

    Presione el Ctrl-c en el plazo de 5 segundos para prevenir el autoboot. Esta acción le pone en el modo de prompt del monitor de la memoria ROM (ROMmon).

    
    !--- Here, you power cycle the switch.
    
    ********************************************************** 
     *                                                        * 
     * Welcome to ROM Monitor for WS-X4014 System.            * 
     * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
     * All rights reserved.                                   * 
     *                                                        * 
     **********************************************************
     
     ROM Monitor Program Version 12.1(10r)EY(1.21) 
    
     Board type 1, Board revision 7
     Swamp FPGA revision 16, Dagobah FPGA revision 43 
     
     Timer interrupt test passed.
    
     MAC Address  : 00-02-b9-83-af-fe 
     IP Address   : 172.16.84.122 
     Netmask      : 255.255.255.0 
     Gateway      : 172.16.84.1 
     TftpServer   : Not set. 
     Main Memory  : 256 MBytes
    
    
     ***** The system will autoboot in 5 seconds *****
    
    
     Type control-C to prevent autobooting. 
    
    !--- At this point, press Ctrl-C.
    
    Autoboot cancelled......... please wait!!!
    Autoboot cancelled......... please wait!!!
    rommon 1 > [interrupt]  
    
    !--- The module ended in the ROMmon.
    
    rommon 1 > [interrupt]
  2. Publique el comando confreg en el prompt ROMMON.

    Haga las selecciones que aparecen aquí en la negrilla para la recuperación de contraseña:

    rommon 1 > set
    
    rommon 1 > confreg
    
     Configuration Summary : 
     => load ROM after netboot fails
     => console baud: 9600
     => autoboot from: commands specified in 'BOOT' environment variable
    
     do you wish to change the configuration? y/n  [n]:  y
     enable  "diagnostic mode"? y/n  [n]:  n
     enable  "use net in IP bcast address"? y/n  [n]:  n
     disable "load ROM after netboot fails"? y/n  [n]:  n
     enable  "use all zero broadcast"? y/n  [n]:  n
     enable  "break/abort has effect"? y/n  [n]:  n
     enable  "ignore system config info"? y/n  [n]:  y
    
     change console baud rate? y/n  [n]:  n
    
     change the boot characteristics? y/n  [n]:  n
    
     Configuration Summary : 
     => load ROM after netboot fails
     => ignore system config info
     => console baud: 9600
     => autoboot from: commands specified in 'BOOT' environment variable
    
     do you wish to save this configuration? y/n  [n]:  y
     You must reset or power cycle for new configuration to take effect
    

    Nota: Usted puede también utilizar el comando confreg 0x2142 en el prompt ROMMON para fijar el valor del registro de la configuración para desviar la configuración de inicio salvada en el NVRAM.

    rommon 1 >confreg 0x2142
    You must reset or power cycle for the new configuration to take effect.
  3. Publique el comando reset de modo que el módulo reinicie.

    Debido a los cambios que usted realizó en el paso 2, el módulo reinicia pero ignora la configuración guardada.

    rommon 2 > reset
    
    Resetting .......
    
    rommon 3 >
    
     ********************************************************** 
     *                                                        * 
     * Welcome to ROM Monitor for WS-X4014 System.            * 
     * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
     * All rights reserved.                                   * 
     *                                                        * 
     **********************************************************
    
    !--- Output suppressed.
    
    Press RETURN to get started! 
    
    !--- Press Return.
    
    00:00:21: %SYS-5-RESTART: System restarted --
    Cisco Internetwork Operating System Software 
    IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), 
       Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    00:00:21: %SNMP-5-COLDSTART: SNMP agent on host Switch 
       is undergoing a cold start
    Switch>
  4. Aseegurese que el valor del registro de la configuración es 0x2142.

    Este valor hace el arranque del módulo del Flash sin una carga de la configuración guardada. Publique el comando enable en el prompt del Switch de ir al enable mode. Entonces, publique el comando show version de marcar el valor del registro de la configuración.

    Switch> enable
    Switch#show version
    Cisco Internetwork Operating System Software 
    IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
       Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    Image text-base: 0x00000000, data-base: 0x00AA2B8C
    
    ROM: 12.1(10r)EY(1.21)
    Switch uptime is 5 minutes
    System returned to ROM by reload
    Running default software
    
    cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
    Processor board ID FOX04183666
    Last reset from Reload
    32 Gigabit Ethernet/IEEE 802.3 interface(s)
    467K bytes of non-volatile configuration memory.
    
    Configuration register is 0x2142
    
    Switch#
  5. Publique el comando configure memory o el comando copy startup-config running-config de copiar el NVRAM en la memoria.

    No publique el comando configure terminal, que muestra la configuración predeterminada en el módulo.

    Switch#configure memory
    
    Uncompressed configuration from 1307 bytes to 3014 bytes
    Switch#
    00:13:52: %SYS-5-CONFIG_I: Configured from memory by console
    c-4006-SUPIII#
  6. Publique el comando show ip interface brief de aseegurarse que las interfaces que eran demostración anterior funcionando al estatus del up up.

    Si es un de los las interfaces que eran funcionando antes de la demostración de la recuperación de contraseña “abajo”, publican el comando no shutdown en esa interfaz de sacar a colación la interfaz.

  7. Publique el comando write terminal o el comando show running-config de visualizar la configuración guardada en el módulo.

    c-4006-SUPIII#show running-config 
    Building configuration...
    
    Current configuration : 3014 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname c-4006-SUPIII
    !
    boot system flash bootflash:
    !
    vtp mode transparent
    
    !--- Output suppressed.
    
    line con 0
     stopbits 1
    line vty 0 4
     login
    !
    end
    
    c-4006-SUPIII#

    Ahora ya puede cambiar la contraseña en el módulo.

  8. Publique estos comandos de cambiar la contraseña:

    c-4006-SUPIII#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    c-4006-SUPIII(config)#no enable secret
    
    !--- This step is necessary if the switch had an enable 
    !--- secret password.
    
    
    c-4006-SUPIII(config)#enable secret < password > 
    [Choose a strong password with at least one capital letter,
     one number, and one special character.]
    
    !--- This command sets the new password.
    
    
  9. Aseegurese que usted cambia el valor del registro de la configuración de nuevo a 0x2102.

    Complete estos pasos en el prompt de los config para cambiar y para verificar el valor del registro de la configuración.

    c-4006-SUPIII(config)#config-register 0x2102
    c-4006-SUPIII(config)# ^Z
    c-4006-SUPIII#
    00:19:01: %SYS-5-CONFIG_I: Configured from console by console
    c-4006-SUPIII#write memory 
    
    !--- This step saves the configuration.
    
    Building configuration...
    Compressed configuration from 3061 bytes to 1365 bytes[OK]
    c-4006-SUPIII#show version 
    
    !--- This step verifies the value change.
    
    Cisco Internetwork Operating System Software 
    IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M), 
    Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    Image text-base: 0x00000000, database: 0x00AA2B8C
    
    ROM: 12.1(10r)EY(1.21)
    c-4006-SUPIII uptime is 20 minutes
    System returned to ROM by reload
    Running default software
    
    cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
    Processor board ID FOX04183666
    Last reset from Reload
    32 Gigabit Ethernet/IEEE 802.3 interface(s)
    467K bytes of nonvolatile configuration memory.
    
    Configuration register is 0x2142 (will be 0x2102 at next reload)
    
    c-4006-SUPIII#

    En este momento, usted ha cambiado la contraseña.

Procedimiento de ejemplo/salida de muestra

Esta salida de muestra es el resultado del procedimiento para recuperación de contraseña en un Catalyst 4000 Supervisor Engine III.

c-4006-SUPIII> enable
Password: 
Password: 
Password: 
% Bad secrets 

!--- Here, you power cycle the switch.

********************************************************** 
 *                                                        * 
 * Welcome to ROM Monitor for WS-X4014 System.            * 
 * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
 * All rights reserved.                                   * 
 *                                                        * 
 **********************************************************
 
 ROM Monitor Program Version 12.1(10r)EY(1.21) 

 Board type 1, Board revision 7
 Swamp FPGA revision 16, Dagobah FPGA revision 43 
 
 Timer interrupt test passed.

 MAC Address  : 00-02-b9-83-af-fe 
 IP Address   : 172.16.84.122 
 Netmask      : 255.255.255.0 
 Gateway      : 172.16.84.1 
 TftpServer   : Not set. 
 Main Memory  : 256 Mbytes


 ***** The system will autoboot in 5 seconds *****

 Type control-C to prevent autobooting. 

!--- At this point, press Ctrl-C.


Autoboot cancelled......... please wait!!!
Autoboot cancelled......... please wait!!!
rommon 1 > [interrupt]

rommon 1 > [interrupt]

rommon 1 > confreg

 Configuration Summary : 
 => load ROM after netboot fails
 => console baud: 9600
 => autoboot from: commands specified in 'BOOT' environment variable

 do you wish to change the configuration? y/n [n]:  y
 enable "diagnostic mode"? y/n [n]:  n
 enable "use net in IP bcast address"? y/n [n]:  n
 disable "load ROM after netboot fails"? y/n [n]:  n
 enable "use all zero broadcast"? y/n [n]:  n
 enable "break/abort has effect"? y/n [n]:  n
 enable "ignore system config info"? y/n [n]:  y

 change console baud rate? y/n [n]:  n

 change the boot characteristics? y/n [n]:  n

 Configuration Summary : 
 => load ROM after netboot fails
 => ignore system config info
 => console baud: 9600
 => autoboot from: commands specified in 'BOOT' environment variable

 do you wish to save this configuration? y/n [n]:  y
 You must reset or power cycle for new configuration to take effect

rommon 2 > reset

Resetting .......


rommon 3 >

 ********************************************************** 
 *                                                        * 
 * Welcome to ROM Monitor for WS-X4014 System.            * 
 * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
 * All rights reserved.                                   * 
 *                                                        * 
 **********************************************************
 
 ROM Monitor Program Version 12.1(10r)EY(1.21) 

 Board type 1, Board revision 7
 Swamp FPGA revision 16, Dagobah FPGA revision 43 
 
 Timer interrupt test passed.

 MAC Address  : 00-02-b9-83-af-fe 
 IP Address   : 172.16.84.122 
 Netmask      : 255.255.255.0 
 Gateway      : 172.16.84.1 
 TftpServer   : Not set. 
 Main Memory  : 256 Mbytes

 ***** The system will autoboot in 5 seconds *****


 Type control-C to prevent autobooting.
 . . . . .

 ******** The system will autoboot now ********


 config-register = 0x2142 
 Autobooting using BOOT variable specified file.....

 Current BOOT file is --- bootflash: 

Rommon reg: 0x2B004180
Decompressing the image : ###########################
#####################################################
####################################### [OK]

k2diags version 1.6

prod: WS-X4014  part: 73-6854-07  serial: JAB0546060Z

Power-on-self-test for Module 1:  WS-X4014
Status: (. = Pass, F = Fail)

Traffic using serdes loopback (L2; one port at a time)...
switch port 0: .       switch port 1: .       switch port 2: .       
switch port 3: .       switch port 4: .       switch port 5: .       
switch port 6: .       switch port 7: .       switch port 8: .       

!--- Output suppressed.

Module 1 Passed


Exiting to ios...

Rommon reg: 0x2B000180
Decompressing the image : ##########################

!--- Output suppressed.

######################################################### [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.


Press RETURN to get started!


00:00:21: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
00:00:21: %SNMP-5-COLDSTART: SNMP agent on host Switch is undergoing a cold start
Switch> enable
Switch# show version
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

ROM: 12.1(10r)EY(1.21)
Switch uptime is 5 minutes
System returned to ROM by reload
Running default software

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.

Configuration register is 0x2142

Switch#

Switch#configure memory

Uncompressed configuration from 1307 bytes to 3014 bytes
c-4006-SUPIII#
00:13:52: %SYS-5-CONFIG_I: Configured from memory by console
c-4006-SUPIII#show running-config 
Building configuration...

Current configuration : 3014 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname c-4006-SUPIII
!
boot system flash bootflash:
!
vtp mode transparent
!
vlan 20
  private-vlan primary
!
vlan 100
!
vlan 202
  private-vlan association 440
!         
vlan 440
  private-vlan isolated
!
vlan 500
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
!
!
interface GigabitEthernet1/1
 no switchport
 ip address 10.1.1.1 255.255.255.0
 ip pim dense-mode
!
interface GigabitEthernet1/2
 no switchport
 ip address 20.1.1.1 255.255.255.0
!

!--- Output suppressed.

!
interface Vlan1
 ip address 172.16.84.140 255.255.255.0
 ip pim dense-mode
!
interface Vlan2
 no ip address
 shutdown
!
interface Vlan20
 no ip address
 shutdown
!

!--- Output suppressed.

!         
line con 0
 stopbits 1
line vty 0 4
 login
!
end

c-4006-SUPIII#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
c-4006-SUPIII(config)#no enable secret

!--- This step is necessary if the switch had 
!--- an enable secret password.

c-4006-SUPIII(config)#enable secret < password > 
[Choose a strong password with at least one capital letter, 
one number, and one special character.]
c-4006-SUPIII(config)#config-register 0x2102
c-4006-SUPIII(config)#^Z
c-4006-SUPIII#
00:19:01: %SYS-5-CONFIG_I: Configured from console by console
c-4006-SUPIII#write memory
Building configuration...
Compressed configuration from 3061 bytes to 1365 bytes[OK]
c-4006-SUPIII#show version
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

ROM: 12.1(10r)EY(1.21)
c-4006-SUPIII uptime is 20 minutes
System returned to ROM by reload
Running default software

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.

Configuration register is 0x2142 (will be 0x2102 at next reload)

c-4006-SUPIII#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 21229