Switching de LAN : EtherChannel

Configuración de EtherChannel entre Switches Catalyst que Ejecutan Software de Sistema Cisco IOS y un Router Cisco

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Esta configuración de muestra demuestra cómo configurar un EtherChannel de la capa 3 (L3), sin el VLAN Trunking, entre un router Cisco y un Cisco Catalyst 6500 Switch que funcionan con el software del sistema de Cisco IOS�. El EtherChannel se puede llamar Fast EtherChannel (FEC) o Gigabit EtherChannel (GEC); el término depende de la velocidad de las interfaces o de los puertos que utilice para formar el EtherChannel. En este ejemplo, dos puertos Fast Ethernet de un router Cisco y un switch Catalyst 6500 fueron unidos en FEC. A lo largo de este documento, los términos FEC, GEC, canal de puerto, canal y grupo de puertos hacen referencia al EtherChannel.

Este documento incluye solamente los archivos de configuración del Switch y del router, y la salida de los ejemplos de comandos show relacionados.

prerrequisitos

Requisitos

Antes de utilizar esta configuración, asegúrese de que cumple con los siguientes requisitos:

  • Catalyst 6500/6000 y Switches de las 4500/4000 Series que funciona con el Cisco IOS Software:

    • El Catalyst 6500/6000 y el Switches de las 4500/4000 Series que funciona con el Cisco IOS Software soportan EtherChannel capa 2 (L2) y L3, con hasta ocho compatible interfaces Ethernet configurada en cualquier módulo. Todas las interfaces en cada EtherChannel deben ser la misma velocidad. Se deben configurar todo como las interfaces L2 o L3.

    • El equilibro de cargas de EtherChannel puede utilizar direcciones MAC, direcciones IP o los números de puerto TCP.

      Nota: El modo seleccionado se aplica a todos los EtherChannels configurados en el switch.

    • Cisco IOS Software Release 12.1E o Posterior del Catalyst 6500/6000 y Cisco IOS Software Release 12.1(8a)EW o Posterior del Catalyst 4500/4000.

  • Routeres Cisco:

    • El tráfico IP distribuye sobre la interfaz del Canal de puerto mientras que el tráfico de otros Routing Protocol envía sobre un solo link. El tráfico Bridged distribuye en base de la información L3 en el paquete. Si la información L3 no existe en el paquete, el tráfico envía sobre el primer link.

  • Una amplia variedad de routeres Cisco soportan el EtherChannel. Para encontrar una plataforma o una versión del código que soporten el EtherChannel en un router Cisco, utilice el Cisco Feature Navigator II (clientes registrados solamente). Una lista de Routers y de versiones de Cisco IOS Software que soporten el EtherChannel se encuentra bajo característica FEC.

Para los requisitos de hardware y de software para el EtherChannel en los otros productos de Cisco, refiera a los requisitos del sistema para implementar el EtherChannel en los switches de Catalyst.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco IOS Software Release 12.1(8b)E10 corriente del Catalyst 6500 Switch

  • Cisco IOS Software Release 12.1(21) corriente del Cisco 7500 Router

La configuración del switch en este documento se aplica a cualquier switch Catalyst serie 6500/6000 y 4500/4000 que ejecute el software del IOS de Cisco.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Nota: La ejecución del comando write erase eliminó las configuraciones de todos los dispositivos para garantizar que tuvieran una configuración predeterminada. Aseegurese para recargar los dispositivos después de que usted publique el comando write erase de vaciar todas las configuraciones no predeterminadas.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Notas importantes

Si usted publica inicialmente el comando channel-group bajo interfaz física, crea automáticamente la interfaz de canal de puerto. Si usted configuró la interfaz de canal de puerto antes de que usted canalizara las interfaces físicas, quite la interfaz de canal de puerto primero. Esto es importante sólo en los switches Catalyst. El orden de los cambios de configuración en el router 7500. Usted debe configurar la interfaz de canal de puerto antes de que usted configure el grupo del the�channel bajo interfaz física.

El orden de configuración de un canal de puerto en los Catalyst 6500/6000 y el software del IOS de Cisco 4500/4000 es importante. Es el mejor publicar cualquier comando switchport antes de que usted publique el comando channel-group en una interfaz física.

Cuando usted publica el comando channel-group antes del comando switchport en una interfaz física (interfaz Gigabit Ethernet 1/1), la interfaz de canal de puerto se crea automáticamente y se convierte en una interfaz L3. Si usted entonces publica el comando switchport bajo interfaz física, la interfaz física se convierte en una interfaz L2. También, la interfaz de canal de puerto que usted creó anterior no tiene ninguna interfaz física asociada a ella. Note que el comando channel-group está ausente de debajo la interfaz física. En este caso, usted debe primero publicar el comando switchport bajo interfaz de canal de puerto nuevamente configurada. Entonces, el puerto físico valida el comando channel-group otra vez. En este caso, el Canal de puerto ha cambiado de una interfaz L3 a una interfaz L2.

Considere, en cambio, si usted publica el comando switchport primero en una interfaz física y después agrega el comando channel-group. En este caso, la interfaz de canal de puerto se crea y hereda automáticamente todos los comandos configured switchport.

En un Cisco IOS Software corriente del Switch del Catalyst 6500/6000, todos los puertos son los puertos L3 por abandono. En un Cisco IOS Software corriente del Switch del Catalyst 4500/4000, todos los puertos son los puertos L2 por abandono.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/21066/135-a.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Nota: Los comentarios y las explicaciones aparecen en los en color azules y en cursiva.

Catalyst 6500 Switch (sin VLAN Trunking)
Building configuration...
�
Current configuration : 5869 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8b.E15.bin
boot bootldr bootflash:c6msfc-boot-mz.121-8b.E15
enable password ww
!
redundancy
�main-cpu
� auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!

!--- In this example, you configure L3 EtherChannel.
!--- For more details, refer to this document:
!--- Configuring EtherChannels.
!--- A logical port-channel interface is automatically created�
!--- when ports are grouped into a channel group.


interface Port-channel 1
�ip address 11.1.1.2 255.255.255.0
 duplex full
 speed 100

!--- If you specify the speed and duplex setting at the port channel 
!--- level, these settings pass down to the physical ports.
!--- In other words, the physical ports inherit the same speed 
!--- and duplex settings as the port-channel interface.

 hold-queue 300 in
!
interface GigabitEthernet1/1
�no ip address
�shutdown
!
interface GigabitEthernet1/2
�no ip address
�shutdown
!
interface FastEthernet3/1
 no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (Port Aggregation Protocol [PAgP]), so PAgP
!--- needs to be disabled. On a Catalyst 4500/4000 switch, all ports are
!--- L2 ports by default. Convert this port from a physical L2 port to
!--- a physical L3 port with the no switchport command.

channel-group 1 mode on

interface FastEthernet3/2
�no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (PAgP), so PAgP needs to be disabled.
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default. 
!--- Convert this port from a physical L2 port to a physical L3 port 
!--- with the no switchport command.


channel-group 1 mode on


interface FastEthernet3/3
�no ip address
�switchport
�switchport mode access
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
�transport input none
line vty 0 4
!
end

Cisco 7500 Router (sin VLAN Trunking)

!--- Output suppressed.

!
interface Port-channel1
�ip address 11.1.1.1 255.255.255.0
 full-duplex
�hold-queue 300 in
!
interface FastEthernet0/0
�no ip address
�full-duplex
 speed 100
�channel-group 1
!
interface FastEthernet0/1
�no ip address���
�full-duplex
 speed 100���������������������������� �
�channel-group 1

!--- Output suppressed.

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

Comandos show

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre el canal del puerto del ID del canal del EtherChannel — Para marcar el Canal de puerto en un Switch del Cisco IOS.

  • muestre el ID del canal del canal del puerto de las interfaces — Para marcar el Canal de puerto en un router del Cisco IOS.

Ejemplo de Resultado del Comando show

Switch del Catalyst 6500/6000

  • muestre el canal del puerto del ID del canal del EtherChannel

Router#show etherchannel 1 port-channel
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 01h:56m:20s

Logical slot/port = 10/1 Number of ports in agport = 2
GC = 0x00010001 HotStandBy port = null
Passive port list = Fa3/1 Fa3/2
Port state = Port-channel L3-Ag Ag-Inuse
Ports in the Port-channel:
Index Load Port
-------------------
0 55 Fa3/1
1 AA Fa3/2
Time since last port bundled: 01h:55m:44s Fa3/2
Router#

Router Cisco 7500

  • ID de canal de show interfaces port-channel

Router#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia 0000.0000.0000)
Internet address is 11.1.1.1/24
MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 62/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
ARP type: ARPA, ARP Timeout 04:00:00
No. of members in this fechannel: 2
Member 0 : FastEthernet0/0
Member 1 : FastEthernet0/1
Last input never, output never, output hang never
Last clearing of "show interface" counters 10:51:55
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/300, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 98281000 bits/sec, 8762 packets/sec
4545 packets input, 539950 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast
0 input packets with dribble condition detected
342251216 packets output, 3093422680 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 21066