Voz : Calidad de voz

Resolución de problemas de voz irregular de QoS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido

VAD

Introducción

Para que los paquetes de voz sean un reemplazo realista para los servicios de telefonía de red telefónica conmutada pública (RTCP), la calidad de recepción de los paquetes de voz debe ser comparable a la de los servicios básicos de telefonía. Esto significa transmisiones de voz de alta calidad de manera consistente. Como otras aplicaciones en tiempo real, los paquetes de voz tienen un ancho de banda amplio y son sensibles al retardo. Para que las transmisiones de voz sean inteligibles (no se entrecorten) para el receptor, los paquetes de voz no se pueden perder, retardarse mucho ni sufrir retardos variables (conocidos también como fluctuaciones). Este documento describe varias consideraciones de calidad de servicio (QoS) que ayudan a solucionar los problemas de voz entrecortada. Los motivos principales de problemas de voz entrecortada son los paquetes perdidos o demorados.

prerrequisitos

Requisitos

Los Quien lea este documento deben estar bien informados de éstos:

  • Configuración básica de los paquetes de voz (VoIP, voz sobre Frame Relay (VoFR) o Voz por ATM (VoATM) según su requisito).

  • Comprensión básica de priorización de voz, fragmentación, diferentes códecs y sus requerimientos de ancho de banda.

Componentes Utilizados

La información en este documento aplica a todos los gatewayes de voz de Cisco las versiones de software y hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Causas de la voz irregular

La calidad de voz entrecortada la causan los paquetes de voz que están retrasados de diversas formas o perdidos en la red. Cuando un paquete de voz se retrasa al alcanzar su destino, la gateway de destino sufre una pérdida de información de tiempo real, En este evento, el gateway de destino debe predecir lo que puede posiblemente ser el contenido del paquete faltado. La predicción lleva a la voz recibida que no tiene las mismas características que la Voz transmitida. Esto lleva a una voz recibida que ése suena robótico. Si un paquete de voz se demora más allá de la capacidad de predicción de una gateway de recepción, esta última deja vacío el intervalo de tiempo real. Con nada llenar ese intervalo en el extremo receptor, pierden a la parte del discurso transmitido. Esto da lugar a la voz entrecortada. Muchos de los problemas de la voz entrecortada son resueltos aseegurandose que los paquetes de voz muy no están retrasados (y más que eso, no no variable retrasado). A veces, la detección de actividad de la Voz (VAD) agrega el recorte de extremo final a una conversación de la Voz. Ésta es otra causa (o acortado) de la Voz picada.

Las diversas secciones en este documento muestran cómo minimizar el caso de la voz entrecortada. La mayor parte de estas medidas requieren asegurar la introducción del jitter mínimo en su red de voz.

Requisito de ancho de banda

Antes de que usted considere aplicar cualquier medida para el jitter de reducción al mínimo, provision el suficiente ancho de banda de la red para soportar el tráfico de voz en tiempo real. Por ejemplo, una llamada VoIP de G.711 del kbps 80 (64 payload del kbps + encabezado del kbps 16) suena pobre sobre un link de kbps 64 porque por lo menos 16 kbps de los paquetes (que sea el 20 por ciento) se caen. Los requerimientos de ancho de banda varían basado en el codificador-decodificador usado para la compresión. Códecs diferentes tienen cargas útiles y requisitos de encabezamiento diferentes. El uso del VAD también afecta a los requerimientos de ancho de banda. Si se utiliza la compresión del encabezamiento del Real-Time Protocol (RTP) (cRTP), puede bajar más lejos los requerimientos de ancho de banda.

Por ejemplo, el ancho de banda requerido para una llamada de voz usando el codificador-decodificador de G.729 (carga útil de bytes del valor por defecto 20) con el cRTP, es como esto:

  • La carga útil de voz + comprimió (encabezado de la encabezado +IP del encabezado RTP + del User Datagram Protocol (UDP)) la encabezado +Layer 2

Esto es equivalente a:

  • 20 bytes + comprimieron (12 bytes + 8 bytes + 20 bytes) + 4 bytes

Esto iguala:

  • 28 bytes, puesto que la compresión del encabezamiento reduce el encabezado IP RTP a un máximo de 4 bytes. Esto produce un resultado de 11.2 kbps a una velocidad de códec de 8 kbps (50 paquetes por segundo).

Para obtener más información, consulte Voz sobre IP – Consumo de ancho de banda por llamada.

Prioridad del tráfico de voz

Hay dos componentes importantes en la Voz de la prioridad. El primer es que clasifica y de marcado del tráfico de voz interesante. El segundo está dando prioridad al tráfico de voz interesante marcado. Las dos subdivisiones aquí discuten los diversos acercamientos a clasificar, marcando, y Voz de la prioridad.

Clasificación y marcado

Para garantizar el ancho de banda para los paquetes de VoIP, un dispositivo de red debe poder identificar los paquetes en todo el tráfico IP que lo atraviesa. Los dispositivos de red usan la dirección IP de origen y destino en el encabezado IP o los números de puerto UDP de origen y destino en el encabezado UDP para identificar los paquetes VoIP. Esta identificación y proceso el agrupar se llama clasificación. Es la base para proporcionar a cualquier QoS.

La clasificación de paquetes puede ser hace un uso intensivo del procesador. Por lo tanto, la clasificación necesita ser tan lejana hecho hacia fuera hacia el borde de la red como sea posible. Como cada salto todavía necesita tomar una determinación sobre el tratamiento que debe recibir cada paquete, debe tener un método de clasificación más simple y eficaz en el núcleo de la red. Esta clasificación más simple se logra mediante el marcado o configuración del byte de Tipo de servicio (ToS) en el encabezado de la IP. Los tres bits más significativos del Byte ToS se llaman los bits de precedencia IP. La mayoría de las aplicaciones y de los proveedores soportan actualmente la configuración y el reconocimiento de estos tres bits. El marcado se lleva a cabo para que los seis bits más significativos del byte ToS, llamados Differentiated Services Code Point (DSCP), puedan usarse. Consulte la Solicitud de comentarios (RFC):

Los Servicios diferenciados (DiffServ) son un modelo nuevo en el cual el tráfico es tratado por los sistemas intermedios con las prioridades relativas basadas en el campo TOS. Definido en RFC 2474 y RFC 2475 , el estándar DiffServ reemplaza la especificación original para definir la prioridad del paquete descrita en RFC 791.leavingcisco.com leavingcisco.com leavingcisco.com DiffServ aumenta el número de niveles de prioridad definibles al reasignar los bits de un paquete de IP para que se les haga una marcación prioritaria. La arquitectura de DiffServ define el campo del DiffServ. Reemplaza el Byte ToS en IP V4 para hacer las decisiones del Per-Hop Behavior (PHB) sobre la clasificación de paquetes y las funciones de condicionamiento del tráfico tales como medición, marcado, formar, y vigilancia. Además de los RFC previamente mencionados, el RFC 2597leavingcisco.com define las clases del Assured Forwarding (AF). Ésta es una ruptura de los campos DSCP. Para obtener más información sobre DSCP, consulte Implementación de políticas de calidad de servicio con DSCP.

Byte ToS - T0 CU T1 del T2 T3 del p0 P2 P1

Precedencia de IP: tres bits (P2-P0), ToS (Tipo de Servicio): cuatro bits (T3-T0), CU: un bit

Campo del DiffServ - DS0 ECN ECN DS1 DS3 DS2 DS5 DS4

DSCP: seis bits (DS5-DS0), ECN: dos bits

XXX00000 bits 0, 1, 2 (DS5, DS4, DS3) son bits de precedencia, donde:

  • 111 = control de red = precedencia 7

  • 110 = control de la red interna = precedencia 6

  • 101 = CRITIC/ECP = precedencia 5

  • 100 = anulación de Flash = precedencia 4

  • 011 = Flash = precedencia 3

  • 010 = inmediato = precedencia 2

  • 001 = prioridad = precedencia 1

  • 000 = rutina = precedencia 0

000XXX00 los bits 3, 4, 5 (DS2, DS1, DS0) son bits del retardo, de la producción, y de la confiabilidad.

  • 3 mordidos = retardo [D] (0 = normal; 1 = bajo)

  • 4 mordidos = producción [T] (0 = normal; 1 = alto)

  • 5 mordidos = confiabilidad [r] (0 = normal; 1 = alto)

000000XX bits 6, 7: ECN

Estas dos secciones discuten dos maneras de las cuales se haga la Clasificación y marcado.

Pares de marcación de voz para clasificar los paquetes marcados

Con los gatewayes VoIP de Cisco, usted utiliza generalmente a los dial peer de la Voz para clasificar los paquetes de VoIP y para marcar los bits de precedencia IP. Esta configuración muestra cómo marcar los bits de precedencia IP:

dial-peer voice 100 voip
destination-pattern 100
session target ipv4:10.10.10.2
ip precedence 5

En el ejemplo anterior, cualquier llamada VoIP que haga juego el comando dial-peer voice 100 voip tiene todos sus paquetes de la carga útil de voz fijados con la Prioridad IP 5. Esto significa que los tres bits más significativos del Byte ToS IP están fijados a 101.

dial-peer voice 100 voip
destination-pattern 100
session target ipv4:10.10.10.2
ip qos dscp ef media
ip qos dscp af31 signaling

En el ejemplo anterior, cualquier llamada VoIP que haga juego el comando dial-peer voice 100 voip tiene todos sus paquetes de carga útil de los media (paquetes de voz) fijados con el patrón de bits 101110 del expedited forwarding (EF). Todos los paquetes de la señalización se fijan con el patrón de bits 011010 AF.

Nota: Soportan al comando ip qos dscp desde el Software Release 12.2(2)T del ½ del ¿Â de Cisco IOSïÂ. La Prioridad IP está no más disponible en el Cisco IOS Software Release 12.2T. Sin embargo, lo mismo es alcanzada por el comando ip qos dscp. La Prioridad IP 5 (101) asocia a IP DSCP 101000. Para más información consulte Clasificación de señalización de VoIP y medios con DSCP para QoS.

Modular QoS CLI para clasificar y marcar paquetes

La clasificación recomendada y el método de marcado para utilizar es la CLI de QoS modular. Éste es un método de configuración basado en plantilla que separa la clasificación de la directiva. Esto permite que las características múltiples de QoS sean configuradas juntas para las clases múltiples. Utilice un comando class-map de clasificar el tráfico basado en los diversos criterios de concordancia y un comando policy-map de determinar qué necesidades de suceder a cada clase. Aplique la directiva al tráfico entrante o saliente en una interfaz publicando el comando service-policy. Este ejemplo de configuración muestra cómo utilizar el Modular QoS CLI para clasificar y para marcar los paquetes:

access-list 100 permit udp any any range 16384 32767
access-list 101 permit tcp any any eq 1720
!
class-map match-all voip
match access-group 100
class-map match-all control
match access-group 101
!
policy-map mqc
class voip
set ip precedence 5
class control
set ip precedence 5
class class-default
set ip precedence 0
!
interface Ethernet0/0
service-policy input mqc

En este ejemplo de configuración, cualquier tráfico que haga juego la lista de control de acceso (ACL) 100 se clasifica como el “voip de la clase” y conjunto con la Prioridad IP 5. Esto significa que los tres bits más significativos del Byte ToS IP están fijados a 101. ACL 100 coincide con los puertos UDP comunes utilizados por VoIP. Semejantemente señalización de tráfico de H.323 de las coincidencias del ACL 101 (puerto 1720 del Transmission Control Protocol (TCP)). El resto del tráfico se fija con la Prioridad IP 0. La directiva se llama “mqc”. Se aplica al tráfico entrante en el Ethernet0/0.

Establecimiento de prioridad

Después de que cada salto en la red pueda clasificar e identificar los paquetes de VoIP (con el puerto/la información de dirección o a través del Byte ToS), esos saltos después proporcionan cada paquete de VoIP con el QoS requerido. En ese momento, técnicas especiales de la configuración de proporcionar la cola prioritaria para aseegurarse que los paquetes de datos grandes no interfieren con la transmisión de datos de voz. Esto se requiere generalmente en links PÁLIDOS más lentos donde hay una alta posibilidad de la congestión. Una vez que todo el tráfico interesante se pone en las clases de QoS basadas en sus requisitos de QoS, proporcione las garantías de ancho de banda y la revisión de prioridades a través de un mecanismo de envío a cola de salida inteligente. Se requiere una cola de prioridad para VoIP.

Nota:  Utilice cualquier Mecanismo para formar la cola que dé con eficacia el VoIP prioritario. Sin embargo, se recomienda el Low Latency Queuing (LLQ) porque es flexible y fácil configurar.

El LLQ utiliza el método de configuración del Modular QoS CLI para proporcionar la prioridad a ciertas clases y para proporcionar el ancho de banda mínimo garantizado para otras clases. Durante los períodos de congestión, el priority queue se limpia a la velocidad configurada de modo que el tráfico de prioridad no utilice encima de todo el ancho de banda disponible. (Si el tráfico de prioridad monopoliza el ancho de banda, evita que las garantías de ancho de banda para otras clases sean encontradas.) Si usted provision el LLQ correctamente, el tráfico que entra el priority queue debe nunca exceder la velocidad configurada.

El LLQ también permite que las profundidades de espera en cola sean especificadas para determinar cuando el router necesita caer los paquetes si hay demasiados paquetes que esperan en cualquier cola de la clase determinada. Hay también un comando class-default que se utiliza para determinar el tratamiento de todo el tráfico no clasificado por una clase configurada. El class-default se configura con un comando fair-queue. Esto significa que cada flujo sin clasificar está dado una parte aproximadamente igual del ancho de banda restante.

Este ejemplo muestra cómo configurar el LLQ. Para más información, refiera a los Datos en espera de la latencia baja:

access-list 100 permit udp any any range 16384 32000
access-list 101 permit tcp any any eq 1720
access-list 102 permit tcp any any eq 80
access-list 103 permit tcp any any eq 23
!
class-map match-all voip
match access-group 100
class-map match-all voip-control
natch access-group 101
class-map match-all data1
match access-group 102
class-map match-all data2
match access-group 103
!
policy-map llq
class voip
priority 32
class voip-control
bandwidth 8
class data1
bandwidth 64
class data2
bandwidth 32
class class-default
fair-queue
!
interface Serial1/0
bandwidth 256
service-policy output llq

En este ejemplo, cualquier tráfico que haga juego ACL 100 se clasifica como “voip de la clase” (tráfico de voz del significado). Se da los hasta 32 kbps prioritario. ACL 100 coincide con los puertos UDP comunes utilizados por VoIP. El access-list 101 hace juego la señalización de tráfico de H.323 (puerto TCP 1720). La clase data1 hace juego el tráfico de la Web (puerto TCP 80 como se ve en la lista de acceso 102) y el kbps de las garantías 64. La clase data2 hace juego el tráfico de Telnet (puerto TCP 23 como se ve en el ACL 103) y el kbps de las garantías 32. La clase predeterminada se configura para conceder la misma porción del ancho de banda restante a los flujos no clasificados. La directiva se llama “llq”. Se aplica al tráfico saliente en el Serial1/0, que tiene un ancho de banda total del kbps 256.

Nota: Por abandono, el ancho de banda garantizado y el ancho de banda prioritario totales para todas las clases necesita ser menos del 75 por ciento del ancho de banda de la interfaz. Modifique este porcentaje publicando el comando max-reserved bandwidth interface.

Esta tabla compara diversos Mecanismos para formar la cola del software con sus Beneficios y limitación respectivos.

Mecanismo para formar la cola del software Descripción Beneficios Limitaciones
Primero en entrar, primero en salir (FIFO) Los paquetes llegan y dejan la cola en exactamente la misma orden. Configuración simple y rápida operación. No es posible el servicio de prioridad ni las garantías de ancho de banda.1
Weighted Fair Queueing (WFQ) Un algoritmo de troceo que fluye en las colas aparte donde las ponderaciones se utilizan para determinar cuántos paquetes son en un momento mantenido. Para definir los pesos, establezca los valores de precedencia IP y DSCP. Configuración simple Predeterminada en links de menos de 2 Mbps No es posible el servicio de prioridad ni las garantías de ancho de banda.1
Cola personalizada (CQ) El tráfico se clasifica en colas múltiples con límites de cola configurables. Los límites de cola se calculan sobre la base del tamaño promedio de los paquetes, de la Unidad máxima de transmisión (MTU) (MTU), y del porcentaje de ancho de banda que se afectará un aparato. Los límites de cola (en número de los bytes) de-se hacen cola para cada cola. Por lo tanto proporciona el ancho de banda afectado un aparato estadístico. Ha estado disponible por algunos años. Permite la asignación de ancho de banda aproximada para diversas colas de administración del tráfico. No hay revisión de prioridades posible. Las garantías de ancho de banda son aproximadas. Hay un número limitado de colas de administración del tráfico. La configuración es relativamente difícil.1
Cola prioritaria (PQ) El tráfico se clasifica en alto, medio, normal, y las colas de baja prioridad. Primero se atiende el tráfico de alta prioridad, seguido por el tráfico de prioridad media, normal y baja. Ha estado disponible por algunos años. Proporciona la revisión de prioridades. Un tráfico más prioritario muere de hambre las colas de menor prioridad del ancho de banda. No hay garantías de ancho de banda possible.2
Class-Based Weighted Fair Queuing (CBWFQ) Modular QoS CLI se usa para clasificar el tráfico. El tráfico clasificado se coloca en colas de ancho de banda reservado o en una cola predeterminada no reservada. Un planificador atiende las colas teniendo en cuenta los pesos, de esta manera se cumplen las garantías del ancho de banda Similar a LLQ, a excepción de que no hay una cola prioritaria. Configuración simple y capacidad de proporcionar garantías de ancho de banda. No hay revisión de prioridades possible.3
Weighted Fair Queuing del priority queue (PQ-WFQ), también llamado prioridad de IP RTP Un comando de interfaz única se utiliza para proporcionar servicio prioritario a todos los paquetes UDP destinados a números de puerto iguales dentro de un rango especificado. Configuración de un comando, simple Proporciona servicio prioritario a paquetes RTP. El resto del tráfico se trata con el WFQ. No se prioriza el tráfico de Protocolo de conferencia en tiempo real (RTCP). No se garantiza la capacidad de ancho de banda 4
LLQ, anteriormente conocido como Class-Based Weighted Fair Queueing (PQCBWFQ) El Modular QoS CLI con el priority queue se utiliza para clasificar el tráfico. El tráfico clasificado se coloca en una cola de prioridad, colas de ancho de banda reservado o en una cola no reservada predeterminada. Un planificador se ocupa de las colas basándose en el peso para que el tráfico de prioridad sea enviado primero (hasta un cierto límite regulado durante la congestión) y para que se cumplan las garantías del ancho de banda. Configuración simple Capacidad de otorgar prioridad a distintas clases de tráfico y ofrece más límites sobre la utilización del ancho de banda prioritario. Usted puede también configurar las clases garantizadas ancho de banda y una clase predeterminada. No se envía ningún mecanismo para proporcionar los niveles múltiples de prioridad todavía, todo el tráfico de prioridad con el mismo priority queue. Las clases de prioridad separadas pueden tener límites superiores separados del ancho de banda prioritario durante la congestión. Sin embargo, la distribución del priority queue entre las aplicaciones puede potencialmente introducir jitter.4

  1. No conveniente para la Voz.

  2. Necesita el ancho de banda garantizado para la Voz.

  3. Necesita el tiempo de espera ser tomado el cuidado de.

  4. Suficiente para la Voz.

Demora de serialización

Incluso si la espera trabaja en su mejor y da prioridad al tráfico de voz, hay las épocas en que el priority queue está vacío y un paquete de otra clase se mantiene. Los paquetes de las clases del ancho de banda garantizado se deben mantener basaron en su ponderación configurada. Si los paquetes de voz de la prioridad llegan en la cola de salida mientras que se están manteniendo estos paquetes, los paquetes de voz pueden esperar una cantidad significativa de tiempo antes de que se envíen. Los paquetes de voz experimentan demora en la serialización cuando deben aguardar detrás de paquetes de datos más grandes.

El retraso de serialización puede introducir la peor forma de jitter para los paquetes de voz. Si los paquetes de voz tienen que esperar detrás de un paquete de datos que sea tan grande como 1500 bytes, en un link más lento, esto traducen a un retardo enorme. El retraso de serialización es sumamente diferente si el paquete de datos es 80 bytes, tal y como se muestra en de este ejemplo:

  • Retraso de serialización en un link de kbps 64 debido a un paquete de bytes 1500 = a un 1500*8/64000 = ms 187.5.

  • Retraso de serialización en un link de kbps 64 debido a un paquete 80bytes = a un 80*8/64000 = ms 10.

Por lo tanto, los paquetes de voz potencialmente tienen que esperar al ms hasta 187.5 antes de que se envíen si consiguen pegados detrás de un solo paquete 1500-byte en un link de kbps 64. Por otra parte, otros paquetes de voz tienen que esperar al ms solamente 10 en el gateway de destino. Esto resulta en una gran fluctuación que se produce como consecuencia de la variación del retraso entre los paquetes. En el gateway de origen, los paquetes de voz generalmente se envían cada ms 20. Con un presupuesto de demora de extremo a extremo de 150 ms y con requerimientos de fluctuaciones estrictos, es inaceptable una brecha de 180 ms.

Introduzca un mecanismo de fragmentación que se asegure de que el tamaño de una unidad de transmisión sea menos del ms 10. Cualquier paquetes que tengan necesidad del retraso de serialización de más de 10 ms de ser hecho fragmentos en 10 pedazos del ms. Un pedazo o el fragmento de 10 ms es la cantidad de bytes que se envía sobre el link en 10 que el ms calcula el tamaño usando la velocidad del link, tal y como se muestra en de este ejemplo:

  • Tamaño de fragmentación = (0.01 segundos * 64,000 bps) / (8 bits/byte) = 80 bytes

Lleva 10 ms enviar un paquete o fragmento de 80 bytes por un link de 64 kbps.

En caso de varias ATM o Circuitos virtuales permanentes Frame Relay (PVC) en una interfaz sola física, configure los valores de fragmentación (en todos los PVC) basados en el PVC que tenga disponible el menor ancho de banda. Por ejemplo, si hay tres PVC que tienen un ancho de banda garantizado de 512 kbps, del kbps 128, y del kbps 256, después configure los tres PVC con un tamaño del fragmento de 160 bytes (el más de poca velocidad es el kbps 128 que requiere un tamaño del fragmento del 160-byte). Estos valores se recomiendan para diversas velocidades del link:

Link Speed (kbps)         Fragmentation Size (bytes) 
56                                  70 
64                                  80 
128                                 160 
256                                 320 
512                                 640 
768                                 960 
1024                                1280 
1536                                1920

Nota: No es necesario realizar una fragmentación si el tamaño del segmento es mayor que el tamaño del link de MTU. Por ejemplo, para un link T1 con un 1500-byte MTU, el tamaño del fragmento es 1920 bytes. Por lo tanto, no se requiere ninguna fragmentación. El tamaño de la fragmentación de paquetes debe nunca ser más bajo que el tamaño de paquete de VoIP. No haga fragmentos de los paquetes de VoIP. La fragmentación de estos paquetes ocasiona muchos problemas de calidad y configuración de las llamadas.

Hay actualmente tres mecanismos de la fragmentación de link y de la interpolación disponibles. Para obtener más detalles acerca de los distintos retardos introducidos en una red de paquetes, consulte Introducción al Retardo en redes de voz en paquetes. Esta tabla enumera a sus Beneficios y limitación:

Mecanismo del Link Fragmentation and Interleaving (LFI) Descripción Beneficios Limitaciones
Fragmentación de MTU con WFQ Comando interface level de cambiar la talla del MTU o la talla del MTU IP. Utilizado para fragmentar paquetes IP grandes a un tamaño MTU especificado. LFI usa WFQ para entrelazar paquetes en tiempo real entre los fragmentos. Configuración simple Los fragmentos son vuelven a montar solamente por la aplicación de recepción. Por lo tanto, uso ineficaz de la red. Solamente los paquetes del IP con no hacen fragmentos (DF) mordido no fijado pueden manejar la fragmentación bien. Carga de trabajo demasiado alta para el procesador. No recomendado.
Multilink Point-to-Point Protocol (MLPPP) LFI En los link serial Point-to-Point, el MLPPP debe primero ser configurado, después un tamaño de fragmentación se debe fijar en el ms que la interpolación se debe también habilitar en la interfaz de links múltiples. Se fragmentan los paquetes en un extremo del link y se vuelven a ensamblar en el otro. Es posible combinar varios links para que funcionen como un gran conducto virtual. Únicamente disponible en links configurados para PPP. Las soluciones para el PPP por Frame Relay o el PPP over ATM también se soportan en el Cisco IOS Software Release 12.1(5)T o Posterior.
Fragmentación de Frame Relay (FRF.12) En los PVC de Frame Relay, el comando frame-relay traffic-shaping debe ser habilitado y el tamaño de la fragmentación establecido en la clase de asociador. Se fragmentan los paquetes en un extremo del PCV y se vuelven a ensamblar al otro. Sólo disponible en PVC de Frame Relay con el comando frame-relay traffic-shaping activo.

VAD

Una conversación de voz común incluye varios momentos de silencio. Una conversación de voz típica consiste en el porciento de silencio 40 a 50. Dado que no se transmite ninguna voz a través de la red durante el 40 por ciento de una llamada de voz, se puede ahorrar parte del ancho de banda mediante la implementación de VAD. Con el VAD, el gateway mira hacia fuera para los intervalos en el discurso. Substituye esos intervalos por el ruido de comodidad (ruido de fondo). Así, una cantidad de ancho de banda se guarda. Sin embargo, es un equilibrio. Hay un de poca monta (en orden de los milisegundos), antes de que el codecs detecte la actividad de voz seguida por un período de silencio. Este breve tiempo produce el recorte por parte del procesador frontal de la voz recibida. Para evitar la activación durante las pausas muy cortas y compensar el recortes, el VAD espera al ms aproximadamente 200 después de que el discurso pare antes de que pare la transmisión. Sobre el recomienzo de la transmisión, incluye al ms anterior 5 del discurso junto con el discurso actual. VAD se inhabilita automáticamente durante una llamada si el ruido del ambiente no le permite diferenciar entre la voz y el ruido de fondo. Sin embargo, si el ancho de banda no es un problema, apague el VAD.

Parámetros VAD para la puesta a punto

Hay dos parámetros que dictan el funcionamiento del VAD. Éstos son los comandos music-threshold and voice vad-time.

music-threshold

Se decide un umbral inicial que gobierna cuando el VAD necesita llegar a ser activo. Esto es controlada definiendo el comando music-threshold threshold_value en un puerto de voz, tal y como se muestra en de este ejemplo. El rango para esto es a partir de -70 decibeles por milivatio (dBm) al dBm -30. El valor predeterminado para esto es el dBm -38. La configuración de un valor inferior (hacia -70 dBm) hace que VAD se vuelva activo con una fuerza de señal mucho más baja (el volumen debe disminuir en gran medida para ser considerado silencio). Configurar un valor más alto (más cercano al dBm -30) da lugar al VAD que llega a ser activo para incluso un pequeño descenso en la fuerza de señal de voz. Conduce el playout para jugar los paquetes de ruido de comodidad más a menudo. Sin embargo, esto lleva a veces al recorte menor del audio.

3640-6#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3640-6(config)#voice-port 3/0/0
3640-6(config-voiceport)#music-threshold ?
WORD Enter a number b/w (-70 to -30)
3640-6(config-voiceport)#music-threshold -50
3640-6(config-voiceport)#end
3640-6#
3640-6#show run | be voice-portvoice-port 3/0/0 music-threshold -50

voice vad-time

Una vez que el VAD llega a ser activo, el componente del ruido de fondo y del ruido de comodidad es controlado configurando el comando voice vad-time timer_value bajo configuración global, tal y como se muestra en de este ejemplo. Este es el tiempo de retardo en milisegundos para la detección y supresión de silencio de la transmisión de paquete de voz. El valor predeterminado para el tiempo de mantenimiento es de 250 mseg. Esto significa que en el plazo de 250 milisegundos, el ruido de comodidad comienza. El rango para este temporizador es de 250 ms a 65536 ms. Si un valor alto se configura para esto, el ruido de comodidad entra en el juego mucho más adelante (el ruido de fondo continúa siendo jugado). Si se configura en 65536 mseg, se apaga el ruido de comodidad. Se requiere un valor superior para este temporizador a fin de lograr una transición más fluida entre el ruido de fondo y el ruido confortable. La desventaja a configurar el comando voice vad-time a un nivel elevado es que no alcanza el ahorro de ancho de banda deseado del 30 a 35 por ciento.

3640-6#
3640-6#
3640-6#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3640-6(config)#voice vad-time ?
<250-65536> milliseconds
3640-6(config)#voice vad-time 750
3640-6(config)#end
3640-6#
3640-6#
3640-6#
3640-6#show run | be vad-time voice vad-time 750

Ejemplos de configuración típica para QoS

Un escenario típico para configurar las llamadas VoIP está sobre un link de Frame Relay o sobre un link PPP. Éstos son ejemplos de configuración para estos escenarios.

VoIPoFR - Ejemplo de la configuración de QoS

En este ejemplo (que contenga solamente las secciones pertinentes de la configuración), se asume que la velocidad de circuito de Frame Relay es el kbps 256. La Velocidad de información comprometida (CIR) garantizada en PVC 100 es de 64 kbps y en PVC 200 es de 192 kbps. El PVC 100 se utiliza para llevar ambos datos y Voz. El PVC 200 se utiliza para llevar solamente los datos. Un máximo de cuatro llamadas de voz simultánea existe en cualquier momento. Configure la fragmentación en ambos PVC basados en el CIR del bajo-ancho de banda-Voz-PVC (Voz que lleva PVC). De acuerdo con los ejemplos en este documento, ese significa que el tamaño de fragmentación está decidido sobre la base del PVC 100's CIR (que es 64 kbps). Tal y como se muestra en de la tabla de la sección de retraso de serialización, para un link de kbps 64, un tamaño de fragmentación de 80 bytes se requiere. Se debe configurar el mismo tamaño de fragmentación para el PVC 200.

Para otros detalles sobre la configuración del VoIP over Frame Relay, refiera al VoIP over Frame Relay con la calidad de servicio (fragmentación, modelado de tráfico, prioridad de RTP LLQ/IP).

3660-1#show run
Building configuration...
!
class-map match-any voip
match ip rtp 16384 16383
match ip dscp 26 46
class-map match-all voip-control
match access-group 101
!
!
policy-map VoIPoFR
class voip
priority 48
class voip-control
bandwidth 8
class class-default
fair-queue
!
voice call send-alert
voice rtp send-recv
!
!
interface Serial4/0:0
bandwidth 256
no ip address
encapsulation frame-relay
frame-relay traffic-shaping
!
interface Serial4/0:0.1 point-to-point
bandwidth 64
ip address 10.10.10.10 255.255.255.0
frame-relay ip rtp header-compression
frame-relay interface-dlci 100
 class voice
!
interface Serial4/0:0.2 point-to-point
bandwidth 192
ip address 20.20.20.20 255.255.255.0
frame-relay interface-dlci 200
class data
!
map-class frame-relay data
frame-relay fragment 80
frame-relay adaptive-shaping becn
frame-relay cir 256000
frame-relay bc 32000
frame-relay be 0
frame-relay mincir 192000
frame-relay fair-queue
!
map-class frame-relay voice
frame-relay fragment 80
no frame-relay adaptive-shaping
frame-relay cir 64000
frame-relay bc 640
frame-relay be 0
frame-relay mincir 64000
service-policy output VoIPoFR
!
!
access-list 101 permit tcp any any eq 1720
!
!
voice-port 3/1/0
!
voice-port 3/1/1
!
!
dial-peer voice 10 voip
incoming called-number .
destination-pattern 1408.......
session target ipv4:10.10.10.11
dtmf-relay h245-signal h245-alphanumeric
no vad
!
dial-peer voice 20 pots
destination-pattern 1234
port 3/1/0
!
dial-peer voice 21 pots
destination-pattern 5678
port 3/1/1

VoIP sobre el PPP - Ejemplo de la configuración de QoS

En este ejemplo (que contenga solamente las secciones pertinentes de la configuración), se asume que el QoS necesita ser configurado para un regulador del Punto a punto fraccional T1 (que tiene doce canales). Un máximo de cuatro llamadas de voz simultánea existe en cualquier momento. La tarea de configuración implica el configurar de esta interfaz serial con la encapsulación PPP, el hacer le de la parte de al grupo multilink, el crear de una interfaz de links múltiples (que pertenezca al mismo grupo multilink), y el configurar de todo el QoS en la interfaz de links múltiples. Para otros detalles sobre la configuración del VoIP sobre el PPP, refiera al VoIP sobre los links PPP con la calidad de servicio (prioridad de RTP LLQ/IP, LFI, cRTP).

3660-1#show run
Building configuration...
!
class-map match-any voip
match ip rtp 16384 16383
match ip dscp 26 46
class-map match-all voip-control
match access-group 101
!
!
policy-map VoIPoPPP
class voip
priority 48
class voip-control
bandwidth 8
class class-default
fair-queue
!
voice call send-alert
voice rtp send-recv
!
!
interface Multilink7
bandwidth 768
ip address 10.10.10.10 255.255.255.0
ip tcp header-compression iphc-format
service-policy output VoIPoPPP
no cdp enable
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
multilink-group 7
ip rtp header-compression iphc-format
!
!
interface Serial4/0:0
bandwidth 768
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 7
!
!
access-list 101 permit tcp any any eq 1720
!
voice-port 3/1/0
!
voice-port 3/1/1
!
!
dial-peer voice 10 voip
incoming called-number .
destination-pattern 1408.......
session target ipv4:10.10.10.11
dtmf-relay h245-signal h245-alphanumeric
no vad
!
dial-peer voice 20 pots
destination-pattern 1234
port 3/1/0
!
dial-peer voice 21 pots
destination-pattern 5678
port 3/1/1
!

Mecanismo de fluctuación y reproducción completa

Hay siempre algunas entidades sin controlar en una red que contribuyen a los más retrasos y oscilación en los paquetes de voz recibidos. Modificando el buffer del jitter en el gateway de terminación la fluctuación no controlada se resuelve en la red de voz.

Mecanismo de reproducción completa

El buffer del jitter es un buffer del tiempo. Es proporcionado por el gateway de terminación para hacer el mecanismo de transmisión más eficaz. Éste es un diagrama funcional del mecanismo de transmisión:

/image/gif/paws/20371/troubleshoot_qos_voice1.gif

Cuando el control de transmisión recibe un paquete de voz, el mismo analiza el sello de fecha y hora de RTP. Si los paquetes de voz se retrasan más allá de la capacidad de espera del buffer del jitter, después el paquete se cae inmediatamente. Si el paquete se encuentra dentro de la capacidad de almacenamiento de memoria intermedia, se lo ubica en la memoria intermedia de fluctuación. La ubicación de este paquete en la memoria intermedia de fluctuación depende de la indicación de fecha y hora de RTP que se calcula para ese paquete. En el evento no hay paquetes de voz disponibles, los intentos del control de transmisión para encubrirlos (predice hacia fuera faltado el paquete). Si se habilita el VAD, se juega el ruido de comodidad.

La responsabilidad del control de transmisión es administrar los eventos de los paquetes perdidos, duplicados, defectuosos y fuera de secuencia. Estos eventos se manejan por el tiempo que alinea los paquetes de voz inquietos, jugando el ruido de comodidad (si se configura el VAD), o aún los tonos de múltiples frecuencias del tono dual de la regeneración (DTMF) que se realizarán al host.

El encubrimiento de un paquete de voz se realiza mediante un encubrimiento de predicción o mediante un encubrimiento de silencio. El ocultamiento de la predicción está basado en el paquete anterior y en el paquete posterior (si están disponibles). Trabaja mejor con el codecs bajo del bitrate (5 kbps a 16 kbps). La pérdida de paquetes de voz para un códec de tasa de bits alta (32 kbps a 64 kbps) puede potencialmente dar lugar al ocultamiento de predicción pobre. El ocultamiento de predicción comienza cuando hay retardos bajos e infrecuentes o un poco número de pérdida del paquete. El ocultamiento de la predicción en exceso puede causar una calidad de voz robótica. El ocultamiento de silencio es la peor forma de ocultamiento de predicción. Entra en juego cuando no hay información disponible para predecir. Es simplemente un ocultamiento de fondo. Comienza cuando hay altos retardos y más número de pérdida del paquete. Demasiado secreto del silencio lleva a la calidad de voz entrecortada. El ocultamiento de la predicción es bueno durante 30 milisegundos, después de que el ocultamiento del silencio entra en juego.

Memoria intermedia para fluctuación

La memoria intermedia de fluctuación está limitada por una marca de agua alta y una marca de agua baja. La marca de agua máxima es el tiempo máximo dentro del cual se espera que llegue un paquete para una transmisión a tiempo. Los paquetes que llegan después de la marca de agua alta son marcados como paquetes tardíos o como paquetes perdidos. La marca de agua baja es el tiempo mínimo dentro del cual se espera que llegue un paquete para una transmisión completa puntual. Los paquetes que llegan antes de que el punto más bajo se considere los paquetes tempranos (él se pueden todavía jugar hacia fuera el tiempo).

Si el gateway de terminación continúa viendo un incremento en la llegada de los últimos paquetes, aumenta el punto más alto. Este valor por punto más alto sigue siendo lo mismo en la duración de la llamada. Esto se aumenta hasta un máximo definido en la configuración. De la misma manera, el gateway de terminación observa el número de paquetes tempranos recibidos. Si estos paquetes comienzan a frecuentar el gateway, reduce el punto más bajo. Este valor sigue siendo lo mismo en la duración de la llamada. Este modo de buffer del jitter se refiere como “modo adaptable,” donde el gateway de terminación adapta su buffer del jitter basado en el patrón de tráfico. El otro modo es “modo fijo.” En el modo fijo, hay un valor inicial por el punto más bajo y el punto más alto. Este valor se basa en el retraso recibido estimado (véase la sección del <port-number> de la llamada de voz de la demostración de este documento).

Para otros detalles en el buffer del jitter, refiera comprensión del jitter en las redes de voz en paquetes (plataformas de Cisco IOS).

Identifique la fluctuación y retraso

Esta sección describe cómo identificar el jitter en su red.

show call active voice

El comando show call active voice brief da mucha información sobre una conversación en curso. Esta salida visualiza algunos puntos importantes que sean doctos de este comando:

11E4 : 2170927hs.1 +600 pid:10 Answer 1000 active
dur 00:08:43 tx:26157/522967 rx:7044/139565
Tele 3/0/0:9: tx:151310/755/0ms g729r8 noise:-62 acom:0 i/0:-56/-48 dBm
11E4 : 2171198hs.1 +329 pid:20 Originate 2000 active
dur 00:08:43 tx:7044/139565 rx:26165/523127
IP 30.30.30.29:18682 rtt:51ms pl:148590/290ms lost:0/0/15 delay:65/60/132ms g729r8

De la salida del comando show call active voice brief, usted ve que sea cual sea se recibe en el tramo de telefonía (rx:7044) se transmite a la pierna IP (tx:7044). Lo mismo es verdad para los paquetes recibidos en las piernas IP (26165) que se remiten al tramo de telefonía (26157). La diferencia en el número de paquetes recibidos en la pierna IP contra el número de paquetes transmitidos en el tramo de telefonía se contribuye a los últimos paquetes que no lo hacen a tiempo.

Esta salida del comando show call active voice (sin la palabra clave “abreviada”), puntas a otros detalles sobre los parámetros que identifican directamente el jitter.

GapFillWithSilence=850 ms
GapFillWithPrediction=9230 ms
GapFillWithInterpolation=0 ms
GapFillWithRedundancy=0 ms

show voice call <número de puerto>

El comando show voice call port-number brinda información útil. Aseegurese ser consolado en el gateway, o si usted es telnetted en un gateway, aseegurese le haber publicado el comando terminal monitor del nivel del ejecutivo.

Nota: Este comando no está disponible en las plataformas AS5x00/AS5x50.

En esta salida, el valor para el retardo Est (ms) del rx es 71. Éste es el valor de búfer actual del jitter. Un valor por el punto más alto y el punto más bajo se deduce en esto. Un valor inicial promedio para la marca de agua alta es 70 milésimas de segundo, mientras que para la marca de agua baja es de 60 milésimas de segundo. Una vez que se especifica un valor inicial, el gateway realiza el seguimiento de cualquier paquete anticipado o tardío que se reciba. Como se ve en la salida aquí, los descensos del ocultamiento de predicción están cercanos al ms 250, mientras que el secreto del silencio es el ms 30. Hay siempre un valor más alto para el ocultamiento de predicción puesto que el secreto del silencio es solamente un escenario de caso peor del ocultamiento de predicción. Para cada caída de ocultamiento de predicción, hay un incremento en el descarte de desbordamiento de memoria.

Si usted ve el buffer desechar, no significa necesariamente que usted ve un aumento en el punto más alto. El punto más alto es el límite superior del buffer del jitter. Cambia solamente si se observa una tendencia. Es decir debe haber un flujo continuo de últimos paquetes. Esto da lugar a un aumento del buffer del jitter. En la salida aquí, tal tendencia está presente. Por lo tanto, el punto más alto se aumenta a partir de 70 milisegundos a 161 milisegundos. Si este valor no se cambia (y si usted todavía ve 14 últimos paquetes), implica que éstos son últimos paquetes esporádicos, no formando una tendencia.

De la salida del comando show call active voice, mire hacia fuera para los paquetes perdidos. Para cada paquete perdido, usted ve dos paquetes que estén fuera de secuencia. Esto se ve en la salida NON-Seq del pkts del rx. Puesto que no es un valor positivo, se concluye que no ha habido ninguna pérdidas del paquete tampoco.

3640-6# ***DSP VOICE TX STATISTICS***
Tx Vox/Fax Pkts: 195, Tx Sig Pkts: 0, Tx Comfort Pkts: 10
Tx Dur(ms): 192070, Tx Vox Dur(ms): 388, Tx Fax Dur(ms): 0
***DSP VOICE RX STATISTICS***
Rx Vox/Fax Pkts: 9604, Rx Signal Pkts: 0, Rx Comfort Pkts: 0
Rx Dur(ms): 192070, Rx Vox Dur(ms): 191560, Rx Fax Dur(ms): 0
Rx Non-seq Pkts: 0, Rx Bad Hdr Pkts: 0
Rx Early Pkts: 0, Rx Late Pkts: 14
***DSP VOICE VP_DELAY STATISTICS***
Clk Offset(ms): 0, Rx Delay Est(ms): 71
Rx Delay Lo Water Mark(ms): 60, Rx Delay Hi Water Mark(ms): 161
***DSP VOICE VP_ERROR STATISTICS***
Predict Conceal(ms): 250, Interpolate Conceal(ms): 0
Silence Conceal(ms): 30, Retroact Mem Update(ms): 0
Buf Overflow Discard(ms): 500, Talkspurt Endpoint Detect Err: 0
***DSP LEVELS***
TDM Bus Levels(dBm0): Rx -49.9 from PBX/Phone, Tx -41.7 to PBX/Phone
TDM ACOM Levels(dBm0): +2.0, TDM ERL Level(dBm0): +11.1
TDM Bgd Levels(dBm0): -58.9, with activity being voice
***DSP VOICE ERROR STATISTICS***
Rx Pkt Drops(Invalid Header): 0, Tx Pkt Drops(HPI SAM Overflow): 0

Observe el Tx Comfort Pkts y el Rx Comfort Pkts. Como de las salidas de ejemplo, se concluye que el teléfono conectado con este router guarda sobre todo silenciosamente puesto que usted tiene porciones de pkts de la comodidad del tx. Al mismo tiempo, usted tiene pkts cero de la comodidad del rx, así que significa que el otro extremo habla continuamente.

Compare la salida aquí con la salida de comando anterior. Hay un mayor número de último pkts del rx (a partir el 14 a 26). Sin embargo, no hay incremento en el valor de marca de agua alto. Esto indica que los 12 paquetes están retrasados esporádico. El descarte por desbordamiento de búfer se aumenta a 910 msecs. Sin embargo, puesto que no hay tendencia observada, el punto más alto no se aumenta.

En la salida aquí, usted tiene un pkts temprano del rx: 3. Esto significa que llega un paquete mucho antes de que se espere. Según lo considerado de la salida aquí, el buffer del jitter se ha estirado para acomodar para más paquetes tempranos reduciendo el punto más bajo a partir del 60 a 51.

3640-6# ***DSP VOICE TX STATISTICS***
Tx Vox/Fax Pkts: 209, Tx Sig Pkts: 0, Tx Comfort Pkts: 11
Tx Dur(ms): 337420, Tx Vox Dur(ms): 416, Tx Fax Dur(ms): 0
***DSP VOICE RX STATISTICS***
Rx Vox/Fax Pkts: 16843, Rx Signal Pkts: 0, Rx Comfort Pkts: 1
Rx Dur(ms): 337420, Rx Vox Dur(ms): 335920, Rx Fax Dur(ms): 0
Rx Non-seq Pkts: 0, Rx Bad Hdr Pkts: 0
Rx Early Pkts: 3, Rx Late Pkts: 26
***DSP VOICE VP_DELAY STATISTICS***
Clk Offset(ms): 0, Rx Delay Est(ms): 72
Rx Delay Lo Water Mark(ms): 51, Rx Delay Hi Water Mark(ms): 161
***DSP VOICE VP_ERROR STATISTICS***
Predict Conceal(ms): 510, Interpolate Conceal(ms): 0
Silence Conceal(ms): 70, Retroact Mem Update(ms): 0
Buf Overflow Discard(ms): 910, Talkspurt Endpoint Detect Err: 0
***DSP LEVELS***
TDM Bus Levels(dBm0): Rx -51.5 from PBX/Phone, Tx -44.1 to PBX/Phone
TDM ACOM Levels(dBm0): +2.0, TDM ERL Level(dBm0): +11.9
TDM Bgd Levels(dBm0): -61.3, with activity being voice
***DSP VOICE ERROR STATISTICS***
Rx Pkt Drops(Invalid Header): 0, Tx Pkt Drops(HPI SAM Overflow): 0

Buffer del jitter de la configuración en un gateway

Las pautas de QoS cubiertas en este documento toman el cuidado del problema de calidad de voz picado o deteriorado. La configuración de búfer de playout delay es a solución alternativa a la implementación incorrecta de la QoS (Calidad de servicio) en la red. Utilice solamente esto como arreglo transitorio o como herramienta para resolver problemas y estrecharse abajo de los problemas de fluctuación introducidos en la red.

Modo retardo de reproducción completa

El buffer del jitter se configura para el modo fijo o el modo adaptable. En el modo adaptable, la gateway le permite configurar un valor mínimo, uno nominal y otro máximo de oscilación de la memoria intermedia. El buffer del jitter espera que los paquetes lleguen dentro del rango de valor nominal. El valor nominal debe ser igual a o mayor que el mínimo, e igual a o menor que el máximo. El buffer se amplía hasta el valor máximo configurado. Esto puede ampliar hasta 1700 milisegundos. Un tema con el máximo valor de configuración es la introducción del retardo de extremo a extremo. Elija el valor del playout-retardo máximo tales que no introduce el retardo indeseado en la red. Esta salida es un ejemplo del buffer del jitter configurado para el modo adaptable:

3640-6#
3640-6#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3640-6(config)#voice-port 3/0/0
3640-6(config-voiceport)#playout-delay mode adaptive
3640-6(config-voiceport)#playout-delay maximum 400
3640-6(config-voiceport)#playout-delay nominal 70
3640-6(config-voiceport)#playout-delay minimum low
3640-6(config-voiceport)#^Z
3640-6#
3640-6#
3640-6#show run | begin 3/0/0
voice-port 3/0/0
playout-delay maximum 400
playout-delay nominal 70
playout-delay minimum low
playout-delay mode adaptive
!

En el modo fijo, el gateway tiene en cuenta el valor configurado de nominal. Aunque permita que usted configure el mínimo y el valor máximo para el playout-retardo, se ignora cuando está configurado para el modo fijo. Cuando en el modo fijo, el valor de marca de agua alto o el valor del punto más bajo sigue siendo siempre constante. Se basa en el valor nominal y en el valor de Rx Delay Est (ms). Es tan posible que bajo modo fijo, usted configura el valor como 200 milisegundos. Sin embargo, si el retraso recibido estimado está cercano al ms 100, que es lo que se fija el punto más alto y el punto más bajo para a la duración entera de la llamada.

3640-6#
3640-6#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3640-6(config)#voice-port 3/0/0
3640-6(config-voiceport)#playout-delay mode fixed
3640-6(config-voiceport)#playout-delay nominal 70
3640-6(config-voiceport)#^Z
3640-6#
3640-6#
3640-6#show run | begin 3/0/0
voice-port 3/0/0
playout-delay mode fixed
playout-delay nominal 70
!

Para más detalles acerca de la configuración de retardo de reproducción completa, consulte Optimización del retardo de reproducción completa para voz sobre IP.


Información Relacionada


Document ID: 20371