Módulos e interfaces de Cisco : Módulo de switching de contenido de Cisco

Configurar el Almacenamiento en memoria caché transparente en el módulo content switch

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar un módulo content switch (CS) para el Almacenamiento en memoria caché transparente, con el Content Engine de Cisco como cachés. La memoria caché transparente se ubica entre el usuario y el servidor El CS se introduce entre el usuario y el caché. El CS es inteligente debido a su capacidad de la capa 5 de analizar dinámicamente el contenido y de determinarlo si es cacheable o no. Estas guías de consulta se aplican:

  • Si es cacheable, la carga CS equilibra la petición al servicio caché basado en el calculador configurado.

  • Si no cacheable, el CS la envía directamente al servidor de origen. Esto evita el salto de rendimiento que ocurre cuando objeto no apto para almacenar en caché va al caché, sólo hacer su petición reorientar por el caché al servidor de origen.

Hay varios métodos de equilibrio disponibles, que dependen de cómo usted quiere distribuir los datos sobre los cachés (por ejemplo, URL entero, cadena URL, y así sucesivamente).

Se puede configurar un CSM con una lista de extensiones de archivos para enviarlo al caché. La lista se denomina una Lista calificadora extensiva (EQL). Una vez que usted configura política SLB es política caché debajo el vserver TRANSPARENTE, sólo las peticiones con las extensiones de archivo que se enumeran en la lista de la correspondencia URL almacenable en caché se envían el caché. Si las extensiones de archivo no se enumeran en la lista de la correspondencia URL almacenable en caché, después la petición golpeará política SLB no es política caché.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.1(8)EX del ½ del ¿Â de Cisco IOSï del Catalyst 6000 Supervisor para el Supervisor Engine 1 con MSFC1 (c6sup11-dsv-mz.121-8a.EX)

  • Versión de software CSM del Catalyst 6000 2.1(2) (c6slb-apc.2-1-2.bin)

  • Versión corriente 5.1.3 del Software Cisco Application and Content Networking System (ACNS) del Cisco Content Engine 565

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección, le presentan con la información para configurar las características que se describen en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

Almacenamiento en memoria caché transparente en el CS

config_transp_caching_19680.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

CS
Building configuration...
Current configuration : 4500 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
enable password cisco
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
ip name-server 10.107.241.185
!

!--- CSM located in slot 3. Module is running as active
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 3
 vlan 100 client
  ip address 10.107.249.251 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.

 vlan 200 server
  ip address 10.107.249.251 255.255.255.248
!

!--- Probe setup to check the availability of the Content
!--- Engine default probe values. Interval is 300 seconds.

 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command.
!--- CSM needs to do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND.
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the map CACHEABLE url list
!--- will use serverfarm OUTBOUND. The NAT server has no
!--- effect, as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
  priority 20
!

!--- CSM located in slot 4. Module is running as standby
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 4
 vlan 100 client
  ip address 10.107.249.253 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.
!--- Note: Module 3 and 4 VLAN IP addresses are different.

 vlan 200 server 
  ip address 10.107.249.253 255.255.255.248
!

!--- Probe setup to check availability of Content Engine.
!--- Default probe values. Interval 300 seconds.

!
 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command. CSM needs to
!--- do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the CACHEABLE URL list will
!--- use serverfarm OUTBOUND. The NAT server has no effect,
!--- as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!

!--- CSM client side VLAN. Uplink to the Internet.

interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
!
interface FastEthernet2/2
 no ip address
 shutdown
!

!--- Cache Engine connected to FE2/3 and FE2/4.
!--- CSM client side VLAN.

interface FastEthernet2/3
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!
interface FastEthernet2/4
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!

!--- CSM Server side VLAN. Connection to end users.

interface FastEthernet2/5
 no ip address
 switchport
 switchport access vlan 200
!

!--- MSFC VLAN 100. Content Engine and client uses this
!--- address as the default gateway.

interface Vlan100
 ip address 10.107.249.250 255.255.255.248
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.107.249.249
no ip http server
!
line con 0
line vty 0 4
password cisco
login
!
end

Content Engine
device mode content-engine
!
hostname ce1
!
http proxy incoming 80

!--- Accept proxy requests on port 80.

!
http l4-switch enable


!--- Instructs the Content Engine to accept traffic that is
!--- directed to any destination IP.

!
ip domain-name cisco.com
!
!
interface Fastethernet 0/0
 ip address 10.107.249.254 255.255.255.248
 exit
!
interface Fastethernet 0/1
 exit
!
ip default-gateway 10.107.249.250
!
primary-interface Fastethernet 0/0
!
!
no auto-register enable
!
ip name-server 10.107.241.185
!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar que su configuración está trabajando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

Comandos debug and show CS

  • show module

  • demostración arp — Proporciona el anuncio del caché del Address Resolution Protocol (ARP) del Equilibrio de carga de servidores (SLB).

  • conns de la demostración — Proporciona la información de conexión SLB.

  • dfp de la demostración — Proporciona la información del administrador del Dynamic Feedback Protocol (DFP) SLB.

  • demostración pies — Proporciona la información de la tolerancia de fallas SLB (pie).

    cat# show module csm 3 ft
    
    FT group 1, vlan 250
    This box is active
    priority 20, heartbeat 1, failover 3, preemption is off
    
    cat# show module csm 4 ft
    
    FT group 1, vlan 250
    This box is in standby state
    priority 10, heartbeat 1, failover 3, preemption is off
  • correspondencia de la demostración — Proporciona la información de mapa SLB.

  • memoria de la demostración — Proporciona la Información de la memoria SLB.

  • natpools de la demostración — Información del agrupamiento NAT del Provee al cliente SLB.

  • directiva de la demostración — Proporciona la información de política SLB.

  • sonda de la demostración — Provee información de sonda SLB.

  • reals de la demostración — Proporciona la información del servidor real SLB.

  • serverfarms de la demostración — Proporciona la información de la red de servidor SLB.

  • parásitos atmosféricos de la demostración — Proporciona la información NAT del servidor estático SLB.

  • stats de la demostración — Provee estadísticas de SLB.

  • estatus de la demostración — Proporciona la información de estatus SLB.

  • demostración Sticky — Proporciona la base de datos fija SLB.

  • tecnología-soporte de la demostración — Proporciona el SLB información técnica del debug.

  • demostración vlan — Proporciona la información de VLAN SLB.

  • vservers de la demostración — Proporciona la información del servidor virtual SLB.

    show module csm 3 vservers name transparent detail
    
    TRANSPARENT, state = OPERATIONAL, v_index = 10
      virtual = 0.0.0.0/0:80, TCP, service = NONE, advertise = FALSE
      idle = 3600, replicate csrp = none, vlan = ALL
      max parse len = 2000, persist rebalance = TRUE
      conns = 0, total conns = 47
      Default policy:
        server farm = CACHE
        sticky: timer = 0, subnet = 0.0.0.0, group id = 0
      Policy           Tot Conn     Client pkts  Server pkts
      ------------------------------------------------------
      CACHE-POLICY     44           249          203
      NONCACHE-POLICY  37           111          37
      (default)        0            0            0
  • ¿módulo csm? — Configura el CS para el Almacenamiento en memoria caché transparente. También especifica la ubicación del CS que usted está configurando.

    cat(config)# module csm ?
    
    <1-6>  slot where the CSM module resides
  • vserver proxy — Configura al servidor virtual.

    cat(config-module-csm)# vserver proxy
    
    cat(config-slb-vserver)# ?
    
  • el vserver hace publicidad — Haga publicidad de la dirección IP virtual.

  • cliente de servidor virtual — Fija los dirección IP del cliente.

  • el vserver omite — Fija un comando a sus valores por defecto.

  • salida del vserver — Sale el submode del Server Load Balancing.

  • marcha lenta del vserver — Fija el temporizador de inactividad.

  • vserver en servicio — Los permisos mantienen para este servidor virtual.

  • ningún vserver — Niega un comando o fija sus valores por defecto.

  • analizar-longitud del vserver — Fija la capa máxima 7 analizan la longitud.

  • vserver persistente — Permisos o persistencia de la conexión de las neutralizaciones.

  • el vserver replica — Fija la replicación de la tolerancia de fallas del vserver.

  • serverfarm del vserver — Fija la granja del servidor real.

  • SLB-directiva del vserver — Fija la directiva del Server Load Balancing.

  • vserver Sticky — Fija el temporizador fijo.

  • URL-hash del vserver — Fija la coincidencia del prefijo/del sufijo para el algoritmo de URL-hash.

  • vserver virtual — Configura a un servidor virtual.

  • caché del serverfarm — Configura el bloque de servidores.

    cat(config-module-csm)# serverfarm cache
    
    cat(config-slb-sfarm)# ?
    
  • bindid del serverfarm — Lazos ID para el DFP.

  • valor por defecto del serverfarm — Fija un comando a sus valores por defecto.

  • salida del serverfarm — Submode del bloque de servidores de las salidas SLB.

  • failaction del serverfarm — Acción a adquirir la falla real del servidor.

  • serverfarm nacional — Fija la traducción de la dirección para el SLB.

  • ningún serverfarm — Niega un comando o fija sus valores por defecto.

  • predictor de serverfarm — Fija el algoritmo de predicción del Equilibrio de carga.

  • sonda del serverfarm — Configuraciones para el uso de una sonda.

  • serverfarm real — Configura a un servidor real.

  • reorientar-vserver del serverfarm — Configura un SLB reorientan al servidor virtual.

Comandos show del Content Engine

  • show statistics http savings — Guarda las estadísticas del Content Engine.

    ce1# show statistics http savings
    
                           Statistics - Savings
                         Requests           Bytes
    -----------------------------------------------
    Total:               635                2764599
    Hits:                113                254517
    Miss:                505                2483555
    Savings:            17.8 %              9.2 %

    Como usted puede ver, había 113 golpes.

Troubleshooting

No hay actualmente información disponible específica para resolver problemas esta configuración.


Información Relacionada


Document ID: 19680