IP : Resolución y asignación dinámica de direcciones

Uso de servidor DHCP para redes de voz y datos

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

En una red de telefonía IP optimizada, las direcciones IP de los teléfonos y los PC se deben configurar en diversos segmentos de red. Si DHCP (Dynamic Host Configuration Protocol) se utiliza para asignar direcciones, normalmente es necesario un servidor DHCP para cada segmento de red. Sin embargo, puede utilizar un solo servidor DHCP para asignar ambos rangos de direcciones si tiene routers compatibles con relé DHCP en su red de IP. Este documento explica cómo y por qué es posible utilizar un servidor único para la voz y las direcciones IP de datos.

Nota: La información de este documento no sirve para redes totalmente conmutadas o si no tiene un dispositivo con capacidad de ruteo. En tales escenarios, hay solamente dos posibilidades de asignar diversos IP Addresses a los teléfonos y PCs.You debe tener un servidor DHCP con dos Network Interface Cards o tener dos servidores DHCP.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Problema

Si usted instala una red de telefonía IP, después usted debe asignar los IP Addresses para sus teléfonos y los PC en diversos segmentos de red. Estas asignaciones de dirección necesitan un servidor DHCP para cada segmento de la red. Sin embargo, usted tiene solamente un servidor DHCP.

Solución

Para poder utilizar el actual servidor DHCP con el fin de asignar direcciones para ambas VLAN, debe tener un dispositivo de capa 3 (L3) en la red que puede realizar el ruteo entre VLAN.

Los dos ejemplos de este documento describen cómo utilizar un servidor DHCP para asignar direcciones IP de voz y de datos.

Configuración de la red

Hay una red actual con un Cisco Catalyst 6000 o un Catalyst 3524-XL-PWR. En cuál, VLAN10 se configura para ser el VLAN de dato usado por los PC y los servidores. En el mismo VLA N hay también un servidor DHCP que funciona con el Windows 2000 para proporcionar los direccionamientos en el rango 10.10.10.20 a 10.10.10.200. La dirección IP del servidor DHCP es 10.10.10.2.

dhcp-multintwk-1.gif

Para agregar el IP Telephony en esta red, conecte un teléfono IP con una PC en la parte posterior al puerto Catalyst, donde se conectó la PC.

Ejemplo de Catalyst 6000 con MSFC

En este escenario, hay un Cisco Catalyst 6000 con un (MSFC) de la Multilayer Switch Feature Card como el dispositivo con capacidad de la encaminamiento.

/image/gif/paws/19580/dhcp-multintwk-2.gif

Para permitir que la PC y el teléfono estén en el mismo puerto Catalyst, es necesario que configure el comando auxiliaryVLAN con la nueva VLAN 110 de voz como se muestra:

cat6k-access> (enable) set VLAN 110 name 11.1.1.0_voice
cat6k-access> (enable) set VLAN 10 5/1-48
cat6k-access> (enable) set port auxiliaryVLAN 5/1-48 110

Para permitir que el servidor DHCP actual en datos VLAN 10 sea utilizado para asignar direcciones IP a los teléfonos, siga estos pasos:

  1. Cree una interfaz en el MSFC para cada VLA N, datos y Voz.

  2. Configure cada interfaz con una dirección válida en el VLA N.

  3. En el VLA N 110 de la interfaz, agregue un comando ip helper-address.

    Este comando permite paquetes de difusión DHCP en la VLAN 110 de voz para ser enviados como paquetes de unidifusión al servidor DHCP en la VLAN 10 de datos.

    La configuración en el MSFC debe ser:

    cat6k-msfc(config)#interface vlan10
    cat6k-msfc(config-if)#ip address 10.10.10.19
    cat6k-msfc(config-if)#<description of data VLAN for PCs and where the DHCP
     server is located>
    
    cat6k-msfc(config)#interface vlan110
    cat6k-msfc(config-if)#ip address 11.1.1.19
    cat6k-msfc(config-if)#ip helper-address 10.10.10.2
    cat6k-msfc(config-if)#<description VLAN for voice>
    

    La configuración del Catalyst 6000 de Cisco permanece sin cambios.

  4. Configure el servidor DHCP con un nuevo alcance de los direccionamientos para los teléfonos (11.1.1.1.X) en el VLA N 110 de la Voz.

    Si el servidor DHCP no tiene un alcance que haga juego la dirección IP del Agente Relay, después el pedido de DHCP falla. Se requiere que agregue la opción 150 al alcance a fin de proporcionar acceso del servidor TFTP a los teléfonos. Para las instrucciones paso a paso en la configuración del servidor DHCP para los teléfonos, refiera a configurar el servidor DHCP del Windows 2000 para el Cisco CallManager.

Ejemplo de Catalyst 3524-XL con un router externo

En este escenario, hay un Cisco Catalyst 3524-XL-PWR y un router externo como el dispositivo con capacidad de la encaminamiento, con una interfaz en cada VLA N.

/image/gif/paws/19580/dhcp-multintwk-3.gif

Para permitir que el PC y el teléfono estén en el mismo puerto Catalyst, enlace de la configuración con el nuevo VLA N 110 de la Voz como se muestra:

interface FastEthernet0/13
description phone and PC
switchport mode trunk
switchport trunk encapsulation dot1q
switchport voice vlan 110
switchport trunk native vlan 10

Repita la configuración para todos los puertos de Catalyst donde haya conectado un teléfono con una PC conectada al mismo.

Para permitir que el servidor DHCP actual en datos VLAN 10 sea utilizado para asignar direcciones IP a los teléfonos, siga estos pasos:

  1. Conecte dos interfaces del router con dos puertos en el Cisco Catalyst 3524-XL, uno en el VLAN10 y el otro en el VLA N 110.

  2. Del lado del router, asigne una dirección válida en cada VLAN.

    Nota: Con el enlace configurado, usted puede también alcanzar esto con un puerto único conectado del Catalyst 3524-XL con el router.

  3. Publique el comando ip helper-address en la interfaz del router que está conectada para expresar el VLA N 110.

    Esto permite que los paquetes de difusión DHCP recibidos en la interfaz se envíen como paquetes de unidifusión al servidor DHCP en VLAN de datos 10.

    La configuración del router debe ser la siguiente:

    router(config)#interface FastEthernet0/0 
    router(config-if)#ip address 10.10.10.19 255.255.255.0 
    
    router(config-if)#<description connected to catalyst port 0/10 
     data VLAN for PCs and DHCP server>
     
    router(config)#interface FastEthernet0/1
    router(config-if)#IP address 11.1.1.19 255.255.255.0 
    router(config-if)#IP helper-address 10.10.10.2 
    router(config-if)#<description connected to catalyst port 0/11 voice VLAN>
    
    

    La configuración en el Cisco Catalyst 3524-XL debe ser:

    router(config)interface FastEthernet0/10
    router(config-if)#switchport access vlan 10
    router(config-if)#<description port on data VLAN going to the router FE0/0>
    
    router(config)interface FastEthernet0/11
    router(config-if)#switchport access vlan 110
    router(config-if)#<description port on voice VLAN going to the router FE0/1>
    
  4. Configure el servidor DHCP con un nuevo alcance de los direccionamientos para los teléfonos (11.1.1.1.X) en el VLA N 110 de la Voz.

    Si el servidor DHCP no tiene un alcance que haga juego la dirección IP del Agente Relay, el pedido de DHCP falla. Se requiere que agregue la opción 150 al alcance a fin de proporcionar acceso del servidor TFTP a los teléfonos. Para las instrucciones paso a paso en la configuración del servidor DHCP para los teléfonos, refiera a configurar el servidor DHCP del Windows 2000 para el Cisco CallManager.

Cómo funciona la solución

El servidor DHCP puede proporcionar direcciones para ambas VLAN desde el alcance adecuado, basado en el uso del campo Relay Agent en los paquetes DHCP. Un Agente Relay es el agente que está responsable de la conversión de los paquetes DHCP del broadcast enviados por el teléfono en los paquetes de unidifusión que se envían al servidor DHCP. Este agente también convierte los paquetes DHCP del unicast enviados del servidor DHCP en los paquetes de broadcast que se envían en la red telefónica. En este ejemplo, el Agente Relay es la interfaz del VLA N 110 en el MSFC configurado con el comando ip helper-address.

Cuando el servidor DHCP recibe el mensaje de detección DHCP con una dirección IP actual en el campo Relay Agent (Agente de retransmisión), utiliza dicha dirección para coincidir con el alcance apropiado y asigna la dirección IP desde ésta. Puede ver los detalles de este protocolo en RFC 3046.leavingcisco.com

Los paquetes DHCP que se intercambian en este ejemplo serían tal como se los muestra:

/image/gif/paws/19580/dhcp-multintwk-4.gif

Las líneas azules muestran los paquetes DHCP que se envían a y desde el IP Telephone. Estos son los únicos paquetes que aparecen si el servidor DHCP está en la misma red Ethernet que los teléfonos.

Las líneas negras representan los paquetes de unidifusión de DHCP que el agente de relé transmite a y desde el servidor DHCP.

Esta tabla muestra los detalles de los paquetes para este ejemplo. Para más información sobre el protocolo DHCP y los campos, refiera al RFC 1541leavingcisco.com .

1 DHCP descubre 2 DHCP descubren
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255] 

DHCP Client IP Address = [0.0.0.0] 
DHCP Relay Agent = [0.0.0.0] 
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover) 
Parameter Request List:
...
    150= Unknown Option 
... 
IP Source Address = [11.1.1.19] 
IP Destination Address =[10.10.10.2]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover)
Parameter Request List:
...
    150= Unknown Option 
...
Oferta de DHCP 4 Oferta de DHCP 3
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2]
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
Pedido de DHCP 5 Petición DHCP 6
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [0.0.0.0]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
IP Source Address = [11.1.1.19] 
IP Destination Address = [10.10.10.2]

DHCP Client IP Address =  [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
8 DHCP Ack 7 DHCP Ack
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2] 
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 19580