IP : Protocolo de puerta de enlace fronteriza (BGP)

Solución de problemas cuando las rutas del BGP no están anunciadas

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El objetivo de este documento es brindar un enfoque sistemático para ayudar a resolver situaciones de problemas cuando un router de un Protocolo de pasarela de frontera (BGP) no anuncia las rutas BGP a los pares.

Hay las diferentes formas en las cuales un prefijo se agrega a una tabla BGP y se anuncia a los pares:

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware. Sin embargo, las salidas mostradas en el documento se basan en los Cisco 2500 Series Router que funcionan con la versión de software 12.2(24)a del½ del¿Â del Cisco IOSïÂ.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Rutas anunciadas que utilizan una declaración de red básica

Cuando las rutas se anuncian usando una declaración de red básica, el comportamiento del comando network varía dependiendo de si el automóvil summary está habilitado o inhabilitado. Cuando autoresumen está habilitado, resume las redes BGP originadas de manera local (red x.x.x.x) a sus límites con clase (autoresumen está habilitado como valor predeterminado en BGP). Si una subred existe en la tabla de ruteo y se satisfacen estas tres condiciones, cualquier subred (ruta del componente) de esa red classful en la tabla de ruteo local indica al BGP que instale la red classful en la tabla BGP:

  • Auto-summary habilitado

  • Declaración de red classful para una red en la tabla de ruteo

  • Máscara con clase en esa declaración de la red

Cuando auto-summary (autoresumen) está deshabilitado, las rutas que se introducen localmente en la tabla de BGP no se resumen en función de sus límites con clase.

Por ejemplo, el BGP introduce la máscara 255.0.0.0 de 75.0.0.0 de la red classful en la tabla BGP si se cumplen estas condiciones:

Si estas condiciones no son todas resueltas, el BGP no instala una entrada en la tabla BGP a menos que haya un exacto - hace juego en la tabla de IP Routing.

Pasos para la resolución de problemas

Con auto-summary habilitado en R101, el router no puede anunciar la red Classful 6.0.0.0/8 a R102.

bgp_noad_01.gif

  1. Marque para ver si el R101 anuncia 6.0.0.0/8 al R102. La salida mostrada confirma que el R101 no anuncia 6.0.0.0/8 al R102.

    R101# 
    show ip bgp neighbors 10.10.10.2 advertised-routes
    
    R101#
  2. Marque la configuración corriente. El ejemplo mostrado ilustra que el R101 está configurado con Declaración de red classful. El automóvil summary se habilita por abandono en la versión del Cisco IOS Software usada para este escenario.

    R101# 
    show running-config | begin bgp
    
    router bgp 1
     network 6.0.0.0
     neighbor 10.10.10.2 remote-as 2
    [...]
  3. Marque para ver si usted tiene una ruta del componente (una ruta classful o una ruta de subred) de la red 6.0.0.0/8 en la tabla de ruteo.

    R101# 
    show ip route 6.0.0.0 255.0.0.0 longer-prefixes 
    
    R101#
  4. Porque no hay ruta del componente (ninguna ruta o ruta de subred classful) en la tabla de IP Routing R101, la red 6.0.0.0 adentro no instalado en la tabla BGP. El requisito mínimo para instalar un prefijo configurado bajo el comando network en una tabla BGP, es tener una ruta componente en la tabla de IP Routing. Aseegurese tanto como el R101 tiene una ruta del componente para la red 6.0.0.0/8 aprendiéndola con el IGP o con la configuración estática. En el ejemplo mostrado, la Static ruta se configura al null0.

    R101(config)# ip route 6.6.10.0 255.255.255.0 null 0 200
    
  5. Tan pronto como la tabla de IP Routing tenga una ruta del componente para 6.0.0.0/8, el BGP instala una red classful en la tabla BGP.

    R101# show ip route 6.0.0.0  255.0.0.0 longer-prefixes 
    
    [..]
         6.0.0.0/24 is subnetted, 1 subnets
    S       6.6.10.0 is directly connected, Null0
    
    
  6. Para que el cambio surja efecto en BGP y comience a anunciar la red 6.0.0.0/8 a R102, debe limpiar el vecino BGP o hacer una restauración de software de par. Este ejemplo muestra un reinicio del software de salida para mirar 10.10.10.2 para traer los cambios en el efecto. Para más detalles en el reinicio del software, vea la sección Administración de cambios en la política de ruteo en configurar el BGP.

    R101# clear ip bgp 10.10.10.2 [soft] out
    R101#
  7. Para que el cambio surja efecto en BGP y comience a anunciar la red 6.0.0.0/8 a R102, debe limpiar el vecino BGP o hacer una restauración de software de par. Este ejemplo muestra un reinicio del software de salida para mirar 10.10.10.2 para traer los cambios en el efecto. Para más información sobre el reinicio por software, consulte la sección de Administración de cambios en la política del ruteo en Configuración de BGP.

    R101# show ip bgp | include 6.0.0.0 
    *> 6.0.0.0 0.0.0.0 0 32768 i
    
  8. El comando show ip bgp confirma que la red classful 6.0.0.0/8 se introduce en BGP.

    R101# show ip bgp | include 6.0.0.0 
    *> 6.0.0.0 0.0.0.0 0 32768 i
  9. Confirme que el R101 anuncia las rutas al R102.

    R101# show ip bgp neighbors 10.10.10.2 advertised-routes | include 6.0.0.0 
    *> 6.0.0.0 0.0.0.0 0 32768 i

    Nota: Con el automóvil summary inhabilitado, el BGP instala la red 6.0.0.0/8 solamente cuando hay una ruta de coincidencia exacta en la tabla de ruteo. Si hay las rutas de subred pero ninguna ruta de coincidencia exacta (6.0.0.0/8) en la tabla de ruteo, después el BGP no instala la red 6.0.0.0/8 en la tabla BGP.

Rutas anunciadas que utilizan la declaración de la red con una máscara

Las redes que caen en un límite de red principal (255.0.0.0, 255.255.0.0, o 255.255.255.0) no necesitan tener una máscara incluida. Por ejemplo, el comando de 172.16.0.0 de la red es suficiente enviar el prefijo 172.16.0.0/16 en la tabla BGP. Sin embargo, las redes que no caen en los límites de red principal se requieren para tener una declaración de la red con una máscara, tal como máscara 255.255.255.0 de 172.16.10.0 de la red.

Una ruta exacto en la tabla de ruteo se requiere para una declaración de la red con una máscara para que sea instalada en una tabla BGP.

Pasos para la resolución de problemas

R101 no puede anunciar la red 172.16.10.0/24 a R102.

/image/gif/paws/19345/bgp_noad_02.gif

  1. Marque para ver si el R101 anuncia el prefijo 172.16.10.0/24 al R102.

    R101# show ip bgp neighbors 10.10.10.2 advertised-routes
    R101#

    O

    Este comando se puede utilizar para marcar si se están haciendo publicidad las rutas:

    R101#show ip bgp 172.16.10.0/24
    R101# BGP routing table entry for 172.16.10.0/24, version 24480684
          Bestpath Modifiers: deterministic-med
          Paths: (4 available, best #3)
          Not advertised to any peer   <---- not advertised to any peers

    El resultado anterior confirma que R101 no está promocionando 192.168.32.0/22 al R102.

  2. Marque la configuración corriente.

    R101# show run | begin bgp
    router bgp 1
      network 172.16.10.0

    Nota: Usted quiere originar la red 172.10.10.0/24. Esta red no cae en el límite de una Red clase B (255.255.0.0). Una declaración de la red con las necesidades de 255.255.255.0 de la máscara de ser configurado para hacer que trabaja.

  3. Después de que una declaración de la red con la máscara se configure, el comando show run muestra la salida similar a esto:

    R101# show run | begin bgp
    router bgp 1
      network 172.16.10.0 mask 255.255.255.0
  4. Marque para ver si la ruta está en la tabla de BGP Routing.

    R101# show ip bgp | include 172.16.10.0
    R101#

    La red 172.16.10.0/24 no existe en la tabla BGP.

  5. Marque para ver si hay una ruta exacto en la tabla de IP Routing. La salida mostrada confirma que no hay una ruta exacto en la tabla de ruteo.

    R101# show ip route 172.16.10.0 255.255.255.0   
    % Network not in table
    R101#
  6. Decida qué rutas usted quiere para originar. Después repare el IGP o configure las Static rutas.

    R101(config)# ip route 172.16.10.0 255.255.255.0 null 0 200
    
  7. Marque la tabla de IP Routing.

    R101# show ip route 172.16.10.0 255.255.255.0 longer-prefixes 
    
    [..]
         172.16.0.0/24 is subnetted, 1 subnets
    S       172.16.10.0 is directly connected, Null0
  8. Verifique que las rutas estén en la tabla BGP

    R101# show ip bgp | include 172.16.10.0 
    *> 172.16.10.0/24   0.0.0.0                  0         32768 i
  9. Para que el cambio se aplique en BGP y comience a anunciarle la red 6.0.0.0/8 al R102, debe borrar el vecino BGP o hacer un reinicio del par por software. Este ejemplo utiliza un reinicio del software de salida para mirar 10.10.10.2. Para más detalles en los reinicios del software, vea la sección Administración de cambios en la política de ruteo en configurar el BGP.

    R101# clear ip bgp 10.10.10.2 [soft] out
    
  10. Confirme que las rutas se están haciendo publicidad al R102.

    R101# show ip bgp  neighbors 10.10.10.2 advertised-routes | include 172.16.10.0
    *> 172.16.10.0/24   0.0.0.0                  0         32768 i
    

Rutas anunciadas usando el comando aggregate-address

El BGP permite la agregación de las rutas específicas en una ruta usando el comando aggregate-address address mask. La agregación se aplica a las rutas que existen en la tabla de BGP Routing. Esto es a diferencia del comando network, que se aplica a las rutas que existen en la tabla de IP Routing. La agregación puede ser realizada si por lo menos uno o más de las rutas específicas de la dirección global existen en la tabla de BGP Routing. Para obtener más información sobre el agregado de BGP y atributos relacionados, consulte Introducción al agregado de rutas en BGP.

Pasos para la resolución de problemas

/image/gif/paws/19345/bgp_noad_03.gif

En este diagrama de la red, el R101 no puede anunciar a la dirección global 192.168.32.0/22 al R102. La red 192.168.32.0/22 agrega estos espacios de la dirección del C de tres clases:

  • 192.168.33.0/24

  • 192.168.35.0/24

  • 192.168.35.0/24

  1. Confirme que el R101 no está anunciando 192.168.32.0/22 al R102.

    R101# show ip bgp neighbors 10.10.10.2 advertised-routes | include 192.168.32.0 
    R101#
  2. Marque la configuración corriente.

    router bgp 1
       [..]
       aggregate-address 192.168.32.0 255.255.252.0 summary-only
       neighbor 10.10.10.2 remote-as 2

    El R101 se configura para anunciar solamente a la dirección global al R102 usando el atributo del “sumario solamente”.

  3. Marque la tabla de IP Routing.

    R101# show ip route 192.168.32.0 255.255.252.0 longer-prefixes 
    [..]
    S    192.168.33.0/24 is directly connected, Null0

    La tabla de IP Routing tiene la ruta del componente del agregado 192.168.32.0/22; no obstante para que una dirección global sea anunciada a un par, una ruta del componente debe existir en la tabla de BGP Routing bastante que en la tabla de IP Routing. La tabla de IP Routing tiene la ruta del componente del agregado 192.168.32.0/22; no obstante para que una dirección global sea anunciada a un par, una ruta del componente debe existir en la tabla de BGP Routing bastante que en la tabla de IP Routing.

  4. Marque para ver si una ruta del componente existe en la tabla de BGP Routing.

    R101# show ip bgp 192.168.32.0 255.255.252.0 longer
       R101#

    La salida confirma que la tabla BGP no tiene una ruta del componente, así que el paso lógico siguiente es asegurarse de que una ruta del componente existe en la tabla BGP.

  5. En este ejemplo, una ruta del componente 192.168.33.0 está instalada en la tabla BGP usando el comando network.

    R101(config)# router bgp 1
    R101(config-router)# network 192.168.33.0
    
  6. Marque para ver si la ruta del componente existe en la tabla BGP.

    R101# show ip bgp 192.168.32.0 255.255.252.0 longer-prefixes 
    BGP table version is 8, local router ID is 10.10.20.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 192.168.32.0/22  0.0.0.0                            32768 i
    s> 192.168.33.0     0.0.0.0                  0         32768 i
    R101#

    “S” significa que la ruta del componente es suprimido debido al argumento del “sumario solamente”.

  7. Confirme que el agregado está anunciado al R102.

    R101# show ip bgp n 10.10.10.2 advertised-routes | include 192.168.32.0/22
    *> 192.168.32.0/22  0.0.0.0

No es posible anunciar las rutas aprendidas iBGP

Un router BGP con la sincronización habilitada no hará publicidad de las rutas IBGP aprendidas a otros pares del eBGP si no puede validar esas rutas en su IGP. Si se asume que el IGP tiene una ruta a las rutas IBGP aprendidas, el router anunciará las rutas del iBGP a los pares del eBGP. Si no el router trata la ruta como no siendo sincronizado con el IGP y no hace publicidad de ella. Inhabilitar la sincronización usando el comando no synchronization bajo el BGP del router evita que el BGP valide las rutas del iBGP en el IGP. Para obtener más información, consulte la sección Sincronización de Estudios de casos BGP.

Pasos para la resolución de problemas

En el diagrama mostrado, el R101 aprende el prefijo 130.130.130.0/24 del R103 con el iBGP y no puede anunciarlo al par R102 del eBGP.

/image/gif/paws/19345/bgp_noad_04.gif

  1. En primer lugar controle R101.

    R101# show ip bgp neighbors 10.10.20.2 advertised-routes | include 130.130.130.0
    R101#

    La salida antes mencionada confirma que R101 no anuncia el prefijo 130.130.130.0/24 a R102. Mire la tabla BGP en el R101:

    R101# show ip bgp 130.130.130 255.255.255.0 longer
    BGP table version is 4, local router ID is 10.10.20.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    * i130.130.130.0/24 10.10.20.3               0    100      0 i
    R101#

    La red 130.130.130.0/24 existe en la tabla BGP. Sin embargo la red 130.130.130.0/24 no tiene el código de estado de la mejor ruta (>). Esto significa que el algoritmo de selección del mejor trayecto BGP no eligió este prefijo como el mejor trayecto. Dado que sólo se anuncian los mejores trayectos a los pares BGP, la red 130.130.130.0/24 no se anuncia a R102. Después, usted necesita resolver problemas porqué el criterio de selección de trayecto BGP no seleccionó esta red como la mejor ruta.

  2. Examine la salida del comando show ip bgp prefix de darle más detalles en porqué el prefijo no fue elegido como la mejor ruta ni fue instalado en la tabla de IP Routing.

    R101# show ip bgp 130.130.130.0
    BGP routing table entry for 130.130.130.0/24, version 4
    Paths: (1 available, no best path)
      Not advertised to any peer
      Local
        10.10.20.3 from 10.10.20.3 (130.130.130.3)
          Origin IGP, metric 0, localpref 100, valid, internal, not synchronized

    El resultado muestra que el prefijo 130.130.130.0/24 no está sincronizado.

    Nota: Antes de que la identificación del bug CSCdr90728 (los “trayectos BGP no se marcan como no sincronizado”), el comando show ip bgp prefix no mostrara las trayectorias marcadas como no sincronizado. Este problema está corregido en las versiones 12.1(4) y posteriores del software del IOS de Cisco.

  3. Marque la configuración BGP corriente.

    R101# show ip protocols 
    Routing Protocol is "bgp 1"
      Outgoing update filter list for all interfaces is not set
      Incoming update filter list for all interfaces is not set
      IGP synchronization is enabled
      Automatic route summarization is disabled
      Neighbor(s):
        Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
        10.10.10.2                                           
        10.10.20.3                                           
      Maximum path: 1
      Routing for Networks:
      Routing Information Sources:
        Gateway         Distance      Last Update
        10.10.20.3           200      01:48:24
      Distance: external 20 internal 200 local 200

    La salida antedicha muestra que la sincronización de BGP está habilitada. La sincronización de BGP se habilita por abandono en Cisco IOS Software.

  4. Configuración BGP para inhabilitar la sincronización. Publique el comando no synchronization bajo el BGP del router.

    R101(config)# router bgp 1
    
    R101(config-router)# no synchronization 
    
    R101# show ip protocols 
    
    Routing Protocol is "bgp 1"
      Outgoing update filter list for all interfaces is not set
      Incoming update filter list for all interfaces is not set
      IGP synchronization is disabled
      Automatic route summarization is disabled
      Neighbor(s):
        Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
        10.10.10.2                                           
        10.10.20.3                                           
      Maximum path: 1
      Routing for Networks:
      Routing Information Sources:
        Gateway         Distance      Last Update
        10.10.20.3           200      01:49:24
      Distance: external 20 internal 200 local 200

    Durante el funcionamiento siguiente del escáner BGP, que analiza la tabla BGP cada 60 segundos y toma la decisión basada en el criterio de selección de trayecto BGP, la red 130.130.130.0 será instalada (puesto que se inhabilita la sincronización). Esto significa que el tiempo máximo para instalar la ruta es de 60 segundos, pero puede ser menos, dependiendo de cuándo se haya configurado el comando no synchronization y de cuándo ocurra la próxima instancia del escáner BGP. Por eso es mejor esperar 60 segundos antes del siguiente paso de verificación.

  5. Verifique que la ruta haya estado instalada.

    La salida mostrada confirma que el prefijo 130.130.130.0/24 es la mejor ruta; por lo tanto, está instalada en la tabla de IP Routing y propagada para mirar 10.10.10.2.

    R101# show ip bgp 130.130.130.0
    BGP routing table entry for 130.130.130.0/24, version 5
    Paths: (1 available, best #1, table Default-IP-Routing-Table)
      Advertised to non peer-group peers:
      10.10.10.2 
      Local
        10.10.20.3 from 10.10.20.3 (130.130.130.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
    
    R101# show ip bgp neighbors 10.10.10.2 advertised-routes | include 130.130.130.0/24
    *>i130.130.130.0/24 10.10.20.3               0    100      0 i

Las rutas anunciadas con redistribuyen los parásitos atmosféricos

Si el Routers está conectado con dos links, y las rutas son doctas a través del BGP y de las Rutas estáticas flotantes, las Rutas estáticas flotantes están instaladas en la tabla de ruteo. Esto ocurre si las Static rutas se redistribuyen en el caso del error de la ruta BGP. Si se vuelven las rutas BGP en línea, las Rutas estáticas flotantes en la tabla de ruteo no se cambian para reflejar las rutas BGP.

Este problema puede ser solucionado si usted quita el comando redistribute static bajo proceso BGP de evitar el priorización de las Rutas estáticas flotantes sobre las rutas BGP.


Información Relacionada


Document ID: 19345