Banda ancha por cable : Cable módems

Cómo configurar a un router Cisco detrás de un cablemódem que no es de Cisco

18 Junio 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (21 Abril 2016) | Comentarios


Contenido


Introducción

En ciertos entornos en los que se utiliza un cable módem (CM) que no es de Cisco, y el CM solamente es capaz de bridging, un router Cisco, como el Cisco 806, se puede conectar al CM a través de la interfaz Ethernet. Entonces el ruteo es realizado por el router detrás del CM. El paso siguiente es la conexión del PC cliente o Equipo en las instalaciones del cliente (CPE) al router. Después de hacer esta conexión, se configura la Traducción de Dirección de Red (NAT) en el router.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • 806 Series Router que funciona con la versión 12.2(2)XI del ½ del ¿Â de Cisco IOSïÂ

  • Router CM que actúa como Bridge

  • Windows 2000 corriente PC que actúa como el CPE

  • Sistema de terminación del cablemódem (CMTS) del uBR7246VXR

Nota: Solamente las configuraciones del Cisco 806 Router se muestran en este documento. Para más información sobre configurar el CMTS, refiera a los ejemplos de configuración y a las notas técnicas de la tecnología de cable.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/broadband-cable/cable-modems/19268-router-behind-cm-19268.gif

Configuraciones

Este documento utiliza la configuración del 806 Router:

Configuración del 806 Router
Building configuration...
Current configuration : 1673 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.
!
username Router password 7 08325C5C00170247425D5506382E2523
username Cisco privilege 15 password 7
134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416
ip subnet-zero
ip name-server 24.29.99.81
ip name-server 24.29.99.82
ip dhcp excluded-address 10.10.10.1 


!--- Issue the ip dhcp excluded-address command to exclude IP 
!--- addresses from being assigned by the DHCP server. This excludes 
!--- E0 IP address.

ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 10.10.10.10
ip dhcp excluded-address 10.10.10.3
ip dhcp excluded-address 10.10.10.4
ip dhcp excluded-address 10.10.10.5
ip dhcp excluded-address 10.10.10.6
ip dhcp excluded-address 10.10.10.7
ip dhcp excluded-address 10.10.10.8
ip dhcp excluded-address 10.10.10.9
!
ip dhcp pool CLIENT 

!--- Configures a DHCP address pool.

import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 24.29.99.82
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0 

!--- This interface connects to the internal network, including CPE.

ip address 10.10.10.1 255.255.255.0
ip nat inside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
interface Ethernet1 

!--- This interface connects to the same Ethernet segment as the CM.
 
ip address dhcp 

!--- This command allows the router to obtain IP address dynamically.

ip nat outside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload 

!--- IP NAT configuration.

ip classless
ip route 0.0.0.0 0.0.0.0 66.108.112.1

!--- IP address 66.108.112.1 is the next hop IP address, also called 
!--- the default gateway. Your Internet service provider (ISP) can tell you what IP address to 
!--- configure as the next hop address.

ip http server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Router#

                     

                      
                     

                     

Verificación

Para verificar que el router obtuviera una dirección IP en su e1 de los Ethernetes dinámicamente, utilice el comando show ip interface brief.

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up    up

Asegúrese de que su tabla de ruteo tenga las entradas correctas. Por ejemplo, en esta visualización, la ruta predeterminado está a 66.108.112.1. Esto está instalada con el proceso DHCP cuando el router recibe la dirección IP en la interfaz de Ethernet.

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

Troubleshooting

Cuando el router está conectado detrás del CM, el primer problema que pudo ocurrir no está obteniendo una dirección IP dinámicamente en la interfaz de Ethernet del router. La mayoría de los ISP permiten solamente un host o PC detrás del CM. Algunos ISP asignan una dirección IP al PC basado en el nombre del host. Por lo tanto, si usted tiene un router detrás del CM, después el nombre del host para el router configurado usando el comando hostname debe ser el mismo nombre del host dado por el ISP.

Si el router no está obteniendo una dirección IP dinámicamente, la primera cosa a marcar es si existe el DHCP del IP Address del comando interface configuration. Este comando está bajo interfaz de Ethernet conectada con el CM. El comando fue introducido en la versión de software IOS 12.1(2)T.

Si existe el comando ip address dhcp, pero el router detrás del CM todavía no está obteniendo una dirección IP, conecte un PC detrás del CM para detectar si está recibiendo una dirección IP. Esto verifica que los servicios del DHCP estén trabajando correctamente. Los ISP permiten típicamente solamente un host detrás del CM, por lo tanto conectando un PC detrás de las cuentas CM como el primer host. Sigue habiendo esta entrada en la base de datos del ISP por 24 horas. Por lo tanto, si usted conecta al router detrás del CM, el ISP piensa que el router es un segundo host y lo rechaza. Si ocurre esto, libere la dirección IP de su PC completando estos pasos en su Windows 2000 PC:

  1. Desde el principio el menú elige el funcionamiento.

  2. El cmd del tipo entonces presiona el retorno de carro.

  3. En el prompt, ipconfig /release del tipo.

  4. Después de liberar la dirección IP del PC, reinicie su CM e intente otra vez.

Si esto no trabaja, usted necesita llamar su ISP y pedirlos para borrar la primera entrada de host en su CMTS.

Otro método es configurar la interfaz de Ethernet del router. Esto conecta con el CM con la dirección MAC del PC usando el comando mac-address ieee-address.

Usando la misma dirección MAC en la interfaz de Ethernet que conecta con el CM como el PC, el ISP aprende solamente cerca de un host y una dirección IP. El PC no consigue rechazado conectado una vez detrás del router. El NAT tiene que ser configurado en el router para validar las traducciones de la dirección IP.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • haga el debug del detalle DHCP — Utilice el comando debug dhcp detail de visualizar la información de debugging del DHCP. Esto se utiliza para resolver problemas porqué el router Cisco no pudo obtener una dirección IP para la interfaz de Ethernet.

  • [packet] del [linkage] del [events] del ip dhcp server del debug — Utilice el comando debug ip dhcp server de visualizar el debugging del servidor DHCP. Esto ayuda a determinar porqué el PC, que está conectado con el router, no pudo obtener un IP Address.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 19268