Switches : Cisco Catalyst Multiservice Switch Routers de la serie 8500

Configuración del ruteo de multidifusión IP sobre el módulo de ruta ATM (ARM) en Cisco Catalyst 8540 MSR

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Mientras que las redes aumentan de tamaño, el IP Multicast Routing llega a ser críticamente importante como los medios de determinar qué segmentos requieren el tráfico Multicast y cuáles no lo hacen. El Multicast IP es una técnica de la encaminamiento que permite que el tráfico IP sea propagado a partir de una fuente a varios destinos, o de muchas fuentes a muchos destinos. Bastante que enviando un paquete a cada destino, un paquete se envía al grupo de multidifusión identificado por un solo grupo de dirección del destino IP.

Este documento muestra cómo configurar el ruteo de multidifusión de IP en un módulo de router ATM (ARM) en un Catalyst 8540 MSR. Esta configuración es admitida por ARM y ARM mejorado (conocidos como ARM I y ARM II, respectivamente).

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimientos acerca de las configuraciones básicas de multidifusión IP en routers de Cisco. Para la información previa, refiera a estos documentos:

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 3600, 7200, y 7500 Series Router que ejecutan la versión de software del � del Cisco IOS 12.1.(7)

  • Catalyst 8540MSR y Catalyst 8510MSR que funcionan con el Cisco IOS Software Release 12.1(7)EY

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

/image/gif/paws/19244/arm-mul.gif

El Cisco 3640 Router, conocido como C3640, está conectado con el Cisco Catalyst 8540 MSR (conocido como 8540MSR) a través del puerto Fast Ethernet 3/0/1. El 8540MSR tiene un BRAZO en el SLOT 11. El C8540MSR está conectado físicamente con el 8510MSR usando la interfaz ATM 9/1/0. El switch ATM 8510MSR se conecta con el 8540MSR en la interfaz ATM 1/0/2.

Hay dos circuitos virtuales permanentes (PVC) construidos con el 8510MSR. Uno proviene de la subinterfaz multipunto 8540MSR ARM hacia el router C7513 y el otro proviene de la misma subinterfaz hacia el router C7204. El protocolo de ruteo utilizado es Abrir trayecto más corto primero (OSPF). Configuran al modo denso de la multidifusión independiente con protocolo IP (PIM) en el Routers. Esto incluye el módulo del BRAZO en 8540MSR. C3640, C7513, y C7204 tienen una interfaz configurada para unirse al grupo de multidifusión 239.0.10.1. Un ping de C3640 a la dirección Multicast 239.0.10.1 consigue las respuestas de C3640, de C7513, y de C7204.

Configuraciones

Esta sección contiene las porciones de la configuración en los routers y switches descritas en el diagrama de red. Ésta es información específica sobre la configuración:

  • La configuración que aparece en este aal5mux de la encapsulación de las aplicaciones del documento.

  • Una subinterfaz de multipunto se crea en el BRAZO, mientras que el ATM PVC se configura a los sitios remotos.

  • PIM se usa en modo denso. Por lo que el PIM, el BRAZO no distingue entre VCs individual en la interfaz multipunto.

  • El tráfico Multicast se remite hacia fuera a todo el VCs que “ha transmitido” configurado.

  • El resultado de show ip mroute ilustra que PIM sólo identifica la interfaz saliente y no los VC individuales.

La configuración para el IP Multicast Routing con la ayuda del PIM se muestra aquí. Muestran todos los comandos relevant para el IP Multicast Routing en intrépido.

C3640
ip multicast-routing
!
interface Ethernet1/0
 ip address 10.10.200.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
!

C8540MSR
ip multicast-routing
!
interface FastEthernet3/0/1
 ip address 10.10.200.2 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 no ip mroute-cache
!
!
interface ATM11/0/0.1 multipoint
 ip address 75.75.75.2 255.255.255.0
 ip pim dense-mode
 ip ospf network point-to-multipoint
 map-group multicast
 atm pvc 2 1000 pd on  encap aal5mux ip interface  ATM9/1/0 0 1000 
 atm pvc 2 1001 pd on  encap aal5mux ip interface  ATM9/1/0 0 1001 
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.1 atm-vc 1000 aal5mux broadcast
 ip 75.75.75.3 atm-vc 1001 aal5mux broadcast

8510MSR
interface ATM1/0/2
 no ip address
 atm pvc 0 1000  interface  ATM1/0/1 0 1000 
!         
interface ATM1/0/3
 no ip address
 atm pvc 0 1001  interface  ATM1/0/2 0 1001 
! 

C7513
ip multicast-routing
!
!         
interface Ethernet9/0/2
 ip address 30.30.30.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
!
interface ATM1/0/0.1 multipoint
 ip address 75.75.75.1 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1000 0 1000 aal5mux ip
!
!
router ospf 1
 log-adjacency-changes
 network 30.30.30.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1000 broadcast
!

C7204
ip multicast-routing
!
interface Loopback0
 ip address 40.40.40.1 255.255.255.0
 ip igmp join-group 239.0.10.1
!
!
interface ATM4/0.5 multipoint
 ip address 75.75.75.3 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1 0 1001 aal5mux ip
!
router ospf 1
 log-adjacency-changes
 network 40.40.40.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1 broadcast

Verificación

Use los siguientes comandos para probar que su red esté funcionando correctamente:

La herramienta Output Interpreter Tool (solo para clientes registrados) soporta ciertos comandos show. Esto le permitirá ver un análisis del resultado del comando show.

  • show ip route—Muestra las entradas de la tabla de IP Routing.

  • muestre al vecino del pim del IP — Enumera a los vecinos del PIM descubiertos por el software de Cisco IOS�.

  • muestre la ruta multicast del IP — Visualiza el contenido de la tabla de IP Multicast Routing.

  • muestre a los grupos IGMP del IP — Visualiza a los grupos de multidifusión que están conectados directamente con el router y que son doctos con el IGMP.

Esta salida es el resultado del ingreso de estos comandos show en los dispositivos presentados en el diagrama de red. Este resultado muestra que la red está funcionando correctamente.

C3640

Se usa el comando show ip route en el C3640 para verificar que este router llegue a todas las direcciones IP de la red. Tiene una ruta a 75.75.75.1, 75.75.75.2, 75.75.75.3. Se definen las interfaces del loopback. Todas las rutas se encuentran con el OSPF.

C3640#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/12] via 10.10.200.2, 00:01:48, Ethernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.200.0 is directly connected, Ethernet1/0
     75.0.0.0/32 is subnetted, 3 subnets
O       75.75.75.3 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.2 [110/10] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.1 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/21] via 10.10.200.2, 00:01:49, Ethernet1/0

Este comando se utiliza para identificar a los vecinos PIM IP. El vecino en este caso es el C8540MSR.

C3640#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface          Uptime/Expires    Ver   DR
Address                                                      Priority/Mode
10.10.200.2       Ethernet1/0        3d03h/00:01:16    v2    N / DR

Si hacen ping al grupo de multidifusión del C3640, es acertado. Esto indica que C3640 transmite al grupo de multidifusión definido por la dirección IP 239.0.10.1.

C3640#ping 239.0.10.1  

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.10.1, timeout is 2 seconds:
Reply to request 0 from 10.10.200.1, 4 ms
Reply to request 0 from 75.75.75.3, 4 ms
Reply to request 0 from 75.75.75.1, 4 ms

El comando show ip mroute visualiza la información sobre el tabla de Multicast Routing. En este ejemplo hay una ruta nula para 239.0.10.1 y 224.0.1.40. La última dirección multidifusión es la designada por la autoridad de números asignados de Internet (IANA) para cisco-rp-discovery.

C3640#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Advertised via MSDP, U - URD,
       I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 2d23h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00

(*, 239.0.10.1), 1w1d/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00
(10.10.200.1, 239.0.10.1), 00:02:37/00:00:22, flags: PCLTA
  Incoming interface: Ethernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list: Null

Marque los grupos IGMP IP con la ayuda del comando show ip igmp groups. Se descubren el Multicast IP Address del descubrimiento rp de Cisco y el grupo de multidifusión del igmp que el C3640 se une a.

C3640#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface            Uptime    Expires   Last Reporter
224.0.1.40       Ethernet1/0          3d00h     00:02:38  10.10.200.2
239.0.10.1       Ethernet1/0          1w1d      00:02:44  10.10.200.1

C8540MSR

En el switch C8540MSR Catalyst se utilizan los mismos comandos show que en la serie C3460. El comando show ip route muestra que el C8540MSR llega a todas las subredes de la red.

C8540MSR#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/2] via 75.75.75.3, 01:25:34, ATM11/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet0
C       10.10.200.0 is directly connected, FastEthernet3/0/1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/1] via 75.75.75.3, 01:25:34, ATM11/0/0.1
O       75.75.75.1/32 [110/1] via 75.75.75.1, 01:25:34, ATM11/0/0.1
C       75.75.75.0/24 is directly connected, ATM11/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/11] via 75.75.75.1, 01:25:35, ATM11/0/0.1
S*   0.0.0.0/0 [1/0] via 10.118.1.21

El comando show ip pim neighbor muestra los vecinos de multidifusión. En el caso del C8540MSR, los vecinos del PIM IP son C3640 (10.10.200.1), C7513 (75.75.75.1), y C7204 (75.75.75.3).

C8540MSR#show ip pim neighbor 
PIM Neighbor Table
Neighbor Address  Interface                Uptime    Expires   Ver  Mode
10.10.200.1       FastEthernet3/0/1        3d02h     00:01:25  v2   
75.75.75.3        ATM11/0/0.1              00:12:11  00:01:33  v2    (DR)
75.75.75.1        ATM11/0/0.1              00:18:43  00:01:32  v2

El comando show ip mroute brinda información acerca de la tabla de ruteo de multidifusión. Este ejemplo ilustra la presencia de una ruta nula para 239.0.10.1 y 224.0.1.40. La última dirección multidifusión es la designada por IANA para cisco-rp-discovery.

C8540MSR#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Group, C - Connected, L - Local,
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set,
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP, U - URD, I - Received Source Specific Host
           Report 
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 3d03h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(*, 239.0.10.1), 3d03h/00:02:59, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:17/00:02:49, flags: CT
  Incoming interface: FastEthernet3/0/1, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 00:00:19/00:00:00

C7513

Las descripciones y las explicaciones para los comandos presentadas aquí son las mismas que se brindaron para C3640 y C8540MSR.

C7513#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/3] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet9/0/1
O       10.10.200.0 [110/2] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     11.0.0.0/24 is subnetted, 2 subnets
C       11.12.12.0 is directly connected, Serial0/0/0/2:2
C       11.11.11.0 is directly connected, Serial0/0/0/1:1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/2] via 75.75.75.2, 02:05:05, ATM1/0/0.1
O       75.75.75.2/32 [110/1] via 75.75.75.2, 02:05:05, ATM1/0/0.1
C       75.75.75.0/24 is directly connected, ATM1/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, Ethernet9/0/2
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7513#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM1/0/0.1               04:28:34/00:01:18 v2    N / DR
C7513#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(*, 239.0.10.1), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:51/00:02:08, flags: CLT
  Incoming interface: ATM1/0/0.1, RPF nbr 75.75.75.2
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 00:00:52/00:00:00
C7513#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       Ethernet9/0/2        22:04:09  00:02:50  30.30.30.1
239.0.10.1       Ethernet9/0/2        22:04:15  00:02:50  30.30.30.1

C7204

Las descripciones y las explicaciones para los comandos presentadas aquí son las mismas que se brindaron para C3640 y C8540MSR.

C7204#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.40.40.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, FastEthernet0/0
O       10.10.200.0 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.2/32 [110/1] via 75.75.75.2, 03:31:48, ATM4/0.5
O       75.75.75.1/32 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
C       75.75.75.0/24 is directly connected, ATM4/0.5
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/12] via 75.75.75.2, 03:31:49, ATM4/0.5
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7204#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM4/0.5                 03:32:29/00:01:23 v2    N /
C7204#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 05:20:47/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:57:26/00:00:00

(*, 239.0.10.1), 03:31:41/00:00:00, RP 0.0.0.0, flags: DL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:31:41/00:00:00
7204#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       ATM4/0.5               05:20:53  00:02:24  75.75.75.3
239.0.10.1       Loopback0              23:33:52  stopped   40.40.40.1

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 19244