Voz : CCS Digital

Configuración y resolución de problemas de CCS transparente

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar y resolver problemas el Common Channel Signaling Transparente (T-CCS).

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • Cómo configurar el software del½ del¿Â del Cisco IOSï para la Funcionalidad de voz.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Versión 12.2.7a del software IOS de Cisco

  • El router 3640 de Cisco.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

T-CCS permite conectar dos PBX con interfaces digitales que utilizan un protocolo CCS de propietario o no admitido sin que se requiera interpretación de señalización CCS para el procesamiento de llamada.

Con el T-CCS, los canales de voz PBX se pueden clavar encima de (hecho permanente), y comprimir entre los sitios. El canal de señalización o los canales de acompañamiento puede ser tunneled (transmitido transparente) a través de la estructura básica IP/FR/ATM entre los PBX. Así, las llamadas de los PBX no son ruteadas por Cisco sobre una base del call-by-call, sino siguen una ruta preconfigurada al destino.

Existen tres formas que se pueden configurar para aplicar esta característica:

  • T-CCS de reenvío de tramas

  • Canal despejado T-CCS

  • Cruz-conecte el T-CCS

Cross connect T-CCS sólo es posible en el Cisco 3810 y no se aborda en este documento.

Matriz de compatibilidad T-CCS

Esta tabla muestra las características T-CCS que se pueden configurar en las diversas Plataformas.

Voz1 Cisco 3810 Cisco 26xx/36xx/72xx
VoIP2 Clear-Channel:
  • Cualquier tipo de señalización CCS.
  • Cualquier número de canales de señalización
Clear-Channel:
  • Cualquier tipo de señalización CCS.
  • Cualquier número de canales de señalización
VoFR3 Clear-Channel:
  • Cualquier tipo de señalización CCS.
  • Cualquier número de canales de señalización
‘Reenvío de tramas:
  • señalización 4 con trama HDLC
  • Solamente 1 canal de señalización: E1.
  • E1 = TS16.
  • T1= TS 24.
Conexión cruzada TDM5:
  • Cualquier tipo de señalización CCS.
  • Cualquier número de canales de señalización
Clear-Channel:
  • Cualquier tipo de señalización CCS.
  • Cualquier número de canales de señalización
‘Reenvío de tramas:
  • Señalización con trama HDLC.
  • Canales de señalización = Grupos de canal configurables por el controlador.
VoATM6 Clear-Channel:
  • Cualquier tipo de señalización CCS.
  • Cualquier número de canales de señalización
‘Reenvío de tramas:
  • Señalización con trama HDLC.
  • Sólo 1 canal de señalización.
Clear-Channel:
  • Cualquier tipo de señalización CCS.
  • Cualquier número de canales de señalización
‘Reenvío de tramas:
  • Señalización con trama HDLC.
  • Canales de señalización = Grupos de canal configurables por el controlador.

1. Voz = Voz sobre X

2. VoIP = voz sobre IP

3. VoFR = Voz sobre el Frame Relay

4. HDLC = High-Level Data Link Control

5. TDM = multiplexión por división de tiempo

6. VoATM = Voice over ATM

T-CCS de reenvío de tramas

El Frame-Forwarding T-CCS se puede utilizar solamente para soportar los protocolos de propietario PBX donde está HDLC-Framed el canal de señalización o los canales, y la tecnología VoX deseada es VoFR o VoATM. En esta solución, las tramas de señalización del HDLC se encapsulan y se remiten a través de un grupo de canal que se configure para la señalización en el regulador, y se tratan así como interfaz serial. Se interpreta y se entiende la alineación de tramas HDLC, aunque no sean los mensajes de señalización. Se suprimen las tramas inactivas y sólo los datos reales se propagan a través del canal de señalización.

Implemente el Frame-Forwarding T-CCS

Advertencia: Limitación CSCdt55871

Existe un límite actual en la cantidad de canales de voz utilizables cuando se configura el TCCS de reenvío de tramas en E1. La limitación ocurre debido a un conflicto entre ds0-group y los rangos de números del channnel-grupo, como se explica en CSCdt55871 (clientes registrados solamente).

El intentar configurar un grupo del ds0 que sea +1 previamente del grupo de canal de entrada da lugar al error, como se muestra abajo.

!
 controller t1 2/1 
 channel-group 0 timeslot 24 speed 64 
 ds0-group 1 timeslots 1 type ext-sig

La configuración antedicha da lugar a un mensaje de error cuando definen al grupo del ds0, demandando que el canal 0 está utilizado ya, como se muestra aquí:

%Channel 0 already used by other group

La solución alternativa es faltar al grupo en conflicto, y continúa con el número de grupo siguiente en el rango. Esto reduce el número de grupos configurables por uno.

Sea consciente de estas puntas antes de implementar el Frame-Forwarding T-CCS:

  • El Frame-Forwarding T-CCS debe ser configurado solamente cuando el protocolo CCS que se transportará utiliza un tipo del HDLC de bastidor.

  • El comando mode ccs-frame-forwarding define el CCS para el reenvío de tramas.

  • El DSO-grupo y los comandos ext sig determinan qué puertos de voz deben ser creados y ser utilizados para el trunk con la señalización de la fuente externa.

  • El comando connection trunk establece los canales de voz permanentes.

  • El comando channel-group define el intervalo de tiempo o los intervalos de tiempo del reenvío de tramas.

  • El Frame-Forwarding T-CCS no se soporta para el VoIP.

  • El TS16 en el e1 es siempre reservado para el Señalización asociada al canal (CAS). Si usted configura otro intervalo de tiempo para CAS (como en el ejemplo antedicho), usted entonces tiene uno menos intervalo de tiempo para la Voz.

Un ejemplo de configuración para Frame-Forwarding VoFR T-CCS

La configuración y la prueba señaladas en esta sección fueron realizadas en un Cisco IOS Software Release 12.2.7a corriente del Cisco 3640 Router. El ejemplo mostrado aquí representa una situación cuando la señalización no se aplica en el intervalo de tiempo normal (slot 16). Otro intervalo de tiempo se utiliza aquí (el slot 6) para mostrar la flexibilidad de la característica (no corresponde en el Cisco 3810 Router).

/image/gif/paws/19087/trans_channel_signal1.gif

Pasos para configurar el lado de voz

Para configurar al Lado de voz, complete estos pasos:

  1. En el controlador T1 o E1:

    1. Agregue el comando mode ccs frame-forwarding.

    2. Defina al canal-grupo para cada canal de señalización (para las Cisco y Series solamente; el router 3810 de Cisco crea automáticamente el canal D).

    3. Defina los grupos ds0 para cada canal de voz usando type ext-sig.

      GTP1
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

      GTP2
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

  2. En la interfaz del canal D (esta interfaz serial se crea una vez configurado el comando channel-group):

    1. Agregue el comando ccs encap frf11 command.

    2. Señale el canal D a un ID del canal en la interfaz de WAN FR usando el comando ccs connect Serial x/y DLCI CID.

      Nota: Debe emplearse un ID de canal para cada canal D si se requiere más de un canal de señalización. Comience con el ID del canal 254, y trabaje al revés.

      GTP1
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

      GTP2
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

  3. En el puerto de voz:

    Agregue el tronco de conexión xxx a cada puerto de voz. El número debe coincidir con el diagrama de destinos del puerto de voz de terminación (interlocutor de conexión de POTS) del otro lado. Solamente un lado de la conexión debe especificar al “modo contestar.”

    GTP1
    !
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 6002
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 6003
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 6030
    !

    GTP2
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 8002 answer-mode
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 8003 answer-mode
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 8030 answer-mode

  4. En los POTS dial peer:

    1. Agregue a un vofr dial peer que haga juego el Número marcado del tronco de conexión, y señálelo al identificador de la conexión de link de datos de Frame Relay (DLCI).

    2. Agregue un par de marcado POTS a cada puerto de voz que coincida con el número marcado por los enunciados xxx del tronco de conexión desde el otro lado.

      GTP1
      !
      dial-peer voice 8002 pots
       destination-pattern 8002
       port 3/0:2
      !
      dial-peer voice 8003 pots
       destination-pattern 8003
       port 3/0:3
      ! 
      ... [channels 4-30 the same] ...
      
      dial-peer voice 6000 vofr
       destination-pattern 6...
       session target Serial0/0 105
      !

      GTP2
      !
      dial-peer voice 6002 pots
       destination-pattern 6002
       port 3/0:2
      !
      dial-peer voice 6003 pots
       destination-pattern 6003
       port 3/0:3
      
      ... [channels 4-30 the same] ... 
      !
       dial-peer voice 8000 vofr
       destination-pattern 8...
       session target Serial1/0 105
      !

Pasos para configurar el lado WAN (Red de área ancha)

Para configurar al lado de WAN, complete estos pasos:

  1. Defina una interfaz serial del Frame Relay, y una subinterfaz punto a punto con VoFR normal.

  2. Ponga en el Voz-ancho de banda basado en el número de canales y el codecs usado para la Voz.

  3. Permita el ancho de banda adicional en la Velocidad de información comprometida (CIR) para el canal de señalización y otros datos que comparten este DLCI.

    GTP1
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay traffic-shaping
    !
    interface Serial0/0.1 point-to-point
     ip address 10.10.105.2 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay bc 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

    GTP2
    !
    interface Serial1/0
     no ip address
     encapsulation frame-relay
     clock rate 768000
     frame-relay traffic-shaping
     frame-relay intf-type dce
    !
    interface Serial1/0.1 point-to-point
     ip address 10.10.105.1 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay BC 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

Ancho de banda

El aprovisionado del ancho de banda en la estructura básica debe permitir toda la voz configurada y canales de señalización. Dado que estas configuraciones utilizan el troncal de conexión, todos los canales de voz y de señalización resultantes siempre están en funcionamiento. La detección de la activación por voz (VAD) proporciona los ahorros en los canales de la voz activa (aunque no en la señalización), solamente el VAD no llega a ser activa hasta que se establezcan los canales de voz. Así, el ancho de banda inicial requerido por el canal de voz debería tomar en cuenta el códec empleado más la tara del encabezado. Para VoFR, solamente el ancho de banda de los canales de voz se debe explicar en los comandos voice bandwidth y LLQ. El ancho de banda de la Voz y los canales de señalización se deben explicar en la interfaz de FR-a-WAN.

Resuelva problemas y verifique el Frame-Forwarding T-CCS

Los siguientes pasos ayudan a verificar que el T-CSS de reenvío de tramas esté operando como se espera.

  1. El controlador E1 debe estar activado para que los puertos de voz se activen y se conecten al enlace troncal.

  2. Marque si la llamada existe, y si los procesadores de señales digitales correctos (DSPs) están afectados un aparato en los intervalos de tiempo.

  3. Si las llamadas no pueden conectar, marque la configuración del estado o la Conectividad del circuito virtual permanente (PVC), y abastecimiento de dial peer.

  4. Si el comando show voice port muestra la “marcha lenta” y “en el gancho” para algún intervalo de tiempo, marque si el intervalo de tiempo relacionado tiene la versión de DSP correcta asignada, y está trabajando correctamente con el comando show voice dsp.

  5. Debug con el comando debug TCCS signaling en el modo guardado en memoria intermedia del registro (éste es mismo uso intensivo de la CPU).

    gtp2#show controllers e1 3/0
    E1 3/0 is up. 
      Applique type is Channelized E1 - balanced
      No alarms detected.
      alarm-trigger is not set
      Version info Firmware: 20011015, FPGA: 15
      Framing is CRC4, Line Code is HDB3, Clock Source is Line.
      Data in current interval (276 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    
    gtp2#show voice dsp
     
    DSP  DSP            DSPWARE CURR  BOOT         VOICE       PAK     TX/RX
    TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT  PACK COUNT
    ==== === == ======= ======= ===== ===== === == ====== == ===== ============
    C549 000 01 g729ar8  3.4.49 busy  idle       0 3/0:18 18     0 119229/70248
    C549 000 00 g729ar8  3.4.49 busy  idle    0  0 3/0:2  02     0  41913/45414
    C549 001 01 g729ar8  3.4.49 busy  idle       0 3/0:19 19     0 119963/70535
    C549 001 00 g729ar8  3.4.49 busy  idle    0  0 3/0:3  03     0  42865/47341
    C549 002 01 g729ar8  3.4.49 busy  idle       0 3/0:20 20     0  77746/69876
    
    
    !--- This shows DSPs are being used.
    
    
    
    gtp2#show voice call summary
    
    PORT         CODEC    VAD VTSP STATE            VPM STATE
    =========   ======== === ============        ==============
    3/0:2.2       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:3.3       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:4.4       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:5.5       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:6.31      g729ar8  y  S_CONNECT             S_TRUNKED
    
    
    !--- This shows call connected.
    
    
    gtp2#show frame-relay pvc
    
    PVC Statistics for interface Serial1/0 (Frame Relay DCE)
    
                  Active     Inactive      Deleted       Static
      Local          1            0            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    
    DLCI = 105, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, 
    INTERFACE = Serial1/0.1
    
      input pkts 1201908       output pkts 2177352      in bytes 37341051  
      out bytes 71856239       dropped pkts 0           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 167       out bcast bytes 48597     
      PVC create time 08:37:30, last time PVC status changed 02:47:05
      Service type VoFR-cisco
    
    
    !--- This shows Frame Relay is active.
    
    
    
    gtp2#show frame-relay fragment 
    interface   dlci  frag-type   frag-size  in-frag  out-frag   dropped-frag
    Serial1/0.1 105   VoFR-cisco  640        172      169        0    
    
    
    debug tccs signaling
    
    Log Buffer (8096 bytes):
    
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  282 tccs packets received from the nework.
    08:55:47: RX from Serial3/0:0:
    08:55:47: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:47: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 01 49 F3 69 00 0C 42 00 
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  283 tccs packets received from the nework.
    08:55:47: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:47: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 03 EA DF 0D 00 0C 42 00 
    08:55:50:  282 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
    08:55:50: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:50: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 03 EA DF 0D 00 62 05 00 
    08:55:50:  283 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
              08:55:50: RX from Serial3/0:0:
    08:55:50: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:50: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 01 49 F3 69 00 62 05 00 
    gtp2# wr t
    
    
    !--- This shows packet forwarding and receiving.
    
    

Codec Clear-Channel T-CCS

El canal despejado T-CCS se utiliza para soportar los protocolos de propiedad de PBX en donde los canales de señalización están basados en el bit ABCD o HDLC o donde la tecnología de transporte de voz es VoIP. En esta solución, el canal de señalización y los canales de voz se encuentran configurados como ds0groups y se los trata a todos como llamadas de voz.

Las llamadas de voz real son conexiones troncales permanentemente conectadas por medio del códec de voz elegido. El canal o los canales de señalización también constituyen troncos conectados permanentemente que utilizan el codec de canal despejado el cual es similar a G.711 en lo que respecta al tamaño de las muestras y de los paquetes pero que excluye automáticamente la cancelación de eco y la VAD. No hay inteligencia en el software de conocer qué canales son canales de voz, y cuáles son canales de señalización. Debe configurar los intervalos de tiempo que sabe que transportan señalización de tráfico para coincidir con un par del marcado que asigne el codec de canal despejado, mientras que los canales de voz deben corresponderse con un par del marcado que codifique la voz (G.729, y otros).

Implemente T-CCS de códec de canal limpio

Sea consciente de estas puntas antes de que usted implemente canal despejado T-CCS:

  • Canal despejado T-CCS un usado para cualquier tipo de e1 o de la señalización digital T1 (alineación de tramas orientada a HDLC incluyendo).

  • Cualquier número de canales de señalización pueden ser admitidos.

  • Canal despejado T-CCS puede ser utilizado en el VoIP, VoFR o los entornos VoATM

  • El códec canal despejado se utiliza para el canal de señalización o los canales adentro canal despejado T-CCS.

  • La señalización VoIP y el ancho de banda de voz se deben explicar en la prioridad de IP RTP o el Low Latency Queuing (LLQ).

  • VoIPovFR/VoFR — La señalización y la Voz pueden estar en lo mismo o separar los DLCI.

  • VoFR — El Ancho de banda de señalización se cuenta como parte de VoFR “ancho de banda de voz.”

  • Con canal despejado T-CCS, la señalización toma 64K del Ancho de banda dedicado (no incluyendo la tara del paquete).

  • La Voz y los canales de señalización de las configuraciones del comando DSO-group.

  • El software del IOS de Cisco no sabe qué canal de señalización está en uso.

  • Treinta y uno DSPs se requieren para un PBX usando la señalización en el intervalo de tiempo 16 con 30 puertos de voz, así que dos trunks en el e1 2MFT agotarían la cantidad de DSPs en el NMV2 (se requieren 62).

Al usar el codecs del canal despejado para transportar el tráfico de datos, es importante que el reloj de la red está sincronizado. Esto es porque el algoritmo del DSP cae los paquetes cuando ocurren las saturaciones del búfer, y utiliza su algoritmo del auto-terraplén cuando ocurre el underruns del buffer (fino para el tráfico de voz, pero no bueno para el tráfico de datos). Ambas situaciones pueden causar la falla y el reinicio del canal D.

Ejemplo de configuración para T-CCS de VoIP de canal despejado

La configuración y la prueba de T-CCS de VoIP de canal claro fueron realizadas en un Cisco IOS Software Release 12.2.7a corriente del Cisco 3640 Router. En el ejemplo mostrado aquí, la señalización no se aplica en el intervalo de tiempo normal (16). Otro intervalo de tiempo se utiliza aquí (el intervalo de tiempo 6) para mostrar la flexibilidad de la característica.

/image/gif/paws/19087/trans_channel_signal2.gif

  1. En el controlador T1 o E1:

    Defina los grupos ds0 para cada canal de voz y de señalización.

    GTP1
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

    GTP2
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
    
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

  2. En el puerto de voz:

    1. Agregue un comando connection trunk xxx a cada configuración de puerto de voz. El número debe coincidir con el diagrama de destinos del puerto de voz de terminación (interlocutor de conexión de POTS) del otro lado.

    2. Agregue un comando connection trunk xxx a cada configuración del puerto de voz de la señalización — el número debe hacer juego el diagrama de destinos del puerto de voz terminal (POTS dial peer) en el otro lado.

    3. Solamente un lado de la conexión debe especificar al modo contestar.

      GTP1
      voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 3001
      !
      voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 6001
      ! 
      ... [channels 2-30 the same] ...
      !
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 6030

      GTP2
      !
       voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 5001 answer-mode
      !
       voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 8001 answer-mode
      !
      ... [channels 2-30 the same] ...
      
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 8030 answer-mode

  3. En los pares de marcado:

    1. Agregue a un voip dial peer que haga juego el Número marcado del tronco de conexión de los canales de voz. Señálelo a la dirección IP del lado remoto; asigne (o valor por defecto) el codificador-decodificador deseado de la Voz en este dial peer.

    2. Agregue a un voip dial peer que haga juego el Número marcado del tronco de conexión de los canales de señalización. Señálelo a la dirección IP del lado remoto; asigne los códecs canal despejado en este dial peer.

    3. Agregue pares de marcado POTS a cada puerto de voz que coincida con el número marcado por los enunciados del tronco de conexión desde el otro lado.

      GTP1
      dial-peer voice 8001 pots
       destination-pattern 8001
       port 3/0:1
      !
      
      
      !--- Pots dial peers 8001 --- 8030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns and ports. These are 
      !--- associated with the voice channels.
      
      
      dial-peer voice 8030 pots
       destination-pattern 8030
       port 3/0:30
      !
      dial-peer voice 5001 pots
       destination-pattern 5001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated with 
      !--- the port connected to the local PBX 
      !--- signaling channel.
      
      
      ! 
      dial-peer voice 6000 voip
       destination-pattern 6...
       session target ipv4:10.10.105.1
      !
      dial-peer voice 3001 voip
       answer-address 5001
       destination-pattern 3001
       session target ipv4:10.10.105.1
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated 
      !--- with the destination pattern that 
      !--- connects to the remote PBX signaling 
      !--- channel port.
      
      

      GTP2
      !
      dial-peer voice 6001 pots
       destination-pattern 6001
       port 3/0:1
      !
      
      
      !--- POTS dial peers 6001 --- 6030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns, and ports. 
      !--- These are associated with the 
      !--- voice channels.
      
      
      dial-peer voice 6030 pots
       destination-pattern 6030
       port 3/0:30
      ! 
      dial-peer voice 3001 pots
       destination-pattern 3001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated 
      !--- with the port connected to the local PBX 
      !--- signaling channel.
      
      
      !
      dial-peer voice 8000 voip
       destination-pattern 8...
       session target ipv4:10.10.105.2
      !
      dial-peer voice 5001 voip
       answer-address 3001
       destination-pattern 5001
       session target ipv4:10.10.105.2
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated with 
      !--- the destination pattern that connects 
      !--- to the remote PBX signaling channel port.
      
      

Pasos para configurar el lado WAN (Red de área ancha)

Para configurar al lado de WAN, complete estos pasos:

Coloque un comando de prioridad IP RTP o ancho de banda LLQ basado en lo siguiente:

  • El número de canales de voz, y el codecs usado para las señales de voz.

  • El número de canales de señalización multiplicados por 80K (tratado como usted trataría G.711).

GTP1
interface Multilink1
 bandwidth 512
 ip address 10.10.105.2 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!
interface Serial0/0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1

GTP2
interface Multilink1
 bandwidth 512
 ip address 10.10.105.1 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!!
interface Serial1/0
 no ip address
 encapsulation ppp
 no fair-queue
 clock rate 512000
 ppp multilink
 multilink-group 1

Resuelva problemas y verifique canal despejado T-CCS

Estos pasos ayudan a verificar que el canal despejado T-CSS está actuando como debe:

  1. El controlador E1 debe estar descuelguen para que los puertos de voz se activen y se conecten al tronco.

  2. Asegúrese de que las llamadas de comprobación existan, y el DSPs correcto se afectan un aparato en los intervalos de tiempo.

  3. Si no puede establecer llamadas, verifique la conectividad y configuración IP y el abastecimiento de par marcado.

  4. Al restaurarse la IP luego de una falla en la interfaz o en el link, el controlador debe ejecutar el comando shut/no shut en su interfaz o el router debe recargarse para abrir las copias de seguridad de las conexiones de tronco.

  5. Si el comando show voice port muestra ocioso y en el gancho para algún intervalo de tiempo, marque que el intervalo de tiempo relacionado tiene la versión de DSP correcta asignada, y que está trabajando correctamente con el comando show voice dsp, como se muestra abajo.

gtp#show voice dsp

DSP  DSP            DSPWARE CURR  BOOT         VOICE      PAK       TX/RX
TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT    PACK COUNT
==== === == ======= ======= ===== ===== === == ====== == =====   ============
C549 000 02 g729r8   3.4.49 busy  idle       0 3/0:25    25      0     264/2771
C549 000 01 g729r8   3.4.49 busy  idle       0 3/0:12    12      0     264/2825
C549 000 00 clear-ch 3.4.49 busy  idle    0  0 3/0:0     06      0 158036/16069


!--- The above identifies that the clear codec is used for timeslot 6.
!--- Ensure that clear codec is applied correctly against the correct timeslot.
                                                                     


gtp1#show voice port sum

PORT   CH SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
====== == ========== ===== ==== ======== ======== ==
3/0:0  6     ext     up    up   trunked  trunked  y
3/0:1  1     ext     up    up   trunked  trunked  y
3/0:2  2     ext     up    up   trunked  trunked  y
3/0:3  3     ext     up    up   trunked  trunked  y


!--- This shows that the voice port used for signaling is off-hook and trunked.
 


gtp1#show voice call sum
PORT         CODEC    VAD VTSP STATE            VPM STATE
============ ======== === ============        =============
3/0:0.6       clear-ch y  S_CONNECT             S_TRUNKED
3/0:1.1       g729r8   y  S_CONNECT             S_TRUNKED
3/0:2.2       g729r8   y  S_CONNECT             S_TRUNKED
3/0:3.3       g729r8   y  S_CONNECT             S_TRUNKED
3/0:4.4       g729r8   y  S_CONNECT             S_TRUNKED
3/0:5.5       g729r8   y  S_CONNECT             S_TRUNKED
3/0:6.31      g729r8   y  S_CONNECT             S_TRUNKED
3/0:7.7       g729r8   y  S_CONNECT             S_TRUNKED


!--- This shows a signaling call in progress.

Habilite la señalización RTP en el AS5350 y el AS5400

Para prevenir los errores causados por los paquetes RTP del tipo de carga útil “123" en las Plataformas del Cisco AS5350 y de las AS5400 Series, el procesamiento de señal RTP se inhabilita por abandono. En algunas circunstancias, los paquetes de este tipo pueden causar un error de dirección de memoria inválido en el AS5350 y las Plataformas de las AS5400 Series, potencialmente causando un crash los dispositivos.

En estos modelos, usted puede habilitar el procesamiento de señal RTP usando el Voz-fastpath Voz-RTP-que señala el comando configuration ocultado permiso. Sin embargo, antes de que usted habilite el procesamiento de señal RTP, prepare la plataforma para manejar los paquetes RTP del tipo de carga útil “123" habilitando el T-CCS.

Después de que usted prepare la plataforma, usted puede utilizar estos comandos para habilitar o inhabilitar el procesamiento de señal RTP.

  • Para habilitar el procesamiento de señal RTP, utilice este comando:

    Router(config)#voice-fastpath voice-rtp-signalling enable
    
  • Para inhabilitar el procesamiento de señal RTP, utilice este comando:

    Router(config)#no voice-fastpath voice-rtp-signalling enable
    

Cómo probar T-CCS (Frame-Forwarding y Clear-Channel) sin PBX

En ciertas situaciones puede ser poco práctico verificar la configuración del T-CCS con los PBX. Esta sección describe un método que implique la substitución de los PBX con el Routers, para probar que la señalización puede ser transportada. Dado que la estructura de la trama utilizada en PPP es similar a la que utiliza la señalización basada en mensajes (como CCS), puede usar routers configurados para PPP a fin de comprobar que el canal de señalización funcione. Esto puede ser útil en las situaciones donde el despliegue del T-CCS ha fallado, y la prueba adicional es necesaria que el canal de señalización está funcionando. (En el Frame-Forwarding T-CCS hay información disponible del debug que muestra la transmisión y la recepción de los bastidores. En el canal despejado T-CCS, no se encuentra disponible información de depuración de tiempo real).

Configure controlador E1 del Routers para el canal de señalización de opción. Este ejemplo utiliza el intervalo de tiempo 6, a la relación con las pruebas antedichas. Configure el PPP en la interfaz serial resultante para representar la señalización de tráfico.

trans_channel_signal3.gif

Router 1
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp

Router 2
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp

Resultado típico con paquetes ppp de depuración
1d00h: Se0:0 LCP: Received id 1, sent id 1, line up
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREQ [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: O ECHOREP [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0x0207, datagramsize 305
1d00h: Se0:0 LCP: O ECHOREQ [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREP [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: Received id 2, sent id 2, line up


Información Relacionada


Document ID: 19087